summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorOndrej Holy <oholy@redhat.com>2018-12-07 12:02:51 +0100
committerOndrej Holy <oholy@redhat.com>2018-12-07 12:24:01 +0000
commita041512cf791e8a827b94e805f8bdf192af977a2 (patch)
treeaab8c1c8ab04316fc87cc384fb597354a80e143f /meson.build
parentab82d984e7961516cd36d5c5e3450897f44cc46f (diff)
downloadgvfs-a041512cf791e8a827b94e805f8bdf192af977a2.tar.gz
build: Use g_unix_mount_get_root_path conditionally
GLib hasn't been released with g_unix_mount_get_root_path support yet, so let's add macros to use this functionality only if available.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 26877b6c..356c3442 100644
--- a/meson.build
+++ b/meson.build
@@ -227,6 +227,8 @@ gio_unix_dep = dependency('gio-unix-2.0')
glib_dep = dependency('glib-2.0', version: '>= 2.57.2')
gobject_dep = dependency('gobject-2.0')
+config_h.set('HAVE_G_UNIX_MOUNT_GET_ROOT_PATH', cc.has_function('g_unix_mount_get_root_path', dependencies: gio_dep))
+
# *** Check for libXML ***
libxml_dep = dependency('libxml-2.0', required: false)
have_libxml = libxml_dep.found()