summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-03-24 11:34:49 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-03 15:10:56 +0100
commit1c14e93e691088d2685011641031180f66989561 (patch)
tree711cd7ae0697d87c9696d1cd270e2f98c7fb2244 /meson.build
parent25cdd19bb040740bd7cdc4359b867f4307b45814 (diff)
downloadgtk+-1c14e93e691088d2685011641031180f66989561.tar.gz
meson: check for xinerama
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 16 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 96d1fdf484..5158c8b1cc 100644
--- a/meson.build
+++ b/meson.build
@@ -122,8 +122,6 @@ endforeach
# Maths functions might be implemented in libm
libm = cc.find_library('m', required : false)
-# FIXME: HAVE_XFREE_XINERAMA
-
check_functions = [
'dcgettext',
'getpagesize',
@@ -231,8 +229,6 @@ if x11_enabled
fontconfig_dep = dependency('fontconfig')
atkbridge_dep = dependency('atk-bridge-2.0', version: atk_req)
- # FIXME: check for xinerama + add to x11_pkgs
-
x11_pkgs = ['fontconfig', 'x11', 'xext', 'xi', 'xrandr']
if xcursor_dep.found()
@@ -281,6 +277,20 @@ if x11_enabled
endif
endif
+ enable_xinerama = get_option('enable-xinerama')
+ if enable_xinerama != 'no'
+ want_xinerama = enable_xinerama == 'yes'
+ xinerama_dep = dependency('xinerama', required : want_xinerama)
+ if xinerama_dep.found() and cc.has_header_symbol('X11/extensions/Xinerama.h', 'XineramaQueryExtension', dependencies : xinerama_dep)
+ cdata.set('HAVE_XFREE_XINERAMA', 1)
+ x11_pkgs += ['xinerama']
+ elif want_xinerama
+ error('No function XineramaQueryExtension in xinerama dependency which was explicitly requested.')
+ endif
+ else
+ xinerama_dep = []
+ endif
+
cdata.set('HAVE_RANDR', xrandr_dep.found())
cdata.set('HAVE_RANDR15', xrandr15_dep.found())
endif
@@ -329,6 +339,8 @@ if enable_vulkan != 'no'
if vulkan_lib.found() and cc.has_function('vkCreateInstance', dependencies : vulkan_lib) and cc.has_header('vulkan/vulkan.h')
have_vulkan = true
pc_gdk_extra_libs += ['-lvulkan']
+ elif enable_vulkan == 'yes'
+ error('Vulkan support not found, but was explicitly requested.')
endif
else
message('Vulkan support explicitly disabled')