summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorJeff Garzik <jgarzik@src.gnome.org>1998-11-24 05:58:53 +0000
committerJeff Garzik <jgarzik@src.gnome.org>1998-11-24 05:58:53 +0000
commit91d99f89037cc1fc06a5f985aa08133590d7943e (patch)
tree5f4b89333667356890667bb91fdb99e4d4dc2da7 /gtk/Makefile.am
parent5a5fb5635f854442509f0dc78167108f3e88d81d (diff)
downloadgtk+-91d99f89037cc1fc06a5f985aa08133590d7943e.tar.gz
Removed DEFS "+=" mess that breaks recent automakes. INCLUDES is the
* gdk/Makefile.am, gtk/Makefile.am: Removed DEFS "+=" mess that breaks recent automakes. INCLUDES is the correct way to add to CFLAGS from Makefile.am. * gdk/gdk.c, gdk/gdkglobals.c, gdk/gdkimage.c, gdk/gdkinput.c, gdk/gdkpixmap.c, gdk/gdkthreads.c, gdk/gdkwindow.c, gdk/gxid_lib.c, gtk/fnmatch.c, gtk/gtkclist.c, gtk/gtkmain.c, gtk/testthreads.c: Include "config.h" instead of "../config.h". Now that DEFS works again, automake will automatically pass us the location of config.h in -I.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 6e64f95b29..e3c33eb94b 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1,7 +1,6 @@
### Process this file with automake to produce Makefile.in
gtkincludedir = $(includedir)/gtk
-DEFS += -DG_LOG_DOMAIN=\"Gtk\"
lib_LTLIBRARIES = libgtk.la
@@ -340,6 +339,7 @@ EXTRA_DIST = \
circles.xbm
INCLUDES = \
+ -DG_LOG_DOMAIN=\"Gtk\" \
-DGTK_EXE_PREFIX=\"$(exec_prefix)\" \
-DGTK_DATA_PREFIX=\"$(prefix)\" \
-I$(top_srcdir) @GLIB_CFLAGS@ @x_cflags@