summaryrefslogtreecommitdiff
path: root/gdk/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2020-02-29 09:17:02 -0500
committerMatthias Clasen <mclasen@redhat.com>2020-03-11 19:35:55 -0400
commitaee8a02fc88577b4cb0487ff2700d38bebeb2e57 (patch)
tree4344e2532147fa5c7caa2e01a48e8d737efd8465 /gdk/meson.build
parent0791363943c952a1bcfbc935f14dc338f8702e1a (diff)
downloadgtk+-aee8a02fc88577b4cb0487ff2700d38bebeb2e57.tar.gz
Introduce GdkPopup
This is a new interface for popup surfaces.
Diffstat (limited to 'gdk/meson.build')
-rw-r--r--gdk/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/gdk/meson.build b/gdk/meson.build
index 1df3b60e74..71d8393f92 100644
--- a/gdk/meson.build
+++ b/gdk/meson.build
@@ -44,7 +44,8 @@ gdk_public_sources = files([
'gdkvulkancontext.c',
'gdksurface.c',
'gdkpopuplayout.c',
- 'gdkprofiler.c'
+ 'gdkprofiler.c',
+ 'gdkpopup.c',
])
gdk_public_headers = files([
@@ -89,6 +90,7 @@ gdk_public_headers = files([
'gdkvulkancontext.h',
'gdksurface.h',
'gdkpopuplayout.h',
+ 'gdkpopup.h',
])
install_headers(gdk_public_headers, subdir: 'gtk-4.0/gdk/')