summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2013-03-15 06:35:30 -0400
committerMatthias Clasen <mclasen@redhat.com>2013-05-05 15:38:48 -0400
commit8af16c5d4481a517cc7c400b97d469ee550ffd79 (patch)
tree69278658bf36bc3db82d9a02b3cb5e36483e9659 /gdk/Makefile.am
parentf5f5b7035518af810ce60331bdbb13391d02845e (diff)
downloadgtk+-8af16c5d4481a517cc7c400b97d469ee550ffd79.tar.gz
New visibility handling in gdk
Change the visibility handling to be the same way we do it in GLib now. We pass -fvisibility=hidden to gcc and decorate public functions with __attribute__((visibility("default"))). This commit just does this for GDK, GTK+ will follow later.
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index 0b81376af1..161996f16b 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -144,11 +144,11 @@ gdk_c_sources = \
gdkwindowimpl.c
gdk_built_sources = \
+ gdkenumtypes.h \
gdkenumtypes.c \
gdkmarshalers.h \
gdkmarshalers.c \
- gdkversionmacros.h \
- gdkenumtypes.h
+ gdkversionmacros.h
#
# setup GDK sources and their dependencies
@@ -166,6 +166,7 @@ common_sources = \
gdkmarshalers.h
libgdk_3_la_SOURCES = $(common_sources)
+libgdk_3_la_CFLAGS = $(AM_CFLAGS) $(GDK_HIDDEN_VISIBILITY_CFLAGS)
libgdk_3_la_LIBADD = $(GDK_DEP_LIBS)
libgdk_3_la_LDFLAGS = $(LDADD)