summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorOwen W. Taylor <otaylor@fishsoup.net>2012-10-03 18:34:01 -0400
committerOwen W. Taylor <otaylor@fishsoup.net>2013-02-14 17:19:47 -0500
commit77bac0d6ae2cbbe9a41ea36e705cc12f36df4cbc (patch)
tree2a50c8e9a30f11ea29399f88ef6a1bca600ada07 /gdk/Makefile.am
parent001f960a433a68124ce1cf49207c81fde646b57a (diff)
downloadgtk+-77bac0d6ae2cbbe9a41ea36e705cc12f36df4cbc.tar.gz
Add GdkFrameClock
Add an object GdkFrameClock that we associate with a GdkWindow. This tracks when the window needs to be repainted, and will also be used for other operations in the future like relayout and updating animations. Based on a patch from Havoc Pennington: https://mail.gnome.org/archives/gtk-devel-list/2010-October/msg00004.html https://bugzilla.gnome.org/show_bug.cgi?id=685460
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index a04f7a3833..a265bcaf17 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -80,6 +80,7 @@ gdk_public_h_sources = \
gdkkeysyms-compat.h \
gdkmain.h \
gdkpango.h \
+ gdkframeclock.h \
gdkpixbuf.h \
gdkprivate.h \
gdkproperty.h \
@@ -101,6 +102,7 @@ gdk_private_headers = \
gdkdisplaymanagerprivate.h \
gdkdisplayprivate.h \
gdkdndprivate.h \
+ gdkframeclockidle.h \
gdkscreenprivate.h \
gdkinternals.h \
gdkintl.h \
@@ -125,6 +127,8 @@ gdk_c_sources = \
gdkkeys.c \
gdkkeyuni.c \
gdkoffscreenwindow.c \
+ gdkframeclock.c \
+ gdkframeclockidle.c \
gdkpango.c \
gdkpixbuf-drawable.c \
gdkrectangle.c \