summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGnome CVS User <gnomecvs@src.gnome.org>1997-11-27 04:16:39 +0000
committerGnome CVS User <gnomecvs@src.gnome.org>1997-11-27 04:16:39 +0000
commitdd34bcca5e6627c8a269c9232a8906e3bd8947df (patch)
tree5309f2ead99fbef5a4138556854079f68df48645 /configure.in
parente522ad46baaef62bb639a3a120c59203cb0af847 (diff)
downloadgtk+-dd34bcca5e6627c8a269c9232a8906e3bd8947df.tar.gz
Patches to support internationalized input by:
Takashi Matsuda <matsu@arch.comp.kyutech.ac.jp> TANAKA Shinya <shinya@race.u-tokyo.ac.jp> See ChangeLog entries for further details. Also some small fixes to event handling in gdk/gdk.c; sending clear events in gtk/gtkselection.c and cut-and-paste in gtk/gtkentry.c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index faa57edc80..c1140ac16a 100644
--- a/configure.in
+++ b/configure.in
@@ -26,6 +26,9 @@ if eval "test x$enable_debug = xyes"; then
fi)
AC_ARG_ENABLE(ansi, [ --enable-ansi turn on strict ansi [default=no]],
, enable_ansi=no)
+AC_ARG_ENABLE(xim, [ --enable-xim support XIM [default=yes]],
+ echo $enable_xim, enable_xim="yes")
+AC_ARG_WITH(locale, [ --with-locale=LOCALE locale name you want to use ])
AC_ARG_WITH(xinput, [ --with-xinput[=no/gxi/xfree] support XInput ])
@@ -63,6 +66,10 @@ if eval "test x$GCC = xyes"; then
fi
fi
+if eval "test x$enable_xim = xyes"; then
+ CFLAGS="$CFLAGS -DUSE_XIM"
+fi
+
# Find the X11 include and library directories
AC_PATH_X
AC_PATH_XTRA
@@ -186,6 +193,25 @@ gtk_cv_display_resource_base="private3")])
AC_MSG_RESULT($gtk_cv_display_resource_base)
AC_DEFINE_UNQUOTED(RESOURCE_BASE, gdk_display->$gtk_cv_display_resource_base)
+# Check if X_LOCALE definition is necessary
+
+AC_MSG_CHECKING(need -DX_LOCALE)
+AC_TRY_RUN([
+#include <stdio.h>
+#include <locale.h>
+
+int
+main ()
+{
+ return setlocale (LC_ALL, "${with_locale}") == NULL;
+}],
+gtk_cv_x_locale=no,
+gtk_cv_x_locale=yes)
+AC_MSG_RESULT($gtk_cv_x_locale)
+if test $gtk_cv_x_locale = yes; then
+ CFLAGS="$CFLAGS -DX_LOCALE"
+fi
+
# Checks for header files.
AC_HEADER_STDC