summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-05-21 15:56:19 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-05-21 15:56:19 +0000
commit479810cac75f31669b8712bce944d73cddf41253 (patch)
treee64febbfc9c07847f594d5a8b60cfd96109dd286 /configure.in
parentb85c58715204b142ddbe511811f8f08dac0a8270 (diff)
downloadgtk+-479810cac75f31669b8712bce944d73cddf41253.tar.gz
Only show the separator if both children are present and visible.
Mon May 21 11:29:21 2001 Owen Taylor <otaylor@redhat.com> * gtk/gtk{h,v,}paned.c: Only show the separator if both children are present and visible. * configure.in: Fixed reversed conditional causing all image libraries to be linked in.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2f44527600..58e8015e74 100644
--- a/configure.in
+++ b/configure.in
@@ -564,8 +564,6 @@ AM_CONDITIONAL(HAVE_PNG, test "x$LIBPNG" != x)
AM_CONDITIONAL(HAVE_JPEG, test "x$LIBJPEG" != x)
if $dynworks ; then
- STATIC_LIB_DEPS="$LIBTIFF $LIBJPEG $LIBPNG"
-else
STATIC_LIB_DEPS=
if echo "$included_loaders" | grep "\(^\|\,\)tiff\(\$\|\,\)" > /dev/null; then
STATIC_LIB_DEPS="$STATIC_LIB_DEPS $LIBTIFF"
@@ -576,6 +574,8 @@ else
if echo "$included_loaders" | grep "\(^\|\,\)png\(\$\|\,\)" > /dev/null; then
STATIC_LIB_DEPS="$STATIC_LIB_DEPS $LIBPNG"
fi
+else
+ STATIC_LIB_DEPS="$LIBTIFF $LIBJPEG $LIBPNG"
fi
# Checks to see if we should compile in MMX support (there will be