summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@collabora.co.uk>2010-03-15 17:07:59 +0100
committerWim Taymans <wim.taymans@collabora.co.uk>2010-03-15 17:07:59 +0100
commitc78c637a771fef7236bd559a42d18d8b5fc370da (patch)
tree9b84bbe8cc2749b871b80f09f268990e1219b674 /configure.ac
parentfb9243178a88eef1b29bb7ba105ad4a80cd47790 (diff)
downloadgstreamer-c78c637a771fef7236bd559a42d18d8b5fc370da.tar.gz
task: use bionic/libc friendly arguments to prctl
prctl is supposed to take 5 arguments. It used to work with 2 arguments on some versions of libc because it is defined as a varags function there. See #611911
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 37967e3f42..3c9e3af635 100644
--- a/configure.ac
+++ b/configure.ac
@@ -281,9 +281,8 @@ dnl check for pthreads
AC_CHECK_HEADERS([pthread.h], HAVE_PTHREAD_H=yes)
AM_CONDITIONAL(HAVE_PTHREAD_H, test "x$HAVE_PTHREAD_H" = "xyes")
-dnl check for sys/prctl
+dnl check for sys/prctl for setting thread name on Linux
AC_CHECK_HEADERS([sys/prctl.h], HAVE_SYS_PRCTL_H=yes)
-AM_CONDITIONAL(HAVE_SYS_PRTCL_H, test "x$HAVE_SYS_PRCTL_H" = "xyes")
dnl Check for valgrind.h
dnl separate from HAVE_VALGRIND because you can have the program, but not