summaryrefslogtreecommitdiff
path: root/docs/plugins/Makefile.am
diff options
context:
space:
mode:
authorStefan Sauer <ensonic@users.sf.net>2014-02-26 22:05:23 +0100
committerStefan Sauer <ensonic@users.sf.net>2014-02-26 22:05:23 +0100
commit99943fd0409cf82d469e767a2663c5ac7f7d7325 (patch)
tree3bbb5771421c20e20eaee462e783235439cc7f41 /docs/plugins/Makefile.am
parent4cb732775274bb9c09ed5197b6863ace6a01fa02 (diff)
downloadgst-libav-99943fd0409cf82d469e767a2663c5ac7f7d7325.tar.gz
docs: try to make the generated docs more useful
Generate the section.txt file. Update the -docs.sgml file with the new sections. If we want to actually see the baseclasses, we should define them with a _get_type() function and have the wrapped types subclass them.
Diffstat (limited to 'docs/plugins/Makefile.am')
-rw-r--r--docs/plugins/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/docs/plugins/Makefile.am b/docs/plugins/Makefile.am
index 0ad0314..b52a84d 100644
--- a/docs/plugins/Makefile.am
+++ b/docs/plugins/Makefile.am
@@ -22,7 +22,7 @@ DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
DOC_SOURCE_DIR = $(top_srcdir)/ext/libav
# Extra options to supply to gtkdoc-scan.
-SCAN_OPTIONS=
+SCAN_OPTIONS=--rebuild-sections
# Extra options to supply to gtkdoc-mkdb.
MKDB_OPTIONS=--sgml-mode
@@ -47,9 +47,6 @@ IGNORE_CFILES =
# but I'm not sure about that - it might be this Just Works given that
# the registry won't have the element
-# huh? thats not a header
-#EXTRA_HFILES = $(DOC_SOURCE_DIR)/gstffmpegenc.c
-
# Images to copy into HTML directory.
HTML_IMAGES =
@@ -61,8 +58,9 @@ extra_files =
# CFLAGS and LDFLAGS for compiling scan program. Only needed if your app/lib
# contains GtkObjects/GObjects and you want to document signals and properties.
-GTKDOC_CFLAGS = $(GST_BASE_CFLAGS) -I$(top_builddir) -I$(top_builddir)/gst-libs
-GTKDOC_LIBS = $(GST_BASE_LIBS)
+GTKDOC_CFLAGS = $(LIBAV_CFLAGS) $(GST_CFLAGS) -I$(top_builddir) -I$(top_builddir)/ext/libav
+GTKDOC_LIBS = -L$(top_builddir)/ext/libav -lgstlibav \
+ $(LIBAV_LIBS) $(GST_BASE_LIBS)
GTKDOC_CC=$(LIBTOOL) --tag=CC --mode=compile $(CC)
GTKDOC_LD=$(LIBTOOL) --tag=CC --mode=link $(CC)