summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2017-07-24 16:15:15 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2017-08-03 11:57:52 +0200
commit0a3c4cfe7d23f58c4e4efc4e928447dbc1a4cf06 (patch)
treede5d4adf61e3cce2517d2d3bac4303cb3105ce71 /tests/Makefile.am
parent67f2fc547acc61f8769125dd3d6218cc282b30d0 (diff)
downloadgnutls-0a3c4cfe7d23f58c4e4efc4e928447dbc1a4cf06.tar.gz
tests: added unit test for RSA-PSS signing over PKCS#11
This requires a softhsm with support for RSA_PKCS_PSS mechanism. Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4f8a43c758..a97814d05c 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -250,7 +250,8 @@ ctests += pkcs11-cert-import-url-exts pkcs11-get-exts pkcs11-get-raw-issuer-exts
pkcs11-import-url-privkey pkcs11-privkey-fork pkcs11/pkcs11-ec-privkey-test \
pkcs11-privkey-always-auth pkcs11-privkey-export pkcs11/pkcs11-import-with-pin \
pkcs11/pkcs11-privkey-pthread pkcs11/pkcs11-pin-func pkcs11/pkcs11-obj-import \
- pkcs11-privkey-fork-reinit pkcs11-mechanisms pkcs11-privkey-safenet-always-auth
+ pkcs11-privkey-fork-reinit pkcs11-mechanisms pkcs11-privkey-safenet-always-auth \
+ pkcs11/pkcs11-rsa-pss-privkey-test
endif