summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2017-10-30 13:51:33 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2017-11-03 16:10:57 +0000
commit418b2e12b5d589f81987ccdaae09b4cc33384ee6 (patch)
tree1521ddaa1154377e2a1041783684a746a9cb2777 /configure.ac
parent00ae9ab6d51929b17c43e1424b434a951a59bd58 (diff)
downloadgnutls-418b2e12b5d589f81987ccdaae09b4cc33384ee6.tar.gz
tests: added PKCS#11 module loading test
This checks: 1. Whether all modules are loaded from p11-kit when no explicit gnutls_pkcs11_init() is called and pkcs11 calls are accessed. 2. Whether only the trusted modules are loaded from p11-kit and no other PKCS#11 calls than PKCS#11 cert validation is performed. 3. Whether the trusted modules are loaded when gnutls_pkcs11_init() is called with manual flag. Resolves #315 Resolves #316 Signed-off-by: Nikos Mavrogiannopoulos <nmav@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b5e6cafdfa..6b46887509 100644
--- a/configure.ac
+++ b/configure.ac
@@ -254,6 +254,11 @@ AC_ARG_ENABLE(tests,
enable_tests=$enableval, enable_tests=$enable_tools)
AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" != "no")
+AC_ARG_ENABLE(destructive-tests,
+ AS_HELP_STRING([--enable-destructive-tests], [compile and run tests which touch outside gnutls' code boundary]),
+ enable_destructive_tests=$enableval, enable_destructive_tests=no)
+AM_CONDITIONAL(ENABLE_DESTRUCTIVE_TESTS, test "$enable_destructive_tests" != "no")
+
AC_ARG_ENABLE(fuzzer-target,
AS_HELP_STRING([--enable-fuzzer-target], [make a library intended for testing - not production]),
enable_fuzzer_target=$enableval, enable_fuzzer_target=no)
@@ -729,6 +734,8 @@ if test "x$with_default_trust_store_pkcs11" != x; then
["$with_default_trust_store_pkcs11"], [use the given pkcs11 uri as default trust store])
fi
+AM_CONDITIONAL([HAVE_PKCS11_TRUST_STORE], [test -n "${with_default_trust_store_pkcs11}"])
+
AC_ARG_WITH([default-trust-store-dir],
[AS_HELP_STRING([--with-default-trust-store-dir=DIR],
[use the given directory as default trust store])])
@@ -981,6 +988,7 @@ AC_MSG_NOTICE([summary of build options:
Local unistring: ${included_unistring}
Use nettle-mini: ${mini_nettle}
Documentation: ${enable_doc} (manpages: ${enable_manpages})
+ Destructive tests: ${enable_destructive_tests}
])
AC_MSG_NOTICE([External hardware support: