summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@redhat.com>2015-08-10 16:43:28 +0200
committerNikos Mavrogiannopoulos <nmav@redhat.com>2015-08-10 16:44:02 +0200
commite6b8825c75a7810a19e12d7b78a60897c6ce9fd7 (patch)
tree19561fd4d5656e33a82efa657cf5af6e35dd8d78 /Makefile.am
parent30d120ee9976ec03a0c594aa5770f2a5a7785181 (diff)
downloadgnutls-e6b8825c75a7810a19e12d7b78a60897c6ce9fd7.tar.gz
before dist ensure that included libopts matches autogen
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1bbb7f4573..19fcb9056f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,4 +85,9 @@ dist-hook:
cd $(distdir)/src/ && for i in *-args.c *-args.h;do \
mv $$i $$i.bak; \
done
+ @echo "*****************************************************************"
+ @echo "Checking whether included libopts matches the system's. If the"
+ @echo "check fails upgrade the included libopts."
+ @echo "*****************************************************************"
+ test "`autoopts-config libsrc|cut -d '-' -f 2|sed 's/.tar.gz//'`" = "`cat src/libopts/autoopts/options.h |grep OPTIONS_VERSION_STRING|cut -d '"' -f 2|sed 's/:/./g'`"
touch $(distdir)/doc/*.html $(distdir)/doc/*.pdf $(distdir)/doc/*.info