summaryrefslogtreecommitdiff
path: root/tests/functional-tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/functional-tests/Makefile.am')
-rw-r--r--tests/functional-tests/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/functional-tests/Makefile.am b/tests/functional-tests/Makefile.am
index c12a47d4c..08082702d 100644
--- a/tests/functional-tests/Makefile.am
+++ b/tests/functional-tests/Makefile.am
@@ -51,13 +51,21 @@ TEST_RUNNER = $(top_srcdir)/tests/functional-tests/test-runner.sh
functional-test: ${standard_tests}
for test in ${standard_tests} ; do \
+ export TRACKER_DB_ONTOLOGIES_DIR=$(top_srcdir)/src/ontologies/nepomuk; \
+ export TRACKER_FUNCTIONAL_TEST_BUILD_DIR=$(top_builddir) ; \
export TRACKER_FUNCTIONAL_TEST_CONFIG=$(top_builddir)/tests/functional-tests/configuration.json ; \
+ export TRACKER_LANGUAGE_STOP_WORDS_DIR=$(top_srcdir)/src/libtracker-common/stop-words ; \
+ export TRACKER_TEST_DOMAIN_ONTOLOGY_RULE=$(top_srcdir)/src/tracker-store/default.rule ; \
$(TEST_RUNNER) python $(top_srcdir)/tests/functional-tests/$$test; \
done
functional-test-slow: ${slow_tests}
@for test in ${slow_tests} ; do \
- export TRACKER_FUNCTIONAL_TEST_CONFIG=$(top_builddir)/tests/functional-tests/configuration.json \
+ export TRACKER_DB_ONTOLOGIES_DIR=$(top_srcdir)/src/ontologies/nepomuk; \
+ export TRACKER_FUNCTIONAL_TEST_BUILD_DIR=$(top_builddir) ; \
+ export TRACKER_FUNCTIONAL_TEST_CONFIG=$(top_builddir)/tests/functional-tests/configuration.json ; \
+ export TRACKER_LANGUAGE_STOP_WORDS_DIR=$(top_srcdir)/src/libtracker-common/stop-words ; \
+ export TRACKER_TEST_DOMAIN_ONTOLOGY_RULE=$(top_srcdir)/src/tracker-store/default.rule ; \
$(TEST_RUNNER) python $(top_srcdir)/tests/functional-tests/$$test; \
done