summaryrefslogtreecommitdiff
path: root/tests/datetime/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/datetime/meson.build')
-rw-r--r--tests/datetime/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/datetime/meson.build b/tests/datetime/meson.build
index 4b2b03b36..fd0896400 100644
--- a/tests/datetime/meson.build
+++ b/tests/datetime/meson.build
@@ -8,6 +8,8 @@ test_units = [
includes = [top_inc, include_directories('../../panels/datetime')]
env = [
'G_MESSAGES_DEBUG=all',
+ 'BUILDDIR=' + meson.current_build_dir(),
+ 'TOP_BUILDDIR=' + meson.build_root()
]
cflags = [
'-DTEST_SRCDIR="@0@"'.format(meson.current_source_dir()),
@@ -23,7 +25,11 @@ foreach unit: test_units
link_with : [datetime_panel_lib],
c_args : cflags
)
-
- test(unit, exe, env: env)
endforeach
+test(
+ 'test-datetime',
+ find_program('test-datetime.py'),
+ env : env,
+ timeout : 10
+) \ No newline at end of file