summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRodney Dawes <dobey@novell.com>2006-01-03 19:33:57 +0000
committerRodney Dawes <dobey@src.gnome.org>2006-01-03 19:33:57 +0000
commitc424013fdd0fe24a088d629dbe22b338923b61db (patch)
tree8dc8def51cfcc03c6dced8c7a6670942c9d0c7be /Makefile.am
parent0215039c19d3184124bc9b8f42f195ea349e6281 (diff)
downloadadwaita-icon-theme-c424013fdd0fe24a088d629dbe22b338923b61db.tar.gz
Disable the checks for hicolor, as we no longer install icons into the
2006-01-03 Rodney Dawes <dobey@novell.com> * Makefile.am: * configure.in: Disable the checks for hicolor, as we no longer install icons into the hicolor theme, with this commit * */*/Makefile.am: Don't install gnome icons to hicolor, to avoid the possibility for conflicts, when we move all the gnome icons over to the Icon Naming Specification names
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 0 insertions, 25 deletions
diff --git a/Makefile.am b/Makefile.am
index e50ee582b..33363b6c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,11 +7,6 @@ THEME_IN_FILES=index.theme.in
%.theme: %.theme.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po) ; $(INTLTOOL_MERGE) $(top_srcdir)/po $< $@ -d -u -c $(top_builddir)/po/.intltool-merge-cache
-hicolor_dirs = \
- $(datadir)/pixmaps \
- $(datadir)/icons \
- /usr/share/icons \
- /usr/share/pixmaps
icondir = $(datadir)/icons/gnome
icon_DATA = index.theme
@@ -26,28 +21,8 @@ EXTRA_DIST= \
# we don't want to install mo files, all translations are already stored
# in theme files
-# Ensure that hicolor is installed too
install-data-local:
$(MAKE) -C po uninstall
-if ENABLE_HICOLOR_CHECK
- @dirs='$(hicolor_dirs)'; for dir in $$dirs; do \
- echo Checking for hicolor theme in \'$$dir/hicolor/index.theme\' ; \
- if test -f "$$dir/hicolor/index.theme"; then \
- echo Good. Found it. ; \
- exit 0; \
- fi ; \
- done ; \
- echo ; \
- echo "@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@" ; \
- echo "Could not find the theme 'hicolor' which acts as the base for all other" ; \
- echo "themes, including gnome-icon-theme. Perhaps you need to install it." ; \
- echo "You can get a copy from http://freedesktop.org/Software/icon-theme/releases" ; \
- echo "@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@" ; \
- echo ; \
- exit 1
-endif
-
-DISTCHECK_CONFIGURE_FLAGS = --disable-hicolor-check
CLEANFILES = \
index.theme