summaryrefslogtreecommitdiff
path: root/libcc1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libcc1/Makefile.am')
-rw-r--r--libcc1/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libcc1/Makefile.am b/libcc1/Makefile.am
index 7a274b3470c..b40820b2189 100644
--- a/libcc1/Makefile.am
+++ b/libcc1/Makefile.am
@@ -44,11 +44,12 @@ cc1lib_LTLIBRARIES = libcc1.la
endif
BUILT_SOURCES = compiler-name.h
+MOSTLYCLEANFILES = compiler-name.h
# Put this in a header so we don't run sed for each compilation. This
# is also simpler to debug as one can easily see the constant.
compiler-name.h: Makefile
- echo "#define COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > compiler-name.h
+ echo "#define COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > $@
shared_source = callbacks.cc callbacks.hh connection.cc connection.hh \