summaryrefslogtreecommitdiff
path: root/libf2c/configure.in
diff options
context:
space:
mode:
authorKaveh R. Ghazi <ghazi@caip.rutgers.edu>1999-03-31 10:56:35 +0000
committerKaveh Ghazi <ghazi@gcc.gnu.org>1999-03-31 10:56:35 +0000
commit8d0823e282b3d83cc743afc11e4732e23647c541 (patch)
tree1f20f9d1acb0ecbd218b2094a3f3c1f9258e2dcd /libf2c/configure.in
parent863ebdad199295368ad0f811eba4e72c168e53fb (diff)
downloadgcc-8d0823e282b3d83cc743afc11e4732e23647c541.tar.gz
configure.in (extra_includes): Don't attempt to calculate the location of the gcc src or obj directories.
* configure.in (extra_includes): Don't attempt to calculate the location of the gcc src or obj directories. Instead rely on precomputed variables, $topsrcdir and $r, to obtain these values. Set -I flags appropriately. From-SVN: r26084
Diffstat (limited to 'libf2c/configure.in')
-rw-r--r--libf2c/configure.in7
1 files changed, 1 insertions, 6 deletions
diff --git a/libf2c/configure.in b/libf2c/configure.in
index a6520e69b58..ea1acc2f836 100644
--- a/libf2c/configure.in
+++ b/libf2c/configure.in
@@ -101,12 +101,7 @@ AC_MSG_CHECKING(f2c integer type)
# Set this back later below!
late_ac_cpp=$ac_cpp
late_cflags=$CFLAGS
-##gcc -c -DIN_GCC -DHAVE_CONFIG_H -I. -I/home/fx/c-e/egcs/gcc -I/home/fx/c-e/egcs/gcc/config -I/home/fx/c-e/egcs/gcc/../include /home/fx/c-e/egcs/gcc/f/proj.c
-if test "$srcdir" != . ; then
- extra_includes="-I$srcdir/../gcc/f -I../../gcc -I$srcdir/../gcc -I$srcdir/../include -I$srcdir/../gcc/config"
-else
- extra_includes="-I../../gcc/f -I../../gcc -I../../include -I../../gcc/config"
-fi
+extra_includes="-I$topsrcdir/gcc/f -I$topsrcdir/gcc -I$topsrcdir/include -I$topsrcdir/gcc/config -I$r/gcc"
ac_cpp="$late_ac_cpp -DIN_GCC -DHAVE_CONFIG_H $extra_includes"
# The AC_EGREP_CPPs below have been known to fail when the header