summaryrefslogtreecommitdiff
path: root/libcc1/Makefile.am
diff options
context:
space:
mode:
authorsegher <segher@138bc75d-0d04-0410-961f-82ee72b054a4>2016-04-11 07:26:36 +0000
committersegher <segher@138bc75d-0d04-0410-961f-82ee72b054a4>2016-04-11 07:26:36 +0000
commit537e38b358fd975288272f278fc39829b1b8930f (patch)
treeacd9cb5711ff45e2f26cfc66ae79b4dccc4327c4 /libcc1/Makefile.am
parenta9022b8b93718e275e13bfd4cfcea974262cb89f (diff)
downloadgcc-537e38b358fd975288272f278fc39829b1b8930f.tar.gz
libcc1: Clean compiler-name.h (PR70173)
Since the file is generated from a Makefile fragment, it needs to be added to MOSTLYCLEANFILES. The directory itself is still not deleted (just like the gnattools and gotools directories). 2016-04-11 Segher Boessenkool <segher@kernel.crashing.org> libcc1/ PR bootstrap/70173 * Makefile.am (MOSTLYCLEANFILES): New, add compiler-name.h . (compiler-name.h): Shorten recipe so that it fits the line. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@234874 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libcc1/Makefile.am')
-rw-r--r--libcc1/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libcc1/Makefile.am b/libcc1/Makefile.am
index 7a274b3470c..b40820b2189 100644
--- a/libcc1/Makefile.am
+++ b/libcc1/Makefile.am
@@ -44,11 +44,12 @@ cc1lib_LTLIBRARIES = libcc1.la
endif
BUILT_SOURCES = compiler-name.h
+MOSTLYCLEANFILES = compiler-name.h
# Put this in a header so we don't run sed for each compilation. This
# is also simpler to debug as one can easily see the constant.
compiler-name.h: Makefile
- echo "#define COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > compiler-name.h
+ echo "#define COMPILER_NAME \"`echo gcc | sed '$(transform)'`\"" > $@
shared_source = callbacks.cc callbacks.hh connection.cc connection.hh \