summaryrefslogtreecommitdiff
path: root/intl/configure.ac
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-02-29 20:22:40 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2004-02-29 20:22:40 +0000
commit43f0acf20aab7210b1fa373f592f63f998db111e (patch)
tree154386c3509235bb7e097c2f593d492f311ef528 /intl/configure.ac
parent0dd9317d2f350c31548029bf761843111a0c3819 (diff)
downloadgcc-43f0acf20aab7210b1fa373f592f63f998db111e.tar.gz
* configure.in: Convert to autoconf 2.57, gratuitous stylistic
cleanup, rename to configure.ac. * configure.ac: Renamed from configure.in. * config.h.in: Rebuilt with autoheader 2.57. * configure: Rebuilt with autoconf 2.57 * README: Update to reflect rename of configure.in to configure.ac. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@78668 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'intl/configure.ac')
-rw-r--r--intl/configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/intl/configure.ac b/intl/configure.ac
new file mode 100644
index 00000000000..0f54336ba86
--- /dev/null
+++ b/intl/configure.ac
@@ -0,0 +1,33 @@
+AC_PREREQ(2.57)
+AC_INIT
+AC_CONFIG_SRCDIR(gettext.c)
+AC_CONFIG_HEADER(config.h)
+AM_GNU_GETTEXT_VERSION(0.12.1)
+AM_GNU_GETTEXT
+
+# This replaces the extensive use of DEFS in the original Makefile.in.
+AC_DEFINE(IN_LIBINTL, 1, [Define because this is libintl.])
+AC_DEFINE(IN_LIBRARY, 1, [Define because this is a library.])
+AC_DEFINE(DEPENDS_ON_LIBICONV, 1, [Define because we depend on libiconv.])
+AC_DEFINE(ENABLE_RELOCATABLE, 1, [Define to enable relocation.])
+AC_DEFINE(NO_XMALLOC, 1, [Define if there is no xmalloc.])
+AC_DEFINE(set_relocation_prefix, libintl_set_relocation_prefix,
+[Define this entry point correctly.])
+AC_DEFINE(relocate, libintl_relocate,
+[Define this entry point correctly.])
+
+# Additional info for config.intl.
+AC_SUBST(LIBINTL_DEP)
+AC_SUBST(INCINTL)
+
+LIBINTL_DEP=
+INCINTL=
+case $USE_INCLUDED_LIBINTL in
+ yes)
+ LIBINTL_DEP='${top_builddir}/intl/libintl.a'
+ INCINTL='-I${top_builddir}/intl'
+ ;;
+esac
+
+AC_CONFIG_FILES(Makefile config.intl)
+AC_OUTPUT