summaryrefslogtreecommitdiff
path: root/boehm-gc/Makefile.am
diff options
context:
space:
mode:
authorTom Tromey <tromey@cygnus.com>1999-04-26 14:15:05 +0000
committerTom Tromey <tromey@gcc.gnu.org>1999-04-26 14:15:05 +0000
commit66deb2be595d1a2ca4d00cfbf24d13e7a772c5ab (patch)
tree419bf5af5475ca11cc989d4c67ec026cfeb18980 /boehm-gc/Makefile.am
parent01656b25ec4da07ca1470bd2b7c64456e5900f2e (diff)
downloadgcc-66deb2be595d1a2ca4d00cfbf24d13e7a772c5ab.tar.gz
libtoolized GC library. See ChangeLog for details.
Also a couple bug fixes: * dyn_load.c (GC_FirstDLOpenedLinkMap): Declare _DYNAMIC as `weak'. * misc.c (GC_init_inner): If QUICK_THREADS defined, compute GC_stackbottom. From-SVN: r26650
Diffstat (limited to 'boehm-gc/Makefile.am')
-rw-r--r--boehm-gc/Makefile.am33
1 files changed, 17 insertions, 16 deletions
diff --git a/boehm-gc/Makefile.am b/boehm-gc/Makefile.am
index 5b0742d5001..cd18abbeed2 100644
--- a/boehm-gc/Makefile.am
+++ b/boehm-gc/Makefile.am
@@ -14,13 +14,12 @@ MULTISUBDIR =
MULTIDO = true
MULTICLEAN = true
-tooldir = $(exec_prefix)/$(target_alias)
-toollibdir = $(tooldir)/lib$(MULTISUBDIR)
+toolexecdir = $(exec_prefix)/$(target_alias)
+toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
-## FIXME: when native, use libtool to provide shared libraries.
-toollib_LIBRARIES = $(target_all)
-EXTRA_LIBRARIES = libgcjgc.a
-libgcjgc_a_SOURCES = allchblk.c alloc.c blacklst.c checksums.c \
+toolexeclib_LTLIBRARIES = $(target_all)
+EXTRA_LTLIBRARIES = libgcjgc.la
+libgcjgc_la_SOURCES = allchblk.c alloc.c blacklst.c checksums.c \
config.h dbg_mlc.c dyn_load.c finalize.c gc.h gc_alloc.h gc_cpp.h \
gc_hdrs.h gc_mark.h gc_priv.h gc_private.h gc_typed.h headers.c \
irix_threads.c linux_threads.c malloc.c mallocx.c mark.c mark_rts.c \
@@ -28,10 +27,11 @@ misc.c new_hblk.c obj_map.c os_dep.c pcr_interface.c ptr_chck.c \
quick_threads.c real_malloc.c reclaim.c solaris_pthreads.c \
solaris_threads.c solaris_threads.h stubborn.c typd_mlc.c version.h \
weakpointer.h
-libgcjgc_a_LIBADD = @addobjs@
-libgcjgc_a_DEPENDENCIES = @addobjs@
+libgcjgc_la_LIBADD = @addobjs@
+libgcjgc_la_DEPENDENCIES = @addobjs@
+libgcjgc_la_LDFLAGS = -release $(VERSION) -rpath $(toolexeclibdir)
-EXTRA_libgcjgc_a_SOURCES = alpha_mach_dep.s mips_sgi_mach_dep.s \
+EXTRA_libgcjgc_la_SOURCES = alpha_mach_dep.s mips_sgi_mach_dep.s \
mips_ultrix_mach_dep.s rs6000_mach_dep.s sparc_mach_dep.s \
sparc_sunos4_mach_dep.s mach_dep.c ecos.cc
@@ -40,22 +40,23 @@ AM_CFLAGS = @BOEHM_GC_CFLAGS@
check_PROGRAMS = gctest
gctest_SOURCES = test.c
-gctest_LDADD = ./libgcjgc.a
+gctest_LDADD = ./libgcjgc.la
## FIXME: relies on internal code generated by automake.
-all_objs = @addobjs@ $(libgcjgc_a_OBJECTS)
+all_objs = @addobjs@ $(libgcjgc_la_OBJECTS)
$(all_objs) : config.h gc_priv.h gc_hdrs.h gc.h gc_mark.h
## FIXME: we shouldn't have to do this, but automake forces us to.
.s.o:
- $(CC) -x assembler-with-cpp $(DEFS) $(INCLUDES) $(CPPFLAGS) $(BOEHM_GC_CFLAGS) \
- $(MY_CFLAGS) -c $<
+ $(LTCOMPILE) -x assembler-with-cpp -c $<
-## We have our own definition of COMPILE because we want to use our
+## We have our own definition of LTCOMPILE because we want to use our
## CFLAGS, not those passed in from the top level make.
-COMPILE = $(CC) $(DEFS) $(INCLUDES) $(CPPFLAGS) $(MY_CFLAGS) $(BOEHM_GC_CFLAGS)
-LINK = $(CC) $(AM_CFLAGS) $(MY_CFLAGS) $(LDFLAGS) -o $@
+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) \
+ $(AM_CFLAGS) $(MY_CFLAGS) $(BOEHM_GC_CFLAGS)
+LINK = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(MY_CFLAGS) $(LDFLAGS) -o $@
AM_CFLAGS = @BOEHM_GC_CFLAGS@