summaryrefslogtreecommitdiff
path: root/src/wayland_protocol/meson.build
diff options
context:
space:
mode:
authorMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-13 12:24:37 +0200
committerMarcel Hollerbach <mail@marcel-hollerbach.de>2018-10-15 22:02:17 +0200
commitbb2b21e55fc650819af6af6dc57934debfcb8ac8 (patch)
tree74a1f5ba956f955122daaee1d0fc4f76bc32ff06 /src/wayland_protocol/meson.build
parentd3122474d44108397b07b28447dc790dd69ab5a8 (diff)
downloadefl-bb2b21e55fc650819af6af6dc57934debfcb8ac8.tar.gz
meson: fix build files size explosion
wayland protocols accidently added generated c source files to the sources. This lead to every dependency of evas compiling those 5 c source code files again and again and again. Which is completly wrong. This commit splits up between headers and c files. which reduces the build files from over 4K to roughly 3K. Differential Revision: https://phab.enlightenment.org/D7159
Diffstat (limited to 'src/wayland_protocol/meson.build')
-rw-r--r--src/wayland_protocol/meson.build19
1 files changed, 10 insertions, 9 deletions
diff --git a/src/wayland_protocol/meson.build b/src/wayland_protocol/meson.build
index 5f3680ee93..5301adbe71 100644
--- a/src/wayland_protocol/meson.build
+++ b/src/wayland_protocol/meson.build
@@ -23,31 +23,32 @@ wl_stable_protocol_sys = [
]
foreach sys_protocol : wl_unstable_protocol_sys
- wl_protocol_local += [
+ wl_protocol_local += [
join_paths(_wayland_protocols.get_pkgconfig_variable('pkgdatadir'), 'unstable',
sys_protocol)]
endforeach
foreach sys_protocol : wl_stable_protocol_sys
- wl_protocol_local += [
+ wl_protocol_local += [
join_paths(_wayland_protocols.get_pkgconfig_variable('pkgdatadir'), 'stable',
sys_protocol)]
endforeach
-gen_obj = []
+gen_obj_c = []
+gen_obj_header = []
foreach item : wl_protocol_local
- gen_obj += custom_target('wl_code_'+item.underscorify(),
+ gen_obj_c += custom_target('wl_code_'+item.underscorify(),
input: item,
output : ['@BASENAME@-protocol.c'],
command: [wayland_scanner_bin, ['code','@INPUT@','@OUTPUT@']]
)
- gen_obj += custom_target('wl_client_header_'+item.underscorify(),
+ gen_obj_header += custom_target('wl_client_header_'+item.underscorify(),
input: item,
output : ['@BASENAME@-client-protocol.h'],
command: [wayland_scanner_bin, ['client-header','@INPUT@','@OUTPUT@']]
)
- gen_obj += custom_target('wl_server_header_'+item.underscorify(),
+ gen_obj_header += custom_target('wl_server_header_'+item.underscorify(),
input: item,
output : ['@BASENAME@-server-protocol.h'],
command: [wayland_scanner_bin, ['server-header','@INPUT@','@OUTPUT@']]
@@ -56,12 +57,12 @@ endforeach
wayland_protocol_lib = static_library('wayland_protocol',
- gen_obj,
+ gen_obj_c + gen_obj_header,
)
wayland_protocol = declare_dependency(
include_directories: include_directories('.'),
link_with: wayland_protocol_lib,
- sources: gen_obj,
+ sources: gen_obj_header,
dependencies : [wayland_client]
-) \ No newline at end of file
+)