summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGustavo Sverzut Barbieri <barbieri@gmail.com>2012-10-10 18:43:15 +0000
committerGustavo Sverzut Barbieri <barbieri@gmail.com>2012-10-10 18:43:15 +0000
commit0b19ba7bc23ce175537a29c2816b3ef12e95ed2d (patch)
tree0efdfaa8435a14f63a2070eb0ec75b25faed49d7 /src/Makefile.am
parentb82e878656f76195be22574eae06b59d92b3c24c (diff)
downloadefl-0b19ba7bc23ce175537a29c2816b3ef12e95ed2d.tar.gz
efl: introduce build profile, simplify options.
Introduced --with-profile={dev,release} that will simplify how to set build options of EFL. NOTE-1: specific e17 benchmark is now gone, it will always be built and is the default benchmark for eina. If we want to have a faster benchmark in the future, just add a command line option for eina_suite. NOTE-2: valgrind build is broken as it needs -fPIC. Will get to it later. Likely someone needs to revisit the eina mempools for valgrind and other basic tools (eo? likely evas). SVN revision: 77771
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 416bb5ad6c..8b0b50e481 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,16 +2,12 @@ MAINTAINERCLEANFILES = Makefile.in
SUBDIRS = lib modules bin scripts benchmarks tests examples
-.PHONY: benchmark benchmark-e17 examples
+.PHONY: benchmark examples
benchmark:
@$(MAKE) $(AM_MAKEFLAGS) -C lib
@$(MAKE) $(AM_MAKEFLAGS) -C benchmarks benchmark
-benchmark-e17:
- @$(MAKE) $(AM_MAKEFLAGS) -C lib
- @$(MAKE) $(AM_MAKEFLAGS) -C benchmarks benchmark-e17
-
examples:
@make -C lib
@$(MAKE) $(AM_MAKEFLAGS) -C examples examples