summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Djärv <jan.h.d@swipnet.se>2002-03-10 16:37:56 +0000
committerJan Djärv <jan.h.d@swipnet.se>2002-03-10 16:37:56 +0000
commit4b1e3a33fa41fec361f0c5e9bf9bebff1d54df46 (patch)
tree72382da247488bab9c55bdc49b8136093d965451 /configure.in
parent10f4e1d945b88aa144706e94eb4df1a088e306fe (diff)
downloademacs-4b1e3a33fa41fec361f0c5e9bf9bebff1d54df46.tar.gz
Added test for X Session Management (HAVE_X_SM).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2c1734563d0..c1d324fab36 100644
--- a/configure.in
+++ b/configure.in
@@ -1935,6 +1935,21 @@ if test "${HAVE_X11}" = "yes"; then
fi
fi
+### Use session management (-lSM -lICE) if available
+HAVE_X_SM=no
+if test "${HAVE_X11}" = "yes"; then
+ AC_CHECK_HEADER(X11/SM/SMlib.h,
+ AC_CHECK_LIB(SM, SmcOpenConnection, HAVE_X_SM=yes, -lICE))
+
+ if test "${HAVE_X_SM}" = "yes"; then
+ AC_DEFINE(HAVE_X_SM)
+ case "$LIBS" in
+ *-lSM*) ;;
+ *) LIBS="-lSM -lICE $LIBS" ;;
+ esac
+ fi
+fi
+
# If netdb.h doesn't declare h_errno, we must declare it by hand.
AC_CACHE_CHECK(whether netdb declares h_errno,
emacs_cv_netdb_declares_h_errno,