summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew Choi <akochoi@shaw.ca>2002-04-26 23:39:06 +0000
committerAndrew Choi <akochoi@shaw.ca>2002-04-26 23:39:06 +0000
commit06e845fb8ea69c350ab79effd585361566fdff0f (patch)
treef4fe64d440e8469a066bdd80bd20c1182b479226 /configure.in
parentf799b24f812a0e9928e59530d6e376299702024b (diff)
downloademacs-06e845fb8ea69c350ab79effd585361566fdff0f.tar.gz
Patch for building Emacs on Mac OS X. April 26, 2002. See ChangeLog,
lisp/ChangeLog, and src/ChangeLog for list of changes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ec584e95756..054a5567221 100644
--- a/configure.in
+++ b/configure.in
@@ -128,6 +128,8 @@ AC_ARG_WITH(toolkit-scroll-bars,
don't use Motif or Xaw3d scroll bars])
AC_ARG_WITH(xim,
[ --without-xim don't use X11 XIM])
+AC_ARG_WITH(carbon,
+[ --without-carbon don't use Carbon GUI on Mac OS X])
#### Make srcdir absolute, if it isn't already. It's important to
#### avoid running the path through pwd unnecessarily, since pwd can
@@ -1104,6 +1106,13 @@ case "${canonical}" in
machine=f301 opsys=uxpv
;;
+ ## Darwin / Mac OS X
+ powerpc-apple-darwin* )
+ machine=powermac opsys=darwin
+ # Define CPP as follows to make autoconf work correctly.
+ CPP="cc -E -traditional-cpp"
+ ;;
+
* )
unported=yes
;;
@@ -1997,6 +2006,16 @@ if test "${HAVE_X11}" = "yes"; then
fi
fi
+### Use Mac OS X Carbon API to implement GUI.
+HAVE_CARBON=no
+if test "${with_carbon}" != "no"; then
+ AC_CHECK_HEADER(Carbon/Carbon.h, HAVE_CARBON=yes)
+fi
+
+if test "${HAVE_CARBON}" = "yes"; then
+ AC_DEFINE(HAVE_CARBON)
+fi
+
### Use session management (-lSM -lICE) if available
HAVE_X_SM=no
if test "${HAVE_X11}" = "yes"; then