summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Zaretskii <eliz@gnu.org>2013-08-30 17:19:16 +0300
committerEli Zaretskii <eliz@gnu.org>2013-08-30 17:19:16 +0300
commitdbe17fefccbff010bbbf6c4d0dccc7b2f3a5e201 (patch)
treed6844a441dc78f6a18610e9f88d82e0c8f12f6db /configure.ac
parent0e82377a2d9d8f815d2ef4ec09dc914f37fc87ac (diff)
downloademacs-dbe17fefccbff010bbbf6c4d0dccc7b2f3a5e201.tar.gz
Enable thread support in the MS-Windows build.
src/systhread.h (w32thread_critsect, w32thread_cond_t, sys_mutex_t) (sys_cond_t, sys_thread_t) [WINDOWSNT]: New data types. src/systhread.c (sys_mutex_init, sys_mutex_lock, sys_mutex_unlock) (sys_mutex_destroy, sys_cond_init, sys_cond_wait) (sys_cond_signal, sys_cond_broadcast, sys_cond_destroy) (sys_thread_self, sys_thread_equal, w32_beginthread_wrapper) (sys_thread_create, sys_thread_yield) [WINDOWSNT]: New functions. configure.ac (THREADS_ENABLED): Enable threads for MinGW, even if pthreads is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b22cd0cfab..f8938d07dbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1956,6 +1956,11 @@ if test "$with_threads" = yes; then
AC_DEFINE(THREADS_ENABLED, 1,
[Define to 1 if you want elisp thread support.])
threads_enabled=yes
+ elif test "${opsys}" = "mingw32"; then
+ dnl MinGW can do native Windows threads even without pthreads
+ AC_DEFINE(THREADS_ENABLED, 1,
+ [Define to 1 if you want elisp thread support.])
+ threads_enabled=yes
fi
fi
AC_MSG_RESULT([$threads_enabled])