summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-11-15 18:55:57 +0000
committerSimon McVittie <smcv@collabora.com>2018-11-15 18:55:57 +0000
commitf93b63587f7f88b65eeb837882432e3db1e97176 (patch)
tree0b5c1c31ddb8722e5f9b4497885ad33ee4eaa1a7 /configure.ac
parenta6674bff178a812d4109a745ff5a4167b5d5c1e6 (diff)
downloaddbus-f93b63587f7f88b65eeb837882432e3db1e97176.tar.gz
internals: Assume compiler supports a subset of ISO varargs syntax
We have considerable anecdotal evidence that every relevant compiler supports at least the small part of ISO varargs syntax that we need here, because tools/tool-common.h has contained #define VERBOSE(...) do {} while (0) since dbus 1.9.2 (2014) and nobody has complained yet. With that in mind, let's simplify. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 0 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index 916633d8..89337836 100644
--- a/configure.ac
+++ b/configure.ac
@@ -777,35 +777,6 @@ dnl Make it easy to check if we have MSG_NOSIGNAL without actually having to inc
AC_CHECK_DECLS([MSG_NOSIGNAL], [], [], [[ #include <sys/types.h>
#include <sys/socket.h> ]])
-dnl check for flavours of varargs macros (test from GLib)
-AC_MSG_CHECKING(for ISO C99 varargs macros in C)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
-int a(int p1, int p2, int p3);
-#define call_a(...) a(1,__VA_ARGS__)
-call_a(2,3);
-]])],
-[dbus_have_iso_c_varargs=yes],
-[dbus_have_iso_c_varargs=no])
-AC_MSG_RESULT($dbus_have_iso_c_varargs)
-
-AC_MSG_CHECKING(for GNUC varargs macros)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[
-int a(int p1, int p2, int p3);
-#define call_a(params...) a(1,params)
-call_a(2,3);
-]])],
-[dbus_have_gnuc_varargs=yes],
-[dbus_have_gnuc_varargs=no])
-AC_MSG_RESULT($dbus_have_gnuc_varargs)
-
-dnl Output varargs tests
-if test x$dbus_have_iso_c_varargs = xyes; then
- AC_DEFINE(HAVE_ISO_VARARGS,1,[Have ISO C99 varargs macros])
-fi
-if test x$dbus_have_gnuc_varargs = xyes; then
- AC_DEFINE(HAVE_GNUC_VARARGS,1,[Have GNU-style varargs macros])
-fi
-
dnl Check for various credentials.
AC_MSG_CHECKING(for struct cmsgcred)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[