summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-12-05 14:09:00 +0000
committerSimon McVittie <smcv@collabora.com>2018-12-05 14:09:00 +0000
commita59eb6e944b2dd12f810ae85fd926d19cf7bea08 (patch)
tree5b739e1361a1755c0269e728342ce132c40c5b7a /configure.ac
parent9d721e57edce87a94e6573bbe4e76f28b53bdbd3 (diff)
parent1191262f5ebb881f9a07862f0b7b9176c502edc1 (diff)
downloaddbus-a59eb6e944b2dd12f810ae85fd926d19cf7bea08.tar.gz
Merge branch 'unpythonize' into 'master'
Translate Python-based tests to C See merge request dbus/dbus!37 Reviewed-by: pwithnall
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index 47bde94a..2d78b7cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,7 +247,7 @@ AC_ARG_ENABLE([tests],
[
if test "x$enableval" = xyes; then
AC_MSG_NOTICE([Full test coverage was requested with --enable-tests=yes])
- AC_MSG_NOTICE([This has many dependencies (GLib, Python etc.)])
+ AC_MSG_NOTICE([This requires GLib])
fi
enable_embedded_tests=$enableval
enable_modular_tests=$enableval
@@ -313,22 +313,6 @@ AC_ARG_ENABLE([installed-tests],
AM_CONDITIONAL([DBUS_ENABLE_INSTALLED_TESTS],
[test "x$enable_installed_tests" = xyes])
-if test "x$enable_tests" = xyes; then
- # full test coverage is required, Python is a hard dependency
- AC_MSG_NOTICE([Full test coverage (--enable-tests=yes) requires Python, dbus-python, pygi])
- AM_PATH_PYTHON([2.6])
- AC_MSG_CHECKING([for Python modules for full test coverage])
- if "$PYTHON" -c "import dbus, gi.repository.GObject, dbus.mainloop.glib"; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
- AC_MSG_ERROR([cannot import dbus, gi.repository.GObject, dbus.mainloop.glib Python modules])
- fi
-else
- # --enable-tests not given: do not abort if Python is missing
- AM_PATH_PYTHON([2.6], [], [:])
-fi
-
if test x$enable_verbose_mode = xyes; then
AC_DEFINE(DBUS_ENABLE_VERBOSE_MODE,1,[Support a verbose mode])
fi