summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-03-08 19:14:38 +0000
committerSimon McVittie <smcv@collabora.com>2018-03-09 12:26:08 +0000
commit83549e28ec5bb07e7c6d913cad4356d6bef5b0ae (patch)
tree7cf30a4fa866de323d4673ad14ff4124a3d0eb3f /configure.ac
parentdc15de1f7b3525babd723151927fc739d7f8a249 (diff)
downloaddbus-83549e28ec5bb07e7c6d913cad4356d6bef5b0ae.tar.gz
Windows: Target Windows Vista or higher
This will give us the RFC-2553 inet_ntop() interface. Windows Vista extended security support ended in 2017, but we don't actually need anything from versions newer than Vista yet. Loosely based on part of a patch by Ralf Habacker. Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Ralf Habacker <ralf.habacker@freenet.de> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=61922
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index efed4f0a..2a4fce85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,6 +156,9 @@ if test "$dbus_win" = yes; then
if test "$dbus_wince" = yes; then
AC_DEFINE(DBUS_WINCE,1,[Defined if we run on a W32 CE API based system])
AC_DEFINE(_WIN32_WCE, 0x0502, [Defined to get newer W32 CE APIs])
+ else
+ AC_DEFINE([_WIN32_WINNT], [0x0600],
+ [Define to the minimum supported Windows version (0x0600 is Vista)])
fi
else
AC_DEFINE(DBUS_UNIX,1,[Defined if we run on a Unix-based system])