summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2019-03-13 10:13:09 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2019-03-13 10:13:09 +0100
commit760e30ec03d21d378890ff87eed91a81f040ba98 (patch)
tree1145e35c95de7266811ae0c56994647558d9bd6a /configure.ac
parent11eb34d86b513f5ffd4fb0e5cb5f31e6d2f92a49 (diff)
downloaddbus-760e30ec03d21d378890ff87eed91a81f040ba98.tar.gz
Do not let doxygen build man pages on Windows
This fixes an issue on gitlab CI not been able to create man page output dir. Also man pages does not make sense on Windows.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b07e0c9..83b3eb72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1269,6 +1269,13 @@ if test x$enable_doxygen_docs = xyes; then
fi
fi
+if test x$dbus_win = xno; then
+ DBUS_GENERATE_MAN=YES
+else
+ DBUS_GENERATE_MAN=NO
+fi
+AC_SUBST([DBUS_GENERATE_MAN])
+
AM_CONDITIONAL(DBUS_DOXYGEN_DOCS_ENABLED, test x$enable_doxygen_docs = xyes)
AC_MSG_RESULT($enable_doxygen_docs)