summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2017-10-18 23:19:52 +0200
committerRalf Habacker <ralf.habacker@freenet.de>2018-03-12 19:47:28 +0100
commit39efd6ebdd1d476ea0a529244653f114ce01c156 (patch)
treec7d738dd199c9e90828a70bceb98bbf6ac00ea83 /configure.ac
parent64a1d59b3dfb847fa5d1d51a2ff2c68737d54c53 (diff)
downloaddbus-39efd6ebdd1d476ea0a529244653f114ce01c156.tar.gz
Add version info to installed executables for cmake build system on Windows
Signed-off-by: Ralf Habacker <ralf.habacker@freenet.de> Reviewed-by: Simon McVittie <smcv@collabora.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=103387
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2a4fce85..0f94d439 100644
--- a/configure.ac
+++ b/configure.ac
@@ -151,6 +151,13 @@ if test "$dbus_win" = yes; then
# Assume DBUS_VERSION is always three numbers
BUILD_FILEVERSION=`echo "$DBUS_VERSION" | sed -e 's/\./,/g'`,0
AC_SUBST(BUILD_FILEVERSION)
+ # In the CMake build system we generate multiple files, versioninfo-*.rc, with a
+ # different "internal name" and "original filename", for embedding in multiple
+ # executables. In the Autotools build system, we currently only generate
+ # versioninfo.rc and embed it in libdbus-1-${SOVERSION}.dll.
+ AC_SUBST([DBUS_VER_INTERNAL_NAME], [libdbus-1-${SOVERSION}])
+ AC_SUBST([DBUS_VER_ORIGINAL_NAME], [libdbus-1-${SOVERSION}.dll])
+ AC_SUBST([DBUS_VER_FILE_TYPE], [VFT_DLL])
AS_IF([test -z "$RC"],
[AC_MSG_ERROR([An implementation of windres is required])])
if test "$dbus_wince" = yes; then