summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-08-29 14:08:40 +0100
committerSimon McVittie <smcv@collabora.com>2018-08-30 17:44:20 +0100
commit29b2b55c39f57e9cb5b3f5743e771cbf29fb5220 (patch)
tree1a62f72ee2b7563b32560a2d7b2c4bcec01d2d6e /configure.ac
parent7cae8b427c95a0e30ff7929b61d913409e7a74c6 (diff)
downloaddbus-29b2b55c39f57e9cb5b3f5743e771cbf29fb5220.tar.gz
build: Make --enable-relocation compatible with hard-coding directories
Open Build Service RPMs for mingw32-dbus-1 hard-code all the directories to make everything explicit, notably: --prefix=/usr/i686-w64-mingw32/sys-root/mingw --exec-prefix=/usr/i686-w64-mingw32/sys-root/mingw ... --libdir=/usr/i686-w64-mingw32/sys-root/mingw/lib Previously we didn't accept this as relocatable, but actually it's fine: ${prefix} is still equivalent to ${libdir}/pkgconfig/../.., so our relocation setup can work. Accept the result of expanding "${prefix}" as an acceptable value for --exec-prefix, and accept the results of expanding "${exec_prefix}/lib" etc. as acceptable values for --libdir. Note the use of single vs. double quotes here. A case statement that matches '${prefix}' tests for the literal string «${prefix}», whereas a case that matches "${prefix}" tests for the string that is the value of the variable named «prefix» that is set by the --prefix command-line argument. Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=107662
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f0d83589..36c63b1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1578,7 +1578,7 @@ AC_ARG_ENABLE([relocation],
can_relocate=yes
AS_CASE(["${exec_prefix}"],
- ['NONE'|'${prefix}'],
+ ['NONE'|'${prefix}'|"${prefix}"],
[:],
[*],
[
@@ -1589,7 +1589,7 @@ AS_CASE(["${exec_prefix}"],
])
AS_CASE(["${libdir}"],
- ['${prefix}/lib'|'${prefix}/lib64'|'${exec_prefix}/lib'|'${exec_prefix}/lib64'],
+ ['${prefix}/lib'|'${prefix}/lib64'|'${exec_prefix}/lib'|'${exec_prefix}/lib64'|"${prefix}/lib"|"${exec_prefix}/lib"|"${prefix}/lib64"|"${exec_prefix}/lib64"],
[:],
[*],
[