summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Tomanek <stefan.tomanek@wertarbyte.de>2010-11-07 16:54:49 +0100
committerDaniel Stenberg <daniel@haxx.se>2010-11-10 10:43:05 +0100
commitf1db21218b35b618f622deb94b6e5ab2c62bbd17 (patch)
tree54673bd388300203faf724cf8034b2ce278014f0 /configure.ac
parent892cacef43b4871d8ce50b2e61a143ede1b3083e (diff)
downloadcurl-f1db21218b35b618f622deb94b6e5ab2c62bbd17.tar.gz
write extended attributes by using fsetxattr
Instead of reopening the downloaded file, fsetxattr uses the (already open) file descriptor to attach extended attributes. This makes the procedure more robust against errors caused by moved or deleted files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 893e53c0c..cc2b6f4d2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2349,7 +2349,7 @@ CURL_CHECK_FUNC_LOCALTIME_R
CURL_CHECK_FUNC_MEMRCHR
CURL_CHECK_FUNC_POLL
CURL_CHECK_FUNC_SETSOCKOPT
-CURL_CHECK_FUNC_SETXATTR
+CURL_CHECK_FUNC_FSETXATTR
CURL_CHECK_FUNC_SIGACTION
CURL_CHECK_FUNC_SIGINTERRUPT
CURL_CHECK_FUNC_SIGNAL