summaryrefslogtreecommitdiff
path: root/contrib/session-helper/meson.build
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2017-08-14 19:54:39 +0100
committerRichard Hughes <richard@hughsie.com>2017-08-14 19:54:41 +0100
commit1c41dd484ac13715b37239991f2e0a5defd6a9ea (patch)
tree05c3df4b4337256aebc9a8a6ed583b41c9e3b1ee /contrib/session-helper/meson.build
parent98cf67bf3ffe2e6ccb629e3bcaf9a6b15dfd79ed (diff)
downloadcolord-wip/hughsie/no-systemd.tar.gz
Add the meson -Denable-systemd=false configure argumentwip/hughsie/no-systemd
Compiling with systemd is turned on by default, obviously. If you turn this configure option off, and colord breaks, you get to keep all the shards of broken glass. It's 100% untested, so caveat emptor.
Diffstat (limited to 'contrib/session-helper/meson.build')
-rw-r--r--contrib/session-helper/meson.build16
1 files changed, 9 insertions, 7 deletions
diff --git a/contrib/session-helper/meson.build b/contrib/session-helper/meson.build
index 6b6bae0..ffff770 100644
--- a/contrib/session-helper/meson.build
+++ b/contrib/session-helper/meson.build
@@ -15,13 +15,15 @@ con2.set('servicedir',
get_option('libexecdir')))
# replace @servicedir@
-configure_file(
- input : 'colord-session.service.in',
- output : 'colord-session.service',
- configuration : con2,
- install: true,
- install_dir: systemd.get_pkgconfig_variable('systemduserunitdir'),
-)
+if get_option('enable-systemd')
+ configure_file(
+ input : 'colord-session.service.in',
+ output : 'colord-session.service',
+ configuration : con2,
+ install: true,
+ install_dir: systemd.get_pkgconfig_variable('systemduserunitdir'),
+ )
+endif
# replace @servicedir@
configure_file(