summaryrefslogtreecommitdiff
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Ballman <aaron@aaronballman.com>2019-05-13 21:39:55 +0000
committerAaron Ballman <aaron@aaronballman.com>2019-05-13 21:39:55 +0000
commitdff959c18122df8e1df43a2f0f2835d16ac1e6dd (patch)
tree6b89bce66d30ee2d058e906da1cc8d9ac8a15dd2 /lib/AST/CMakeLists.txt
parent2d96fcd91c5a9cbd7da8c2118611a7dcf97f1b72 (diff)
downloadclang-dff959c18122df8e1df43a2f0f2835d16ac1e6dd.tar.gz
Introduce the ability to dump the AST to JSON.
This adds the -ast-dump=json cc1 flag (in addition to -ast-dump=default, which is the default if no dump format is specified), as well as some initial AST dumping functionality and tests. git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@360622 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index 570ca718ac..a7c50bec11 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -44,6 +44,7 @@ add_clang_library(clangAST
InheritViz.cpp
ItaniumCXXABI.cpp
ItaniumMangle.cpp
+ JSONNodeDumper.cpp
Mangle.cpp
MicrosoftCXXABI.cpp
MicrosoftMangle.cpp