summaryrefslogtreecommitdiff
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorJohannes Altmanninger <aclopte@gmail.com>2017-08-23 16:28:26 +0000
committerJohannes Altmanninger <aclopte@gmail.com>2017-08-23 16:28:26 +0000
commit60830325117d250680532611af3c73b087ee891b (patch)
tree333bb12b3a1f3f06f30016d88657630d124ad830 /lib/AST/CMakeLists.txt
parent4bf0c5df66b237c106fefeb146fff7c51ece8a7f (diff)
downloadclang-60830325117d250680532611af3c73b087ee891b.tar.gz
[analyzer] Make StmtDataCollector customizable
Summary: This moves the data collection macro calls for Stmt nodes to lib/AST/StmtDataCollectors.inc Users can subclass ConstStmtVisitor and include StmtDataCollectors.inc to define visitor methods for each Stmt subclass. This makes it also possible to customize the visit methods as exemplified in lib/Analysis/CloneDetection.cpp. Move helper methods for data collection to a new module, AST/DataCollection. Add data collection for DeclRefExpr, MemberExpr and some literals. Reviewers: arphaman, teemperor! Subscribers: mgorny, xazax.hun, cfe-commits Differential Revision: https://reviews.llvm.org/D36664 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@311569 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index ab9b591842..db771b5eb7 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -20,6 +20,7 @@ add_clang_library(clangAST
CommentLexer.cpp
CommentParser.cpp
CommentSema.cpp
+ DataCollection.cpp
Decl.cpp
DeclarationName.cpp
DeclBase.cpp