summaryrefslogtreecommitdiff
path: root/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
authorPuyan Lotfi <puyan@puyan.org>2019-06-19 20:51:35 +0000
committerPuyan Lotfi <puyan@puyan.org>2019-06-19 20:51:35 +0000
commit276f9e79a318281962cf8a42204d0fea74a31daa (patch)
treed20d14da1ccc32aaf9915d825c83156c84236d5f /lib/AST/CMakeLists.txt
parent529da857ce42fd45d73ec1386bec4c31662bde56 (diff)
downloadclang-276f9e79a318281962cf8a42204d0fea74a31daa.tar.gz
[clang][AST] ASTNameGenerator: A refactoring of CodegenNameGeneratorImpl (NFC).
This is a NFC refactor move of CodegenNameGeneratorImpl from clang::Index to clang:AST (and rename to ASTNameGenerator). The purpose is to make the highlevel mangling code more reusable inside of clang (say in places like clang FrontendAction). This does not affect anything in CodegenNameGenerator, except that CodegenNameGenerator will now use ASTNameGenerator (in AST). Differential Revision: https://reviews.llvm.org/D63535 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@363878 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/AST/CMakeLists.txt')
-rw-r--r--lib/AST/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/AST/CMakeLists.txt b/lib/AST/CMakeLists.txt
index a7c50bec11..64ad029cce 100644
--- a/lib/AST/CMakeLists.txt
+++ b/lib/AST/CMakeLists.txt
@@ -1,5 +1,6 @@
set(LLVM_LINK_COMPONENTS
BinaryFormat
+ Core
Support
)