BerkeleyDB Namespace

[image]

Berkeley DB .NET API Documentation
BerkeleyDB Namespace
Send Feedback

Classes

Class | Description
AckPolicy | The AckPolicy class specifies how master and client sites handle acknowledgment of replication messages which are necessary for "permanent" records. The current implementation requires all sites in a replication group to configure the same acknowledgement policy.
ActiveTransaction | The ActiveTransaction class describes a currently active transaction.
BackupOptions | Configuration parameters for hot backup.
BadSecondaryException | A secondary index has been corrupted. This is likely the result of an application operating on related databases without first associating them.
BaseCursor | The abstract base class from which all cursor classes inherit. Cursors may span threads, but only serially. The application must serialize access to the cursor handle.
BaseDatabase | The base class from which all database classes inherit.
BTreeCursor | A class for traversing the records of a BTreeDatabase
BTreeDatabase | A class representing a BTreeDatabase. The Btree format is a representation of a sorted, balanced tree structure.
BTreeDatabaseConfig | A class representing configuration parameters for BTreeDatabase
BTreeStats | Statistical information about a BTreeDatabase
ByteOrder | A class to represent the database byte order.
CacheInfo | A class to represent information about the Berkeley DB cache
CachePriority | A class to represent cache priority for database pages
CompactConfig | A class to represent configuration settings for Compact(CompactConfig) and Compact(CompactConfig).
CompactData | A class for representing compact operation statistics
Cursor | A class representing database cursors, which allows for traversal of database records.
CursorConfig | A class representing configuration parameters for Cursor
Database | A class representing a Berkeley DB database, a base class for access method specific classes.
DatabaseConfig | A class representing configuration parameters for Database
DatabaseEntry | A class representing a key or data item in a Berkeley DB database
DatabaseEnvironment | A class representing a Berkeley DB database environment - a collection including support for some or all of caching, locking, logging and transaction subsystems, as well as databases and log files.
DatabaseEnvironmentConfig | A class representing configuration parameters for DatabaseEnvironment
DatabaseException | Represents errors that occur during Berkley DB operations.
DatabaseStream | A class representing a database stream, which allows streaming access to blobs.
DatabaseStreamConfig | A class representing configuration parameters for DatabaseStream
DatabaseType | A class representing the supported Berkeley DB access methods.
DbChannel | A class representing a channel in Berkeley DB HA replication manager.
DbSite | A class representing a site in Berkeley DB HA replication manager.
DbSiteConfig | Configuration properties for a site in replication manager.
DbThreadID | A class representing a unique identifier for a thread of control in a Berkeley DB application.
DeadlockException | When multiple threads of control are modifying the database, there is normally the potential for deadlock. In Berkeley DB, deadlock is signified by a DeadlockException thrown from the Berkeley DB function. Whenever a Berkeley DB function throws a DeadlockException, the enclosing transaction should be aborted.
DeadlockPolicy | A class to represent what lock request(s) should be rejected during deadlock resolution.
ErrorCodes | Constants representing error codes returned by the Berkeley DB library.
ForeignConflictException |
FullLogBufferException | In-memory logs are configured and no more log buffer space is available.
HashCursor | A class for traversing the records of a HashDatabase
HashDatabase | A class representing a HashDatabase. The Hash format is an extensible, dynamic hashing scheme.
HashDatabaseConfig | A class representing configuration parameters for HashDatabase
HashStats | Statistical information about a HashDatabase
HeapDatabase | A class representing a HeapDatabase.
HeapDatabaseConfig | A class representing configuration parameters for HeapDatabase
HeapFullException | An attempt was made to add or update a record in a HeapDatabase. However, the size of the database was constrained using MaxSize(UInt32, UInt32), and that limit has been reached.
HeapRecordId | Content used for the key in a Heap database record. Berkeley DB creates this value for you when you create a record in a Heap database. You should never create this structure yourself; Berkeley DB must create it for you. This structure is returned in the key DatabaseEntry parameter of the method that you use to add a record to the Heap database.
HeapStats | Statistical information about a QueueDatabase
JoinCursor | A class representing a join cursor, for use in performing equality or natural joins on secondary indices. For information on how to organize your data to use this functionality, see Equality join in the Programmer's Reference Guide.
KeyEmptyException | The requested key/data pair logically exists but was never explicitly created by the application, or that the requested key/data pair was deleted and never re-created. In addition, the Queue access method throws a KeyEmptyException for records that were created as part of a transaction that was later aborted and never re-created.
KeyExistException | A key/data pair was inserted into the database using PutNoOverwrite(MultipleKeyDatabaseEntry) and the key already exists in the database, or using PutNoDuplicate(DatabaseEntry, DatabaseEntry) or PutNoDuplicate(DatabaseEntry, DatabaseEntry) and the key/data pair already exists in the database.
KeyRange | A class representing an estimate of the proportion of keys that are less than, equal to, and greater than a given key. Values are in the range of 0 to 1; for example, if the field less is 0.05, 5% of the keys in the database are less than the key parameter. The value for equal is zero if there is no matching key, and is non-zero otherwise.
LeaseExpiredException | The site's replication master lease has expired.
LockingConfig | A class representing configuration parameters for a DatabaseEnvironment's locking subsystem.
LockingInfo | A class representing the locking options for Berkeley DB operations.
LockNotGrantedException | If TimeNotGranted is true, database calls timing out based on lock or transaction timeout values throw a LockNotGrantedException, instead of a DeadlockException.
LockStats | Statistical information about the locking subsystem
LogConfig | A class representing configuration parameters for a DatabaseEnvironment's logging subsystem.
LogStats | Statistical information about the logging subsystem
LogVerifyConfig | A class representing configuration parameters for log verification.
LSN | A log sequence number, which specifies a unique location in a log file.
MetaCheckSumFailException | A checksum mismatch was detected on a database metadata page. Either the database is corrupted or the file is not a Berkeley DB database file.
MPoolConfig | A class representing configuration parameters for a DatabaseEnvironment's memory pool subsystem.
MPoolFileStats | Statistical information about a file in the memory pool
MPoolStats | Statistical information about the memory pool subsystem
MultipleDatabaseEntry | A class providing access to multiple DatabaseEntry objects.
MultipleKeyDatabaseEntry | A class providing access to multiple key/data pairs.
MutexConfig | A class representing configuration parameters for a DatabaseEnvironment's mutex subsystem.
MutexStats | Statistical information about the mutex subsystem
NotFoundException | The requested key/data pair did not exist in the database or that start-of- or end-of-file has been reached by a cursor.
OldVersionException | This version of Berkeley DB is unable to upgrade a given database.
PageNotFoundException |
PreparedTransaction | A class representing a transaction that must be resolved by the application following Recover(Int32, Boolean).
QueueDatabase | A class representing a QueueDatabase. The Queue format supports fast access to fixed-length records accessed sequentially or by logical record number.
QueueDatabaseConfig | A class representing configuration parameters for QueueDatabase
QueueStats | Statistical information about a QueueDatabase
RecnoCursor | A class for traversing the records of a RecnoDatabase
RecnoDatabase | A class representing a RecnoDatabase. The Recno format supports fixed- or variable-length records, accessed sequentially or by logical record number, and optionally backed by a flat text file.
RecnoDatabaseConfig | A class representing configuration parameters for RecnoDatabase
RecnoStats | Statistical information about a RecnoDatabase
ReplicationConfig | A class representing configuration parameters for a DatabaseEnvironment's replication subsystem.
ReplicationHostAddress | A class representing the address of a replication site used by Berkeley DB HA.
ReplicationStats | Statistical information about the replication subsystem
RepMgrSite | A class representing a replication site used by Replication Manager.
RepMgrStats | Statistical information about the Replication Manager
RepProcMsgResult | A class representing the return value of RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
RunRecoveryException | Berkeley DB has encountered an error it considers fatal to an entire environment. Once a RunRecoveryException has been thrown by any interface, it is returned from all subsequent Berkeley DB calls made by any threads of control participating in the environment.
SecondaryBTreeDatabase | A class representing a SecondaryBTreeDatabase. The Btree format is a representation of a sorted, balanced tree structure.
SecondaryBTreeDatabaseConfig | A class representing configuration parameters for SecondaryBTreeDatabase
SecondaryCursor | A class representing database cursors over secondary indexes, which allow for traversal of database records.
SecondaryDatabase | A class representing a secondary Berkeley DB database, a base class for access method specific classes.
SecondaryDatabaseConfig | A class representing configuration parameters for SecondaryDatabase
SecondaryHashDatabase | A class representing a SecondaryHashDatabase. The Hash format is an extensible, dynamic hashing scheme.
SecondaryHashDatabaseConfig | A class representing configuration parameters for SecondaryHashDatabase
SecondaryQueueDatabase | A class representing a SecondaryQueueDatabase. The Queue format supports fast access to fixed-length records accessed sequentially or by logical record number.
SecondaryQueueDatabaseConfig | A class representing configuration parameters for SecondaryQueueDatabase
SecondaryRecnoDatabase | A class representing a RecnoDatabase. The Recno format supports fixed- or variable-length records, accessed sequentially or by logical record number, and optionally backed by a flat text file.
SecondaryRecnoDatabaseConfig | A class representing configuration parameters for RecnoDatabase
Sequence | A class that provides an arbitrary number of persistent objects that return an increasing or decreasing sequence of integers.
SequenceConfig | Configuration properties for a Sequence
SequenceStats | Statistical information about a Sequence
Transaction | A class representing Berkeley DB transactions
TransactionConfig | A class representing configuration parameters for a Transaction.
TransactionStats | Statistical information about the transaction subsystem.
VerboseMessages | Enable specific additional informational and debugging messages.
VerificationException | Thrown by Verify(String, DatabaseConfig) if a database is corrupted, and by Salvage(String, DatabaseConfig) if all key/data pairs in the file may not have been successfully output.
VersionMismatchException | The version of the Berkeley DB library does not match the version that created the database environment.

Interfaces

Interface | Description
IBackup | An interface that can optionally be used to override the default behavior performed by the Backup(String, BackupOptions) and BackupDatabase(String, String, Boolean) methods. Implementation of this interface is required if the DatabaseEnvironment.backup or DatabaseEnvironment.backupDatabase target parameter is null. You configure the environment with this handler via BackupHandler.

Delegates

Delegate | Description
AppendRecordDelegate | A function to call after the record number has been selected but before the data has been stored into the database.
BTreeCompressDelegate | A function to store a compressed key/data pair into a supplied buffer.
BTreeDecompressDelegate | A function to decompress a key/data pair from a supplied buffer.
DatabaseFeedbackDelegate | The application-specified feedback function called to report the operation progress of Berkeley DB.
EntryComparisonDelegate | An application-specified comparison function.
EntryPrefixComparisonDelegate | An application-specified prefix comparison function.
EnvironmentFeedbackDelegate | The application-specified feedback function called to report Berkeley DB operation progress.
ErrorFeedbackDelegate | The application-specified error reporting function.
EventNotifyDelegate | The application's event notification function.
ForeignKeyNullifyDelegate |
HashFunctionDelegate | The application-specified hash function.
MessageDispatchDelegate | Application-specific function used to handle messages sent over Replication Manager message channels.
MessageFeedbackDelegate | The application-specified reporting function.
PartitionDelegate | An application-specified partitioning function.
ReplicationTransportDelegate | The function used to transmit data using the replication application's communication infrastructure.
ReplicationViewDelegate | Application-specific function used by a replication view to determine whether a database file is replicated to the local site.
SecondaryKeyGenDelegate | The function that creates the set of secondary keys corresponding to a given primary key and data pair. To create multiple secondary keys, return a MultipleDatabaseEntry.
SetThreadIDDelegate | A function which returns a unique identifier pair for a thread of control in a Berkeley DB application.
SetThreadNameDelegate | A function which returns an identifier pair for a thread of control formatted for display.
ThreadIsAliveDelegate | A function which returns whether the thread of control, identified by info, is still running.

Enumerations

Enumeration | Description
CreatePolicy | The policy for how to handle database creation.
Cursor..::.InsertLocation | Specifies where to place duplicate data elements of the key to which the cursor refers.
Database..::.VerifyOperation | Specifies the type of verification to perform
DatabaseFeedbackEvent | Specifies the database operation whose progress is being reported
DuplicatesPolicy | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
EncryptionAlgorithm | Specifies an algorithm used for encryption and decryption
EnvironmentFeedbackEvent | Specifies the environment operation whose progress is being reported
EnvironmentID | Special environment IDs.
ForeignKeyDeleteAction | Specifies the action to take when deleting a foreign key
Isolation | Specify the degree of isolation for transactional operations
NotificationEvent | Specify a Berkeley DB event
RepProcMsgResult..::.ProcMsgResult | The result of processing an incoming replication message.
TransactionAppliedStatus | Status values from transaction application checking operations.
TransactionConfig..::.LogFlush | Specifies the log flushing behavior on transaction commit
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


AckPolicy Class

[image]

Berkeley DB .NET API Documentation
AckPolicy Class
Members See Also Send Feedback
The AckPolicy class specifies how master and client sites handle acknowledgment of replication messages which are necessary for "permanent" records. The current implementation requires all sites in a replication group to configure the same acknowledgement policy.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class AckPolicy
Visual Basic (Declaration)
Public Class AckPolicy
Visual C++
public ref class AckPolicy

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.AckPolicy

See Also

AckPolicy Members
BerkeleyDB Namespace


AckPolicy Members

[image] [image]

Berkeley DB .NET API Documentation
AckPolicy Members
AckPolicy Class Methods Fields See Also Send Feedback

The AckPolicy type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
ALL | The master should wait until all replication clients have acknowledged each permanent replication message.
ALL_AVAILABLE | The master should wait until all currently connected replication clients have acknowledged each permanent replication message.
ALL_PEERS | The master should wait until all electable peers have acknowledged each permanent replication message (where "electable peer" means a client capable of being subsequently elected master of the replication group).
NONE | The master should not wait for any client replication message acknowledgments.
ONE | The master should wait until at least one client site has acknowledged each permanent replication message.
ONE_PEER | The master should wait until at least one electable peer has acknowledged each permanent replication message (where "electable peer" means a client capable of being subsequently elected master of the replication group).
QUORUM | The master should wait until it has received acknowledgements from the minimum number of electable peers sufficient to ensure that the effect of the permanent record remains durable if an election is held (where "electable peer" means a client capable of being subsequently elected master of the replication group). This is the default acknowledgement policy.

See Also

AckPolicy Class


AckPolicy Fields

[image] [image]

Berkeley DB .NET API Documentation
AckPolicy Fields
AckPolicy Class See Also Send Feedback

The AckPolicy type exposes the following members.

Fields

Name | Description
ALL | The master should wait until all replication clients have acknowledged each permanent replication message.
ALL_AVAILABLE | The master should wait until all currently connected replication clients have acknowledged each permanent replication message.
ALL_PEERS | The master should wait until all electable peers have acknowledged each permanent replication message (where "electable peer" means a client capable of being subsequently elected master of the replication group).
NONE | The master should not wait for any client replication message acknowledgments.
ONE | The master should wait until at least one client site has acknowledged each permanent replication message.
ONE_PEER | The master should wait until at least one electable peer has acknowledged each permanent replication message (where "electable peer" means a client capable of being subsequently elected master of the replication group).
QUORUM | The master should wait until it has received acknowledgements from the minimum number of electable peers sufficient to ensure that the effect of the permanent record remains durable if an election is held (where "electable peer" means a client capable of being subsequently elected master of the replication group). This is the default acknowledgement policy.

See Also

AckPolicy Class


ALL Field

[image]

Berkeley DB .NET API Documentation
AckPolicy..::.ALL Field
AckPolicy Class See Also Send Feedback
The master should wait until all replication clients have acknowledged each permanent replication message.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static AckPolicy ALL
Visual Basic (Declaration)
Public Shared ALL As AckPolicy
Visual C++
public:
static AckPolicy^ ALL

See Also

AckPolicy Class


ALL_AVAILABLE Field

[image]

Berkeley DB .NET API Documentation
AckPolicy..::.ALL_AVAILABLE Field
AckPolicy Class See Also Send Feedback
The master should wait until all currently connected replication clients have acknowledged each permanent replication message.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static AckPolicy ALL_AVAILABLE
Visual Basic (Declaration)
Public Shared ALL_AVAILABLE As AckPolicy
Visual C++
public:
static AckPolicy^ ALL_AVAILABLE

See Also

AckPolicy Class


ALL_PEERS Field

[image]

Berkeley DB .NET API Documentation
AckPolicy..::.ALL_PEERS Field
AckPolicy Class See Also Send Feedback
The master should wait until all electable peers have acknowledged each permanent replication message (where "electable peer" means a client capable of being subsequently elected master of the replication group).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static AckPolicy ALL_PEERS
Visual Basic (Declaration)
Public Shared ALL_PEERS As AckPolicy
Visual C++
public:
static AckPolicy^ ALL_PEERS

See Also

AckPolicy Class


NONE Field

[image]

Berkeley DB .NET API Documentation
AckPolicy..::.NONE Field
AckPolicy Class See Also Send Feedback
The master should not wait for any client replication message acknowledgments.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static AckPolicy NONE
Visual Basic (Declaration)
Public Shared NONE As AckPolicy
Visual C++
public:
static AckPolicy^ NONE

See Also

AckPolicy Class


ONE Field

[image]

Berkeley DB .NET API Documentation
AckPolicy..::.ONE Field
AckPolicy Class See Also Send Feedback
The master should wait until at least one client site has acknowledged each permanent replication message.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static AckPolicy ONE
Visual Basic (Declaration)
Public Shared ONE As AckPolicy
Visual C++
public:
static AckPolicy^ ONE

See Also

AckPolicy Class


ONE_PEER Field

[image]

Berkeley DB .NET API Documentation
AckPolicy..::.ONE_PEER Field
AckPolicy Class See Also Send Feedback
The master should wait until at least one electable peer has acknowledged each permanent replication message (where "electable peer" means a client capable of being subsequently elected master of the replication group).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static AckPolicy ONE_PEER
Visual Basic (Declaration)
Public Shared ONE_PEER As AckPolicy
Visual C++
public:
static AckPolicy^ ONE_PEER

See Also

AckPolicy Class


QUORUM Field

[image]

Berkeley DB .NET API Documentation
AckPolicy..::.QUORUM Field
AckPolicy Class See Also Send Feedback
The master should wait until it has received acknowledgements from the minimum number of electable peers sufficient to ensure that the effect of the permanent record remains durable if an election is held (where "electable peer" means a client capable of being subsequently elected master of the replication group). This is the default acknowledgement policy.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static AckPolicy QUORUM
Visual Basic (Declaration)
Public Shared QUORUM As AckPolicy
Visual C++
public:
static AckPolicy^ QUORUM

See Also

AckPolicy Class


AckPolicy Methods

[image] [image]

Berkeley DB .NET API Documentation
AckPolicy Methods
AckPolicy Class See Also Send Feedback

The AckPolicy type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

AckPolicy Class


ActiveTransaction Class

[image]

Berkeley DB .NET API Documentation
ActiveTransaction Class
Members See Also Send Feedback
The ActiveTransaction class describes a currently active transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class ActiveTransaction
Visual Basic (Declaration)
Public Class ActiveTransaction
Visual C++
public ref class ActiveTransaction

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.ActiveTransaction

See Also

ActiveTransaction Members


ActiveTransaction Members

[image] [image]

Berkeley DB .NET API Documentation
ActiveTransaction Members
ActiveTransaction Class Methods Properties See Also Send Feedback

The ActiveTransaction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Begun | The current log sequence number when the transaction was begun.
BufferCopiesInCache | The number of MVCC buffer copies created by this transaction that remains in the cache.
GlobalID | If the transaction is a prepared transaction, return the transaction's Global ID. Otherwise, the GlobalID contents are undefined.
ID | The transaction ID of the transaction.
Name | If a name was specified for the transaction, return up to the first 50 bytes of that name.
ParentID | The transaction ID of the parent transaction (or 0, if no parent).
Priority | Assigned priority used when resolving deadlocks.
ProcessID | The process ID of the originator of the transaction.
SnapshotReads | The log sequence number of reads for snapshot transactions.
ThreadID | The thread of control ID of the originator of the transaction.

See Also

ActiveTransaction Class


ActiveTransaction Methods

[image] [image]

Berkeley DB .NET API Documentation
ActiveTransaction Methods
ActiveTransaction Class See Also Send Feedback

The ActiveTransaction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ActiveTransaction Class


ActiveTransaction Properties

[image] [image]

Berkeley DB .NET API Documentation
ActiveTransaction Properties
ActiveTransaction Class See Also Send Feedback

The ActiveTransaction type exposes the following members.

Properties

Name | Description
Begun | The current log sequence number when the transaction was begun.
BufferCopiesInCache | The number of MVCC buffer copies created by this transaction that remains in the cache.
GlobalID | If the transaction is a prepared transaction, return the transaction's Global ID. Otherwise, the GlobalID contents are undefined.
ID | The transaction ID of the transaction.
Name | If a name was specified for the transaction, return up to the first 50 bytes of that name.
ParentID | The transaction ID of the parent transaction (or 0, if no parent).
Priority | Assigned priority used when resolving deadlocks.
ProcessID | The process ID of the originator of the transaction.
SnapshotReads | The log sequence number of reads for snapshot transactions.
ThreadID | The thread of control ID of the originator of the transaction.

See Also

ActiveTransaction Class


Begun Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.Begun Property
ActiveTransaction Class See Also Send Feedback
The current log sequence number when the transaction was begun.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN Begun { get; }
Visual Basic (Declaration)
Public ReadOnly Property Begun As LSN
Visual C++
public:
property LSN^ Begun {
    LSN^ get ();
}

See Also

ActiveTransaction Class


BufferCopiesInCache Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.BufferCopiesInCache Property
ActiveTransaction Class See Also Send Feedback
The number of MVCC buffer copies created by this transaction that remains in the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BufferCopiesInCache { get; }
Visual Basic (Declaration)
Public ReadOnly Property BufferCopiesInCache As UInteger
Visual C++
public:
property unsigned int BufferCopiesInCache {
    unsigned int get ();
}

See Also

ActiveTransaction Class


GlobalID Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.GlobalID Property
ActiveTransaction Class See Also Send Feedback
If the transaction is a prepared transaction, return the transaction's Global ID. Otherwise, the GlobalID contents are undefined.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public byte[] GlobalID { get; }
Visual Basic (Declaration)
Public ReadOnly Property GlobalID As Byte()
Visual C++
public:
property array<unsigned char>^ GlobalID {
    array<unsigned char>^ get ();
}

See Also

ActiveTransaction Class


ID Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.ID Property
ActiveTransaction Class See Also Send Feedback
The transaction ID of the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ID As UInteger
Visual C++
public:
property unsigned int ID {
    unsigned int get ();
}

See Also

ActiveTransaction Class


Name Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.Name Property
ActiveTransaction Class See Also Send Feedback
If a name was specified for the transaction, return up to the first 50 bytes of that name.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

ActiveTransaction Class


ParentID Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.ParentID Property
ActiveTransaction Class See Also Send Feedback
The transaction ID of the parent transaction (or 0, if no parent).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ParentID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentID As UInteger
Visual C++
public:
property unsigned int ParentID {
    unsigned int get ();
}

See Also

ActiveTransaction Class


Priority Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.Priority Property
ActiveTransaction Class See Also Send Feedback
Assigned priority used when resolving deadlocks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Priority { get; }
Visual Basic (Declaration)
Public ReadOnly Property Priority As UInteger
Visual C++
public:
property unsigned int Priority {
    unsigned int get ();
}

See Also

ActiveTransaction Class


ProcessID Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.ProcessID Property
ActiveTransaction Class See Also Send Feedback
The process ID of the originator of the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int ProcessID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProcessID As Integer
Visual C++
public:
property int ProcessID {
    int get ();
}

See Also

ActiveTransaction Class


SnapshotReads Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.SnapshotReads Property
ActiveTransaction Class See Also Send Feedback
The log sequence number of reads for snapshot transactions.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN SnapshotReads { get; }
Visual Basic (Declaration)
Public ReadOnly Property SnapshotReads As LSN
Visual C++
public:
property LSN^ SnapshotReads {
    LSN^ get ();
}

See Also

ActiveTransaction Class


ThreadID Property

[image]

Berkeley DB .NET API Documentation
ActiveTransaction..::.ThreadID Property
ActiveTransaction Class See Also Send Feedback
The thread of control ID of the originator of the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ThreadID { get; }
Visual Basic (Declaration)
Public ReadOnly Property ThreadID As UInteger
Visual C++
public:
property unsigned int ThreadID {
    unsigned int get ();
}

See Also

ActiveTransaction Class


AppendRecordDelegate Delegate

[image]

Berkeley DB .NET API Documentation
AppendRecordDelegate Delegate
See Also Send Feedback
A function to call after the record number has been selected but before the data has been stored into the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate void AppendRecordDelegate(
    DatabaseEntry data,
    uint recno
)
Visual Basic (Declaration)
Public Delegate Sub AppendRecordDelegate ( _
    data As DatabaseEntry, _
    recno As UInteger _
)
Visual C++
public delegate void AppendRecordDelegate(
    DatabaseEntry^ data,
    unsigned int recno
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data to be stored.
recno
Type: System..::.UInt32
The generated record number.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


BackupOptions Class

[image]

Berkeley DB .NET API Documentation
BackupOptions Class
Members See Also Send Feedback
Configuration parameters for hot backup.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class BackupOptions
Visual Basic (Declaration)
Public Class BackupOptions
Visual C++
public ref class BackupOptions

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BackupOptions

See Also

BackupOptions Members


BackupOptions Members

[image] [image]

Berkeley DB .NET API Documentation
BackupOptions Members
BackupOptions Class Constructors Methods Fields See Also Send Feedback

The BackupOptions type exposes the following members.

Constructors

Name | Description
BackupOptions | Initializes a new instance of the BackupOptions class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Clean | If true, all files are removed from the target backup directory before the backup is performed.
Creation | Specify whether the target directory is created if it does not already exist.
Files | If true, all ordinary files that might exist in the environment or in the environment's subdirectories are backed up; otherwise, only files necessary for the proper operation of Berkeley DB are backed up.
NoLogs | If true, log files are not included in the backup. Instead, only *.db files are copied to the target directory.
SingleDir | If true, then regardless of the directory structure used by the source environment, place all backup files in the single target directory. Use this option if absolute path names to your environment directory and the files within that directory are required by your application.
Update | If true, perform an incremental back up, instead of a full backup. When this option is specified, only log files are copied to the target directory.

See Also

BackupOptions Class


BackupOptions Constructor

[image]

Berkeley DB .NET API Documentation
BackupOptions Constructor
BackupOptions Class See Also Send Feedback
Initializes a new instance of the BackupOptions class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BackupOptions()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BackupOptions()

See Also

BackupOptions Class


BackupOptions Fields

[image] [image]

Berkeley DB .NET API Documentation
BackupOptions Fields
BackupOptions Class See Also Send Feedback

The BackupOptions type exposes the following members.

Fields

Name | Description
Clean | If true, all files are removed from the target backup directory before the backup is performed.
Creation | Specify whether the target directory is created if it does not already exist.
Files | If true, all ordinary files that might exist in the environment or in the environment's subdirectories are backed up; otherwise, only files necessary for the proper operation of Berkeley DB are backed up.
NoLogs | If true, log files are not included in the backup. Instead, only *.db files are copied to the target directory.
SingleDir | If true, then regardless of the directory structure used by the source environment, place all backup files in the single target directory. Use this option if absolute path names to your environment directory and the files within that directory are required by your application.
Update | If true, perform an incremental back up, instead of a full backup. When this option is specified, only log files are copied to the target directory.

See Also

BackupOptions Class


Clean Field

[image]

Berkeley DB .NET API Documentation
BackupOptions..::.Clean Field
BackupOptions Class See Also Send Feedback
If true, all files are removed from the target backup directory before the backup is performed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Clean
Visual Basic (Declaration)
Public Clean As Boolean
Visual C++
public:
bool Clean

See Also

BackupOptions Class


Creation Field

[image]

Berkeley DB .NET API Documentation
BackupOptions..::.Creation Field
BackupOptions Class See Also Send Feedback
Specify whether the target directory is created if it does not already exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

See Also

BackupOptions Class


Files Field

[image]

Berkeley DB .NET API Documentation
BackupOptions..::.Files Field
BackupOptions Class See Also Send Feedback
If true, all ordinary files that might exist in the environment or in the environment's subdirectories are backed up; otherwise, only files necessary for the proper operation of Berkeley DB are backed up.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Files
Visual Basic (Declaration)
Public Files As Boolean
Visual C++
public:
bool Files

See Also

BackupOptions Class


NoLogs Field

[image]

Berkeley DB .NET API Documentation
BackupOptions..::.NoLogs Field
BackupOptions Class See Also Send Feedback
If true, log files are not included in the backup. Instead, only *.db files are copied to the target directory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoLogs
Visual Basic (Declaration)
Public NoLogs As Boolean
Visual C++
public:
bool NoLogs

See Also

BackupOptions Class


SingleDir Field

[image]

Berkeley DB .NET API Documentation
BackupOptions..::.SingleDir Field
BackupOptions Class See Also Send Feedback
If true, then regardless of the directory structure used by the source environment, place all backup files in the single target directory. Use this option if absolute path names to your environment directory and the files within that directory are required by your application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SingleDir
Visual Basic (Declaration)
Public SingleDir As Boolean
Visual C++
public:
bool SingleDir

See Also

BackupOptions Class


Update Field

[image]

Berkeley DB .NET API Documentation
BackupOptions..::.Update Field
BackupOptions Class See Also Send Feedback
If true, perform an incremental back up, instead of a full backup. When this option is specified, only log files are copied to the target directory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Update
Visual Basic (Declaration)
Public Update As Boolean
Visual C++
public:
bool Update

See Also

BackupOptions Class


BackupOptions Methods

[image] [image]

Berkeley DB .NET API Documentation
BackupOptions Methods
BackupOptions Class See Also Send Feedback

The BackupOptions type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BackupOptions Class


BadSecondaryException Class

[image]

Berkeley DB .NET API Documentation
BadSecondaryException Class
Members See Also Send Feedback
A secondary index has been corrupted. This is likely the result of an application operating on related databases without first associating them.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class BadSecondaryException : DatabaseException
Visual Basic (Declaration)
Public Class BadSecondaryException _
    Inherits DatabaseException
Visual C++
public ref class BadSecondaryException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.BadSecondaryException

See Also

BadSecondaryException Members


BadSecondaryException Members

[image] [image]

Berkeley DB .NET API Documentation
BadSecondaryException Members
BadSecondaryException Class Constructors Methods Fields Properties See Also Send Feedback

The BadSecondaryException type exposes the following members.

Constructors

Name | Description
BadSecondaryException | Initialize a new instance of the BadSecondaryException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BadSecondaryException Class


BadSecondaryException Constructor

[image]

Berkeley DB .NET API Documentation
BadSecondaryException Constructor
BadSecondaryException Class See Also Send Feedback
Initialize a new instance of the BadSecondaryException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BadSecondaryException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BadSecondaryException()

See Also

BadSecondaryException Class


BadSecondaryException Fields

[image] [image]

Berkeley DB .NET API Documentation
BadSecondaryException Fields
BadSecondaryException Class See Also Send Feedback

The BadSecondaryException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

BadSecondaryException Class


BadSecondaryException Methods

[image] [image]

Berkeley DB .NET API Documentation
BadSecondaryException Methods
BadSecondaryException Class See Also Send Feedback

The BadSecondaryException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BadSecondaryException Class


BadSecondaryException Properties

[image] [image]

Berkeley DB .NET API Documentation
BadSecondaryException Properties
BadSecondaryException Class See Also Send Feedback

The BadSecondaryException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BadSecondaryException Class


BaseCursor Class

[image]

Berkeley DB .NET API Documentation
BaseCursor Class
Members See Also Send Feedback

The abstract base class from which all cursor classes inherit.

Cursors may span threads, but only serially. The application must serialize access to the cursor handle.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public abstract class BaseCursor : IDisposable,
    IEnumerable<KeyValuePair<DatabaseEntry, DatabaseEntry>>, IEnumerable
Visual Basic (Declaration)
Public MustInherit Class BaseCursor _
    Implements IDisposable, IEnumerable(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry)),  _
    IEnumerable
Visual C++
public ref class BaseCursor abstract : IDisposable,
    IEnumerable<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>, IEnumerable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseCursor
BerkeleyDB..::.Cursor
BerkeleyDB..::.SecondaryCursor

See Also

BaseCursor Members


BaseCursor Members

[image] [image]

Berkeley DB .NET API Documentation
BaseCursor Members
BaseCursor Class Methods See Also Send Feedback

The BaseCursor type exposes the following members.

Methods

Name | Description
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again.
Compare | Compare this cursor's position to another's.
Count | Returns a count of the number of data items for the key to which the cursor refers.
Delete | Delete the key/data pair to which the cursor refers. When called on a SecondaryCursor, delete the key/data pair from the primary database and all secondary indices. The cursor position is unchanged after a delete, and subsequent calls to cursor functions expecting the cursor to refer to an existing key will fail.
Dispose | Release the resources held by this object, and close the cursor if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the cursor.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BaseCursor Class


BaseCursor Methods

[image] [image]

Berkeley DB .NET API Documentation
BaseCursor Methods
BaseCursor Class See Also Send Feedback

The BaseCursor type exposes the following members.

Methods

Name | Description
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again.
Compare | Compare this cursor's position to another's.
Count | Returns a count of the number of data items for the key to which the cursor refers.
Delete | Delete the key/data pair to which the cursor refers. When called on a SecondaryCursor, delete the key/data pair from the primary database and all secondary indices. The cursor position is unchanged after a delete, and subsequent calls to cursor functions expecting the cursor to refer to an existing key will fail.
Dispose | Release the resources held by this object, and close the cursor if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the cursor.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BaseCursor Class


Close Method

[image]

Berkeley DB .NET API Documentation
BaseCursor..::.Close Method
BaseCursor Class See Also Send Feedback

Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor.

It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed.

After Close has been called, regardless of its result, the object may not be used again.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

Exceptions

Exception | Condition
BerkeleyDB..::.DeadlockException |

See Also

BaseCursor Class


Compare Method

[image]

Berkeley DB .NET API Documentation
BaseCursor..::.Compare Method
BaseCursor Class See Also Send Feedback
Compare this cursor's position to another's.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Compare(
    Cursor compareTo
)
Visual Basic (Declaration)
Public Function Compare ( _
    compareTo As Cursor _
) As Boolean
Visual C++
public:
bool Compare(
    Cursor^ compareTo
)

Parameters

compareTo
Type: BerkeleyDB..::.Cursor
The cursor with which to compare.

Return Value

True if both cursors point to the same item, false otherwise.

See Also

BaseCursor Class


Count Method

[image]

Berkeley DB .NET API Documentation
BaseCursor..::.Count Method
BaseCursor Class See Also Send Feedback
Returns a count of the number of data items for the key to which the cursor refers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Count()
Visual Basic (Declaration)
Public Function Count As UInteger
Visual C++
public:
unsigned int Count()

Return Value

A count of the number of data items for the key to which the cursor refers.

See Also

BaseCursor Class


Delete Method

[image]

Berkeley DB .NET API Documentation
BaseCursor..::.Delete Method
BaseCursor Class See Also Send Feedback

Delete the key/data pair to which the cursor refers.

When called on a SecondaryCursor, delete the key/data pair from the primary database and all secondary indices.

The cursor position is unchanged after a delete, and subsequent calls to cursor functions expecting the cursor to refer to an existing key will fail.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

Exceptions

Exception | Condition
BerkeleyDB..::.KeyEmptyException | Thrown if the element has already been deleted.

See Also

BaseCursor Class


Dispose Method

[image]

Berkeley DB .NET API Documentation
BaseCursor..::.Dispose Method
BaseCursor Class See Also Send Feedback
Release the resources held by this object, and close the cursor if it is still open.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

BaseCursor Class


GetEnumerator Method

[image]

Berkeley DB .NET API Documentation
BaseCursor..::.GetEnumerator Method
BaseCursor Class See Also Send Feedback
Returns an enumerator that iterates through the cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public virtual IEnumerator<KeyValuePair<DatabaseEntry, DatabaseEntry>> GetEnumerator()
Visual Basic (Declaration)
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry))
Visual C++
public:
virtual IEnumerator<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>^ GetEnumerator()

Return Value

An enumerator for the cursor.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

BaseCursor Class


BaseDatabase Class

[image]

Berkeley DB .NET API Documentation
BaseDatabase Class
Members See Also Send Feedback
The base class from which all database classes inherit.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class BaseDatabase : IDisposable
Visual Basic (Declaration)
Public Class BaseDatabase _
    Implements IDisposable
Visual C++
public ref class BaseDatabase : IDisposable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.Database
BerkeleyDB..::.SecondaryDatabase

See Also

BaseDatabase Members


BaseDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase Members
BaseDatabase Class Methods Properties See Also Send Feedback

The BaseDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Remove Overloaded.

Applications should never remove databases with open DB handles, or in the case of removing a file, when any database in the file has an open handle. For example, some architectures do not permit the removal of files with open system handles. On these architectures, attempts to remove databases currently in use by any thread of control in the system may fail.

Remove should not be called if the remove is intended to be transactionally safe; RemoveDB(String, Boolean) should be used instead.

Rename Overloaded.

Applications should not rename databases that are currently in use. If an underlying file is being renamed and logging is currently enabled in the database environment, no database in the file should be open when Rename is called. In particular, some architectures do not permit renaming files with open handles. On these architectures, attempts to rename databases that are currently in use by any thread of control in the system may fail.

Rename should not be called if the rename is intended to be transactionally safe; RenameDB(String, String, Boolean) should be used instead.

Sync
Flush any cached information to disk.
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected.
CacheSize | The size of the shared memory buffer pool (the cache).
Creation | The CreatePolicy with which this database was opened.
DatabaseName | The name of this database, if it has one.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption.
Encrypted | If true, encrypt all data stored in the database.
Endianness | The database byte order.
ErrorFeedback | The mechanism for reporting detailed error messages to the application.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
Feedback | Monitor progress within long running operations.
FileName | The filename of this database, if it has one.
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space.
HasMultiple | If true, the object references a physical file supporting multiple databases.
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not.
messageFeedback | The mechanism for reporting detailed statistic messages to the application.
Msgfile | The message file.
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information.
NonDurableTxns | If true, Berkeley DB does not write log records for this database.
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database.
Pagesize | The database's current page size.
Priority | The cache priority for pages referenced by this object.
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files.
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data.
Transactional | If true, this database has been opened in a transactional mode.
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held.
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig).
UseMVCC | If true, the database was opened with support for multiversion concurrency control.

See Also

BaseDatabase Class


BaseDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase Methods
BaseDatabase Class See Also Send Feedback

The BaseDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Remove Overloaded.

Applications should never remove databases with open DB handles, or in the case of removing a file, when any database in the file has an open handle. For example, some architectures do not permit the removal of files with open system handles. On these architectures, attempts to remove databases currently in use by any thread of control in the system may fail.

Remove should not be called if the remove is intended to be transactionally safe; RemoveDB(String, Boolean) should be used instead.

Rename Overloaded.

Applications should not rename databases that are currently in use. If an underlying file is being renamed and logging is currently enabled in the database environment, no database in the file should be open when Rename is called. In particular, some architectures do not permit renaming files with open handles. On these architectures, attempts to rename databases that are currently in use by any thread of control in the system may fail.

Rename should not be called if the rename is intended to be transactionally safe; RenameDB(String, String, Boolean) should be used instead.

Sync
Flush any cached information to disk.
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

See Also

BaseDatabase Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Close Method
BaseDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files.
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files.

See Also

BaseDatabase Class
BaseDatabase Members


Close Method

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Close Method
BaseDatabase Class See Also Send Feedback
Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

BaseDatabase Class
Close Overload


Close Method (Boolean)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Close Method (Boolean)
BaseDatabase Class See Also Send Feedback
Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close(
    bool sync
)
Visual Basic (Declaration)
Public Sub Close ( _
    sync As Boolean _
)
Visual C++
public:
void Close(
    bool sync
)

Parameters

sync
Type: System..::.Boolean
If false, do not flush cached information to disk.

Remarks

The sync parameter is a dangerous option. It should be set to false only if the application is doing logging (with transactions) so that the database is recoverable after a system or application crash, or if the database is always generated from scratch after any system or application crash.

Flushing cached information to disk only minimizes the window of opportunity for corrupted data. Although unlikely, it is possible for database corruption to occur in the event of a system or application crash while writing data to the database. To ensure that database corruption never occurs, applications must either use transactions and logging with automatic recovery, or edit a copy of the database and then replace the corrupted database with the updated copy once all applications using the database have successfully called Close()()().

This parameter only works when the database has been opened using an environment.

See Also

BaseDatabase Class
Close Overload


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Cursor Method
BaseDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor.
Cursor(CursorConfig) | Create a database cursor with the given configuration.
Cursor(Transaction) | Create a transactionally protected database cursor.
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration.

See Also

BaseDatabase Class
BaseDatabase Members


Cursor Method

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Cursor Method
BaseDatabase Class See Also Send Feedback
Create a database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Cursor Cursor()
Visual Basic (Declaration)
Public Function Cursor As Cursor
Visual C++
public:
Cursor^ Cursor()

Return Value

A newly created cursor

See Also

BaseDatabase Class
Cursor Overload


Cursor Method (CursorConfig)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Cursor Method (CursorConfig)
BaseDatabase Class See Also Send Feedback
Create a database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Cursor Cursor(
    CursorConfig cfg
)
Visual Basic (Declaration)
Public Function Cursor ( _
    cfg As CursorConfig _
) As Cursor
Visual C++
public:
Cursor^ Cursor(
    CursorConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.

Return Value

A newly created cursor

See Also

BaseDatabase Class
Cursor Overload


Cursor Method (Transaction)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Cursor Method (Transaction)
BaseDatabase Class See Also Send Feedback
Create a transactionally protected database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Cursor Cursor(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Cursor ( _
    txn As Transaction _
) As Cursor
Visual C++
public:
Cursor^ Cursor(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

BaseDatabase Class
Cursor Overload


Cursor Method (CursorConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Cursor Method (CursorConfig, Transaction)
BaseDatabase Class See Also Send Feedback
Create a transactionally protected database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Cursor Cursor(
    CursorConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Cursor ( _
    cfg As CursorConfig, _
    txn As Transaction _
) As Cursor
Visual C++
public:
Cursor^ Cursor(
    CursorConfig^ cfg,
    Transaction^ txn
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.
txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

BaseDatabase Class
Cursor Overload


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Delete Method
BaseDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers.
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers.

See Also

BaseDatabase Class
BaseDatabase Members


Delete Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Delete Method (DatabaseEntry)
BaseDatabase Class See Also Send Feedback
Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Delete(
    DatabaseEntry key
)
Visual Basic (Declaration)
Public Sub Delete ( _
    key As DatabaseEntry _
)
Visual C++
public:
void Delete(
    DatabaseEntry^ key
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
Discard the key/data pair associated with key.

Remarks

When called on a secondary database, remove the key/data pair from the primary database and all secondary indices.

If the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Delete Overload


Delete Method (DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Delete Method (DatabaseEntry, Transaction)
BaseDatabase Class See Also Send Feedback
Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Delete(
    DatabaseEntry key,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub Delete ( _
    key As DatabaseEntry, _
    txn As Transaction _
)
Visual C++
public:
void Delete(
    DatabaseEntry^ key,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
Discard the key/data pairs associated with key.
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Remarks

When called on a secondary database, remove the key/data pairs from the primary database and all secondary indices.

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Delete Overload


Dispose Method

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Dispose Method
BaseDatabase Class See Also Send Feedback
Release the resources held by this object, and close the database if it is still open.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

BaseDatabase Class


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Exists Method
BaseDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database.
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database.
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database.

See Also

BaseDatabase Class
BaseDatabase Members


Exists Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Exists Method (DatabaseEntry)
BaseDatabase Class See Also Send Feedback
Check whether key appears in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Exists(
    DatabaseEntry key
)
Visual Basic (Declaration)
Public Function Exists ( _
    key As DatabaseEntry _
) As Boolean
Visual C++
public:
bool Exists(
    DatabaseEntry^ key
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for.

Return Value

True if key appears in the database, false otherwise.

Remarks

If the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Exists Overload


Exists Method (DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Exists Method (DatabaseEntry, Transaction)
BaseDatabase Class See Also Send Feedback
Check whether key appears in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Exists(
    DatabaseEntry key,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Exists ( _
    key As DatabaseEntry, _
    txn As Transaction _
) As Boolean
Visual C++
public:
bool Exists(
    DatabaseEntry^ key,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for.
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

True if key appears in the database, false otherwise.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Exists Overload


Exists Method (DatabaseEntry, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Exists Method (DatabaseEntry, Transaction, LockingInfo)
BaseDatabase Class See Also Send Feedback
Check whether key appears in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Exists(
    DatabaseEntry key,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Exists ( _
    key As DatabaseEntry, _
    txn As Transaction, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Exists(
    DatabaseEntry^ key,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for.
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if key appears in the database, false otherwise.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Exists Overload


Get Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Get Method
BaseDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key.
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned.
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key.
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned.
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key.
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned.

See Also

BaseDatabase Class
BaseDatabase Members


Get Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Get Method (DatabaseEntry)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    DatabaseEntry key
)
Visual Basic (Declaration)
Public Function Get ( _
    key As DatabaseEntry _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    DatabaseEntry^ key
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data.

Remarks

If the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Get Overload


Get Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Get Method (DatabaseEntry, DatabaseEntry)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function Get ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the partially retrieved bytes in the data.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Get Overload


Get Method (DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Get Method (DatabaseEntry, Transaction)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    DatabaseEntry key,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Get ( _
    key As DatabaseEntry, _
    txn As Transaction _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    DatabaseEntry^ key,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Get Overload


Get Method (DatabaseEntry, DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Get Method (DatabaseEntry, DatabaseEntry, Transaction)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    DatabaseEntry key,
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Get ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    txn As Transaction _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the partially retrieved bytes in the data.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Get Overload


Get Method (DatabaseEntry, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Get Method (DatabaseEntry, Transaction, LockingInfo)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    DatabaseEntry key,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Get ( _
    key As DatabaseEntry, _
    txn As Transaction, _
    info As LockingInfo _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    DatabaseEntry^ key,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Get Overload


Get Method (DatabaseEntry, DatabaseEntry, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Get Method (DatabaseEntry, DatabaseEntry, Transaction, LockingInfo)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    DatabaseEntry key,
    DatabaseEntry data,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Get ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    txn As Transaction, _
    info As LockingInfo _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the partially retrieved bytes in the data.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
Get Overload


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.GetBoth Method
BaseDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data.
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data.
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data.

See Also

BaseDatabase Class
BaseDatabase Members


GetBoth Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.GetBoth Method (DatabaseEntry, DatabaseEntry)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database which matches key and data.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> GetBoth(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function GetBoth ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> GetBoth(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The data to search for

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is data.

Remarks

If the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key and data are not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
GetBoth Overload


GetBoth Method (DatabaseEntry, DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.GetBoth Method (DatabaseEntry, DatabaseEntry, Transaction)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database which matches key and data.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> GetBoth(
    DatabaseEntry key,
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Function GetBoth ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    txn As Transaction _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> GetBoth(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The data to search for
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is data.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key and data are not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
GetBoth Overload


GetBoth Method (DatabaseEntry, DatabaseEntry, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.GetBoth Method (DatabaseEntry, DatabaseEntry, Transaction, LockingInfo)
BaseDatabase Class See Also Send Feedback
Retrieve a key/data pair from the database which matches key and data.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> GetBoth(
    DatabaseEntry key,
    DatabaseEntry data,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function GetBoth ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    txn As Transaction, _
    info As LockingInfo _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> GetBoth(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The data to search for
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is data.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key and data are not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

BaseDatabase Class
GetBoth Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.PrintFastStats Method
BaseDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database.
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database.

See Also

BaseDatabase Class
BaseDatabase Members


PrintFastStats Method

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.PrintFastStats Method
BaseDatabase Class See Also Send Feedback
Display the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintFastStats()
Visual Basic (Declaration)
Public Sub PrintFastStats
Visual C++
public:
void PrintFastStats()

Remarks

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

See Also

BaseDatabase Class
PrintFastStats Overload


PrintFastStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.PrintFastStats Method (Boolean)
BaseDatabase Class See Also Send Feedback
Display the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintFastStats(
    bool PrintAll
)
Visual Basic (Declaration)
Public Sub PrintFastStats ( _
    PrintAll As Boolean _
)
Visual C++
public:
void PrintFastStats(
    bool PrintAll
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.

Remarks

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

See Also

BaseDatabase Class
PrintFastStats Overload


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.PrintStats Method
BaseDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information.
PrintStats(Boolean) | Display the database statistical information.

See Also

BaseDatabase Class
BaseDatabase Members


PrintStats Method

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.PrintStats Method
BaseDatabase Class See Also Send Feedback
Display the database statistical information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintStats()
Visual Basic (Declaration)
Public Sub PrintStats
Visual C++
public:
void PrintStats()

See Also

BaseDatabase Class
PrintStats Overload


PrintStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.PrintStats Method (Boolean)
BaseDatabase Class See Also Send Feedback
Display the database statistical information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintStats(
    bool PrintAll
)
Visual Basic (Declaration)
Public Sub PrintStats ( _
    PrintAll As Boolean _
)
Visual C++
public:
void PrintStats(
    bool PrintAll
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.

See Also

BaseDatabase Class
PrintStats Overload


Remove Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Remove Method
BaseDatabase Class See Also Send Feedback

Applications should never remove databases with open DB handles, or in the case of removing a file, when any database in the file has an open handle. For example, some architectures do not permit the removal of files with open system handles. On these architectures, attempts to remove databases currently in use by any thread of control in the system may fail.

Remove should not be called if the remove is intended to be transactionally safe; RemoveDB(String, Boolean) should be used instead.

Overload List

Name | Description
Remove(String) | Remove the underlying file represented by Filename, incidentally removing all of the databases it contained.
Remove(String, DatabaseEnvironment) | Remove the underlying file represented by Filename, incidentally removing all of the databases it contained.
Remove(String, String) | Remove the database specified by Filename and DatabaseName.
Remove(String, String, DatabaseEnvironment) | Remove the database specified by Filename and DatabaseName.

See Also

BaseDatabase Class
BaseDatabase Members


Remove Method (String)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Remove Method (String)
BaseDatabase Class See Also Send Feedback
Remove the underlying file represented by Filename, incidentally removing all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Remove(
    string Filename
)
Visual Basic (Declaration)
Public Shared Sub Remove ( _
    Filename As String _
)
Visual C++
public:
static void Remove(
    String^ Filename
)

Parameters

Filename
Type: System..::.String
The file to remove

See Also

BaseDatabase Class
Remove Overload


Remove Method (String, DatabaseEnvironment)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Remove Method (String, DatabaseEnvironment)
BaseDatabase Class See Also Send Feedback
Remove the underlying file represented by Filename, incidentally removing all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Remove(
    string Filename,
    DatabaseEnvironment DbEnv
)
Visual Basic (Declaration)
Public Shared Sub Remove ( _
    Filename As String, _
    DbEnv As DatabaseEnvironment _
)
Visual C++
public:
static void Remove(
    String^ Filename,
    DatabaseEnvironment^ DbEnv
)

Parameters

Filename
Type: System..::.String
The file to remove
DbEnv
Type: BerkeleyDB..::.DatabaseEnvironment
The DatabaseEnvironment the database belongs to

See Also

BaseDatabase Class
Remove Overload


Remove Method (String, String)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Remove Method (String, String)
BaseDatabase Class See Also Send Feedback
Remove the database specified by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Remove(
    string Filename,
    string DatabaseName
)
Visual Basic (Declaration)
Public Shared Sub Remove ( _
    Filename As String, _
    DatabaseName As String _
)
Visual C++
public:
static void Remove(
    String^ Filename,
    String^ DatabaseName
)

Parameters

Filename
Type: System..::.String
The file to remove
DatabaseName
Type: System..::.String
The database to remove

See Also

BaseDatabase Class
Remove Overload


Remove Method (String, String, DatabaseEnvironment)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Remove Method (String, String, DatabaseEnvironment)
BaseDatabase Class See Also Send Feedback
Remove the database specified by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Remove(
    string Filename,
    string DatabaseName,
    DatabaseEnvironment DbEnv
)
Visual Basic (Declaration)
Public Shared Sub Remove ( _
    Filename As String, _
    DatabaseName As String, _
    DbEnv As DatabaseEnvironment _
)
Visual C++
public:
static void Remove(
    String^ Filename,
    String^ DatabaseName,
    DatabaseEnvironment^ DbEnv
)

Parameters

Filename
Type: System..::.String
The file to remove
DatabaseName
Type: System..::.String
The database to remove
DbEnv
Type: BerkeleyDB..::.DatabaseEnvironment
The DatabaseEnvironment the database belongs to

See Also

BaseDatabase Class
Remove Overload


Rename Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Rename Method
BaseDatabase Class See Also Send Feedback

Applications should not rename databases that are currently in use. If an underlying file is being renamed and logging is currently enabled in the database environment, no database in the file should be open when Rename is called. In particular, some architectures do not permit renaming files with open handles. On these architectures, attempts to rename databases that are currently in use by any thread of control in the system may fail.

Rename should not be called if the rename is intended to be transactionally safe; RenameDB(String, String, Boolean) should be used instead.

Overload List

Name | Description
Rename(String, String) | Rename the underlying file represented by Filename, incidentally renaming all of the databases it contained.
Rename(String, String, DatabaseEnvironment) | Rename the underlying file represented by Filename, incidentally renaming all of the databases it contained.
Rename(String, String, String) | Rename the database specified by Filename and DatabaseName.
Rename(String, String, String, DatabaseEnvironment) | Rename the database specified by Filename and DatabaseName.

See Also

BaseDatabase Class
BaseDatabase Members


Rename Method (String, String)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Rename Method (String, String)
BaseDatabase Class See Also Send Feedback
Rename the underlying file represented by Filename, incidentally renaming all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Rename(
    string Filename,
    string NewName
)
Visual Basic (Declaration)
Public Shared Sub Rename ( _
    Filename As String, _
    NewName As String _
)
Visual C++
public:
static void Rename(
    String^ Filename,
    String^ NewName
)

Parameters

Filename
Type: System..::.String
The file to rename
NewName
Type: System..::.String
The new filename

See Also

BaseDatabase Class
Rename Overload


Rename Method (String, String, DatabaseEnvironment)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Rename Method (String, String, DatabaseEnvironment)
BaseDatabase Class See Also Send Feedback
Rename the underlying file represented by Filename, incidentally renaming all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Rename(
    string Filename,
    string NewName,
    DatabaseEnvironment DbEnv
)
Visual Basic (Declaration)
Public Shared Sub Rename ( _
    Filename As String, _
    NewName As String, _
    DbEnv As DatabaseEnvironment _
)
Visual C++
public:
static void Rename(
    String^ Filename,
    String^ NewName,
    DatabaseEnvironment^ DbEnv
)

Parameters

Filename
Type: System..::.String
The file to rename
NewName
Type: System..::.String
The new filename
DbEnv
Type: BerkeleyDB..::.DatabaseEnvironment
The DatabaseEnvironment the database belongs to

See Also

BaseDatabase Class
Rename Overload


Rename Method (String, String, String)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Rename Method (String, String, String)
BaseDatabase Class See Also Send Feedback
Rename the database specified by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Rename(
    string Filename,
    string DatabaseName,
    string NewName
)
Visual Basic (Declaration)
Public Shared Sub Rename ( _
    Filename As String, _
    DatabaseName As String, _
    NewName As String _
)
Visual C++
public:
static void Rename(
    String^ Filename,
    String^ DatabaseName,
    String^ NewName
)

Parameters

Filename
Type: System..::.String
The file to rename
DatabaseName
Type: System..::.String
The database to rename
NewName
Type: System..::.String
The new database name

See Also

BaseDatabase Class
Rename Overload


Rename Method (String, String, String, DatabaseEnvironment)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Rename Method (String, String, String, DatabaseEnvironment)
BaseDatabase Class See Also Send Feedback
Rename the database specified by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Rename(
    string Filename,
    string DatabaseName,
    string NewName,
    DatabaseEnvironment DbEnv
)
Visual Basic (Declaration)
Public Shared Sub Rename ( _
    Filename As String, _
    DatabaseName As String, _
    NewName As String, _
    DbEnv As DatabaseEnvironment _
)
Visual C++
public:
static void Rename(
    String^ Filename,
    String^ DatabaseName,
    String^ NewName,
    DatabaseEnvironment^ DbEnv
)

Parameters

Filename
Type: System..::.String
The file to rename
DatabaseName
Type: System..::.String
The database to rename
NewName
Type: System..::.String
The new database name
DbEnv
Type: BerkeleyDB..::.DatabaseEnvironment
The DatabaseEnvironment the database belongs to

See Also

BaseDatabase Class
Rename Overload


Sync Method

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Sync Method
BaseDatabase Class See Also Send Feedback
Flush any cached information to disk.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Sync()
Visual Basic (Declaration)
Public Sub Sync
Visual C++
public:
void Sync()

Remarks

If the database is in-memory only, Sync has no effect and always succeeds.

Flushing cached information to disk only minimizes the window of opportunity for corrupted data. Although unlikely, it is possible for database corruption to occur in the event of a system or application crash while writing data to the database. To ensure that database corruption never occurs, applications must either use transactions and logging with automatic recovery, or edit a copy of the database and then replace the corrupted database with the updated copy once all applications using the database have successfully called Close()()().

See Also

BaseDatabase Class


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Truncate Method
BaseDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains.
Truncate(Transaction) | Empty the database, discarding all records it contains.

See Also

BaseDatabase Class
BaseDatabase Members


Truncate Method

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Truncate Method
BaseDatabase Class See Also Send Feedback
Empty the database, discarding all records it contains.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Truncate()
Visual Basic (Declaration)
Public Function Truncate As UInteger
Visual C++
public:
unsigned int Truncate()

Return Value

The number of records discarded from the database.

Remarks

If the operation occurs in a transactional database, the operation is implicitly transaction protected.

See Also

BaseDatabase Class
Truncate Overload


Truncate Method (Transaction)

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Truncate Method (Transaction)
BaseDatabase Class See Also Send Feedback
Empty the database, discarding all records it contains.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Truncate(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Truncate ( _
    txn As Transaction _
) As UInteger
Visual C++
public:
unsigned int Truncate(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The number of records discarded from the database.

Remarks

If txn is null and the operation occurs in a transactional database, the operation is implicitly transaction protected.

See Also

BaseDatabase Class
Truncate Overload


BaseDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
BaseDatabase Properties
BaseDatabase Class See Also Send Feedback

The BaseDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected.
CacheSize | The size of the shared memory buffer pool (the cache).
Creation | The CreatePolicy with which this database was opened.
DatabaseName | The name of this database, if it has one.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption.
Encrypted | If true, encrypt all data stored in the database.
Endianness | The database byte order.
ErrorFeedback | The mechanism for reporting detailed error messages to the application.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
Feedback | Monitor progress within long running operations.
FileName | The filename of this database, if it has one.
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space.
HasMultiple | If true, the object references a physical file supporting multiple databases.
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not.
messageFeedback | The mechanism for reporting detailed statistic messages to the application.
Msgfile | The message file.
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information.
NonDurableTxns | If true, Berkeley DB does not write log records for this database.
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database.
Pagesize | The database's current page size.
Priority | The cache priority for pages referenced by this object.
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files.
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data.
Transactional | If true, this database has been opened in a transactional mode.
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held.
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig).
UseMVCC | If true, the database was opened with support for multiversion concurrency control.

See Also

BaseDatabase Class


AutoCommit Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.AutoCommit Property
BaseDatabase Class See Also Send Feedback
If true, all database modification operations based on this object are transactionally protected.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool AutoCommit { get; }
Visual Basic (Declaration)
Public ReadOnly Property AutoCommit As Boolean
Visual C++
public:
property bool AutoCommit {
    bool get ();
}

See Also

BaseDatabase Class


CacheSize Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.CacheSize Property
BaseDatabase Class See Also Send Feedback
The size of the shared memory buffer pool (the cache).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CacheInfo CacheSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property CacheSize As CacheInfo
Visual C++
public:
property CacheInfo^ CacheSize {
    CacheInfo^ get ();
}

See Also

BaseDatabase Class


Creation Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Creation Property
BaseDatabase Class See Also Send Feedback
The CreatePolicy with which this database was opened.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation { get; }
Visual Basic (Declaration)
Public ReadOnly Property Creation As CreatePolicy
Visual C++
public:
property CreatePolicy Creation {
    CreatePolicy get ();
}

See Also

BaseDatabase Class


DatabaseName Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.DatabaseName Property
BaseDatabase Class See Also Send Feedback
The name of this database, if it has one.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string DatabaseName { get; }
Visual Basic (Declaration)
Public ReadOnly Property DatabaseName As String
Visual C++
public:
property String^ DatabaseName {
    String^ get ();
}

See Also

BaseDatabase Class


DoChecksum Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.DoChecksum Property
BaseDatabase Class See Also Send Feedback
If true, do checksum verification of pages read into the cache from the backing filestore.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool DoChecksum { get; }
Visual Basic (Declaration)
Public ReadOnly Property DoChecksum As Boolean
Visual C++
public:
property bool DoChecksum {
    bool get ();
}

Remarks

Berkeley DB uses the SHA1 Secure Hash Algorithm if encryption is configured and a general hash algorithm if it is not.

See Also

BaseDatabase Class


EncryptAlgorithm Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.EncryptAlgorithm Property
BaseDatabase Class See Also Send Feedback
The algorithm used by the Berkeley DB library to perform encryption and decryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EncryptionAlgorithm EncryptAlgorithm { get; }
Visual Basic (Declaration)
Public ReadOnly Property EncryptAlgorithm As EncryptionAlgorithm
Visual C++
public:
property EncryptionAlgorithm EncryptAlgorithm {
    EncryptionAlgorithm get ();
}

See Also

BaseDatabase Class


Encrypted Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Encrypted Property
BaseDatabase Class See Also Send Feedback
If true, encrypt all data stored in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Encrypted { get; }
Visual Basic (Declaration)
Public ReadOnly Property Encrypted As Boolean
Visual C++
public:
property bool Encrypted {
    bool get ();
}

See Also

BaseDatabase Class


Endianness Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Endianness Property
BaseDatabase Class See Also Send Feedback
The database byte order.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ByteOrder Endianness { get; }
Visual Basic (Declaration)
Public ReadOnly Property Endianness As ByteOrder
Visual C++
public:
property ByteOrder^ Endianness {
    ByteOrder^ get ();
}

See Also

BaseDatabase Class


ErrorFeedback Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.ErrorFeedback Property
BaseDatabase Class See Also Send Feedback
The mechanism for reporting detailed error messages to the application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ErrorFeedbackDelegate ErrorFeedback { get; set; }
Visual Basic (Declaration)
Public Property ErrorFeedback As ErrorFeedbackDelegate
Visual C++
public:
property ErrorFeedbackDelegate^ ErrorFeedback {
    ErrorFeedbackDelegate^ get ();
    void set (ErrorFeedbackDelegate^ value);
}

Remarks

When an error occurs in the Berkeley DB library, a DatabaseException, or subclass of DatabaseException, is thrown. In some cases the exception may be insufficient to completely describe the cause of the error, especially during initial application debugging.

In some cases, when an error occurs, Berkeley DB calls the given delegate with additional error information. It is up to the delegate to display the error message in an appropriate manner.

Setting ErrorFeedback to NULL resets the callback interface.

This error-logging enhancement does not slow performance or significantly increase application size, and may be run during normal operation as well as during application debugging.

For databases opened inside of a DatabaseEnvironment, setting ErrorFeedback affects the entire environment and is equivalent to setting DatabaseEnvironment.ErrorFeedback.

For databases not opened in an environment, setting ErrorFeedback configures operations performed using the specified object, instead of all operations performed on the underlying database.

See Also

BaseDatabase Class


ErrorPrefix Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.ErrorPrefix Property
BaseDatabase Class See Also Send Feedback
The prefix string that appears before error messages issued by Berkeley DB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string ErrorPrefix { get; set; }
Visual Basic (Declaration)
Public Property ErrorPrefix As String
Visual C++
public:
property String^ ErrorPrefix {
    String^ get ();
    void set (String^ value);
}

Remarks

For databases opened inside of a DatabaseEnvironment, setting ErrorPrefix affects the entire environment and is equivalent to setting ErrorPrefix.

Setting ErrorPrefix configures operations performed using the specified object, not all operations performed on the underlying database.

See Also

BaseDatabase Class


Feedback Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Feedback Property
BaseDatabase Class See Also Send Feedback
Monitor progress within long running operations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseFeedbackDelegate Feedback { get; set; }
Visual Basic (Declaration)
Public Property Feedback As DatabaseFeedbackDelegate
Visual C++
public:
property DatabaseFeedbackDelegate^ Feedback {
    DatabaseFeedbackDelegate^ get ();
    void set (DatabaseFeedbackDelegate^ value);
}

Remarks

Some operations performed by the Berkeley DB library can take non-trivial amounts of time. When an operation is likely to take a long time, Berkeley DB calls the the Feedback delegate to monitor progress within these operations.

It is up to the delegate to display this information in an appropriate manner.

See Also

BaseDatabase Class


FileName Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.FileName Property
BaseDatabase Class See Also Send Feedback
The filename of this database, if it has one.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string FileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

BaseDatabase Class


FreeThreaded Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.FreeThreaded Property
BaseDatabase Class See Also Send Feedback
If true, the object is free-threaded; concurrently usable by multiple threads in the address space.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool FreeThreaded { get; }
Visual Basic (Declaration)
Public ReadOnly Property FreeThreaded As Boolean
Visual C++
public:
property bool FreeThreaded {
    bool get ();
}

See Also

BaseDatabase Class


HasMultiple Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.HasMultiple Property
BaseDatabase Class See Also Send Feedback
If true, the object references a physical file supporting multiple databases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool HasMultiple { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasMultiple As Boolean
Visual C++
public:
property bool HasMultiple {
    bool get ();
}

Remarks

If true, the object is a handle on a database whose key values are the names of the databases stored in the physical file and whose data values are opaque objects. No keys or data values may be modified or stored using the database handle.

See Also

BaseDatabase Class


InHostOrder Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.InHostOrder Property
BaseDatabase Class See Also Send Feedback
If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool InHostOrder { get; }
Visual Basic (Declaration)
Public ReadOnly Property InHostOrder As Boolean
Visual C++
public:
property bool InHostOrder {
    bool get ();
}

See Also

BaseDatabase Class


messageFeedback Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.messageFeedback Property
BaseDatabase Class See Also Send Feedback
The mechanism for reporting detailed statistic messages to the application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MessageFeedbackDelegate messageFeedback { get; set; }
Visual Basic (Declaration)
Public Property messageFeedback As MessageFeedbackDelegate
Visual C++
public:
property MessageFeedbackDelegate^ messageFeedback {
    MessageFeedbackDelegate^ get ();
    void set (MessageFeedbackDelegate^ value);
}

Remarks

There are interfaces in the Berkeley DB library which either directly output informational messages or statistical information, or configure the library to output such messages when performing other operations.

Berkeley DB calls the given delegate with each message. It is up to the delegate to display the message in an appropriate manner.

Setting MessageFeedback to NULL resets the callback interface.

For databases opened inside of a DatabaseEnvironment, setting MessageFeedback affects the entire environment and is equivalent to setting DatabaseEnvironment.MessageFeedback.

For databases not opened in an environment, setting MessageFeedback configures operations performed using the specified object, instead of all operations performed on the underlying database.

See Also

BaseDatabase Class


Msgfile Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Msgfile Property
BaseDatabase Class See Also Send Feedback
The message file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Msgfile { set; }
Visual Basic (Declaration)
Public WriteOnly Property Msgfile As String
Visual C++
public:
property String^ Msgfile {
    void set (String^ value);
}

See Also

BaseDatabase Class


NoMMap Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.NoMMap Property
BaseDatabase Class See Also Send Feedback

If true, this database is not mapped into process memory.

See MMapSize for further information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoMMap { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoMMap As Boolean
Visual C++
public:
property bool NoMMap {
    bool get ();
}

See Also

BaseDatabase Class


NonDurableTxns Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.NonDurableTxns Property
BaseDatabase Class See Also Send Feedback
If true, Berkeley DB does not write log records for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NonDurableTxns { get; }
Visual Basic (Declaration)
Public ReadOnly Property NonDurableTxns As Boolean
Visual C++
public:
property bool NonDurableTxns {
    bool get ();
}

See Also

BaseDatabase Class


NoWaitDbExclusiveLock Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.NoWaitDbExclusiveLock Property
BaseDatabase Class See Also Send Feedback
If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Nullable<bool> NoWaitDbExclusiveLock { get; }
Visual Basic (Declaration)
Public ReadOnly Property NoWaitDbExclusiveLock As Nullable(Of Boolean)
Visual C++
public:
property Nullable<bool> NoWaitDbExclusiveLock {
    Nullable<bool> get ();
}

See Also

BaseDatabase Class


Pagesize Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Pagesize Property
BaseDatabase Class See Also Send Feedback
The database's current page size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Pagesize { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pagesize As UInteger
Visual C++
public:
property unsigned int Pagesize {
    unsigned int get ();
}

Remarks

If PageSize was not set by your application, then the default page size is selected based on the underlying filesystem I/O block size.

See Also

BaseDatabase Class


Priority Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Priority Property
BaseDatabase Class See Also Send Feedback
The cache priority for pages referenced by this object.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CachePriority Priority { get; }
Visual Basic (Declaration)
Public ReadOnly Property Priority As CachePriority
Visual C++
public:
property CachePriority^ Priority {
    CachePriority^ get ();
}

See Also

BaseDatabase Class


ReadOnly Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.ReadOnly Property
BaseDatabase Class See Also Send Feedback
If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReadOnly As Boolean
Visual C++
public:
property bool ReadOnly {
    bool get ();
}

See Also

BaseDatabase Class


ReadUncommitted Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.ReadUncommitted Property
BaseDatabase Class See Also Send Feedback
If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReadUncommitted { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReadUncommitted As Boolean
Visual C++
public:
property bool ReadUncommitted {
    bool get ();
}

See Also

BaseDatabase Class


Transactional Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Transactional Property
BaseDatabase Class See Also Send Feedback
If true, this database has been opened in a transactional mode.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Transactional { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transactional As Boolean
Visual C++
public:
property bool Transactional {
    bool get ();
}

See Also

BaseDatabase Class


Truncated Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Truncated Property
BaseDatabase Class See Also Send Feedback
If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Truncated { get; }
Visual Basic (Declaration)
Public ReadOnly Property Truncated As Boolean
Visual C++
public:
property bool Truncated {
    bool get ();
}

See Also

BaseDatabase Class


Type Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.Type Property
BaseDatabase Class See Also Send Feedback
The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseType Type { get; }
Visual Basic (Declaration)
Public ReadOnly Property Type As DatabaseType
Visual C++
public:
property DatabaseType^ Type {
    DatabaseType^ get ();
}

See Also

BaseDatabase Class


UseMVCC Property

[image]

Berkeley DB .NET API Documentation
BaseDatabase..::.UseMVCC Property
BaseDatabase Class See Also Send Feedback
If true, the database was opened with support for multiversion concurrency control.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseMVCC { get; }
Visual Basic (Declaration)
Public ReadOnly Property UseMVCC As Boolean
Visual C++
public:
property bool UseMVCC {
    bool get ();
}

See Also

BaseDatabase Class


BTreeCompressDelegate Delegate

[image]

Berkeley DB .NET API Documentation
BTreeCompressDelegate Delegate
See Also Send Feedback
A function to store a compressed key/data pair into a supplied buffer.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate bool BTreeCompressDelegate(
    DatabaseEntry prevKey,
    DatabaseEntry prevData,
    DatabaseEntry key,
    DatabaseEntry data,
    ref byte[] dest,
    out int size
)
Visual Basic (Declaration)
Public Delegate Function BTreeCompressDelegate ( _
    prevKey As DatabaseEntry, _
    prevData As DatabaseEntry, _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    ByRef dest As Byte(), _
    <OutAttribute> ByRef size As Integer _
) As Boolean
Visual C++
public delegate bool BTreeCompressDelegate(
    DatabaseEntry^ prevKey,
    DatabaseEntry^ prevData,
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    array<unsigned char>^% dest,
    [OutAttribute] int% size
)

Parameters

prevKey
Type: BerkeleyDB..::.DatabaseEntry
The key immediately preceding the application supplied key.
prevData
Type: BerkeleyDB..::.DatabaseEntry
The data associated with prevKey.
key
Type: BerkeleyDB..::.DatabaseEntry
The application supplied key.
data
Type: BerkeleyDB..::.DatabaseEntry
The application supplied data.
dest
Type: array< System..::.Byte >[]()[] %
The compressed data to be stored in the database.
size
Type: System..::.Int32 %
The number of compressed bytes written to dest, or the required size of dest, if too small.

Return Value

True on success, false if dest is too small to contain the compressed data. All other errors should throw an exception.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


BTreeCursor Class

[image]

Berkeley DB .NET API Documentation
BTreeCursor Class
Members See Also Send Feedback
A class for traversing the records of a BTreeDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class BTreeCursor : Cursor
Visual Basic (Declaration)
Public Class BTreeCursor _
    Inherits Cursor
Visual C++
public ref class BTreeCursor : public Cursor

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseCursor
BerkeleyDB..::.Cursor
BerkeleyDB..::.BTreeCursor

See Also

BTreeCursor Members


BTreeCursor Members

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor Members
BTreeCursor Class Methods Properties See Also Send Feedback

The BTreeCursor type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddUnique | Insert the specified key/data pair into the database, unless a key/data pair comparing equally to it already exists in the database.
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
DbStream | Overloaded.
Delete | Delete the key/data pair to which the cursor refers. (Inherited from Cursor.)
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Cursor. (Inherited from Cursor.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Insert | Insert the data element as a duplicate element of the key to which the cursor refers.
Move | Overloaded.
MoveFirst | Overloaded.
MoveFirstMultiple | Overloaded. If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).
MoveFirstMultipleKey | Overloaded.
MoveLast | Overloaded.
MoveMultiple | Overloaded.
MoveMultipleKey | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextDuplicateMultiple | Overloaded.
MoveNextDuplicateMultipleKey | Overloaded.
MoveNextMultiple | Overloaded.
MoveNextMultipleKey | Overloaded.
MoveNextUnique | Overloaded.
MoveNextUniqueMultiple | Overloaded.
MoveNextUniqueMultipleKey | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Overwrite | Overwrite the data of the key/data pair to which the cursor refers with the specified data item. (Inherited from Cursor.)
Recno | Overloaded.
Refresh | Overloaded.
RefreshMultiple | Overloaded.
RefreshMultipleKey | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Current | The key/data pair at which the cursor currently points. (Inherited from Cursor.)
CurrentMultiple | The key and multiple data items at which the cursor currently points. (Inherited from Cursor.)
CurrentMultipleKey | The multiple key and data items at which the cursor currently points. (Inherited from Cursor.)
Priority | The cache priority for pages referenced by the cursor. (Inherited from Cursor.)

See Also

BTreeCursor Class


BTreeCursor Methods

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor Methods
BTreeCursor Class See Also Send Feedback

The BTreeCursor type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddUnique | Insert the specified key/data pair into the database, unless a key/data pair comparing equally to it already exists in the database.
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
DbStream | Overloaded.
Delete | Delete the key/data pair to which the cursor refers. (Inherited from Cursor.)
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Cursor. (Inherited from Cursor.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Insert | Insert the data element as a duplicate element of the key to which the cursor refers.
Move | Overloaded.
MoveFirst | Overloaded.
MoveFirstMultiple | Overloaded. If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).
MoveFirstMultipleKey | Overloaded.
MoveLast | Overloaded.
MoveMultiple | Overloaded.
MoveMultipleKey | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextDuplicateMultiple | Overloaded.
MoveNextDuplicateMultipleKey | Overloaded.
MoveNextMultiple | Overloaded.
MoveNextMultipleKey | Overloaded.
MoveNextUnique | Overloaded.
MoveNextUniqueMultiple | Overloaded.
MoveNextUniqueMultipleKey | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Overwrite | Overwrite the data of the key/data pair to which the cursor refers with the specified data item. (Inherited from Cursor.)
Recno | Overloaded.
Refresh | Overloaded.
RefreshMultiple | Overloaded.
RefreshMultipleKey | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BTreeCursor Class


Add Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Add Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
Add(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>)) | Stores the key/data pair in the database. (Inherited from Cursor.)
Add(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Cursor..::.InsertLocation) | Insert the specified key/data pair into the database.

See Also

BTreeCursor Class
BTreeCursor Members


Add Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Cursor.InsertLocation)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Add Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Cursor..::.InsertLocation)
BTreeCursor Class See Also Send Feedback
Insert the specified key/data pair into the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Add(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    Cursor..::.InsertLocation loc
)
Visual Basic (Declaration)
Public Sub Add ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    loc As Cursor..::.InsertLocation _
)
Visual C++
public:
void Add(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    Cursor..::.InsertLocation loc
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair to be inserted
loc
Type: BerkeleyDB..::.Cursor..::.InsertLocation
If the key already exists in the database and no duplicate sort function has been specified, specify whether the inserted data item is added as the first or the last of the data items for that key.

See Also

BTreeCursor Class
Add Overload


AddUnique Method

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.AddUnique Method
BTreeCursor Class See Also Send Feedback
Insert the specified key/data pair into the database, unless a key/data pair comparing equally to it already exists in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void AddUnique(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair
)
Visual Basic (Declaration)
Public Sub AddUnique ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry) _
)
Visual C++
public:
void AddUnique(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair to be inserted

Exceptions

Exception | Condition
BerkeleyDB..::.KeyExistException | Thrown if a matching key/data pair already exists in the database.

See Also

BTreeCursor Class


DbStream Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.DbStream Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
DbStream()()() | Create a database stream pointing to a key/value pair where the data item is a blob.
DbStream(DatabaseStreamConfig) | Create a database stream pointing to a key/value pair where the data item is a blob with the given configuration.

See Also

BTreeCursor Class
BTreeCursor Members


DbStream Method

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.DbStream Method
BTreeCursor Class See Also Send Feedback
Create a database stream pointing to a key/value pair where the data item is a blob.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseStream DbStream()
Visual Basic (Declaration)
Public Function DbStream As DatabaseStream
Visual C++
public:
DatabaseStream^ DbStream()

Return Value

A newly created database stream

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException | Thrown if the data item is not a blob.

See Also

BTreeCursor Class
DbStream Overload


DbStream Method (DatabaseStreamConfig)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.DbStream Method (DatabaseStreamConfig)
BTreeCursor Class See Also Send Feedback
Create a database stream pointing to a key/value pair where the data item is a blob with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseStream DbStream(
    DatabaseStreamConfig cfg
)
Visual Basic (Declaration)
Public Function DbStream ( _
    cfg As DatabaseStreamConfig _
) As DatabaseStream
Visual C++
public:
DatabaseStream^ DbStream(
    DatabaseStreamConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.DatabaseStreamConfig
The configuration properties for the database stream.

Return Value

A newly created database stream

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException | Thrown if the data of the key/value pair it is pointing to is not a blob.

See Also

BTreeCursor Class
DbStream Overload


Duplicate Method

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Duplicate Method
BTreeCursor Class See Also Send Feedback
Create a new cursor that uses the same transaction and locker ID as the original cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeCursor Duplicate(
    bool keepPosition
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    keepPosition As Boolean _
) As BTreeCursor
Visual C++
public:
BTreeCursor^ Duplicate(
    bool keepPosition
)

Parameters

keepPosition
Type: System..::.Boolean
If true, the newly created cursor is initialized to refer to the same position in the database as the original cursor (if any) and hold the same locks (if any). If false, or if the original cursor does not hold a database position and locks, the created cursor is uninitialized and behaves like a cursor newly created by Cursor()()().

Return Value

A newly created cursor

Remarks

This is useful when an application is using locking and requires two or more cursors in the same thread of control.

See Also

BTreeCursor Class


Insert Method

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Insert Method
BTreeCursor Class See Also Send Feedback
Insert the data element as a duplicate element of the key to which the cursor refers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Insert(
    DatabaseEntry data,
    Cursor..::.InsertLocation loc
)
Visual Basic (Declaration)
Public Sub Insert ( _
    data As DatabaseEntry, _
    loc As Cursor..::.InsertLocation _
)
Visual C++
public:
void Insert(
    DatabaseEntry^ data,
    Cursor..::.InsertLocation loc
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data element to insert
loc
Type: BerkeleyDB..::.Cursor..::.InsertLocation
Specify whether to insert the data item immediately before or immediately after the cursor's current position.

See Also

BTreeCursor Class


Move Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Move Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
Move(UInt32) | Position the cursor at a specific key/data pair in the database, and store the key/data pair in Current.
Move(UInt32, LockingInfo) | Position the cursor at a specific key/data pair in the database, and store the key/data pair in Current.
Move(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
Move(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
Move(DatabaseEntry, DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned. (Inherited from Cursor.)
Move(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
Move(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
Move(DatabaseEntry, DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


Move Method (UInt32)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Move Method (UInt32)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    uint recno
)
Visual Basic (Declaration)
Public Function Move ( _
    recno As UInteger _
) As Boolean
Visual C++
public:
bool Move(
    unsigned int recno
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
Move Overload


Move Method (UInt32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Move Method (UInt32, LockingInfo)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    uint recno,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Move ( _
    recno As UInteger, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Move(
    unsigned int recno,
    LockingInfo^ info
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
Move Overload


MoveFirst Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveFirst Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirst()()() | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveFirst(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveFirst(DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveFirst(DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveFirstMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveFirstMultiple Method
BTreeCursor Class See Also Send Feedback
If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

Overload List

Name | Description
MoveFirstMultiple()()() | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(Int32) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(Int32, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveFirstMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveFirstMultipleKey Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirstMultipleKey()()() | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(Int32) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(Int32, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveLast Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveLast Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveLast()()() | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveLast(LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveLast(DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveLast(DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultiple Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveMultiple(UInt32) | Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.
MoveMultiple(UInt32, LockingInfo) | Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.
MoveMultiple(UInt32, Int32) | Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.
MoveMultiple(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(UInt32, Int32, LockingInfo) | Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.
MoveMultiple(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(DatabaseEntry, Boolean, Int32) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(DatabaseEntry, Boolean, Int32, LockingInfo) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveMultiple Method (UInt32)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultiple Method (UInt32)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    uint recno
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    recno As UInteger _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    unsigned int recno
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
MoveMultiple Overload


MoveMultiple Method (UInt32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultiple Method (UInt32, LockingInfo)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    uint recno,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    recno As UInteger, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    unsigned int recno,
    LockingInfo^ info
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
MoveMultiple Overload


MoveMultiple Method (UInt32, Int32)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultiple Method (UInt32, Int32)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    uint recno,
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    recno As UInteger, _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    unsigned int recno,
    int BufferSize
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
MoveMultiple Overload


MoveMultiple Method (UInt32, Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultiple Method (UInt32, Int32, LockingInfo)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    uint recno,
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    recno As UInteger, _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    unsigned int recno,
    int BufferSize,
    LockingInfo^ info
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
MoveMultiple Overload


MoveMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultipleKey Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveMultipleKey(UInt32) | Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
MoveMultipleKey(UInt32, LockingInfo) | Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
MoveMultipleKey(UInt32, Int32) | Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
MoveMultipleKey(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(UInt32, Int32, LockingInfo) | Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
MoveMultipleKey(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(DatabaseEntry, Boolean, Int32) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(DatabaseEntry, Boolean, Int32, LockingInfo) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveMultipleKey Method (UInt32)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultipleKey Method (UInt32)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    uint recno
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    recno As UInteger _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    unsigned int recno
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (UInt32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultipleKey Method (UInt32, LockingInfo)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    uint recno,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    recno As UInteger, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    unsigned int recno,
    LockingInfo^ info
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (UInt32, Int32)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultipleKey Method (UInt32, Int32)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    uint recno,
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    recno As UInteger, _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    unsigned int recno,
    int BufferSize
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (UInt32, Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveMultipleKey Method (UInt32, Int32, LockingInfo)
BTreeCursor Class See Also Send Feedback
Position the cursor at a specific key/data pair in the database, and store the key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    uint recno,
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    recno As UInteger, _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    unsigned int recno,
    int BufferSize,
    LockingInfo^ info
)

Parameters

recno
Type: System..::.UInt32
The specific numbered record of the database at which to position the cursor.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

BTreeCursor Class
MoveMultipleKey Overload


MoveNext Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNext Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNext()()() | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MoveNext(LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MoveNext(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNext(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveNextDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNextDuplicate Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicate()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicate(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicate(DatabaseEntry, DatabaseEntry) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNextDuplicate(DatabaseEntry, DatabaseEntry, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveNextDuplicateMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNextDuplicateMultiple Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicateMultiple()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(Int32) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, then move cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(Int32, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveNextDuplicateMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNextDuplicateMultipleKey Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicateMultipleKey()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(Int32) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(Int32, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveNextMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNextMultiple Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextMultiple()()() | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(LockingInfo) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(Int32) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveNextMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNextMultipleKey Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextMultipleKey()()() | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(LockingInfo) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(Int32) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveNextUnique Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNextUnique Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUnique()()() | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUnique(LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUnique(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNextUnique(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveNextUniqueMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNextUniqueMultiple Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUniqueMultiple()()() | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(Int32) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MoveNextUniqueMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MoveNextUniqueMultipleKey Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUniqueMultipleKey()()() | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(Int32) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MovePrev Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MovePrev Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrev()()() | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MovePrev(LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MovePrev(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrev(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MovePrevDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MovePrevDuplicate Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevDuplicate()()() | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MovePrevDuplicate(LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MovePrevDuplicate(DatabaseEntry, DatabaseEntry) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrevDuplicate(DatabaseEntry, DatabaseEntry, LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


MovePrevUnique Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.MovePrevUnique Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevUnique()()() | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MovePrevUnique(LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MovePrevUnique(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if ntheo non-duplicate key/data pairs exist after the cursor position in database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrevUnique(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


Recno Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Recno Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
Recno()()() | Return the record number associated with the cursor's current position.
Recno(LockingInfo) | Return the record number associated with the cursor's current position.

See Also

BTreeCursor Class
BTreeCursor Members


Recno Method

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Recno Method
BTreeCursor Class See Also Send Feedback
Return the record number associated with the cursor's current position.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Recno()
Visual Basic (Declaration)
Public Function Recno As UInteger
Visual C++
public:
unsigned int Recno()

Return Value

The record number associated with the cursor.

See Also

BTreeCursor Class
Recno Overload


Recno Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Recno Method (LockingInfo)
BTreeCursor Class See Also Send Feedback
Return the record number associated with the cursor's current position.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Recno(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Recno ( _
    info As LockingInfo _
) As UInteger
Visual C++
public:
unsigned int Recno(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

The record number associated with the cursor.

See Also

BTreeCursor Class
Recno Overload


Refresh Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.Refresh Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
Refresh()()() | Store the key/data pair to which the cursor refers in Current. (Inherited from Cursor.)
Refresh(LockingInfo) | Store the key/data pair to which the cursor refers in Current. (Inherited from Cursor.)
Refresh(DatabaseEntry, DatabaseEntry) | Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned. (Inherited from Cursor.)
Refresh(DatabaseEntry, DatabaseEntry, LockingInfo) | Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


RefreshMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.RefreshMultiple Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
RefreshMultiple()()() | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(LockingInfo) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(Int32) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(Int32, LockingInfo) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


RefreshMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor..::.RefreshMultipleKey Method
BTreeCursor Class See Also Send Feedback

Overload List

Name | Description
RefreshMultipleKey()()() | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(LockingInfo) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(Int32) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(Int32, LockingInfo) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)

See Also

BTreeCursor Class
BTreeCursor Members


BTreeCursor Properties

[image] [image]

Berkeley DB .NET API Documentation
BTreeCursor Properties
BTreeCursor Class See Also Send Feedback

The BTreeCursor type exposes the following members.

Properties

Name | Description
Current | The key/data pair at which the cursor currently points. (Inherited from Cursor.)
CurrentMultiple | The key and multiple data items at which the cursor currently points. (Inherited from Cursor.)
CurrentMultipleKey | The multiple key and data items at which the cursor currently points. (Inherited from Cursor.)
Priority | The cache priority for pages referenced by the cursor. (Inherited from Cursor.)

See Also

BTreeCursor Class


BTreeDatabase Class

[image]

Berkeley DB .NET API Documentation
BTreeDatabase Class
Members See Also Send Feedback
A class representing a BTreeDatabase. The Btree format is a representation of a sorted, balanced tree structure.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class BTreeDatabase : Database
Visual Basic (Declaration)
Public Class BTreeDatabase _
    Inherits Database
Visual C++
public ref class BTreeDatabase : public Database

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.Database
BerkeleyDB..::.BTreeDatabase

See Also

BTreeDatabase Members


BTreeDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase Members
BTreeDatabase Class Methods Properties See Also Send Feedback

The BTreeDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Compact | Overloaded.
Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
KeyRange | Overloaded.
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoDuplicate | Overloaded.
PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by BTreeStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.
TruncateUnusedPages | Overloaded.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
BlobDir | The path of the directory where blobs are stored.
BlobThreshold | The threshold value in bytes beyond which data items are stored as blobs. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. A value of 0 indicates that blobs are not used by the database.
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Compare | The Btree key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.
Compress | The compression function used to store key/data pairs in the database.
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
Decompress | The decompression function used to retrieve key/data pairs from the database.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
DupCompare | The duplicate data item comparison function.
Duplicates | Whether the insertion of duplicate data items in the database is permitted, and whether duplicate items are sorted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
MinKeysPerPage | The minimum number of key/data pairs intended to be stored on any single Btree leaf page.
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
NParts | Return the number of partitions created in the database.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Partition | Return the application-specified partitioning function.
PartitionKeys | Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.
PrefixCompare | The Btree prefix function. The prefix function is used to determine the amount by which keys stored on the Btree internal pages can be safely truncated without losing their uniqueness.
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
RecordNumbers | If true, this object supports retrieval from the Btree using record numbers.
ReverseSplit | If false, empty pages are not coalesced into higher-level pages.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class


BTreeDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase Methods
BTreeDatabase Class See Also Send Feedback

The BTreeDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Compact | Overloaded.
Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
KeyRange | Overloaded.
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoDuplicate | Overloaded.
PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by BTreeStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.
TruncateUnusedPages | Overloaded.

See Also

BTreeDatabase Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Close Method
BTreeDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class
BTreeDatabase Members


Compact Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Compact Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Compact(CompactConfig) | Compact the database, and optionally return unused database pages to the underlying filesystem.
Compact(CompactConfig, Transaction) | Compact the database, and optionally return unused database pages to the underlying filesystem.

See Also

BTreeDatabase Class
BTreeDatabase Members


Compact Method (CompactConfig)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Compact Method (CompactConfig)
BTreeDatabase Class See Also Send Feedback
Compact the database, and optionally return unused database pages to the underlying filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CompactData Compact(
    CompactConfig cdata
)
Visual Basic (Declaration)
Public Function Compact ( _
    cdata As CompactConfig _
) As CompactData
Visual C++
public:
CompactData^ Compact(
    CompactConfig^ cdata
)

Parameters

cdata
Type: BerkeleyDB..::.CompactConfig
Compact configuration parameters

Return Value

Compact operation statistics

Remarks

If the operation occurs in a transactional database, the operation is implicitly transaction protected using multiple transactions. These transactions are periodically committed to avoid locking large sections of the tree. Any deadlocks encountered cause the compaction operation to be retried from the point of the last transaction commit.

See Also

BTreeDatabase Class
Compact Overload


Compact Method (CompactConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Compact Method (CompactConfig, Transaction)
BTreeDatabase Class See Also Send Feedback
Compact the database, and optionally return unused database pages to the underlying filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CompactData Compact(
    CompactConfig cdata,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Compact ( _
    cdata As CompactConfig, _
    txn As Transaction _
) As CompactData
Visual C++
public:
CompactData^ Compact(
    CompactConfig^ cdata,
    Transaction^ txn
)

Parameters

cdata
Type: BerkeleyDB..::.CompactConfig
Compact configuration parameters
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

Compact operation statistics

Remarks

If txn is non-null, then the operation is performed using that transaction. In this event, large sections of the tree may be locked during the course of the transaction.

If txn is null, but the operation occurs in a transactional database, the operation is implicitly transaction protected using multiple transactions. These transactions are periodically committed to avoid locking large sections of the tree. Any deadlocks encountered cause the compaction operation to be retried from the point of the last transaction commit.

See Also

BTreeDatabase Class
Compact Overload


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Cursor Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor.
Cursor(CursorConfig) | Create a database cursor with the given configuration.
Cursor(Transaction) | Create a transactionally protected database cursor.
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration.

See Also

BTreeDatabase Class
BTreeDatabase Members


Cursor Method

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Cursor Method
BTreeDatabase Class See Also Send Feedback
Create a database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeCursor Cursor()
Visual Basic (Declaration)
Public Function Cursor As BTreeCursor
Visual C++
public:
BTreeCursor^ Cursor()

Return Value

A newly created cursor

See Also

BTreeDatabase Class
Cursor Overload


Cursor Method (CursorConfig)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Cursor Method (CursorConfig)
BTreeDatabase Class See Also Send Feedback
Create a database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeCursor Cursor(
    CursorConfig cfg
)
Visual Basic (Declaration)
Public Function Cursor ( _
    cfg As CursorConfig _
) As BTreeCursor
Visual C++
public:
BTreeCursor^ Cursor(
    CursorConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.

Return Value

A newly created cursor

See Also

BTreeDatabase Class
Cursor Overload


Cursor Method (Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Cursor Method (Transaction)
BTreeDatabase Class See Also Send Feedback
Create a transactionally protected database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeCursor Cursor(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Cursor ( _
    txn As Transaction _
) As BTreeCursor
Visual C++
public:
BTreeCursor^ Cursor(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

BTreeDatabase Class
Cursor Overload


Cursor Method (CursorConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Cursor Method (CursorConfig, Transaction)
BTreeDatabase Class See Also Send Feedback
Create a transactionally protected database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeCursor Cursor(
    CursorConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Cursor ( _
    cfg As CursorConfig, _
    txn As Transaction _
) As BTreeCursor
Visual C++
public:
BTreeCursor^ Cursor(
    CursorConfig^ cfg,
    Transaction^ txn
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.
txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

BTreeDatabase Class
Cursor Overload


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Delete Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class
BTreeDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Exists Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class
BTreeDatabase Members


FastStats Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.FastStats Method
BTreeDatabase Class See Also Send Feedback

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
FastStats()()() | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction) | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction, Isolation) | Return the database statistical information which does not require traversal of the database.

See Also

BTreeDatabase Class
BTreeDatabase Members


FastStats Method

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.FastStats Method
BTreeDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeStats FastStats()
Visual Basic (Declaration)
Public Function FastStats As BTreeStats
Visual C++
public:
BTreeStats^ FastStats()

Return Value

The database statistical information which does not require traversal of the database.

See Also

BTreeDatabase Class
FastStats Overload


FastStats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.FastStats Method (Transaction)
BTreeDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeStats FastStats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction _
) As BTreeStats
Visual C++
public:
BTreeStats^ FastStats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The database statistical information which does not require traversal of the database.

See Also

BTreeDatabase Class
FastStats Overload


FastStats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.FastStats Method (Transaction, Isolation)
BTreeDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeStats FastStats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As BTreeStats
Visual C++
public:
BTreeStats^ FastStats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE is silently ignored for databases which did not specify ReadUncommitted.

Return Value

The database statistical information which does not require traversal of the database.

See Also

BTreeDatabase Class
FastStats Overload


Get Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Get Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(UInt32) | Retrieve a specific numbered key/data pair from the database.
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(UInt32, Transaction) | Retrieve a specific numbered key/data pair from the database.
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(UInt32, Transaction, LockingInfo) | Retrieve a specific numbered key/data pair from the database.
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class
BTreeDatabase Members


Get Method (UInt32)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Get Method (UInt32)
BTreeDatabase Class See Also Send Feedback
Retrieve a specific numbered key/data pair from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    uint recno
)
Visual Basic (Declaration)
Public Function Get ( _
    recno As UInteger _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    unsigned int recno
)

Parameters

recno
Type: System..::.UInt32
The record number of the record to be retrieved.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is recno and whose Value parameter is the retrieved data.

See Also

BTreeDatabase Class
Get Overload


Get Method (UInt32, Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Get Method (UInt32, Transaction)
BTreeDatabase Class See Also Send Feedback
Retrieve a specific numbered key/data pair from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    uint recno,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Get ( _
    recno As UInteger, _
    txn As Transaction _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    unsigned int recno,
    Transaction^ txn
)

Parameters

recno
Type: System..::.UInt32
The record number of the record to be retrieved.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is recno and whose Value parameter is the retrieved data.

See Also

BTreeDatabase Class
Get Overload


Get Method (UInt32, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Get Method (UInt32, Transaction, LockingInfo)
BTreeDatabase Class See Also Send Feedback
Retrieve a specific numbered key/data pair from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Get(
    uint recno,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Get ( _
    recno As UInteger, _
    txn As Transaction, _
    info As LockingInfo _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, DatabaseEntry^> Get(
    unsigned int recno,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

recno
Type: System..::.UInt32
The record number of the record to be retrieved.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is recno and whose Value parameter is the retrieved data.

See Also

BTreeDatabase Class
Get Overload


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.GetBoth Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class
BTreeDatabase Members


GetBothMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.GetBothMultiple Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBothMultiple(DatabaseEntry, DatabaseEntry) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction, LockingInfo) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)

See Also

BTreeDatabase Class
BTreeDatabase Members


GetMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.GetMultiple Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
GetMultiple(UInt32) | Retrieve a specific numbered key and all duplicate data items from the database.
GetMultiple(DatabaseEntry) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(UInt32, Int32) | Retrieve a specific numbered key and all duplicate data items from the database.
GetMultiple(DatabaseEntry, Int32) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(UInt32, Int32, Transaction) | Retrieve a specific numbered key and all duplicate data items from the database.
GetMultiple(DatabaseEntry, Int32, Transaction) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(UInt32, Int32, Transaction, LockingInfo) | Retrieve a specific numbered key and all duplicate data items from the database.
GetMultiple(DatabaseEntry, Int32, Transaction, LockingInfo) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)

See Also

BTreeDatabase Class
BTreeDatabase Members


GetMultiple Method (UInt32)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.GetMultiple Method (UInt32)
BTreeDatabase Class See Also Send Feedback
Retrieve a specific numbered key and all duplicate data items from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetMultiple(
    uint recno
)
Visual Basic (Declaration)
Public Function GetMultiple ( _
    recno As UInteger _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetMultiple(
    unsigned int recno
)

Parameters

recno
Type: System..::.UInt32
The record number of the record to be retrieved.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is recno and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if recno is not in the database.

See Also

BTreeDatabase Class
GetMultiple Overload


GetMultiple Method (UInt32, Int32)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.GetMultiple Method (UInt32, Int32)
BTreeDatabase Class See Also Send Feedback
Retrieve a specific numbered key and all duplicate data items from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetMultiple(
    uint recno,
    int BufferSize
)
Visual Basic (Declaration)
Public Function GetMultiple ( _
    recno As UInteger, _
    BufferSize As Integer _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetMultiple(
    unsigned int recno,
    int BufferSize
)

Parameters

recno
Type: System..::.UInt32
The record number of the record to be retrieved.
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is recno and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if recno is not in the database.

See Also

BTreeDatabase Class
GetMultiple Overload


GetMultiple Method (UInt32, Int32, Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.GetMultiple Method (UInt32, Int32, Transaction)
BTreeDatabase Class See Also Send Feedback
Retrieve a specific numbered key and all duplicate data items from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetMultiple(
    uint recno,
    int BufferSize,
    Transaction txn
)
Visual Basic (Declaration)
Public Function GetMultiple ( _
    recno As UInteger, _
    BufferSize As Integer, _
    txn As Transaction _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetMultiple(
    unsigned int recno,
    int BufferSize,
    Transaction^ txn
)

Parameters

recno
Type: System..::.UInt32
The record number of the record to be retrieved.
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is recno and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if recno is not in the database.

See Also

BTreeDatabase Class
GetMultiple Overload


GetMultiple Method (UInt32, Int32, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.GetMultiple Method (UInt32, Int32, Transaction, LockingInfo)
BTreeDatabase Class See Also Send Feedback
Retrieve a specific numbered key and all duplicate data items from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetMultiple(
    uint recno,
    int BufferSize,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function GetMultiple ( _
    recno As UInteger, _
    BufferSize As Integer, _
    txn As Transaction, _
    info As LockingInfo _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetMultiple(
    unsigned int recno,
    int BufferSize,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

recno
Type: System..::.UInt32
The record number of the record to be retrieved.
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is recno and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if recno is not in the database.

See Also

BTreeDatabase Class
GetMultiple Overload


KeyRange Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.KeyRange Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
KeyRange(DatabaseEntry) | Return an estimate of the proportion of keys that are less than, equal to, and greater than the specified key.
KeyRange(DatabaseEntry, Transaction) | Return an estimate of the proportion of keys that are less than, equal to, and greater than the specified key.

See Also

BTreeDatabase Class
BTreeDatabase Members


KeyRange Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.KeyRange Method (DatabaseEntry)
BTreeDatabase Class See Also Send Feedback
Return an estimate of the proportion of keys that are less than, equal to, and greater than the specified key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyRange KeyRange(
    DatabaseEntry key
)
Visual Basic (Declaration)
Public Function KeyRange ( _
    key As DatabaseEntry _
) As KeyRange
Visual C++
public:
KeyRange^ KeyRange(
    DatabaseEntry^ key
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for

Return Value

An estimate of the proportion of keys that are less than, equal to, and greater than the specified key.

See Also

BTreeDatabase Class
KeyRange Overload


KeyRange Method (DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.KeyRange Method (DatabaseEntry, Transaction)
BTreeDatabase Class See Also Send Feedback
Return an estimate of the proportion of keys that are less than, equal to, and greater than the specified key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyRange KeyRange(
    DatabaseEntry key,
    Transaction txn
)
Visual Basic (Declaration)
Public Function KeyRange ( _
    key As DatabaseEntry, _
    txn As Transaction _
) As KeyRange
Visual C++
public:
KeyRange^ KeyRange(
    DatabaseEntry^ key,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

An estimate of the proportion of keys that are less than, equal to, and greater than the specified key.

See Also

BTreeDatabase Class
KeyRange Overload


Open Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Open Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, BTreeDatabaseConfig) | Instantiate a new BTreeDatabase object and open the database represented by Filename.
Open(String, BTreeDatabaseConfig, Transaction) | Instantiate a new BTreeDatabase object and open the database represented by Filename.
Open(String, String, BTreeDatabaseConfig) | Instantiate a new BTreeDatabase object and open the database represented by Filename and DatabaseName.
Open(String, String, BTreeDatabaseConfig, Transaction) | Instantiate a new BTreeDatabase object and open the database represented by Filename and DatabaseName.

See Also

BTreeDatabase Class
BTreeDatabase Members


Open Method (String, BTreeDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Open Method (String, BTreeDatabaseConfig)
BTreeDatabase Class See Also Send Feedback
Instantiate a new BTreeDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static BTreeDatabase Open(
    string Filename,
    BTreeDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As BTreeDatabaseConfig _
) As BTreeDatabase
Visual C++
public:
static BTreeDatabase^ Open(
    String^ Filename,
    BTreeDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.BTreeDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

BTreeDatabase Class
Open Overload


Open Method (String, BTreeDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Open Method (String, BTreeDatabaseConfig, Transaction)
BTreeDatabase Class See Also Send Feedback
Instantiate a new BTreeDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static BTreeDatabase Open(
    string Filename,
    BTreeDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As BTreeDatabaseConfig, _
    txn As Transaction _
) As BTreeDatabase
Visual C++
public:
static BTreeDatabase^ Open(
    String^ Filename,
    BTreeDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.BTreeDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

BTreeDatabase Class
Open Overload


Open Method (String, String, BTreeDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Open Method (String, String, BTreeDatabaseConfig)
BTreeDatabase Class See Also Send Feedback
Instantiate a new BTreeDatabase object and open the database represented by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static BTreeDatabase Open(
    string Filename,
    string DatabaseName,
    BTreeDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As BTreeDatabaseConfig _
) As BTreeDatabase
Visual C++
public:
static BTreeDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    BTreeDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file that used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.BTreeDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

BTreeDatabase Class
Open Overload


Open Method (String, String, BTreeDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Open Method (String, String, BTreeDatabaseConfig, Transaction)
BTreeDatabase Class See Also Send Feedback
Instantiate a new BTreeDatabase object and open the database represented by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static BTreeDatabase Open(
    string Filename,
    string DatabaseName,
    BTreeDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As BTreeDatabaseConfig, _
    txn As Transaction _
) As BTreeDatabase
Visual C++
public:
static BTreeDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    BTreeDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.BTreeDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and be replicated to client sites in any replication group.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

BTreeDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.PrintFastStats Method
BTreeDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class
BTreeDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.PrintStats Method
BTreeDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class
BTreeDatabase Members


Put Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Put Method
BTreeDatabase Class See Also Send Feedback

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

Overload List

Name | Description
Put(MultipleKeyDatabaseEntry) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)
Put(MultipleKeyDatabaseEntry, Transaction) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)

See Also

BTreeDatabase Class
BTreeDatabase Members


PutNoDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.PutNoDuplicate Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
PutNoDuplicate(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database only if it does not already appear in the database.
PutNoDuplicate(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database only if it does not already appear in the database.

See Also

BTreeDatabase Class
BTreeDatabase Members


PutNoDuplicate Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.PutNoDuplicate Method (DatabaseEntry, DatabaseEntry)
BTreeDatabase Class See Also Send Feedback
Store the key/data pair in the database only if it does not already appear in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PutNoDuplicate(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Sub PutNoDuplicate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
)
Visual C++
public:
void PutNoDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to store in the database
data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database

See Also

BTreeDatabase Class
PutNoDuplicate Overload


PutNoDuplicate Method (DatabaseEntry, DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.PutNoDuplicate Method (DatabaseEntry, DatabaseEntry, Transaction)
BTreeDatabase Class See Also Send Feedback
Store the key/data pair in the database only if it does not already appear in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PutNoDuplicate(
    DatabaseEntry key,
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub PutNoDuplicate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    txn As Transaction _
)
Visual C++
public:
void PutNoDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to store in the database
data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

See Also

BTreeDatabase Class
PutNoDuplicate Overload


PutNoOverwrite Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.PutNoOverwrite Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
PutNoOverwrite(MultipleKeyDatabaseEntry) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(MultipleKeyDatabaseEntry, Transaction) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)

See Also

BTreeDatabase Class
BTreeDatabase Members


Stats Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Stats Method
BTreeDatabase Class See Also Send Feedback
The statistical information is described by BTreeStats.

Overload List

Name | Description
Stats()()() | Return the database statistical information for this database.
Stats(Transaction) | Return the database statistical information for this database.
Stats(Transaction, Isolation) | Return the database statistical information for this database.

See Also

BTreeDatabase Class
BTreeDatabase Members


Stats Method

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Stats Method
BTreeDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeStats Stats()
Visual Basic (Declaration)
Public Function Stats As BTreeStats
Visual C++
public:
BTreeStats^ Stats()

Return Value

Database statistical information.

See Also

BTreeDatabase Class
Stats Overload


Stats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Stats Method (Transaction)
BTreeDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeStats Stats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction _
) As BTreeStats
Visual C++
public:
BTreeStats^ Stats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

Database statistical information.

See Also

BTreeDatabase Class
Stats Overload


Stats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Stats Method (Transaction, Isolation)
BTreeDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeStats Stats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As BTreeStats
Visual C++
public:
BTreeStats^ Stats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE is silently ignored for databases which did not specify ReadUncommitted.

Return Value

Database statistical information.

See Also

BTreeDatabase Class
Stats Overload


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Truncate Method
BTreeDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class
BTreeDatabase Members


TruncateUnusedPages Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.TruncateUnusedPages Method
BTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
TruncateUnusedPages()()() | Return pages to the filesystem that are already free and at the end of the file.
TruncateUnusedPages(Transaction) | Return pages to the filesystem that are already free and at the end of the file.

See Also

BTreeDatabase Class
BTreeDatabase Members


TruncateUnusedPages Method

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.TruncateUnusedPages Method
BTreeDatabase Class See Also Send Feedback
Return pages to the filesystem that are already free and at the end of the file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TruncateUnusedPages()
Visual Basic (Declaration)
Public Function TruncateUnusedPages As UInteger
Visual C++
public:
unsigned int TruncateUnusedPages()

Return Value

The number of database pages returned to the filesystem

See Also

BTreeDatabase Class
TruncateUnusedPages Overload


TruncateUnusedPages Method (Transaction)

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.TruncateUnusedPages Method (Transaction)
BTreeDatabase Class See Also Send Feedback
Return pages to the filesystem that are already free and at the end of the file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TruncateUnusedPages(
    Transaction txn
)
Visual Basic (Declaration)
Public Function TruncateUnusedPages ( _
    txn As Transaction _
) As UInteger
Visual C++
public:
unsigned int TruncateUnusedPages(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The number of database pages returned to the filesystem

See Also

BTreeDatabase Class
TruncateUnusedPages Overload


BTreeDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabase Properties
BTreeDatabase Class See Also Send Feedback

The BTreeDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
BlobDir | The path of the directory where blobs are stored.
BlobThreshold | The threshold value in bytes beyond which data items are stored as blobs. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. A value of 0 indicates that blobs are not used by the database.
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Compare | The Btree key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.
Compress | The compression function used to store key/data pairs in the database.
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
Decompress | The decompression function used to retrieve key/data pairs from the database.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
DupCompare | The duplicate data item comparison function.
Duplicates | Whether the insertion of duplicate data items in the database is permitted, and whether duplicate items are sorted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
MinKeysPerPage | The minimum number of key/data pairs intended to be stored on any single Btree leaf page.
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
NParts | Return the number of partitions created in the database.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Partition | Return the application-specified partitioning function.
PartitionKeys | Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.
PrefixCompare | The Btree prefix function. The prefix function is used to determine the amount by which keys stored on the Btree internal pages can be safely truncated without losing their uniqueness.
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
RecordNumbers | If true, this object supports retrieval from the Btree using record numbers.
ReverseSplit | If false, empty pages are not coalesced into higher-level pages.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

BTreeDatabase Class


BlobDir Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.BlobDir Property
BTreeDatabase Class See Also Send Feedback
The path of the directory where blobs are stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BlobDir { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlobDir As String
Visual C++
public:
property String^ BlobDir {
    String^ get ();
}

See Also

BTreeDatabase Class


BlobThreshold Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.BlobThreshold Property
BTreeDatabase Class See Also Send Feedback
The threshold value in bytes beyond which data items are stored as blobs.

Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob.

A value of 0 indicates that blobs are not used by the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BlobThreshold { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlobThreshold As UInteger
Visual C++
public:
property unsigned int BlobThreshold {
    unsigned int get ();
}

See Also

BTreeDatabase Class


Compare Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Compare Property
BTreeDatabase Class See Also Send Feedback
The Btree key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate Compare { get; private set; }
Visual Basic (Declaration)
Public Property Compare As EntryComparisonDelegate
Visual C++
public:
property EntryComparisonDelegate^ Compare {
    EntryComparisonDelegate^ get ();
    void set (EntryComparisonDelegate^ value);
}

See Also

BTreeDatabase Class


Compress Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Compress Property
BTreeDatabase Class See Also Send Feedback
The compression function used to store key/data pairs in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeCompressDelegate Compress { get; private set; }
Visual Basic (Declaration)
Public Property Compress As BTreeCompressDelegate
Visual C++
public:
property BTreeCompressDelegate^ Compress {
    BTreeCompressDelegate^ get ();
    void set (BTreeCompressDelegate^ value);
}

See Also

BTreeDatabase Class


Decompress Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Decompress Property
BTreeDatabase Class See Also Send Feedback
The decompression function used to retrieve key/data pairs from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeDecompressDelegate Decompress { get; private set; }
Visual Basic (Declaration)
Public Property Decompress As BTreeDecompressDelegate
Visual C++
public:
property BTreeDecompressDelegate^ Decompress {
    BTreeDecompressDelegate^ get ();
    void set (BTreeDecompressDelegate^ value);
}

See Also

BTreeDatabase Class


DupCompare Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.DupCompare Property
BTreeDatabase Class See Also Send Feedback
The duplicate data item comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate DupCompare { get; private set; }
Visual Basic (Declaration)
Public Property DupCompare As EntryComparisonDelegate
Visual C++
public:
property EntryComparisonDelegate^ DupCompare {
    EntryComparisonDelegate^ get ();
    void set (EntryComparisonDelegate^ value);
}

See Also

BTreeDatabase Class


Duplicates Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Duplicates Property
BTreeDatabase Class See Also Send Feedback
Whether the insertion of duplicate data items in the database is permitted, and whether duplicate items are sorted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DuplicatesPolicy Duplicates { get; }
Visual Basic (Declaration)
Public ReadOnly Property Duplicates As DuplicatesPolicy
Visual C++
public:
property DuplicatesPolicy Duplicates {
    DuplicatesPolicy get ();
}

See Also

BTreeDatabase Class


MinKeysPerPage Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.MinKeysPerPage Property
BTreeDatabase Class See Also Send Feedback
The minimum number of key/data pairs intended to be stored on any single Btree leaf page.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MinKeysPerPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinKeysPerPage As UInteger
Visual C++
public:
property unsigned int MinKeysPerPage {
    unsigned int get ();
}

See Also

BTreeDatabase Class


NParts Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.NParts Property
BTreeDatabase Class See Also Send Feedback
Return the number of partitions created in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NParts { get; private set; }
Visual Basic (Declaration)
Public Property NParts As UInteger
Visual C++
public:
property unsigned int NParts {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BTreeDatabase Class


Partition Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.Partition Property
BTreeDatabase Class See Also Send Feedback
Return the application-specified partitioning function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public PartitionDelegate Partition { get; private set; }
Visual Basic (Declaration)
Public Property Partition As PartitionDelegate
Visual C++
public:
property PartitionDelegate^ Partition {
    PartitionDelegate^ get ();
    void set (PartitionDelegate^ value);
}

See Also

BTreeDatabase Class


PartitionKeys Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.PartitionKeys Property
BTreeDatabase Class See Also Send Feedback
Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry[] PartitionKeys { get; private set; }
Visual Basic (Declaration)
Public Property PartitionKeys As DatabaseEntry()
Visual C++
public:
property array<DatabaseEntry^>^ PartitionKeys {
    array<DatabaseEntry^>^ get ();
    void set (array<DatabaseEntry^>^ value);
}

See Also

BTreeDatabase Class


PrefixCompare Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.PrefixCompare Property
BTreeDatabase Class See Also Send Feedback
The Btree prefix function. The prefix function is used to determine the amount by which keys stored on the Btree internal pages can be safely truncated without losing their uniqueness.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryPrefixComparisonDelegate PrefixCompare { get; private set; }
Visual Basic (Declaration)
Public Property PrefixCompare As EntryPrefixComparisonDelegate
Visual C++
public:
property EntryPrefixComparisonDelegate^ PrefixCompare {
    EntryPrefixComparisonDelegate^ get ();
    void set (EntryPrefixComparisonDelegate^ value);
}

See Also

BTreeDatabase Class


RecordNumbers Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.RecordNumbers Property
BTreeDatabase Class See Also Send Feedback
If true, this object supports retrieval from the Btree using record numbers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RecordNumbers { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordNumbers As Boolean
Visual C++
public:
property bool RecordNumbers {
    bool get ();
}

See Also

BTreeDatabase Class


ReverseSplit Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabase..::.ReverseSplit Property
BTreeDatabase Class See Also Send Feedback
If false, empty pages are not coalesced into higher-level pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReverseSplit { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReverseSplit As Boolean
Visual C++
public:
property bool ReverseSplit {
    bool get ();
}

See Also

BTreeDatabase Class


BTreeDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for BTreeDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class BTreeDatabaseConfig : DatabaseConfig
Visual Basic (Declaration)
Public Class BTreeDatabaseConfig _
    Inherits DatabaseConfig
Visual C++
public ref class BTreeDatabaseConfig : public DatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.BTreeDatabaseConfig

See Also

BTreeDatabaseConfig Members


BTreeDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig Members
BTreeDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The BTreeDatabaseConfig type exposes the following members.

Constructors

Name | Description
BTreeDatabaseConfig | Create a new BTreeDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetCompression | Overloaded.
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetPartitionByCallback | Enable database partitioning using the specified number of partitions and partition function. Return true if the specified number of partitions are successfully enabled; otherwise return false. The number of partitions to createThe name of partitioning function
SetPartitionByKeys | Enable database partitioning using the specified partition keys. Return true if partitioning is successfully enabled; otherwise return false. An array of DatabaseEntry where each array entry defines the range of key values to be stored in each partition
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BlobDir | The path of the directory where blobs are stored. If the database is opened within DatabaseEnvironment, this path setting is ignored during Open(String, BTreeDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.
BTreeCompare | The Btree key comparison function.
BTreePrefixCompare | The Btree prefix function.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
DuplicateCompare | The duplicate data item comparison function.
Duplicates | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoReverseSplitting | Turn reverse splitting in the Btree on or off.
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)
UseRecordNumbers | If true, support retrieval from the Btree using record numbers.

Properties

Name | Description
BlobThreshold | The size in bytes which is used to determine when a data item is stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, blobs are never be used by the database. It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.
Compress | The compression function used to store key/data pairs in the database.
Decompress | The decompression function used to retrieve key/data pairs from the database.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
MinKeysPerPage | The minimum number of key/data pairs intended to be stored on any single Btree leaf page.
NParts | Return the number of partitions to create.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Partition | Return the application-specified partitioning function.
PartitionKeys | Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.

See Also

BTreeDatabaseConfig Class


BTreeDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig Constructor
BTreeDatabaseConfig Class See Also Send Feedback
Create a new BTreeDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeDatabaseConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BTreeDatabaseConfig()

See Also

BTreeDatabaseConfig Class


BTreeDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig Fields
BTreeDatabaseConfig Class See Also Send Feedback

The BTreeDatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BlobDir | The path of the directory where blobs are stored. If the database is opened within DatabaseEnvironment, this path setting is ignored during Open(String, BTreeDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.
BTreeCompare | The Btree key comparison function.
BTreePrefixCompare | The Btree prefix function.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
DuplicateCompare | The duplicate data item comparison function.
Duplicates | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoReverseSplitting | Turn reverse splitting in the Btree on or off.
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)
UseRecordNumbers | If true, support retrieval from the Btree using record numbers.

See Also

BTreeDatabaseConfig Class


BlobDir Field

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.BlobDir Field
BTreeDatabaseConfig Class See Also Send Feedback
The path of the directory where blobs are stored.

If the database is opened within DatabaseEnvironment, this path setting is ignored during Open(String, BTreeDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BlobDir
Visual Basic (Declaration)
Public BlobDir As String
Visual C++
public:
String^ BlobDir

See Also

BTreeDatabaseConfig Class


BTreeCompare Field

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.BTreeCompare Field
BTreeDatabaseConfig Class See Also Send Feedback
The Btree key comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate BTreeCompare
Visual Basic (Declaration)
Public BTreeCompare As EntryComparisonDelegate
Visual C++
public:
EntryComparisonDelegate^ BTreeCompare

Remarks

The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.

If no comparison function is specified, the keys are compared lexically, with shorter keys collating before longer keys.

If the database already exists, the comparison function must be the same as that historically used to create the database or corruption can occur.

See Also

BTreeDatabaseConfig Class


BTreePrefixCompare Field

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.BTreePrefixCompare Field
BTreeDatabaseConfig Class See Also Send Feedback
The Btree prefix function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryPrefixComparisonDelegate BTreePrefixCompare
Visual Basic (Declaration)
Public BTreePrefixCompare As EntryPrefixComparisonDelegate
Visual C++
public:
EntryPrefixComparisonDelegate^ BTreePrefixCompare

Remarks

The prefix function is used to determine the amount by which keys stored on the Btree internal pages can be safely truncated without losing their uniqueness. See the Btree prefix comparison section of the Berkeley DB Reference Guide for more details about how this works. The usefulness of this is data-dependent, but can produce significantly reduced tree sizes and search times in some data sets.

If no prefix function or key comparison function is specified by the application, a default lexical comparison function is used as the prefix function. If no prefix function is specified and BTreeCompare is specified, no prefix function is used. It is an error to specify a prefix function without also specifying BTreeCompare.

If the database already exists, the prefix function must be the same as that historically used to create the database or corruption can occur.

See Also

BTreeDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.Creation Field
BTreeDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, BTreeDatabaseConfig) fails.

See Also

BTreeDatabaseConfig Class


DuplicateCompare Field

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.DuplicateCompare Field
BTreeDatabaseConfig Class See Also Send Feedback
The duplicate data item comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate DuplicateCompare
Visual Basic (Declaration)
Public DuplicateCompare As EntryComparisonDelegate
Visual C++
public:
EntryComparisonDelegate^ DuplicateCompare

Remarks

The comparison function is called whenever it is necessary to compare a data item specified by the application with a data item currently stored in the database. Setting DuplicateCompare implies setting Duplicates to SORTED.

If no comparison function is specified, the data items are compared lexically, with shorter data items collating before longer data items.

If the database already exists when Open(String, BTreeDatabaseConfig) is called, the delegate must be the same as that historically used to create the database or corruption can occur.

See Also

BTreeDatabaseConfig Class


Duplicates Field

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.Duplicates Field
BTreeDatabaseConfig Class See Also Send Feedback
Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DuplicatesPolicy Duplicates
Visual Basic (Declaration)
Public Duplicates As DuplicatesPolicy
Visual C++
public:
DuplicatesPolicy Duplicates

Remarks

The ordering of duplicates in the database for UNSORTED is determined by the order of insertion, unless the ordering is otherwise specified by use of a cursor operation or a duplicate sort function. The ordering of duplicates in the database for SORTED is determined by the duplicate comparison function. If the application does not specify a comparison function using DuplicateCompare, a default lexical comparison is used.

SORTED is preferred to UNSORTED for performance reasons. UNSORTED should only be used by applications wanting to order duplicate data items manually.

If the database already exists, the value of Duplicates must be the same as the existing database or an error is returned.

It is an error to specify UseRecordNumbers and anything other than NONE.

See Also

BTreeDatabaseConfig Class


NoReverseSplitting Field

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.NoReverseSplitting Field
BTreeDatabaseConfig Class See Also Send Feedback
Turn reverse splitting in the Btree on or off.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoReverseSplitting
Visual Basic (Declaration)
Public NoReverseSplitting As Boolean
Visual C++
public:
bool NoReverseSplitting

Remarks

As pages are emptied in a database, the Berkeley DB Btree implementation attempts to coalesce empty pages into higher-level pages in order to keep the database as small as possible and minimize search time. This can hurt performance in applications with cyclical data demands; applications where the database grows and shrinks repeatedly. For example, because Berkeley DB does page-level locking, the maximum level of concurrency in a database of two pages is far smaller than that in a database of 100 pages, so a database that has shrunk to a minimal size can cause severe deadlocking when a new cycle of data insertion begins.

See Also

BTreeDatabaseConfig Class


UseRecordNumbers Field

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.UseRecordNumbers Field
BTreeDatabaseConfig Class See Also Send Feedback
If true, support retrieval from the Btree using record numbers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseRecordNumbers
Visual Basic (Declaration)
Public UseRecordNumbers As Boolean
Visual C++
public:
bool UseRecordNumbers

Remarks

Logical record numbers in Btree databases are mutable in the face of record insertion or deletion. See Renumber for further discussion.

Maintaining record counts within a Btree introduces a serious point of contention, namely the page locations where the record counts are stored. In addition, the entire database must be locked during both insertions and deletions, effectively single-threading the database for those operations. Specifying UseRecordNumbers can result in serious performance degradation for some applications and data sets.

It is an error to specify UseRecordNumbers and anything other than NONE.

If the database already exists, the value of UseRecordNumbers must be the same as the existing database or an error is returned.

See Also

BTreeDatabaseConfig Class


BTreeDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig Methods
BTreeDatabaseConfig Class See Also Send Feedback

The BTreeDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetCompression | Overloaded.
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetPartitionByCallback | Enable database partitioning using the specified number of partitions and partition function. Return true if the specified number of partitions are successfully enabled; otherwise return false. The number of partitions to createThe name of partitioning function
SetPartitionByKeys | Enable database partitioning using the specified partition keys. Return true if partitioning is successfully enabled; otherwise return false. An array of DatabaseEntry where each array entry defines the range of key values to be stored in each partition
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BTreeDatabaseConfig Class


SetCompression Method

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.SetCompression Method
BTreeDatabaseConfig Class See Also Send Feedback

Overload List

Name | Description
SetCompression()()() | Enable compression of the key/data pairs stored in the database, using the default compression and decompression functions.
SetCompression(BTreeCompressDelegate, BTreeDecompressDelegate) | Enable compression of the key/data pairs stored in the database, using the specified compression and decompression functions.

See Also

BTreeDatabaseConfig Class
BTreeDatabaseConfig Members


SetCompression Method

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.SetCompression Method
BTreeDatabaseConfig Class See Also Send Feedback
Enable compression of the key/data pairs stored in the database, using the default compression and decompression functions.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetCompression()
Visual Basic (Declaration)
Public Sub SetCompression
Visual C++
public:
void SetCompression()

Remarks

The default functions perform prefix compression on keys, and prefix compression on data items for duplicate keys.

See Also

BTreeDatabaseConfig Class
SetCompression Overload


SetCompression Method (BTreeCompressDelegate, BTreeDecompressDelegate)

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.SetCompression Method (BTreeCompressDelegate, BTreeDecompressDelegate)
BTreeDatabaseConfig Class See Also Send Feedback
Enable compression of the key/data pairs stored in the database, using the specified compression and decompression functions.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetCompression(
    BTreeCompressDelegate compression,
    BTreeDecompressDelegate decompression
)
Visual Basic (Declaration)
Public Sub SetCompression ( _
    compression As BTreeCompressDelegate, _
    decompression As BTreeDecompressDelegate _
)
Visual C++
public:
void SetCompression(
    BTreeCompressDelegate^ compression,
    BTreeDecompressDelegate^ decompression
)

Parameters

compression
Type: BerkeleyDB..::.BTreeCompressDelegate
The compression function
decompression
Type: BerkeleyDB..::.BTreeDecompressDelegate
The decompression function

See Also

BTreeDatabaseConfig Class
SetCompression Overload


SetPartitionByCallback Method

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.SetPartitionByCallback Method
BTreeDatabaseConfig Class See Also Send Feedback
Enable database partitioning using the specified number of partitions and partition function. Return true if the specified number of partitions are successfully enabled; otherwise return false. The number of partitions to createThe name of partitioning function

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SetPartitionByCallback(
    uint parts,
    PartitionDelegate partFunc
)
Visual Basic (Declaration)
Public Function SetPartitionByCallback ( _
    parts As UInteger, _
    partFunc As PartitionDelegate _
) As Boolean
Visual C++
public:
bool SetPartitionByCallback(
    unsigned int parts,
    PartitionDelegate^ partFunc
)

Parameters

parts
Type: System..::.UInt32
partFunc
Type: BerkeleyDB..::.PartitionDelegate

See Also

BTreeDatabaseConfig Class


SetPartitionByKeys Method

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.SetPartitionByKeys Method
BTreeDatabaseConfig Class See Also Send Feedback
Enable database partitioning using the specified partition keys. Return true if partitioning is successfully enabled; otherwise return false. An array of DatabaseEntry where each array entry defines the range of key values to be stored in each partition

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SetPartitionByKeys(
    DatabaseEntry[] keys
)
Visual Basic (Declaration)
Public Function SetPartitionByKeys ( _
    keys As DatabaseEntry() _
) As Boolean
Visual C++
public:
bool SetPartitionByKeys(
    array<DatabaseEntry^>^ keys
)

Parameters

keys
Type: array< BerkeleyDB..::.DatabaseEntry >[]()[]

See Also

BTreeDatabaseConfig Class


BTreeDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig Properties
BTreeDatabaseConfig Class See Also Send Feedback

The BTreeDatabaseConfig type exposes the following members.

Properties

Name | Description
BlobThreshold | The size in bytes which is used to determine when a data item is stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, blobs are never be used by the database. It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.
Compress | The compression function used to store key/data pairs in the database.
Decompress | The decompression function used to retrieve key/data pairs from the database.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
MinKeysPerPage | The minimum number of key/data pairs intended to be stored on any single Btree leaf page.
NParts | Return the number of partitions to create.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Partition | Return the application-specified partitioning function.
PartitionKeys | Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.

See Also

BTreeDatabaseConfig Class


BlobThreshold Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.BlobThreshold Property
BTreeDatabaseConfig Class See Also Send Feedback
The size in bytes which is used to determine when a data item is stored as a blob.

Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob.

If the threshold value is 0, blobs are never be used by the database.

It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BlobThreshold { get; set; }
Visual Basic (Declaration)
Public Property BlobThreshold As UInteger
Visual C++
public:
property unsigned int BlobThreshold {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

BTreeDatabaseConfig Class


Compress Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.Compress Property
BTreeDatabaseConfig Class See Also Send Feedback
The compression function used to store key/data pairs in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeCompressDelegate Compress { get; }
Visual Basic (Declaration)
Public ReadOnly Property Compress As BTreeCompressDelegate
Visual C++
public:
property BTreeCompressDelegate^ Compress {
    BTreeCompressDelegate^ get ();
}

See Also

BTreeDatabaseConfig Class


Decompress Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.Decompress Property
BTreeDatabaseConfig Class See Also Send Feedback
The decompression function used to retrieve key/data pairs from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public BTreeDecompressDelegate Decompress { get; }
Visual Basic (Declaration)
Public ReadOnly Property Decompress As BTreeDecompressDelegate
Visual C++
public:
property BTreeDecompressDelegate^ Decompress {
    BTreeDecompressDelegate^ get ();
}

See Also

BTreeDatabaseConfig Class


MinKeysPerPage Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.MinKeysPerPage Property
BTreeDatabaseConfig Class See Also Send Feedback
The minimum number of key/data pairs intended to be stored on any single Btree leaf page.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MinKeysPerPage { get; set; }
Visual Basic (Declaration)
Public Property MinKeysPerPage As UInteger
Visual C++
public:
property unsigned int MinKeysPerPage {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used to determine if key or data items are stored on overflow pages instead of Btree leaf pages. For more information on the specific algorithm used, see the Berkeley DB Reference Guide. The value specified must be at least 2; if not explicitly set, a value of 2 is used.

If the database already exists, MinKeysPerPage is ignored.

See Also

BTreeDatabaseConfig Class


NParts Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.NParts Property
BTreeDatabaseConfig Class See Also Send Feedback
Return the number of partitions to create.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NParts { get; }
Visual Basic (Declaration)
Public ReadOnly Property NParts As UInteger
Visual C++
public:
property unsigned int NParts {
    unsigned int get ();
}

See Also

BTreeDatabaseConfig Class


Partition Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.Partition Property
BTreeDatabaseConfig Class See Also Send Feedback
Return the application-specified partitioning function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public PartitionDelegate Partition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Partition As PartitionDelegate
Visual C++
public:
property PartitionDelegate^ Partition {
    PartitionDelegate^ get ();
}

See Also

BTreeDatabaseConfig Class


PartitionKeys Property

[image]

Berkeley DB .NET API Documentation
BTreeDatabaseConfig..::.PartitionKeys Property
BTreeDatabaseConfig Class See Also Send Feedback
Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry[] PartitionKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartitionKeys As DatabaseEntry()
Visual C++
public:
property array<DatabaseEntry^>^ PartitionKeys {
    array<DatabaseEntry^>^ get ();
}

See Also

BTreeDatabaseConfig Class


BTreeDecompressDelegate Delegate

[image]

Berkeley DB .NET API Documentation
BTreeDecompressDelegate Delegate
See Also Send Feedback
A function to decompress a key/data pair from a supplied buffer.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate KeyValuePair<DatabaseEntry, DatabaseEntry> BTreeDecompressDelegate(
    DatabaseEntry prevKey,
    DatabaseEntry prevData,
    byte[] compressed,
    out uint bytesRead
)
Visual Basic (Declaration)
Public Delegate Function BTreeDecompressDelegate ( _
    prevKey As DatabaseEntry, _
    prevData As DatabaseEntry, _
    compressed As Byte(), _
    <OutAttribute> ByRef bytesRead As UInteger _
) As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public delegate KeyValuePair<DatabaseEntry^, DatabaseEntry^> BTreeDecompressDelegate(
    DatabaseEntry^ prevKey,
    DatabaseEntry^ prevData,
    array<unsigned char>^ compressed,
    [OutAttribute] unsigned int% bytesRead
)

Parameters

prevKey
Type: BerkeleyDB..::.DatabaseEntry
The key immediately preceding the key being decompressed.
prevData
Type: BerkeleyDB..::.DatabaseEntry
The data associated with prevKey.
compressed
Type: array< System..::.Byte >[]()[]
The data stored in the tree, that is, the compressed data.
bytesRead
Type: System..::.UInt32 %
The number of bytes read from compressed.

Return Value

Two new DatabaseEntry objects representing the decompressed key/data pair.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


BTreeStats Class

[image]

Berkeley DB .NET API Documentation
BTreeStats Class
Members See Also Send Feedback
Statistical information about a BTreeDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class BTreeStats
Visual Basic (Declaration)
Public Class BTreeStats
Visual C++
public ref class BTreeStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BTreeStats

See Also

BTreeStats Members


BTreeStats Members

[image] [image]

Berkeley DB .NET API Documentation
BTreeStats Members
BTreeStats Class Methods Properties See Also Send Feedback

The BTreeStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
DuplicatePages | Duplicate pages.
DuplicatePagesFreeBytes | Bytes free in duplicate pages.
EmptyPages | Empty pages.
FreePages | Pages on the free list.
InternalPages | Internal pages.
InternalPagesFreeBytes | Bytes free in internal pages.
LeafPages | Leaf pages.
LeafPagesFreeBytes | Bytes free in leaf pages.
Levels | Tree levels.
MagicNumber | Magic number.
MetadataFlags | Metadata flags.
MinKey | Minkey value.
nBlobRecords | Number of blob records.
nData | Number of data items.
nKeys | Number of unique keys.
nPages | Page count.
OverflowPages | Overflow pages.
OverflowPagesFreeBytes | Bytes free in overflow pages.
PageSize | Page size.
Version | Version number.

See Also

BTreeStats Class


BTreeStats Methods

[image] [image]

Berkeley DB .NET API Documentation
BTreeStats Methods
BTreeStats Class See Also Send Feedback

The BTreeStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

BTreeStats Class


BTreeStats Properties

[image] [image]

Berkeley DB .NET API Documentation
BTreeStats Properties
BTreeStats Class See Also Send Feedback

The BTreeStats type exposes the following members.

Properties

Name | Description
DuplicatePages | Duplicate pages.
DuplicatePagesFreeBytes | Bytes free in duplicate pages.
EmptyPages | Empty pages.
FreePages | Pages on the free list.
InternalPages | Internal pages.
InternalPagesFreeBytes | Bytes free in internal pages.
LeafPages | Leaf pages.
LeafPagesFreeBytes | Bytes free in leaf pages.
Levels | Tree levels.
MagicNumber | Magic number.
MetadataFlags | Metadata flags.
MinKey | Minkey value.
nBlobRecords | Number of blob records.
nData | Number of data items.
nKeys | Number of unique keys.
nPages | Page count.
OverflowPages | Overflow pages.
OverflowPagesFreeBytes | Bytes free in overflow pages.
PageSize | Page size.
Version | Version number.

See Also

BTreeStats Class


DuplicatePages Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.DuplicatePages Property
BTreeStats Class See Also Send Feedback
Duplicate pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DuplicatePages { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuplicatePages As UInteger
Visual C++
public:
property unsigned int DuplicatePages {
    unsigned int get ();
}

See Also

BTreeStats Class


DuplicatePagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.DuplicatePagesFreeBytes Property
BTreeStats Class See Also Send Feedback
Bytes free in duplicate pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong DuplicatePagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuplicatePagesFreeBytes As ULong
Visual C++
public:
property unsigned long long DuplicatePagesFreeBytes {
    unsigned long long get ();
}

See Also

BTreeStats Class


EmptyPages Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.EmptyPages Property
BTreeStats Class See Also Send Feedback
Empty pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint EmptyPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmptyPages As UInteger
Visual C++
public:
property unsigned int EmptyPages {
    unsigned int get ();
}

See Also

BTreeStats Class


FreePages Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.FreePages Property
BTreeStats Class See Also Send Feedback
Pages on the free list.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FreePages { get; }
Visual Basic (Declaration)
Public ReadOnly Property FreePages As UInteger
Visual C++
public:
property unsigned int FreePages {
    unsigned int get ();
}

See Also

BTreeStats Class


InternalPages Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.InternalPages Property
BTreeStats Class See Also Send Feedback
Internal pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InternalPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalPages As UInteger
Visual C++
public:
property unsigned int InternalPages {
    unsigned int get ();
}

See Also

BTreeStats Class


InternalPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.InternalPagesFreeBytes Property
BTreeStats Class See Also Send Feedback
Bytes free in internal pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong InternalPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long InternalPagesFreeBytes {
    unsigned long long get ();
}

See Also

BTreeStats Class


LeafPages Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.LeafPages Property
BTreeStats Class See Also Send Feedback
Leaf pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LeafPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeafPages As UInteger
Visual C++
public:
property unsigned int LeafPages {
    unsigned int get ();
}

See Also

BTreeStats Class


LeafPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.LeafPagesFreeBytes Property
BTreeStats Class See Also Send Feedback
Bytes free in leaf pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LeafPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeafPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long LeafPagesFreeBytes {
    unsigned long long get ();
}

See Also

BTreeStats Class


Levels Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.Levels Property
BTreeStats Class See Also Send Feedback
Tree levels.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Levels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Levels As UInteger
Visual C++
public:
property unsigned int Levels {
    unsigned int get ();
}

See Also

BTreeStats Class


MagicNumber Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.MagicNumber Property
BTreeStats Class See Also Send Feedback
Magic number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MagicNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property MagicNumber As UInteger
Visual C++
public:
property unsigned int MagicNumber {
    unsigned int get ();
}

See Also

BTreeStats Class


MetadataFlags Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.MetadataFlags Property
BTreeStats Class See Also Send Feedback
Metadata flags.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MetadataFlags { get; }
Visual Basic (Declaration)
Public ReadOnly Property MetadataFlags As UInteger
Visual C++
public:
property unsigned int MetadataFlags {
    unsigned int get ();
}

See Also

BTreeStats Class


MinKey Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.MinKey Property
BTreeStats Class See Also Send Feedback
Minkey value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MinKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinKey As UInteger
Visual C++
public:
property unsigned int MinKey {
    unsigned int get ();
}

See Also

BTreeStats Class


nBlobRecords Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.nBlobRecords Property
BTreeStats Class See Also Send Feedback
Number of blob records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nBlobRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property nBlobRecords As UInteger
Visual C++
public:
property unsigned int nBlobRecords {
    unsigned int get ();
}

See Also

BTreeStats Class


nData Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.nData Property
BTreeStats Class See Also Send Feedback
Number of data items.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nData { get; }
Visual Basic (Declaration)
Public ReadOnly Property nData As UInteger
Visual C++
public:
property unsigned int nData {
    unsigned int get ();
}

See Also

BTreeStats Class


nKeys Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.nKeys Property
BTreeStats Class See Also Send Feedback
Number of unique keys.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property nKeys As UInteger
Visual C++
public:
property unsigned int nKeys {
    unsigned int get ();
}

See Also

BTreeStats Class


nPages Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.nPages Property
BTreeStats Class See Also Send Feedback
Page count.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property nPages As UInteger
Visual C++
public:
property unsigned int nPages {
    unsigned int get ();
}

See Also

BTreeStats Class


OverflowPages Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.OverflowPages Property
BTreeStats Class See Also Send Feedback
Overflow pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint OverflowPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowPages As UInteger
Visual C++
public:
property unsigned int OverflowPages {
    unsigned int get ();
}

See Also

BTreeStats Class


OverflowPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.OverflowPagesFreeBytes Property
BTreeStats Class See Also Send Feedback
Bytes free in overflow pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong OverflowPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long OverflowPagesFreeBytes {
    unsigned long long get ();
}

See Also

BTreeStats Class


PageSize Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.PageSize Property
BTreeStats Class See Also Send Feedback
Page size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As UInteger
Visual C++
public:
property unsigned int PageSize {
    unsigned int get ();
}

See Also

BTreeStats Class


Version Property

[image]

Berkeley DB .NET API Documentation
BTreeStats..::.Version Property
BTreeStats Class See Also Send Feedback
Version number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As UInteger
Visual C++
public:
property unsigned int Version {
    unsigned int get ();
}

See Also

BTreeStats Class


ByteOrder Class

[image]

Berkeley DB .NET API Documentation
ByteOrder Class
Members See Also Send Feedback
A class to represent the database byte order.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class ByteOrder
Visual Basic (Declaration)
Public Class ByteOrder
Visual C++
public ref class ByteOrder

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.ByteOrder

See Also

ByteOrder Members


ByteOrder Members

[image] [image]

Berkeley DB .NET API Documentation
ByteOrder Members
ByteOrder Class Methods Fields See Also Send Feedback

The ByteOrder type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FromConst | Convert from the integer constant used to represent byte order in the C library to its corresponding ByteOrder object.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
BIG_ENDIAN | Big endian byte order
LITTLE_ENDIAN | Little endian byte order
MACHINE | The host byte order of the machine where the Berkeley DB library was compiled.

See Also

ByteOrder Class


ByteOrder Fields

[image] [image]

Berkeley DB .NET API Documentation
ByteOrder Fields
ByteOrder Class See Also Send Feedback

The ByteOrder type exposes the following members.

Fields

Name | Description
BIG_ENDIAN | Big endian byte order
LITTLE_ENDIAN | Little endian byte order
MACHINE | The host byte order of the machine where the Berkeley DB library was compiled.

See Also

ByteOrder Class


BIG_ENDIAN Field

[image]

Berkeley DB .NET API Documentation
ByteOrder..::.BIG_ENDIAN Field
ByteOrder Class See Also Send Feedback
Big endian byte order

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static ByteOrder BIG_ENDIAN
Visual Basic (Declaration)
Public Shared BIG_ENDIAN As ByteOrder
Visual C++
public:
static ByteOrder^ BIG_ENDIAN

See Also

ByteOrder Class


LITTLE_ENDIAN Field

[image]

Berkeley DB .NET API Documentation
ByteOrder..::.LITTLE_ENDIAN Field
ByteOrder Class See Also Send Feedback
Little endian byte order

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static ByteOrder LITTLE_ENDIAN
Visual Basic (Declaration)
Public Shared LITTLE_ENDIAN As ByteOrder
Visual C++
public:
static ByteOrder^ LITTLE_ENDIAN

See Also

ByteOrder Class


MACHINE Field

[image]

Berkeley DB .NET API Documentation
ByteOrder..::.MACHINE Field
ByteOrder Class See Also Send Feedback
The host byte order of the machine where the Berkeley DB library was compiled.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static ByteOrder MACHINE
Visual Basic (Declaration)
Public Shared MACHINE As ByteOrder
Visual C++
public:
static ByteOrder^ MACHINE

See Also

ByteOrder Class


ByteOrder Methods

[image] [image]

Berkeley DB .NET API Documentation
ByteOrder Methods
ByteOrder Class See Also Send Feedback

The ByteOrder type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FromConst | Convert from the integer constant used to represent byte order in the C library to its corresponding ByteOrder object.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ByteOrder Class


FromConst Method

[image]

Berkeley DB .NET API Documentation
ByteOrder..::.FromConst Method
ByteOrder Class See Also Send Feedback
Convert from the integer constant used to represent byte order in the C library to its corresponding ByteOrder object.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static ByteOrder FromConst(
    int order
)
Visual Basic (Declaration)
Public Shared Function FromConst ( _
    order As Integer _
) As ByteOrder
Visual C++
public:
static ByteOrder^ FromConst(
    int order
)

Parameters

order
Type: System..::.Int32
The C library constant

Return Value

The ByteOrder object corresponding to the given constant

See Also

ByteOrder Class


CacheInfo Class

[image]

Berkeley DB .NET API Documentation
CacheInfo Class
Members See Also Send Feedback
A class to represent information about the Berkeley DB cache

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class CacheInfo
Visual Basic (Declaration)
Public Class CacheInfo
Visual C++
public ref class CacheInfo

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.CacheInfo

See Also

CacheInfo Members


CacheInfo Members

[image] [image]

Berkeley DB .NET API Documentation
CacheInfo Members
CacheInfo Class Constructors Methods Fields See Also Send Feedback

The CacheInfo type exposes the following members.

Constructors

Name | Description
CacheInfo | Create a new CacheInfo object. The size of the cache is set to gbytes gigabytes plus bytes and spread over numCaches separate caches.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Bytes | The number of bytes in the cache
Gigabytes | The number of gigabytes in the cache
NCaches | The number of caches

See Also

CacheInfo Class


CacheInfo Constructor

[image]

Berkeley DB .NET API Documentation
CacheInfo Constructor
CacheInfo Class See Also Send Feedback
Create a new CacheInfo object. The size of the cache is set to gbytes gigabytes plus bytes and spread over numCaches separate caches.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CacheInfo(
    uint gbytes,
    uint bytes,
    int numCaches
)
Visual Basic (Declaration)
Public Sub New ( _
    gbytes As UInteger, _
    bytes As UInteger, _
    numCaches As Integer _
)
Visual C++
public:
CacheInfo(
    unsigned int gbytes,
    unsigned int bytes,
    int numCaches
)

Parameters

gbytes
Type: System..::.UInt32
The number of gigabytes in the cache
bytes
Type: System..::.UInt32
The number of bytes in the cache
numCaches
Type: System..::.Int32
The number of caches

See Also

CacheInfo Class


CacheInfo Fields

[image] [image]

Berkeley DB .NET API Documentation
CacheInfo Fields
CacheInfo Class See Also Send Feedback

The CacheInfo type exposes the following members.

Fields

Name | Description
Bytes | The number of bytes in the cache
Gigabytes | The number of gigabytes in the cache
NCaches | The number of caches

See Also

CacheInfo Class


Bytes Field

[image]

Berkeley DB .NET API Documentation
CacheInfo..::.Bytes Field
CacheInfo Class See Also Send Feedback
The number of bytes in the cache

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Bytes
Visual Basic (Declaration)
Public Bytes As UInteger
Visual C++
public:
unsigned int Bytes

See Also

CacheInfo Class


Gigabytes Field

[image]

Berkeley DB .NET API Documentation
CacheInfo..::.Gigabytes Field
CacheInfo Class See Also Send Feedback
The number of gigabytes in the cache

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Gigabytes
Visual Basic (Declaration)
Public Gigabytes As UInteger
Visual C++
public:
unsigned int Gigabytes

See Also

CacheInfo Class


NCaches Field

[image]

Berkeley DB .NET API Documentation
CacheInfo..::.NCaches Field
CacheInfo Class See Also Send Feedback
The number of caches

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int NCaches
Visual Basic (Declaration)
Public NCaches As Integer
Visual C++
public:
int NCaches

See Also

CacheInfo Class


CacheInfo Methods

[image] [image]

Berkeley DB .NET API Documentation
CacheInfo Methods
CacheInfo Class See Also Send Feedback

The CacheInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CacheInfo Class


CachePriority Class

[image]

Berkeley DB .NET API Documentation
CachePriority Class
Members See Also Send Feedback
A class to represent cache priority for database pages

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class CachePriority
Visual Basic (Declaration)
Public Class CachePriority
Visual C++
public ref class CachePriority

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.CachePriority

See Also

CachePriority Members


CachePriority Members

[image] [image]

Berkeley DB .NET API Documentation
CachePriority Members
CachePriority Class Methods Fields See Also Send Feedback

The CachePriority type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
DEFAULT | The default priority.
HIGH | The next highest priority.
LOW | The next lowest priority.
VERY_HIGH | The highest priority: pages are the least likely to be discarded.
VERY_LOW | The lowest priority: pages are the most likely to be discarded.

See Also

CachePriority Class


CachePriority Fields

[image] [image]

Berkeley DB .NET API Documentation
CachePriority Fields
CachePriority Class See Also Send Feedback

The CachePriority type exposes the following members.

Fields

Name | Description
DEFAULT | The default priority.
HIGH | The next highest priority.
LOW | The next lowest priority.
VERY_HIGH | The highest priority: pages are the least likely to be discarded.
VERY_LOW | The lowest priority: pages are the most likely to be discarded.

See Also

CachePriority Class


DEFAULT Field

[image]

Berkeley DB .NET API Documentation
CachePriority..::.DEFAULT Field
CachePriority Class See Also Send Feedback
The default priority.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static CachePriority DEFAULT
Visual Basic (Declaration)
Public Shared DEFAULT As CachePriority
Visual C++
public:
static CachePriority^ DEFAULT

See Also

CachePriority Class


HIGH Field

[image]

Berkeley DB .NET API Documentation
CachePriority..::.HIGH Field
CachePriority Class See Also Send Feedback
The next highest priority.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static CachePriority HIGH
Visual Basic (Declaration)
Public Shared HIGH As CachePriority
Visual C++
public:
static CachePriority^ HIGH

See Also

CachePriority Class


LOW Field

[image]

Berkeley DB .NET API Documentation
CachePriority..::.LOW Field
CachePriority Class See Also Send Feedback
The next lowest priority.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static CachePriority LOW
Visual Basic (Declaration)
Public Shared LOW As CachePriority
Visual C++
public:
static CachePriority^ LOW

See Also

CachePriority Class


VERY_HIGH Field

[image]

Berkeley DB .NET API Documentation
CachePriority..::.VERY_HIGH Field
CachePriority Class See Also Send Feedback
The highest priority: pages are the least likely to be discarded.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static CachePriority VERY_HIGH
Visual Basic (Declaration)
Public Shared VERY_HIGH As CachePriority
Visual C++
public:
static CachePriority^ VERY_HIGH

See Also

CachePriority Class


VERY_LOW Field

[image]

Berkeley DB .NET API Documentation
CachePriority..::.VERY_LOW Field
CachePriority Class See Also Send Feedback
The lowest priority: pages are the most likely to be discarded.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static CachePriority VERY_LOW
Visual Basic (Declaration)
Public Shared VERY_LOW As CachePriority
Visual C++
public:
static CachePriority^ VERY_LOW

See Also

CachePriority Class


CachePriority Methods

[image] [image]

Berkeley DB .NET API Documentation
CachePriority Methods
CachePriority Class See Also Send Feedback

The CachePriority type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CachePriority Class


CompactConfig Class

[image]

Berkeley DB .NET API Documentation
CompactConfig Class
Members See Also Send Feedback
A class to represent configuration settings for Compact(CompactConfig) and Compact(CompactConfig).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class CompactConfig
Visual Basic (Declaration)
Public Class CompactConfig
Visual C++
public ref class CompactConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.CompactConfig

See Also

CompactConfig Members


CompactConfig Members

[image] [image]

Berkeley DB .NET API Documentation
CompactConfig Members
CompactConfig Class Constructors Methods Fields Properties See Also Send Feedback

The CompactConfig type exposes the following members.

Constructors

Name | Description
CompactConfig | Create a new CompactConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
returnEnd | Return the database key marking the end of the compaction operation in a Btree or Recno database. This is generally the first key of the page where the operation stopped.
start | If non-null, the starting point for compaction. For a Btree or Recno database compaction starts at the smallest key greater than or equal to the starting point. For a Hash database, compaction starts in the bucket specified by the integer stored in the starting point. If null, compaction starts at the beginning of the database.
stop | If non-null, the stopping point for compaction. For a Btree or Recno database compaction stops at the page with the smallest key greater than the stopping point. For a Hash database compaction stops in the bucket specified by the integer stored in the stopping point. If null, compaction stops at the end of the database.
TruncatePages | If true, return pages to the filesystem when possible. If false, pages emptied as a result of compaction are placed on the free list for re-use, but never returned to the filesystem.

Properties

Name | Description
FillPercentage | If non-zero, this provides the goal for filling pages, specified as a percentage between 1 and 100. Any page not at or above this percentage full is considered for compaction. The default behavior is to consider every page for compaction, regardless of its page fill percentage.
Pages | If non-zero, compaction completes after the specified number of pages have been freed.
Timeout | If non-zero, and no Transaction is specified, this parameter identifies the lock timeout used for implicit transactions, in microseconds.

See Also

CompactConfig Class


CompactConfig Constructor

[image]

Berkeley DB .NET API Documentation
CompactConfig Constructor
CompactConfig Class See Also Send Feedback
Create a new CompactConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CompactConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompactConfig()

See Also

CompactConfig Class


CompactConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
CompactConfig Fields
CompactConfig Class See Also Send Feedback

The CompactConfig type exposes the following members.

Fields

Name | Description
returnEnd | Return the database key marking the end of the compaction operation in a Btree or Recno database. This is generally the first key of the page where the operation stopped.
start | If non-null, the starting point for compaction. For a Btree or Recno database compaction starts at the smallest key greater than or equal to the starting point. For a Hash database, compaction starts in the bucket specified by the integer stored in the starting point. If null, compaction starts at the beginning of the database.
stop | If non-null, the stopping point for compaction. For a Btree or Recno database compaction stops at the page with the smallest key greater than the stopping point. For a Hash database compaction stops in the bucket specified by the integer stored in the stopping point. If null, compaction stops at the end of the database.
TruncatePages | If true, return pages to the filesystem when possible. If false, pages emptied as a result of compaction are placed on the free list for re-use, but never returned to the filesystem.

See Also

CompactConfig Class


returnEnd Field

[image]

Berkeley DB .NET API Documentation
CompactConfig..::.returnEnd Field
CompactConfig Class See Also Send Feedback
Return the database key marking the end of the compaction operation in a Btree or Recno database. This is generally the first key of the page where the operation stopped.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool returnEnd
Visual Basic (Declaration)
Public returnEnd As Boolean
Visual C++
public:
bool returnEnd

See Also

CompactConfig Class


start Field

[image]

Berkeley DB .NET API Documentation
CompactConfig..::.start Field
CompactConfig Class See Also Send Feedback
If non-null, the starting point for compaction. For a Btree or Recno database compaction starts at the smallest key greater than or equal to the starting point. For a Hash database, compaction starts in the bucket specified by the integer stored in the starting point. If null, compaction starts at the beginning of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry start
Visual Basic (Declaration)
Public start As DatabaseEntry
Visual C++
public:
DatabaseEntry^ start

See Also

CompactConfig Class


stop Field

[image]

Berkeley DB .NET API Documentation
CompactConfig..::.stop Field
CompactConfig Class See Also Send Feedback
If non-null, the stopping point for compaction. For a Btree or Recno database compaction stops at the page with the smallest key greater than the stopping point. For a Hash database compaction stops in the bucket specified by the integer stored in the stopping point. If null, compaction stops at the end of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry stop
Visual Basic (Declaration)
Public stop As DatabaseEntry
Visual C++
public:
DatabaseEntry^ stop

See Also

CompactConfig Class


TruncatePages Field

[image]

Berkeley DB .NET API Documentation
CompactConfig..::.TruncatePages Field
CompactConfig Class See Also Send Feedback
If true, return pages to the filesystem when possible. If false, pages emptied as a result of compaction are placed on the free list for re-use, but never returned to the filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TruncatePages
Visual Basic (Declaration)
Public TruncatePages As Boolean
Visual C++
public:
bool TruncatePages

Remarks

Only pages at the end of a file can be returned to the filesystem. Because of the one-pass nature of the compaction algorithm, any unemptied page near the end of the file inhibits returning pages to the file system. A repeated call to Compact(CompactConfig) or Compact(CompactConfig) with a low FillPercentage may be used to return pages in this case.

See Also

CompactConfig Class


CompactConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
CompactConfig Methods
CompactConfig Class See Also Send Feedback

The CompactConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CompactConfig Class


CompactConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
CompactConfig Properties
CompactConfig Class See Also Send Feedback

The CompactConfig type exposes the following members.

Properties

Name | Description
FillPercentage | If non-zero, this provides the goal for filling pages, specified as a percentage between 1 and 100. Any page not at or above this percentage full is considered for compaction. The default behavior is to consider every page for compaction, regardless of its page fill percentage.
Pages | If non-zero, compaction completes after the specified number of pages have been freed.
Timeout | If non-zero, and no Transaction is specified, this parameter identifies the lock timeout used for implicit transactions, in microseconds.

See Also

CompactConfig Class


FillPercentage Property

[image]

Berkeley DB .NET API Documentation
CompactConfig..::.FillPercentage Property
CompactConfig Class See Also Send Feedback
If non-zero, this provides the goal for filling pages, specified as a percentage between 1 and 100. Any page not at or above this percentage full is considered for compaction. The default behavior is to consider every page for compaction, regardless of its page fill percentage.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FillPercentage { get; set; }
Visual Basic (Declaration)
Public Property FillPercentage As UInteger
Visual C++
public:
property unsigned int FillPercentage {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

CompactConfig Class


Pages Property

[image]

Berkeley DB .NET API Documentation
CompactConfig..::.Pages Property
CompactConfig Class See Also Send Feedback
If non-zero, compaction completes after the specified number of pages have been freed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Pages { get; set; }
Visual Basic (Declaration)
Public Property Pages As UInteger
Visual C++
public:
property unsigned int Pages {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

CompactConfig Class


Timeout Property

[image]

Berkeley DB .NET API Documentation
CompactConfig..::.Timeout Property
CompactConfig Class See Also Send Feedback
If non-zero, and no Transaction is specified, this parameter identifies the lock timeout used for implicit transactions, in microseconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Timeout { get; set; }
Visual Basic (Declaration)
Public Property Timeout As UInteger
Visual C++
public:
property unsigned int Timeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

CompactConfig Class


CompactData Class

[image]

Berkeley DB .NET API Documentation
CompactData Class
Members See Also Send Feedback
A class for representing compact operation statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class CompactData
Visual Basic (Declaration)
Public Class CompactData
Visual C++
public ref class CompactData

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.CompactData

See Also

CompactData Members


CompactData Members

[image] [image]

Berkeley DB .NET API Documentation
CompactData Members
CompactData Class Methods Properties See Also Send Feedback

The CompactData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Deadlocks | If no Transaction parameter was specified, the number of deadlocks which occurred.
EmptyBuckets | The number of empty hash buckets that were found in the compaction phase.
End | The database key marking the end of the compaction operation. This is generally the first key of the page where the operation stopped and is only non-null if returnEnd was true.
Levels | The number of levels removed from the Btree or Recno database during the compaction phase.
PagesExamined | The number of database pages reviewed during the compaction phase.
PagesFreed | The number of database pages freed during the compaction phase.
PagesTruncated | The number of database pages returned to the filesystem.

See Also

CompactData Class


CompactData Methods

[image] [image]

Berkeley DB .NET API Documentation
CompactData Methods
CompactData Class See Also Send Feedback

The CompactData type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CompactData Class


CompactData Properties

[image] [image]

Berkeley DB .NET API Documentation
CompactData Properties
CompactData Class See Also Send Feedback

The CompactData type exposes the following members.

Properties

Name | Description
Deadlocks | If no Transaction parameter was specified, the number of deadlocks which occurred.
EmptyBuckets | The number of empty hash buckets that were found in the compaction phase.
End | The database key marking the end of the compaction operation. This is generally the first key of the page where the operation stopped and is only non-null if returnEnd was true.
Levels | The number of levels removed from the Btree or Recno database during the compaction phase.
PagesExamined | The number of database pages reviewed during the compaction phase.
PagesFreed | The number of database pages freed during the compaction phase.
PagesTruncated | The number of database pages returned to the filesystem.

See Also

CompactData Class


Deadlocks Property

[image]

Berkeley DB .NET API Documentation
CompactData..::.Deadlocks Property
CompactData Class See Also Send Feedback
If no Transaction parameter was specified, the number of deadlocks which occurred.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Deadlocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Deadlocks As UInteger
Visual C++
public:
property unsigned int Deadlocks {
    unsigned int get ();
}

See Also

CompactData Class


EmptyBuckets Property

[image]

Berkeley DB .NET API Documentation
CompactData..::.EmptyBuckets Property
CompactData Class See Also Send Feedback
The number of empty hash buckets that were found in the compaction phase.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint EmptyBuckets { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmptyBuckets As UInteger
Visual C++
public:
property unsigned int EmptyBuckets {
    unsigned int get ();
}

See Also

CompactData Class


End Property

[image]

Berkeley DB .NET API Documentation
CompactData..::.End Property
CompactData Class See Also Send Feedback
The database key marking the end of the compaction operation. This is generally the first key of the page where the operation stopped and is only non-null if returnEnd was true.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry End { get; }
Visual Basic (Declaration)
Public ReadOnly Property End As DatabaseEntry
Visual C++
public:
property DatabaseEntry^ End {
    DatabaseEntry^ get ();
}

See Also

CompactData Class


Levels Property

[image]

Berkeley DB .NET API Documentation
CompactData..::.Levels Property
CompactData Class See Also Send Feedback
The number of levels removed from the Btree or Recno database during the compaction phase.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Levels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Levels As UInteger
Visual C++
public:
property unsigned int Levels {
    unsigned int get ();
}

See Also

CompactData Class


PagesExamined Property

[image]

Berkeley DB .NET API Documentation
CompactData..::.PagesExamined Property
CompactData Class See Also Send Feedback
The number of database pages reviewed during the compaction phase.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PagesExamined { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesExamined As UInteger
Visual C++
public:
property unsigned int PagesExamined {
    unsigned int get ();
}

See Also

CompactData Class


PagesFreed Property

[image]

Berkeley DB .NET API Documentation
CompactData..::.PagesFreed Property
CompactData Class See Also Send Feedback
The number of database pages freed during the compaction phase.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PagesFreed { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesFreed As UInteger
Visual C++
public:
property unsigned int PagesFreed {
    unsigned int get ();
}

See Also

CompactData Class


PagesTruncated Property

[image]

Berkeley DB .NET API Documentation
CompactData..::.PagesTruncated Property
CompactData Class See Also Send Feedback
The number of database pages returned to the filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PagesTruncated { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesTruncated As UInteger
Visual C++
public:
property unsigned int PagesTruncated {
    unsigned int get ();
}

See Also

CompactData Class


CreatePolicy Enumeration

[image]

Berkeley DB .NET API Documentation
CreatePolicy Enumeration
See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum CreatePolicy
Visual Basic (Declaration)
Public Enumeration CreatePolicy
Visual C++
public enum class CreatePolicy

Members

Member name | Description
NEVER | Never create the database.
IF_NEEDED | Create the database if it does not already exist.
ALWAYS | Do not open the database and return an error if it already exists.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


Cursor Class

[image]

Berkeley DB .NET API Documentation
Cursor Class
Members See Also Send Feedback
A class representing database cursors, which allows for traversal of database records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class Cursor : BaseCursor, IDisposable,
    IEnumerable<KeyValuePair<DatabaseEntry, DatabaseEntry>>, IEnumerable
Visual Basic (Declaration)
Public Class Cursor _
    Inherits BaseCursor _
    Implements IDisposable, IEnumerable(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry)),  _
    IEnumerable
Visual C++
public ref class Cursor : public BaseCursor,
    IDisposable, IEnumerable<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>,
    IEnumerable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseCursor
BerkeleyDB..::.Cursor
BerkeleyDB..::.BTreeCursor
BerkeleyDB..::.HashCursor
BerkeleyDB..::.RecnoCursor

See Also

Cursor Members


Cursor Members

[image] [image]

Berkeley DB .NET API Documentation
Cursor Members
Cursor Class Methods Properties See Also Send Feedback

The Cursor type exposes the following members.

Methods

Name | Description
Add | Stores the key/data pair in the database.
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
Delete | Delete the key/data pair to which the cursor refers.
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Cursor.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Move | Overloaded.
MoveFirst | Overloaded.
MoveFirstMultiple | Overloaded. If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).
MoveFirstMultipleKey | Overloaded.
MoveLast | Overloaded.
MoveMultiple | Overloaded.
MoveMultipleKey | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextDuplicateMultiple | Overloaded.
MoveNextDuplicateMultipleKey | Overloaded.
MoveNextMultiple | Overloaded.
MoveNextMultipleKey | Overloaded.
MoveNextUnique | Overloaded.
MoveNextUniqueMultiple | Overloaded.
MoveNextUniqueMultipleKey | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Overwrite | Overwrite the data of the key/data pair to which the cursor refers with the specified data item.
Refresh | Overloaded.
RefreshMultiple | Overloaded.
RefreshMultipleKey | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Current | The key/data pair at which the cursor currently points.
CurrentMultiple | The key and multiple data items at which the cursor currently points.
CurrentMultipleKey | The multiple key and data items at which the cursor currently points.
Priority | The cache priority for pages referenced by the cursor.

See Also

Cursor Class


Cursor Methods

[image] [image]

Berkeley DB .NET API Documentation
Cursor Methods
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Methods

Name | Description
Add | Stores the key/data pair in the database.
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
Delete | Delete the key/data pair to which the cursor refers.
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Cursor.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Move | Overloaded.
MoveFirst | Overloaded.
MoveFirstMultiple | Overloaded. If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).
MoveFirstMultipleKey | Overloaded.
MoveLast | Overloaded.
MoveMultiple | Overloaded.
MoveMultipleKey | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextDuplicateMultiple | Overloaded.
MoveNextDuplicateMultipleKey | Overloaded.
MoveNextMultiple | Overloaded.
MoveNextMultipleKey | Overloaded.
MoveNextUnique | Overloaded.
MoveNextUniqueMultiple | Overloaded.
MoveNextUniqueMultipleKey | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Overwrite | Overwrite the data of the key/data pair to which the cursor refers with the specified data item.
Refresh | Overloaded.
RefreshMultiple | Overloaded.
RefreshMultipleKey | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Cursor Class


Add Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.Add Method
Cursor Class See Also Send Feedback
Stores the key/data pair in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Add(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair
)
Visual Basic (Declaration)
Public Sub Add ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry) _
)
Visual C++
public:
void Add(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair to be stored in the database.

Remarks

If the underlying database supports duplicate data items, and if the key already exists in the database and a duplicate sort function has been specified, the inserted data item is added in its sorted location. If the key already exists in the database and no duplicate sort function has been specified, the inserted data item is added as the first of the data items for that key.

See Also

Cursor Class


Delete Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.Delete Method
Cursor Class See Also Send Feedback
Delete the key/data pair to which the cursor refers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

Remarks

The cursor position is unchanged after a delete, and subsequent calls to cursor functions expecting the cursor to refer to an existing key will fail.

Exceptions

Exception | Condition
BerkeleyDB..::.KeyEmptyException | The element has already been deleted.

See Also

Cursor Class


Duplicate Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.Duplicate Method
Cursor Class See Also Send Feedback
Create a new cursor that uses the same transaction and locker ID as the original cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Cursor Duplicate(
    bool keepPosition
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    keepPosition As Boolean _
) As Cursor
Visual C++
public:
Cursor^ Duplicate(
    bool keepPosition
)

Parameters

keepPosition
Type: System..::.Boolean
If true, the newly created cursor is initialized to refer to the same position in the database as the original cursor (if any) and hold the same locks (if any). If false, or if the original cursor does not hold a database position and locks, the created cursor is uninitialized and behaves like a cursor newly created by Cursor()()().

Return Value

A newly created cursor

Remarks

This is useful when an application is using locking and requires two or more cursors in the same thread of control.

See Also

Cursor Class


GetEnumerator Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.GetEnumerator Method
Cursor Class See Also Send Feedback
Returns an enumerator that iterates through the Cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public IEnumerator<KeyValuePair<DatabaseEntry, DatabaseEntry>> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry))
Visual C++
public:
virtual IEnumerator<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>^ GetEnumerator() sealed

Return Value

An enumerator for the Cursor.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

Remarks

The enumerator begins at the cursor's current position (or the first record if the cursor has not yet been positioned) and iterate forwards (i.e. in the direction of MoveNext()()()) over the remaining records.

See Also

Cursor Class


Move Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.Move Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
Move(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current.
Move(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
Move(DatabaseEntry, DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned.
Move(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current.
Move(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
Move(DatabaseEntry, DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


Move Method (DatabaseEntry, Boolean)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Move Method (DatabaseEntry, Boolean)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    DatabaseEntry key,
    bool exact
)
Visual Basic (Declaration)
Public Function Move ( _
    key As DatabaseEntry, _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool Move(
    DatabaseEntry^ key,
    bool exact
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If true, require the given key to match the key in the database exactly. If false, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
Move Overload


Move Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Move Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact
)
Visual Basic (Declaration)
Public Function Move ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool Move(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If true, require the given key and data to match the key and data in the database exactly. If false, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function).

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

If this flag is specified on a database configured without sorted duplicate support, the value of exact is ignored.

See Also

Cursor Class
Move Overload


Move Method (DatabaseEntry, DatabaseEntry, Boolean)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Move Method (DatabaseEntry, DatabaseEntry, Boolean)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    DatabaseEntry key,
    DatabaseEntry data,
    bool exact
)
Visual Basic (Declaration)
Public Function Move ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool Move(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    bool exact
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
exact
Type: System..::.Boolean
If true, require the given key to match the key in the database exactly. If false, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
Move Overload


Move Method (DatabaseEntry, Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Move Method (DatabaseEntry, Boolean, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    DatabaseEntry key,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Move ( _
    key As DatabaseEntry, _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Move(
    DatabaseEntry^ key,
    bool exact,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If true, require the given key to match the key in the database exactly. If false, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
Move Overload


Move Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Move Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Move ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Move(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact,
    LockingInfo^ info
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If true, require the given key and data to match the key and data in the database exactly. If false, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function).
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

If this flag is specified on a database configured without sorted duplicate support, the value of exact is ignored.

See Also

Cursor Class
Move Overload


Move Method (DatabaseEntry, DatabaseEntry, Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Move Method (DatabaseEntry, DatabaseEntry, Boolean, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    DatabaseEntry key,
    DatabaseEntry data,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Move ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Move(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    bool exact,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
exact
Type: System..::.Boolean
If true, require the given key to match the key in the database exactly. If false, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
Move Overload


MoveFirst Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirst Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirst()()() | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current.
MoveFirst(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current.
MoveFirst(DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned.
MoveFirst(DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


MoveFirst Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirst Method
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirst()
Visual Basic (Declaration)
Public Function MoveFirst As Boolean
Visual C++
public:
bool MoveFirst()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveFirst Overload


MoveFirst Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirst Method (LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirst(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveFirst ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveFirst(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveFirst Overload


MoveFirst Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirst Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirst(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveFirst ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveFirst(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveFirst Overload


MoveFirst Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirst Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirst(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveFirst ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveFirst(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveFirst Overload


MoveFirstMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultiple Method
Cursor Class See Also Send Feedback
If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

Overload List

Name | Description
MoveFirstMultiple()()() | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.
MoveFirstMultiple(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.
MoveFirstMultiple(Int32) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple.
MoveFirstMultiple(Int32, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple.

See Also

Cursor Class
Cursor Members


MoveFirstMultiple Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultiple Method
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirstMultiple()
Visual Basic (Declaration)
Public Function MoveFirstMultiple As Boolean
Visual C++
public:
bool MoveFirstMultiple()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveFirstMultiple Overload


MoveFirstMultiple Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultiple Method (LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirstMultiple(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveFirstMultiple ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveFirstMultiple(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveFirstMultiple Overload


MoveFirstMultiple Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultiple Method (Int32)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirstMultiple(
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveFirstMultiple ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveFirstMultiple(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveFirstMultiple Overload


MoveFirstMultiple Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultiple Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirstMultiple(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveFirstMultiple ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveFirstMultiple(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveFirstMultiple Overload


MoveFirstMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultipleKey Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirstMultipleKey()()() | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
MoveFirstMultipleKey(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
MoveFirstMultipleKey(Int32) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.
MoveFirstMultipleKey(Int32, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.

See Also

Cursor Class
Cursor Members


MoveFirstMultipleKey Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultipleKey Method
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirstMultipleKey()
Visual Basic (Declaration)
Public Function MoveFirstMultipleKey As Boolean
Visual C++
public:
bool MoveFirstMultipleKey()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveFirstMultipleKey Overload


MoveFirstMultipleKey Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultipleKey Method (LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirstMultipleKey(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveFirstMultipleKey ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveFirstMultipleKey(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveFirstMultipleKey Overload


MoveFirstMultipleKey Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultipleKey Method (Int32)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirstMultipleKey(
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveFirstMultipleKey ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveFirstMultipleKey(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveFirstMultipleKey Overload


MoveFirstMultipleKey Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveFirstMultipleKey Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirstMultipleKey(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveFirstMultipleKey ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveFirstMultipleKey(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveFirstMultipleKey Overload


MoveLast Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveLast Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveLast()()() | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current.
MoveLast(LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current.
MoveLast(DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned.
MoveLast(DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


MoveLast Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveLast Method
Cursor Class See Also Send Feedback
Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveLast()
Visual Basic (Declaration)
Public Function MoveLast As Boolean
Visual C++
public:
bool MoveLast()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveLast Overload


MoveLast Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveLast Method (LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveLast(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveLast ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveLast(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveLast Overload


MoveLast Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveLast Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveLast(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveLast ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveLast(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveLast Overload


MoveLast Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveLast Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveLast(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveLast ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveLast(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveLast Overload


MoveMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveMultiple(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple.
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
MoveMultiple(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple.
MoveMultiple(DatabaseEntry, Boolean, Int32) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple.
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
MoveMultiple(DatabaseEntry, Boolean, Int32, LockingInfo) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple.
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

See Also

Cursor Class
Cursor Members


MoveMultiple Method (DatabaseEntry, Boolean)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method (DatabaseEntry, Boolean)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    DatabaseEntry key,
    bool exact
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    key As DatabaseEntry, _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    DatabaseEntry^ key,
    bool exact
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultiple Overload


MoveMultiple Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultiple Overload


MoveMultiple Method (DatabaseEntry, Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method (DatabaseEntry, Boolean, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    DatabaseEntry key,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    key As DatabaseEntry, _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    DatabaseEntry^ key,
    bool exact,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultiple Overload


MoveMultiple Method (DatabaseEntry, Boolean, Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method (DatabaseEntry, Boolean, Int32)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    DatabaseEntry key,
    bool exact,
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    key As DatabaseEntry, _
    exact As Boolean, _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    DatabaseEntry^ key,
    bool exact,
    int BufferSize
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultiple Overload


MoveMultiple Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact,
    LockingInfo^ info
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultiple Overload


MoveMultiple Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean, Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact,
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean, _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact,
    int BufferSize
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultiple Overload


MoveMultiple Method (DatabaseEntry, Boolean, Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method (DatabaseEntry, Boolean, Int32, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    DatabaseEntry key,
    bool exact,
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    key As DatabaseEntry, _
    exact As Boolean, _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    DatabaseEntry^ key,
    bool exact,
    int BufferSize,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultiple Overload


MoveMultiple Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean, Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultiple Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultiple(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact,
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultiple ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean, _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultiple(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact,
    int BufferSize,
    LockingInfo^ info
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultiple Overload


MoveMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveMultipleKey(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
MoveMultipleKey(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
MoveMultipleKey(DatabaseEntry, Boolean, Int32) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
MoveMultipleKey(DatabaseEntry, Boolean, Int32, LockingInfo) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

See Also

Cursor Class
Cursor Members


MoveMultipleKey Method (DatabaseEntry, Boolean)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method (DatabaseEntry, Boolean)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    DatabaseEntry key,
    bool exact
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    key As DatabaseEntry, _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    DatabaseEntry^ key,
    bool exact
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (DatabaseEntry, Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method (DatabaseEntry, Boolean, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    DatabaseEntry key,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    key As DatabaseEntry, _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    DatabaseEntry^ key,
    bool exact,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (DatabaseEntry, Boolean, Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method (DatabaseEntry, Boolean, Int32)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    DatabaseEntry key,
    bool exact,
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    key As DatabaseEntry, _
    exact As Boolean, _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    DatabaseEntry^ key,
    bool exact,
    int BufferSize
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact,
    LockingInfo^ info
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean, Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact,
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean, _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact,
    int BufferSize
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (DatabaseEntry, Boolean, Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method (DatabaseEntry, Boolean, Int32, LockingInfo)
Cursor Class See Also Send Feedback
Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    DatabaseEntry key,
    bool exact,
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    key As DatabaseEntry, _
    exact As Boolean, _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    DatabaseEntry^ key,
    bool exact,
    int BufferSize,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultipleKey Overload


MoveMultipleKey Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Boolean, Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveMultipleKey Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo)
Cursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveMultipleKey(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    bool exact,
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveMultipleKey ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    exact As Boolean, _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveMultipleKey(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    bool exact,
    int BufferSize,
    LockingInfo^ info
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.
BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveMultipleKey Overload


MoveNext Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNext Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNext()()() | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.
MoveNext(LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.
MoveNext(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned.
MoveNext(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


MoveNext Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNext Method
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext()
Visual Basic (Declaration)
Public Function MoveNext As Boolean
Visual C++
public:
bool MoveNext()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNext Overload


MoveNext Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNext Method (LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNext ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNext(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNext Overload


MoveNext Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNext Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveNext ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveNext(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNext Overload


MoveNext Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNext Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNext ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNext(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNext Overload


MoveNextDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicate Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicate()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicate(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicate(DatabaseEntry, DatabaseEntry) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned.
MoveNextDuplicate(DatabaseEntry, DatabaseEntry, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


MoveNextDuplicate Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicate Method
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicate()
Visual Basic (Declaration)
Public Function MoveNextDuplicate As Boolean
Visual C++
public:
bool MoveNextDuplicate()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNextDuplicate Overload


MoveNextDuplicate Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicate Method (LockingInfo)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicate(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextDuplicate ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextDuplicate(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNextDuplicate Overload


MoveNextDuplicate Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicate Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicate(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveNextDuplicate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveNextDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNextDuplicate Overload


MoveNextDuplicate Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicate Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicate(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextDuplicate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNextDuplicate Overload


MoveNextDuplicateMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultiple Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicateMultiple()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicateMultiple(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicateMultiple(Int32) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, then move cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicateMultiple(Int32, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

See Also

Cursor Class
Cursor Members


MoveNextDuplicateMultiple Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultiple Method
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicateMultiple()
Visual Basic (Declaration)
Public Function MoveNextDuplicateMultiple As Boolean
Visual C++
public:
bool MoveNextDuplicateMultiple()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextDuplicateMultiple Overload


MoveNextDuplicateMultiple Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultiple Method (LockingInfo)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicateMultiple(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextDuplicateMultiple ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextDuplicateMultiple(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextDuplicateMultiple Overload


MoveNextDuplicateMultiple Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultiple Method (Int32)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, then move cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicateMultiple(
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveNextDuplicateMultiple ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveNextDuplicateMultiple(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextDuplicateMultiple Overload


MoveNextDuplicateMultiple Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultiple Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicateMultiple(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextDuplicateMultiple ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextDuplicateMultiple(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextDuplicateMultiple Overload


MoveNextDuplicateMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultipleKey Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicateMultipleKey()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicateMultipleKey(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicateMultipleKey(Int32) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicateMultipleKey(Int32, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

See Also

Cursor Class
Cursor Members


MoveNextDuplicateMultipleKey Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultipleKey Method
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicateMultipleKey()
Visual Basic (Declaration)
Public Function MoveNextDuplicateMultipleKey As Boolean
Visual C++
public:
bool MoveNextDuplicateMultipleKey()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextDuplicateMultipleKey Overload


MoveNextDuplicateMultipleKey Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultipleKey Method (LockingInfo)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicateMultipleKey(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextDuplicateMultipleKey ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextDuplicateMultipleKey(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextDuplicateMultipleKey Overload


MoveNextDuplicateMultipleKey Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultipleKey Method (Int32)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicateMultipleKey(
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveNextDuplicateMultipleKey ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveNextDuplicateMultipleKey(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextDuplicateMultipleKey Overload


MoveNextDuplicateMultipleKey Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextDuplicateMultipleKey Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicateMultipleKey(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextDuplicateMultipleKey ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextDuplicateMultipleKey(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextDuplicateMultipleKey Overload


MoveNextMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultiple Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextMultiple()()() | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change.
MoveNextMultiple(LockingInfo) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change.
MoveNextMultiple(Int32) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change.
MoveNextMultiple(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change.

See Also

Cursor Class
Cursor Members


MoveNextMultiple Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultiple Method
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextMultiple()
Visual Basic (Declaration)
Public Function MoveNextMultiple As Boolean
Visual C++
public:
bool MoveNextMultiple()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextMultiple Overload


MoveNextMultiple Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultiple Method (LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextMultiple(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextMultiple ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextMultiple(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextMultiple Overload


MoveNextMultiple Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultiple Method (Int32)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextMultiple(
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveNextMultiple ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveNextMultiple(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextMultiple Overload


MoveNextMultiple Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultiple Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextMultiple(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextMultiple ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextMultiple(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextMultiple Overload


MoveNextMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultipleKey Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextMultipleKey()()() | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change.
MoveNextMultipleKey(LockingInfo) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change.
MoveNextMultipleKey(Int32) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change.
MoveNextMultipleKey(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change.

See Also

Cursor Class
Cursor Members


MoveNextMultipleKey Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultipleKey Method
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextMultipleKey()
Visual Basic (Declaration)
Public Function MoveNextMultipleKey As Boolean
Visual C++
public:
bool MoveNextMultipleKey()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextMultipleKey Overload


MoveNextMultipleKey Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultipleKey Method (LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextMultipleKey(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextMultipleKey ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextMultipleKey(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextMultipleKey Overload


MoveNextMultipleKey Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultipleKey Method (Int32)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextMultipleKey(
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveNextMultipleKey ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveNextMultipleKey(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextMultipleKey Overload


MoveNextMultipleKey Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextMultipleKey Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextMultipleKey(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextMultipleKey ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextMultipleKey(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextMultipleKey Overload


MoveNextUnique Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUnique Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUnique()()() | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUnique(LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUnique(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned.
MoveNextUnique(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


MoveNextUnique Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUnique Method
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUnique()
Visual Basic (Declaration)
Public Function MoveNextUnique As Boolean
Visual C++
public:
bool MoveNextUnique()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNextUnique Overload


MoveNextUnique Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUnique Method (LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUnique(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextUnique ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextUnique(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If the database is a Queue or Recno database, MoveNextUnique ignores any keys that exist but were never explicitly created by the application, or those that were created and later deleted.

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNextUnique Overload


MoveNextUnique Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUnique Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUnique(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveNextUnique ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveNextUnique(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If the database is a Queue or Recno database, MoveNextUnique ignores any keys that exist but were never explicitly created by the application, or those that were created and later deleted.

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNextUnique Overload


MoveNextUnique Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUnique Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUnique(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextUnique ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextUnique(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If the database is a Queue or Recno database, MoveNextUnique ignores any keys that exist but were never explicitly created by the application, or those that were created and later deleted.

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MoveNextUnique Overload


MoveNextUniqueMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultiple Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUniqueMultiple()()() | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUniqueMultiple(LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUniqueMultiple(Int32) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUniqueMultiple(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

See Also

Cursor Class
Cursor Members


MoveNextUniqueMultiple Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultiple Method
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUniqueMultiple()
Visual Basic (Declaration)
Public Function MoveNextUniqueMultiple As Boolean
Visual C++
public:
bool MoveNextUniqueMultiple()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextUniqueMultiple Overload


MoveNextUniqueMultiple Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultiple Method (LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUniqueMultiple(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextUniqueMultiple ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextUniqueMultiple(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextUniqueMultiple Overload


MoveNextUniqueMultiple Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultiple Method (Int32)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUniqueMultiple(
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveNextUniqueMultiple ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveNextUniqueMultiple(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextUniqueMultiple Overload


MoveNextUniqueMultiple Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultiple Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUniqueMultiple(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextUniqueMultiple ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextUniqueMultiple(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextUniqueMultiple Overload


MoveNextUniqueMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultipleKey Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUniqueMultipleKey()()() | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUniqueMultipleKey(LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUniqueMultipleKey(Int32) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUniqueMultipleKey(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

See Also

Cursor Class
Cursor Members


MoveNextUniqueMultipleKey Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultipleKey Method
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUniqueMultipleKey()
Visual Basic (Declaration)
Public Function MoveNextUniqueMultipleKey As Boolean
Visual C++
public:
bool MoveNextUniqueMultipleKey()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextUniqueMultipleKey Overload


MoveNextUniqueMultipleKey Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultipleKey Method (LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUniqueMultipleKey(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextUniqueMultipleKey ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextUniqueMultipleKey(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextUniqueMultipleKey Overload


MoveNextUniqueMultipleKey Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultipleKey Method (Int32)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUniqueMultipleKey(
    int BufferSize
)
Visual Basic (Declaration)
Public Function MoveNextUniqueMultipleKey ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool MoveNextUniqueMultipleKey(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextUniqueMultipleKey Overload


MoveNextUniqueMultipleKey Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MoveNextUniqueMultipleKey Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUniqueMultipleKey(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextUniqueMultipleKey ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextUniqueMultipleKey(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
MoveNextUniqueMultipleKey Overload


MovePrev Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrev Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MovePrev()()() | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.
MovePrev(LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.
MovePrev(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned.
MovePrev(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


MovePrev Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrev Method
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrev()
Visual Basic (Declaration)
Public Function MovePrev As Boolean
Visual C++
public:
bool MovePrev()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrev Overload


MovePrev Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrev Method (LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrev(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrev ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrev(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrev Overload


MovePrev Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrev Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrev(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MovePrev ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MovePrev(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrev Overload


MovePrev Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrev Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrev(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrev ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrev(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrev Overload


MovePrevDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevDuplicate Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevDuplicate()()() | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair.
MovePrevDuplicate(LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair.
MovePrevDuplicate(DatabaseEntry, DatabaseEntry) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned.
MovePrevDuplicate(DatabaseEntry, DatabaseEntry, LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


MovePrevDuplicate Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevDuplicate Method
Cursor Class See Also Send Feedback
If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevDuplicate()
Visual Basic (Declaration)
Public Function MovePrevDuplicate As Boolean
Visual C++
public:
bool MovePrevDuplicate()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrevDuplicate Overload


MovePrevDuplicate Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevDuplicate Method (LockingInfo)
Cursor Class See Also Send Feedback
If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevDuplicate(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrevDuplicate ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrevDuplicate(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrevDuplicate Overload


MovePrevDuplicate Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevDuplicate Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevDuplicate(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MovePrevDuplicate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MovePrevDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrevDuplicate Overload


MovePrevDuplicate Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevDuplicate Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevDuplicate(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrevDuplicate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrevDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrevDuplicate Overload


MovePrevUnique Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevUnique Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevUnique()()() | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MovePrevUnique(LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MovePrevUnique(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if ntheo non-duplicate key/data pairs exist after the cursor position in database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned.
MovePrevUnique(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


MovePrevUnique Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevUnique Method
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevUnique()
Visual Basic (Declaration)
Public Function MovePrevUnique As Boolean
Visual C++
public:
bool MovePrevUnique()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrevUnique Overload


MovePrevUnique Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevUnique Method (LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevUnique(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrevUnique ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrevUnique(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrevUnique Overload


MovePrevUnique Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevUnique Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if ntheo non-duplicate key/data pairs exist after the cursor position in database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevUnique(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MovePrevUnique ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MovePrevUnique(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrevUnique Overload


MovePrevUnique Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.MovePrevUnique Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevUnique(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrevUnique ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrevUnique(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
MovePrevUnique Overload


Overwrite Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.Overwrite Method
Cursor Class See Also Send Feedback
Overwrite the data of the key/data pair to which the cursor refers with the specified data item.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Overwrite(
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Sub Overwrite ( _
    data As DatabaseEntry _
)
Visual C++
public:
void Overwrite(
    DatabaseEntry^ data
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry

See Also

Cursor Class


Refresh Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.Refresh Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
Refresh()()() | Store the key/data pair to which the cursor refers in Current.
Refresh(LockingInfo) | Store the key/data pair to which the cursor refers in Current.
Refresh(DatabaseEntry, DatabaseEntry) | Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned.
Refresh(DatabaseEntry, DatabaseEntry, LockingInfo) | Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned.

See Also

Cursor Class
Cursor Members


Refresh Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.Refresh Method
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Refresh()
Visual Basic (Declaration)
Public Function Refresh As Boolean
Visual C++
public:
bool Refresh()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
Refresh Overload


Refresh Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Refresh Method (LockingInfo)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Refresh(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Refresh ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Refresh(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
Refresh Overload


Refresh Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Refresh Method (DatabaseEntry, DatabaseEntry)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Refresh(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function Refresh ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool Refresh(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
Refresh Overload


Refresh Method (DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.Refresh Method (DatabaseEntry, DatabaseEntry, LockingInfo)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Refresh(
    DatabaseEntry key,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Refresh ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Refresh(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

Cursor Class
Refresh Overload


RefreshMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultiple Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
RefreshMultiple()()() | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.
RefreshMultiple(LockingInfo) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.
RefreshMultiple(Int32) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple.
RefreshMultiple(Int32, LockingInfo) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple.

See Also

Cursor Class
Cursor Members


RefreshMultiple Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultiple Method
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RefreshMultiple()
Visual Basic (Declaration)
Public Function RefreshMultiple As Boolean
Visual C++
public:
bool RefreshMultiple()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
RefreshMultiple Overload


RefreshMultiple Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultiple Method (LockingInfo)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RefreshMultiple(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function RefreshMultiple ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool RefreshMultiple(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
RefreshMultiple Overload


RefreshMultiple Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultiple Method (Int32)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RefreshMultiple(
    int BufferSize
)
Visual Basic (Declaration)
Public Function RefreshMultiple ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool RefreshMultiple(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
RefreshMultiple Overload


RefreshMultiple Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultiple Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RefreshMultiple(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function RefreshMultiple ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool RefreshMultiple(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with duplicate data items. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
RefreshMultiple Overload


RefreshMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultipleKey Method
Cursor Class See Also Send Feedback

Overload List

Name | Description
RefreshMultipleKey()()() | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
RefreshMultipleKey(LockingInfo) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.
RefreshMultipleKey(Int32) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.
RefreshMultipleKey(Int32, LockingInfo) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.

See Also

Cursor Class
Cursor Members


RefreshMultipleKey Method

[image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultipleKey Method
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RefreshMultipleKey()
Visual Basic (Declaration)
Public Function RefreshMultipleKey As Boolean
Visual C++
public:
bool RefreshMultipleKey()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
RefreshMultipleKey Overload


RefreshMultipleKey Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultipleKey Method (LockingInfo)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RefreshMultipleKey(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function RefreshMultipleKey ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool RefreshMultipleKey(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
RefreshMultipleKey Overload


RefreshMultipleKey Method (Int32)

[image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultipleKey Method (Int32)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RefreshMultipleKey(
    int BufferSize
)
Visual Basic (Declaration)
Public Function RefreshMultipleKey ( _
    BufferSize As Integer _
) As Boolean
Visual C++
public:
bool RefreshMultipleKey(
    int BufferSize
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
RefreshMultipleKey Overload


RefreshMultipleKey Method (Int32, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Cursor..::.RefreshMultipleKey Method (Int32, LockingInfo)
Cursor Class See Also Send Feedback
Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RefreshMultipleKey(
    int BufferSize,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function RefreshMultipleKey ( _
    BufferSize As Integer, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool RefreshMultipleKey(
    int BufferSize,
    LockingInfo^ info
)

Parameters

BufferSize
Type: System..::.Int32
The size of a buffer to fill with key/data pairs. Must be at least the page size of the underlying database and be a multiple of 1024.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

Cursor Class
RefreshMultipleKey Overload


Cursor Properties

[image] [image]

Berkeley DB .NET API Documentation
Cursor Properties
Cursor Class See Also Send Feedback

The Cursor type exposes the following members.

Properties

Name | Description
Current | The key/data pair at which the cursor currently points.
CurrentMultiple | The key and multiple data items at which the cursor currently points.
CurrentMultipleKey | The multiple key and data items at which the cursor currently points.
Priority | The cache priority for pages referenced by the cursor.

See Also

Cursor Class


Current Property

[image]

Berkeley DB .NET API Documentation
Cursor..::.Current Property
Cursor Class See Also Send Feedback
The key/data pair at which the cursor currently points.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Current { get; private set; }
Visual Basic (Declaration)
Public Property Current As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
property KeyValuePair<DatabaseEntry^, DatabaseEntry^> Current {
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> get ();
    void set (KeyValuePair<DatabaseEntry^, DatabaseEntry^> value);
}

Remarks

Only one of Current, CurrentMultiple and CurrentMultipleKey is ever non-empty.

See Also

Cursor Class


CurrentMultiple Property

[image]

Berkeley DB .NET API Documentation
Cursor..::.CurrentMultiple Property
Cursor Class See Also Send Feedback
The key and multiple data items at which the cursor currently points.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> CurrentMultiple { get; private set; }
Visual Basic (Declaration)
Public Property CurrentMultiple As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
property KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> CurrentMultiple {
    KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> get ();
    void set (KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> value);
}

Remarks

Only one of Current, CurrentMultiple and CurrentMultipleKey is ever non-empty.

See Also

Cursor Class


CurrentMultipleKey Property

[image]

Berkeley DB .NET API Documentation
Cursor..::.CurrentMultipleKey Property
Cursor Class See Also Send Feedback
The multiple key and data items at which the cursor currently points.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MultipleKeyDatabaseEntry CurrentMultipleKey { get; private set; }
Visual Basic (Declaration)
Public Property CurrentMultipleKey As MultipleKeyDatabaseEntry
Visual C++
public:
property MultipleKeyDatabaseEntry^ CurrentMultipleKey {
    MultipleKeyDatabaseEntry^ get ();
    void set (MultipleKeyDatabaseEntry^ value);
}

Remarks

Only one of Current, CurrentMultiple and CurrentMultipleKey is ever non-empty.

See Also

Cursor Class


Priority Property

[image]

Berkeley DB .NET API Documentation
Cursor..::.Priority Property
Cursor Class See Also Send Feedback
The cache priority for pages referenced by the cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CachePriority Priority { get; set; }
Visual Basic (Declaration)
Public Property Priority As CachePriority
Visual C++
public:
property CachePriority^ Priority {
    CachePriority^ get ();
    void set (CachePriority^ value);
}

Remarks

The priority of a page biases the replacement algorithm to be more or less likely to discard a page when space is needed in the buffer pool. The bias is temporary, and pages are eventually discarded if they are not referenced again. The setting is only advisory, and does not guarantee pages are treated in a specific way.

See Also

Cursor Class


Cursor.InsertLocation Enumeration

[image]

Berkeley DB .NET API Documentation
Cursor..::.InsertLocation Enumeration
Cursor Class See Also Send Feedback
Specifies where to place duplicate data elements of the key to which the cursor refers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum InsertLocation
Visual Basic (Declaration)
Public Enumeration InsertLocation
Visual C++
public enum class InsertLocation

Members

Member name | Description
AFTER | The new element appears immediately after the current cursor position.
BEFORE | The new element appears immediately before the current cursor position.
FIRST | The new element appears as the first of the data items for the given key
LAST | The new element appears as the last of the data items for the given key

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


CursorConfig Class

[image]

Berkeley DB .NET API Documentation
CursorConfig Class
Members See Also Send Feedback
A class representing configuration parameters for Cursor

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class CursorConfig
Visual Basic (Declaration)
Public Class CursorConfig
Visual C++
public ref class CursorConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.CursorConfig

See Also

CursorConfig Members


CursorConfig Members

[image] [image]

Berkeley DB .NET API Documentation
CursorConfig Members
CursorConfig Class Constructors Methods Fields See Also Send Feedback

The CursorConfig type exposes the following members.

Constructors

Name | Description
CursorConfig | Instantiate a new CursorConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
IsolationDegree | The isolation degree that the cursor should use.
Priority | The cache priority for pages referenced by the cursor.
SnapshotIsolation | Configure a transactional cursor to operate with read-only snapshot isolation. For databases with UseMVCC set, data values are read as they are when the cursor is opened, without taking read locks. This setting implicitly begins a transaction that is committed when the cursor is closed. This setting is silently ignored if UseMVCC is not set on the underlying database or if a transaction is supplied to Cursor()()()
WriteCursor | If true, specify that the cursor is used to update the database. The underlying database environment must have been opened with UseCDB set.

See Also

CursorConfig Class


CursorConfig Constructor

[image]

Berkeley DB .NET API Documentation
CursorConfig Constructor
CursorConfig Class See Also Send Feedback
Instantiate a new CursorConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CursorConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CursorConfig()

See Also

CursorConfig Class


CursorConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
CursorConfig Fields
CursorConfig Class See Also Send Feedback

The CursorConfig type exposes the following members.

Fields

Name | Description
IsolationDegree | The isolation degree that the cursor should use.
Priority | The cache priority for pages referenced by the cursor.
SnapshotIsolation | Configure a transactional cursor to operate with read-only snapshot isolation. For databases with UseMVCC set, data values are read as they are when the cursor is opened, without taking read locks. This setting implicitly begins a transaction that is committed when the cursor is closed. This setting is silently ignored if UseMVCC is not set on the underlying database or if a transaction is supplied to Cursor()()()
WriteCursor | If true, specify that the cursor is used to update the database. The underlying database environment must have been opened with UseCDB set.

See Also

CursorConfig Class


IsolationDegree Field

[image]

Berkeley DB .NET API Documentation
CursorConfig..::.IsolationDegree Field
CursorConfig Class See Also Send Feedback
The isolation degree that the cursor should use.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Isolation IsolationDegree
Visual Basic (Declaration)
Public IsolationDegree As Isolation
Visual C++
public:
Isolation IsolationDegree

Remarks

DEGREE_TWO ensures the stability of the current data item read by this cursor but permits data read by this cursor to be modified or deleted prior to the commit of the transaction for this cursor.

DEGREE_ONE allows read operations performed by the cursor to return modified but not yet committed data. Silently ignored if the ReadUncommitted was not specified when the underlying database was opened.

See Also

CursorConfig Class


Priority Field

[image]

Berkeley DB .NET API Documentation
CursorConfig..::.Priority Field
CursorConfig Class See Also Send Feedback
The cache priority for pages referenced by the cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CachePriority Priority
Visual Basic (Declaration)
Public Priority As CachePriority
Visual C++
public:
CachePriority^ Priority

Remarks

The priority of a page biases the replacement algorithm to be more or less likely to discard a page when space is needed in the buffer pool. The bias is temporary, and pages are eventually discarded if they are not referenced again. The setting is only advisory, and does not guarantee pages will be treated in a specific way.

See Also

CursorConfig Class


SnapshotIsolation Field

[image]

Berkeley DB .NET API Documentation
CursorConfig..::.SnapshotIsolation Field
CursorConfig Class See Also Send Feedback

Configure a transactional cursor to operate with read-only snapshot isolation. For databases with UseMVCC set, data values are read as they are when the cursor is opened, without taking read locks.

This setting implicitly begins a transaction that is committed when the cursor is closed.

This setting is silently ignored if UseMVCC is not set on the underlying database or if a transaction is supplied to Cursor()()()

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SnapshotIsolation
Visual Basic (Declaration)
Public SnapshotIsolation As Boolean
Visual C++
public:
bool SnapshotIsolation

See Also

CursorConfig Class


WriteCursor Field

[image]

Berkeley DB .NET API Documentation
CursorConfig..::.WriteCursor Field
CursorConfig Class See Also Send Feedback
If true, specify that the cursor is used to update the database. The underlying database environment must have been opened with UseCDB set.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool WriteCursor
Visual Basic (Declaration)
Public WriteCursor As Boolean
Visual C++
public:
bool WriteCursor

See Also

CursorConfig Class


CursorConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
CursorConfig Methods
CursorConfig Class See Also Send Feedback

The CursorConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CursorConfig Class


Database Class

[image]

Berkeley DB .NET API Documentation
Database Class
Members See Also Send Feedback
A class representing a Berkeley DB database, a base class for access method specific classes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class Database : BaseDatabase, IDisposable
Visual Basic (Declaration)
Public Class Database _
    Inherits BaseDatabase _
    Implements IDisposable
Visual C++
public ref class Database : public BaseDatabase,
    IDisposable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.Database
BerkeleyDB..::.BTreeDatabase
BerkeleyDB..::.HashDatabase
BerkeleyDB..::.HeapDatabase
BerkeleyDB..::.QueueDatabase
BerkeleyDB..::.RecnoDatabase

See Also

Database Members


Database Members

[image] [image]

Berkeley DB .NET API Documentation
Database Members
Database Class Methods Properties See Also Send Feedback

The Database type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoOverwrite | Overloaded.
Salvage | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.
Upgrade Overloaded.
Database upgrades are done in place and are destructive. For example, if pages need to be allocated and no disk space is available, the database may be left corrupted. Backups should be made before databases are upgraded. See Upgrading databases in the Programmer's Reference Guide for more information.
Verify Overloaded.
Verify does not perform any locking, even in Berkeley DB environments that are configured with a locking subsystem. As such, it should only be used on files that are not being modified by another thread of control.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

Database Class


Database Methods

[image] [image]

Berkeley DB .NET API Documentation
Database Methods
Database Class See Also Send Feedback

The Database type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoOverwrite | Overloaded.
Salvage | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.
Upgrade Overloaded.
Database upgrades are done in place and are destructive. For example, if pages need to be allocated and no disk space is available, the database may be left corrupted. Backups should be made before databases are upgraded. See Upgrading databases in the Programmer's Reference Guide for more information.
Verify Overloaded.
Verify does not perform any locking, even in Berkeley DB environments that are configured with a locking subsystem. As such, it should only be used on files that are not being modified by another thread of control.

See Also

Database Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Close Method
Database Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Cursor Method
Database Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig) | Create a database cursor with the given configuration. (Inherited from BaseDatabase.)
Cursor(Transaction) | Create a transactionally protected database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Delete Method
Database Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Exists Method
Database Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


Get Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Get Method
Database Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.GetBoth Method
Database Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


GetBothMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.GetBothMultiple Method
Database Class See Also Send Feedback

Overload List

Name | Description
GetBothMultiple(DatabaseEntry, DatabaseEntry) | If a key/data pair in the database matches key and data, return the key and all duplicate data items.
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32) | If a key/data pair in the database matches key and data, return the key and all duplicate data items.
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction) | If a key/data pair in the database matches key and data, return the key and all duplicate data items.
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction, LockingInfo) | If a key/data pair in the database matches key and data, return the key and all duplicate data items.

See Also

Database Class
Database Members


GetBothMultiple Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Database..::.GetBothMultiple Method (DatabaseEntry, DatabaseEntry)
Database Class See Also Send Feedback
If a key/data pair in the database matches key and data, return the key and all duplicate data items.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetBothMultiple(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function GetBothMultiple ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetBothMultiple(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The data to search for

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key and data are not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

Database Class
GetBothMultiple Overload


GetBothMultiple Method (DatabaseEntry, DatabaseEntry, Int32)

[image]

Berkeley DB .NET API Documentation
Database..::.GetBothMultiple Method (DatabaseEntry, DatabaseEntry, Int32)
Database Class See Also Send Feedback
If a key/data pair in the database matches key and data, return the key and all duplicate data items.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetBothMultiple(
    DatabaseEntry key,
    DatabaseEntry data,
    int BufferSize
)
Visual Basic (Declaration)
Public Function GetBothMultiple ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    BufferSize As Integer _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetBothMultiple(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    int BufferSize
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The data to search for
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key and data are not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

Database Class
GetBothMultiple Overload


GetBothMultiple Method (DatabaseEntry, DatabaseEntry, Int32, Transaction)

[image]

Berkeley DB .NET API Documentation
Database..::.GetBothMultiple Method (DatabaseEntry, DatabaseEntry, Int32, Transaction)
Database Class See Also Send Feedback
If a key/data pair in the database matches key and data, return the key and all duplicate data items.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetBothMultiple(
    DatabaseEntry key,
    DatabaseEntry data,
    int BufferSize,
    Transaction txn
)
Visual Basic (Declaration)
Public Function GetBothMultiple ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    BufferSize As Integer, _
    txn As Transaction _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetBothMultiple(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    int BufferSize,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The data to search for
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key and data are not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

Database Class
GetBothMultiple Overload


GetBothMultiple Method (DatabaseEntry, DatabaseEntry, Int32, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Database..::.GetBothMultiple Method (DatabaseEntry, DatabaseEntry, Int32, Transaction, LockingInfo)
Database Class See Also Send Feedback
If a key/data pair in the database matches key and data, return the key and all duplicate data items.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetBothMultiple(
    DatabaseEntry key,
    DatabaseEntry data,
    int BufferSize,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function GetBothMultiple ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    BufferSize As Integer, _
    txn As Transaction, _
    info As LockingInfo _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetBothMultiple(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    int BufferSize,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
data
Type: BerkeleyDB..::.DatabaseEntry
The data to search for
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key and data are not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

Database Class
GetBothMultiple Overload


GetMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.GetMultiple Method
Database Class See Also Send Feedback

Overload List

Name | Description
GetMultiple(DatabaseEntry) | Retrieve a key and all duplicate data items from the database.
GetMultiple(DatabaseEntry, Int32) | Retrieve a key and all duplicate data items from the database.
GetMultiple(DatabaseEntry, Int32, Transaction) | Retrieve a key and all duplicate data items from the database.
GetMultiple(DatabaseEntry, Int32, Transaction, LockingInfo) | Retrieve a key and all duplicate data items from the database.

See Also

Database Class
Database Members


GetMultiple Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Database..::.GetMultiple Method (DatabaseEntry)
Database Class See Also Send Feedback
Retrieve a key and all duplicate data items from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetMultiple(
    DatabaseEntry key
)
Visual Basic (Declaration)
Public Function GetMultiple ( _
    key As DatabaseEntry _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetMultiple(
    DatabaseEntry^ key
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

Database Class
GetMultiple Overload


GetMultiple Method (DatabaseEntry, Int32)

[image]

Berkeley DB .NET API Documentation
Database..::.GetMultiple Method (DatabaseEntry, Int32)
Database Class See Also Send Feedback
Retrieve a key and all duplicate data items from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetMultiple(
    DatabaseEntry key,
    int BufferSize
)
Visual Basic (Declaration)
Public Function GetMultiple ( _
    key As DatabaseEntry, _
    BufferSize As Integer _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetMultiple(
    DatabaseEntry^ key,
    int BufferSize
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data items.

Exceptions

Exception | Condition
BerkeleyDB..::.NotFoundException | A NotFoundException is thrown if key is not in the database.
BerkeleyDB..::.KeyEmptyException | A KeyEmptyException is thrown if the database is a QueueDatabase or RecnoDatabase database and key exists, but was never explicitly created by the application or was later deleted.

See Also

Database Class
GetMultiple Overload


GetMultiple Method (DatabaseEntry, Int32, Transaction)

[image]

Berkeley DB .NET API Documentation
Database..::.GetMultiple Method (DatabaseEntry, Int32, Transaction)
Database Class See Also Send Feedback
Retrieve a key and all duplicate data items from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetMultiple(
    DatabaseEntry key,
    int BufferSize,
    Transaction txn
)
Visual Basic (Declaration)
Public Function GetMultiple ( _
    key As DatabaseEntry, _
    BufferSize As Integer, _
    txn As Transaction _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetMultiple(
    DatabaseEntry^ key,
    int BufferSize,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data items.

See Also

Database Class
GetMultiple Overload


GetMultiple Method (DatabaseEntry, Int32, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
Database..::.GetMultiple Method (DatabaseEntry, Int32, Transaction, LockingInfo)
Database Class See Also Send Feedback
Retrieve a key and all duplicate data items from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, MultipleDatabaseEntry> GetMultiple(
    DatabaseEntry key,
    int BufferSize,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function GetMultiple ( _
    key As DatabaseEntry, _
    BufferSize As Integer, _
    txn As Transaction, _
    info As LockingInfo _
) As KeyValuePair(Of DatabaseEntry, MultipleDatabaseEntry)
Visual C++
public:
KeyValuePair<DatabaseEntry^, MultipleDatabaseEntry^> GetMultiple(
    DatabaseEntry^ key,
    int BufferSize,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to search for
BufferSize
Type: System..::.Int32
The initial size of the buffer to fill with duplicate data items. If the buffer is not large enough, it is automatically resized.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is key and whose Value parameter is the retrieved data items.

See Also

Database Class
GetMultiple Overload


Join Method

[image]

Berkeley DB .NET API Documentation
Database..::.Join Method
Database Class See Also Send Feedback
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public JoinCursor Join(
    SecondaryCursor[] lst,
    bool sortCursors
)
Visual Basic (Declaration)
Public Function Join ( _
    lst As SecondaryCursor(), _
    sortCursors As Boolean _
) As JoinCursor
Visual C++
public:
JoinCursor^ Join(
    array<SecondaryCursor^>^ lst,
    bool sortCursors
)

Parameters

lst
Type: array< BerkeleyDB..::.SecondaryCursor >[]()[]
An array of SecondaryCursors. Each cursor must have been initialized to refer to the key on which the underlying database should be joined.
sortCursors
Type: System..::.Boolean
If true, sort the cursors from the one that refers to the least number of data items to the one that refers to the most. If the data is structured so that cursors with many data items also share many common elements, higher performance results from listing those cursors before cursors with fewer data items; a sort order other than the default. A setting of false permits applications to perform join optimization prior to calling Join.

Return Value

A specialized join cursor for use in performing equality or natural joins on secondary indices.

Remarks

Once the cursors have been passed as part of lst, they should not be accessed or modified until the newly created JoinCursorhas been closed, or else inconsistent results may be returned.

Joined values are retrieved by doing a sequential iteration over the first cursor in lst, and a nested iteration over each secondary cursor in the order they are specified in the curslist parameter. This requires database traversals to search for the current datum in all the cursors after the first. For this reason, the best join performance normally results from sorting the cursors from the one that refers to the least number of data items to the one that refers to the most.

See Also

Database Class


Open Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Open Method
Database Class See Also Send Feedback

Overload List

Name | Description
Open(String, DatabaseConfig) | Instantiate a new Database object and open the database represented by Filename. The file specified by Filename must exist.
Open(String, DatabaseConfig, Transaction) | Instantiate a new Database object and open the database represented by Filename. The file specified by Filename must exist.
Open(String, String, DatabaseConfig) | Instantiate a new Database object and open the database represented by Filename and DatabaseName. The file specified by Filename must exist.
Open(String, String, DatabaseConfig, Transaction) | Instantiate a new Database object and open the database represented by Filename and DatabaseName. The file specified by Filename must exist.

See Also

Database Class
Database Members


Open Method (String, DatabaseConfig)

[image]

Berkeley DB .NET API Documentation
Database..::.Open Method (String, DatabaseConfig)
Database Class See Also Send Feedback
Instantiate a new Database object and open the database represented by Filename. The file specified by Filename must exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static Database Open(
    string Filename,
    DatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As DatabaseConfig _
) As Database
Visual C++
public:
static Database^ Open(
    String^ Filename,
    DatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database.
cfg
Type: BerkeleyDB..::.DatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

Database Class
Open Overload


Open Method (String, DatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
Database..::.Open Method (String, DatabaseConfig, Transaction)
Database Class See Also Send Feedback
Instantiate a new Database object and open the database represented by Filename. The file specified by Filename must exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static Database Open(
    string Filename,
    DatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As DatabaseConfig, _
    txn As Transaction _
) As Database
Visual C++
public:
static Database^ Open(
    String^ Filename,
    DatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.DatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

Database Class
Open Overload


Open Method (String, String, DatabaseConfig)

[image]

Berkeley DB .NET API Documentation
Database..::.Open Method (String, String, DatabaseConfig)
Database Class See Also Send Feedback
Instantiate a new Database object and open the database represented by Filename and DatabaseName. The file specified by Filename must exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static Database Open(
    string Filename,
    string DatabaseName,
    DatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As DatabaseConfig _
) As Database
Visual C++
public:
static Database^ Open(
    String^ Filename,
    String^ DatabaseName,
    DatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, an error occurs if you attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.DatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

Database Class
Open Overload


Open Method (String, String, DatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
Database..::.Open Method (String, String, DatabaseConfig, Transaction)
Database Class See Also Send Feedback
Instantiate a new Database object and open the database represented by Filename and DatabaseName. The file specified by Filename must exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static Database Open(
    string Filename,
    string DatabaseName,
    DatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As DatabaseConfig, _
    txn As Transaction _
) As Database
Visual C++
public:
static Database^ Open(
    String^ Filename,
    String^ DatabaseName,
    DatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.DatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and be replicated to client sites in any replication group.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

Database Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.PrintFastStats Method
Database Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.PrintStats Method
Database Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


Put Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Put Method
Database Class See Also Send Feedback

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

Overload List

Name | Description
Put(MultipleKeyDatabaseEntry) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one.
Put(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed.
Put(MultipleKeyDatabaseEntry, Transaction) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one.
Put(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed.

See Also

Database Class
Database Members


Put Method (MultipleKeyDatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Database..::.Put Method (MultipleKeyDatabaseEntry)
Database Class See Also Send Feedback
Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Put(
    MultipleKeyDatabaseEntry key
)
Visual Basic (Declaration)
Public Sub Put ( _
    key As MultipleKeyDatabaseEntry _
)
Visual C++
public:
void Put(
    MultipleKeyDatabaseEntry^ key
)

Parameters

key
Type: BerkeleyDB..::.MultipleKeyDatabaseEntry
Multiple key/data pairs to store in the database

Remarks

See Also

Database Class
Put Overload


Put Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Database..::.Put Method (DatabaseEntry, DatabaseEntry)
Database Class See Also Send Feedback
Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Put(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Sub Put ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
)
Visual C++
public:
void Put(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to store in the database
data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException | Partial put to a duplicate database, or QueueDatabase or RecnoDatabase with fixed-length records.

See Also

Database Class
Put Overload


Put Method (MultipleKeyDatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
Database..::.Put Method (MultipleKeyDatabaseEntry, Transaction)
Database Class See Also Send Feedback
Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Put(
    MultipleKeyDatabaseEntry key,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub Put ( _
    key As MultipleKeyDatabaseEntry, _
    txn As Transaction _
)
Visual C++
public:
void Put(
    MultipleKeyDatabaseEntry^ key,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.MultipleKeyDatabaseEntry
Multiple key/data pairs to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

See Also

Database Class
Put Overload


Put Method (DatabaseEntry, DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
Database..::.Put Method (DatabaseEntry, DatabaseEntry, Transaction)
Database Class See Also Send Feedback
Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Put(
    DatabaseEntry key,
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub Put ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    txn As Transaction _
)
Visual C++
public:
void Put(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to store in the database
data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Remarks

When partial put to a duplicate database, a DatabaseException is thrown.

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException | Partial put to a duplicate database, or QueueDatabase or RecnoDatabase with fixed-length records.

See Also

Database Class
Put Overload


PutNoOverwrite Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.PutNoOverwrite Method
Database Class See Also Send Feedback

Overload List

Name | Description
PutNoOverwrite(MultipleKeyDatabaseEntry) | Store the key/data pairs in the database, only if the key does not already appear in the database.
PutNoOverwrite(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, only if the key does not already appear in the database.
PutNoOverwrite(MultipleKeyDatabaseEntry, Transaction) | Store the key/data pairs in the database, only if the key does not already appear in the database.
PutNoOverwrite(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, only if the key does not already appear in the database.

See Also

Database Class
Database Members


PutNoOverwrite Method (MultipleKeyDatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Database..::.PutNoOverwrite Method (MultipleKeyDatabaseEntry)
Database Class See Also Send Feedback
Store the key/data pairs in the database, only if the key does not already appear in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PutNoOverwrite(
    MultipleKeyDatabaseEntry key
)
Visual Basic (Declaration)
Public Sub PutNoOverwrite ( _
    key As MultipleKeyDatabaseEntry _
)
Visual C++
public:
void PutNoOverwrite(
    MultipleKeyDatabaseEntry^ key
)

Parameters

key
Type: BerkeleyDB..::.MultipleKeyDatabaseEntry
Key/data pairs to store in the database

See Also

Database Class
PutNoOverwrite Overload


PutNoOverwrite Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
Database..::.PutNoOverwrite Method (DatabaseEntry, DatabaseEntry)
Database Class See Also Send Feedback
Store the key/data pair in the database, only if the key does not already appear in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PutNoOverwrite(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Sub PutNoOverwrite ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
)
Visual C++
public:
void PutNoOverwrite(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to store in the database
data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database

Remarks

This enforcement of uniqueness of keys applies only to the primary key, the behavior of insertions into secondary databases is not affected. In particular, the insertion of a record that would result in the creation of a duplicate key in a secondary database that allows duplicates would not be prevented by the use of this flag.

See Also

Database Class
PutNoOverwrite Overload


PutNoOverwrite Method (MultipleKeyDatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
Database..::.PutNoOverwrite Method (MultipleKeyDatabaseEntry, Transaction)
Database Class See Also Send Feedback
Store the key/data pairs in the database, only if the key does not already appear in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PutNoOverwrite(
    MultipleKeyDatabaseEntry key,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub PutNoOverwrite ( _
    key As MultipleKeyDatabaseEntry, _
    txn As Transaction _
)
Visual C++
public:
void PutNoOverwrite(
    MultipleKeyDatabaseEntry^ key,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.MultipleKeyDatabaseEntry
Key/data pairs to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

See Also

Database Class
PutNoOverwrite Overload


PutNoOverwrite Method (DatabaseEntry, DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
Database..::.PutNoOverwrite Method (DatabaseEntry, DatabaseEntry, Transaction)
Database Class See Also Send Feedback
Store the key/data pair in the database, only if the key does not already appear in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PutNoOverwrite(
    DatabaseEntry key,
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub PutNoOverwrite ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    txn As Transaction _
)
Visual C++
public:
void PutNoOverwrite(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to store in the database
data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Remarks

This enforcement of uniqueness of keys applies only to the primary key, the behavior of insertions into secondary databases is not affected. In particular, the insertion of a record that would result in the creation of a duplicate key in a secondary database that allows duplicates would not be prevented by the use of this flag.

See Also

Database Class
PutNoOverwrite Overload


Salvage Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Salvage Method
Database Class See Also Send Feedback

Overload List

Name | Description
Salvage(String, DatabaseConfig) | Write the key/data pairs from all databases in the file to Out. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.
Salvage(String, DatabaseConfig, Boolean) | Write the key/data pairs from all databases in the file to Out. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.
Salvage(String, DatabaseConfig, TextWriter) | Write the key/data pairs from all databases in the file to OutputStream. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.
Salvage(String, DatabaseConfig, Boolean, Boolean) | Write the key/data pairs from all databases in the file to Out. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.
Salvage(String, DatabaseConfig, Boolean, TextWriter) | Write the key/data pairs from all databases in the file to OutputStream. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.
Salvage(String, DatabaseConfig, Boolean, Boolean, TextWriter) | Write the key/data pairs from all databases in the file to OutputStream. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.

See Also

Database Class
Database Members


Salvage Method (String, DatabaseConfig)

[image]

Berkeley DB .NET API Documentation
Database..::.Salvage Method (String, DatabaseConfig)
Database Class See Also Send Feedback
Write the key/data pairs from all databases in the file to Out. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Salvage(
    string file,
    DatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Sub Salvage ( _
    file As String, _
    cfg As DatabaseConfig _
)
Visual C++
public:
static void Salvage(
    String^ file,
    DatabaseConfig^ cfg
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be salvaged are found.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be salvaged.

See Also

Database Class
Salvage Overload


Salvage Method (String, DatabaseConfig, Boolean)

[image]

Berkeley DB .NET API Documentation
Database..::.Salvage Method (String, DatabaseConfig, Boolean)
Database Class See Also Send Feedback
Write the key/data pairs from all databases in the file to Out. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Salvage(
    string file,
    DatabaseConfig cfg,
    bool Printable
)
Visual Basic (Declaration)
Public Shared Sub Salvage ( _
    file As String, _
    cfg As DatabaseConfig, _
    Printable As Boolean _
)
Visual C++
public:
static void Salvage(
    String^ file,
    DatabaseConfig^ cfg,
    bool Printable
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be salvaged are found.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be salvaged.
Printable
Type: System..::.Boolean
If true and characters in either the key or data items are printing characters (as defined by isprint(3)), use printing characters to represent them. This setting permits users to use standard text editors and tools to modify the contents of databases or selectively remove data from salvager output.

See Also

Database Class
Salvage Overload


Salvage Method (String, DatabaseConfig, TextWriter)

[image]

Berkeley DB .NET API Documentation
Database..::.Salvage Method (String, DatabaseConfig, TextWriter)
Database Class See Also Send Feedback
Write the key/data pairs from all databases in the file to OutputStream. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Salvage(
    string file,
    DatabaseConfig cfg,
    TextWriter OutputStream
)
Visual Basic (Declaration)
Public Shared Sub Salvage ( _
    file As String, _
    cfg As DatabaseConfig, _
    OutputStream As TextWriter _
)
Visual C++
public:
static void Salvage(
    String^ file,
    DatabaseConfig^ cfg,
    TextWriter^ OutputStream
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be salvaged are found.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be salvaged.
OutputStream
Type: System.IO..::.TextWriter
The TextWriter to which the databases' key/data pairs are written. If null, Out is used.

See Also

Database Class
Salvage Overload


Salvage Method (String, DatabaseConfig, Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
Database..::.Salvage Method (String, DatabaseConfig, Boolean, Boolean)
Database Class See Also Send Feedback
Write the key/data pairs from all databases in the file to Out. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Salvage(
    string file,
    DatabaseConfig cfg,
    bool Printable,
    bool Aggressive
)
Visual Basic (Declaration)
Public Shared Sub Salvage ( _
    file As String, _
    cfg As DatabaseConfig, _
    Printable As Boolean, _
    Aggressive As Boolean _
)
Visual C++
public:
static void Salvage(
    String^ file,
    DatabaseConfig^ cfg,
    bool Printable,
    bool Aggressive
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be salvaged are found.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be salvaged.
Printable
Type: System..::.Boolean
If true and characters in either the key or data items are printing characters (as defined by isprint(3)), use printing characters to represent them. This setting permits users to use standard text editors and tools to modify the contents of databases or selectively remove data from salvager output.
Aggressive
Type: System..::.Boolean
If true, output all the key/data pairs found in the file. Corruption of these data pairs is assumed, and corrupted or deleted data pairs may appear in the output (even if the salvaged file is in no way corrupt). This output almost certainly requires editing before being loaded into a database.

See Also

Database Class
Salvage Overload


Salvage Method (String, DatabaseConfig, Boolean, TextWriter)

[image]

Berkeley DB .NET API Documentation
Database..::.Salvage Method (String, DatabaseConfig, Boolean, TextWriter)
Database Class See Also Send Feedback
Write the key/data pairs from all databases in the file to OutputStream. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Salvage(
    string file,
    DatabaseConfig cfg,
    bool Printable,
    TextWriter OutputStream
)
Visual Basic (Declaration)
Public Shared Sub Salvage ( _
    file As String, _
    cfg As DatabaseConfig, _
    Printable As Boolean, _
    OutputStream As TextWriter _
)
Visual C++
public:
static void Salvage(
    String^ file,
    DatabaseConfig^ cfg,
    bool Printable,
    TextWriter^ OutputStream
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be salvaged are found.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be salvaged.
Printable
Type: System..::.Boolean
If true and characters in either the key or data items are printing characters (as defined by isprint(3)), use printing characters to represent them. This setting permits users to use standard text editors and tools to modify the contents of databases or selectively remove data from salvager output.
OutputStream
Type: System.IO..::.TextWriter
The TextWriter to which the databases' key/data pairs are written. If null, Out is used.

See Also

Database Class
Salvage Overload


Salvage Method (String, DatabaseConfig, Boolean, Boolean, TextWriter)

[image]

Berkeley DB .NET API Documentation
Database..::.Salvage Method (String, DatabaseConfig, Boolean, Boolean, TextWriter)
Database Class See Also Send Feedback
Write the key/data pairs from all databases in the file to OutputStream. Key values are written for Btree, Hash and Queue databases, but not for Recno databases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Salvage(
    string file,
    DatabaseConfig cfg,
    bool Printable,
    bool Aggressive,
    TextWriter OutputStream
)
Visual Basic (Declaration)
Public Shared Sub Salvage ( _
    file As String, _
    cfg As DatabaseConfig, _
    Printable As Boolean, _
    Aggressive As Boolean, _
    OutputStream As TextWriter _
)
Visual C++
public:
static void Salvage(
    String^ file,
    DatabaseConfig^ cfg,
    bool Printable,
    bool Aggressive,
    TextWriter^ OutputStream
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be salvaged are found.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be salvaged.
Printable
Type: System..::.Boolean
If true and characters in either the key or data items are printing characters (as defined by isprint(3)), use printing characters to represent them. This setting permits users to use standard text editors and tools to modify the contents of databases or selectively remove data from salvager output.
Aggressive
Type: System..::.Boolean
If true, output all the key/data pairs found in the file. Corruption of these data pairs is assumed, and corrupted or deleted data pairs may appear in the output (even if the salvaged file is in no way corrupt). This output almost certainly requires editing before being loaded into a database.
OutputStream
Type: System.IO..::.TextWriter
The TextWriter to which the databases' key/data pairs are written. If null, Out is used.

See Also

Database Class
Salvage Overload


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Truncate Method
Database Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

Database Class
Database Members


Upgrade Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Upgrade Method
Database Class See Also Send Feedback
Database upgrades are done in place and are destructive. For example, if pages need to be allocated and no disk space is available, the database may be left corrupted. Backups should be made before databases are upgraded. See Upgrading databases in the Programmer's Reference Guide for more information.

Overload List

Name | Description
Upgrade(String, DatabaseConfig) | Upgrade all of the databases included in the file file, if necessary. If no upgrade is necessary, Upgrade always returns successfully.
Upgrade(String, DatabaseConfig, Boolean) | Upgrade all of the databases included in the file file, if necessary. If no upgrade is necessary, Upgrade always returns successfully.

See Also

Database Class
Database Members


Upgrade Method (String, DatabaseConfig)

[image]

Berkeley DB .NET API Documentation
Database..::.Upgrade Method (String, DatabaseConfig)
Database Class See Also Send Feedback
Upgrade all of the databases included in the file file, if necessary. If no upgrade is necessary, Upgrade always returns successfully.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Upgrade(
    string file,
    DatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Sub Upgrade ( _
    file As String, _
    cfg As DatabaseConfig _
)
Visual C++
public:
static void Upgrade(
    String^ file,
    DatabaseConfig^ cfg
)

Parameters

file
Type: System..::.String
The physical file containing the databases to be upgraded.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be upgraded.

See Also

Database Class
Upgrade Overload


Upgrade Method (String, DatabaseConfig, Boolean)

[image]

Berkeley DB .NET API Documentation
Database..::.Upgrade Method (String, DatabaseConfig, Boolean)
Database Class See Also Send Feedback
Upgrade all of the databases included in the file file, if necessary. If no upgrade is necessary, Upgrade always returns successfully.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Upgrade(
    string file,
    DatabaseConfig cfg,
    bool dupSortUpgraded
)
Visual Basic (Declaration)
Public Shared Sub Upgrade ( _
    file As String, _
    cfg As DatabaseConfig, _
    dupSortUpgraded As Boolean _
)
Visual C++
public:
static void Upgrade(
    String^ file,
    DatabaseConfig^ cfg,
    bool dupSortUpgraded
)

Parameters

file
Type: System..::.String
The physical file containing the databases to be upgraded.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be upgraded.
dupSortUpgraded
Type: System..::.Boolean
If true, the duplicates in the upgraded database are sorted; otherwise they are assumed to be unsorted. This setting is only meaningful when upgrading databases from releases before the Berkeley DB 3.1 release.

Remarks

As part of the upgrade from the Berkeley DB 3.0 release to the 3.1 release, the on-disk format of duplicate data items changed. To correctly upgrade the format requires applications to specify whether duplicate data items in the database are sorted or not. Specifying dupSortUpgraded informs Upgrade that the duplicates are sorted; otherwise they are assumed to be unsorted. Incorrectly specifying the value of this flag may lead to database corruption.

Further, because this method upgrades a physical file (including all the databases it contains), it is not possible to use Upgrade to upgrade files in which some of the databases it includes have sorted duplicate data items, and some of the databases it includes have unsorted duplicate data items. If the file does not have more than a single database, if the databases do not support duplicate data items, or if all of the databases that support duplicate data items support the same style of duplicates (either sorted or unsorted), Upgrade works correctly as long as dupSortUpgraded is correctly specified. Otherwise, the file cannot be upgraded using Upgrade it must be upgraded manually by dumping and reloading the databases.

See Also

Database Class
Upgrade Overload


Verify Method

[image] [image]

Berkeley DB .NET API Documentation
Database..::.Verify Method
Database Class See Also Send Feedback
Verify does not perform any locking, even in Berkeley DB environments that are configured with a locking subsystem. As such, it should only be used on files that are not being modified by another thread of control.

Overload List

Name | Description
Verify(String, DatabaseConfig) | Verify the integrity of all databases in the file specified by file.
Verify(String, DatabaseConfig, Database..::.VerifyOperation) | Verify the integrity of all databases in the file specified by file.
Verify(String, String, DatabaseConfig, Database..::.VerifyOperation) | Verify the integrity of the database specified by file and database.

See Also

Database Class
Database Members


Verify Method (String, DatabaseConfig)

[image]

Berkeley DB .NET API Documentation
Database..::.Verify Method (String, DatabaseConfig)
Database Class See Also Send Feedback
Verify the integrity of all databases in the file specified by file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Verify(
    string file,
    DatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Sub Verify ( _
    file As String, _
    cfg As DatabaseConfig _
)
Visual C++
public:
static void Verify(
    String^ file,
    DatabaseConfig^ cfg
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be verified are found.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be verified.

See Also

Database Class
Verify Overload


Verify Method (String, DatabaseConfig, Database.VerifyOperation)

[image]

Berkeley DB .NET API Documentation
Database..::.Verify Method (String, DatabaseConfig, Database..::.VerifyOperation)
Database Class See Also Send Feedback
Verify the integrity of all databases in the file specified by file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Verify(
    string file,
    DatabaseConfig cfg,
    Database..::.VerifyOperation op
)
Visual Basic (Declaration)
Public Shared Sub Verify ( _
    file As String, _
    cfg As DatabaseConfig, _
    op As Database..::.VerifyOperation _
)
Visual C++
public:
static void Verify(
    String^ file,
    DatabaseConfig^ cfg,
    Database..::.VerifyOperation op
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be verified are found.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be verified.
op
Type: BerkeleyDB..::.Database..::.VerifyOperation
The extent of verification

Remarks

Berkeley DB normally verifies that btree keys and duplicate items are correctly sorted, and hash keys are correctly hashed. If the file being verified contains multiple databases using differing sorting or hashing algorithms, some of them must necessarily fail database verification because only one sort order or hash function can be specified in cfg. To verify files with multiple databases having differing sorting orders or hashing functions, first perform verification of the file as a whole by using NO_ORDER_CHECK, and then individually verify the sort order and hashing function for each database in the file using ORDER_CHECK_ONLY.

See Also

Database Class
Verify Overload


Verify Method (String, String, DatabaseConfig, Database.VerifyOperation)

[image]

Berkeley DB .NET API Documentation
Database..::.Verify Method (String, String, DatabaseConfig, Database..::.VerifyOperation)
Database Class See Also Send Feedback
Verify the integrity of the database specified by file and database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Verify(
    string file,
    string database,
    DatabaseConfig cfg,
    Database..::.VerifyOperation op
)
Visual Basic (Declaration)
Public Shared Sub Verify ( _
    file As String, _
    database As String, _
    cfg As DatabaseConfig, _
    op As Database..::.VerifyOperation _
)
Visual C++
public:
static void Verify(
    String^ file,
    String^ database,
    DatabaseConfig^ cfg,
    Database..::.VerifyOperation op
)

Parameters

file
Type: System..::.String
The physical file in which the databases to be verified are found.
database
Type: System..::.String
The database in file on which the database checks for btree and duplicate sort order and for hashing are to be performed. A non-null value for database is only allowed with ORDER_CHECK_ONLY.
cfg
Type: BerkeleyDB..::.DatabaseConfig
Configuration parameters for the databases to be verified.
op
Type: BerkeleyDB..::.Database..::.VerifyOperation
The extent of verification

Remarks

Berkeley DB normally verifies that btree keys and duplicate items are correctly sorted, and hash keys are correctly hashed. If the file being verified contains multiple databases using differing sorting or hashing algorithms, some of them must necessarily fail database verification because only one sort order or hash function can be specified in cfg. To verify files with multiple databases having differing sorting orders or hashing functions, first perform verification of the file as a whole by using NO_ORDER_CHECK, and then individually verify the sort order and hashing function for each database in the file using ORDER_CHECK_ONLY.

See Also

Database Class
Verify Overload


Database Properties

[image] [image]

Berkeley DB .NET API Documentation
Database Properties
Database Class See Also Send Feedback

The Database type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

Database Class


Database.VerifyOperation Enumeration

[image]

Berkeley DB .NET API Documentation
Database..::.VerifyOperation Enumeration
Database Class See Also Send Feedback
Specifies the type of verification to perform

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum VerifyOperation
Visual Basic (Declaration)
Public Enumeration VerifyOperation
Visual C++
public enum class VerifyOperation

Members

Member name | Description
DEFAULT | Perform database checks and check sort order
ORDER_CHECK_ONLY | Perform the database checks for btree and duplicate sort order and for hashing
NO_ORDER_CHECK | Skip the database checks for btree and duplicate sort order and for hashing.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


DatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
DatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for Database

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DatabaseConfig
Visual Basic (Declaration)
Public Class DatabaseConfig
Visual C++
public ref class DatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.BTreeDatabaseConfig
BerkeleyDB..::.HashDatabaseConfig
BerkeleyDB..::.HeapDatabaseConfig
BerkeleyDB..::.QueueDatabaseConfig
BerkeleyDB..::.RecnoDatabaseConfig
BerkeleyDB..::.SecondaryDatabaseConfig

See Also

DatabaseConfig Members


DatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
DatabaseConfig Members
DatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The DatabaseConfig type exposes the following members.

Constructors

Name | Description
DatabaseConfig | Instantiate a new DatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value.
CacheSize | The size of the shared memory buffer pool (the cache).
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment.
ErrorFeedback | The mechanism for reporting error messages to the application.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
Feedback |
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space.
NoMMap | Do not map this database into process memory.
NonDurableTxns | If true, Berkeley DB does not write log records for this database.
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database.
Priority | The cache priority for pages referenced by the database.
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files.
ReadUncommitted | Support transactional read operations with degree 1 isolation.
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held.
UseMVCC | Open the database with support for multiversion concurrency control.

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption.
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption.
EncryptionPassword | The password used to perform encryption and decryption.
PageSize | The size of the pages used to hold items in the database, in bytes.

See Also

DatabaseConfig Class


DatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
DatabaseConfig Constructor
DatabaseConfig Class See Also Send Feedback
Instantiate a new DatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DatabaseConfig()

See Also

DatabaseConfig Class


DatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
DatabaseConfig Fields
DatabaseConfig Class See Also Send Feedback

The DatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value.
CacheSize | The size of the shared memory buffer pool (the cache).
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment.
ErrorFeedback | The mechanism for reporting error messages to the application.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
Feedback |
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space.
NoMMap | Do not map this database into process memory.
NonDurableTxns | If true, Berkeley DB does not write log records for this database.
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database.
Priority | The cache priority for pages referenced by the database.
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files.
ReadUncommitted | Support transactional read operations with degree 1 isolation.
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held.
UseMVCC | Open the database with support for multiversion concurrency control.

See Also

DatabaseConfig Class


AutoCommit Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.AutoCommit Field
DatabaseConfig Class See Also Send Feedback
Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool AutoCommit
Visual Basic (Declaration)
Public AutoCommit As Boolean
Visual C++
public:
bool AutoCommit

See Also

DatabaseConfig Class


ByteOrder Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.ByteOrder Field
DatabaseConfig Class See Also Send Feedback
The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ByteOrder ByteOrder
Visual Basic (Declaration)
Public ByteOrder As ByteOrder
Visual C++
public:
ByteOrder^ ByteOrder

Remarks

The access methods provide no guarantees about the byte ordering of the application data stored in the database. Applications are responsible for maintaining any necessary ordering.

If creating additional databases in a single physical file, this parameter is ignored and the byte order of the existing databases is used.

See Also

DatabaseConfig Class


CacheSize Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.CacheSize Field
DatabaseConfig Class See Also Send Feedback
The size of the shared memory buffer pool (the cache).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CacheInfo CacheSize
Visual Basic (Declaration)
Public CacheSize As CacheInfo
Visual C++
public:
CacheInfo^ CacheSize

Remarks

The cache should be the size of the normal working data set of the application, with some small amount of additional memory for unusual situations. (Note: the working set is not the same as the number of pages accessed simultaneously, and is usually much larger.)

The default cache size is 256KB, and may not be specified as less than 20KB. Any cache size less than 500MB is automatically increased by 25% to account for buffer pool overhead; cache sizes larger than 500MB are used as specified. The maximum size of a single cache is 4GB on 32-bit systems and 10TB on 64-bit systems. (All sizes are in powers-of-two, 256KB is 2^18 not 256,000.) For information on tuning the Berkeley DB cache size, see Selecting a cache size in the Programmer's Reference Guide.

See Also

DatabaseConfig Class


DoChecksum Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.DoChecksum Field
DatabaseConfig Class See Also Send Feedback
If true, do checksum verification of pages read into the cache from the backing filestore.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool DoChecksum
Visual Basic (Declaration)
Public DoChecksum As Boolean
Visual C++
public:
bool DoChecksum

Remarks

Berkeley DB uses the SHA1 Secure Hash Algorithm if encryption is configured and a general hash algorithm if it is not.

If the database already exists, this setting is ignored.

See Also

DatabaseConfig Class


Env Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.Env Field
DatabaseConfig Class See Also Send Feedback
The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEnvironment Env
Visual Basic (Declaration)
Public Env As DatabaseEnvironment
Visual C++
public:
DatabaseEnvironment^ Env

Remarks

The database access methods automatically make calls to the other subsystems in Berkeley DB, based on the enclosing environment. For example, if the environment has been configured to use locking, the access methods automatically acquire the correct locks when reading and writing pages of the database.

See Also

DatabaseConfig Class


ErrorFeedback Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.ErrorFeedback Field
DatabaseConfig Class See Also Send Feedback
The mechanism for reporting error messages to the application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ErrorFeedbackDelegate ErrorFeedback
Visual Basic (Declaration)
Public ErrorFeedback As ErrorFeedbackDelegate
Visual C++
public:
ErrorFeedbackDelegate^ ErrorFeedback

Remarks

In some cases, when an error occurs, Berkeley DB calls ErrorFeedback with additional error information. It is up to the delegate function to display the error message in an appropriate manner.

This error-logging enhancement does not slow performance or significantly increase application size, and may be run during normal operation as well as during application debugging.

For databases opened inside of Berkeley DB environments, setting ErrorFeedback affects the entire environment and is equivalent to setting ErrorFeedback.

See Also

DatabaseConfig Class


ErrorPrefix Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.ErrorPrefix Field
DatabaseConfig Class See Also Send Feedback
The prefix string that appears before error messages issued by Berkeley DB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string ErrorPrefix
Visual Basic (Declaration)
Public ErrorPrefix As String
Visual C++
public:
String^ ErrorPrefix

See Also

DatabaseConfig Class


Feedback Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.Feedback Field
DatabaseConfig Class See Also Send Feedback

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseFeedbackDelegate Feedback
Visual Basic (Declaration)
Public Feedback As DatabaseFeedbackDelegate
Visual C++
public:
DatabaseFeedbackDelegate^ Feedback

See Also

DatabaseConfig Class


FreeThreaded Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.FreeThreaded Field
DatabaseConfig Class See Also Send Feedback
Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool FreeThreaded
Visual Basic (Declaration)
Public FreeThreaded As Boolean
Visual C++
public:
bool FreeThreaded

See Also

DatabaseConfig Class


NoMMap Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.NoMMap Field
DatabaseConfig Class See Also Send Feedback
Do not map this database into process memory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoMMap
Visual Basic (Declaration)
Public NoMMap As Boolean
Visual C++
public:
bool NoMMap

See Also

DatabaseConfig Class


NonDurableTxns Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.NonDurableTxns Field
DatabaseConfig Class See Also Send Feedback
If true, Berkeley DB does not write log records for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NonDurableTxns
Visual Basic (Declaration)
Public NonDurableTxns As Boolean
Visual C++
public:
bool NonDurableTxns

Remarks

If Berkeley DB does not write log records, updates of this database exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); database integrity persists if the application or system does not fail. The database file must be verified and/or restored from backup after a failure. In order to ensure integrity after application shut down, the database must be synced when closed, or all database changes must be flushed from the database environment cache using either Checkpoint()()() or SyncMemPool()()(). All database objects for a single physical file must set NonDurableTxns, including database objects for different databases in a physical file.

See Also

DatabaseConfig Class


NoWaitDbExclusiveLock Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.NoWaitDbExclusiveLock Field
DatabaseConfig Class See Also Send Feedback
Configuration of BaseDatabase handle to obtain a write lock on the entire database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Nullable<bool> NoWaitDbExclusiveLock
Visual Basic (Declaration)
Public NoWaitDbExclusiveLock As Nullable(Of Boolean)
Visual C++
public:
Nullable<bool> NoWaitDbExclusiveLock

Remarks

If true, configure the BaseDatabase handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the BaseDatabase handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the BaseDatabase handle to obtain a write lock on the entire database.

See Also

DatabaseConfig Class


Priority Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.Priority Field
DatabaseConfig Class See Also Send Feedback
The cache priority for pages referenced by the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CachePriority Priority
Visual Basic (Declaration)
Public Priority As CachePriority
Visual C++
public:
CachePriority^ Priority

Remarks

The priority of a page biases the replacement algorithm to be more or less likely to discard a page when space is needed in the buffer pool. The bias is temporary, and pages are eventually discarded if they are not referenced again. This priority is only advisory, and does not guarantee pages will be treated in a specific way.

See Also

DatabaseConfig Class


ReadOnly Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.ReadOnly Field
DatabaseConfig Class See Also Send Feedback
Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReadOnly
Visual Basic (Declaration)
Public ReadOnly As Boolean
Visual C++
public:
bool ReadOnly

See Also

DatabaseConfig Class


ReadUncommitted Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.ReadUncommitted Field
DatabaseConfig Class See Also Send Feedback
Support transactional read operations with degree 1 isolation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReadUncommitted
Visual Basic (Declaration)
Public ReadUncommitted As Boolean
Visual C++
public:
bool ReadUncommitted

Remarks

Read operations on the database may request the return of modified but not yet committed data. This flag must be specified on all database objects used to perform dirty reads or database updates, otherwise requests for dirty reads may not be honored and the read may block.

See Also

DatabaseConfig Class


Truncate Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.Truncate Field
DatabaseConfig Class See Also Send Feedback
Physically truncate the underlying file, discarding all previous databases it might have held.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Truncate
Visual Basic (Declaration)
Public Truncate As Boolean
Visual C++
public:
bool Truncate

Remarks

Underlying filesystem primitives are used to implement this flag. For this reason, it is applicable only to the file and cannot be used to discard databases within a file.

This setting cannot be lock or transaction-protected, and it is an error to specify it in a locking or transaction-protected environment.

See Also

DatabaseConfig Class


UseMVCC Field

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.UseMVCC Field
DatabaseConfig Class See Also Send Feedback
Open the database with support for multiversion concurrency control.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseMVCC
Visual Basic (Declaration)
Public UseMVCC As Boolean
Visual C++
public:
bool UseMVCC

Remarks

Enables database updates to follow a copy-on-write protocol, which is required to support snapshot isolation. This setting requires the database to be transactionally protected when it is opened(or, sometimes, at open time). Also, this setting is not supported by the queue format.

See Also

DatabaseConfig Class


DatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
DatabaseConfig Methods
DatabaseConfig Class See Also Send Feedback

The DatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DatabaseConfig Class


SetEncryption Method

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.SetEncryption Method
DatabaseConfig Class See Also Send Feedback
Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetEncryption(
    string password,
    EncryptionAlgorithm alg
)
Visual Basic (Declaration)
Public Sub SetEncryption ( _
    password As String, _
    alg As EncryptionAlgorithm _
)
Visual C++
public:
void SetEncryption(
    String^ password,
    EncryptionAlgorithm alg
)

Parameters

password
Type: System..::.String
The password used to perform encryption and decryption.
alg
Type: BerkeleyDB..::.EncryptionAlgorithm
The algorithm used to perform encryption and decryption.

See Also

DatabaseConfig Class


DatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
DatabaseConfig Properties
DatabaseConfig Class See Also Send Feedback

The DatabaseConfig type exposes the following members.

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption.
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption.
EncryptionPassword | The password used to perform encryption and decryption.
PageSize | The size of the pages used to hold items in the database, in bytes.

See Also

DatabaseConfig Class


EncryptAlgorithm Property

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.EncryptAlgorithm Property
DatabaseConfig Class See Also Send Feedback
The algorithm used to perform encryption and decryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EncryptionAlgorithm EncryptAlgorithm { get; }
Visual Basic (Declaration)
Public ReadOnly Property EncryptAlgorithm As EncryptionAlgorithm
Visual C++
public:
property EncryptionAlgorithm EncryptAlgorithm {
    EncryptionAlgorithm get ();
}

See Also

DatabaseConfig Class


Encrypted Property

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.Encrypted Property
DatabaseConfig Class See Also Send Feedback
Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Encrypted { get; set; }
Visual Basic (Declaration)
Public Property Encrypted As Boolean
Visual C++
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}

Remarks

If the database already exists, the value of Encrypted must be the same as the existing database or an error is returned.

Encrypted databases are not portable between machines of different byte orders, that is, encrypted databases created on big-endian machines cannot be read on little-endian machines, and vice versa.

See Also

DatabaseConfig Class


EncryptionPassword Property

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.EncryptionPassword Property
DatabaseConfig Class See Also Send Feedback
The password used to perform encryption and decryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string EncryptionPassword { get; }
Visual Basic (Declaration)
Public ReadOnly Property EncryptionPassword As String
Visual C++
public:
property String^ EncryptionPassword {
    String^ get ();
}

See Also

DatabaseConfig Class


PageSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseConfig..::.PageSize Property
DatabaseConfig Class See Also Send Feedback
The size of the pages used to hold items in the database, in bytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageSize { get; set; }
Visual Basic (Declaration)
Public Property PageSize As UInteger
Visual C++
public:
property unsigned int PageSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The minimum page size is 512 bytes, the maximum page size is 64K bytes, and the page size must be a power-of-two. If the page size is not explicitly set, one is selected based on the underlying filesystem I/O block size. The automatically selected size has a lower limit of 512 bytes and an upper limit of 16K bytes.

For information on tuning the Berkeley DB page size, see the "Selecting a page size" section in the Programmer's Reference Guide.

If creating additional databases in a single physical file, this parameter is ignored and the page size of the existing databases is used.

See Also

DatabaseConfig Class


DatabaseEntry Class

[image]

Berkeley DB .NET API Documentation
DatabaseEntry Class
Members See Also Send Feedback
A class representing a key or data item in a Berkeley DB database

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DatabaseEntry : IDisposable
Visual Basic (Declaration)
Public Class DatabaseEntry _
    Implements IDisposable
Visual C++
public ref class DatabaseEntry : IDisposable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseEntry
BerkeleyDB..::.MultipleDatabaseEntry
BerkeleyDB..::.MultipleKeyDatabaseEntry

See Also

DatabaseEntry Members


DatabaseEntry Members

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEntry Members
DatabaseEntry Class Constructors Methods Properties See Also Send Feedback

The DatabaseEntry type exposes the following members.

Constructors

Name | Description
DatabaseEntry | Overloaded.

Methods

Name | Description
Dispose | Release the resources held by the underlying C library.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Blob | Whether the record data will be stored as a blob, regardless of size.
Data | The byte string stored in or retrieved from a database
Partial | Whether the DatabaseEntry is partial record.
PartialLen | The byte length of the partial record being read or written by the application
PartialOffset | The offset of the partial record being read or written by the application, in bytes.
ReadOnly | Set this DatabaseEntry as read only - Berkeley DB cannot alter the entry.

See Also

DatabaseEntry Class


DatabaseEntry Constructor

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEntry Constructor
DatabaseEntry Class See Also Send Feedback

Overload List

Name | Description
DatabaseEntry()()() | Create a new, empty DatabaseEntry object.
DatabaseEntry(array<Byte>[]()[]) | Create a new DatabaseEntry object, with the specified data
DatabaseEntry(UInt32, UInt32) | Create a new partial DatabaseEntry object.
DatabaseEntry(array<Byte>[]()[], UInt32, UInt32) | Create a new partial DatabaseEntry object, with the specified data

See Also

DatabaseEntry Class
DatabaseEntry Members


DatabaseEntry Constructor

[image]

Berkeley DB .NET API Documentation
DatabaseEntry Constructor
DatabaseEntry Class See Also Send Feedback
Create a new, empty DatabaseEntry object.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DatabaseEntry()

See Also

DatabaseEntry Class
DatabaseEntry Overload


DatabaseEntry Constructor (Byte[])

[image]

Berkeley DB .NET API Documentation
DatabaseEntry Constructor (array<Byte>[]()[])
DatabaseEntry Class See Also Send Feedback
Create a new DatabaseEntry object, with the specified data

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry(
    byte[] data
)
Visual Basic (Declaration)
Public Sub New ( _
    data As Byte() _
)
Visual C++
public:
DatabaseEntry(
    array<unsigned char>^ data
)

Parameters

data
Type: array< System..::.Byte >[]()[]
The new object's Data

See Also

DatabaseEntry Class
DatabaseEntry Overload


DatabaseEntry Constructor (UInt32, UInt32)

[image]

Berkeley DB .NET API Documentation
DatabaseEntry Constructor (UInt32, UInt32)
DatabaseEntry Class See Also Send Feedback
Create a new partial DatabaseEntry object.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry(
    uint offset,
    uint len
)
Visual Basic (Declaration)
Public Sub New ( _
    offset As UInteger, _
    len As UInteger _
)
Visual C++
public:
DatabaseEntry(
    unsigned int offset,
    unsigned int len
)

Parameters

offset
Type: System..::.UInt32
The offset of the partial record being read or written by the application, in bytes
len
Type: System..::.UInt32
The byte length of the partial record being read or written by the application

See Also

DatabaseEntry Class
DatabaseEntry Overload


DatabaseEntry Constructor (Byte[], UInt32, UInt32)

[image]

Berkeley DB .NET API Documentation
DatabaseEntry Constructor (array<Byte>[]()[], UInt32, UInt32)
DatabaseEntry Class See Also Send Feedback
Create a new partial DatabaseEntry object, with the specified data

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry(
    byte[] data,
    uint offset,
    uint len
)
Visual Basic (Declaration)
Public Sub New ( _
    data As Byte(), _
    offset As UInteger, _
    len As UInteger _
)
Visual C++
public:
DatabaseEntry(
    array<unsigned char>^ data,
    unsigned int offset,
    unsigned int len
)

Parameters

data
Type: array< System..::.Byte >[]()[]
Byte array wrapped by the DatabaseEntry
offset
Type: System..::.UInt32
The offset of the partial record being read or written by the application, in bytes
len
Type: System..::.UInt32
The byte length of the partial record being read or written by the application

See Also

DatabaseEntry Class
DatabaseEntry Overload


DatabaseEntry Methods

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEntry Methods
DatabaseEntry Class See Also Send Feedback

The DatabaseEntry type exposes the following members.

Methods

Name | Description
Dispose | Release the resources held by the underlying C library.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DatabaseEntry Class


Dispose Method

[image]

Berkeley DB .NET API Documentation
DatabaseEntry..::.Dispose Method
DatabaseEntry Class See Also Send Feedback
Release the resources held by the underlying C library.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public virtual void Dispose()
Visual Basic (Declaration)
Public Overridable Sub Dispose
Visual C++
public:
virtual void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

DatabaseEntry Class


DatabaseEntry Properties

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEntry Properties
DatabaseEntry Class See Also Send Feedback

The DatabaseEntry type exposes the following members.

Properties

Name | Description
Blob | Whether the record data will be stored as a blob, regardless of size.
Data | The byte string stored in or retrieved from a database
Partial | Whether the DatabaseEntry is partial record.
PartialLen | The byte length of the partial record being read or written by the application
PartialOffset | The offset of the partial record being read or written by the application, in bytes.
ReadOnly | Set this DatabaseEntry as read only - Berkeley DB cannot alter the entry.

See Also

DatabaseEntry Class


Blob Property

[image]

Berkeley DB .NET API Documentation
DatabaseEntry..::.Blob Property
DatabaseEntry Class See Also Send Feedback
Whether the record data will be stored as a blob, regardless of size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Blob { get; set; }
Visual Basic (Declaration)
Public Property Blob As Boolean
Visual C++
public:
property bool Blob {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEntry Class


Data Property

[image]

Berkeley DB .NET API Documentation
DatabaseEntry..::.Data Property
DatabaseEntry Class See Also Send Feedback
The byte string stored in or retrieved from a database

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public byte[] Data { get; set; }
Visual Basic (Declaration)
Public Property Data As Byte()
Visual C++
public:
property array<unsigned char>^ Data {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

DatabaseEntry Class


Partial Property

[image]

Berkeley DB .NET API Documentation
DatabaseEntry..::.Partial Property
DatabaseEntry Class See Also Send Feedback
Whether the DatabaseEntry is partial record.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Partial { get; set; }
Visual Basic (Declaration)
Public Property Partial As Boolean
Visual C++
public:
property bool Partial {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEntry Class


PartialLen Property

[image]

Berkeley DB .NET API Documentation
DatabaseEntry..::.PartialLen Property
DatabaseEntry Class See Also Send Feedback
The byte length of the partial record being read or written by the application

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PartialLen { get; set; }
Visual Basic (Declaration)
Public Property PartialLen As UInteger
Visual C++
public:
property unsigned int PartialLen {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEntry Class


PartialOffset Property

[image]

Berkeley DB .NET API Documentation
DatabaseEntry..::.PartialOffset Property
DatabaseEntry Class See Also Send Feedback
The offset of the partial record being read or written by the application, in bytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PartialOffset { get; set; }
Visual Basic (Declaration)
Public Property PartialOffset As UInteger
Visual C++
public:
property unsigned int PartialOffset {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEntry Class


ReadOnly Property

[image]

Berkeley DB .NET API Documentation
DatabaseEntry..::.ReadOnly Property
DatabaseEntry Class See Also Send Feedback
Set this DatabaseEntry as read only - Berkeley DB cannot alter the entry.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEntry Class


DatabaseEnvironment Class

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment Class
Members See Also Send Feedback
A class representing a Berkeley DB database environment - a collection including support for some or all of caching, locking, logging and transaction subsystems, as well as databases and log files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DatabaseEnvironment
Visual Basic (Declaration)
Public Class DatabaseEnvironment
Visual C++
public ref class DatabaseEnvironment

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseEnvironment

See Also

DatabaseEnvironment Members


DatabaseEnvironment Members

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment Members
DatabaseEnvironment Class Methods Properties See Also Send Feedback

The DatabaseEnvironment type exposes the following members.

Methods

Name | Description
ArchivableDatabaseFiles
The database files that need to be archived in order to recover the database from catastrophic failure. Database files that have not been accessed during the lifetime of the current log files are not included in this list. It is also possible that some of the files referred to by the log have since been deleted from the system.
ArchivableLogFiles
The names of all of the log files that are no longer in use (for example, that are no longer involved in active transactions), and that may safely be archived for catastrophic recovery and then removed from the system.
Backup
Perform a hot back up of the open environment.

All files used by the environment are backed up, so long as the normal rules for file placement are followed. For information on how files are normally placed relative to the environment directory, see the "Berkeley DB File Naming" section in the Berkeley DB Reference Guide.

By default, data directories and the log directory specified relative to the home directory are recreated relative to the target directory. If absolute path names are used, then use the SingleDir method.

This method provides the same functionality as the db_hotbackup utility. However, this method does not perform the housekeeping actions performed by that utility. In particular, you may want to run a checkpoint before calling this method. To run a checkpoint, use the Checkpoint()()() method. For more information on checkpoints, see the "Checkpoint" section in the Berkeley DB Reference Guide.

To back up a single database file within the environment, use the BackupDatabase(String, String, Boolean) method.

In addition to the configuration options available using the BackupOptions class, additional tuning modifications can be made using the BackupReadCount, BackupReadSleepDuration, BackupBufferSize, and BackupWriteDirect properties. Alternatively, you can write your own custom hot back up facility using the IBackup interface.

BackupDatabase
Perform a hot back up of a single database file contained within the environment.

To back up the entire environment, use the Backup(String, BackupOptions) method.

You can make some tuning modifications to the backup process using the BackupReadCount, BackupReadSleepDuration, BackupBufferSize, and BackupWriteDirect properties. Alternatively, you can write your own custom hot back up facility using the IBackup interface.

BeginCDSGroup
Allocate a locker ID in an environment configured for Berkeley DB Concurrent Data Store applications.
BeginTransaction | Overloaded.
Checkpoint | Overloaded.
Close
By closing the Berkeley DB environment you can free allocated resources and close any open databases along with the underlying subsystems.
CloseForceSync
Close the Berkeley DB environment, freeing any allocated resources, closing any open databases as well as underlying subsystems.
CloseForceSyncAndForceSyncEnv
CloseForceSyncEnv
Close the Berkeley DB environment, freeing any allocated resources, closing any open databases as well as underlying subsystems.
DetectDeadlocks
Run one iteration of the deadlock detector. The deadlock detector traverses the lock table and marks one of the participating lock requesters for rejection in each deadlock it finds.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
FailCheck
Check for threads of control (either a true thread or a process) that have exited while manipulating Berkeley DB library data structures, while holding a logical database lock, or with an unresolved transaction (that is, a transaction that was never aborted or committed).
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
IsTransactionApplied
This method checks to see if a specified transaction has been replicated from the master of a replication group. It may be called by applications using either the Base API or the Replication Manager.
LockingSystemStats | Overloaded.
LogFile
Map an LSN object to a log filename
LogFiles
The names of all of the log files
LogFlush | Overloaded.
LoggingSystemStats | Overloaded.
LogVerify
Verify log records of this environment.
LogWrite
Append a record to the log
MPoolSystemStats | Overloaded.
MutexSystemStats | Overloaded.
Open
Instantiate a new DatabaseEnvironment object and open the Berkeley DB environment represented by home.
Panic
Set the panic state for the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException.)
PrintLockingSystemStats | Overloaded.
PrintLoggingSystemStats | Overloaded.
PrintMPoolSystemStats | Overloaded.
PrintMutexSystemStats | Overloaded.
PrintReplicationSystemStats | Overloaded.
PrintRepMgrSystemStats | Overloaded.
PrintStats | Overloaded.
PrintSubsystemStats | Overloaded.
PrintTransactionSystemStats | Overloaded.
Recover
Restore transactions that were prepared, but not yet resolved at the time of the system shut down or crash, to their state prior to the shut down or crash, including any locks previously held.
RegionSetMemoryLimit
The amount of memory to be used by shared structures in the main environment region. These are structures other than mutexes and the page cache (memory pool).
Remove Overloaded.

The environment regions, including any backing files, are removed. Any log or database files and the environment directory are not removed.

If there are processes that have called Open(String, DatabaseEnvironmentConfig) without calling Close()()() (that is, there are processes currently using the environment), Remove fails without further action.

Calling Remove should not be necessary for most applications because the Berkeley DB environment is cleaned up as part of normal database recovery procedures. However, applications may want to call Remove as part of application shut down to free up system resources. For example, if SystemMemory was specified to Open(String, DatabaseEnvironmentConfig), it may be useful to call Remove in order to release system shared memory segments that have been allocated. Or, on architectures in which mutexes require allocation of underlying system resources, it may be useful to call Remove in order to release those resources. Alternatively, if recovery is not required because no database state is maintained across failures, and no system resources need to be released, it is possible to clean up an environment by simply removing all the Berkeley DB files in the database environment's directories.

In multithreaded applications, only a single thread may call Remove.

RemoveDB | Overloaded.
RemoveUnusedLogFiles
Remove log files that are no longer needed. Automatic log file removal is likely to make catastrophic recovery impossible.
RenameDB | Overloaded.
RepHoldElection Overloaded.

RepHoldElection is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

If the election is successful, Berkeley DB notifies the application of the results of the election by means of either the REP_ELECTED or REP_NEWMASTER events (see EventNotifyfor more information). The application is responsible for adjusting its relationship to the other database environments in the replication group, including directing all database updates to the newly selected master, in accordance with the results of the election.

The thread of control that calls RepHoldElection must not be the thread of control that processes incoming messages; processing the incoming messages is necessary to successfully complete an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

ReplicationSystemStats | Overloaded.
RepMgrChannel
Create DbChannel with given eid.
RepmgrSetIncomingQueueMax
Set a byte-count limit on the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RepMgrSite | Overloaded.
RepMgrSiteConfig
Configure a site in the replication manager.
RepMgrStartClient Overloaded.

There are two ways to build Berkeley DB replication applications: the most common approach is to use the Berkeley DB library "replication manager" support, where the Berkeley DB library manages the replication group, including network transport, all replication message processing and acknowledgment, and group elections. Applications using the replication manager support generally make the following calls:

  1. Configure the local site in the replication group, RepMgrLocalSite.
  2. Call RepMgrSiteConfig(DbSiteConfig) to configure the remote site(s) in the replication group.
  3. Configure the message acknowledgment policy (RepMgrAckPolicy) which provides the replication group's transactional needs.
  4. Configure the local site's election priority, RepPriority.
  5. Call RepMgrStartClient(Int32) or RepMgrStartMaster(Int32) to start the replication application.

For more information on building replication manager applications, please see the Replication Getting Started Guide included in the Berkeley DB documentation.

Applications with special needs (for example, applications using network protocols not supported by the Berkeley DB replication manager), must perform additional configuration and call other Berkeley DB replication methods. For more information on building advanced replication applications, please see the Base Replication API section in the Berkeley DB Programmer's Reference Guide for more information.

Starting the replication manager consists of opening the TCP/IP listening socket to accept incoming connections, and starting all necessary background threads. When multiple processes share a database environment, only one process can open the listening socket; RepMgrStartClient(Int32) (and RepMgrStartMaster(Int32)) automatically open the socket in the first process to call it, and skips this step in the later calls from other processes.

RepMgrStartMaster
Start the replication manager as a master site, and do not call for an election.
RepMgrSystemStats | Overloaded.
RepProcessMessage
Process an incoming replication message sent by a member of the replication group to the local database environment.
RepSetClockskew
Set the clock skew ratio among replication group members based on the fastest and slowest measurements among the group for use with master leases.
RepSetRetransmissionRequest
Set a threshold for the minimum and maximum time that a client waits before requesting retransmission of a missing message.
RepSetTransmitLimit
Set a byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32). The limit is not a hard limit, and the record that exceeds the limit is the last record to be sent.
RepSetTransport
Initialize the communication infrastructure for a database environment participating in a replicated application.
RepStartClient Overloaded.

RepStartClient is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

Replication master environments are the only database environments where replicated databases may be modified. Replication client environments are read-only as long as they are clients. Replication client environments may be upgraded to be replication master environments in the case that the current master fails or there is no master present. If master leases are in use, this method cannot be used to appoint a master, and should only be used to configure a database environment as a master as the result of an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

RepStartMaster Overloaded.

RepStartMaster is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

Replication master environments are the only database environments where replicated databases may be modified. Replication client environments are read-only as long as they are clients. Replication client environments may be upgraded to be replication master environments in the case that the current master fails or there is no master present. If master leases are in use, this method cannot be used to appoint a master, and should only be used to configure a database environment as a master as the result of an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

RepSync
Force master synchronization to begin for this client.
ResetFileID
Allow database files to be copied and used in the same database environment as the original.
ResetLSN
Allow database files to be moved from one transactional database environment to another.
SetMaxSequentialWrites
Limit the number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
SyncMemPool | Overloaded.
ToString
Returns a string that represents the current object.
(Inherited from Object.)
TransactionSystemStats | Overloaded.
TrickleCleanMemPool
Ensure that a specified percent of the pages in the cache are clean, by writing dirty pages to their backing files.
WriteToLog Overloaded.
WriteToLog allows applications to include information in the database environment log files, for later review using the db_printlog utility. This method is intended for debugging and performance tuning.
WriteToLog allows applications to include information in the database environment log files, for later review using the db_printlog utility. This method is intended for debugging and performance tuning.

Properties

Name | Description
AutoCommit | If true, database operations for which no explicit transaction handle was specified, and which modify databases in the database environment, are automatically enclosed within a transaction.
BackupBufferSize | The size of the buffer, in bytes, to read from the database during a hot backup.
BackupHandler | Sets the IBackup interface to be used when performing hot backups. This interface is used to override the default behavior used by the Backup(String, BackupOptions) and BackupDatabase(String, String, Boolean) methods.
BackupReadCount | The number of pages to read before pausing during the hot backup. Increasing this value increases the amount of I/O the backup process performs for any given time interval. If your application is already heavily I/O bound, setting this value to a lower number may help to improve your overall data throughput by reducing the I/O demands placed on your system. By default, all pages are read without a pause.
BackupReadSleepDuration | The number of microseconds to sleep between batches of reads during a hot backup. Increasing this value decreases the amount of I/O the backup process performs for any given time interval. If your application is already heavily I/O bound, setting this value to a higher number may help to improve your overall data throughput by reducing the I/O demands placed on your system.
BackupWriteDirect | If true, direct I/O is used when writing pages to the disk during a hot backup. For some environments, direct I/O can provide faster write throughput, but usually it is slower because the OS buffer pool offers asynchronous activity.
BlobDir | The path of the directory where blobs are stored.
BlobThreshold | The size in bytes which is used to determine when a data item is stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, databases opened in the environment default to never using blob support. It is illegal to enable blob support if replication is enabled for the environment.
CacheSize | The size of the shared memory buffer pool (the cache).
CDB_ALLDB | If true, Berkeley DB Concurrent Data Store applications perform locking on an environment-wide basis rather than on a per-database basis.
Create | If true, Berkeley DB subsystems create any underlying files, as necessary.
DataDirs | The array of directories where database files are stored.
DeadlockResolution | The deadlock detector configuration, specifying which lock request(s) should be rejected. As transactions acquire locks on behalf of a single locker ID, rejecting a lock request associated with a transaction normally requires the transaction to be aborted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption.
ErrorFeedback | The mechanism for reporting detailed error messages to the application.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
EventNotify | A delegate which is called to notify the process of specific Berkeley DB events.
Feedback | Monitor progress within long running operations.
ForceFlush | If true, flush database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.
FreeThreaded | If true, the object is free-threaded; that is, concurrently usable by multiple threads in the address space.
Home | The database environment home directory.
HotbackupInProgress | Whether there is any hot backup in progress.
InitLockCount | The number of locks allocated when the environment is created
InitLockerCount | The number of lockers allocated when the environment is created
InitLockObjectCount | The number of lock objects allocated when the environment is created
InitLogIdCount | The number of log identifier objects allocated when the environment is created
InitMutexes | The initial number of mutexes allocated
InitRegions | If true, Berkeley DB page-faults shared regions into memory when initially creating or joining a Berkeley DB environment.
InitThreadCount | The number of thread objects allocated when the environment is created
InitTxnCount | The number of transaction objects allocated when the environment is created
IntermediateDirMode | The intermediate directory permissions.
LockConflictMatrix | The current lock conflicts array.
Lockdown | If true, lock shared Berkeley DB environment files and memory-mapped databases into memory.
LockPartitions | The number of lock table partitions used in the Berkeley DB environment.
LockTableSize | The size of the lock table in the Berkeley DB environment.
LockTimeout | A value, in microseconds, representing lock timeouts.
LogAutoRemove | If true, Berkeley DB automatically removes log files that are no longer needed.
LogBlobContent | If true, enables full logging of blob data. Required if using HA or the hotbackup utility.
LogBufferSize | The size of the in-memory log buffer, in bytes
LogDir | The path of a directory to be used as the location of logging files. Log files created by the Log Manager subsystem are created in this directory.
LogFileMode | The absolute file mode for created log files. This property is only useful for the rare Berkeley DB application that does not control its umask value.
LogForceSync | If true, Berkeley DB flushes log writes to the backing disk before returning from the write system call, rather than flushing log writes explicitly in a separate system call, as necessary.
LogInMemory | If true, transaction logs are maintained in-memory rather than on disk. This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability).
LogNoBuffer | If true, system buffering is turned off for Berkeley DB log files to avoid double caching.
LogNoSync | If true, Berkeley DB avoids the fsync() call when the log files are flushed.
LogRegionSize | The size of the underlying logging area of the Berkeley DB environment, in bytes.
LogZeroOnCreate | If true, all pages of a log file are zeroed when that log file is created.
MaxCacheSize | The maximum cache size
MaxLockers | The maximum number of locking entities supported by the Berkeley DB environment.
MaxLocks | The maximum number of locks supported by the Berkeley DB environment.
MaxLogFileSize | The maximum size of a single file in the log, in bytes. Because LSN Offsets are unsigned four-byte values, the size may not be larger than the maximum unsigned four-byte value.
MaxMutexes | The total number of mutexes allocated
MaxObjects | The maximum number of locked objects
MaxOpenFiles | The number of file descriptors the library opens concurrently when flushing dirty pages from the cache.
MaxSequentialWrites | The number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
MaxTransactions | The number of active transactions supported by the environment. This value bounds the size of the memory allocated for transactions. Child transactions are counted as active until they either commit or abort.
messageFeedback | The mechanism for reporting detailed statistic messages to the application.
MetadataDir | The path of directory to store the persistent metadata.
MMapSize | The maximum file size, in bytes, for a file to be mapped into the process address space. If no value is specified, it defaults to 10MB.
Msgfile | The message file.
MutexAlignment | The mutex alignment, in bytes.
MutexIncrement | The number of additional mutexes allocated.
NoBuffer | If true, turn off system buffering of Berkeley DB database files to avoid double caching.
NoLocking | If true, Berkeley DB grants all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.
NoMMap | If true, Berkeley DB copies read-only database files into the local cache instead of potentially mapping them into process memory.
NoPanic | If true, Berkeley DB ignores any panic state in the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException.) This functionality should never be used for purposes other than debugging.
NumTestAndSetSpins | The number of times that test-and-set mutexes should spin without blocking. The value defaults to 1 on uniprocessor systems and to 50 times the number of processors on multiprocessor systems.
Overwrite | If true, overwrite files stored in encrypted formats before deleting them.
Private | If true, allocate region memory from the heap instead of from memory backed by the filesystem or system shared memory.
RegionMemoryLimitBytes | The bytes component of the byte-count limit on the amount of memory to be used by shared structures in the main environment region. These are the structures other than mutexes and the page cache (memory pool).
RegionMemoryLimitGBytes | The gigabytes component of the byte-count limit on the amount of memory to be used by shared structures in the main environment region. These are the structures other than mutexes and the page cache (memory pool).
Register | If true, Berkeley DB checks if recovery is needed to be performed before opening the database environment.
RepAckTimeout | The amount of time the replication manager's transport function waits to collect enough acknowledgments from replication group clients, before giving up and returning a failure indication. The default wait time is 1 second.
RepAutoInit | If true, the replication master automatically re-initializes outdated clients (defaults to true).
RepBulkTransfer | If true, the replication master sends groups of records to the clients in a single network transfer
RepCheckpointDelay | The amount of time a master site delays between completing a checkpoint and writing a checkpoint record into the log.
RepClockskewFast | The value, relative to RepClockskewSlow, of the fastest clock in the group of sites.
RepClockskewSlow | The value of the slowest clock in the group of sites.
RepConnectionRetry | The amount of time the replication manager waits before trying to re-establish a connection to another site after a communication failure. The default wait time is 30 seconds.
RepDelayClientSync | If true, the client should delay synchronizing to a newly declared master (defaults to false). Clients configured in this way remain unsynchronized until the application calls RepSync()()().
RepElectionRetry | Configure the amount of time the replication manager waits before retrying a failed election. The default wait time is 10 seconds.
RepElectionTimeout | The timeout period for an election. The default timeout is 2 seconds.
RepFullElectionTimeout | An optional configuration timeout period to wait for full election participation the first time the replication group finds a master. By default this option is turned off and normal election timeouts are used. (See the Elections section in the Berkeley DB Reference Guide for more information.)
RepHeartbeatMonitor | The amount of time the replication manager, running at a client site, waits for some message activity on the connection from the master (heartbeats or other messages) before concluding that the connection has been lost. When 0 (the default), no monitoring is performed.
RepHeartbeatSend | The frequency at which the replication manager, running at a master site, broadcasts a heartbeat message in an otherwise idle system. When 0 (the default), no heartbeat messages are sent.
RepInMemory | If true, replication only stores the internal information in-memory and cannot keep persistent state across a site crash or reboot. By default, it is false and replication creates files in the environment home directory to preserve the internal information.
RepLeaseTimeout | The amount of time a client grants its master lease to a master. When using master leases all sites in a replication group must use the same lease timeout value. There is no default value. If leases are desired, this method must be called prior to calling RepStartClient()()() or RepStartMaster()()().
ReplicationView | The function used to create a replication view that determines whether a database file is replicated to the local site.
RepMessageDispatch | Set the message dispatch function. It is responsible for receiving messages sent from remote sites using either SendMessage(array<DatabaseEntry>[]()[]) or SendRequest(array<DatabaseEntry>[]()[], UInt32). If the message received by this function was sent using SendMessage(array<DatabaseEntry>[]()[]), then no response is required. If the message was sent using SendRequest(array<DatabaseEntry>[]()[], UInt32), then this function must send a response using SendMessage(array<DatabaseEntry>[]()[]).
RepMgrAckPolicy | Specify how master and client sites handle acknowledgment of replication messages which are necessary for "permanent" records. The current implementation requires all sites in a replication group configure the same acknowledgement policy.
RepmgrIncomingQueueMaxBytes | The bytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RepmgrIncomingQueueMaxGBytes | The gigabytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RepMgrLocalSite | The local site of the replication manager. Returns null if the local site has not been configured.
RepMgrRemoteSites | The status of the sites currently known by the replication manager.
RepMgrRunElections | If true, Replication Manager automatically runs elections to choose a new master when the old master disconnects (defaults to true).
RepNoBlocking | If true, errors are returned immediately for Berkeley DB method calls that would normally block while clients are in recovery (defaults to false).
RepNSites | The total number of sites in the replication group.
RepPrefmasClient | This flag is used to specify the client site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The client site in a preferred master replication group takes over temporarily as master when the preferred master site is unavailable.
RepPrefmasMaster | This flag is used to specify the preferred master site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The preferred master site operates as the master site whenever possible.
RepPriority | The database environment's priority in replication group elections. A special value of 0 indicates that this environment cannot be a replication group master. If not configured, then a default value of 100 is used.
RepRetransmissionRequestMax | The maximum number of microseconds a client waits before requesting retransmission.
RepRetransmissionRequestMin | The minimum number of microseconds a client waits before requesting retransmission.
RepStrict2Site | Replication Manager observes the strict "majority" rule in managing elections, even in a group with only 2 sites. The client in a 2-site group is unable to take over as master if the original master fails or becomes disconnected. (See the Elections section in the Berkeley DB Reference Guide for more information.) Both sites in the replication group should have the same value for this parameter.
RepTransmitLimitBytes | The bytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
RepTransmitLimitGBytes | The gigabytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
RepTransport | The delegate used to transmit data using the replication application's communication infrastructure.
RepUseMasterLeases | If true, master leases are used for this site (defaults to false).
RunFatalRecovery | If true, catastrophic recovery was run on this environment before opening it for normal use.
RunRecovery | If true, normal recovery was run on this environment before opening it for normal use.
SequentialWritePause | The number of microseconds the thread of control pauses before scheduling further write operations.
SetThreadID | A delegate that returns a unique identifier pair for the current thread of control.
SetThreadName | A delegate that formats a process ID and thread ID identifier pair.
SystemMemory | If true, allocate region memory from system shared memory instead of from heap memory or memory backed by the filesystem.
TempDir | The path of a directory to be used as the location for temporary files.
ThreadCount | An approximate number of threads in the database environment.
ThreadIsAlive | A delegate that returns if a thread of control (either a true thread or a process) is still running.
TimeNotGranted | If true, database calls timing out based on lock or transaction timeout values throw LockNotGrantedException instead of DeadlockException.
TxnNoSync | If true, Berkeley DB does not write or synchronously flush the log on transaction commit.
TxnNoWait | If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw DeadlockException (or LockNotGrantedException if configured with TimeNotGranted).
TxnSnapshot | If true, all transactions in the environment are started as if Snapshot was passed to BeginTransaction()()(), and all non-transactional cursors are opened as if SnapshotIsolation was passed to Cursor()()().
TxnTimeout | A value, in microseconds, representing transaction timeouts.
TxnTimestamp | The recovery timestamp
TxnWriteNoSync | If true, Berkeley DB writes, but does not synchronously flush, the log on transaction commit.
UseEnvironmentVars | The Berkeley DB process' environment may be permitted to specify information to be used when naming files; see Berkeley DB File Naming in the Programmer's Reference Guide for more information.
UseMVCC | If true, all databases in the environment are opened as if UseMVCC was set.
UsingCDB | If true, locking for the Berkeley DB Concurrent Data Store product was initialized.
UsingLocking | If true, the locking subsystem was initialized.
UsingLogging | If true, the logging subsystem was initialized.
UsingMPool | If true, the shared memory buffer pool subsystem was initialized.
UsingReplication | If true, the replication subsystem was initialized.
UsingTxns | If true, the transaction subsystem was initialized.
Verbosity | Specific additional informational and debugging messages in the Berkeley DB message output.
YieldCPU | If true, Berkeley DB yields the processor immediately after each page or mutex acquisition.

See Also

DatabaseEnvironment Class


DatabaseEnvironment Methods

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment Methods
DatabaseEnvironment Class See Also Send Feedback

The DatabaseEnvironment type exposes the following members.

Methods

Name | Description
ArchivableDatabaseFiles
The database files that need to be archived in order to recover the database from catastrophic failure. Database files that have not been accessed during the lifetime of the current log files are not included in this list. It is also possible that some of the files referred to by the log have since been deleted from the system.
ArchivableLogFiles
The names of all of the log files that are no longer in use (for example, that are no longer involved in active transactions), and that may safely be archived for catastrophic recovery and then removed from the system.
Backup
Perform a hot back up of the open environment.

All files used by the environment are backed up, so long as the normal rules for file placement are followed. For information on how files are normally placed relative to the environment directory, see the "Berkeley DB File Naming" section in the Berkeley DB Reference Guide.

By default, data directories and the log directory specified relative to the home directory are recreated relative to the target directory. If absolute path names are used, then use the SingleDir method.

This method provides the same functionality as the db_hotbackup utility. However, this method does not perform the housekeeping actions performed by that utility. In particular, you may want to run a checkpoint before calling this method. To run a checkpoint, use the Checkpoint()()() method. For more information on checkpoints, see the "Checkpoint" section in the Berkeley DB Reference Guide.

To back up a single database file within the environment, use the BackupDatabase(String, String, Boolean) method.

In addition to the configuration options available using the BackupOptions class, additional tuning modifications can be made using the BackupReadCount, BackupReadSleepDuration, BackupBufferSize, and BackupWriteDirect properties. Alternatively, you can write your own custom hot back up facility using the IBackup interface.

BackupDatabase
Perform a hot back up of a single database file contained within the environment.

To back up the entire environment, use the Backup(String, BackupOptions) method.

You can make some tuning modifications to the backup process using the BackupReadCount, BackupReadSleepDuration, BackupBufferSize, and BackupWriteDirect properties. Alternatively, you can write your own custom hot back up facility using the IBackup interface.

BeginCDSGroup
Allocate a locker ID in an environment configured for Berkeley DB Concurrent Data Store applications.
BeginTransaction | Overloaded.
Checkpoint | Overloaded.
Close
By closing the Berkeley DB environment you can free allocated resources and close any open databases along with the underlying subsystems.
CloseForceSync
Close the Berkeley DB environment, freeing any allocated resources, closing any open databases as well as underlying subsystems.
CloseForceSyncAndForceSyncEnv
CloseForceSyncEnv
Close the Berkeley DB environment, freeing any allocated resources, closing any open databases as well as underlying subsystems.
DetectDeadlocks
Run one iteration of the deadlock detector. The deadlock detector traverses the lock table and marks one of the participating lock requesters for rejection in each deadlock it finds.
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
FailCheck
Check for threads of control (either a true thread or a process) that have exited while manipulating Berkeley DB library data structures, while holding a logical database lock, or with an unresolved transaction (that is, a transaction that was never aborted or committed).
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
IsTransactionApplied
This method checks to see if a specified transaction has been replicated from the master of a replication group. It may be called by applications using either the Base API or the Replication Manager.
LockingSystemStats | Overloaded.
LogFile
Map an LSN object to a log filename
LogFiles
The names of all of the log files
LogFlush | Overloaded.
LoggingSystemStats | Overloaded.
LogVerify
Verify log records of this environment.
LogWrite
Append a record to the log
MPoolSystemStats | Overloaded.
MutexSystemStats | Overloaded.
Open
Instantiate a new DatabaseEnvironment object and open the Berkeley DB environment represented by home.
Panic
Set the panic state for the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException.)
PrintLockingSystemStats | Overloaded.
PrintLoggingSystemStats | Overloaded.
PrintMPoolSystemStats | Overloaded.
PrintMutexSystemStats | Overloaded.
PrintReplicationSystemStats | Overloaded.
PrintRepMgrSystemStats | Overloaded.
PrintStats | Overloaded.
PrintSubsystemStats | Overloaded.
PrintTransactionSystemStats | Overloaded.
Recover
Restore transactions that were prepared, but not yet resolved at the time of the system shut down or crash, to their state prior to the shut down or crash, including any locks previously held.
RegionSetMemoryLimit
The amount of memory to be used by shared structures in the main environment region. These are structures other than mutexes and the page cache (memory pool).
Remove Overloaded.

The environment regions, including any backing files, are removed. Any log or database files and the environment directory are not removed.

If there are processes that have called Open(String, DatabaseEnvironmentConfig) without calling Close()()() (that is, there are processes currently using the environment), Remove fails without further action.

Calling Remove should not be necessary for most applications because the Berkeley DB environment is cleaned up as part of normal database recovery procedures. However, applications may want to call Remove as part of application shut down to free up system resources. For example, if SystemMemory was specified to Open(String, DatabaseEnvironmentConfig), it may be useful to call Remove in order to release system shared memory segments that have been allocated. Or, on architectures in which mutexes require allocation of underlying system resources, it may be useful to call Remove in order to release those resources. Alternatively, if recovery is not required because no database state is maintained across failures, and no system resources need to be released, it is possible to clean up an environment by simply removing all the Berkeley DB files in the database environment's directories.

In multithreaded applications, only a single thread may call Remove.

RemoveDB | Overloaded.
RemoveUnusedLogFiles
Remove log files that are no longer needed. Automatic log file removal is likely to make catastrophic recovery impossible.
RenameDB | Overloaded.
RepHoldElection Overloaded.

RepHoldElection is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

If the election is successful, Berkeley DB notifies the application of the results of the election by means of either the REP_ELECTED or REP_NEWMASTER events (see EventNotifyfor more information). The application is responsible for adjusting its relationship to the other database environments in the replication group, including directing all database updates to the newly selected master, in accordance with the results of the election.

The thread of control that calls RepHoldElection must not be the thread of control that processes incoming messages; processing the incoming messages is necessary to successfully complete an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

ReplicationSystemStats | Overloaded.
RepMgrChannel
Create DbChannel with given eid.
RepmgrSetIncomingQueueMax
Set a byte-count limit on the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RepMgrSite | Overloaded.
RepMgrSiteConfig
Configure a site in the replication manager.
RepMgrStartClient Overloaded.

There are two ways to build Berkeley DB replication applications: the most common approach is to use the Berkeley DB library "replication manager" support, where the Berkeley DB library manages the replication group, including network transport, all replication message processing and acknowledgment, and group elections. Applications using the replication manager support generally make the following calls:

  1. Configure the local site in the replication group, RepMgrLocalSite.
  2. Call RepMgrSiteConfig(DbSiteConfig) to configure the remote site(s) in the replication group.
  3. Configure the message acknowledgment policy (RepMgrAckPolicy) which provides the replication group's transactional needs.
  4. Configure the local site's election priority, RepPriority.
  5. Call RepMgrStartClient(Int32) or RepMgrStartMaster(Int32) to start the replication application.

For more information on building replication manager applications, please see the Replication Getting Started Guide included in the Berkeley DB documentation.

Applications with special needs (for example, applications using network protocols not supported by the Berkeley DB replication manager), must perform additional configuration and call other Berkeley DB replication methods. For more information on building advanced replication applications, please see the Base Replication API section in the Berkeley DB Programmer's Reference Guide for more information.

Starting the replication manager consists of opening the TCP/IP listening socket to accept incoming connections, and starting all necessary background threads. When multiple processes share a database environment, only one process can open the listening socket; RepMgrStartClient(Int32) (and RepMgrStartMaster(Int32)) automatically open the socket in the first process to call it, and skips this step in the later calls from other processes.

RepMgrStartMaster
Start the replication manager as a master site, and do not call for an election.
RepMgrSystemStats | Overloaded.
RepProcessMessage
Process an incoming replication message sent by a member of the replication group to the local database environment.
RepSetClockskew
Set the clock skew ratio among replication group members based on the fastest and slowest measurements among the group for use with master leases.
RepSetRetransmissionRequest
Set a threshold for the minimum and maximum time that a client waits before requesting retransmission of a missing message.
RepSetTransmitLimit
Set a byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32). The limit is not a hard limit, and the record that exceeds the limit is the last record to be sent.
RepSetTransport
Initialize the communication infrastructure for a database environment participating in a replicated application.
RepStartClient Overloaded.

RepStartClient is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

Replication master environments are the only database environments where replicated databases may be modified. Replication client environments are read-only as long as they are clients. Replication client environments may be upgraded to be replication master environments in the case that the current master fails or there is no master present. If master leases are in use, this method cannot be used to appoint a master, and should only be used to configure a database environment as a master as the result of an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

RepStartMaster Overloaded.

RepStartMaster is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

Replication master environments are the only database environments where replicated databases may be modified. Replication client environments are read-only as long as they are clients. Replication client environments may be upgraded to be replication master environments in the case that the current master fails or there is no master present. If master leases are in use, this method cannot be used to appoint a master, and should only be used to configure a database environment as a master as the result of an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

RepSync
Force master synchronization to begin for this client.
ResetFileID
Allow database files to be copied and used in the same database environment as the original.
ResetLSN
Allow database files to be moved from one transactional database environment to another.
SetMaxSequentialWrites
Limit the number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
SyncMemPool | Overloaded.
ToString
Returns a string that represents the current object.
(Inherited from Object.)
TransactionSystemStats | Overloaded.
TrickleCleanMemPool
Ensure that a specified percent of the pages in the cache are clean, by writing dirty pages to their backing files.
WriteToLog Overloaded.
WriteToLog allows applications to include information in the database environment log files, for later review using the db_printlog utility. This method is intended for debugging and performance tuning.
WriteToLog allows applications to include information in the database environment log files, for later review using the db_printlog utility. This method is intended for debugging and performance tuning.

See Also

DatabaseEnvironment Class


ArchivableDatabaseFiles Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ArchivableDatabaseFiles Method
DatabaseEnvironment Class See Also Send Feedback
The database files that need to be archived in order to recover the database from catastrophic failure. Database files that have not been accessed during the lifetime of the current log files are not included in this list. It is also possible that some of the files referred to by the log have since been deleted from the system.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public List<string> ArchivableDatabaseFiles(
    bool AbsolutePaths
)
Visual Basic (Declaration)
Public Function ArchivableDatabaseFiles ( _
    AbsolutePaths As Boolean _
) As List(Of String)
Visual C++
public:
List<String^>^ ArchivableDatabaseFiles(
    bool AbsolutePaths
)

Parameters

AbsolutePaths
Type: System..::.Boolean
If true, all pathnames are returned as absolute pathnames, instead of relative to the database home directory.

Return Value

The database files that need to be archived in order to recover the database from catastrophic failure.

Remarks

When Replication Manager is in use, log archiving is performed in a replication group-aware manner such that the log file status of other sites in the group are examined to determine if a log file could be in use.

See the db_archive utility for more information on database archival procedures.

See Also

DatabaseEnvironment Class


ArchivableLogFiles Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ArchivableLogFiles Method
DatabaseEnvironment Class See Also Send Feedback
The names of all of the log files that are no longer in use (for example, that are no longer involved in active transactions), and that may safely be archived for catastrophic recovery and then removed from the system.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public List<string> ArchivableLogFiles(
    bool AbsolutePaths
)
Visual Basic (Declaration)
Public Function ArchivableLogFiles ( _
    AbsolutePaths As Boolean _
) As List(Of String)
Visual C++
public:
List<String^>^ ArchivableLogFiles(
    bool AbsolutePaths
)

Parameters

AbsolutePaths
Type: System..::.Boolean
If true, all pathnames are returned as absolute pathnames, instead of relative to the database home directory.

Return Value

The names of all of the log files that are no longer in use

Remarks

The Berkeley DB interfaces to the database environment logging subsystem (for example, Abort()()()) may allocate log cursors and have open file descriptors for log files as well. On operating systems where filesystem related system calls (for example, rename and unlink on Windows/NT) can fail if a process has an open file descriptor for the affected file, attempting to move or remove the log files listed by ArchivableLogFiles may fail. All Berkeley DB internal use of log cursors operates on active log files only and furthermore, is short-lived in nature. So, an application seeing such a failure should be restructured to retry the operation until it succeeds. (Although this is not likely to be necessary; it is hard to imagine a reason to move or rename a log file in which transactions are being logged or aborted.)

When Replication Manager is in use, log archiving is performed in a replication group-aware manner such that the log file status of other sites in the group are examined to determine if a log file could be in use.

See the db_archive utility for more information on database archival procedures.

See Also

DatabaseEnvironment Class


Backup Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Backup Method
DatabaseEnvironment Class See Also Send Feedback
Perform a hot back up of the open environment.

All files used by the environment are backed up, so long as the normal rules for file placement are followed. For information on how files are normally placed relative to the environment directory, see the "Berkeley DB File Naming" section in the Berkeley DB Reference Guide.

By default, data directories and the log directory specified relative to the home directory are recreated relative to the target directory. If absolute path names are used, then use the SingleDir method.

This method provides the same functionality as the db_hotbackup utility. However, this method does not perform the housekeeping actions performed by that utility. In particular, you may want to run a checkpoint before calling this method. To run a checkpoint, use the Checkpoint()()() method. For more information on checkpoints, see the "Checkpoint" section in the Berkeley DB Reference Guide.

To back up a single database file within the environment, use the BackupDatabase(String, String, Boolean) method.

In addition to the configuration options available using the BackupOptions class, additional tuning modifications can be made using the BackupReadCount, BackupReadSleepDuration, BackupBufferSize, and BackupWriteDirect properties. Alternatively, you can write your own custom hot back up facility using the IBackup interface.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Backup(
    string target,
    BackupOptions opt
)
Visual Basic (Declaration)
Public Sub Backup ( _
    target As String, _
    opt As BackupOptions _
)
Visual C++
public:
void Backup(
    String^ target,
    BackupOptions^ opt
)

Parameters

target
Type: System..::.String
Identifies the directory in which the back up is placed. Any subdirectories required to contain the back up must be placed relative to this directory. If an IBackup is configured for the environment, then the value specified to this parameter is passed on to the Open(String, String) method. If this parameter is null, then the target must be specified to the Open(String, String) method.

This directory, and any required subdirectories, are created for you if you specify IF_NEEDED or ALWAYS for the Creation property.

opt
Type: BerkeleyDB..::.BackupOptions
The BackupOptions instance used to configure the hot back up.

See Also

DatabaseEnvironment Class


BackupDatabase Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BackupDatabase Method
DatabaseEnvironment Class See Also Send Feedback
Perform a hot back up of a single database file contained within the environment.

To back up the entire environment, use the Backup(String, BackupOptions) method.

You can make some tuning modifications to the backup process using the BackupReadCount, BackupReadSleepDuration, BackupBufferSize, and BackupWriteDirect properties. Alternatively, you can write your own custom hot back up facility using the IBackup interface.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void BackupDatabase(
    string target,
    string database,
    bool must_create
)
Visual Basic (Declaration)
Public Sub BackupDatabase ( _
    target As String, _
    database As String, _
    must_create As Boolean _
)
Visual C++
public:
void BackupDatabase(
    String^ target,
    String^ database,
    bool must_create
)

Parameters

target
Type: System..::.String
Identifies the directory in which the back up is placed.
database
Type: System..::.String
The database file that you want to back up.
must_create
Type: System..::.Boolean
If true, then if the target file exists, this method throws an exception.

See Also

DatabaseEnvironment Class


BeginCDSGroup Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BeginCDSGroup Method
DatabaseEnvironment Class See Also Send Feedback
Allocate a locker ID in an environment configured for Berkeley DB Concurrent Data Store applications.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Transaction BeginCDSGroup()
Visual Basic (Declaration)
Public Function BeginCDSGroup As Transaction
Visual C++
public:
Transaction^ BeginCDSGroup()

Return Value

A Transaction object that uniquely identifies the locker ID

Remarks

Calling Commit()()() discards the allocated locker ID.

See Berkeley DB Concurrent Data Store applications in the Programmer's Reference Guide for more information about when this is required.

See Also

DatabaseEnvironment Class


BeginTransaction Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BeginTransaction Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
BeginTransaction()()() | Create a new transaction in the environment, with the default configuration.
BeginTransaction(TransactionConfig) | Create a new transaction in the environment.
BeginTransaction(TransactionConfig, Transaction) | Create a new transaction in the environment.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


BeginTransaction Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BeginTransaction Method
DatabaseEnvironment Class See Also Send Feedback
Create a new transaction in the environment, with the default configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Transaction BeginTransaction()
Visual Basic (Declaration)
Public Function BeginTransaction As Transaction
Visual C++
public:
Transaction^ BeginTransaction()

Return Value

A new transaction object

See Also

DatabaseEnvironment Class
BeginTransaction Overload


BeginTransaction Method (TransactionConfig)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BeginTransaction Method (TransactionConfig)
DatabaseEnvironment Class See Also Send Feedback
Create a new transaction in the environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Transaction BeginTransaction(
    TransactionConfig cfg
)
Visual Basic (Declaration)
Public Function BeginTransaction ( _
    cfg As TransactionConfig _
) As Transaction
Visual C++
public:
Transaction^ BeginTransaction(
    TransactionConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.TransactionConfig
The configuration properties for the transaction

Return Value

A new transaction object

See Also

DatabaseEnvironment Class
BeginTransaction Overload


BeginTransaction Method (TransactionConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BeginTransaction Method (TransactionConfig, Transaction)
DatabaseEnvironment Class See Also Send Feedback
Create a new transaction in the environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Transaction BeginTransaction(
    TransactionConfig cfg,
    Transaction parent
)
Visual Basic (Declaration)
Public Function BeginTransaction ( _
    cfg As TransactionConfig, _
    parent As Transaction _
) As Transaction
Visual C++
public:
Transaction^ BeginTransaction(
    TransactionConfig^ cfg,
    Transaction^ parent
)

Parameters

cfg
Type: BerkeleyDB..::.TransactionConfig
The configuration properties for the transaction
parent
Type: BerkeleyDB..::.Transaction
If non-null, the new transaction is a nested transaction, with parent as the new transaction's parent. Transactions may be nested to any level.

Return Value

A new transaction object

Remarks

In the presence of distributed transactions and two-phase commit, only the parental transaction, that is a transaction without a parent specified, should be passed as an parameter to Prepare(array<Byte>[]()[]).

See Also

DatabaseEnvironment Class
BeginTransaction Overload


Checkpoint Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Checkpoint Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
Checkpoint()()() | Flush the underlying memory pool, write a checkpoint record to the log, and then flush the log, even if there has been no activity since the last checkpoint.
Checkpoint(UInt32, UInt32) | If there has been any logging activity in the database environment since the last checkpoint, flush the underlying memory pool, write a checkpoint record to the log, and then flush the log.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


Checkpoint Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Checkpoint Method
DatabaseEnvironment Class See Also Send Feedback
Flush the underlying memory pool, write a checkpoint record to the log, and then flush the log, even if there has been no activity since the last checkpoint.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Checkpoint()
Visual Basic (Declaration)
Public Sub Checkpoint
Visual C++
public:
void Checkpoint()

See Also

DatabaseEnvironment Class
Checkpoint Overload


Checkpoint Method (UInt32, UInt32)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Checkpoint Method (UInt32, UInt32)
DatabaseEnvironment Class See Also Send Feedback
If there has been any logging activity in the database environment since the last checkpoint, flush the underlying memory pool, write a checkpoint record to the log, and then flush the log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Checkpoint(
    uint kbytesWritten,
    uint minutesElapsed
)
Visual Basic (Declaration)
Public Sub Checkpoint ( _
    kbytesWritten As UInteger, _
    minutesElapsed As UInteger _
)
Visual C++
public:
void Checkpoint(
    unsigned int kbytesWritten,
    unsigned int minutesElapsed
)

Parameters

kbytesWritten
Type: System..::.UInt32
A checkpoint is performed if more than kbytesWritten kilobytes of log data have been written since the last checkpoint.
minutesElapsed
Type: System..::.UInt32
A checkpoint is performed if more than minutesElapsed minutes have passed since the last checkpoint.

See Also

DatabaseEnvironment Class
Checkpoint Overload


Close Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Close Method
DatabaseEnvironment Class See Also Send Feedback
By closing the Berkeley DB environment you can free allocated resources and close any open databases along with the underlying subsystems.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

Remarks

The object should not be closed while any other handle that refers to it is not yet closed; for example, database environment handles must not be closed while transactions in the environment have not yet been committed or aborted. When you close each database handle, by default, the database is not synchronized. To synchronize all open databases ensure that the last environment object is closed by the CloseForceSync() method. When the close operation fails, the method returns a non-zero error value for the first instance of such error, and continues to close the rest of the environment objects.

Where the environment was configured with UseTxns, calling CloseForceSync aborts any unresolved transactions. Applications should not depend on this behavior for transactions involving Berkeley DB databases; all such transactions should be explicitly resolved. The problem with depending on this semantic is that aborting an unresolved transaction involving database operations requires a database handle. Because the database handles should have been closed before calling CloseForceSync, it is not possible to abort the transaction, and recovery should be run on the Berkeley DB environment before further operations are done.

In multithreaded applications, only a single thread may call CloseForceSync.

See Also

DatabaseEnvironment Class


CloseForceSync Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.CloseForceSync Method
DatabaseEnvironment Class See Also Send Feedback
Close the Berkeley DB environment, freeing any allocated resources, closing any open databases as well as underlying subsystems.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void CloseForceSync()
Visual Basic (Declaration)
Public Sub CloseForceSync
Visual C++
public:
void CloseForceSync()

Remarks

The object should not be closed while any other handle that refers to it is not yet closed; for example, database environment handles must not be closed while transactions in the environment have not yet been committed or aborted. If there are open database handles, they are all closed, and each of them is synced on close. The first error in the close operations, if any, is returned at last, and the environment close procedures carry on anyway.

Where the environment was configured with UseTxns, calling CloseForceSync aborts any unresolved transactions. Applications should not depend on this behavior for transactions involving Berkeley DB databases; all such transactions should be explicitly resolved. The problem with depending on this semantic is that aborting an unresolved transaction involving database operations requires a database handle. Because the database handles should have been closed before calling CloseForceSync, it is not possible to abort the transaction, and recovery should be run on the Berkeley DB environment before further operations are done.

In multithreaded applications, only a single thread may call CloseForceSync.

See Also

DatabaseEnvironment Class


CloseForceSyncAndForceSyncEnv Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.CloseForceSyncAndForceSyncEnv Method
DatabaseEnvironment Class See Also Send Feedback

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void CloseForceSyncAndForceSyncEnv()
Visual Basic (Declaration)
Public Sub CloseForceSyncAndForceSyncEnv
Visual C++
public:
void CloseForceSyncAndForceSyncEnv()

See Also

DatabaseEnvironment Class


CloseForceSyncEnv Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.CloseForceSyncEnv Method
DatabaseEnvironment Class See Also Send Feedback
Close the Berkeley DB environment, freeing any allocated resources, closing any open databases as well as underlying subsystems.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void CloseForceSyncEnv()
Visual Basic (Declaration)
Public Sub CloseForceSyncEnv
Visual C++
public:
void CloseForceSyncEnv()

Remarks

The object should not be closed while any other handle that refers to it is not yet closed; for example, database environment handles must not be closed while transactions in the environment have not yet been committed or aborted. Calling CloseForceSyncEnv flushes all memory mapped environment regions before closing the environment.

See Also

DatabaseEnvironment Class


DetectDeadlocks Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.DetectDeadlocks Method
DatabaseEnvironment Class See Also Send Feedback
Run one iteration of the deadlock detector. The deadlock detector traverses the lock table and marks one of the participating lock requesters for rejection in each deadlock it finds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DetectDeadlocks(
    DeadlockPolicy atype
)
Visual Basic (Declaration)
Public Function DetectDeadlocks ( _
    atype As DeadlockPolicy _
) As UInteger
Visual C++
public:
unsigned int DetectDeadlocks(
    DeadlockPolicy^ atype
)

Parameters

atype
Type: BerkeleyDB..::.DeadlockPolicy
Specify which lock request(s) to reject

Return Value

The number of lock requests that were rejected.

See Also

DatabaseEnvironment Class


FailCheck Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.FailCheck Method
DatabaseEnvironment Class See Also Send Feedback
Check for threads of control (either a true thread or a process) that have exited while manipulating Berkeley DB library data structures, while holding a logical database lock, or with an unresolved transaction (that is, a transaction that was never aborted or committed).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void FailCheck()
Visual Basic (Declaration)
Public Sub FailCheck
Visual C++
public:
void FailCheck()

Remarks

For more information, see Architecting Data Store and Concurrent Data Store applications, and Architecting Transactional Data Store applications, both in the Berkeley DB Programmer's Reference Guide.

FailCheck is based on the SetThreadID and ThreadIsAlive delegates. Applications calling FailCheck must have already set ThreadIsAlive, and must have configured ThreadCount.

If FailCheck determines a thread of control exited while holding database read locks, it releases those locks. If FailCheck determines a thread of control exited with an unresolved transaction, the transaction aborts. In either of these cases, FailCheck returns successfully and the application may continue to use the database environment.

In either of these cases, FailCheck also reports the process and thread IDs associated with any released locks or aborted transactions. The information is printed to a specified output channel (see Verbosity for more information), or passed to an application delegate (see Feedback for more information).

If FailCheck determines a thread of control has exited such that database environment recovery is required, it throws RunRecoveryException. In this case, the application should not continue to use the database environment. For a further description as to the actions the application should take when this failure occurs, see Handling failure in Data Store and Concurrent Data Store applications, and Handling failure in Transactional Data Store applications, both in the Berkeley DB Programmer's Reference Guide.

See Also

DatabaseEnvironment Class


IsTransactionApplied Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.IsTransactionApplied Method
DatabaseEnvironment Class See Also Send Feedback
This method checks to see if a specified transaction has been replicated from the master of a replication group. It may be called by applications using either the Base API or the Replication Manager.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public TransactionAppliedStatus IsTransactionApplied(
    byte[] token,
    uint timeout
)
Visual Basic (Declaration)
Public Function IsTransactionApplied ( _
    token As Byte(), _
    timeout As UInteger _
) As TransactionAppliedStatus
Visual C++
public:
TransactionAppliedStatus IsTransactionApplied(
    array<unsigned char>^ token,
    unsigned int timeout
)

Parameters

token
Type: array< System..::.Byte >[]()[]
The commit token from a transaction previously written at a master site in the replication group. Commit tokens are retrieved using the CommitToken method.
timeout
Type: System..::.UInt32
The maximum time to wait for the transaction to arrive by replication, expressed in microseconds. To check the status of the transaction without waiting, the timeout may be specified as 0.

Return Value

This method returns TransactionAppliedStatus.APPLIED to indicate that the specified transaction has indeed been applied at the local site. TransactionAppliedStatus.TIMEOUT returns if the specified transaction has not yet arrived at the calling site, but can be expected to arrive soon. TransactionAppliedStatus.NOTFOUND is returned if the transaction has not been applied at the local site, and it can be determined that the transaction has been rolled back due to a master takeover, and is therefore never expected to arrive. TransactionAppliedStatus.EMPTY_TRANSACTION returns if the specified token was generated by a transaction that did not modify the database environment (e.g., a read-only transaction).

See Also

DatabaseEnvironment Class


LockingSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LockingSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
LockingSystemStats()()() | The locking subsystem statistics
LockingSystemStats(Boolean) | The locking subsystem statistics

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


LockingSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LockingSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
The locking subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LockStats LockingSystemStats()
Visual Basic (Declaration)
Public Function LockingSystemStats As LockStats
Visual C++
public:
LockStats^ LockingSystemStats()

Return Value

The locking subsystem statistics

See Also

DatabaseEnvironment Class
LockingSystemStats Overload


LockingSystemStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LockingSystemStats Method (Boolean)
DatabaseEnvironment Class See Also Send Feedback
The locking subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LockStats LockingSystemStats(
    bool clearStats
)
Visual Basic (Declaration)
Public Function LockingSystemStats ( _
    clearStats As Boolean _
) As LockStats
Visual C++
public:
LockStats^ LockingSystemStats(
    bool clearStats
)

Parameters

clearStats
Type: System..::.Boolean
If true, reset statistics after returning their values.

Return Value

The locking subsystem statistics

See Also

DatabaseEnvironment Class
LockingSystemStats Overload


LogFile Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogFile Method
DatabaseEnvironment Class See Also Send Feedback
Map an LSN object to a log filename

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string LogFile(
    LSN logSeqNum
)
Visual Basic (Declaration)
Public Function LogFile ( _
    logSeqNum As LSN _
) As String
Visual C++
public:
String^ LogFile(
    LSN^ logSeqNum
)

Parameters

logSeqNum
Type: BerkeleyDB..::.LSN
The DB_LSN structure for which a filename is wanted.

Return Value

The name of the file containing the record named by logSeqNum.

See Also

DatabaseEnvironment Class


LogFiles Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogFiles Method
DatabaseEnvironment Class See Also Send Feedback
The names of all of the log files

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public List<string> LogFiles(
    bool AbsolutePaths
)
Visual Basic (Declaration)
Public Function LogFiles ( _
    AbsolutePaths As Boolean _
) As List(Of String)
Visual C++
public:
List<String^>^ LogFiles(
    bool AbsolutePaths
)

Parameters

AbsolutePaths
Type: System..::.Boolean
If true, all pathnames are returned as absolute pathnames, instead of relative to the database home directory.

Return Value

All the log filenames, regardless of whether or not they are in use.

Remarks

The Berkeley DB interfaces to the database environment logging subsystem (for example, Abort()()()) may allocate log cursors and have open file descriptors for log files as well. On operating systems where filesystem related system calls (for example, rename and unlink on Windows/NT) can fail if a process has an open file descriptor for the affected file, attempting to move or remove the log files listed by LogFiles may fail. All Berkeley DB internal use of log cursors operates on active log files only and furthermore, is short-lived in nature. So, an application seeing such a failure should be restructured to retry the operation until it succeeds. (Although this is not likely to be necessary; it is hard to imagine a reason to move or rename a log file in which transactions are being logged or aborted.)

See the db_archive utility for more information on database archival procedures.

See Also

DatabaseEnvironment Class


LogFlush Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogFlush Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
LogFlush()()() | Write all log records to disk.
LogFlush(LSN) | Write log records to disk.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


LogFlush Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogFlush Method
DatabaseEnvironment Class See Also Send Feedback
Write all log records to disk.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void LogFlush()
Visual Basic (Declaration)
Public Sub LogFlush
Visual C++
public:
void LogFlush()

See Also

DatabaseEnvironment Class
LogFlush Overload


LogFlush Method (LSN)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogFlush Method (LSN)
DatabaseEnvironment Class See Also Send Feedback
Write log records to disk.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void LogFlush(
    LSN logSeqNum
)
Visual Basic (Declaration)
Public Sub LogFlush ( _
    logSeqNum As LSN _
)
Visual C++
public:
void LogFlush(
    LSN^ logSeqNum
)

Parameters

logSeqNum
Type: BerkeleyDB..::.LSN
All log records with LSN values less than or equal to logSeqNum are written to disk. If null, all records in the log are flushed.

See Also

DatabaseEnvironment Class
LogFlush Overload


LoggingSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LoggingSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
LoggingSystemStats()()() | The logging subsystem statistics
LoggingSystemStats(Boolean) | The logging subsystem statistics

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


LoggingSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LoggingSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
The logging subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LogStats LoggingSystemStats()
Visual Basic (Declaration)
Public Function LoggingSystemStats As LogStats
Visual C++
public:
LogStats^ LoggingSystemStats()

Return Value

The logging subsystem statistics

See Also

DatabaseEnvironment Class
LoggingSystemStats Overload


LoggingSystemStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LoggingSystemStats Method (Boolean)
DatabaseEnvironment Class See Also Send Feedback
The logging subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LogStats LoggingSystemStats(
    bool clearStats
)
Visual Basic (Declaration)
Public Function LoggingSystemStats ( _
    clearStats As Boolean _
) As LogStats
Visual C++
public:
LogStats^ LoggingSystemStats(
    bool clearStats
)

Parameters

clearStats
Type: System..::.Boolean
If true, reset statistics after returning their values.

Return Value

The logging subsystem statistics

See Also

DatabaseEnvironment Class
LoggingSystemStats Overload


LogVerify Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogVerify Method
DatabaseEnvironment Class See Also Send Feedback
Verify log records of this environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int LogVerify(
    LogVerifyConfig config
)
Visual Basic (Declaration)
Public Function LogVerify ( _
    config As LogVerifyConfig _
) As Integer
Visual C++
public:
int LogVerify(
    LogVerifyConfig^ config
)

Parameters

config
Type: BerkeleyDB..::.LogVerifyConfig
Log verification configuration object.

See Also

DatabaseEnvironment Class


LogWrite Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogWrite Method
DatabaseEnvironment Class See Also Send Feedback
Append a record to the log

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN LogWrite(
    DatabaseEntry dbt,
    bool flush
)
Visual Basic (Declaration)
Public Function LogWrite ( _
    dbt As DatabaseEntry, _
    flush As Boolean _
) As LSN
Visual C++
public:
LSN^ LogWrite(
    DatabaseEntry^ dbt,
    bool flush
)

Parameters

dbt
Type: BerkeleyDB..::.DatabaseEntry
The record to write to the log.
flush
Type: System..::.Boolean
If true, the log is forced to disk after this record is written, guaranteeing that all records with LSN values less than or equal to the one being "put" are on disk before LogWrite returns.

Return Value

The LSN of the written record

See Also

DatabaseEnvironment Class


MPoolSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MPoolSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
MPoolSystemStats()()() | The memory pool (that is, the buffer cache) subsystem statistics
MPoolSystemStats(Boolean) | The memory pool (that is, the buffer cache) subsystem statistics

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


MPoolSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MPoolSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
The memory pool (that is, the buffer cache) subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MPoolStats MPoolSystemStats()
Visual Basic (Declaration)
Public Function MPoolSystemStats As MPoolStats
Visual C++
public:
MPoolStats^ MPoolSystemStats()

Return Value

The memory pool subsystem statistics

See Also

DatabaseEnvironment Class
MPoolSystemStats Overload


MPoolSystemStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MPoolSystemStats Method (Boolean)
DatabaseEnvironment Class See Also Send Feedback
The memory pool (that is, the buffer cache) subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MPoolStats MPoolSystemStats(
    bool clearStats
)
Visual Basic (Declaration)
Public Function MPoolSystemStats ( _
    clearStats As Boolean _
) As MPoolStats
Visual C++
public:
MPoolStats^ MPoolSystemStats(
    bool clearStats
)

Parameters

clearStats
Type: System..::.Boolean
If true, reset statistics after returning their values.

Return Value

The memory pool subsystem statistics

See Also

DatabaseEnvironment Class
MPoolSystemStats Overload


MutexSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MutexSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
MutexSystemStats()()() | The mutex subsystem statistics
MutexSystemStats(Boolean) | The mutex subsystem statistics

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


MutexSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MutexSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
The mutex subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MutexStats MutexSystemStats()
Visual Basic (Declaration)
Public Function MutexSystemStats As MutexStats
Visual C++
public:
MutexStats^ MutexSystemStats()

Return Value

The mutex subsystem statistics

See Also

DatabaseEnvironment Class
MutexSystemStats Overload


MutexSystemStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MutexSystemStats Method (Boolean)
DatabaseEnvironment Class See Also Send Feedback
The mutex subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MutexStats MutexSystemStats(
    bool clearStats
)
Visual Basic (Declaration)
Public Function MutexSystemStats ( _
    clearStats As Boolean _
) As MutexStats
Visual C++
public:
MutexStats^ MutexSystemStats(
    bool clearStats
)

Parameters

clearStats
Type: System..::.Boolean
If true, reset statistics after returning their values.

Return Value

The mutex subsystem statistics

See Also

DatabaseEnvironment Class
MutexSystemStats Overload


Open Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Open Method
DatabaseEnvironment Class See Also Send Feedback
Instantiate a new DatabaseEnvironment object and open the Berkeley DB environment represented by home.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DatabaseEnvironment Open(
    string home,
    DatabaseEnvironmentConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    home As String, _
    cfg As DatabaseEnvironmentConfig _
) As DatabaseEnvironment
Visual C++
public:
static DatabaseEnvironment^ Open(
    String^ home,
    DatabaseEnvironmentConfig^ cfg
)

Parameters

home
Type: System..::.String
The database environment's home directory. For more information on home, and filename resolution in general, see Berkeley DB File Naming in the Programmer's Reference Guide.
cfg
Type: BerkeleyDB..::.DatabaseEnvironmentConfig
The environment's configuration

Return Value

A new, open DatabaseEnvironment object

See Also

DatabaseEnvironment Class


Panic Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Panic Method
DatabaseEnvironment Class See Also Send Feedback
Set the panic state for the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException.)

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Panic()
Visual Basic (Declaration)
Public Sub Panic
Visual C++
public:
void Panic()

See Also

DatabaseEnvironment Class


PrintLockingSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLockingSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintLockingSystemStats()()() | Display the locking subsystem statistical information, as described by LockStats.
PrintLockingSystemStats(Boolean, Boolean) | Display the locking subsystem statistical information, as described by LockStats.
PrintLockingSystemStats(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Display the locking subsystem statistical information, as described by LockStats.
PrintLockingSystemStats(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Display the locking subsystem statistical information, as described by LockStats.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintLockingSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLockingSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the locking subsystem statistical information, as described by LockStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintLockingSystemStats()
Visual Basic (Declaration)
Public Sub PrintLockingSystemStats
Visual C++
public:
void PrintLockingSystemStats()

See Also

DatabaseEnvironment Class
PrintLockingSystemStats Overload


PrintLockingSystemStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLockingSystemStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the locking subsystem statistical information, as described by LockStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintLockingSystemStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintLockingSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintLockingSystemStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintLockingSystemStats Overload


PrintLockingSystemStats Method (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLockingSystemStats Method (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the locking subsystem statistical information, as described by LockStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintLockingSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool ConflictMatrix,
    bool Lockers,
    bool Objects,
    bool Parameters
)
Visual Basic (Declaration)
Public Sub PrintLockingSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean, _
    ConflictMatrix As Boolean, _
    Lockers As Boolean, _
    Objects As Boolean, _
    Parameters As Boolean _
)
Visual C++
public:
void PrintLockingSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool ConflictMatrix,
    bool Lockers,
    bool Objects,
    bool Parameters
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.
ConflictMatrix
Type: System..::.Boolean
If true, display the lock conflict matrix.
Lockers
Type: System..::.Boolean
If true, display the lockers within hash chains.
Objects
Type: System..::.Boolean
If true, display the lock objects within hash chains.
Parameters
Type: System..::.Boolean
If true, display the locking subsystem parameters.

See Also

DatabaseEnvironment Class
PrintLockingSystemStats Overload


PrintLockingSystemStats Method (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLockingSystemStats Method (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the locking subsystem statistical information, as described by LockStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintLockingSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool ConflictMatrix,
    bool Lockers,
    bool Objects,
    bool Parameters,
    bool PrintAlloc
)
Visual Basic (Declaration)
Public Sub PrintLockingSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean, _
    ConflictMatrix As Boolean, _
    Lockers As Boolean, _
    Objects As Boolean, _
    Parameters As Boolean, _
    PrintAlloc As Boolean _
)
Visual C++
public:
void PrintLockingSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool ConflictMatrix,
    bool Lockers,
    bool Objects,
    bool Parameters,
    bool PrintAlloc
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.
ConflictMatrix
Type: System..::.Boolean
If true, display the lock conflict matrix.
Lockers
Type: System..::.Boolean
If true, display the lockers within hash chains.
Objects
Type: System..::.Boolean
If true, display the lock objects within hash chains.
Parameters
Type: System..::.Boolean
If true, display the locking subsystem parameters.
PrintAlloc
Type: System..::.Boolean
If true, display allocation information.

See Also

DatabaseEnvironment Class
PrintLockingSystemStats Overload


PrintLoggingSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLoggingSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintLoggingSystemStats()()() | Display the logging subsystem statistical information, as described by LogStats.
PrintLoggingSystemStats(Boolean, Boolean) | Display the logging subsystem statistical information, as described by LogStats.
PrintLoggingSystemStats(Boolean, Boolean, Boolean) | Display the logging subsystem statistical information, as described by LogStats.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintLoggingSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLoggingSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the logging subsystem statistical information, as described by LogStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintLoggingSystemStats()
Visual Basic (Declaration)
Public Sub PrintLoggingSystemStats
Visual C++
public:
void PrintLoggingSystemStats()

See Also

DatabaseEnvironment Class
PrintLoggingSystemStats Overload


PrintLoggingSystemStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLoggingSystemStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the logging subsystem statistical information, as described by LogStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintLoggingSystemStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintLoggingSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintLoggingSystemStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintLoggingSystemStats Overload


PrintLoggingSystemStats Method (Boolean, Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintLoggingSystemStats Method (Boolean, Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the logging subsystem statistical information, as described by LogStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintLoggingSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool PrintAlloc
)
Visual Basic (Declaration)
Public Sub PrintLoggingSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean, _
    PrintAlloc As Boolean _
)
Visual C++
public:
void PrintLoggingSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool PrintAlloc
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.
PrintAlloc
Type: System..::.Boolean
If true, display allocation information.

See Also

DatabaseEnvironment Class
PrintLoggingSystemStats Overload


PrintMPoolSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMPoolSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintMPoolSystemStats()()() | Display the memory pool (buffer cache) subsystem statistical information, as described by MPoolStats.
PrintMPoolSystemStats(Boolean, Boolean) | Display the memory pool (buffer cache) subsystem statistical information, as described by MPoolStats.
PrintMPoolSystemStats(Boolean, Boolean, Boolean) | Display the memory pool (buffer cache) subsystem statistical information, as described by MPoolStats.
PrintMPoolSystemStats(Boolean, Boolean, Boolean, Boolean) | Display the memory pool (that is, buffer cache) subsystem statistical information, as described by MPoolStats.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintMPoolSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMPoolSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the memory pool (buffer cache) subsystem statistical information, as described by MPoolStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintMPoolSystemStats()
Visual Basic (Declaration)
Public Sub PrintMPoolSystemStats
Visual C++
public:
void PrintMPoolSystemStats()

See Also

DatabaseEnvironment Class
PrintMPoolSystemStats Overload


PrintMPoolSystemStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMPoolSystemStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the memory pool (buffer cache) subsystem statistical information, as described by MPoolStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintMPoolSystemStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintMPoolSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintMPoolSystemStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintMPoolSystemStats Overload


PrintMPoolSystemStats Method (Boolean, Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMPoolSystemStats Method (Boolean, Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the memory pool (buffer cache) subsystem statistical information, as described by MPoolStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintMPoolSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool HashChains
)
Visual Basic (Declaration)
Public Sub PrintMPoolSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean, _
    HashChains As Boolean _
)
Visual C++
public:
void PrintMPoolSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool HashChains
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.
HashChains
Type: System..::.Boolean
If true, display the buffers with hash chains.

See Also

DatabaseEnvironment Class
PrintMPoolSystemStats Overload


PrintMPoolSystemStats Method (Boolean, Boolean, Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMPoolSystemStats Method (Boolean, Boolean, Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the memory pool (that is, buffer cache) subsystem statistical information, as described by MPoolStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintMPoolSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool HashChains,
    bool PrintAlloc
)
Visual Basic (Declaration)
Public Sub PrintMPoolSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean, _
    HashChains As Boolean, _
    PrintAlloc As Boolean _
)
Visual C++
public:
void PrintMPoolSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool HashChains,
    bool PrintAlloc
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.
HashChains
Type: System..::.Boolean
If true, display the buffers with hash chains.
PrintAlloc
Type: System..::.Boolean
If true, display allocation information.

See Also

DatabaseEnvironment Class
PrintMPoolSystemStats Overload


PrintMutexSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMutexSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintMutexSystemStats()()() | Display the mutex subsystem statistical information, as described by MutexStats.
PrintMutexSystemStats(Boolean, Boolean) | Display the mutex subsystem statistical information, as described by MutexStats.
PrintMutexSystemStats(Boolean, Boolean, Boolean) | Display the mutex subsystem statistical information, as described by MutexStats.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintMutexSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMutexSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the mutex subsystem statistical information, as described by MutexStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintMutexSystemStats()
Visual Basic (Declaration)
Public Sub PrintMutexSystemStats
Visual C++
public:
void PrintMutexSystemStats()

See Also

DatabaseEnvironment Class
PrintMutexSystemStats Overload


PrintMutexSystemStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMutexSystemStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the mutex subsystem statistical information, as described by MutexStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintMutexSystemStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintMutexSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintMutexSystemStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintMutexSystemStats Overload


PrintMutexSystemStats Method (Boolean, Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintMutexSystemStats Method (Boolean, Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the mutex subsystem statistical information, as described by MutexStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintMutexSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool PrintAlloc
)
Visual Basic (Declaration)
Public Sub PrintMutexSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean, _
    PrintAlloc As Boolean _
)
Visual C++
public:
void PrintMutexSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool PrintAlloc
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.
PrintAlloc
Type: System..::.Boolean
If true, display allocation information.

See Also

DatabaseEnvironment Class
PrintMutexSystemStats Overload


PrintReplicationSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintReplicationSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintReplicationSystemStats()()() | Display the replication subsystem statistical information, as described by ReplicationStats.
PrintReplicationSystemStats(Boolean, Boolean) | Display the replication subsystem statistical information, as described by ReplicationStats.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintReplicationSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintReplicationSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the replication subsystem statistical information, as described by ReplicationStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintReplicationSystemStats()
Visual Basic (Declaration)
Public Sub PrintReplicationSystemStats
Visual C++
public:
void PrintReplicationSystemStats()

See Also

DatabaseEnvironment Class
PrintReplicationSystemStats Overload


PrintReplicationSystemStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintReplicationSystemStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the replication subsystem statistical information, as described by ReplicationStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintReplicationSystemStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintReplicationSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintReplicationSystemStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintReplicationSystemStats Overload


PrintRepMgrSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintRepMgrSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintRepMgrSystemStats()()() | Display the replication manager statistical information, as described by RepMgrStats.
PrintRepMgrSystemStats(Boolean, Boolean) | Display the replication manager statistical information, as described by RepMgrStats.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintRepMgrSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintRepMgrSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the replication manager statistical information, as described by RepMgrStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintRepMgrSystemStats()
Visual Basic (Declaration)
Public Sub PrintRepMgrSystemStats
Visual C++
public:
void PrintRepMgrSystemStats()

See Also

DatabaseEnvironment Class
PrintRepMgrSystemStats Overload


PrintRepMgrSystemStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintRepMgrSystemStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the replication manager statistical information, as described by RepMgrStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintRepMgrSystemStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintRepMgrSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintRepMgrSystemStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintRepMgrSystemStats Overload


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintStats()()() | Display the default statistical information.
PrintStats(Boolean, Boolean) | Display the default statistical information.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the default statistical information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintStats()
Visual Basic (Declaration)
Public Sub PrintStats
Visual C++
public:
void PrintStats()

See Also

DatabaseEnvironment Class
PrintStats Overload


PrintStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the default statistical information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintStats Overload


PrintSubsystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintSubsystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintSubsystemStats()()() | Display the default subsystem statistical information.
PrintSubsystemStats(Boolean, Boolean) | Display the default subsystem statistical information.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintSubsystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintSubsystemStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the default subsystem statistical information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintSubsystemStats()
Visual Basic (Declaration)
Public Sub PrintSubsystemStats
Visual C++
public:
void PrintSubsystemStats()

See Also

DatabaseEnvironment Class
PrintSubsystemStats Overload


PrintSubsystemStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintSubsystemStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the default subsystem statistical information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintSubsystemStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintSubsystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintSubsystemStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintSubsystemStats Overload


PrintTransactionSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintTransactionSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
PrintTransactionSystemStats()()() | Display the transaction subsystem statistical information, as described by TransactionStats.
PrintTransactionSystemStats(Boolean, Boolean) | Display the transaction subsystem statistical information, as described by TransactionStats.
PrintTransactionSystemStats(Boolean, Boolean, Boolean) | Display the transaction subsystem statistical information, as described by TransactionStats.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


PrintTransactionSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintTransactionSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
Display the transaction subsystem statistical information, as described by TransactionStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintTransactionSystemStats()
Visual Basic (Declaration)
Public Sub PrintTransactionSystemStats
Visual C++
public:
void PrintTransactionSystemStats()

See Also

DatabaseEnvironment Class
PrintTransactionSystemStats Overload


PrintTransactionSystemStats Method (Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintTransactionSystemStats Method (Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the transaction subsystem statistical information, as described by TransactionStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintTransactionSystemStats(
    bool PrintAll,
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintTransactionSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintTransactionSystemStats(
    bool PrintAll,
    bool ClearStats
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.

See Also

DatabaseEnvironment Class
PrintTransactionSystemStats Overload


PrintTransactionSystemStats Method (Boolean, Boolean, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.PrintTransactionSystemStats Method (Boolean, Boolean, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Display the transaction subsystem statistical information, as described by TransactionStats.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintTransactionSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool PrintAlloc
)
Visual Basic (Declaration)
Public Sub PrintTransactionSystemStats ( _
    PrintAll As Boolean, _
    ClearStats As Boolean, _
    PrintAlloc As Boolean _
)
Visual C++
public:
void PrintTransactionSystemStats(
    bool PrintAll,
    bool ClearStats,
    bool PrintAlloc
)

Parameters

PrintAll
Type: System..::.Boolean
If true, display all available information.
ClearStats
Type: System..::.Boolean
If true, reset statistics after displaying their values.
PrintAlloc
Type: System..::.Boolean
If true, display allocation information.

See Also

DatabaseEnvironment Class
PrintTransactionSystemStats Overload


Recover Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Recover Method
DatabaseEnvironment Class See Also Send Feedback
Restore transactions that were prepared, but not yet resolved at the time of the system shut down or crash, to their state prior to the shut down or crash, including any locks previously held.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public PreparedTransaction[] Recover(
    int count,
    bool resume
)
Visual Basic (Declaration)
Public Function Recover ( _
    count As Integer, _
    resume As Boolean _
) As PreparedTransaction()
Visual C++
public:
array<PreparedTransaction^>^ Recover(
    int count,
    bool resume
)

Parameters

count
Type: System..::.Int32
The maximum number of PreparedTransaction objects to return.
resume
Type: System..::.Boolean
If true, continue returning a list of prepared, but not yet resolved transactions, starting where the last call to Recover left off. If false, begins a new pass over all prepared, but not yet completed transactions, regardless of whether they have already been returned in previous calls to Recover.

Return Value

A list of the prepared transactions

Remarks

Calls to Recover from different threads of control should not be intermixed in the same environment.

See Also

DatabaseEnvironment Class


RegionSetMemoryLimit Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RegionSetMemoryLimit Method
DatabaseEnvironment Class See Also Send Feedback
The amount of memory to be used by shared structures in the main environment region. These are structures other than mutexes and the page cache (memory pool).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RegionSetMemoryLimit(
    uint GBytes,
    uint Bytes
)
Visual Basic (Declaration)
Public Sub RegionSetMemoryLimit ( _
    GBytes As UInteger, _
    Bytes As UInteger _
)
Visual C++
public:
void RegionSetMemoryLimit(
    unsigned int GBytes,
    unsigned int Bytes
)

Parameters

GBytes
Type: System..::.UInt32
The number of gigabytes to allocate for the main memory region. The gigabytes allocated are added to the bytes input.
Bytes
Type: System..::.UInt32
The number of gigabytes to allocate for the main memory region. The bytes allocated are added to the gigabytes input.

See Also

DatabaseEnvironment Class


Remove Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Remove Method
DatabaseEnvironment Class See Also Send Feedback

The environment regions, including any backing files, are removed. Any log or database files and the environment directory are not removed.

If there are processes that have called Open(String, DatabaseEnvironmentConfig) without calling Close()()() (that is, there are processes currently using the environment), Remove fails without further action.

Calling Remove should not be necessary for most applications because the Berkeley DB environment is cleaned up as part of normal database recovery procedures. However, applications may want to call Remove as part of application shut down to free up system resources. For example, if SystemMemory was specified to Open(String, DatabaseEnvironmentConfig), it may be useful to call Remove in order to release system shared memory segments that have been allocated. Or, on architectures in which mutexes require allocation of underlying system resources, it may be useful to call Remove in order to release those resources. Alternatively, if recovery is not required because no database state is maintained across failures, and no system resources need to be released, it is possible to clean up an environment by simply removing all the Berkeley DB files in the database environment's directories.

In multithreaded applications, only a single thread may call Remove.

Overload List

Name | Description
Remove(String) | Destroy a Berkeley DB environment if it is not currently in use.
Remove(String, Boolean) | Destroy a Berkeley DB environment if it is not currently in use.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


Remove Method (String)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Remove Method (String)
DatabaseEnvironment Class See Also Send Feedback
Destroy a Berkeley DB environment if it is not currently in use.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Remove(
    string db_home
)
Visual Basic (Declaration)
Public Shared Sub Remove ( _
    db_home As String _
)
Visual C++
public:
static void Remove(
    String^ db_home
)

Parameters

db_home
Type: System..::.String
The database environment to be removed.

See Also

DatabaseEnvironment Class
Remove Overload


Remove Method (String, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Remove Method (String, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Destroy a Berkeley DB environment if it is not currently in use.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void Remove(
    string db_home,
    bool force
)
Visual Basic (Declaration)
Public Shared Sub Remove ( _
    db_home As String, _
    force As Boolean _
)
Visual C++
public:
static void Remove(
    String^ db_home,
    bool force
)

Parameters

db_home
Type: System..::.String
The database environment to be removed.
force
Type: System..::.Boolean
If true, the environment is removed, regardless of any processes that may still using it, and no locks are acquired during this process.

Remarks

Generally, force is specified only when applications were unable to shut down cleanly, and there is a risk that an application may have died holding a Berkeley DB lock.)

The result of attempting to forcibly destroy the environment when it is in use is unspecified. Processes using an environment often maintain open file descriptors for shared regions within it. On UNIX systems, the environment removal usually succeeds, and processes that have already joined the region continue to run in that region without change. However, processes attempting to join the environment either fail or create new regions. On non-UNIX systems, region removal is not possible because the unlink(2) system call fails if any process has an open file descriptor for the file.

See Also

DatabaseEnvironment Class
Remove Overload


RemoveDB Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RemoveDB Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
RemoveDB(String, Boolean) | Remove the underlying file represented by file, incidentally removing all of the databases it contained.
RemoveDB(String, Boolean, Transaction) | Remove the underlying file represented by file, incidentally removing all of the databases it contained.
RemoveDB(String, String, Boolean) | Remove the database specified by file and database. If no database is specified, the underlying file represented by file is removed, incidentally removing all of the databases it contained.
RemoveDB(String, String, Boolean, Transaction) | Remove the database specified by file and database. If no database is specified, the underlying file represented by file is removed, incidentally removing all of the databases it contained.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


RemoveDB Method (String, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RemoveDB Method (String, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Remove the underlying file represented by file, incidentally removing all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RemoveDB(
    string file,
    bool autoCommit
)
Visual Basic (Declaration)
Public Sub RemoveDB ( _
    file As String, _
    autoCommit As Boolean _
)
Visual C++
public:
void RemoveDB(
    String^ file,
    bool autoCommit
)

Parameters

file
Type: System..::.String
The physical file to be removed.
autoCommit
Type: System..::.Boolean
If true, enclose RemoveDB within a transaction. If the call succeeds, changes made by the operation are recoverable. If the call fails, the operation has made no changes.

See Also

DatabaseEnvironment Class
RemoveDB Overload


RemoveDB Method (String, Boolean, Transaction)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RemoveDB Method (String, Boolean, Transaction)
DatabaseEnvironment Class See Also Send Feedback
Remove the underlying file represented by file, incidentally removing all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RemoveDB(
    string file,
    bool autoCommit,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub RemoveDB ( _
    file As String, _
    autoCommit As Boolean, _
    txn As Transaction _
)
Visual C++
public:
void RemoveDB(
    String^ file,
    bool autoCommit,
    Transaction^ txn
)

Parameters

file
Type: System..::.String
The physical file to be removed.
autoCommit
Type: System..::.Boolean
If true, enclose RemoveDB within a transaction. If the call succeeds, changes made by the operation are recoverable. If the call fails, the operation has made no changes.
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null. If null, but autoCommit or AutoCommit is true, the operation is implicitly transaction protected.

See Also

DatabaseEnvironment Class
RemoveDB Overload


RemoveDB Method (String, String, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RemoveDB Method (String, String, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Remove the database specified by file and database. If no database is specified, the underlying file represented by file is removed, incidentally removing all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RemoveDB(
    string file,
    string database,
    bool autoCommit
)
Visual Basic (Declaration)
Public Sub RemoveDB ( _
    file As String, _
    database As String, _
    autoCommit As Boolean _
)
Visual C++
public:
void RemoveDB(
    String^ file,
    String^ database,
    bool autoCommit
)

Parameters

file
Type: System..::.String
The physical file which contains the database(s) to be removed.
database
Type: System..::.String
The database to be removed.
autoCommit
Type: System..::.Boolean
If true, enclose RemoveDB within a transaction. If the call succeeds, changes made by the operation are recoverable. If the call fails, the operation has made no changes.

See Also

DatabaseEnvironment Class
RemoveDB Overload


RemoveDB Method (String, String, Boolean, Transaction)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RemoveDB Method (String, String, Boolean, Transaction)
DatabaseEnvironment Class See Also Send Feedback
Remove the database specified by file and database. If no database is specified, the underlying file represented by file is removed, incidentally removing all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RemoveDB(
    string file,
    string database,
    bool autoCommit,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub RemoveDB ( _
    file As String, _
    database As String, _
    autoCommit As Boolean, _
    txn As Transaction _
)
Visual C++
public:
void RemoveDB(
    String^ file,
    String^ database,
    bool autoCommit,
    Transaction^ txn
)

Parameters

file
Type: System..::.String
The physical file which contains the database(s) to be removed.
database
Type: System..::.String
The database to be removed.
autoCommit
Type: System..::.Boolean
If true, enclose RemoveDB within a transaction. If the call succeeds, changes made by the operation are recoverable. If the call fails, the operation has made no changes.
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null. If null, but autoCommit or AutoCommit is true, the operation is implicitly transaction protected.

See Also

DatabaseEnvironment Class
RemoveDB Overload


RemoveUnusedLogFiles Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RemoveUnusedLogFiles Method
DatabaseEnvironment Class See Also Send Feedback
Remove log files that are no longer needed. Automatic log file removal is likely to make catastrophic recovery impossible.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RemoveUnusedLogFiles()
Visual Basic (Declaration)
Public Sub RemoveUnusedLogFiles
Visual C++
public:
void RemoveUnusedLogFiles()

Remarks

When Replication Manager is in use, log archiving is performed in a replication group-aware manner such that the log file status of other sites in the group are examined to determine if a log file could be in use.

See Also

DatabaseEnvironment Class


RenameDB Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RenameDB Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
RenameDB(String, String, Boolean) | Rename the underlying file represented by file using the value supplied to newname, incidentally renaming all of the databases it contained.
RenameDB(String, String, Boolean, Transaction) | Rename the underlying file represented by file using the value supplied to newname, incidentally renaming all of the databases it contained.
RenameDB(String, String, String, Boolean) | Rename the database specified by file and database to newname. If no database is specified, the underlying file represented by file is renamed using the value supplied to newname, incidentally renaming all of the databases it contained.
RenameDB(String, String, String, Boolean, Transaction) | Rename the database specified by file and database to newname. If no database is specified, the underlying file represented by file is renamed using the value supplied to newname, incidentally renaming all of the databases it contained.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


RenameDB Method (String, String, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RenameDB Method (String, String, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Rename the underlying file represented by file using the value supplied to newname, incidentally renaming all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RenameDB(
    string file,
    string newname,
    bool autoCommit
)
Visual Basic (Declaration)
Public Sub RenameDB ( _
    file As String, _
    newname As String, _
    autoCommit As Boolean _
)
Visual C++
public:
void RenameDB(
    String^ file,
    String^ newname,
    bool autoCommit
)

Parameters

file
Type: System..::.String
The physical file to be renamed.
newname
Type: System..::.String
The new name of the database or file.
autoCommit
Type: System..::.Boolean
If true, enclose RenameDB within a transaction. If the call succeeds, changes made by the operation are recoverable. If the call fails, the operation has made no changes.

See Also

DatabaseEnvironment Class
RenameDB Overload


RenameDB Method (String, String, Boolean, Transaction)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RenameDB Method (String, String, Boolean, Transaction)
DatabaseEnvironment Class See Also Send Feedback
Rename the underlying file represented by file using the value supplied to newname, incidentally renaming all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RenameDB(
    string file,
    string newname,
    bool autoCommit,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub RenameDB ( _
    file As String, _
    newname As String, _
    autoCommit As Boolean, _
    txn As Transaction _
)
Visual C++
public:
void RenameDB(
    String^ file,
    String^ newname,
    bool autoCommit,
    Transaction^ txn
)

Parameters

file
Type: System..::.String
The physical file to be renamed.
newname
Type: System..::.String
The new name of the database or file.
autoCommit
Type: System..::.Boolean
If true, enclose RenameDB within a transaction. If the call succeeds, changes made by the operation are recoverable. If the call fails, the operation has made no changes.
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null. If null, but autoCommit or AutoCommit is true, the operation is implicitly transaction protected.

See Also

DatabaseEnvironment Class
RenameDB Overload


RenameDB Method (String, String, String, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RenameDB Method (String, String, String, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Rename the database specified by file and database to newname. If no database is specified, the underlying file represented by file is renamed using the value supplied to newname, incidentally renaming all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RenameDB(
    string file,
    string database,
    string newname,
    bool autoCommit
)
Visual Basic (Declaration)
Public Sub RenameDB ( _
    file As String, _
    database As String, _
    newname As String, _
    autoCommit As Boolean _
)
Visual C++
public:
void RenameDB(
    String^ file,
    String^ database,
    String^ newname,
    bool autoCommit
)

Parameters

file
Type: System..::.String
The physical file which contains the database(s) to be renamed.
database
Type: System..::.String
The database to be renamed.
newname
Type: System..::.String
The new name of the database or file.
autoCommit
Type: System..::.Boolean
If true, enclose RenameDB within a transaction. If the call succeeds, changes made by the operation are recoverable. If the call fails, the operation has made no changes.

See Also

DatabaseEnvironment Class
RenameDB Overload


RenameDB Method (String, String, String, Boolean, Transaction)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RenameDB Method (String, String, String, Boolean, Transaction)
DatabaseEnvironment Class See Also Send Feedback
Rename the database specified by file and database to newname. If no database is specified, the underlying file represented by file is renamed using the value supplied to newname, incidentally renaming all of the databases it contained.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RenameDB(
    string file,
    string database,
    string newname,
    bool autoCommit,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub RenameDB ( _
    file As String, _
    database As String, _
    newname As String, _
    autoCommit As Boolean, _
    txn As Transaction _
)
Visual C++
public:
void RenameDB(
    String^ file,
    String^ database,
    String^ newname,
    bool autoCommit,
    Transaction^ txn
)

Parameters

file
Type: System..::.String
The physical file which contains the database(s) to be renamed.
database
Type: System..::.String
The database to be renamed.
newname
Type: System..::.String
The new name of the database or file.
autoCommit
Type: System..::.Boolean
If true, enclose RenameDB within a transaction. If the call succeeds, changes made by the operation are recoverable. If the call fails, the operation has made no changes.
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null. If null, but autoCommit or AutoCommit is true, the operation is implicitly transaction protected.

See Also

DatabaseEnvironment Class
RenameDB Overload


RepHoldElection Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepHoldElection Method
DatabaseEnvironment Class See Also Send Feedback

RepHoldElection is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

If the election is successful, Berkeley DB notifies the application of the results of the election by means of either the REP_ELECTED or REP_NEWMASTER events (see EventNotifyfor more information). The application is responsible for adjusting its relationship to the other database environments in the replication group, including directing all database updates to the newly selected master, in accordance with the results of the election.

The thread of control that calls RepHoldElection must not be the thread of control that processes incoming messages; processing the incoming messages is necessary to successfully complete an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

Overload List

Name | Description
RepHoldElection()()() | Hold an election for the master of a replication group.
RepHoldElection(UInt32) | Hold an election for the master of a replication group.
RepHoldElection(UInt32, UInt32) | Hold an election for the master of a replication group.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


RepHoldElection Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepHoldElection Method
DatabaseEnvironment Class See Also Send Feedback
Hold an election for the master of a replication group.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepHoldElection()
Visual Basic (Declaration)
Public Sub RepHoldElection
Visual C++
public:
void RepHoldElection()

See Also

DatabaseEnvironment Class
RepHoldElection Overload


RepHoldElection Method (UInt32)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepHoldElection Method (UInt32)
DatabaseEnvironment Class See Also Send Feedback
Hold an election for the master of a replication group.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepHoldElection(
    uint nsites
)
Visual Basic (Declaration)
Public Sub RepHoldElection ( _
    nsites As UInteger _
)
Visual C++
public:
void RepHoldElection(
    unsigned int nsites
)

Parameters

nsites
Type: System..::.UInt32
The number of replication sites expected to participate in the election. Once the current site has election information from that many sites, it short-circuits the election and immediately casts its vote for a new master. If an application is using master leases, then the value must be 0 and RepNSites must be used.

See Also

DatabaseEnvironment Class
RepHoldElection Overload


RepHoldElection Method (UInt32, UInt32)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepHoldElection Method (UInt32, UInt32)
DatabaseEnvironment Class See Also Send Feedback
Hold an election for the master of a replication group.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepHoldElection(
    uint nsites,
    uint nvotes
)
Visual Basic (Declaration)
Public Sub RepHoldElection ( _
    nsites As UInteger, _
    nvotes As UInteger _
)
Visual C++
public:
void RepHoldElection(
    unsigned int nsites,
    unsigned int nvotes
)

Parameters

nsites
Type: System..::.UInt32
The number of replication sites expected to participate in the election. Once the current site has election information from that many sites, it short-circuits the election and immediately casts its vote for a new master. This parameter must be no less than nvotes, or 0 if the election should use RepNSites. If an application is using master leases, then the value must be 0 and RepNSites must be used.
nvotes
Type: System..::.UInt32
The minimum number of replication sites from which the current site must have election information, before the current site casts a vote for a new master. This parameter must be no greater than nsites, or 0 if the election should use the value ((nsites / 2) + 1).

See Also

DatabaseEnvironment Class
RepHoldElection Overload


ReplicationSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ReplicationSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
ReplicationSystemStats()()() | The replication subsystem statistics
ReplicationSystemStats(Boolean) | The replication subsystem statistics

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


ReplicationSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ReplicationSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
The replication subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationStats ReplicationSystemStats()
Visual Basic (Declaration)
Public Function ReplicationSystemStats As ReplicationStats
Visual C++
public:
ReplicationStats^ ReplicationSystemStats()

Return Value

The replication subsystem statistics

See Also

DatabaseEnvironment Class
ReplicationSystemStats Overload


ReplicationSystemStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ReplicationSystemStats Method (Boolean)
DatabaseEnvironment Class See Also Send Feedback
The replication subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationStats ReplicationSystemStats(
    bool clearStats
)
Visual Basic (Declaration)
Public Function ReplicationSystemStats ( _
    clearStats As Boolean _
) As ReplicationStats
Visual C++
public:
ReplicationStats^ ReplicationSystemStats(
    bool clearStats
)

Parameters

clearStats
Type: System..::.Boolean
If true, reset statistics after returning their values.

Return Value

The replication subsystem statistics

See Also

DatabaseEnvironment Class
ReplicationSystemStats Overload


RepMgrChannel Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrChannel Method
DatabaseEnvironment Class See Also Send Feedback
Create DbChannel with given eid.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DbChannel RepMgrChannel(
    int eid
)
Visual Basic (Declaration)
Public Function RepMgrChannel ( _
    eid As Integer _
) As DbChannel
Visual C++
public:
DbChannel^ RepMgrChannel(
    int eid
)

Parameters

eid
Type: System..::.Int32
Environment id. If the eid is EID_MASTER, create channel sending to master site only.

See Also

DatabaseEnvironment Class


RepmgrSetIncomingQueueMax Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepmgrSetIncomingQueueMax Method
DatabaseEnvironment Class See Also Send Feedback
Set a byte-count limit on the maximum amount of dynamic memory used by the Replication Manager incoming queue.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepmgrSetIncomingQueueMax(
    uint GBytes,
    uint Bytes
)
Visual Basic (Declaration)
Public Sub RepmgrSetIncomingQueueMax ( _
    GBytes As UInteger, _
    Bytes As UInteger _
)
Visual C++
public:
void RepmgrSetIncomingQueueMax(
    unsigned int GBytes,
    unsigned int Bytes
)

Parameters

GBytes
Type: System..::.UInt32
The number of gigabytes which, when added to Bytes, specifies the maximum amount of dynamic memory used by the Replication Manager incoming queue.
Bytes
Type: System..::.UInt32
The number of bytes which, when added to GBytes, specifies the maximum amount of dynamic memory used by the Replication Manager incoming queue.

Remarks

By default, the Replication Manager incoming queue size has a limit of 100MB.

If both GBytes and Bytes are zero, then the Replication Manager incoming queue size is limited by available heap memory.

See Also

DatabaseEnvironment Class


RepMgrSite Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrSite Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
RepMgrSite(Int32) | Create DbSite with the given eid.
RepMgrSite(String, UInt32) | Create DbSite with the given host and port.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


RepMgrSite Method (Int32)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrSite Method (Int32)
DatabaseEnvironment Class See Also Send Feedback
Create DbSite with the given eid.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DbSite RepMgrSite(
    int eid
)
Visual Basic (Declaration)
Public Function RepMgrSite ( _
    eid As Integer _
) As DbSite
Visual C++
public:
DbSite^ RepMgrSite(
    int eid
)

Parameters

eid
Type: System..::.Int32
The environment id

Remarks

It is only possible to use this method after env open, because EID values are not established before that time.

See Also

DatabaseEnvironment Class
RepMgrSite Overload


RepMgrSite Method (String, UInt32)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrSite Method (String, UInt32)
DatabaseEnvironment Class See Also Send Feedback
Create DbSite with the given host and port.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DbSite RepMgrSite(
    string host,
    uint port
)
Visual Basic (Declaration)
Public Function RepMgrSite ( _
    host As String, _
    port As UInteger _
) As DbSite
Visual C++
public:
DbSite^ RepMgrSite(
    String^ host,
    unsigned int port
)

Parameters

host
Type: System..::.String
The host address
port
Type: System..::.UInt32
The port

See Also

DatabaseEnvironment Class
RepMgrSite Overload


RepMgrSiteConfig Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrSiteConfig Method
DatabaseEnvironment Class See Also Send Feedback
Configure a site in the replication manager.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepMgrSiteConfig(
    DbSiteConfig siteConfig
)
Visual Basic (Declaration)
Public Sub RepMgrSiteConfig ( _
    siteConfig As DbSiteConfig _
)
Visual C++
public:
void RepMgrSiteConfig(
    DbSiteConfig^ siteConfig
)

Parameters

siteConfig
Type: BerkeleyDB..::.DbSiteConfig
The configuration of a site

See Also

DatabaseEnvironment Class


RepMgrStartClient Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrStartClient Method
DatabaseEnvironment Class See Also Send Feedback

There are two ways to build Berkeley DB replication applications: the most common approach is to use the Berkeley DB library "replication manager" support, where the Berkeley DB library manages the replication group, including network transport, all replication message processing and acknowledgment, and group elections. Applications using the replication manager support generally make the following calls:

  1. Configure the local site in the replication group, RepMgrLocalSite.
  2. Call RepMgrSiteConfig(DbSiteConfig) to configure the remote site(s) in the replication group.
  3. Configure the message acknowledgment policy (RepMgrAckPolicy) which provides the replication group's transactional needs.
  4. Configure the local site's election priority, RepPriority.
  5. Call RepMgrStartClient(Int32) or RepMgrStartMaster(Int32) to start the replication application.

For more information on building replication manager applications, please see the Replication Getting Started Guide included in the Berkeley DB documentation.

Applications with special needs (for example, applications using network protocols not supported by the Berkeley DB replication manager), must perform additional configuration and call other Berkeley DB replication methods. For more information on building advanced replication applications, please see the Base Replication API section in the Berkeley DB Programmer's Reference Guide for more information.

Starting the replication manager consists of opening the TCP/IP listening socket to accept incoming connections, and starting all necessary background threads. When multiple processes share a database environment, only one process can open the listening socket; RepMgrStartClient(Int32) (and RepMgrStartMaster(Int32)) automatically open the socket in the first process to call it, and skips this step in the later calls from other processes.

Overload List

Name | Description
RepMgrStartClient(Int32) | Start the replication manager as a client site, and do not call for an election.
RepMgrStartClient(Int32, Boolean) | Start the replication manager as a client site, and optionally call for an election.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


RepMgrStartClient Method (Int32)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrStartClient Method (Int32)
DatabaseEnvironment Class See Also Send Feedback
Start the replication manager as a client site, and do not call for an election.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepMgrStartClient(
    int nthreads
)
Visual Basic (Declaration)
Public Sub RepMgrStartClient ( _
    nthreads As Integer _
)
Visual C++
public:
void RepMgrStartClient(
    int nthreads
)

Parameters

nthreads
Type: System..::.Int32
Specify the number of threads of control created and dedicated to processing replication messages. In addition to these message processing threads, the replication manager creates and manages a few of its own threads of control.

See Also

DatabaseEnvironment Class
RepMgrStartClient Overload


RepMgrStartClient Method (Int32, Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrStartClient Method (Int32, Boolean)
DatabaseEnvironment Class See Also Send Feedback
Start the replication manager as a client site, and optionally call for an election.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepMgrStartClient(
    int nthreads,
    bool holdElection
)
Visual Basic (Declaration)
Public Sub RepMgrStartClient ( _
    nthreads As Integer, _
    holdElection As Boolean _
)
Visual C++
public:
void RepMgrStartClient(
    int nthreads,
    bool holdElection
)

Parameters

nthreads
Type: System..::.Int32
Specify the number of threads of control created and dedicated to processing replication messages. In addition to these message processing threads, the replication manager creates and manages a few of its own threads of control.
holdElection
Type: System..::.Boolean
If true, start as a client, and call for an election if no master is found.

See Also

DatabaseEnvironment Class
RepMgrStartClient Overload


RepMgrStartMaster Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrStartMaster Method
DatabaseEnvironment Class See Also Send Feedback
Start the replication manager as a master site, and do not call for an election.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepMgrStartMaster(
    int nthreads
)
Visual Basic (Declaration)
Public Sub RepMgrStartMaster ( _
    nthreads As Integer _
)
Visual C++
public:
void RepMgrStartMaster(
    int nthreads
)

Parameters

nthreads
Type: System..::.Int32
Specify the number of threads of control created and dedicated to processing replication messages. In addition to these message processing threads, the replication manager creates and manages a few of its own threads of control.

Remarks

There are two ways to build Berkeley DB replication applications: the most common approach is to use the Berkeley DB library "replication manager" support, where the Berkeley DB library manages the replication group, including network transport, all replication message processing and acknowledgment, and group elections. Applications using the replication manager support generally make the following calls:

  1. Configure the local site in the replication group, RepMgrLocalSite.
  2. Call RepMgrSiteConfig(DbSiteConfig) to configure the remote site(s) in the replication group.
  3. Configure the message acknowledgment policy (RepMgrAckPolicy) which provides the replication group's transactional needs.
  4. Configure the local site's election priority, RepPriority.
  5. Call RepMgrStartClient(Int32) or RepMgrStartMaster(Int32) to start the replication application.

For more information on building replication manager applications, please see the Replication Getting Started Guide included in the Berkeley DB documentation.

Applications with special needs (for example, applications using network protocols not supported by the Berkeley DB replication manager), must perform additional configuration and call other Berkeley DB replication methods. For more information on building advanced replication applications, please see the Base Replication API section in the Berkeley DB Programmer's Reference Guide for more information.

Starting the replication manager consists of opening the TCP/IP listening socket to accept incoming connections, and starting all necessary background threads. When multiple processes share a database environment, only one process can open the listening socket; RepMgrStartMaster(Int32) (and RepMgrStartClient(Int32)) automatically open the socket in the first process to call it, and skips this step in the later calls from other processes.

See Also

DatabaseEnvironment Class


RepMgrSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
RepMgrSystemStats()()() | The replication manager statistics
RepMgrSystemStats(Boolean) | The replication manager statistics

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


RepMgrSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
The replication manager statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RepMgrStats RepMgrSystemStats()
Visual Basic (Declaration)
Public Function RepMgrSystemStats As RepMgrStats
Visual C++
public:
RepMgrStats^ RepMgrSystemStats()

Return Value

The replication manager statistics

See Also

DatabaseEnvironment Class
RepMgrSystemStats Overload


RepMgrSystemStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrSystemStats Method (Boolean)
DatabaseEnvironment Class See Also Send Feedback
The replication manager statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RepMgrStats RepMgrSystemStats(
    bool clearStats
)
Visual Basic (Declaration)
Public Function RepMgrSystemStats ( _
    clearStats As Boolean _
) As RepMgrStats
Visual C++
public:
RepMgrStats^ RepMgrSystemStats(
    bool clearStats
)

Parameters

clearStats
Type: System..::.Boolean
If true, reset statistics after returning their values.

Return Value

The replication manager statistics

See Also

DatabaseEnvironment Class
RepMgrSystemStats Overload


RepProcessMessage Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepProcessMessage Method
DatabaseEnvironment Class See Also Send Feedback
Process an incoming replication message sent by a member of the replication group to the local database environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RepProcMsgResult RepProcessMessage(
    DatabaseEntry control,
    DatabaseEntry rec,
    int envid
)
Visual Basic (Declaration)
Public Function RepProcessMessage ( _
    control As DatabaseEntry, _
    rec As DatabaseEntry, _
    envid As Integer _
) As RepProcMsgResult
Visual C++
public:
RepProcMsgResult^ RepProcessMessage(
    DatabaseEntry^ control,
    DatabaseEntry^ rec,
    int envid
)

Parameters

control
Type: BerkeleyDB..::.DatabaseEntry
A copy of the control parameter specified by Berkeley DB on the sending environment.
rec
Type: BerkeleyDB..::.DatabaseEntry
A copy of the rec parameter specified by Berkeley DB on the sending environment.
envid
Type: System..::.Int32
The local identifier that corresponds to the environment that sent the message to be processed (see Replication environment IDs in the Programmer's Reference Guide for more information)..

Return Value

The result of processing a message

Remarks

RepProcessMessage is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

For implementation reasons, all incoming replication messages must be processed using the same DatabaseEnvironment object. It is not required that a single thread of control process all messages, only that all threads of control processing messages use the same object.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

See Also

DatabaseEnvironment Class


RepSetClockskew Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepSetClockskew Method
DatabaseEnvironment Class See Also Send Feedback
Set the clock skew ratio among replication group members based on the fastest and slowest measurements among the group for use with master leases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepSetClockskew(
    uint fast,
    uint slow
)
Visual Basic (Declaration)
Public Sub RepSetClockskew ( _
    fast As UInteger, _
    slow As UInteger _
)
Visual C++
public:
void RepSetClockskew(
    unsigned int fast,
    unsigned int slow
)

Parameters

fast
Type: System..::.UInt32
The value, relative to slow, of the fastest clock in the group of sites.
slow
Type: System..::.UInt32
The value of the slowest clock in the group of sites.

Remarks

Calling this method is optional, the default values for clock skew assume no skew. The user must also configure leases via RepUseMasterLeases. Additionally, the user must also set the master lease timeout via RepLeaseTimeout and the number of sites in the replication group via RepNSites. These settings may be configured in any order. For a description of the clock skew values, see Clock skew in the Berkeley DB Programmer's Reference Guide. For a description of master leases, see Master leases in the Berkeley DB Programmer's Reference Guide.

These arguments can be used to express either raw measurements of a clock timing experiment or a percentage across machines. For instance a group of sites have a 2% variance, then fast should be set to 102, and slow should be set to 100. Or, for a 0.03% difference, you can use 10003 and 10000 respectively.

See Also

DatabaseEnvironment Class


RepSetRetransmissionRequest Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepSetRetransmissionRequest Method
DatabaseEnvironment Class See Also Send Feedback
Set a threshold for the minimum and maximum time that a client waits before requesting retransmission of a missing message.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepSetRetransmissionRequest(
    uint min,
    uint max
)
Visual Basic (Declaration)
Public Sub RepSetRetransmissionRequest ( _
    min As UInteger, _
    max As UInteger _
)
Visual C++
public:
void RepSetRetransmissionRequest(
    unsigned int min,
    unsigned int max
)

Parameters

min
Type: System..::.UInt32
The minimum number of microseconds a client waits before requesting retransmission.
max
Type: System..::.UInt32
The maximum number of microseconds a client waits before requesting retransmission.

Remarks

If the client detects a gap in the sequence of incoming log records or database pages, Berkeley DB will wait for at least min microseconds before requesting retransmission of the missing record. Berkeley DB will double that amount before requesting the same missing record again, and so on, up to a maximum threshold of max microseconds.

These values are only thresholds. Since Berkeley DB has no thread available as a timer in the library, the threshold is only checked when a thread enters the Berkeley DB library to process an incoming replication message. Berkeley DB checks whether the amount of time since a request was made is beyond the threshold value or not.

By default the minimum is 40000 and the maximum is 1280000 microseconds (1.28 seconds). These defaults are fairly arbitrary and the application likely needs to adjust these. The values should be based on expected load and performance characteristics of the master and client host platforms and transport infrastructure as well as round-trip message time.

See Also

DatabaseEnvironment Class


RepSetTransmitLimit Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepSetTransmitLimit Method
DatabaseEnvironment Class See Also Send Feedback
Set a byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32). The limit is not a hard limit, and the record that exceeds the limit is the last record to be sent.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepSetTransmitLimit(
    uint GBytes,
    uint Bytes
)
Visual Basic (Declaration)
Public Sub RepSetTransmitLimit ( _
    GBytes As UInteger, _
    Bytes As UInteger _
)
Visual C++
public:
void RepSetTransmitLimit(
    unsigned int GBytes,
    unsigned int Bytes
)

Parameters

GBytes
Type: System..::.UInt32
The number of gigabytes which, when added to Bytes, specifies the maximum number of bytes that are sent in a single call to RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
Bytes
Type: System..::.UInt32
The number of bytes which, when added to GBytes, specifies the maximum number of bytes that are sent in a single call to RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

Remarks

Record transmission throttling is turned on by default with a limit of 10MB.

If both GBytes and Bytes are zero, then the transmission limit is turned off.

See Also

DatabaseEnvironment Class


RepSetTransport Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepSetTransport Method
DatabaseEnvironment Class See Also Send Feedback
Initialize the communication infrastructure for a database environment participating in a replicated application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepSetTransport(
    int envid,
    ReplicationTransportDelegate transport
)
Visual Basic (Declaration)
Public Sub RepSetTransport ( _
    envid As Integer, _
    transport As ReplicationTransportDelegate _
)
Visual C++
public:
void RepSetTransport(
    int envid,
    ReplicationTransportDelegate^ transport
)

Parameters

envid
Type: System..::.Int32
The local environment's ID. It must be a non-negative integer and uniquely identify this Berkeley DB database environment (see Replication environment IDs in the Programmer's Reference Guide for more information).
transport
Type: BerkeleyDB..::.ReplicationTransportDelegate
The delegate used to transmit data using the replication application's communication infrastructure.

Remarks

RepSetTransport is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

See Also

DatabaseEnvironment Class


RepStartClient Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepStartClient Method
DatabaseEnvironment Class See Also Send Feedback

RepStartClient is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

Replication master environments are the only database environments where replicated databases may be modified. Replication client environments are read-only as long as they are clients. Replication client environments may be upgraded to be replication master environments in the case that the current master fails or there is no master present. If master leases are in use, this method cannot be used to appoint a master, and should only be used to configure a database environment as a master as the result of an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

Overload List

Name | Description
RepStartClient()()() | Configure the database environment as a client in a group of replicated database environments.
RepStartClient(DatabaseEntry) | Configure the database environment as a client in a group of replicated database environments.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


RepStartClient Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepStartClient Method
DatabaseEnvironment Class See Also Send Feedback
Configure the database environment as a client in a group of replicated database environments.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepStartClient()
Visual Basic (Declaration)
Public Sub RepStartClient
Visual C++
public:
void RepStartClient()

See Also

DatabaseEnvironment Class
RepStartClient Overload


RepStartClient Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepStartClient Method (DatabaseEntry)
DatabaseEnvironment Class See Also Send Feedback
Configure the database environment as a client in a group of replicated database environments.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepStartClient(
    DatabaseEntry cdata
)
Visual Basic (Declaration)
Public Sub RepStartClient ( _
    cdata As DatabaseEntry _
)
Visual C++
public:
void RepStartClient(
    DatabaseEntry^ cdata
)

Parameters

cdata
Type: BerkeleyDB..::.DatabaseEntry
An opaque data item that is sent over the communication infrastructure when the client comes online (see Connecting to a new site in the Programmer's Reference Guide for more information). If no such information is useful, cdata should be null.

See Also

DatabaseEnvironment Class
RepStartClient Overload


RepStartMaster Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepStartMaster Method
DatabaseEnvironment Class See Also Send Feedback

RepStartMaster is not called by most replication applications. It should only be called by applications implementing their own network transport layer, explicitly holding replication group elections and handling replication messages outside of the replication manager framework.

Replication master environments are the only database environments where replicated databases may be modified. Replication client environments are read-only as long as they are clients. Replication client environments may be upgraded to be replication master environments in the case that the current master fails or there is no master present. If master leases are in use, this method cannot be used to appoint a master, and should only be used to configure a database environment as a master as the result of an election.

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

Overload List

Name | Description
RepStartMaster()()() | Configure the database environment as a master in a group of replicated database environments.
RepStartMaster(DatabaseEntry) | Configure the database environment as a master in a group of replicated database environments.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


RepStartMaster Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepStartMaster Method
DatabaseEnvironment Class See Also Send Feedback
Configure the database environment as a master in a group of replicated database environments.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepStartMaster()
Visual Basic (Declaration)
Public Sub RepStartMaster
Visual C++
public:
void RepStartMaster()

See Also

DatabaseEnvironment Class
RepStartMaster Overload


RepStartMaster Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepStartMaster Method (DatabaseEntry)
DatabaseEnvironment Class See Also Send Feedback
Configure the database environment as a master in a group of replicated database environments.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepStartMaster(
    DatabaseEntry cdata
)
Visual Basic (Declaration)
Public Sub RepStartMaster ( _
    cdata As DatabaseEntry _
)
Visual C++
public:
void RepStartMaster(
    DatabaseEntry^ cdata
)

Parameters

cdata
Type: BerkeleyDB..::.DatabaseEntry
An opaque data item that is sent over the communication infrastructure when the client comes online (see Connecting to a new site in the Programmer's Reference Guide for more information). If no such information is useful, cdata should be null.

See Also

DatabaseEnvironment Class
RepStartMaster Overload


RepSync Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepSync Method
DatabaseEnvironment Class See Also Send Feedback
Force master synchronization to begin for this client.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepSync()
Visual Basic (Declaration)
Public Sub RepSync
Visual C++
public:
void RepSync()

Remarks

This method is the other half of setting RepDelayClientSync.

If an application has configured delayed master synchronization, the application must synchronize explicitly (otherwise the client remains out-of-date and ignores database changes forwarded from the replication group master). RepSync may be called any time after the client application learns that the new master has been established (by receiving REP_NEWMASTER).

Before calling this method, the RepTransport delegate must already have been configured to send replication messages.

See Also

DatabaseEnvironment Class


ResetFileID Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ResetFileID Method
DatabaseEnvironment Class See Also Send Feedback
Allow database files to be copied and used in the same database environment as the original.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void ResetFileID(
    string file,
    bool encrypted
)
Visual Basic (Declaration)
Public Sub ResetFileID ( _
    file As String, _
    encrypted As Boolean _
)
Visual C++
public:
void ResetFileID(
    String^ file,
    bool encrypted
)

Parameters

file
Type: System..::.String
The name of the physical file in which new file IDs are to be created.
encrypted
Type: System..::.Boolean
If true, the file contains encrypted databases.

Remarks

All databases contain an ID string used to identify the database in the database environment cache. If a physical database file is copied, and used in the same environment as another file with the same ID strings, corruption can occur. ResetFileID creates new ID strings for all of the databases in the physical file.

ResetFileID modifies the physical file, in-place. Applications should not reset IDs in files that are currently in use.

See Also

DatabaseEnvironment Class


ResetLSN Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ResetLSN Method
DatabaseEnvironment Class See Also Send Feedback
Allow database files to be moved from one transactional database environment to another.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void ResetLSN(
    string file,
    bool encrypted
)
Visual Basic (Declaration)
Public Sub ResetLSN ( _
    file As String, _
    encrypted As Boolean _
)
Visual C++
public:
void ResetLSN(
    String^ file,
    bool encrypted
)

Parameters

file
Type: System..::.String
encrypted
Type: System..::.Boolean

Remarks

Database pages in transactional database environments contain references to the environment's log files (that is, log sequence numbers, or LSNs). Copying or moving a database file from one database environment to another, and then modifying it, can result in data corruption if the LSNs are not first cleared.

LSNs should be reset before moving or copying the database file into a new database environment, rather than moving or copying the database file and then resetting the LSNs. Berkeley DB has consistency checks that may be triggered if an application calls ResetLSN on a database in a new environment when the database LSNs still reflect the old environment.

The ResetLSN method modifies the physical file, in-place. Applications should not reset LSNs in files that are currently in use.

See Also

DatabaseEnvironment Class


SetMaxSequentialWrites Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.SetMaxSequentialWrites Method
DatabaseEnvironment Class See Also Send Feedback
Limit the number of sequential write operations scheduled by the library when flushing dirty pages from the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetMaxSequentialWrites(
    int maxWrites,
    uint pause
)
Visual Basic (Declaration)
Public Sub SetMaxSequentialWrites ( _
    maxWrites As Integer, _
    pause As UInteger _
)
Visual C++
public:
void SetMaxSequentialWrites(
    int maxWrites,
    unsigned int pause
)

Parameters

maxWrites
Type: System..::.Int32
The maximum number of sequential write operations scheduled by the library when flushing dirty pages from the cache, or 0 if there is no limitation on the number of sequential write operations.
pause
Type: System..::.UInt32
The number of microseconds the thread of control should pause before scheduling further write operations. It must be specified as an unsigned 32-bit number of microseconds, limiting the maximum pause to roughly 71 minutes.

See Also

DatabaseEnvironment Class


SyncMemPool Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.SyncMemPool Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
SyncMemPool()()() | Flush all modified pages in the cache to their backing files.
SyncMemPool(LSN) | Flush modified pages in the cache with log sequence numbers less than minLSN to their backing files.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


SyncMemPool Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.SyncMemPool Method
DatabaseEnvironment Class See Also Send Feedback
Flush all modified pages in the cache to their backing files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SyncMemPool()
Visual Basic (Declaration)
Public Sub SyncMemPool
Visual C++
public:
void SyncMemPool()

Remarks

Pages in the cache that cannot be immediately written back to disk (for example, pages that are currently in use by another thread of control) are waited for and written to disk as soon as it is possible to do so.

See Also

DatabaseEnvironment Class
SyncMemPool Overload


SyncMemPool Method (LSN)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.SyncMemPool Method (LSN)
DatabaseEnvironment Class See Also Send Feedback
Flush modified pages in the cache with log sequence numbers less than minLSN to their backing files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SyncMemPool(
    LSN minLSN
)
Visual Basic (Declaration)
Public Sub SyncMemPool ( _
    minLSN As LSN _
)
Visual C++
public:
void SyncMemPool(
    LSN^ minLSN
)

Parameters

minLSN
Type: BerkeleyDB..::.LSN
All modified pages with a log sequence number less than the minLSN parameter are written to disk. If null, all modified pages in the cache are written to disk.

Remarks

Pages in the cache that cannot be immediately written back to disk (for example, pages that are currently in use by another thread of control) are waited for and written to disk as soon as it is possible to do so.

See Also

DatabaseEnvironment Class
SyncMemPool Overload


TransactionSystemStats Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TransactionSystemStats Method
DatabaseEnvironment Class See Also Send Feedback

Overload List

Name | Description
TransactionSystemStats()()() | The transaction subsystem statistics
TransactionSystemStats(Boolean) | The transaction subsystem statistics

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


TransactionSystemStats Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TransactionSystemStats Method
DatabaseEnvironment Class See Also Send Feedback
The transaction subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public TransactionStats TransactionSystemStats()
Visual Basic (Declaration)
Public Function TransactionSystemStats As TransactionStats
Visual C++
public:
TransactionStats^ TransactionSystemStats()

Return Value

The transaction subsystem statistics

See Also

DatabaseEnvironment Class
TransactionSystemStats Overload


TransactionSystemStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TransactionSystemStats Method (Boolean)
DatabaseEnvironment Class See Also Send Feedback
The transaction subsystem statistics

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public TransactionStats TransactionSystemStats(
    bool clearStats
)
Visual Basic (Declaration)
Public Function TransactionSystemStats ( _
    clearStats As Boolean _
) As TransactionStats
Visual C++
public:
TransactionStats^ TransactionSystemStats(
    bool clearStats
)

Parameters

clearStats
Type: System..::.Boolean
If true, reset statistics after returning their values.

Return Value

The transaction subsystem statistics

See Also

DatabaseEnvironment Class
TransactionSystemStats Overload


TrickleCleanMemPool Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TrickleCleanMemPool Method
DatabaseEnvironment Class See Also Send Feedback
Ensure that a specified percent of the pages in the cache are clean, by writing dirty pages to their backing files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int TrickleCleanMemPool(
    int pctClean
)
Visual Basic (Declaration)
Public Function TrickleCleanMemPool ( _
    pctClean As Integer _
) As Integer
Visual C++
public:
int TrickleCleanMemPool(
    int pctClean
)

Parameters

pctClean
Type: System..::.Int32
The percent of the pages in the cache that should be clean.

Return Value

The number of pages written to reach the specified percentage is copied.

See Also

DatabaseEnvironment Class


WriteToLog Method

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.WriteToLog Method
DatabaseEnvironment Class See Also Send Feedback
WriteToLog allows applications to include information in the database environment log files, for later review using the db_printlog utility. This method is intended for debugging and performance tuning.
WriteToLog allows applications to include information in the database environment log files, for later review using the db_printlog utility. This method is intended for debugging and performance tuning.

Overload List

Name | Description
WriteToLog(String) | Append an informational message to the Berkeley DB database environment log files.
WriteToLog(String, Transaction) | Append an informational message to the Berkeley DB database environment log files.

See Also

DatabaseEnvironment Class
DatabaseEnvironment Members


WriteToLog Method (String)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.WriteToLog Method (String)
DatabaseEnvironment Class See Also Send Feedback
Append an informational message to the Berkeley DB database environment log files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void WriteToLog(
    string str
)
Visual Basic (Declaration)
Public Sub WriteToLog ( _
    str As String _
)
Visual C++
public:
void WriteToLog(
    String^ str
)

Parameters

str
Type: System..::.String
The message to append to the log files

See Also

DatabaseEnvironment Class
WriteToLog Overload


WriteToLog Method (String, Transaction)

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.WriteToLog Method (String, Transaction)
DatabaseEnvironment Class See Also Send Feedback
Append an informational message to the Berkeley DB database environment log files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void WriteToLog(
    string str,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub WriteToLog ( _
    str As String, _
    txn As Transaction _
)
Visual C++
public:
void WriteToLog(
    String^ str,
    Transaction^ txn
)

Parameters

str
Type: System..::.String
The message to append to the log files
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); otherwise null.

See Also

DatabaseEnvironment Class
WriteToLog Overload


DatabaseEnvironment Properties

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironment Properties
DatabaseEnvironment Class See Also Send Feedback

The DatabaseEnvironment type exposes the following members.

Properties

Name | Description
AutoCommit | If true, database operations for which no explicit transaction handle was specified, and which modify databases in the database environment, are automatically enclosed within a transaction.
BackupBufferSize | The size of the buffer, in bytes, to read from the database during a hot backup.
BackupHandler | Sets the IBackup interface to be used when performing hot backups. This interface is used to override the default behavior used by the Backup(String, BackupOptions) and BackupDatabase(String, String, Boolean) methods.
BackupReadCount | The number of pages to read before pausing during the hot backup. Increasing this value increases the amount of I/O the backup process performs for any given time interval. If your application is already heavily I/O bound, setting this value to a lower number may help to improve your overall data throughput by reducing the I/O demands placed on your system. By default, all pages are read without a pause.
BackupReadSleepDuration | The number of microseconds to sleep between batches of reads during a hot backup. Increasing this value decreases the amount of I/O the backup process performs for any given time interval. If your application is already heavily I/O bound, setting this value to a higher number may help to improve your overall data throughput by reducing the I/O demands placed on your system.
BackupWriteDirect | If true, direct I/O is used when writing pages to the disk during a hot backup. For some environments, direct I/O can provide faster write throughput, but usually it is slower because the OS buffer pool offers asynchronous activity.
BlobDir | The path of the directory where blobs are stored.
BlobThreshold | The size in bytes which is used to determine when a data item is stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, databases opened in the environment default to never using blob support. It is illegal to enable blob support if replication is enabled for the environment.
CacheSize | The size of the shared memory buffer pool (the cache).
CDB_ALLDB | If true, Berkeley DB Concurrent Data Store applications perform locking on an environment-wide basis rather than on a per-database basis.
Create | If true, Berkeley DB subsystems create any underlying files, as necessary.
DataDirs | The array of directories where database files are stored.
DeadlockResolution | The deadlock detector configuration, specifying which lock request(s) should be rejected. As transactions acquire locks on behalf of a single locker ID, rejecting a lock request associated with a transaction normally requires the transaction to be aborted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption.
ErrorFeedback | The mechanism for reporting detailed error messages to the application.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
EventNotify | A delegate which is called to notify the process of specific Berkeley DB events.
Feedback | Monitor progress within long running operations.
ForceFlush | If true, flush database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.
FreeThreaded | If true, the object is free-threaded; that is, concurrently usable by multiple threads in the address space.
Home | The database environment home directory.
HotbackupInProgress | Whether there is any hot backup in progress.
InitLockCount | The number of locks allocated when the environment is created
InitLockerCount | The number of lockers allocated when the environment is created
InitLockObjectCount | The number of lock objects allocated when the environment is created
InitLogIdCount | The number of log identifier objects allocated when the environment is created
InitMutexes | The initial number of mutexes allocated
InitRegions | If true, Berkeley DB page-faults shared regions into memory when initially creating or joining a Berkeley DB environment.
InitThreadCount | The number of thread objects allocated when the environment is created
InitTxnCount | The number of transaction objects allocated when the environment is created
IntermediateDirMode | The intermediate directory permissions.
LockConflictMatrix | The current lock conflicts array.
Lockdown | If true, lock shared Berkeley DB environment files and memory-mapped databases into memory.
LockPartitions | The number of lock table partitions used in the Berkeley DB environment.
LockTableSize | The size of the lock table in the Berkeley DB environment.
LockTimeout | A value, in microseconds, representing lock timeouts.
LogAutoRemove | If true, Berkeley DB automatically removes log files that are no longer needed.
LogBlobContent | If true, enables full logging of blob data. Required if using HA or the hotbackup utility.
LogBufferSize | The size of the in-memory log buffer, in bytes
LogDir | The path of a directory to be used as the location of logging files. Log files created by the Log Manager subsystem are created in this directory.
LogFileMode | The absolute file mode for created log files. This property is only useful for the rare Berkeley DB application that does not control its umask value.
LogForceSync | If true, Berkeley DB flushes log writes to the backing disk before returning from the write system call, rather than flushing log writes explicitly in a separate system call, as necessary.
LogInMemory | If true, transaction logs are maintained in-memory rather than on disk. This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability).
LogNoBuffer | If true, system buffering is turned off for Berkeley DB log files to avoid double caching.
LogNoSync | If true, Berkeley DB avoids the fsync() call when the log files are flushed.
LogRegionSize | The size of the underlying logging area of the Berkeley DB environment, in bytes.
LogZeroOnCreate | If true, all pages of a log file are zeroed when that log file is created.
MaxCacheSize | The maximum cache size
MaxLockers | The maximum number of locking entities supported by the Berkeley DB environment.
MaxLocks | The maximum number of locks supported by the Berkeley DB environment.
MaxLogFileSize | The maximum size of a single file in the log, in bytes. Because LSN Offsets are unsigned four-byte values, the size may not be larger than the maximum unsigned four-byte value.
MaxMutexes | The total number of mutexes allocated
MaxObjects | The maximum number of locked objects
MaxOpenFiles | The number of file descriptors the library opens concurrently when flushing dirty pages from the cache.
MaxSequentialWrites | The number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
MaxTransactions | The number of active transactions supported by the environment. This value bounds the size of the memory allocated for transactions. Child transactions are counted as active until they either commit or abort.
messageFeedback | The mechanism for reporting detailed statistic messages to the application.
MetadataDir | The path of directory to store the persistent metadata.
MMapSize | The maximum file size, in bytes, for a file to be mapped into the process address space. If no value is specified, it defaults to 10MB.
Msgfile | The message file.
MutexAlignment | The mutex alignment, in bytes.
MutexIncrement | The number of additional mutexes allocated.
NoBuffer | If true, turn off system buffering of Berkeley DB database files to avoid double caching.
NoLocking | If true, Berkeley DB grants all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.
NoMMap | If true, Berkeley DB copies read-only database files into the local cache instead of potentially mapping them into process memory.
NoPanic | If true, Berkeley DB ignores any panic state in the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException.) This functionality should never be used for purposes other than debugging.
NumTestAndSetSpins | The number of times that test-and-set mutexes should spin without blocking. The value defaults to 1 on uniprocessor systems and to 50 times the number of processors on multiprocessor systems.
Overwrite | If true, overwrite files stored in encrypted formats before deleting them.
Private | If true, allocate region memory from the heap instead of from memory backed by the filesystem or system shared memory.
RegionMemoryLimitBytes | The bytes component of the byte-count limit on the amount of memory to be used by shared structures in the main environment region. These are the structures other than mutexes and the page cache (memory pool).
RegionMemoryLimitGBytes | The gigabytes component of the byte-count limit on the amount of memory to be used by shared structures in the main environment region. These are the structures other than mutexes and the page cache (memory pool).
Register | If true, Berkeley DB checks if recovery is needed to be performed before opening the database environment.
RepAckTimeout | The amount of time the replication manager's transport function waits to collect enough acknowledgments from replication group clients, before giving up and returning a failure indication. The default wait time is 1 second.
RepAutoInit | If true, the replication master automatically re-initializes outdated clients (defaults to true).
RepBulkTransfer | If true, the replication master sends groups of records to the clients in a single network transfer
RepCheckpointDelay | The amount of time a master site delays between completing a checkpoint and writing a checkpoint record into the log.
RepClockskewFast | The value, relative to RepClockskewSlow, of the fastest clock in the group of sites.
RepClockskewSlow | The value of the slowest clock in the group of sites.
RepConnectionRetry | The amount of time the replication manager waits before trying to re-establish a connection to another site after a communication failure. The default wait time is 30 seconds.
RepDelayClientSync | If true, the client should delay synchronizing to a newly declared master (defaults to false). Clients configured in this way remain unsynchronized until the application calls RepSync()()().
RepElectionRetry | Configure the amount of time the replication manager waits before retrying a failed election. The default wait time is 10 seconds.
RepElectionTimeout | The timeout period for an election. The default timeout is 2 seconds.
RepFullElectionTimeout | An optional configuration timeout period to wait for full election participation the first time the replication group finds a master. By default this option is turned off and normal election timeouts are used. (See the Elections section in the Berkeley DB Reference Guide for more information.)
RepHeartbeatMonitor | The amount of time the replication manager, running at a client site, waits for some message activity on the connection from the master (heartbeats or other messages) before concluding that the connection has been lost. When 0 (the default), no monitoring is performed.
RepHeartbeatSend | The frequency at which the replication manager, running at a master site, broadcasts a heartbeat message in an otherwise idle system. When 0 (the default), no heartbeat messages are sent.
RepInMemory | If true, replication only stores the internal information in-memory and cannot keep persistent state across a site crash or reboot. By default, it is false and replication creates files in the environment home directory to preserve the internal information.
RepLeaseTimeout | The amount of time a client grants its master lease to a master. When using master leases all sites in a replication group must use the same lease timeout value. There is no default value. If leases are desired, this method must be called prior to calling RepStartClient()()() or RepStartMaster()()().
ReplicationView | The function used to create a replication view that determines whether a database file is replicated to the local site.
RepMessageDispatch | Set the message dispatch function. It is responsible for receiving messages sent from remote sites using either SendMessage(array<DatabaseEntry>[]()[]) or SendRequest(array<DatabaseEntry>[]()[], UInt32). If the message received by this function was sent using SendMessage(array<DatabaseEntry>[]()[]), then no response is required. If the message was sent using SendRequest(array<DatabaseEntry>[]()[], UInt32), then this function must send a response using SendMessage(array<DatabaseEntry>[]()[]).
RepMgrAckPolicy | Specify how master and client sites handle acknowledgment of replication messages which are necessary for "permanent" records. The current implementation requires all sites in a replication group configure the same acknowledgement policy.
RepmgrIncomingQueueMaxBytes | The bytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RepmgrIncomingQueueMaxGBytes | The gigabytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RepMgrLocalSite | The local site of the replication manager. Returns null if the local site has not been configured.
RepMgrRemoteSites | The status of the sites currently known by the replication manager.
RepMgrRunElections | If true, Replication Manager automatically runs elections to choose a new master when the old master disconnects (defaults to true).
RepNoBlocking | If true, errors are returned immediately for Berkeley DB method calls that would normally block while clients are in recovery (defaults to false).
RepNSites | The total number of sites in the replication group.
RepPrefmasClient | This flag is used to specify the client site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The client site in a preferred master replication group takes over temporarily as master when the preferred master site is unavailable.
RepPrefmasMaster | This flag is used to specify the preferred master site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The preferred master site operates as the master site whenever possible.
RepPriority | The database environment's priority in replication group elections. A special value of 0 indicates that this environment cannot be a replication group master. If not configured, then a default value of 100 is used.
RepRetransmissionRequestMax | The maximum number of microseconds a client waits before requesting retransmission.
RepRetransmissionRequestMin | The minimum number of microseconds a client waits before requesting retransmission.
RepStrict2Site | Replication Manager observes the strict "majority" rule in managing elections, even in a group with only 2 sites. The client in a 2-site group is unable to take over as master if the original master fails or becomes disconnected. (See the Elections section in the Berkeley DB Reference Guide for more information.) Both sites in the replication group should have the same value for this parameter.
RepTransmitLimitBytes | The bytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
RepTransmitLimitGBytes | The gigabytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
RepTransport | The delegate used to transmit data using the replication application's communication infrastructure.
RepUseMasterLeases | If true, master leases are used for this site (defaults to false).
RunFatalRecovery | If true, catastrophic recovery was run on this environment before opening it for normal use.
RunRecovery | If true, normal recovery was run on this environment before opening it for normal use.
SequentialWritePause | The number of microseconds the thread of control pauses before scheduling further write operations.
SetThreadID | A delegate that returns a unique identifier pair for the current thread of control.
SetThreadName | A delegate that formats a process ID and thread ID identifier pair.
SystemMemory | If true, allocate region memory from system shared memory instead of from heap memory or memory backed by the filesystem.
TempDir | The path of a directory to be used as the location for temporary files.
ThreadCount | An approximate number of threads in the database environment.
ThreadIsAlive | A delegate that returns if a thread of control (either a true thread or a process) is still running.
TimeNotGranted | If true, database calls timing out based on lock or transaction timeout values throw LockNotGrantedException instead of DeadlockException.
TxnNoSync | If true, Berkeley DB does not write or synchronously flush the log on transaction commit.
TxnNoWait | If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw DeadlockException (or LockNotGrantedException if configured with TimeNotGranted).
TxnSnapshot | If true, all transactions in the environment are started as if Snapshot was passed to BeginTransaction()()(), and all non-transactional cursors are opened as if SnapshotIsolation was passed to Cursor()()().
TxnTimeout | A value, in microseconds, representing transaction timeouts.
TxnTimestamp | The recovery timestamp
TxnWriteNoSync | If true, Berkeley DB writes, but does not synchronously flush, the log on transaction commit.
UseEnvironmentVars | The Berkeley DB process' environment may be permitted to specify information to be used when naming files; see Berkeley DB File Naming in the Programmer's Reference Guide for more information.
UseMVCC | If true, all databases in the environment are opened as if UseMVCC was set.
UsingCDB | If true, locking for the Berkeley DB Concurrent Data Store product was initialized.
UsingLocking | If true, the locking subsystem was initialized.
UsingLogging | If true, the logging subsystem was initialized.
UsingMPool | If true, the shared memory buffer pool subsystem was initialized.
UsingReplication | If true, the replication subsystem was initialized.
UsingTxns | If true, the transaction subsystem was initialized.
Verbosity | Specific additional informational and debugging messages in the Berkeley DB message output.
YieldCPU | If true, Berkeley DB yields the processor immediately after each page or mutex acquisition.

See Also

DatabaseEnvironment Class


AutoCommit Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.AutoCommit Property
DatabaseEnvironment Class See Also Send Feedback
If true, database operations for which no explicit transaction handle was specified, and which modify databases in the database environment, are automatically enclosed within a transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool AutoCommit { get; set; }
Visual Basic (Declaration)
Public Property AutoCommit As Boolean
Visual C++
public:
property bool AutoCommit {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


BackupBufferSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BackupBufferSize Property
DatabaseEnvironment Class See Also Send Feedback
The size of the buffer, in bytes, to read from the database during a hot backup.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BackupBufferSize { get; set; }
Visual Basic (Declaration)
Public Property BackupBufferSize As UInteger
Visual C++
public:
property unsigned int BackupBufferSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


BackupHandler Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BackupHandler Property
DatabaseEnvironment Class See Also Send Feedback
Sets the IBackup interface to be used when performing hot backups.

This interface is used to override the default behavior used by the Backup(String, BackupOptions) and BackupDatabase(String, String, Boolean) methods.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public IBackup BackupHandler { get; set; }
Visual Basic (Declaration)
Public Property BackupHandler As IBackup
Visual C++
public:
property IBackup^ BackupHandler {
    IBackup^ get ();
    void set (IBackup^ value);
}

See Also

DatabaseEnvironment Class


BackupReadCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BackupReadCount Property
DatabaseEnvironment Class See Also Send Feedback
The number of pages to read before pausing during the hot backup.

Increasing this value increases the amount of I/O the backup process performs for any given time interval. If your application is already heavily I/O bound, setting this value to a lower number may help to improve your overall data throughput by reducing the I/O demands placed on your system. By default, all pages are read without a pause.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BackupReadCount { get; set; }
Visual Basic (Declaration)
Public Property BackupReadCount As UInteger
Visual C++
public:
property unsigned int BackupReadCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


BackupReadSleepDuration Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BackupReadSleepDuration Property
DatabaseEnvironment Class See Also Send Feedback
The number of microseconds to sleep between batches of reads during a hot backup.

Increasing this value decreases the amount of I/O the backup process performs for any given time interval. If your application is already heavily I/O bound, setting this value to a higher number may help to improve your overall data throughput by reducing the I/O demands placed on your system.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BackupReadSleepDuration { get; set; }
Visual Basic (Declaration)
Public Property BackupReadSleepDuration As UInteger
Visual C++
public:
property unsigned int BackupReadSleepDuration {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


BackupWriteDirect Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BackupWriteDirect Property
DatabaseEnvironment Class See Also Send Feedback
If true, direct I/O is used when writing pages to the disk during a hot backup.

For some environments, direct I/O can provide faster write throughput, but usually it is slower because the OS buffer pool offers asynchronous activity.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool BackupWriteDirect { get; set; }
Visual Basic (Declaration)
Public Property BackupWriteDirect As Boolean
Visual C++
public:
property bool BackupWriteDirect {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


BlobDir Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BlobDir Property
DatabaseEnvironment Class See Also Send Feedback
The path of the directory where blobs are stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BlobDir { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlobDir As String
Visual C++
public:
property String^ BlobDir {
    String^ get ();
}

See Also

DatabaseEnvironment Class


BlobThreshold Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.BlobThreshold Property
DatabaseEnvironment Class See Also Send Feedback
The size in bytes which is used to determine when a data item is stored as a blob.

Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob.

If the threshold value is 0, databases opened in the environment default to never using blob support.

It is illegal to enable blob support if replication is enabled for the environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BlobThreshold { get; set; }
Visual Basic (Declaration)
Public Property BlobThreshold As UInteger
Visual C++
public:
property unsigned int BlobThreshold {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


CacheSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.CacheSize Property
DatabaseEnvironment Class See Also Send Feedback
The size of the shared memory buffer pool (the cache).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CacheInfo CacheSize { get; set; }
Visual Basic (Declaration)
Public Property CacheSize As CacheInfo
Visual C++
public:
property CacheInfo^ CacheSize {
    CacheInfo^ get ();
    void set (CacheInfo^ value);
}

Remarks

The cache should be the size of the normal working data set of the application, with some small amount of additional memory for unusual situations. (Note: the working set is not the same as the number of pages accessed simultaneously, and is usually much larger.)

The default cache size is 256KB, and may not be specified as less than 20KB. Any cache size less than 500MB is automatically increased by 25% to account for buffer pool overhead; cache sizes larger than 500MB are used as specified. The maximum size of a single cache is 4GB on 32-bit systems and 10TB on 64-bit systems. (All sizes are in powers-of-two, 256KB is 2^18 not 256,000.) For information on tuning the Berkeley DB cache size, see Selecting a cache size in the Programmer's Reference Guide.

See Also

DatabaseEnvironment Class


CDB_ALLDB Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.CDB_ALLDB Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB Concurrent Data Store applications perform locking on an environment-wide basis rather than on a per-database basis.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool CDB_ALLDB { get; }
Visual Basic (Declaration)
Public ReadOnly Property CDB_ALLDB As Boolean
Visual C++
public:
property bool CDB_ALLDB {
    bool get ();
}

See Also

DatabaseEnvironment Class


Create Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Create Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB subsystems create any underlying files, as necessary.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Create { get; }
Visual Basic (Declaration)
Public ReadOnly Property Create As Boolean
Visual C++
public:
property bool Create {
    bool get ();
}

See Also

DatabaseEnvironment Class


DataDirs Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.DataDirs Property
DatabaseEnvironment Class See Also Send Feedback
The array of directories where database files are stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public List<string> DataDirs { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataDirs As List(Of String)
Visual C++
public:
property List<String^>^ DataDirs {
    List<String^>^ get ();
}

See Also

DatabaseEnvironment Class


DeadlockResolution Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.DeadlockResolution Property
DatabaseEnvironment Class See Also Send Feedback
The deadlock detector configuration, specifying which lock request(s) should be rejected. As transactions acquire locks on behalf of a single locker ID, rejecting a lock request associated with a transaction normally requires the transaction to be aborted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DeadlockPolicy DeadlockResolution { get; set; }
Visual Basic (Declaration)
Public Property DeadlockResolution As DeadlockPolicy
Visual C++
public:
property DeadlockPolicy^ DeadlockResolution {
    DeadlockPolicy^ get ();
    void set (DeadlockPolicy^ value);
}

See Also

DatabaseEnvironment Class


EncryptAlgorithm Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.EncryptAlgorithm Property
DatabaseEnvironment Class See Also Send Feedback
The algorithm used by the Berkeley DB library to perform encryption and decryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EncryptionAlgorithm EncryptAlgorithm { get; }
Visual Basic (Declaration)
Public ReadOnly Property EncryptAlgorithm As EncryptionAlgorithm
Visual C++
public:
property EncryptionAlgorithm EncryptAlgorithm {
    EncryptionAlgorithm get ();
}

See Also

DatabaseEnvironment Class


ErrorFeedback Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ErrorFeedback Property
DatabaseEnvironment Class See Also Send Feedback
The mechanism for reporting detailed error messages to the application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ErrorFeedbackDelegate ErrorFeedback { get; set; }
Visual Basic (Declaration)
Public Property ErrorFeedback As ErrorFeedbackDelegate
Visual C++
public:
property ErrorFeedbackDelegate^ ErrorFeedback {
    ErrorFeedbackDelegate^ get ();
    void set (ErrorFeedbackDelegate^ value);
}

Remarks

When an error occurs in the Berkeley DB library, a DatabaseException, or subclass of DatabaseException, is thrown. In some cases the exception may be insufficient to completely describe the cause of the error, especially during initial application debugging.

In some cases, when an error occurs, Berkeley DB calls the given delegate with additional error information. It is up to the delegate to display the error message in an appropriate manner.

Setting ErrorFeedback to NULL unconfigures the callback interface.

This error-logging enhancement does not slow performance or significantly increase application size, and may be run during normal operation as well as during application debugging.

See Also

DatabaseEnvironment Class


ErrorPrefix Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ErrorPrefix Property
DatabaseEnvironment Class See Also Send Feedback
The prefix string that appears before error messages issued by Berkeley DB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string ErrorPrefix { get; set; }
Visual Basic (Declaration)
Public Property ErrorPrefix As String
Visual C++
public:
property String^ ErrorPrefix {
    String^ get ();
    void set (String^ value);
}

Remarks

For databases opened inside of a DatabaseEnvironment, setting ErrorPrefix affects the entire environment and is equivalent to setting ErrorPrefix.

Setting ErrorPrefix configures operations performed using the specified object, not all operations performed on the underlying database.

See Also

DatabaseEnvironment Class


EventNotify Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.EventNotify Property
DatabaseEnvironment Class See Also Send Feedback
A delegate which is called to notify the process of specific Berkeley DB events.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EventNotifyDelegate EventNotify { get; set; }
Visual Basic (Declaration)
Public Property EventNotify As EventNotifyDelegate
Visual C++
public:
property EventNotifyDelegate^ EventNotify {
    EventNotifyDelegate^ get ();
    void set (EventNotifyDelegate^ value);
}

See Also

DatabaseEnvironment Class


Feedback Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Feedback Property
DatabaseEnvironment Class See Also Send Feedback
Monitor progress within long running operations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EnvironmentFeedbackDelegate Feedback { get; set; }
Visual Basic (Declaration)
Public Property Feedback As EnvironmentFeedbackDelegate
Visual C++
public:
property EnvironmentFeedbackDelegate^ Feedback {
    EnvironmentFeedbackDelegate^ get ();
    void set (EnvironmentFeedbackDelegate^ value);
}

Remarks

Some operations performed by the Berkeley DB library can take non-trivial amounts of time. When an operation is likely to take a long time, Berkeley DB calls the the Feedback delegate to monitor progress within these operations.

It is up to the delegate to display this information in an appropriate manner.

See Also

DatabaseEnvironment Class


ForceFlush Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ForceFlush Property
DatabaseEnvironment Class See Also Send Feedback
If true, flush database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ForceFlush { get; set; }
Visual Basic (Declaration)
Public Property ForceFlush As Boolean
Visual C++
public:
property bool ForceFlush {
    bool get ();
    void set (bool value);
}

Remarks

This flag may result in inaccurate file modification times and other file-level information for Berkeley DB database files. This flag almost certainly results in a performance decrease on most systems.

See Also

DatabaseEnvironment Class


FreeThreaded Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.FreeThreaded Property
DatabaseEnvironment Class See Also Send Feedback
If true, the object is free-threaded; that is, concurrently usable by multiple threads in the address space.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool FreeThreaded { get; }
Visual Basic (Declaration)
Public ReadOnly Property FreeThreaded As Boolean
Visual C++
public:
property bool FreeThreaded {
    bool get ();
}

See Also

DatabaseEnvironment Class


Home Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Home Property
DatabaseEnvironment Class See Also Send Feedback
The database environment home directory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Home { get; }
Visual Basic (Declaration)
Public ReadOnly Property Home As String
Visual C++
public:
property String^ Home {
    String^ get ();
}

See Also

DatabaseEnvironment Class


HotbackupInProgress Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.HotbackupInProgress Property
DatabaseEnvironment Class See Also Send Feedback
Whether there is any hot backup in progress.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool HotbackupInProgress { get; set; }
Visual Basic (Declaration)
Public Property HotbackupInProgress As Boolean
Visual C++
public:
property bool HotbackupInProgress {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


InitLockCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.InitLockCount Property
DatabaseEnvironment Class See Also Send Feedback
The number of locks allocated when the environment is created

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLockCount { get; private set; }
Visual Basic (Declaration)
Public Property InitLockCount As UInteger
Visual C++
public:
property unsigned int InitLockCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


InitLockerCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.InitLockerCount Property
DatabaseEnvironment Class See Also Send Feedback
The number of lockers allocated when the environment is created

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLockerCount { get; private set; }
Visual Basic (Declaration)
Public Property InitLockerCount As UInteger
Visual C++
public:
property unsigned int InitLockerCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


InitLockObjectCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.InitLockObjectCount Property
DatabaseEnvironment Class See Also Send Feedback
The number of lock objects allocated when the environment is created

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLockObjectCount { get; private set; }
Visual Basic (Declaration)
Public Property InitLockObjectCount As UInteger
Visual C++
public:
property unsigned int InitLockObjectCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


InitLogIdCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.InitLogIdCount Property
DatabaseEnvironment Class See Also Send Feedback
The number of log identifier objects allocated when the environment is created

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLogIdCount { get; private set; }
Visual Basic (Declaration)
Public Property InitLogIdCount As UInteger
Visual C++
public:
property unsigned int InitLogIdCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


InitMutexes Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.InitMutexes Property
DatabaseEnvironment Class See Also Send Feedback
The initial number of mutexes allocated

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitMutexes { get; private set; }
Visual Basic (Declaration)
Public Property InitMutexes As UInteger
Visual C++
public:
property unsigned int InitMutexes {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


InitRegions Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.InitRegions Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB page-faults shared regions into memory when initially creating or joining a Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool InitRegions { get; set; }
Visual Basic (Declaration)
Public Property InitRegions As Boolean
Visual C++
public:
property bool InitRegions {
    bool get ();
    void set (bool value);
}

Remarks

In some applications, the expense of page-faulting the underlying shared memory regions can affect performance. (For example, if the page-fault occurs while holding a lock, other lock requests can convoy, and overall throughput may decrease.)

In addition to page-faulting, Berkeley DB writes the shared regions when creating an environment, forcing the underlying virtual memory and filesystems to instantiate both the necessary memory and the necessary disk space. This can also avoid out-of-disk space failures later on.

See Also

DatabaseEnvironment Class


InitThreadCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.InitThreadCount Property
DatabaseEnvironment Class See Also Send Feedback
The number of thread objects allocated when the environment is created

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitThreadCount { get; private set; }
Visual Basic (Declaration)
Public Property InitThreadCount As UInteger
Visual C++
public:
property unsigned int InitThreadCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


InitTxnCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.InitTxnCount Property
DatabaseEnvironment Class See Also Send Feedback
The number of transaction objects allocated when the environment is created

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitTxnCount { get; private set; }
Visual Basic (Declaration)
Public Property InitTxnCount As UInteger
Visual C++
public:
property unsigned int InitTxnCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


IntermediateDirMode Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.IntermediateDirMode Property
DatabaseEnvironment Class See Also Send Feedback
The intermediate directory permissions.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string IntermediateDirMode { get; private set; }
Visual Basic (Declaration)
Public Property IntermediateDirMode As String
Visual C++
public:
property String^ IntermediateDirMode {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseEnvironment Class


LockConflictMatrix Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LockConflictMatrix Property
DatabaseEnvironment Class See Also Send Feedback
The current lock conflicts array.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public byte[,] LockConflictMatrix { get; private set; }
Visual Basic (Declaration)
Public Property LockConflictMatrix As Byte(,)
Visual C++
public:
property array<unsigned char,2>^ LockConflictMatrix {
    array<unsigned char,2>^ get ();
    void set (array<unsigned char,2>^ value);
}

See Also

DatabaseEnvironment Class


Lockdown Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Lockdown Property
DatabaseEnvironment Class See Also Send Feedback
If true, lock shared Berkeley DB environment files and memory-mapped databases into memory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Lockdown { get; }
Visual Basic (Declaration)
Public ReadOnly Property Lockdown As Boolean
Visual C++
public:
property bool Lockdown {
    bool get ();
}

See Also

DatabaseEnvironment Class


LockPartitions Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LockPartitions Property
DatabaseEnvironment Class See Also Send Feedback
The number of lock table partitions used in the Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LockPartitions { get; private set; }
Visual Basic (Declaration)
Public Property LockPartitions As UInteger
Visual C++
public:
property unsigned int LockPartitions {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


LockTableSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LockTableSize Property
DatabaseEnvironment Class See Also Send Feedback
The size of the lock table in the Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LockTableSize { get; private set; }
Visual Basic (Declaration)
Public Property LockTableSize As UInteger
Visual C++
public:
property unsigned int LockTableSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


LockTimeout Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LockTimeout Property
DatabaseEnvironment Class See Also Send Feedback
A value, in microseconds, representing lock timeouts.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LockTimeout { get; set; }
Visual Basic (Declaration)
Public Property LockTimeout As UInteger
Visual C++
public:
property unsigned int LockTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

All timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values specified for the database environment may be overridden on a per-transaction basis, see SetLockTimeout(UInt32).

See Also

DatabaseEnvironment Class


LogAutoRemove Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogAutoRemove Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB automatically removes log files that are no longer needed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LogAutoRemove { get; set; }
Visual Basic (Declaration)
Public Property LogAutoRemove As Boolean
Visual C++
public:
property bool LogAutoRemove {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


LogBlobContent Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogBlobContent Property
DatabaseEnvironment Class See Also Send Feedback
If true, enables full logging of blob data. Required if using HA or the hotbackup utility.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LogBlobContent { get; set; }
Visual Basic (Declaration)
Public Property LogBlobContent As Boolean
Visual C++
public:
property bool LogBlobContent {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


LogBufferSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogBufferSize Property
DatabaseEnvironment Class See Also Send Feedback
The size of the in-memory log buffer, in bytes

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LogBufferSize { get; private set; }
Visual Basic (Declaration)
Public Property LogBufferSize As UInteger
Visual C++
public:
property unsigned int LogBufferSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


LogDir Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogDir Property
DatabaseEnvironment Class See Also Send Feedback
The path of a directory to be used as the location of logging files. Log files created by the Log Manager subsystem are created in this directory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string LogDir { get; private set; }
Visual Basic (Declaration)
Public Property LogDir As String
Visual C++
public:
property String^ LogDir {
    String^ get ();
    void set (String^ value);
}

See Also

DatabaseEnvironment Class


LogFileMode Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogFileMode Property
DatabaseEnvironment Class See Also Send Feedback
The absolute file mode for created log files. This property is only useful for the rare Berkeley DB application that does not control its umask value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int LogFileMode { get; set; }
Visual Basic (Declaration)
Public Property LogFileMode As Integer
Visual C++
public:
property int LogFileMode {
    int get ();
    void set (int value);
}

Remarks

Normally, if Berkeley DB applications set their umask appropriately, all processes in the application suite obtain read permission on the log files created by any process in the application suite. However, if the Berkeley DB application is a library, a process using the library might set its umask to a value preventing other processes in the application suite from reading the log files it creates. In this rare case, this property can be used to set the mode of created log files to an absolute value.

See Also

DatabaseEnvironment Class


LogForceSync Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogForceSync Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB flushes log writes to the backing disk before returning from the write system call, rather than flushing log writes explicitly in a separate system call, as necessary.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LogForceSync { get; set; }
Visual Basic (Declaration)
Public Property LogForceSync As Boolean
Visual C++
public:
property bool LogForceSync {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


LogInMemory Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogInMemory Property
DatabaseEnvironment Class See Also Send Feedback
If true, transaction logs are maintained in-memory rather than on disk. This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LogInMemory { get; }
Visual Basic (Declaration)
Public ReadOnly Property LogInMemory As Boolean
Visual C++
public:
property bool LogInMemory {
    bool get ();
}

See Also

DatabaseEnvironment Class


LogNoBuffer Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogNoBuffer Property
DatabaseEnvironment Class See Also Send Feedback
If true, system buffering is turned off for Berkeley DB log files to avoid double caching.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LogNoBuffer { get; set; }
Visual Basic (Declaration)
Public Property LogNoBuffer As Boolean
Visual C++
public:
property bool LogNoBuffer {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


LogNoSync Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogNoSync Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB avoids the fsync() call when the log files are flushed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LogNoSync { get; set; }
Visual Basic (Declaration)
Public Property LogNoSync As Boolean
Visual C++
public:
property bool LogNoSync {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


LogRegionSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogRegionSize Property
DatabaseEnvironment Class See Also Send Feedback
The size of the underlying logging area of the Berkeley DB environment, in bytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LogRegionSize { get; private set; }
Visual Basic (Declaration)
Public Property LogRegionSize As UInteger
Visual C++
public:
property unsigned int LogRegionSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


LogZeroOnCreate Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.LogZeroOnCreate Property
DatabaseEnvironment Class See Also Send Feedback
If true, all pages of a log file are zeroed when that log file is created.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LogZeroOnCreate { get; }
Visual Basic (Declaration)
Public ReadOnly Property LogZeroOnCreate As Boolean
Visual C++
public:
property bool LogZeroOnCreate {
    bool get ();
}

See Also

DatabaseEnvironment Class


MaxCacheSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxCacheSize Property
DatabaseEnvironment Class See Also Send Feedback
The maximum cache size

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CacheInfo MaxCacheSize { get; private set; }
Visual Basic (Declaration)
Public Property MaxCacheSize As CacheInfo
Visual C++
public:
property CacheInfo^ MaxCacheSize {
    CacheInfo^ get ();
    void set (CacheInfo^ value);
}

See Also

DatabaseEnvironment Class


MaxLockers Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxLockers Property
DatabaseEnvironment Class See Also Send Feedback
The maximum number of locking entities supported by the Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLockers { get; private set; }
Visual Basic (Declaration)
Public Property MaxLockers As UInteger
Visual C++
public:
property unsigned int MaxLockers {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


MaxLocks Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxLocks Property
DatabaseEnvironment Class See Also Send Feedback
The maximum number of locks supported by the Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLocks { get; private set; }
Visual Basic (Declaration)
Public Property MaxLocks As UInteger
Visual C++
public:
property unsigned int MaxLocks {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


MaxLogFileSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxLogFileSize Property
DatabaseEnvironment Class See Also Send Feedback
The maximum size of a single file in the log, in bytes. Because LSN Offsets are unsigned four-byte values, the size may not be larger than the maximum unsigned four-byte value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLogFileSize { get; set; }
Visual Basic (Declaration)
Public Property MaxLogFileSize As UInteger
Visual C++
public:
property unsigned int MaxLogFileSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

When the logging subsystem is configured for on-disk logging, the default size of a log file is 10MB.

When the logging subsystem is configured for in-memory logging, the default size of a log file is 256KB. In addition, the configured log buffer size must be larger than the log file size. (The logging subsystem divides memory configured for in-memory log records into "files", as database environments configured for in-memory log records may exchange log records with other members of a replication group, and those members may be configured to store log records on-disk.) When choosing log buffer and file sizes for in-memory logs, applications should ensure the in-memory log buffer size is large enough that no transaction ever spans the entire buffer, and avoid a state where the in-memory buffer is full and no space can be freed because a transaction that started in the first log "file" is still active.

See Log File Limits in the Programmer's Reference Guide for more information.

If no size is specified by the application, the size last specified for the database region is used, or if no database region previously existed, the default is used.

See Also

DatabaseEnvironment Class


MaxMutexes Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxMutexes Property
DatabaseEnvironment Class See Also Send Feedback
The total number of mutexes allocated

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxMutexes { get; private set; }
Visual Basic (Declaration)
Public Property MaxMutexes As UInteger
Visual C++
public:
property unsigned int MaxMutexes {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


MaxObjects Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxObjects Property
DatabaseEnvironment Class See Also Send Feedback
The maximum number of locked objects

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxObjects { get; private set; }
Visual Basic (Declaration)
Public Property MaxObjects As UInteger
Visual C++
public:
property unsigned int MaxObjects {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


MaxOpenFiles Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxOpenFiles Property
DatabaseEnvironment Class See Also Send Feedback
The number of file descriptors the library opens concurrently when flushing dirty pages from the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int MaxOpenFiles { get; set; }
Visual Basic (Declaration)
Public Property MaxOpenFiles As Integer
Visual C++
public:
property int MaxOpenFiles {
    int get ();
    void set (int value);
}

See Also

DatabaseEnvironment Class


MaxSequentialWrites Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxSequentialWrites Property
DatabaseEnvironment Class See Also Send Feedback
The number of sequential write operations scheduled by the library when flushing dirty pages from the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int MaxSequentialWrites { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxSequentialWrites As Integer
Visual C++
public:
property int MaxSequentialWrites {
    int get ();
}

See Also

DatabaseEnvironment Class


MaxTransactions Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MaxTransactions Property
DatabaseEnvironment Class See Also Send Feedback
The number of active transactions supported by the environment. This value bounds the size of the memory allocated for transactions. Child transactions are counted as active until they either commit or abort.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxTransactions { get; set; }
Visual Basic (Declaration)
Public Property MaxTransactions As UInteger
Visual C++
public:
property unsigned int MaxTransactions {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Transactions that update multiversion databases are not freed until the last page version that the transaction created is flushed from cache. This means that applications using multi-version concurrency control may need in the extreme case a transaction for each page in cache.

When all of the memory available in the database environment for transactions is in use, calls to BeginTransaction()()() fail (until some active transactions complete). If MaxTransactions is never set, the database environment is configured to support at least 100 active transactions.

See Also

DatabaseEnvironment Class


messageFeedback Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.messageFeedback Property
DatabaseEnvironment Class See Also Send Feedback
The mechanism for reporting detailed statistic messages to the application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MessageFeedbackDelegate messageFeedback { get; set; }
Visual Basic (Declaration)
Public Property messageFeedback As MessageFeedbackDelegate
Visual C++
public:
property MessageFeedbackDelegate^ messageFeedback {
    MessageFeedbackDelegate^ get ();
    void set (MessageFeedbackDelegate^ value);
}

Remarks

There are interfaces in the Berkeley DB library which either directly output informational messages or statistical information, or configure the library to output such messages when performing other operations.

Berkeley DB calls the given delegate with each message. It is up to the delegate to display the message in an appropriate manner.

Setting MessageFeedback to NULL resets the callback interface.

See Also

DatabaseEnvironment Class


MetadataDir Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MetadataDir Property
DatabaseEnvironment Class See Also Send Feedback
The path of directory to store the persistent metadata.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string MetadataDir { get; }
Visual Basic (Declaration)
Public ReadOnly Property MetadataDir As String
Visual C++
public:
property String^ MetadataDir {
    String^ get ();
}

Remarks

By default, metadata is stored in the environment home directory. See Berkeley DB File Naming in the Programmer's Reference Guide for more information.

When used in a replicated application, the metadata directory must be the same location for all sites within a replication group.

See Also

DatabaseEnvironment Class


MMapSize Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MMapSize Property
DatabaseEnvironment Class See Also Send Feedback
The maximum file size, in bytes, for a file to be mapped into the process address space. If no value is specified, it defaults to 10MB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MMapSize { get; set; }
Visual Basic (Declaration)
Public Property MMapSize As UInteger
Visual C++
public:
property unsigned int MMapSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Files that are opened read-only in the cache (and that satisfy a few other criteria) are, by default, mapped into the process address space instead of being copied into the local cache. This can result in better-than-usual performance because available virtual memory is normally much larger than the local cache, and page faults are faster than page copying on many systems. However, it can cause resource starvation in the presence of limited virtual memory, and it can result in immense process sizes in the presence of large databases.

See Also

DatabaseEnvironment Class


Msgfile Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Msgfile Property
DatabaseEnvironment Class See Also Send Feedback
The message file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Msgfile { set; }
Visual Basic (Declaration)
Public WriteOnly Property Msgfile As String
Visual C++
public:
property String^ Msgfile {
    void set (String^ value);
}

See Also

DatabaseEnvironment Class


MutexAlignment Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MutexAlignment Property
DatabaseEnvironment Class See Also Send Feedback
The mutex alignment, in bytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MutexAlignment { get; private set; }
Visual Basic (Declaration)
Public Property MutexAlignment As UInteger
Visual C++
public:
property unsigned int MutexAlignment {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


MutexIncrement Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.MutexIncrement Property
DatabaseEnvironment Class See Also Send Feedback
The number of additional mutexes allocated.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MutexIncrement { get; private set; }
Visual Basic (Declaration)
Public Property MutexIncrement As UInteger
Visual C++
public:
property unsigned int MutexIncrement {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


NoBuffer Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.NoBuffer Property
DatabaseEnvironment Class See Also Send Feedback
If true, turn off system buffering of Berkeley DB database files to avoid double caching.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoBuffer { get; set; }
Visual Basic (Declaration)
Public Property NoBuffer As Boolean
Visual C++
public:
property bool NoBuffer {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


NoLocking Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.NoLocking Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB grants all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoLocking { get; set; }
Visual Basic (Declaration)
Public Property NoLocking As Boolean
Visual C++
public:
property bool NoLocking {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


NoMMap Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.NoMMap Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB copies read-only database files into the local cache instead of potentially mapping them into process memory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoMMap { get; set; }
Visual Basic (Declaration)
Public Property NoMMap As Boolean
Visual C++
public:
property bool NoMMap {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class
BerkeleyDB Namespace
DatabaseEnvironment..::.MMapSize


NoPanic Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.NoPanic Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB ignores any panic state in the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException.) This functionality should never be used for purposes other than debugging.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoPanic { get; set; }
Visual Basic (Declaration)
Public Property NoPanic As Boolean
Visual C++
public:
property bool NoPanic {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


NumTestAndSetSpins Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.NumTestAndSetSpins Property
DatabaseEnvironment Class See Also Send Feedback
The number of times that test-and-set mutexes should spin without blocking. The value defaults to 1 on uniprocessor systems and to 50 times the number of processors on multiprocessor systems.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NumTestAndSetSpins { get; set; }
Visual Basic (Declaration)
Public Property NumTestAndSetSpins As UInteger
Visual C++
public:
property unsigned int NumTestAndSetSpins {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


Overwrite Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Overwrite Property
DatabaseEnvironment Class See Also Send Feedback
If true, overwrite files stored in encrypted formats before deleting them.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Overwrite { get; set; }
Visual Basic (Declaration)
Public Property Overwrite As Boolean
Visual C++
public:
property bool Overwrite {
    bool get ();
    void set (bool value);
}

Remarks

Berkeley DB overwrites files using alternating 0xff, 0x00 and 0xff byte patterns. For an effective overwrite, the underlying file must be stored on a fixed-block filesystem. Systems with journaling or logging filesystems require operating system support and probably modification of the Berkeley DB sources.

See Also

DatabaseEnvironment Class


Private Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Private Property
DatabaseEnvironment Class See Also Send Feedback
If true, allocate region memory from the heap instead of from memory backed by the filesystem or system shared memory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Private { get; }
Visual Basic (Declaration)
Public ReadOnly Property Private As Boolean
Visual C++
public:
property bool Private {
    bool get ();
}

See Also

DatabaseEnvironment Class


RegionMemoryLimitBytes Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RegionMemoryLimitBytes Property
DatabaseEnvironment Class See Also Send Feedback
The bytes component of the byte-count limit on the amount of memory to be used by shared structures in the main environment region. These are the structures other than mutexes and the page cache (memory pool).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RegionMemoryLimitBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionMemoryLimitBytes As UInteger
Visual C++
public:
property unsigned int RegionMemoryLimitBytes {
    unsigned int get ();
}

Return Value

The maximum number of bytes used by the main region.

See Also

DatabaseEnvironment Class


RegionMemoryLimitGBytes Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RegionMemoryLimitGBytes Property
DatabaseEnvironment Class See Also Send Feedback
The gigabytes component of the byte-count limit on the amount of memory to be used by shared structures in the main environment region. These are the structures other than mutexes and the page cache (memory pool).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RegionMemoryLimitGBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionMemoryLimitGBytes As UInteger
Visual C++
public:
property unsigned int RegionMemoryLimitGBytes {
    unsigned int get ();
}

Return Value

The maximum number of gigabytes used by the main region.

See Also

DatabaseEnvironment Class


Register Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Register Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB checks if recovery is needed to be performed before opening the database environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Register { get; }
Visual Basic (Declaration)
Public ReadOnly Property Register As Boolean
Visual C++
public:
property bool Register {
    bool get ();
}

See Also

DatabaseEnvironment Class


RepAckTimeout Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepAckTimeout Property
DatabaseEnvironment Class See Also Send Feedback
The amount of time the replication manager's transport function waits to collect enough acknowledgments from replication group clients, before giving up and returning a failure indication. The default wait time is 1 second.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepAckTimeout { get; set; }
Visual Basic (Declaration)
Public Property RepAckTimeout As UInteger
Visual C++
public:
property unsigned int RepAckTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


RepAutoInit Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepAutoInit Property
DatabaseEnvironment Class See Also Send Feedback
If true, the replication master automatically re-initializes outdated clients (defaults to true).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepAutoInit { get; set; }
Visual Basic (Declaration)
Public Property RepAutoInit As Boolean
Visual C++
public:
property bool RepAutoInit {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


RepBulkTransfer Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepBulkTransfer Property
DatabaseEnvironment Class See Also Send Feedback
If true, the replication master sends groups of records to the clients in a single network transfer

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepBulkTransfer { get; set; }
Visual Basic (Declaration)
Public Property RepBulkTransfer As Boolean
Visual C++
public:
property bool RepBulkTransfer {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


RepCheckpointDelay Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepCheckpointDelay Property
DatabaseEnvironment Class See Also Send Feedback
The amount of time a master site delays between completing a checkpoint and writing a checkpoint record into the log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepCheckpointDelay { get; set; }
Visual Basic (Declaration)
Public Property RepCheckpointDelay As UInteger
Visual C++
public:
property unsigned int RepCheckpointDelay {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This delay allows clients to complete their own checkpoints before the master requires completion of them. The default is 30 seconds. Delay should be set to 0 if all databases in the environment and the environment's transaction log are configured to reside in-memory.

See Also

DatabaseEnvironment Class


RepClockskewFast Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepClockskewFast Property
DatabaseEnvironment Class See Also Send Feedback
The value, relative to RepClockskewSlow, of the fastest clock in the group of sites.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepClockskewFast { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepClockskewFast As UInteger
Visual C++
public:
property unsigned int RepClockskewFast {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


RepClockskewSlow Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepClockskewSlow Property
DatabaseEnvironment Class See Also Send Feedback
The value of the slowest clock in the group of sites.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepClockskewSlow { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepClockskewSlow As UInteger
Visual C++
public:
property unsigned int RepClockskewSlow {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


RepConnectionRetry Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepConnectionRetry Property
DatabaseEnvironment Class See Also Send Feedback
The amount of time the replication manager waits before trying to re-establish a connection to another site after a communication failure. The default wait time is 30 seconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepConnectionRetry { get; set; }
Visual Basic (Declaration)
Public Property RepConnectionRetry As UInteger
Visual C++
public:
property unsigned int RepConnectionRetry {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


RepDelayClientSync Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepDelayClientSync Property
DatabaseEnvironment Class See Also Send Feedback
If true, the client should delay synchronizing to a newly declared master (defaults to false). Clients configured in this way remain unsynchronized until the application calls RepSync()()().

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepDelayClientSync { get; set; }
Visual Basic (Declaration)
Public Property RepDelayClientSync As Boolean
Visual C++
public:
property bool RepDelayClientSync {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


RepElectionRetry Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepElectionRetry Property
DatabaseEnvironment Class See Also Send Feedback
Configure the amount of time the replication manager waits before retrying a failed election. The default wait time is 10 seconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepElectionRetry { get; set; }
Visual Basic (Declaration)
Public Property RepElectionRetry As UInteger
Visual C++
public:
property unsigned int RepElectionRetry {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


RepElectionTimeout Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepElectionTimeout Property
DatabaseEnvironment Class See Also Send Feedback
The timeout period for an election. The default timeout is 2 seconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepElectionTimeout { get; set; }
Visual Basic (Declaration)
Public Property RepElectionTimeout As UInteger
Visual C++
public:
property unsigned int RepElectionTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


RepFullElectionTimeout Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepFullElectionTimeout Property
DatabaseEnvironment Class See Also Send Feedback
An optional configuration timeout period to wait for full election participation the first time the replication group finds a master. By default this option is turned off and normal election timeouts are used. (See the Elections section in the Berkeley DB Reference Guide for more information.)

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepFullElectionTimeout { get; set; }
Visual Basic (Declaration)
Public Property RepFullElectionTimeout As UInteger
Visual C++
public:
property unsigned int RepFullElectionTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


RepHeartbeatMonitor Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepHeartbeatMonitor Property
DatabaseEnvironment Class See Also Send Feedback
The amount of time the replication manager, running at a client site, waits for some message activity on the connection from the master (heartbeats or other messages) before concluding that the connection has been lost. When 0 (the default), no monitoring is performed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepHeartbeatMonitor { get; set; }
Visual Basic (Declaration)
Public Property RepHeartbeatMonitor As UInteger
Visual C++
public:
property unsigned int RepHeartbeatMonitor {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


RepHeartbeatSend Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepHeartbeatSend Property
DatabaseEnvironment Class See Also Send Feedback
The frequency at which the replication manager, running at a master site, broadcasts a heartbeat message in an otherwise idle system. When 0 (the default), no heartbeat messages are sent.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepHeartbeatSend { get; set; }
Visual Basic (Declaration)
Public Property RepHeartbeatSend As UInteger
Visual C++
public:
property unsigned int RepHeartbeatSend {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


RepInMemory Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepInMemory Property
DatabaseEnvironment Class See Also Send Feedback
If true, replication only stores the internal information in-memory and cannot keep persistent state across a site crash or reboot. By default, it is false and replication creates files in the environment home directory to preserve the internal information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepInMemory { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepInMemory As Boolean
Visual C++
public:
property bool RepInMemory {
    bool get ();
}

See Also

DatabaseEnvironment Class


RepLeaseTimeout Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepLeaseTimeout Property
DatabaseEnvironment Class See Also Send Feedback
The amount of time a client grants its master lease to a master. When using master leases all sites in a replication group must use the same lease timeout value. There is no default value. If leases are desired, this method must be called prior to calling RepStartClient()()() or RepStartMaster()()().

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepLeaseTimeout { get; set; }
Visual Basic (Declaration)
Public Property RepLeaseTimeout As UInteger
Visual C++
public:
property unsigned int RepLeaseTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


ReplicationView Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ReplicationView Property
DatabaseEnvironment Class See Also Send Feedback
The function used to create a replication view that determines whether a database file is replicated to the local site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationViewDelegate ReplicationView { get; private set; }
Visual Basic (Declaration)
Public Property ReplicationView As ReplicationViewDelegate
Visual C++
public:
property ReplicationViewDelegate^ ReplicationView {
    ReplicationViewDelegate^ get ();
    void set (ReplicationViewDelegate^ value);
}

Remarks

If it is null, the replication view is a full view and all database files are replicated to the local site. Otherwise it is a partial view and only some database files are replicated to the local site.

See Also

DatabaseEnvironment Class


RepMessageDispatch Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMessageDispatch Property
DatabaseEnvironment Class See Also Send Feedback
Set the message dispatch function. It is responsible for receiving messages sent from remote sites using either SendMessage(array<DatabaseEntry>[]()[]) or SendRequest(array<DatabaseEntry>[]()[], UInt32). If the message received by this function was sent using SendMessage(array<DatabaseEntry>[]()[]), then no response is required. If the message was sent using SendRequest(array<DatabaseEntry>[]()[], UInt32), then this function must send a response using SendMessage(array<DatabaseEntry>[]()[]).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MessageDispatchDelegate RepMessageDispatch { get; set; }
Visual Basic (Declaration)
Public Property RepMessageDispatch As MessageDispatchDelegate
Visual C++
public:
property MessageDispatchDelegate^ RepMessageDispatch {
    MessageDispatchDelegate^ get ();
    void set (MessageDispatchDelegate^ value);
}

Remarks

It should be called before the Replication Manager has been started.

See Also

DatabaseEnvironment Class


RepMgrAckPolicy Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrAckPolicy Property
DatabaseEnvironment Class See Also Send Feedback
Specify how master and client sites handle acknowledgment of replication messages which are necessary for "permanent" records. The current implementation requires all sites in a replication group configure the same acknowledgement policy.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public AckPolicy RepMgrAckPolicy { get; set; }
Visual Basic (Declaration)
Public Property RepMgrAckPolicy As AckPolicy
Visual C++
public:
property AckPolicy^ RepMgrAckPolicy {
    AckPolicy^ get ();
    void set (AckPolicy^ value);
}

See Also

DatabaseEnvironment Class
BerkeleyDB Namespace
DatabaseEnvironment..::.RepAckTimeout


RepmgrIncomingQueueMaxBytes Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepmgrIncomingQueueMaxBytes Property
DatabaseEnvironment Class See Also Send Feedback
The bytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepmgrIncomingQueueMaxBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepmgrIncomingQueueMaxBytes As UInteger
Visual C++
public:
property unsigned int RepmgrIncomingQueueMaxBytes {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


RepmgrIncomingQueueMaxGBytes Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepmgrIncomingQueueMaxGBytes Property
DatabaseEnvironment Class See Also Send Feedback
The gigabytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepmgrIncomingQueueMaxGBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepmgrIncomingQueueMaxGBytes As UInteger
Visual C++
public:
property unsigned int RepmgrIncomingQueueMaxGBytes {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


RepMgrLocalSite Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrLocalSite Property
DatabaseEnvironment Class See Also Send Feedback
The local site of the replication manager. Returns null if the local site has not been configured.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DbSite RepMgrLocalSite { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepMgrLocalSite As DbSite
Visual C++
public:
property DbSite^ RepMgrLocalSite {
    DbSite^ get ();
}

See Also

DatabaseEnvironment Class


RepMgrRemoteSites Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrRemoteSites Property
DatabaseEnvironment Class See Also Send Feedback
The status of the sites currently known by the replication manager.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RepMgrSite[] RepMgrRemoteSites { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepMgrRemoteSites As RepMgrSite()
Visual C++
public:
property array<RepMgrSite^>^ RepMgrRemoteSites {
    array<RepMgrSite^>^ get ();
}

See Also

DatabaseEnvironment Class


RepMgrRunElections Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepMgrRunElections Property
DatabaseEnvironment Class See Also Send Feedback
If true, Replication Manager automatically runs elections to choose a new master when the old master disconnects (defaults to true).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepMgrRunElections { get; set; }
Visual Basic (Declaration)
Public Property RepMgrRunElections As Boolean
Visual C++
public:
property bool RepMgrRunElections {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


RepNoBlocking Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepNoBlocking Property
DatabaseEnvironment Class See Also Send Feedback
If true, errors are returned immediately for Berkeley DB method calls that would normally block while clients are in recovery (defaults to false).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepNoBlocking { get; set; }
Visual Basic (Declaration)
Public Property RepNoBlocking As Boolean
Visual C++
public:
property bool RepNoBlocking {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


RepNSites Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepNSites Property
DatabaseEnvironment Class See Also Send Feedback
The total number of sites in the replication group.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepNSites { get; set; }
Visual Basic (Declaration)
Public Property RepNSites As UInteger
Visual C++
public:
property unsigned int RepNSites {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This setting is typically used by applications which use the Berkeley DB library "replication manager" support. (However, see also RepHoldElection()()(), the description of the nsites parameter.)

See Also

DatabaseEnvironment Class


RepPrefmasClient Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepPrefmasClient Property
DatabaseEnvironment Class See Also Send Feedback
This flag is used to specify the client site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The client site in a preferred master replication group takes over temporarily as master when the preferred master site is unavailable.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepPrefmasClient { get; set; }
Visual Basic (Declaration)
Public Property RepPrefmasClient As Boolean
Visual C++
public:
property bool RepPrefmasClient {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


RepPrefmasMaster Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepPrefmasMaster Property
DatabaseEnvironment Class See Also Send Feedback
This flag is used to specify the preferred master site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The preferred master site operates as the master site whenever possible.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepPrefmasMaster { get; set; }
Visual Basic (Declaration)
Public Property RepPrefmasMaster As Boolean
Visual C++
public:
property bool RepPrefmasMaster {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


RepPriority Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepPriority Property
DatabaseEnvironment Class See Also Send Feedback
The database environment's priority in replication group elections. A special value of 0 indicates that this environment cannot be a replication group master. If not configured, then a default value of 100 is used.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepPriority { get; set; }
Visual Basic (Declaration)
Public Property RepPriority As UInteger
Visual C++
public:
property unsigned int RepPriority {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


RepRetransmissionRequestMax Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepRetransmissionRequestMax Property
DatabaseEnvironment Class See Also Send Feedback
The maximum number of microseconds a client waits before requesting retransmission.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepRetransmissionRequestMax { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepRetransmissionRequestMax As UInteger
Visual C++
public:
property unsigned int RepRetransmissionRequestMax {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


RepRetransmissionRequestMin Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepRetransmissionRequestMin Property
DatabaseEnvironment Class See Also Send Feedback
The minimum number of microseconds a client waits before requesting retransmission.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepRetransmissionRequestMin { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepRetransmissionRequestMin As UInteger
Visual C++
public:
property unsigned int RepRetransmissionRequestMin {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


RepStrict2Site Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepStrict2Site Property
DatabaseEnvironment Class See Also Send Feedback
Replication Manager observes the strict "majority" rule in managing elections, even in a group with only 2 sites. The client in a 2-site group is unable to take over as master if the original master fails or becomes disconnected. (See the Elections section in the Berkeley DB Reference Guide for more information.) Both sites in the replication group should have the same value for this parameter.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepStrict2Site { get; set; }
Visual Basic (Declaration)
Public Property RepStrict2Site As Boolean
Visual C++
public:
property bool RepStrict2Site {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


RepTransmitLimitBytes Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepTransmitLimitBytes Property
DatabaseEnvironment Class See Also Send Feedback
The bytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepTransmitLimitBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepTransmitLimitBytes As UInteger
Visual C++
public:
property unsigned int RepTransmitLimitBytes {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


RepTransmitLimitGBytes Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepTransmitLimitGBytes Property
DatabaseEnvironment Class See Also Send Feedback
The gigabytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepTransmitLimitGBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepTransmitLimitGBytes As UInteger
Visual C++
public:
property unsigned int RepTransmitLimitGBytes {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


RepTransport Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepTransport Property
DatabaseEnvironment Class See Also Send Feedback
The delegate used to transmit data using the replication application's communication infrastructure.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationTransportDelegate RepTransport { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepTransport As ReplicationTransportDelegate
Visual C++
public:
property ReplicationTransportDelegate^ RepTransport {
    ReplicationTransportDelegate^ get ();
}

See Also

DatabaseEnvironment Class


RepUseMasterLeases Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RepUseMasterLeases Property
DatabaseEnvironment Class See Also Send Feedback
If true, master leases are used for this site (defaults to false).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepUseMasterLeases { get; set; }
Visual Basic (Declaration)
Public Property RepUseMasterLeases As Boolean
Visual C++
public:
property bool RepUseMasterLeases {
    bool get ();
    void set (bool value);
}

Remarks

Configuring this option may result in a LeaseExpiredException when attempting to read entries from a database after the site's master lease has expired.

See Also

DatabaseEnvironment Class


RunFatalRecovery Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RunFatalRecovery Property
DatabaseEnvironment Class See Also Send Feedback
If true, catastrophic recovery was run on this environment before opening it for normal use.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RunFatalRecovery { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunFatalRecovery As Boolean
Visual C++
public:
property bool RunFatalRecovery {
    bool get ();
}

See Also

DatabaseEnvironment Class


RunRecovery Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.RunRecovery Property
DatabaseEnvironment Class See Also Send Feedback
If true, normal recovery was run on this environment before opening it for normal use.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RunRecovery { get; }
Visual Basic (Declaration)
Public ReadOnly Property RunRecovery As Boolean
Visual C++
public:
property bool RunRecovery {
    bool get ();
}

See Also

DatabaseEnvironment Class


SequentialWritePause Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.SequentialWritePause Property
DatabaseEnvironment Class See Also Send Feedback
The number of microseconds the thread of control pauses before scheduling further write operations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint SequentialWritePause { get; }
Visual Basic (Declaration)
Public ReadOnly Property SequentialWritePause As UInteger
Visual C++
public:
property unsigned int SequentialWritePause {
    unsigned int get ();
}

See Also

DatabaseEnvironment Class


SetThreadID Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.SetThreadID Property
DatabaseEnvironment Class See Also Send Feedback
A delegate that returns a unique identifier pair for the current thread of control.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SetThreadIDDelegate SetThreadID { get; set; }
Visual Basic (Declaration)
Public Property SetThreadID As SetThreadIDDelegate
Visual C++
public:
property SetThreadIDDelegate^ SetThreadID {
    SetThreadIDDelegate^ get ();
    void set (SetThreadIDDelegate^ value);
}

Remarks

This delegate supports FailCheck()()(). For more information, see Architecting Data Store and Concurrent Data Store applications, and Architecting Transactional Data Store applications, both in the Berkeley DB Programmer's Reference Guide.

See Also

DatabaseEnvironment Class


SetThreadName Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.SetThreadName Property
DatabaseEnvironment Class See Also Send Feedback
A delegate that formats a process ID and thread ID identifier pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SetThreadNameDelegate SetThreadName { get; set; }
Visual Basic (Declaration)
Public Property SetThreadName As SetThreadNameDelegate
Visual C++
public:
property SetThreadNameDelegate^ SetThreadName {
    SetThreadNameDelegate^ get ();
    void set (SetThreadNameDelegate^ value);
}

See Also

DatabaseEnvironment Class


SystemMemory Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.SystemMemory Property
DatabaseEnvironment Class See Also Send Feedback
If true, allocate region memory from system shared memory instead of from heap memory or memory backed by the filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SystemMemory { get; }
Visual Basic (Declaration)
Public ReadOnly Property SystemMemory As Boolean
Visual C++
public:
property bool SystemMemory {
    bool get ();
}

See Also

DatabaseEnvironment Class


TempDir Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TempDir Property
DatabaseEnvironment Class See Also Send Feedback
The path of a directory to be used as the location for temporary files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string TempDir { get; set; }
Visual Basic (Declaration)
Public Property TempDir As String
Visual C++
public:
property String^ TempDir {
    String^ get ();
    void set (String^ value);
}

Remarks

The files created to back in-memory access method databases are created relative to this path. These temporary files can be quite large, depending on the size of the database.

If no directories are specified, the following alternatives are checked in the specified order. The first existing directory path is used for all temporary files.

  1. The value of the environment variable TMPDIR.
  2. The value of the environment variable TEMP.
  3. The value of the environment variable TMP.
  4. The value of the environment variable TempFolder.
  5. The value returned by the GetTempPath interface.
  6. The directory /var/tmp.
  7. The directory /usr/tmp.
  8. The directory /temp.
  9. The directory /tmp.
  10. The directory C:/temp.
  11. The directory C:/tmp.

Environment variables are only checked if UseEnvironmentVars is true.

See Also

DatabaseEnvironment Class


ThreadCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ThreadCount Property
DatabaseEnvironment Class See Also Send Feedback
An approximate number of threads in the database environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ThreadCount { get; private set; }
Visual Basic (Declaration)
Public Property ThreadCount As UInteger
Visual C++
public:
property unsigned int ThreadCount {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironment Class


ThreadIsAlive Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.ThreadIsAlive Property
DatabaseEnvironment Class See Also Send Feedback
A delegate that returns if a thread of control (either a true thread or a process) is still running.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ThreadIsAliveDelegate ThreadIsAlive { get; set; }
Visual Basic (Declaration)
Public Property ThreadIsAlive As ThreadIsAliveDelegate
Visual C++
public:
property ThreadIsAliveDelegate^ ThreadIsAlive {
    ThreadIsAliveDelegate^ get ();
    void set (ThreadIsAliveDelegate^ value);
}

See Also

DatabaseEnvironment Class


TimeNotGranted Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TimeNotGranted Property
DatabaseEnvironment Class See Also Send Feedback
If true, database calls timing out based on lock or transaction timeout values throw LockNotGrantedException instead of DeadlockException.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TimeNotGranted { get; set; }
Visual Basic (Declaration)
Public Property TimeNotGranted As Boolean
Visual C++
public:
property bool TimeNotGranted {
    bool get ();
    void set (bool value);
}

Remarks

If true, allows applications to distinguish between deadlocked operations and operations that have exceeded their time limits.

See Also

DatabaseEnvironment Class


TxnNoSync Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TxnNoSync Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB does not write or synchronously flush the log on transaction commit.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TxnNoSync { get; set; }
Visual Basic (Declaration)
Public Property TxnNoSync As Boolean
Visual C++
public:
property bool TxnNoSync {
    bool get ();
    void set (bool value);
}

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); database integrity is maintained, but if the application or system fails, it is possible some number of the most recently committed transactions may be undone during recovery. The number of transactions at risk is governed by how many log updates can fit into the log buffer, how often the operating system flushes dirty buffers to disk, and how often the log is checkpointed.

See Also

DatabaseEnvironment Class


TxnNoWait Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TxnNoWait Property
DatabaseEnvironment Class See Also Send Feedback
If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw DeadlockException (or LockNotGrantedException if configured with TimeNotGranted).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TxnNoWait { get; set; }
Visual Basic (Declaration)
Public Property TxnNoWait As Boolean
Visual C++
public:
property bool TxnNoWait {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


TxnSnapshot Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TxnSnapshot Property
DatabaseEnvironment Class See Also Send Feedback
If true, all transactions in the environment are started as if Snapshot was passed to BeginTransaction()()(), and all non-transactional cursors are opened as if SnapshotIsolation was passed to Cursor()()().

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TxnSnapshot { get; set; }
Visual Basic (Declaration)
Public Property TxnSnapshot As Boolean
Visual C++
public:
property bool TxnSnapshot {
    bool get ();
    void set (bool value);
}

See Also

DatabaseEnvironment Class


TxnTimeout Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TxnTimeout Property
DatabaseEnvironment Class See Also Send Feedback
A value, in microseconds, representing transaction timeouts.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TxnTimeout { get; set; }
Visual Basic (Declaration)
Public Property TxnTimeout As UInteger
Visual C++
public:
property unsigned int TxnTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

All timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. The accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values specified for the database environment may be overridden on a per-transaction basis, see SetTxnTimeout(UInt32).

See Also

DatabaseEnvironment Class


TxnTimestamp Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TxnTimestamp Property
DatabaseEnvironment Class See Also Send Feedback
The recovery timestamp

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DateTime TxnTimestamp { get; private set; }
Visual Basic (Declaration)
Public Property TxnTimestamp As DateTime
Visual C++
public:
property DateTime TxnTimestamp {
    DateTime get ();
    void set (DateTime value);
}

See Also

DatabaseEnvironment Class


TxnWriteNoSync Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.TxnWriteNoSync Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB writes, but does not synchronously flush, the log on transaction commit.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TxnWriteNoSync { get; set; }
Visual Basic (Declaration)
Public Property TxnWriteNoSync As Boolean
Visual C++
public:
property bool TxnWriteNoSync {
    bool get ();
    void set (bool value);
}

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); database integrity is maintained, but if the application or system fails, it is possible that some number of the most recently committed transactions may be undone during recovery. The number of transactions at risk is governed by how often the system flushes dirty buffers to disk and how often the log is checkpointed.

See Also

DatabaseEnvironment Class


UseEnvironmentVars Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.UseEnvironmentVars Property
DatabaseEnvironment Class See Also Send Feedback
The Berkeley DB process' environment may be permitted to specify information to be used when naming files; see Berkeley DB File Naming in the Programmer's Reference Guide for more information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseEnvironmentVars { get; }
Visual Basic (Declaration)
Public ReadOnly Property UseEnvironmentVars As Boolean
Visual C++
public:
property bool UseEnvironmentVars {
    bool get ();
}

See Also

DatabaseEnvironment Class


UseMVCC Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.UseMVCC Property
DatabaseEnvironment Class See Also Send Feedback
If true, all databases in the environment are opened as if UseMVCC was set.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseMVCC { get; set; }
Visual Basic (Declaration)
Public Property UseMVCC As Boolean
Visual C++
public:
property bool UseMVCC {
    bool get ();
    void set (bool value);
}

Remarks

This flag is ignored for queue databases for which MVCC is not supported.

See Also

DatabaseEnvironment Class


UsingCDB Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.UsingCDB Property
DatabaseEnvironment Class See Also Send Feedback
If true, locking for the Berkeley DB Concurrent Data Store product was initialized.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UsingCDB { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsingCDB As Boolean
Visual C++
public:
property bool UsingCDB {
    bool get ();
}

See Also

DatabaseEnvironment Class


UsingLocking Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.UsingLocking Property
DatabaseEnvironment Class See Also Send Feedback
If true, the locking subsystem was initialized.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UsingLocking { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsingLocking As Boolean
Visual C++
public:
property bool UsingLocking {
    bool get ();
}

See Also

DatabaseEnvironment Class


UsingLogging Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.UsingLogging Property
DatabaseEnvironment Class See Also Send Feedback
If true, the logging subsystem was initialized.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UsingLogging { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsingLogging As Boolean
Visual C++
public:
property bool UsingLogging {
    bool get ();
}

See Also

DatabaseEnvironment Class


UsingMPool Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.UsingMPool Property
DatabaseEnvironment Class See Also Send Feedback
If true, the shared memory buffer pool subsystem was initialized.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UsingMPool { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsingMPool As Boolean
Visual C++
public:
property bool UsingMPool {
    bool get ();
}

See Also

DatabaseEnvironment Class


UsingReplication Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.UsingReplication Property
DatabaseEnvironment Class See Also Send Feedback
If true, the replication subsystem was initialized.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UsingReplication { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsingReplication As Boolean
Visual C++
public:
property bool UsingReplication {
    bool get ();
}

See Also

DatabaseEnvironment Class


UsingTxns Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.UsingTxns Property
DatabaseEnvironment Class See Also Send Feedback
If true, the transaction subsystem was initialized.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UsingTxns { get; }
Visual Basic (Declaration)
Public ReadOnly Property UsingTxns As Boolean
Visual C++
public:
property bool UsingTxns {
    bool get ();
}

See Also

DatabaseEnvironment Class


Verbosity Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.Verbosity Property
DatabaseEnvironment Class See Also Send Feedback
Specific additional informational and debugging messages in the Berkeley DB message output.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public VerboseMessages Verbosity { get; set; }
Visual Basic (Declaration)
Public Property Verbosity As VerboseMessages
Visual C++
public:
property VerboseMessages^ Verbosity {
    VerboseMessages^ get ();
    void set (VerboseMessages^ value);
}

See Also

DatabaseEnvironment Class


YieldCPU Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironment..::.YieldCPU Property
DatabaseEnvironment Class See Also Send Feedback
If true, Berkeley DB yields the processor immediately after each page or mutex acquisition.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool YieldCPU { get; set; }
Visual Basic (Declaration)
Public Property YieldCPU As Boolean
Visual C++
public:
property bool YieldCPU {
    bool get ();
    void set (bool value);
}

Remarks

This functionality should never be used for purposes other than stress testing.

See Also

DatabaseEnvironment Class


DatabaseEnvironmentConfig Class

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig Class
Members See Also Send Feedback
A class representing configuration parameters for DatabaseEnvironment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DatabaseEnvironmentConfig
Visual Basic (Declaration)
Public Class DatabaseEnvironmentConfig
Visual C++
public ref class DatabaseEnvironmentConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseEnvironmentConfig

See Also

DatabaseEnvironmentConfig Members


DatabaseEnvironmentConfig Members

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig Members
DatabaseEnvironmentConfig Class Constructors Methods Fields Properties See Also Send Feedback

The DatabaseEnvironmentConfig type exposes the following members.

Constructors

Name | Description
DatabaseEnvironmentConfig | Create a new object with default settings

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | If true, database operations for which no explicit transaction handle was specified, and which modify databases in the database environment, are automatically enclosed within a transaction.
BlobDir | The path of the directory where blobs are stored.
CDB_ALLDB | If true, Berkeley DB Concurrent Data Store applications perform locking on an environment-wide basis rather than on a per-database basis.
Create | If true, Berkeley DB subsystems create any underlying files, as necessary.
CreationDir | The path of a directory to be used as the location to create the access method database files. When Open(String, BTreeDatabaseConfig), Open(String, HashDatabaseConfig), Open(String, QueueDatabaseConfig) or Open(String, RecnoDatabaseConfig) is used to create a file, it will be created relative to this path.
DataDirs | Paths of directories to be used as the location of the access method database files.
ErrorFeedback | The mechanism for reporting detailed error messages to the application.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
EventNotify | A delegate which is called to notify the process of specific Berkeley DB events.
Feedback | Monitor progress within long running operations.
ForceFlush | If true, Berkeley DB flushes database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.
FreeThreaded | If true, the created DatabaseEnvironment object is free-threaded; that is, concurrently usable by multiple threads in the address space.
HotbackupInProgress | Set a flag in the environment indicating that a hot backup is in progress.
InitRegions | If true, Berkeley DB page-faults shared regions into memory when initially creating or joining a Berkeley DB environment. In addition, Berkeley DB writes the shared regions when creating an environment, forcing the underlying virtual memory and filesystems to instantiate both the necessary memory and the necessary disk space. This can also avoid out-of-disk space failures later on.
IntermediateDirMode | The permissions for any intermediate directories created by Berkeley DB.
Lockdown | If true, lock shared Berkeley DB environment files and memory-mapped databases into memory.
LockSystemCfg | Configuration for the locking subsystem
LogSystemCfg | Configuration for the logging subsystem
MetadataDir | The path of a directory to be used as the location to store the persistent metadata.
MPoolSystemCfg | Configuration for the memory pool subsystem
MutexSystemCfg | Configuration for the mutex subsystem
NoBuffer | If true, turn off system buffering of Berkeley DB database files to avoid double caching.
NoLocking | If true, Berkeley DB grants all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.
NoMMap | If true, Berkeley DB copies read-only database files into the local cache instead of potentially mapping them into process memory (see MMapSize for further information).
NoPanic | If true, Berkeley DB ignores any panic state in the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException. This functionality should never be used for purposes other than debugging.
Overwrite | If true, overwrite files stored in encrypted formats before deleting them.
Private | If true, allocate region memory from the heap instead of from memory backed by the filesystem or system shared memory.
Register | If true, check to see if recovery needs to be performed before opening the database environment. (For this check to be accurate, all processes using the environment must specify it when opening the environment.)
RepSystemCfg | Configuration for the replication subsystem
RunFatalRecovery | If true, catastrophic recovery is run on this environment before opening it for normal use.
RunRecovery | If true, normal recovery is run on this environment before opening it for normal use.
SetThreadID | A delegate that returns a unique identifier pair for the current thread of control.
SystemMemory | If true, allocate region memory from system shared memory instead of from heap memory or memory backed by the filesystem.
TempDir | The path of a directory to be used as the location for temporary files.
ThreadIsAlive | A delegate that returns if a thread of control (either a true thread or a process) is still running.
ThreadName | A delegate that formats a process ID and thread ID identifier pair.
TimeNotGranted | If true, database calls timing out based on lock or transaction timeout values throw LockNotGrantedException instead of DeadlockException. This allows applications to distinguish between operations which have deadlocked and operations which have exceeded their time limits.
TxnNoSync | If true, Berkeley DB does not write or synchronously flush the log on transaction commit.
TxnNoWait | If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw DeadlockException (or LockNotGrantedException if TimeNotGranted is set.
TxnSnapshot | If true, all transactions in the environment are started as if Snapshot were passed to BeginTransaction()()(), and all non-transactional cursors are opened as if SnapshotIsolation were passed to Cursor()()().
TxnWriteNoSync | If true, Berkeley DB writes, but does not synchronously flush, the log on transaction commit.
UseCDB | If true, initialize locking for the Berkeley DB Concurrent Data Store product.
UseEnvironmentVars | If true, the Berkeley DB process' environment may be permitted to specify information to be used when naming files.
UseLocking | If true, initialize the locking subsystem.
UseLogging | If true, initialize the logging subsystem.
UseMPool | If true, initialize the shared memory buffer pool subsystem.
UseMVCC | If true, all databases in the environment are opened as if UseMVCC is passed to Open(String, DatabaseConfig). This flag is ignored for queue databases for which MVCC is not supported.
UseReplication | If true, initialize the replication subsystem.
UseTxns | If true, initialize the transaction subsystem.
Verbosity | Specific additional informational and debugging messages in the Berkeley DB message output.
YieldCPU | If true, Berkeley DB yields the processor immediately after each page or mutex acquisition. This functionality should never be used for purposes other than stress testing.

Properties

Name | Description
BlobThreshold | The size in bytes which is used to determine when a data item will be stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, databases opened in the environment default to never using blob support. It is illegal to enable blob support in the environment if any of TxnSnapshot, UseReplication, and UseMVCC is set to true.
EncryptAlgorithm | The algorithm used to perform encryption and decryption.
EncryptionPassword | The password used to perform encryption and decryption.
InitThreadCount | The initial number of concurrent threads catered for by the Berkeley DB environment
InitTxnCount | The initial number of transactions catered for by the Berkeley DB environment
LockTimeout | A value, in microseconds, representing lock timeouts.
MaxTransactions | The number of active transactions supported by the environment. This value bounds the size of the memory allocated for transactions. Child transactions are counted as active until they either commit or abort.
ThreadCount | An approximate number of threads in the database environment.
TxnTimeout | A value, in microseconds, representing transaction timeouts.
TxnTimestamp | Recover to the time specified by timestamp rather than to the most current possible date.

See Also

DatabaseEnvironmentConfig Class


DatabaseEnvironmentConfig Constructor

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig Constructor
DatabaseEnvironmentConfig Class See Also Send Feedback
Create a new object with default settings

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEnvironmentConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DatabaseEnvironmentConfig()

See Also

DatabaseEnvironmentConfig Class


DatabaseEnvironmentConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig Fields
DatabaseEnvironmentConfig Class See Also Send Feedback

The DatabaseEnvironmentConfig type exposes the following members.

Fields

Name | Description
AutoCommit | If true, database operations for which no explicit transaction handle was specified, and which modify databases in the database environment, are automatically enclosed within a transaction.
BlobDir | The path of the directory where blobs are stored.
CDB_ALLDB | If true, Berkeley DB Concurrent Data Store applications perform locking on an environment-wide basis rather than on a per-database basis.
Create | If true, Berkeley DB subsystems create any underlying files, as necessary.
CreationDir | The path of a directory to be used as the location to create the access method database files. When Open(String, BTreeDatabaseConfig), Open(String, HashDatabaseConfig), Open(String, QueueDatabaseConfig) or Open(String, RecnoDatabaseConfig) is used to create a file, it will be created relative to this path.
DataDirs | Paths of directories to be used as the location of the access method database files.
ErrorFeedback | The mechanism for reporting detailed error messages to the application.
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB.
EventNotify | A delegate which is called to notify the process of specific Berkeley DB events.
Feedback | Monitor progress within long running operations.
ForceFlush | If true, Berkeley DB flushes database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.
FreeThreaded | If true, the created DatabaseEnvironment object is free-threaded; that is, concurrently usable by multiple threads in the address space.
HotbackupInProgress | Set a flag in the environment indicating that a hot backup is in progress.
InitRegions | If true, Berkeley DB page-faults shared regions into memory when initially creating or joining a Berkeley DB environment. In addition, Berkeley DB writes the shared regions when creating an environment, forcing the underlying virtual memory and filesystems to instantiate both the necessary memory and the necessary disk space. This can also avoid out-of-disk space failures later on.
IntermediateDirMode | The permissions for any intermediate directories created by Berkeley DB.
Lockdown | If true, lock shared Berkeley DB environment files and memory-mapped databases into memory.
LockSystemCfg | Configuration for the locking subsystem
LogSystemCfg | Configuration for the logging subsystem
MetadataDir | The path of a directory to be used as the location to store the persistent metadata.
MPoolSystemCfg | Configuration for the memory pool subsystem
MutexSystemCfg | Configuration for the mutex subsystem
NoBuffer | If true, turn off system buffering of Berkeley DB database files to avoid double caching.
NoLocking | If true, Berkeley DB grants all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.
NoMMap | If true, Berkeley DB copies read-only database files into the local cache instead of potentially mapping them into process memory (see MMapSize for further information).
NoPanic | If true, Berkeley DB ignores any panic state in the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException. This functionality should never be used for purposes other than debugging.
Overwrite | If true, overwrite files stored in encrypted formats before deleting them.
Private | If true, allocate region memory from the heap instead of from memory backed by the filesystem or system shared memory.
Register | If true, check to see if recovery needs to be performed before opening the database environment. (For this check to be accurate, all processes using the environment must specify it when opening the environment.)
RepSystemCfg | Configuration for the replication subsystem
RunFatalRecovery | If true, catastrophic recovery is run on this environment before opening it for normal use.
RunRecovery | If true, normal recovery is run on this environment before opening it for normal use.
SetThreadID | A delegate that returns a unique identifier pair for the current thread of control.
SystemMemory | If true, allocate region memory from system shared memory instead of from heap memory or memory backed by the filesystem.
TempDir | The path of a directory to be used as the location for temporary files.
ThreadIsAlive | A delegate that returns if a thread of control (either a true thread or a process) is still running.
ThreadName | A delegate that formats a process ID and thread ID identifier pair.
TimeNotGranted | If true, database calls timing out based on lock or transaction timeout values throw LockNotGrantedException instead of DeadlockException. This allows applications to distinguish between operations which have deadlocked and operations which have exceeded their time limits.
TxnNoSync | If true, Berkeley DB does not write or synchronously flush the log on transaction commit.
TxnNoWait | If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw DeadlockException (or LockNotGrantedException if TimeNotGranted is set.
TxnSnapshot | If true, all transactions in the environment are started as if Snapshot were passed to BeginTransaction()()(), and all non-transactional cursors are opened as if SnapshotIsolation were passed to Cursor()()().
TxnWriteNoSync | If true, Berkeley DB writes, but does not synchronously flush, the log on transaction commit.
UseCDB | If true, initialize locking for the Berkeley DB Concurrent Data Store product.
UseEnvironmentVars | If true, the Berkeley DB process' environment may be permitted to specify information to be used when naming files.
UseLocking | If true, initialize the locking subsystem.
UseLogging | If true, initialize the logging subsystem.
UseMPool | If true, initialize the shared memory buffer pool subsystem.
UseMVCC | If true, all databases in the environment are opened as if UseMVCC is passed to Open(String, DatabaseConfig). This flag is ignored for queue databases for which MVCC is not supported.
UseReplication | If true, initialize the replication subsystem.
UseTxns | If true, initialize the transaction subsystem.
Verbosity | Specific additional informational and debugging messages in the Berkeley DB message output.
YieldCPU | If true, Berkeley DB yields the processor immediately after each page or mutex acquisition. This functionality should never be used for purposes other than stress testing.

See Also

DatabaseEnvironmentConfig Class


AutoCommit Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.AutoCommit Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, database operations for which no explicit transaction handle was specified, and which modify databases in the database environment, are automatically enclosed within a transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool AutoCommit
Visual Basic (Declaration)
Public AutoCommit As Boolean
Visual C++
public:
bool AutoCommit

See Also

DatabaseEnvironmentConfig Class


BlobDir Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.BlobDir Field
DatabaseEnvironmentConfig Class See Also Send Feedback
The path of the directory where blobs are stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BlobDir
Visual Basic (Declaration)
Public BlobDir As String
Visual C++
public:
String^ BlobDir

See Also

DatabaseEnvironmentConfig Class


CDB_ALLDB Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.CDB_ALLDB Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB Concurrent Data Store applications perform locking on an environment-wide basis rather than on a per-database basis.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool CDB_ALLDB
Visual Basic (Declaration)
Public CDB_ALLDB As Boolean
Visual C++
public:
bool CDB_ALLDB

See Also

DatabaseEnvironmentConfig Class


Create Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.Create Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB subsystems create any underlying files, as necessary.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Create
Visual Basic (Declaration)
Public Create As Boolean
Visual C++
public:
bool Create

See Also

DatabaseEnvironmentConfig Class


CreationDir Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.CreationDir Field
DatabaseEnvironmentConfig Class See Also Send Feedback
The path of a directory to be used as the location to create the access method database files. When Open(String, BTreeDatabaseConfig), Open(String, HashDatabaseConfig), Open(String, QueueDatabaseConfig) or Open(String, RecnoDatabaseConfig) is used to create a file, it will be created relative to this path.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string CreationDir
Visual Basic (Declaration)
Public CreationDir As String
Visual C++
public:
String^ CreationDir

Remarks

This path must also exist in DataDirs.

If no database directory is specified, database files must be named either by absolute paths or relative to the environment home directory. See Berkeley DB File Naming in the Programmer's Reference Guide for more information.

See Also

DatabaseEnvironmentConfig Class


DataDirs Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.DataDirs Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Paths of directories to be used as the location of the access method database files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public List<string> DataDirs
Visual Basic (Declaration)
Public DataDirs As List(Of String)
Visual C++
public:
List<String^>^ DataDirs

Remarks

Paths specified to Open(String, DatabaseConfig) are searched relative to this path. Paths set using this method are additive, and specifying more than one results in each specified directory being searched for database files.

If no database directories are specified, database files must be named either by absolute paths or relative to the environment home directory. See Berkeley DB File Naming in the Programmer's Reference Guide for more information.

See Also

DatabaseEnvironmentConfig Class


ErrorFeedback Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.ErrorFeedback Field
DatabaseEnvironmentConfig Class See Also Send Feedback
The mechanism for reporting detailed error messages to the application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ErrorFeedbackDelegate ErrorFeedback
Visual Basic (Declaration)
Public ErrorFeedback As ErrorFeedbackDelegate
Visual C++
public:
ErrorFeedbackDelegate^ ErrorFeedback

Remarks

When an error occurs in the Berkeley DB library, a DatabaseException, or subclass of DatabaseException, is thrown. In some cases the exception may be insufficient to completely describe the cause of the error, especially during initial application debugging.

In some cases, when an error occurs, Berkeley DB calls the given delegate with additional error information. It is up to the delegate to display the error message in an appropriate manner.

Setting ErrorFeedback to NULL unconfigures the callback interface.

This error-logging enhancement does not slow performance or significantly increase application size, and may be run during normal operation as well as during application debugging.

See Also

DatabaseEnvironmentConfig Class


ErrorPrefix Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.ErrorPrefix Field
DatabaseEnvironmentConfig Class See Also Send Feedback
The prefix string that appears before error messages issued by Berkeley DB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string ErrorPrefix
Visual Basic (Declaration)
Public ErrorPrefix As String
Visual C++
public:
String^ ErrorPrefix

Remarks

For databases opened inside of a DatabaseEnvironment, setting ErrorPrefix affects the entire environment and is equivalent to setting ErrorPrefix.

See Also

DatabaseEnvironmentConfig Class


EventNotify Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.EventNotify Field
DatabaseEnvironmentConfig Class See Also Send Feedback
A delegate which is called to notify the process of specific Berkeley DB events.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EventNotifyDelegate EventNotify
Visual Basic (Declaration)
Public EventNotify As EventNotifyDelegate
Visual C++
public:
EventNotifyDelegate^ EventNotify

See Also

DatabaseEnvironmentConfig Class


Feedback Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.Feedback Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Monitor progress within long running operations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EnvironmentFeedbackDelegate Feedback
Visual Basic (Declaration)
Public Feedback As EnvironmentFeedbackDelegate
Visual C++
public:
EnvironmentFeedbackDelegate^ Feedback

Remarks

Some operations performed by the Berkeley DB library can take non-trivial amounts of time. The Feedback delegate can be used by applications to monitor progress within these operations. When an operation is likely to take a long time, Berkeley DB will call the specified delegate with progress information.

It is up to the delegate to display this information in an appropriate manner.

See Also

DatabaseEnvironmentConfig Class


ForceFlush Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.ForceFlush Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB flushes database writes to the backing disk before returning from the write system call, rather than flushing database writes explicitly in a separate system call, as necessary.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ForceFlush
Visual Basic (Declaration)
Public ForceFlush As Boolean
Visual C++
public:
bool ForceFlush

Remarks

This is only available on some systems (for example, systems supporting the IEEE/ANSI Std 1003.1 (POSIX) standard O_DSYNC flag, or systems supporting the Windows FILE_FLAG_WRITE_THROUGH flag). This flag may result in inaccurate file modification times and other file-level information for Berkeley DB database files. This flag almost certainly results in a performance decrease on most systems. This flag is only applicable to certain filesystems (for example, the Veritas VxFS filesystem), where the filesystem's support for trickling writes back to stable storage behaves badly (or more likely, has been misconfigured).

See Also

DatabaseEnvironmentConfig Class


FreeThreaded Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.FreeThreaded Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, the created DatabaseEnvironment object is free-threaded; that is, concurrently usable by multiple threads in the address space.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool FreeThreaded
Visual Basic (Declaration)
Public FreeThreaded As Boolean
Visual C++
public:
bool FreeThreaded

Remarks

Required to be true if the created DatabaseEnvironment object is concurrently used by more than one thread in the process, or if any Database objects opened in the scope of the DatabaseEnvironment object is concurrently used by more than one thread in the process.

Required to be true when using the Replication Manager.

See Also

DatabaseEnvironmentConfig Class


HotbackupInProgress Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.HotbackupInProgress Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Set a flag in the environment indicating that a hot backup is in progress.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool HotbackupInProgress
Visual Basic (Declaration)
Public HotbackupInProgress As Boolean
Visual C++
public:
bool HotbackupInProgress

Remarks

When a "hot backup" copy of a database environment is taken, this attribute should be configured in the environment prior to copying. If any transactions with the bulk insert optimization enabled (i.e., started with the Bulk configuration attribute) are in progress, setting the HotBackupInProgress attribute forces a checkpoint in the environment. After this attribute is set, the bulk insert optimization is disabled, until the attribute is reset. Using this protocol allows a hot backup procedure to make a consistent copy of the database even when bulk transactions are ongoing. For more information about hot backups see the Getting Started With Transactions Guide. To learn more about the Bulk attribute see Bulk.

See Also

DatabaseEnvironmentConfig Class


InitRegions Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.InitRegions Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB page-faults shared regions into memory when initially creating or joining a Berkeley DB environment. In addition, Berkeley DB writes the shared regions when creating an environment, forcing the underlying virtual memory and filesystems to instantiate both the necessary memory and the necessary disk space. This can also avoid out-of-disk space failures later on.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool InitRegions
Visual Basic (Declaration)
Public InitRegions As Boolean
Visual C++
public:
bool InitRegions

Remarks

In some applications, the expense of page-faulting the underlying shared memory regions can affect performance. (For example, if the page-fault occurs while holding a lock, other lock requests can convoy, and overall throughput may decrease.)

See Also

DatabaseEnvironmentConfig Class


IntermediateDirMode Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.IntermediateDirMode Field
DatabaseEnvironmentConfig Class See Also Send Feedback
The permissions for any intermediate directories created by Berkeley DB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string IntermediateDirMode
Visual Basic (Declaration)
Public IntermediateDirMode As String
Visual C++
public:
String^ IntermediateDirMode

Remarks

By default, Berkeley DB does not create intermediate directories needed for recovery. For example, if the file /a/b/c/mydatabase is being recovered, and the directory path b/c does not exist, recovery fails. This occurs because Berkeley DB does not know what permissions are appropriate for intermediate directory creation, and creating the directory might result in a security problem.

Directory permissions are interpreted as a string of nine characters, using the character set r (read), w (write), x (execute or search), and - (none). The first character is the read permissions for the directory owner (set to either r or -). The second character is the write permissions for the directory owner (set to either w or -). The third character is the execute permissions for the directory owner (set to either x or -).

Similarly, the second set of three characters are the read, write and execute/search permissions for the directory group, and the third set of three characters are the read, write and execute/search permissions for all others. For example, the string rwx------ would configure read, write and execute/search access for the owner only. The string rwxrwx--- would configure read, write and execute/search access for both the owner and the group. The string rwxr----- would configure read, write and execute/search access for the directory owner and read-only access for the directory group.

See Also

DatabaseEnvironmentConfig Class


Lockdown Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.Lockdown Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, lock shared Berkeley DB environment files and memory-mapped databases into memory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Lockdown
Visual Basic (Declaration)
Public Lockdown As Boolean
Visual C++
public:
bool Lockdown

See Also

DatabaseEnvironmentConfig Class


LockSystemCfg Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.LockSystemCfg Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Configuration for the locking subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LockingConfig LockSystemCfg
Visual Basic (Declaration)
Public LockSystemCfg As LockingConfig
Visual C++
public:
LockingConfig^ LockSystemCfg

See Also

DatabaseEnvironmentConfig Class


LogSystemCfg Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.LogSystemCfg Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Configuration for the logging subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LogConfig LogSystemCfg
Visual Basic (Declaration)
Public LogSystemCfg As LogConfig
Visual C++
public:
LogConfig^ LogSystemCfg

See Also

DatabaseEnvironmentConfig Class


MetadataDir Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.MetadataDir Field
DatabaseEnvironmentConfig Class See Also Send Feedback
The path of a directory to be used as the location to store the persistent metadata.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string MetadataDir
Visual Basic (Declaration)
Public MetadataDir As String
Visual C++
public:
String^ MetadataDir

Remarks

By default, metadata is stored in the environment home directory. See Berkeley DB File Naming in the Programmer's Reference Guide for more information.

When used in a replicated application, the metadata directory must be the same location for all sites within a replication group.

See Also

DatabaseEnvironmentConfig Class


MPoolSystemCfg Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.MPoolSystemCfg Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Configuration for the memory pool subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MPoolConfig MPoolSystemCfg
Visual Basic (Declaration)
Public MPoolSystemCfg As MPoolConfig
Visual C++
public:
MPoolConfig^ MPoolSystemCfg

See Also

DatabaseEnvironmentConfig Class


MutexSystemCfg Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.MutexSystemCfg Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Configuration for the mutex subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MutexConfig MutexSystemCfg
Visual Basic (Declaration)
Public MutexSystemCfg As MutexConfig
Visual C++
public:
MutexConfig^ MutexSystemCfg

See Also

DatabaseEnvironmentConfig Class


NoBuffer Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.NoBuffer Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, turn off system buffering of Berkeley DB database files to avoid double caching.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoBuffer
Visual Basic (Declaration)
Public NoBuffer As Boolean
Visual C++
public:
bool NoBuffer

See Also

DatabaseEnvironmentConfig Class


NoLocking Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.NoLocking Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB grants all requested mutual exclusion mutexes and database locks without regard for their actual availability. This functionality should never be used for purposes other than debugging.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoLocking
Visual Basic (Declaration)
Public NoLocking As Boolean
Visual C++
public:
bool NoLocking

See Also

DatabaseEnvironmentConfig Class


NoMMap Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.NoMMap Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB copies read-only database files into the local cache instead of potentially mapping them into process memory (see MMapSize for further information).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoMMap
Visual Basic (Declaration)
Public NoMMap As Boolean
Visual C++
public:
bool NoMMap

See Also

DatabaseEnvironmentConfig Class


NoPanic Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.NoPanic Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB ignores any panic state in the database environment. (Database environments in a panic state normally refuse all attempts to call Berkeley DB functions, throwing RunRecoveryException. This functionality should never be used for purposes other than debugging.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoPanic
Visual Basic (Declaration)
Public NoPanic As Boolean
Visual C++
public:
bool NoPanic

See Also

DatabaseEnvironmentConfig Class


Overwrite Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.Overwrite Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, overwrite files stored in encrypted formats before deleting them.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Overwrite
Visual Basic (Declaration)
Public Overwrite As Boolean
Visual C++
public:
bool Overwrite

Remarks

Berkeley DB overwrites files using alternating 0xff, 0x00 and 0xff byte patterns. For an effective overwrite, the underlying file must be stored on a fixed-block filesystem. Systems with journaling or logging filesystems require operating system support and probably modification of the Berkeley DB sources.

See Also

DatabaseEnvironmentConfig Class


Private Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.Private Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, allocate region memory from the heap instead of from memory backed by the filesystem or system shared memory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Private
Visual Basic (Declaration)
Public Private As Boolean
Visual C++
public:
bool Private

Remarks

This setting implies the environment is only accessed by a single process (although that process may be multithreaded). This flag has two effects on the Berkeley DB environment. First, all underlying data structures are allocated from per-process memory instead of from shared memory that is accessible to more than a single process. Second, mutexes are only configured to work between threads.

This setting should be false if more than a single process is accessing the environment because it is likely to cause database corruption and unpredictable behavior. For example, if both a server application and Berkeley DB utilities (for example, db_archive, db_checkpoint or db_stat) are expected to access the environment, this setting should be false.

See Also

DatabaseEnvironmentConfig Class


Register Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.Register Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, check to see if recovery needs to be performed before opening the database environment. (For this check to be accurate, all processes using the environment must specify it when opening the environment.)

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Register
Visual Basic (Declaration)
Public Register As Boolean
Visual C++
public:
bool Register

Remarks

If recovery needs to be performed for any reason (including the initial use of this setting), and RunRecoveryis also specified, recovery is performed and the open proceeds normally. If recovery needs to be performed and RunRecovery is not specified, RunRecoveryException is thrown. If recovery does not need to be performed, RunRecovery is ignored. See Architecting Transactional Data Store applications in the Programmer's Reference Guide for more information.

See Also

DatabaseEnvironmentConfig Class


RepSystemCfg Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.RepSystemCfg Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Configuration for the replication subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationConfig RepSystemCfg
Visual Basic (Declaration)
Public RepSystemCfg As ReplicationConfig
Visual C++
public:
ReplicationConfig^ RepSystemCfg

See Also

DatabaseEnvironmentConfig Class


RunFatalRecovery Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.RunFatalRecovery Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, catastrophic recovery is run on this environment before opening it for normal use.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RunFatalRecovery
Visual Basic (Declaration)
Public RunFatalRecovery As Boolean
Visual C++
public:
bool RunFatalRecovery

Remarks

If true, the Create and UseTxns must also be set, because the regions are going to be removed and re-created, and transactions are required for application recovery.

See Also

DatabaseEnvironmentConfig Class


RunRecovery Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.RunRecovery Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, normal recovery is run on this environment before opening it for normal use.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RunRecovery
Visual Basic (Declaration)
Public RunRecovery As Boolean
Visual C++
public:
bool RunRecovery

Remarks

If true, the Create and UseTxns must also be set, because the regions are going to be removed and re-created, and transactions are required for application recovery.

See Also

DatabaseEnvironmentConfig Class


SetThreadID Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.SetThreadID Field
DatabaseEnvironmentConfig Class See Also Send Feedback
A delegate that returns a unique identifier pair for the current thread of control.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SetThreadIDDelegate SetThreadID
Visual Basic (Declaration)
Public SetThreadID As SetThreadIDDelegate
Visual C++
public:
SetThreadIDDelegate^ SetThreadID

Remarks

This delegate supports FailCheck()()(). For more information, see Architecting Data Store and Concurrent Data Store applications, and Architecting Transactional Data Store applications, both in the Berkeley DB Programmer's Reference Guide.

See Also

DatabaseEnvironmentConfig Class


SystemMemory Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.SystemMemory Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, allocate region memory from system shared memory instead of from heap memory or memory backed by the filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SystemMemory
Visual Basic (Declaration)
Public SystemMemory As Boolean
Visual C++
public:
bool SystemMemory

Remarks

See Shared Memory Regions in the Programmer's Reference Guide for more information.

See Also

DatabaseEnvironmentConfig Class


TempDir Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.TempDir Field
DatabaseEnvironmentConfig Class See Also Send Feedback
The path of a directory to be used as the location for temporary files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string TempDir
Visual Basic (Declaration)
Public TempDir As String
Visual C++
public:
String^ TempDir

Remarks

The files created to back in-memory access method databases are created relative to this path. These temporary files can be quite large, depending on the size of the database.

If no directories are specified, the following alternatives are checked in the specified order. The first existing directory path is used for all temporary files.

  1. The value of the environment variable TMPDIR.
  2. The value of the environment variable TEMP.
  3. The value of the environment variable TMP.
  4. The value of the environment variable TempFolder.
  5. The value returned by the GetTempPath interface.
  6. The directory /var/tmp.
  7. The directory /usr/tmp.
  8. The directory /temp.
  9. The directory /tmp.
  10. The directory C:/temp.
  11. The directory C:/tmp.

Environment variables are only checked if UseEnvironmentVars is true.

See Also

DatabaseEnvironmentConfig Class


ThreadIsAlive Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.ThreadIsAlive Field
DatabaseEnvironmentConfig Class See Also Send Feedback
A delegate that returns if a thread of control (either a true thread or a process) is still running.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ThreadIsAliveDelegate ThreadIsAlive
Visual Basic (Declaration)
Public ThreadIsAlive As ThreadIsAliveDelegate
Visual C++
public:
ThreadIsAliveDelegate^ ThreadIsAlive

See Also

DatabaseEnvironmentConfig Class


ThreadName Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.ThreadName Field
DatabaseEnvironmentConfig Class See Also Send Feedback
A delegate that formats a process ID and thread ID identifier pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SetThreadNameDelegate ThreadName
Visual Basic (Declaration)
Public ThreadName As SetThreadNameDelegate
Visual C++
public:
SetThreadNameDelegate^ ThreadName

See Also

DatabaseEnvironmentConfig Class


TimeNotGranted Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.TimeNotGranted Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, database calls timing out based on lock or transaction timeout values throw LockNotGrantedException instead of DeadlockException. This allows applications to distinguish between operations which have deadlocked and operations which have exceeded their time limits.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TimeNotGranted
Visual Basic (Declaration)
Public TimeNotGranted As Boolean
Visual C++
public:
bool TimeNotGranted

See Also

DatabaseEnvironmentConfig Class


TxnNoSync Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.TxnNoSync Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB does not write or synchronously flush the log on transaction commit.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TxnNoSync
Visual Basic (Declaration)
Public TxnNoSync As Boolean
Visual C++
public:
bool TxnNoSync

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); database integrity is maintained, but if the application or system fails, it is possible that some number of the most recently committed transactions may be undone during recovery. The number of transactions at risk is governed by how many log updates can fit into the log buffer, how often the operating system flushes dirty buffers to disk, and how often the log is checkpointed.

See Also

DatabaseEnvironmentConfig Class


TxnNoWait Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.TxnNoWait Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw DeadlockException (or LockNotGrantedException if TimeNotGranted is set.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TxnNoWait
Visual Basic (Declaration)
Public TxnNoWait As Boolean
Visual C++
public:
bool TxnNoWait

See Also

DatabaseEnvironmentConfig Class


TxnSnapshot Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.TxnSnapshot Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, all transactions in the environment are started as if Snapshot were passed to BeginTransaction()()(), and all non-transactional cursors are opened as if SnapshotIsolation were passed to Cursor()()().

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TxnSnapshot
Visual Basic (Declaration)
Public TxnSnapshot As Boolean
Visual C++
public:
bool TxnSnapshot

See Also

DatabaseEnvironmentConfig Class


TxnWriteNoSync Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.TxnWriteNoSync Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB writes, but does not synchronously flush, the log on transaction commit.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool TxnWriteNoSync
Visual Basic (Declaration)
Public TxnWriteNoSync As Boolean
Visual C++
public:
bool TxnWriteNoSync

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); database integrity is maintained, but if the system fails, it is possible that some number of the most recently committed transactions may be undone during recovery. The number of transactions at risk is governed by how often the system flushes dirty buffers to disk and how often the log is checkpointed.

See Also

DatabaseEnvironmentConfig Class


UseCDB Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.UseCDB Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, initialize locking for the Berkeley DB Concurrent Data Store product.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseCDB
Visual Basic (Declaration)
Public UseCDB As Boolean
Visual C++
public:
bool UseCDB

Remarks

In this mode, Berkeley DB provides multiple reader/single writer access. The only other subsystem that should be specified with UseCDB flag is UseMPool.

See Also

DatabaseEnvironmentConfig Class


UseEnvironmentVars Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.UseEnvironmentVars Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, the Berkeley DB process' environment may be permitted to specify information to be used when naming files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseEnvironmentVars
Visual Basic (Declaration)
Public UseEnvironmentVars As Boolean
Visual C++
public:
bool UseEnvironmentVars

Remarks

See Berkeley DB File Naming in the Programmer's Reference Guide for more information.

Because permitting users to specify which files are used can create security problems, environment information is used in file naming for all users only if UseEnvironmentVars is true.

See Also

DatabaseEnvironmentConfig Class


UseLocking Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.UseLocking Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, initialize the locking subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseLocking
Visual Basic (Declaration)
Public UseLocking As Boolean
Visual C++
public:
bool UseLocking

Remarks

This subsystem should be used when multiple processes or threads are going to be reading and writing a Berkeley DB database, so that they do not interfere with each other. If all threads are accessing the database(s) read-only, locking is unnecessary. When UseLocking is specified, it is usually necessary to run a deadlock detector, as well. See DetectDeadlocks(DeadlockPolicy) for more information.

See Also

DatabaseEnvironmentConfig Class


UseLogging Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.UseLogging Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, initialize the logging subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseLogging
Visual Basic (Declaration)
Public UseLogging As Boolean
Visual C++
public:
bool UseLogging

Remarks

This subsystem should be used when recovery from application or system failure is necessary. If the log region is being created and log files are already present, the log files are reviewed; subsequent log writes are appended to the end of the log, rather than overwriting current log entries.

See Also

DatabaseEnvironmentConfig Class


UseMPool Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.UseMPool Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, initialize the shared memory buffer pool subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseMPool
Visual Basic (Declaration)
Public UseMPool As Boolean
Visual C++
public:
bool UseMPool

Remarks

This subsystem should be used whenever an application is using any Berkeley DB access method.

See Also

DatabaseEnvironmentConfig Class


UseMVCC Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.UseMVCC Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, all databases in the environment are opened as if UseMVCC is passed to Open(String, DatabaseConfig). This flag is ignored for queue databases for which MVCC is not supported.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseMVCC
Visual Basic (Declaration)
Public UseMVCC As Boolean
Visual C++
public:
bool UseMVCC

See Also

DatabaseEnvironmentConfig Class


UseReplication Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.UseReplication Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, initialize the replication subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseReplication
Visual Basic (Declaration)
Public UseReplication As Boolean
Visual C++
public:
bool UseReplication

Remarks

This subsystem should be used whenever an application plans on using replication. UseReplication requires UseTxns and UseLocking also be set.

See Also

DatabaseEnvironmentConfig Class


UseTxns Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.UseTxns Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, initialize the transaction subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseTxns
Visual Basic (Declaration)
Public UseTxns As Boolean
Visual C++
public:
bool UseTxns

Remarks

This subsystem should be used when recovery and atomicity of multiple operations are important. UseTxns implies UseLogging.

See Also

DatabaseEnvironmentConfig Class


Verbosity Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.Verbosity Field
DatabaseEnvironmentConfig Class See Also Send Feedback
Specific additional informational and debugging messages in the Berkeley DB message output.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public VerboseMessages Verbosity
Visual Basic (Declaration)
Public Verbosity As VerboseMessages
Visual C++
public:
VerboseMessages^ Verbosity

See Also

DatabaseEnvironmentConfig Class


YieldCPU Field

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.YieldCPU Field
DatabaseEnvironmentConfig Class See Also Send Feedback
If true, Berkeley DB yields the processor immediately after each page or mutex acquisition. This functionality should never be used for purposes other than stress testing.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool YieldCPU
Visual Basic (Declaration)
Public YieldCPU As Boolean
Visual C++
public:
bool YieldCPU

See Also

DatabaseEnvironmentConfig Class


DatabaseEnvironmentConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig Methods
DatabaseEnvironmentConfig Class See Also Send Feedback

The DatabaseEnvironmentConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DatabaseEnvironmentConfig Class


SetEncryption Method

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.SetEncryption Method
DatabaseEnvironmentConfig Class See Also Send Feedback
Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetEncryption(
    string password,
    EncryptionAlgorithm alg
)
Visual Basic (Declaration)
Public Sub SetEncryption ( _
    password As String, _
    alg As EncryptionAlgorithm _
)
Visual C++
public:
void SetEncryption(
    String^ password,
    EncryptionAlgorithm alg
)

Parameters

password
Type: System..::.String
The password used to perform encryption and decryption.
alg
Type: BerkeleyDB..::.EncryptionAlgorithm
The algorithm used to perform encryption and decryption.

See Also

DatabaseEnvironmentConfig Class


DatabaseEnvironmentConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig Properties
DatabaseEnvironmentConfig Class See Also Send Feedback

The DatabaseEnvironmentConfig type exposes the following members.

Properties

Name | Description
BlobThreshold | The size in bytes which is used to determine when a data item will be stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, databases opened in the environment default to never using blob support. It is illegal to enable blob support in the environment if any of TxnSnapshot, UseReplication, and UseMVCC is set to true.
EncryptAlgorithm | The algorithm used to perform encryption and decryption.
EncryptionPassword | The password used to perform encryption and decryption.
InitThreadCount | The initial number of concurrent threads catered for by the Berkeley DB environment
InitTxnCount | The initial number of transactions catered for by the Berkeley DB environment
LockTimeout | A value, in microseconds, representing lock timeouts.
MaxTransactions | The number of active transactions supported by the environment. This value bounds the size of the memory allocated for transactions. Child transactions are counted as active until they either commit or abort.
ThreadCount | An approximate number of threads in the database environment.
TxnTimeout | A value, in microseconds, representing transaction timeouts.
TxnTimestamp | Recover to the time specified by timestamp rather than to the most current possible date.

See Also

DatabaseEnvironmentConfig Class


BlobThreshold Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.BlobThreshold Property
DatabaseEnvironmentConfig Class See Also Send Feedback
The size in bytes which is used to determine when a data item will be stored as a blob.

Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob.

If the threshold value is 0, databases opened in the environment default to never using blob support.

It is illegal to enable blob support in the environment if any of TxnSnapshot, UseReplication, and UseMVCC is set to true.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BlobThreshold { get; set; }
Visual Basic (Declaration)
Public Property BlobThreshold As UInteger
Visual C++
public:
property unsigned int BlobThreshold {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

DatabaseEnvironmentConfig Class


EncryptAlgorithm Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.EncryptAlgorithm Property
DatabaseEnvironmentConfig Class See Also Send Feedback
The algorithm used to perform encryption and decryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EncryptionAlgorithm EncryptAlgorithm { get; }
Visual Basic (Declaration)
Public ReadOnly Property EncryptAlgorithm As EncryptionAlgorithm
Visual C++
public:
property EncryptionAlgorithm EncryptAlgorithm {
    EncryptionAlgorithm get ();
}

See Also

DatabaseEnvironmentConfig Class


EncryptionPassword Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.EncryptionPassword Property
DatabaseEnvironmentConfig Class See Also Send Feedback
The password used to perform encryption and decryption.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string EncryptionPassword { get; }
Visual Basic (Declaration)
Public ReadOnly Property EncryptionPassword As String
Visual C++
public:
property String^ EncryptionPassword {
    String^ get ();
}

See Also

DatabaseEnvironmentConfig Class


InitThreadCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.InitThreadCount Property
DatabaseEnvironmentConfig Class See Also Send Feedback
The initial number of concurrent threads catered for by the Berkeley DB environment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitThreadCount { get; set; }
Visual Basic (Declaration)
Public Property InitThreadCount As UInteger
Visual C++
public:
property unsigned int InitThreadCount {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to force Berkeley DB to allocate a certain number of thread objects when the environment is created. This can be useful if an application uses a large number of thread objects, and experiences performance issues with the default dynamic allocation algorithm.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of InitLockers is ignored.

See Also

DatabaseEnvironmentConfig Class


InitTxnCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.InitTxnCount Property
DatabaseEnvironmentConfig Class See Also Send Feedback
The initial number of transactions catered for by the Berkeley DB environment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitTxnCount { get; set; }
Visual Basic (Declaration)
Public Property InitTxnCount As UInteger
Visual C++
public:
property unsigned int InitTxnCount {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to force Berkeley DB to allocate a certain number of transaction objects when the environment is created. This can be useful if an application uses a large number of transaction objects, and experiences performance issues with the default dynamic allocation algorithm.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of InitLockers is ignored.

See Also

DatabaseEnvironmentConfig Class


LockTimeout Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.LockTimeout Property
DatabaseEnvironmentConfig Class See Also Send Feedback
A value, in microseconds, representing lock timeouts.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LockTimeout { get; set; }
Visual Basic (Declaration)
Public Property LockTimeout As UInteger
Visual C++
public:
property unsigned int LockTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

All timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values specified for the database environment may be overridden on a per-transaction basis, see SetLockTimeout(UInt32).

See Also

DatabaseEnvironmentConfig Class


MaxTransactions Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.MaxTransactions Property
DatabaseEnvironmentConfig Class See Also Send Feedback
The number of active transactions supported by the environment. This value bounds the size of the memory allocated for transactions. Child transactions are counted as active until they either commit or abort.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxTransactions { get; set; }
Visual Basic (Declaration)
Public Property MaxTransactions As UInteger
Visual C++
public:
property unsigned int MaxTransactions {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Transactions that update multiversion databases are not freed until the last page version that the transaction created is flushed from cache. This means that applications using multi-version concurrency control may need in the extreme case a transaction for each page in cache.

When all of the memory available in the database environment for transactions is in use, calls to BeginTransaction()()() fail (until some active transactions complete). If MaxTransactions is never set, the database environment is configured to support at least 100 active transactions.

See Also

DatabaseEnvironmentConfig Class


ThreadCount Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.ThreadCount Property
DatabaseEnvironmentConfig Class See Also Send Feedback
An approximate number of threads in the database environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ThreadCount { get; set; }
Visual Basic (Declaration)
Public Property ThreadCount As UInteger
Visual C++
public:
property unsigned int ThreadCount {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

ThreadCount must set if FailCheck()()() is used. ThreadCount does not set the maximum number of threads. It is used to determine memory sizing and the thread control block reclamation policy.

If a process has not configured ThreadIsAlive, and then attempts to join a database environment configured for failure checking with FailCheck()()(), SetThreadID, ThreadIsAlive and ThreadCount, the program may be unable to allocate a thread control block and fail to join the environment. This is true of the standalone Berkeley DB utility programs. To avoid problems when using the standalone Berkeley DB utility programs with environments configured for failure checking, incorporate the utility's functionality directly in the application, or call FailCheck()()() before running the utility.

See Also

DatabaseEnvironmentConfig Class


TxnTimeout Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.TxnTimeout Property
DatabaseEnvironmentConfig Class See Also Send Feedback
A value, in microseconds, representing transaction timeouts.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TxnTimeout { get; set; }
Visual Basic (Declaration)
Public Property TxnTimeout As UInteger
Visual C++
public:
property unsigned int TxnTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

All timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values specified for the database environment may be overridden on a per-transaction basis, see SetTxnTimeout(UInt32).

See Also

DatabaseEnvironmentConfig Class


TxnTimestamp Property

[image]

Berkeley DB .NET API Documentation
DatabaseEnvironmentConfig..::.TxnTimestamp Property
DatabaseEnvironmentConfig Class See Also Send Feedback
Recover to the time specified by timestamp rather than to the most current possible date.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DateTime TxnTimestamp { get; set; }
Visual Basic (Declaration)
Public Property TxnTimestamp As DateTime
Visual C++
public:
property DateTime TxnTimestamp {
    DateTime get ();
    void set (DateTime value);
}

Remarks

Once a database environment has been upgraded to a new version of Berkeley DB involving a log format change (see Upgrading Berkeley DB installations in the Programmer's Reference Guide), it is no longer possible to recover to a specific time before that upgrade.

See Also

DatabaseEnvironmentConfig Class


DatabaseException Class

[image]

Berkeley DB .NET API Documentation
DatabaseException Class
Members See Also Send Feedback
Represents errors that occur during Berkley DB operations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DatabaseException : Exception
Visual Basic (Declaration)
Public Class DatabaseException _
    Inherits Exception
Visual C++
public ref class DatabaseException : public Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.BadSecondaryException
BerkeleyDB..::.DeadlockException
BerkeleyDB..::.ForeignConflictException
BerkeleyDB..::.FullLogBufferException
BerkeleyDB..::.HeapFullException
BerkeleyDB..::.KeyEmptyException
BerkeleyDB..::.KeyExistException
BerkeleyDB..::.LeaseExpiredException
BerkeleyDB..::.LockNotGrantedException
BerkeleyDB..::.MetaCheckSumFailException
BerkeleyDB..::.NotFoundException
BerkeleyDB..::.OldVersionException
BerkeleyDB..::.PageNotFoundException
BerkeleyDB..::.RunRecoveryException
BerkeleyDB..::.VerificationException
BerkeleyDB..::.VersionMismatchException

See Also

DatabaseException Members


DatabaseException Members

[image] [image]

Berkeley DB .NET API Documentation
DatabaseException Members
DatabaseException Class Constructors Methods Fields Properties See Also Send Feedback

The DatabaseException type exposes the following members.

Constructors

Name | Description
DatabaseException | Create a new DatabaseException, encapsulating a specific error code.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ThrowException | Throw an exception which corresponds to the specified Berkeley DB error code.
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DatabaseException Class


DatabaseException Constructor

[image]

Berkeley DB .NET API Documentation
DatabaseException Constructor
DatabaseException Class See Also Send Feedback
Create a new DatabaseException, encapsulating a specific error code.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseException(
    int err
)
Visual Basic (Declaration)
Public Sub New ( _
    err As Integer _
)
Visual C++
public:
DatabaseException(
    int err
)

Parameters

err
Type: System..::.Int32
The error code to encapsulate.

See Also

DatabaseException Class


DatabaseException Fields

[image] [image]

Berkeley DB .NET API Documentation
DatabaseException Fields
DatabaseException Class See Also Send Feedback

The DatabaseException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library.

See Also

DatabaseException Class


ErrorCode Field

[image]

Berkeley DB .NET API Documentation
DatabaseException..::.ErrorCode Field
DatabaseException Class See Also Send Feedback
The underlying error code from the Berkeley DB C library.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int ErrorCode
Visual Basic (Declaration)
Public ErrorCode As Integer
Visual C++
public:
int ErrorCode

See Also

DatabaseException Class


DatabaseException Methods

[image] [image]

Berkeley DB .NET API Documentation
DatabaseException Methods
DatabaseException Class See Also Send Feedback

The DatabaseException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ThrowException | Throw an exception which corresponds to the specified Berkeley DB error code.
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DatabaseException Class


ThrowException Method

[image]

Berkeley DB .NET API Documentation
DatabaseException..::.ThrowException Method
DatabaseException Class See Also Send Feedback
Throw an exception which corresponds to the specified Berkeley DB error code.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static void ThrowException(
    int err
)
Visual Basic (Declaration)
Public Shared Sub ThrowException ( _
    err As Integer _
)
Visual C++
public:
static void ThrowException(
    int err
)

Parameters

err
Type: System..::.Int32
The Berkeley DB error code

See Also

DatabaseException Class


DatabaseException Properties

[image] [image]

Berkeley DB .NET API Documentation
DatabaseException Properties
DatabaseException Class See Also Send Feedback

The DatabaseException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DatabaseException Class


DatabaseFeedbackDelegate Delegate

[image]

Berkeley DB .NET API Documentation
DatabaseFeedbackDelegate Delegate
See Also Send Feedback
The application-specified feedback function called to report the operation progress of Berkeley DB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate void DatabaseFeedbackDelegate(
    DatabaseFeedbackEvent opcode,
    int percent
)
Visual Basic (Declaration)
Public Delegate Sub DatabaseFeedbackDelegate ( _
    opcode As DatabaseFeedbackEvent, _
    percent As Integer _
)
Visual C++
public delegate void DatabaseFeedbackDelegate(
    DatabaseFeedbackEvent opcode,
    int percent
)

Parameters

opcode
Type: BerkeleyDB..::.DatabaseFeedbackEvent
An operation code specifying the Berkley DB operation
percent
Type: System..::.Int32
The percent of the operation that has been completed, specified as an integer value between 0 and 100.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


DatabaseFeedbackEvent Enumeration

[image]

Berkeley DB .NET API Documentation
DatabaseFeedbackEvent Enumeration
See Also Send Feedback
Specifies the database operation whose progress is being reported

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum DatabaseFeedbackEvent
Visual Basic (Declaration)
Public Enumeration DatabaseFeedbackEvent
Visual C++
public enum class DatabaseFeedbackEvent

Members

Member name | Description
UPGRADE | The underlying database is being upgraded.
VERIFY | The underlying database is being verified.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


DatabaseStream Class

[image]

Berkeley DB .NET API Documentation
DatabaseStream Class
Members See Also Send Feedback
A class representing a database stream, which allows streaming access to blobs.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DatabaseStream : IDisposable
Visual Basic (Declaration)
Public Class DatabaseStream _
    Implements IDisposable
Visual C++
public ref class DatabaseStream : IDisposable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseStream

See Also

DatabaseStream Members


DatabaseStream Members

[image] [image]

Berkeley DB .NET API Documentation
DatabaseStream Members
DatabaseStream Class Methods Properties See Also Send Feedback

The DatabaseStream type exposes the following members.

Methods

Name | Description
Close | Discard the database stream. It is possible for the Close() method to throw a DatabaseException if there is any failure. After Close has been called, regardless of its result, the database stream handle cannot be used again. Always close the stream when you have finished accessing the BLOB.
Dispose | Release the resources held by this object, and close the database stream if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Read | Read from the blob accessed by this database stream.
Size | Return the size of the blob in bytes accessed by the database stream.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Write | Write to the blob accessed by the database stream.

Properties

Name | Description
GetConfig | Return the database stream configuration.

See Also

DatabaseStream Class


DatabaseStream Methods

[image] [image]

Berkeley DB .NET API Documentation
DatabaseStream Methods
DatabaseStream Class See Also Send Feedback

The DatabaseStream type exposes the following members.

Methods

Name | Description
Close | Discard the database stream. It is possible for the Close() method to throw a DatabaseException if there is any failure. After Close has been called, regardless of its result, the database stream handle cannot be used again. Always close the stream when you have finished accessing the BLOB.
Dispose | Release the resources held by this object, and close the database stream if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Read | Read from the blob accessed by this database stream.
Size | Return the size of the blob in bytes accessed by the database stream.
ToString | Returns a string that represents the current object. (Inherited from Object.)
Write | Write to the blob accessed by the database stream.

See Also

DatabaseStream Class


Close Method

[image]

Berkeley DB .NET API Documentation
DatabaseStream..::.Close Method
DatabaseStream Class See Also Send Feedback

Discard the database stream.

It is possible for the Close() method to throw a DatabaseException if there is any failure.

After Close has been called, regardless of its result, the database stream handle cannot be used again. Always close the stream when you have finished accessing the BLOB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException |

See Also

DatabaseStream Class


Dispose Method

[image]

Berkeley DB .NET API Documentation
DatabaseStream..::.Dispose Method
DatabaseStream Class See Also Send Feedback
Release the resources held by this object, and close the database stream if it is still open.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DatabaseStream Class


Read Method

[image]

Berkeley DB .NET API Documentation
DatabaseStream..::.Read Method
DatabaseStream Class See Also Send Feedback
Read from the blob accessed by this database stream.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry Read(
    long offset,
    uint size
)
Visual Basic (Declaration)
Public Function Read ( _
    offset As Long, _
    size As UInteger _
) As DatabaseEntry
Visual C++
public:
DatabaseEntry^ Read(
    long long offset,
    unsigned int size
)

Parameters

offset
Type: System..::.Int64
The position in bytes in the blob where the reading starts.
size
Type: System..::.UInt32
The number of bytes to read.

Return Value

DatabaseEntry which contains the data read from the database stream.

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException | Thrown if there is any failure.

See Also

DatabaseStream Class


Size Method

[image]

Berkeley DB .NET API Documentation
DatabaseStream..::.Size Method
DatabaseStream Class See Also Send Feedback
Return the size of the blob in bytes accessed by the database stream.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Size()
Visual Basic (Declaration)
Public Function Size As Long
Visual C++
public:
long long Size()

Return Value

Return the size of the blob in bytes accessed by the database stream.

See Also

DatabaseStream Class


Write Method

[image]

Berkeley DB .NET API Documentation
DatabaseStream..::.Write Method
DatabaseStream Class See Also Send Feedback
Write to the blob accessed by the database stream.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Write(
    DatabaseEntry data,
    long offset
)
Visual Basic (Declaration)
Public Function Write ( _
    data As DatabaseEntry, _
    offset As Long _
) As Boolean
Visual C++
public:
bool Write(
    DatabaseEntry^ data,
    long long offset
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The DatabaseEntry containing the data to write. into the blob.
offset
Type: System..::.Int64
The position in bytes in the blob where the writing starts.

Return Value

True if the writing succeeds and false otherwise.

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException | Thrown if there is any failure.

See Also

DatabaseStream Class


DatabaseStream Properties

[image] [image]

Berkeley DB .NET API Documentation
DatabaseStream Properties
DatabaseStream Class See Also Send Feedback

The DatabaseStream type exposes the following members.

Properties

Name | Description
GetConfig | Return the database stream configuration.

See Also

DatabaseStream Class


GetConfig Property

[image]

Berkeley DB .NET API Documentation
DatabaseStream..::.GetConfig Property
DatabaseStream Class See Also Send Feedback
Return the database stream configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseStreamConfig GetConfig { get; }
Visual Basic (Declaration)
Public ReadOnly Property GetConfig As DatabaseStreamConfig
Visual C++
public:
property DatabaseStreamConfig^ GetConfig {
    DatabaseStreamConfig^ get ();
}

Return Value

Return the database stream configuration.

See Also

DatabaseStream Class


DatabaseStreamConfig Class

[image]

Berkeley DB .NET API Documentation
DatabaseStreamConfig Class
Members See Also Send Feedback
A class representing configuration parameters for DatabaseStream

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DatabaseStreamConfig
Visual Basic (Declaration)
Public Class DatabaseStreamConfig
Visual C++
public ref class DatabaseStreamConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseStreamConfig

See Also

DatabaseStreamConfig Members


DatabaseStreamConfig Members

[image] [image]

Berkeley DB .NET API Documentation
DatabaseStreamConfig Members
DatabaseStreamConfig Class Constructors Methods Fields Properties See Also Send Feedback

The DatabaseStreamConfig type exposes the following members.

Constructors

Name | Description
DatabaseStreamConfig | Instantiate a new DatabaseStreamConfig object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
SyncPerWrite | True if the database stream syncs the blob on each write.

Properties

Name | Description
ReadOnly | The database stream is read only.

See Also

DatabaseStreamConfig Class


DatabaseStreamConfig Constructor

[image]

Berkeley DB .NET API Documentation
DatabaseStreamConfig Constructor
DatabaseStreamConfig Class See Also Send Feedback
Instantiate a new DatabaseStreamConfig object.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseStreamConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DatabaseStreamConfig()

See Also

DatabaseStreamConfig Class


DatabaseStreamConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
DatabaseStreamConfig Fields
DatabaseStreamConfig Class See Also Send Feedback

The DatabaseStreamConfig type exposes the following members.

Fields

Name | Description
SyncPerWrite | True if the database stream syncs the blob on each write.

See Also

DatabaseStreamConfig Class


SyncPerWrite Field

[image]

Berkeley DB .NET API Documentation
DatabaseStreamConfig..::.SyncPerWrite Field
DatabaseStreamConfig Class See Also Send Feedback
True if the database stream syncs the blob on each write.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SyncPerWrite
Visual Basic (Declaration)
Public SyncPerWrite As Boolean
Visual C++
public:
bool SyncPerWrite

See Also

DatabaseStreamConfig Class


DatabaseStreamConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
DatabaseStreamConfig Methods
DatabaseStreamConfig Class See Also Send Feedback

The DatabaseStreamConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DatabaseStreamConfig Class


DatabaseStreamConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
DatabaseStreamConfig Properties
DatabaseStreamConfig Class See Also Send Feedback

The DatabaseStreamConfig type exposes the following members.

Properties

Name | Description
ReadOnly | The database stream is read only.

See Also

DatabaseStreamConfig Class


ReadOnly Property

[image]

Berkeley DB .NET API Documentation
DatabaseStreamConfig..::.ReadOnly Property
DatabaseStreamConfig Class See Also Send Feedback
The database stream is read only.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic (Declaration)
Public Property ReadOnly As Boolean
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

See Also

DatabaseStreamConfig Class


DatabaseType Class

[image]

Berkeley DB .NET API Documentation
DatabaseType Class
Members See Also Send Feedback
A class representing the supported Berkeley DB access methods.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DatabaseType
Visual Basic (Declaration)
Public Class DatabaseType
Visual C++
public ref class DatabaseType

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseType

See Also

DatabaseType Members


DatabaseType Members

[image] [image]

Berkeley DB .NET API Documentation
DatabaseType Members
DatabaseType Class Methods Fields See Also Send Feedback

The DatabaseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Convert this instance of DatabaseType to its string representation. (Overrides Object..::.ToString()()().)

Fields

Name | Description
BTREE | BTree access method
HASH | Hash access method
HEAP | Heap access method
QUEUE | Queue access method
RECNO | Recno access method
UNKNOWN | Unknown access method

See Also

DatabaseType Class


DatabaseType Fields

[image] [image]

Berkeley DB .NET API Documentation
DatabaseType Fields
DatabaseType Class See Also Send Feedback

The DatabaseType type exposes the following members.

Fields

Name | Description
BTREE | BTree access method
HASH | Hash access method
HEAP | Heap access method
QUEUE | Queue access method
RECNO | Recno access method
UNKNOWN | Unknown access method

See Also

DatabaseType Class


BTREE Field

[image]

Berkeley DB .NET API Documentation
DatabaseType..::.BTREE Field
DatabaseType Class See Also Send Feedback
BTree access method

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static readonly DatabaseType BTREE
Visual Basic (Declaration)
Public Shared ReadOnly BTREE As DatabaseType
Visual C++
public:
static initonly DatabaseType^ BTREE

See Also

DatabaseType Class


HASH Field

[image]

Berkeley DB .NET API Documentation
DatabaseType..::.HASH Field
DatabaseType Class See Also Send Feedback
Hash access method

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static readonly DatabaseType HASH
Visual Basic (Declaration)
Public Shared ReadOnly HASH As DatabaseType
Visual C++
public:
static initonly DatabaseType^ HASH

See Also

DatabaseType Class


HEAP Field

[image]

Berkeley DB .NET API Documentation
DatabaseType..::.HEAP Field
DatabaseType Class See Also Send Feedback
Heap access method

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static readonly DatabaseType HEAP
Visual Basic (Declaration)
Public Shared ReadOnly HEAP As DatabaseType
Visual C++
public:
static initonly DatabaseType^ HEAP

See Also

DatabaseType Class


QUEUE Field

[image]

Berkeley DB .NET API Documentation
DatabaseType..::.QUEUE Field
DatabaseType Class See Also Send Feedback
Queue access method

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static readonly DatabaseType QUEUE
Visual Basic (Declaration)
Public Shared ReadOnly QUEUE As DatabaseType
Visual C++
public:
static initonly DatabaseType^ QUEUE

See Also

DatabaseType Class


RECNO Field

[image]

Berkeley DB .NET API Documentation
DatabaseType..::.RECNO Field
DatabaseType Class See Also Send Feedback
Recno access method

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static readonly DatabaseType RECNO
Visual Basic (Declaration)
Public Shared ReadOnly RECNO As DatabaseType
Visual C++
public:
static initonly DatabaseType^ RECNO

See Also

DatabaseType Class


UNKNOWN Field

[image]

Berkeley DB .NET API Documentation
DatabaseType..::.UNKNOWN Field
DatabaseType Class See Also Send Feedback
Unknown access method

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static readonly DatabaseType UNKNOWN
Visual Basic (Declaration)
Public Shared ReadOnly UNKNOWN As DatabaseType
Visual C++
public:
static initonly DatabaseType^ UNKNOWN

See Also

DatabaseType Class


DatabaseType Methods

[image] [image]

Berkeley DB .NET API Documentation
DatabaseType Methods
DatabaseType Class See Also Send Feedback

The DatabaseType type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Convert this instance of DatabaseType to its string representation. (Overrides Object..::.ToString()()().)

See Also

DatabaseType Class


ToString Method

[image]

Berkeley DB .NET API Documentation
DatabaseType..::.ToString Method
DatabaseType Class See Also Send Feedback
Convert this instance of DatabaseType to its string representation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string representation of this instance.

See Also

DatabaseType Class


DbChannel Class

[image]

Berkeley DB .NET API Documentation
DbChannel Class
Members See Also Send Feedback
A class representing a channel in Berkeley DB HA replication manager.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DbChannel : IDisposable
Visual Basic (Declaration)
Public Class DbChannel _
    Implements IDisposable
Visual C++
public ref class DbChannel : IDisposable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DbChannel

See Also

DbChannel Members


DbChannel Members

[image] [image]

Berkeley DB .NET API Documentation
DbChannel Members
DbChannel Class Methods Properties See Also Send Feedback

The DbChannel type exposes the following members.

Methods

Name | Description
Close | Close the channel.
Dispose | Release the resources held by this object, and close the channel if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SendMessage | Send a message on the message channel. The message is sent asynchronously. The method does not wait for a response before returning. It usually completes quickly because it only waits for local TCP implementation to accept the bytes into its network data buffer. However, this message could block briefly for longer messages, and/or if the network data buffer is nearly full. It could even block indefinitely if the remote site is slow to read.
SendRequest | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Timeout | Set the default timeout value. It is used by SendRequest(array<DatabaseEntry>[]()[], UInt32).

See Also

DbChannel Class


DbChannel Methods

[image] [image]

Berkeley DB .NET API Documentation
DbChannel Methods
DbChannel Class See Also Send Feedback

The DbChannel type exposes the following members.

Methods

Name | Description
Close | Close the channel.
Dispose | Release the resources held by this object, and close the channel if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SendMessage | Send a message on the message channel. The message is sent asynchronously. The method does not wait for a response before returning. It usually completes quickly because it only waits for local TCP implementation to accept the bytes into its network data buffer. However, this message could block briefly for longer messages, and/or if the network data buffer is nearly full. It could even block indefinitely if the remote site is slow to read.
SendRequest | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DbChannel Class


Close Method

[image]

Berkeley DB .NET API Documentation
DbChannel..::.Close Method
DbChannel Class See Also Send Feedback
Close the channel.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

Remarks

All channels must be closed before the encompassing environment is closed. Also, all on-going messaging operations on the channel should be allowed to complete before attempting to close the channel.

After close, regardless of its return, the DbChannel may not be accessed again.

See Also

DbChannel Class


Dispose Method

[image]

Berkeley DB .NET API Documentation
DbChannel..::.Dispose Method
DbChannel Class See Also Send Feedback
Release the resources held by this object, and close the channel if it is still open.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DbChannel Class


SendMessage Method

[image]

Berkeley DB .NET API Documentation
DbChannel..::.SendMessage Method
DbChannel Class See Also Send Feedback
Send a message on the message channel. The message is sent asynchronously. The method does not wait for a response before returning. It usually completes quickly because it only waits for local TCP implementation to accept the bytes into its network data buffer. However, this message could block briefly for longer messages, and/or if the network data buffer is nearly full. It could even block indefinitely if the remote site is slow to read.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SendMessage(
    DatabaseEntry[] msg
)
Visual Basic (Declaration)
Public Sub SendMessage ( _
    msg As DatabaseEntry() _
)
Visual C++
public:
void SendMessage(
    array<DatabaseEntry^>^ msg
)

Parameters

msg
Type: array< BerkeleyDB..::.DatabaseEntry >[]()[]
An array of DatabaseEntry objects. Any flags for the DatabaseEntry objects are ignored.

Remarks

To block while waiting for a response from a remote site, use SendRequest(array<DatabaseEntry>[]()[], UInt32) instead of this method.

The sent message is received and handled at remote sites using a message dispatch callback, which is configured using RepMessageDispatch. This method may be used within the message dispatch callback on the remote site to send a reply or acknowledgement for messages that it receives and is handling.

This method may be used on channels opened to any destination. See RepMgrChannel(Int32) for a list of potential destinations.

See Also

DbChannel Class


SendRequest Method

[image] [image]

Berkeley DB .NET API Documentation
DbChannel..::.SendRequest Method
DbChannel Class See Also Send Feedback

Overload List

Name | Description
SendRequest(array<DatabaseEntry>[]()[], UInt32) | Send a message on the message channel. The message is sent synchronously. The method blocks waiting for a response before returning. If a response is not received within the timeout value configured for this request, this method returns with an error condition.
SendRequest(array<DatabaseEntry>[]()[], Int32, UInt32) | Send a message on the message channel. The message is sent synchronously. The method blocks waiting for a response before returning. If a response is not received within the timeout value configured for this request, this method returns with an error condition.

See Also

DbChannel Class
DbChannel Members


SendRequest Method (DatabaseEntry[], UInt32)

[image]

Berkeley DB .NET API Documentation
DbChannel..::.SendRequest Method (array<DatabaseEntry>[]()[], UInt32)
DbChannel Class See Also Send Feedback
Send a message on the message channel. The message is sent synchronously. The method blocks waiting for a response before returning. If a response is not received within the timeout value configured for this request, this method returns with an error condition.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry SendRequest(
    DatabaseEntry[] request,
    uint timeout
)
Visual Basic (Declaration)
Public Function SendRequest ( _
    request As DatabaseEntry(), _
    timeout As UInteger _
) As DatabaseEntry
Visual C++
public:
DatabaseEntry^ SendRequest(
    array<DatabaseEntry^>^ request,
    unsigned int timeout
)

Parameters

request
Type: array< BerkeleyDB..::.DatabaseEntry >[]()[]
DatabaseEntry objects array. Any flags for the DatabaseEntry objects are ignored.
timeout
Type: System..::.UInt32
The amount of time that may elapse while this method waits for a response from the remote site. The timeout value must be specified as an unsigned 32-bit number of microseconds, limiting the maximum timeout to roughly 71 minutes. A timeout value of 0 indicates that the channel's default timeout value should be used. This default is configured using Timeout.

Return Value

The response from remote site

Remarks

To avoid block while waiting for a response from a remote site, use SendMessage(array<DatabaseEntry>[]()[])

The message sent by this method is received and handled at remote sites using a message dispatch callback, which is configured using RepMessageDispatch

See Also

DbChannel Class
SendRequest Overload


SendRequest Method (DatabaseEntry[], Int32, UInt32)

[image]

Berkeley DB .NET API Documentation
DbChannel..::.SendRequest Method (array<DatabaseEntry>[]()[], Int32, UInt32)
DbChannel Class See Also Send Feedback
Send a message on the message channel. The message is sent synchronously. The method blocks waiting for a response before returning. If a response is not received within the timeout value configured for this request, this method returns with an error condition.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MultipleDatabaseEntry SendRequest(
    DatabaseEntry[] request,
    int bufferSize,
    uint timeout
)
Visual Basic (Declaration)
Public Function SendRequest ( _
    request As DatabaseEntry(), _
    bufferSize As Integer, _
    timeout As UInteger _
) As MultipleDatabaseEntry
Visual C++
public:
MultipleDatabaseEntry^ SendRequest(
    array<DatabaseEntry^>^ request,
    int bufferSize,
    unsigned int timeout
)

Parameters

request
Type: array< BerkeleyDB..::.DatabaseEntry >[]()[]
DatabaseEntry objects array. Any flags for the DatabaseEntry objects are ignored.
bufferSize
Type: System..::.Int32
Size of bulk buffer
timeout
Type: System..::.UInt32
The amount of time that may elapse while this method waits for a response from the remote site. The timeout value must be specified as an unsigned 32-bit number of microseconds, limiting the maximum timeout to roughly 71 minutes. A timeout value of 0 indicates that the channel's default timeout value should be used. This default is configured using Timeout.

Return Value

Multiple responses from the remote site.

Remarks

To avoid block while waiting for a response from a remote site, use SendMessage(array<DatabaseEntry>[]()[])

The message sent by this method is received and handled at remote sites using a message dispatch callback, which is configured using RepMessageDispatch

See Also

DbChannel Class
SendRequest Overload


DbChannel Properties

[image] [image]

Berkeley DB .NET API Documentation
DbChannel Properties
DbChannel Class See Also Send Feedback

The DbChannel type exposes the following members.

Properties

Name | Description
Timeout | Set the default timeout value. It is used by SendRequest(array<DatabaseEntry>[]()[], UInt32).

See Also

DbChannel Class


Timeout Property

[image]

Berkeley DB .NET API Documentation
DbChannel..::.Timeout Property
DbChannel Class See Also Send Feedback
Set the default timeout value. It is used by SendRequest(array<DatabaseEntry>[]()[], UInt32).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Timeout { get; set; }
Visual Basic (Declaration)
Public Property Timeout As UInteger
Visual C++
public:
property unsigned int Timeout {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The timeout is the amount of time that may elapse while SendRequest(array<DatabaseEntry>[]()[], UInt32) waits for a message response. It must be specified as an unsigned 32-bit number of microseconds, limiting the maximum timeout to roughly 71 minutes.

See Also

DbChannel Class


DbSite Class

[image]

Berkeley DB .NET API Documentation
DbSite Class
Members See Also Send Feedback
A class representing a site in Berkeley DB HA replication manager.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DbSite : IDisposable
Visual Basic (Declaration)
Public Class DbSite _
    Implements IDisposable
Visual C++
public ref class DbSite : IDisposable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DbSite

See Also

DbSite Members


DbSite Members

[image] [image]

Berkeley DB .NET API Documentation
DbSite Members
DbSite Class Methods Properties See Also Send Feedback

The DbSite type exposes the following members.

Methods

Name | Description
Close | Close the site.
Dispose | Release the resources held by this object, and close the site if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Remove | Remove the site from the replication manager.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Address | The host and port of the site.
EId | The eid of the site.
GroupCreator | Whether the site is a group creator.
Helper | Whether the site is a helper site.
Legacy | Whether the site is within a legacy group.
LocalSite | Whether it is a local site.
Peer | Whether the site is peer to a local site.

See Also

DbSite Class


DbSite Methods

[image] [image]

Berkeley DB .NET API Documentation
DbSite Methods
DbSite Class See Also Send Feedback

The DbSite type exposes the following members.

Methods

Name | Description
Close | Close the site.
Dispose | Release the resources held by this object, and close the site if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Remove | Remove the site from the replication manager.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DbSite Class


Close Method

[image]

Berkeley DB .NET API Documentation
DbSite..::.Close Method
DbSite Class See Also Send Feedback
Close the site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

Remarks

All open DbSite must be closed before its owning DatabaseEnvironment is closed.

See Also

DbSite Class


Dispose Method

[image]

Berkeley DB .NET API Documentation
DbSite..::.Dispose Method
DbSite Class See Also Send Feedback
Release the resources held by this object, and close the site if it is still open.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

DbSite Class


Remove Method

[image]

Berkeley DB .NET API Documentation
DbSite..::.Remove Method
DbSite Class See Also Send Feedback
Remove the site from the replication manager.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove
Visual C++
public:
void Remove()

See Also

DbSite Class


DbSite Properties

[image] [image]

Berkeley DB .NET API Documentation
DbSite Properties
DbSite Class See Also Send Feedback

The DbSite type exposes the following members.

Properties

Name | Description
Address | The host and port of the site.
EId | The eid of the site.
GroupCreator | Whether the site is a group creator.
Helper | Whether the site is a helper site.
Legacy | Whether the site is within a legacy group.
LocalSite | Whether it is a local site.
Peer | Whether the site is peer to a local site.

See Also

DbSite Class


Address Property

[image]

Berkeley DB .NET API Documentation
DbSite..::.Address Property
DbSite Class See Also Send Feedback
The host and port of the site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationHostAddress Address { get; }
Visual Basic (Declaration)
Public ReadOnly Property Address As ReplicationHostAddress
Visual C++
public:
property ReplicationHostAddress^ Address {
    ReplicationHostAddress^ get ();
}

See Also

DbSite Class


EId Property

[image]

Berkeley DB .NET API Documentation
DbSite..::.EId Property
DbSite Class See Also Send Feedback
The eid of the site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int EId { get; }
Visual Basic (Declaration)
Public ReadOnly Property EId As Integer
Visual C++
public:
property int EId {
    int get ();
}

See Also

DbSite Class


GroupCreator Property

[image]

Berkeley DB .NET API Documentation
DbSite..::.GroupCreator Property
DbSite Class See Also Send Feedback
Whether the site is a group creator.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool GroupCreator { get; set; }
Visual Basic (Declaration)
Public Property GroupCreator As Boolean
Visual C++
public:
property bool GroupCreator {
    bool get ();
    void set (bool value);
}

Remarks

Only the local site could be applied as a group creator. The group creator would create the initial membership database, defining a replication group of just the one site, rather than trying to join an existing group when it starts for the first time.

See Also

DbSite Class


Helper Property

[image]

Berkeley DB .NET API Documentation
DbSite..::.Helper Property
DbSite Class See Also Send Feedback
Whether the site is a helper site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Helper { get; set; }
Visual Basic (Declaration)
Public Property Helper As Boolean
Visual C++
public:
property bool Helper {
    bool get ();
    void set (bool value);
}

Remarks

A remote site may be a helper site when the local site first joins the replication group. Once the local site has been established as a member of the group, this configuration setting is ignored.

See Also

DbSite Class


Legacy Property

[image]

Berkeley DB .NET API Documentation
DbSite..::.Legacy Property
DbSite Class See Also Send Feedback
Whether the site is within a legacy group.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Legacy { get; set; }
Visual Basic (Declaration)
Public Property Legacy As Boolean
Visual C++
public:
property bool Legacy {
    bool get ();
    void set (bool value);
}

Remarks

Specify the site in a legacy group. It would be considered as part of an existing group, upgrading from a previous version of Berkeley DB. All sites in the legacy group must specify this for themselves (the local site) and for all other sites initially in the group.

See Also

DbSite Class


LocalSite Property

[image]

Berkeley DB .NET API Documentation
DbSite..::.LocalSite Property
DbSite Class See Also Send Feedback
Whether it is a local site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LocalSite { get; set; }
Visual Basic (Declaration)
Public Property LocalSite As Boolean
Visual C++
public:
property bool LocalSite {
    bool get ();
    void set (bool value);
}

See Also

DbSite Class


Peer Property

[image]

Berkeley DB .NET API Documentation
DbSite..::.Peer Property
DbSite Class See Also Send Feedback
Whether the site is peer to a local site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Peer { get; set; }
Visual Basic (Declaration)
Public Property Peer As Boolean
Visual C++
public:
property bool Peer {
    bool get ();
    void set (bool value);
}

Remarks

A peer site may be used as a target for "client-to-client" synchronization messages. It only makes sense to specify this for a remote site.

See Also

DbSite Class


DbSiteConfig Class

[image]

Berkeley DB .NET API Documentation
DbSiteConfig Class
Members See Also Send Feedback
Configuration properties for a site in replication manager.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DbSiteConfig
Visual Basic (Declaration)
Public Class DbSiteConfig
Visual C++
public ref class DbSiteConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DbSiteConfig

See Also

DbSiteConfig Members


DbSiteConfig Members

[image] [image]

Berkeley DB .NET API Documentation
DbSiteConfig Members
DbSiteConfig Class Constructors Methods Fields Properties See Also Send Feedback

The DbSiteConfig type exposes the following members.

Constructors

Name | Description
DbSiteConfig | Create a new DbSiteConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Host | The host of the site.
Port | The port of the site.

Properties

Name | Description
GroupCreator | Whether the site is a group creator.
Helper | Whether the site is a helper site.
Legacy | Whether the site is within a legacy group.
LocalSite | Whether it is local site.
Peer | Whether the site is peer to local site.

See Also

DbSiteConfig Class


DbSiteConfig Constructor

[image]

Berkeley DB .NET API Documentation
DbSiteConfig Constructor
DbSiteConfig Class See Also Send Feedback
Create a new DbSiteConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DbSiteConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DbSiteConfig()

See Also

DbSiteConfig Class


DbSiteConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
DbSiteConfig Fields
DbSiteConfig Class See Also Send Feedback

The DbSiteConfig type exposes the following members.

Fields

Name | Description
Host | The host of the site.
Port | The port of the site.

See Also

DbSiteConfig Class


Host Field

[image]

Berkeley DB .NET API Documentation
DbSiteConfig..::.Host Field
DbSiteConfig Class See Also Send Feedback
The host of the site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Host
Visual Basic (Declaration)
Public Host As String
Visual C++
public:
String^ Host

See Also

DbSiteConfig Class


Port Field

[image]

Berkeley DB .NET API Documentation
DbSiteConfig..::.Port Field
DbSiteConfig Class See Also Send Feedback
The port of the site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Port
Visual Basic (Declaration)
Public Port As UInteger
Visual C++
public:
unsigned int Port

See Also

DbSiteConfig Class


DbSiteConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
DbSiteConfig Methods
DbSiteConfig Class See Also Send Feedback

The DbSiteConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DbSiteConfig Class


DbSiteConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
DbSiteConfig Properties
DbSiteConfig Class See Also Send Feedback

The DbSiteConfig type exposes the following members.

Properties

Name | Description
GroupCreator | Whether the site is a group creator.
Helper | Whether the site is a helper site.
Legacy | Whether the site is within a legacy group.
LocalSite | Whether it is local site.
Peer | Whether the site is peer to local site.

See Also

DbSiteConfig Class


GroupCreator Property

[image]

Berkeley DB .NET API Documentation
DbSiteConfig..::.GroupCreator Property
DbSiteConfig Class See Also Send Feedback
Whether the site is a group creator.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool GroupCreator { get; set; }
Visual Basic (Declaration)
Public Property GroupCreator As Boolean
Visual C++
public:
property bool GroupCreator {
    bool get ();
    void set (bool value);
}

Remarks

Only the local site could be applied as a group creator. The group creator would create the initial membership database, defining a replication group of just the one site, rather than trying to join an existing group when it starts for the first time.

See Also

DbSiteConfig Class


Helper Property

[image]

Berkeley DB .NET API Documentation
DbSiteConfig..::.Helper Property
DbSiteConfig Class See Also Send Feedback
Whether the site is a helper site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Helper { get; set; }
Visual Basic (Declaration)
Public Property Helper As Boolean
Visual C++
public:
property bool Helper {
    bool get ();
    void set (bool value);
}

Remarks

A remote site may be a helper site when the local site first joins the replication group. Once the local site has been established as a member of the group, this config setting is ignored.

See Also

DbSiteConfig Class


Legacy Property

[image]

Berkeley DB .NET API Documentation
DbSiteConfig..::.Legacy Property
DbSiteConfig Class See Also Send Feedback
Whether the site is within a legacy group.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Legacy { get; set; }
Visual Basic (Declaration)
Public Property Legacy As Boolean
Visual C++
public:
property bool Legacy {
    bool get ();
    void set (bool value);
}

Remarks

Specify the site in a legacy group. It would be considered as part of an existing group, upgrading from a previous version of Berkeley DB. All sites in the legacy group must specify this for themselves (the local site) and for all other sites initially in the group.

See Also

DbSiteConfig Class


LocalSite Property

[image]

Berkeley DB .NET API Documentation
DbSiteConfig..::.LocalSite Property
DbSiteConfig Class See Also Send Feedback
Whether it is local site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LocalSite { get; set; }
Visual Basic (Declaration)
Public Property LocalSite As Boolean
Visual C++
public:
property bool LocalSite {
    bool get ();
    void set (bool value);
}

See Also

DbSiteConfig Class


Peer Property

[image]

Berkeley DB .NET API Documentation
DbSiteConfig..::.Peer Property
DbSiteConfig Class See Also Send Feedback
Whether the site is peer to local site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Peer { get; set; }
Visual Basic (Declaration)
Public Property Peer As Boolean
Visual C++
public:
property bool Peer {
    bool get ();
    void set (bool value);
}

Remarks

A peer site may be used as a target for "client-to-client" synchronization messages. It only makes sense to specify this for a remote site.

See Also

DbSiteConfig Class


DbThreadID Class

[image]

Berkeley DB .NET API Documentation
DbThreadID Class
Members See Also Send Feedback
A class representing a unique identifier for a thread of control in a Berkeley DB application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DbThreadID
Visual Basic (Declaration)
Public Class DbThreadID
Visual C++
public ref class DbThreadID

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DbThreadID

See Also

DbThreadID Members


DbThreadID Members

[image] [image]

Berkeley DB .NET API Documentation
DbThreadID Members
DbThreadID Class Constructors Methods Fields See Also Send Feedback

The DbThreadID type exposes the following members.

Constructors

Name | Description
DbThreadID | Instantiate a new DbThreadID object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
processID | The Process ID of the thread of control
threadID | The Thread ID of the thread of control

See Also

DbThreadID Class


DbThreadID Constructor

[image]

Berkeley DB .NET API Documentation
DbThreadID Constructor
DbThreadID Class See Also Send Feedback
Instantiate a new DbThreadID object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DbThreadID(
    int pid,
    uint tid
)
Visual Basic (Declaration)
Public Sub New ( _
    pid As Integer, _
    tid As UInteger _
)
Visual C++
public:
DbThreadID(
    int pid,
    unsigned int tid
)

Parameters

pid
Type: System..::.Int32
The Process ID of the thread of control
tid
Type: System..::.UInt32
The Thread ID of the thread of control

See Also

DbThreadID Class


DbThreadID Fields

[image] [image]

Berkeley DB .NET API Documentation
DbThreadID Fields
DbThreadID Class See Also Send Feedback

The DbThreadID type exposes the following members.

Fields

Name | Description
processID | The Process ID of the thread of control
threadID | The Thread ID of the thread of control

See Also

DbThreadID Class


processID Field

[image]

Berkeley DB .NET API Documentation
DbThreadID..::.processID Field
DbThreadID Class See Also Send Feedback
The Process ID of the thread of control

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int processID
Visual Basic (Declaration)
Public processID As Integer
Visual C++
public:
int processID

See Also

DbThreadID Class


threadID Field

[image]

Berkeley DB .NET API Documentation
DbThreadID..::.threadID Field
DbThreadID Class See Also Send Feedback
The Thread ID of the thread of control

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint threadID
Visual Basic (Declaration)
Public threadID As UInteger
Visual C++
public:
unsigned int threadID

See Also

DbThreadID Class


DbThreadID Methods

[image] [image]

Berkeley DB .NET API Documentation
DbThreadID Methods
DbThreadID Class See Also Send Feedback

The DbThreadID type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DbThreadID Class


DeadlockException Class

[image]

Berkeley DB .NET API Documentation
DeadlockException Class
Members See Also Send Feedback
When multiple threads of control are modifying the database, there is normally the potential for deadlock. In Berkeley DB, deadlock is signified by a DeadlockException thrown from the Berkeley DB function. Whenever a Berkeley DB function throws a DeadlockException, the enclosing transaction should be aborted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DeadlockException : DatabaseException
Visual Basic (Declaration)
Public Class DeadlockException _
    Inherits DatabaseException
Visual C++
public ref class DeadlockException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.DeadlockException

See Also

DeadlockException Members


DeadlockException Members

[image] [image]

Berkeley DB .NET API Documentation
DeadlockException Members
DeadlockException Class Constructors Methods Fields Properties See Also Send Feedback

The DeadlockException type exposes the following members.

Constructors

Name | Description
DeadlockException | Initialize a new instance of the DeadlockException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DeadlockException Class


DeadlockException Constructor

[image]

Berkeley DB .NET API Documentation
DeadlockException Constructor
DeadlockException Class See Also Send Feedback
Initialize a new instance of the DeadlockException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DeadlockException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DeadlockException()

See Also

DeadlockException Class


DeadlockException Fields

[image] [image]

Berkeley DB .NET API Documentation
DeadlockException Fields
DeadlockException Class See Also Send Feedback

The DeadlockException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

DeadlockException Class


DeadlockException Methods

[image] [image]

Berkeley DB .NET API Documentation
DeadlockException Methods
DeadlockException Class See Also Send Feedback

The DeadlockException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DeadlockException Class


DeadlockException Properties

[image] [image]

Berkeley DB .NET API Documentation
DeadlockException Properties
DeadlockException Class See Also Send Feedback

The DeadlockException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DeadlockException Class


DeadlockPolicy Class

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy Class
Members See Also Send Feedback
A class to represent what lock request(s) should be rejected during deadlock resolution.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class DeadlockPolicy
Visual Basic (Declaration)
Public Class DeadlockPolicy
Visual C++
public ref class DeadlockPolicy

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DeadlockPolicy

See Also

DeadlockPolicy Members


DeadlockPolicy Members

[image] [image]

Berkeley DB .NET API Documentation
DeadlockPolicy Members
DeadlockPolicy Class Methods Fields See Also Send Feedback

The DeadlockPolicy type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
DEFAULT | If no DeadlockPolicy has yet been specified, use RANDOM.
EXPIRE | Reject lock requests which have timed out. No other deadlock detection is performed.
MAX_LOCKS | Reject the lock request for the locker ID with the most locks.
MAX_WRITE | Reject the lock request for the locker ID with the most write locks.
MIN_LOCKS | Reject the lock request for the locker ID with the fewest locks.
MIN_WRITE | Reject the lock request for the locker ID with the fewest write locks.
OLDEST | Reject the lock request for the locker ID with the oldest lock.
RANDOM | Reject the lock request for a random locker ID.
YOUNGEST | Reject the lock request for the locker ID with the youngest lock.

See Also

DeadlockPolicy Class


DeadlockPolicy Fields

[image] [image]

Berkeley DB .NET API Documentation
DeadlockPolicy Fields
DeadlockPolicy Class See Also Send Feedback

The DeadlockPolicy type exposes the following members.

Fields

Name | Description
DEFAULT | If no DeadlockPolicy has yet been specified, use RANDOM.
EXPIRE | Reject lock requests which have timed out. No other deadlock detection is performed.
MAX_LOCKS | Reject the lock request for the locker ID with the most locks.
MAX_WRITE | Reject the lock request for the locker ID with the most write locks.
MIN_LOCKS | Reject the lock request for the locker ID with the fewest locks.
MIN_WRITE | Reject the lock request for the locker ID with the fewest write locks.
OLDEST | Reject the lock request for the locker ID with the oldest lock.
RANDOM | Reject the lock request for a random locker ID.
YOUNGEST | Reject the lock request for the locker ID with the youngest lock.

See Also

DeadlockPolicy Class


DEFAULT Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.DEFAULT Field
DeadlockPolicy Class See Also Send Feedback
If no DeadlockPolicy has yet been specified, use RANDOM.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy DEFAULT
Visual Basic (Declaration)
Public Shared DEFAULT As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ DEFAULT

See Also

DeadlockPolicy Class


EXPIRE Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.EXPIRE Field
DeadlockPolicy Class See Also Send Feedback
Reject lock requests which have timed out. No other deadlock detection is performed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy EXPIRE
Visual Basic (Declaration)
Public Shared EXPIRE As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ EXPIRE

See Also

DeadlockPolicy Class


MAX_LOCKS Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.MAX_LOCKS Field
DeadlockPolicy Class See Also Send Feedback
Reject the lock request for the locker ID with the most locks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy MAX_LOCKS
Visual Basic (Declaration)
Public Shared MAX_LOCKS As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ MAX_LOCKS

See Also

DeadlockPolicy Class


MAX_WRITE Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.MAX_WRITE Field
DeadlockPolicy Class See Also Send Feedback
Reject the lock request for the locker ID with the most write locks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy MAX_WRITE
Visual Basic (Declaration)
Public Shared MAX_WRITE As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ MAX_WRITE

See Also

DeadlockPolicy Class


MIN_LOCKS Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.MIN_LOCKS Field
DeadlockPolicy Class See Also Send Feedback
Reject the lock request for the locker ID with the fewest locks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy MIN_LOCKS
Visual Basic (Declaration)
Public Shared MIN_LOCKS As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ MIN_LOCKS

See Also

DeadlockPolicy Class


MIN_WRITE Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.MIN_WRITE Field
DeadlockPolicy Class See Also Send Feedback
Reject the lock request for the locker ID with the fewest write locks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy MIN_WRITE
Visual Basic (Declaration)
Public Shared MIN_WRITE As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ MIN_WRITE

See Also

DeadlockPolicy Class


OLDEST Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.OLDEST Field
DeadlockPolicy Class See Also Send Feedback
Reject the lock request for the locker ID with the oldest lock.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy OLDEST
Visual Basic (Declaration)
Public Shared OLDEST As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ OLDEST

See Also

DeadlockPolicy Class


RANDOM Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.RANDOM Field
DeadlockPolicy Class See Also Send Feedback
Reject the lock request for a random locker ID.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy RANDOM
Visual Basic (Declaration)
Public Shared RANDOM As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ RANDOM

See Also

DeadlockPolicy Class


YOUNGEST Field

[image]

Berkeley DB .NET API Documentation
DeadlockPolicy..::.YOUNGEST Field
DeadlockPolicy Class See Also Send Feedback
Reject the lock request for the locker ID with the youngest lock.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static DeadlockPolicy YOUNGEST
Visual Basic (Declaration)
Public Shared YOUNGEST As DeadlockPolicy
Visual C++
public:
static DeadlockPolicy^ YOUNGEST

See Also

DeadlockPolicy Class


DeadlockPolicy Methods

[image] [image]

Berkeley DB .NET API Documentation
DeadlockPolicy Methods
DeadlockPolicy Class See Also Send Feedback

The DeadlockPolicy type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

DeadlockPolicy Class


DuplicatesPolicy Enumeration

[image]

Berkeley DB .NET API Documentation
DuplicatesPolicy Enumeration
See Also Send Feedback
Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum DuplicatesPolicy
Visual Basic (Declaration)
Public Enumeration DuplicatesPolicy
Visual C++
public enum class DuplicatesPolicy

Members

Member name | Description
NONE | Does not allow a key/data pair to be inserted into the database even if the key already exists
SORTED | Duplicates are allowed and mainted in sorted order, as determined by the duplicate comparison function.
UNSORTED | Duplicates are allowed and ordered in the database by the order of insertion, unless the ordering is otherwise specified by use of a cursor operation or a duplicate sort function.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


EncryptionAlgorithm Enumeration

[image]

Berkeley DB .NET API Documentation
EncryptionAlgorithm Enumeration
See Also Send Feedback
Specifies an algorithm used for encryption and decryption

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum EncryptionAlgorithm
Visual Basic (Declaration)
Public Enumeration EncryptionAlgorithm
Visual C++
public enum class EncryptionAlgorithm

Members

Member name | Description
DEFAULT | The default algorithm, or the algorithm previously used in an existing environment
AES | The Rijndael/AES algorithm

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


EntryComparisonDelegate Delegate

[image]

Berkeley DB .NET API Documentation
EntryComparisonDelegate Delegate
See Also Send Feedback
An application-specified comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate int EntryComparisonDelegate(
    DatabaseEntry dbt1,
    DatabaseEntry dbt2
)
Visual Basic (Declaration)
Public Delegate Function EntryComparisonDelegate ( _
    dbt1 As DatabaseEntry, _
    dbt2 As DatabaseEntry _
) As Integer
Visual C++
public delegate int EntryComparisonDelegate(
    DatabaseEntry^ dbt1,
    DatabaseEntry^ dbt2
)

Parameters

dbt1
Type: BerkeleyDB..::.DatabaseEntry
The application supplied key.
dbt2
Type: BerkeleyDB..::.DatabaseEntry
The current tree's key.

Return Value

An integer value less than, equal to, or greater than zero if the first key parameter is considered to be respectively less than, equal to, or greater than the second key parameter.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


EntryPrefixComparisonDelegate Delegate

[image]

Berkeley DB .NET API Documentation
EntryPrefixComparisonDelegate Delegate
See Also Send Feedback
An application-specified prefix comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate uint EntryPrefixComparisonDelegate(
    DatabaseEntry dbt1,
    DatabaseEntry dbt2
)
Visual Basic (Declaration)
Public Delegate Function EntryPrefixComparisonDelegate ( _
    dbt1 As DatabaseEntry, _
    dbt2 As DatabaseEntry _
) As UInteger
Visual C++
public delegate unsigned int EntryPrefixComparisonDelegate(
    DatabaseEntry^ dbt1,
    DatabaseEntry^ dbt2
)

Parameters

dbt1
Type: BerkeleyDB..::.DatabaseEntry
The application supplied key.
dbt2
Type: BerkeleyDB..::.DatabaseEntry
The current tree's key.

Return Value

An unsigned integer value less than, equal to, or greater than zero if the firstkey parameter is considered to be respectively less than, equal to, or greater than the second key parameter.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


EnvironmentFeedbackDelegate Delegate

[image]

Berkeley DB .NET API Documentation
EnvironmentFeedbackDelegate Delegate
See Also Send Feedback
The application-specified feedback function called to report Berkeley DB operation progress.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate void EnvironmentFeedbackDelegate(
    EnvironmentFeedbackEvent opcode,
    int percent
)
Visual Basic (Declaration)
Public Delegate Sub EnvironmentFeedbackDelegate ( _
    opcode As EnvironmentFeedbackEvent, _
    percent As Integer _
)
Visual C++
public delegate void EnvironmentFeedbackDelegate(
    EnvironmentFeedbackEvent opcode,
    int percent
)

Parameters

opcode
Type: BerkeleyDB..::.EnvironmentFeedbackEvent
An operation code specifying the Berkley DB operation
percent
Type: System..::.Int32
The percent of the operation that has been completed, specified as an integer value between 0 and 100.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


EnvironmentFeedbackEvent Enumeration

[image]

Berkeley DB .NET API Documentation
EnvironmentFeedbackEvent Enumeration
See Also Send Feedback
Specifies the environment operation whose progress is being reported

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum EnvironmentFeedbackEvent
Visual Basic (Declaration)
Public Enumeration EnvironmentFeedbackEvent
Visual C++
public enum class EnvironmentFeedbackEvent

Members

Member name | Description
RECOVERY | The environment is being recovered.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


EnvironmentID Enumeration

[image]

Berkeley DB .NET API Documentation
EnvironmentID Enumeration
See Also Send Feedback
Special environment IDs.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum EnvironmentID
Visual Basic (Declaration)
Public Enumeration EnvironmentID
Visual C++
public enum class EnvironmentID

Members

Member name | Description
EID_BROADCAST | A message should be broadcast to every environment in the replication group, whose eid in ReplicationTransportDelegate is set to be this ID.
EID_INVALID | An invalid environment ID.
EID_MASTER | Messages sent on the channel created by RepMgrChannel(Int32) with this ID would be sent only to the master site.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


ErrorCodes Class

[image]

Berkeley DB .NET API Documentation
ErrorCodes Class
Members See Also Send Feedback
Constants representing error codes returned by the Berkeley DB library.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class ErrorCodes
Visual Basic (Declaration)
Public Class ErrorCodes
Visual C++
public ref class ErrorCodes

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.ErrorCodes

See Also

ErrorCodes Members


ErrorCodes Members

[image] [image]

Berkeley DB .NET API Documentation
ErrorCodes Members
ErrorCodes Class Constructors Methods Fields See Also Send Feedback

The ErrorCodes type exposes the following members.

Constructors

Name | Description
ErrorCodes | Initializes a new instance of the ErrorCodes class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
DB_BUFFER_SMALL | User memory too small for return.
DB_DONOTINDEX | "Null" return from secondary callback.
DB_FOREIGN_CONFLICT | A foreign database constraint triggered.
DB_HEAP_FULL | Heap database full.
DB_KEYEMPTY | Key/data deleted or never created.
DB_KEYEXIST | The key/data pair already exists.
DB_LOCK_DEADLOCK | Deadlock.
DB_LOCK_NOTGRANTED | Lock unavailable.
DB_LOG_BUFFER_FULL | In-memory log buffer full.
DB_META_CHKSUM_FAIL | Checksum mismatch detected.
DB_NOSERVER | Server panic return.
DB_NOTFOUND | Key/data pair not found (EOF).
DB_OLD_VERSION | Out-of-date version.
DB_PAGE_NOTFOUND | Requested page not found.
DB_REP_DUPMASTER | There are two masters.
DB_REP_HANDLE_DEAD | Rolled back a commit.
DB_REP_HOLDELECTION | Time to hold an election.
DB_REP_IGNORE | This message should be ignored.
DB_REP_ISPERM | Cached not written perm written.
DB_REP_JOIN_FAILURE | Unable to join replication group.
DB_REP_LEASE_EXPIRED | Master lease has expired.
DB_REP_LOCKOUT | API/Replication lockout now.
DB_REP_NEWSITE | New site entered system.
DB_REP_NOTPERM | Permanent log record not written.
DB_REP_UNAVAIL | Site cannot currently be reached.
DB_RUNRECOVERY | Panic return.
DB_SECONDARY_BAD | Secondary index corrupt.
DB_VERIFY_BAD | Verify failed; bad format.
DB_VERSION_MISMATCH | Environment version mismatch.

See Also

ErrorCodes Class


ErrorCodes Constructor

[image]

Berkeley DB .NET API Documentation
ErrorCodes Constructor
ErrorCodes Class See Also Send Feedback
Initializes a new instance of the ErrorCodes class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ErrorCodes()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ErrorCodes()

See Also

ErrorCodes Class


ErrorCodes Fields

[image] [image]

Berkeley DB .NET API Documentation
ErrorCodes Fields
ErrorCodes Class See Also Send Feedback

The ErrorCodes type exposes the following members.

Fields

Name | Description
DB_BUFFER_SMALL | User memory too small for return.
DB_DONOTINDEX | "Null" return from secondary callback.
DB_FOREIGN_CONFLICT | A foreign database constraint triggered.
DB_HEAP_FULL | Heap database full.
DB_KEYEMPTY | Key/data deleted or never created.
DB_KEYEXIST | The key/data pair already exists.
DB_LOCK_DEADLOCK | Deadlock.
DB_LOCK_NOTGRANTED | Lock unavailable.
DB_LOG_BUFFER_FULL | In-memory log buffer full.
DB_META_CHKSUM_FAIL | Checksum mismatch detected.
DB_NOSERVER | Server panic return.
DB_NOTFOUND | Key/data pair not found (EOF).
DB_OLD_VERSION | Out-of-date version.
DB_PAGE_NOTFOUND | Requested page not found.
DB_REP_DUPMASTER | There are two masters.
DB_REP_HANDLE_DEAD | Rolled back a commit.
DB_REP_HOLDELECTION | Time to hold an election.
DB_REP_IGNORE | This message should be ignored.
DB_REP_ISPERM | Cached not written perm written.
DB_REP_JOIN_FAILURE | Unable to join replication group.
DB_REP_LEASE_EXPIRED | Master lease has expired.
DB_REP_LOCKOUT | API/Replication lockout now.
DB_REP_NEWSITE | New site entered system.
DB_REP_NOTPERM | Permanent log record not written.
DB_REP_UNAVAIL | Site cannot currently be reached.
DB_RUNRECOVERY | Panic return.
DB_SECONDARY_BAD | Secondary index corrupt.
DB_VERIFY_BAD | Verify failed; bad format.
DB_VERSION_MISMATCH | Environment version mismatch.

See Also

ErrorCodes Class


DB_BUFFER_SMALL Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_BUFFER_SMALL Field
ErrorCodes Class See Also Send Feedback
User memory too small for return.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_BUFFER_SMALL
Visual Basic (Declaration)
Public Const DB_BUFFER_SMALL As Integer
Visual C++
public:
literal int DB_BUFFER_SMALL

See Also

ErrorCodes Class


DB_DONOTINDEX Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_DONOTINDEX Field
ErrorCodes Class See Also Send Feedback
"Null" return from secondary callback.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_DONOTINDEX
Visual Basic (Declaration)
Public Const DB_DONOTINDEX As Integer
Visual C++
public:
literal int DB_DONOTINDEX

See Also

ErrorCodes Class


DB_FOREIGN_CONFLICT Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_FOREIGN_CONFLICT Field
ErrorCodes Class See Also Send Feedback
A foreign database constraint triggered.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_FOREIGN_CONFLICT
Visual Basic (Declaration)
Public Const DB_FOREIGN_CONFLICT As Integer
Visual C++
public:
literal int DB_FOREIGN_CONFLICT

See Also

ErrorCodes Class


DB_HEAP_FULL Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_HEAP_FULL Field
ErrorCodes Class See Also Send Feedback
Heap database full.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_HEAP_FULL
Visual Basic (Declaration)
Public Const DB_HEAP_FULL As Integer
Visual C++
public:
literal int DB_HEAP_FULL

See Also

ErrorCodes Class


DB_KEYEMPTY Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_KEYEMPTY Field
ErrorCodes Class See Also Send Feedback
Key/data deleted or never created.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_KEYEMPTY
Visual Basic (Declaration)
Public Const DB_KEYEMPTY As Integer
Visual C++
public:
literal int DB_KEYEMPTY

See Also

ErrorCodes Class


DB_KEYEXIST Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_KEYEXIST Field
ErrorCodes Class See Also Send Feedback
The key/data pair already exists.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_KEYEXIST
Visual Basic (Declaration)
Public Const DB_KEYEXIST As Integer
Visual C++
public:
literal int DB_KEYEXIST

See Also

ErrorCodes Class


DB_LOCK_DEADLOCK Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_LOCK_DEADLOCK Field
ErrorCodes Class See Also Send Feedback
Deadlock.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_LOCK_DEADLOCK
Visual Basic (Declaration)
Public Const DB_LOCK_DEADLOCK As Integer
Visual C++
public:
literal int DB_LOCK_DEADLOCK

See Also

ErrorCodes Class


DB_LOCK_NOTGRANTED Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_LOCK_NOTGRANTED Field
ErrorCodes Class See Also Send Feedback
Lock unavailable.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_LOCK_NOTGRANTED
Visual Basic (Declaration)
Public Const DB_LOCK_NOTGRANTED As Integer
Visual C++
public:
literal int DB_LOCK_NOTGRANTED

See Also

ErrorCodes Class


DB_LOG_BUFFER_FULL Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_LOG_BUFFER_FULL Field
ErrorCodes Class See Also Send Feedback
In-memory log buffer full.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_LOG_BUFFER_FULL
Visual Basic (Declaration)
Public Const DB_LOG_BUFFER_FULL As Integer
Visual C++
public:
literal int DB_LOG_BUFFER_FULL

See Also

ErrorCodes Class


DB_META_CHKSUM_FAIL Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_META_CHKSUM_FAIL Field
ErrorCodes Class See Also Send Feedback
Checksum mismatch detected.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_META_CHKSUM_FAIL
Visual Basic (Declaration)
Public Const DB_META_CHKSUM_FAIL As Integer
Visual C++
public:
literal int DB_META_CHKSUM_FAIL

See Also

ErrorCodes Class


DB_NOSERVER Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_NOSERVER Field
ErrorCodes Class See Also Send Feedback
Server panic return.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_NOSERVER
Visual Basic (Declaration)
Public Const DB_NOSERVER As Integer
Visual C++
public:
literal int DB_NOSERVER

See Also

ErrorCodes Class


DB_NOTFOUND Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_NOTFOUND Field
ErrorCodes Class See Also Send Feedback
Key/data pair not found (EOF).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_NOTFOUND
Visual Basic (Declaration)
Public Const DB_NOTFOUND As Integer
Visual C++
public:
literal int DB_NOTFOUND

See Also

ErrorCodes Class


DB_OLD_VERSION Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_OLD_VERSION Field
ErrorCodes Class See Also Send Feedback
Out-of-date version.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_OLD_VERSION
Visual Basic (Declaration)
Public Const DB_OLD_VERSION As Integer
Visual C++
public:
literal int DB_OLD_VERSION

See Also

ErrorCodes Class


DB_PAGE_NOTFOUND Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_PAGE_NOTFOUND Field
ErrorCodes Class See Also Send Feedback
Requested page not found.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_PAGE_NOTFOUND
Visual Basic (Declaration)
Public Const DB_PAGE_NOTFOUND As Integer
Visual C++
public:
literal int DB_PAGE_NOTFOUND

See Also

ErrorCodes Class


DB_REP_DUPMASTER Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_DUPMASTER Field
ErrorCodes Class See Also Send Feedback
There are two masters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_DUPMASTER
Visual Basic (Declaration)
Public Const DB_REP_DUPMASTER As Integer
Visual C++
public:
literal int DB_REP_DUPMASTER

See Also

ErrorCodes Class


DB_REP_HANDLE_DEAD Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_HANDLE_DEAD Field
ErrorCodes Class See Also Send Feedback
Rolled back a commit.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_HANDLE_DEAD
Visual Basic (Declaration)
Public Const DB_REP_HANDLE_DEAD As Integer
Visual C++
public:
literal int DB_REP_HANDLE_DEAD

See Also

ErrorCodes Class


DB_REP_HOLDELECTION Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_HOLDELECTION Field
ErrorCodes Class See Also Send Feedback
Time to hold an election.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_HOLDELECTION
Visual Basic (Declaration)
Public Const DB_REP_HOLDELECTION As Integer
Visual C++
public:
literal int DB_REP_HOLDELECTION

See Also

ErrorCodes Class


DB_REP_IGNORE Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_IGNORE Field
ErrorCodes Class See Also Send Feedback
This message should be ignored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_IGNORE
Visual Basic (Declaration)
Public Const DB_REP_IGNORE As Integer
Visual C++
public:
literal int DB_REP_IGNORE

See Also

ErrorCodes Class


DB_REP_ISPERM Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_ISPERM Field
ErrorCodes Class See Also Send Feedback
Cached not written perm written.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_ISPERM
Visual Basic (Declaration)
Public Const DB_REP_ISPERM As Integer
Visual C++
public:
literal int DB_REP_ISPERM

See Also

ErrorCodes Class


DB_REP_JOIN_FAILURE Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_JOIN_FAILURE Field
ErrorCodes Class See Also Send Feedback
Unable to join replication group.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_JOIN_FAILURE
Visual Basic (Declaration)
Public Const DB_REP_JOIN_FAILURE As Integer
Visual C++
public:
literal int DB_REP_JOIN_FAILURE

See Also

ErrorCodes Class


DB_REP_LEASE_EXPIRED Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_LEASE_EXPIRED Field
ErrorCodes Class See Also Send Feedback
Master lease has expired.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_LEASE_EXPIRED
Visual Basic (Declaration)
Public Const DB_REP_LEASE_EXPIRED As Integer
Visual C++
public:
literal int DB_REP_LEASE_EXPIRED

See Also

ErrorCodes Class


DB_REP_LOCKOUT Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_LOCKOUT Field
ErrorCodes Class See Also Send Feedback
API/Replication lockout now.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_LOCKOUT
Visual Basic (Declaration)
Public Const DB_REP_LOCKOUT As Integer
Visual C++
public:
literal int DB_REP_LOCKOUT

See Also

ErrorCodes Class


DB_REP_NEWSITE Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_NEWSITE Field
ErrorCodes Class See Also Send Feedback
New site entered system.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_NEWSITE
Visual Basic (Declaration)
Public Const DB_REP_NEWSITE As Integer
Visual C++
public:
literal int DB_REP_NEWSITE

See Also

ErrorCodes Class


DB_REP_NOTPERM Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_NOTPERM Field
ErrorCodes Class See Also Send Feedback
Permanent log record not written.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_NOTPERM
Visual Basic (Declaration)
Public Const DB_REP_NOTPERM As Integer
Visual C++
public:
literal int DB_REP_NOTPERM

See Also

ErrorCodes Class


DB_REP_UNAVAIL Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_REP_UNAVAIL Field
ErrorCodes Class See Also Send Feedback
Site cannot currently be reached.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_REP_UNAVAIL
Visual Basic (Declaration)
Public Const DB_REP_UNAVAIL As Integer
Visual C++
public:
literal int DB_REP_UNAVAIL

See Also

ErrorCodes Class


DB_RUNRECOVERY Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_RUNRECOVERY Field
ErrorCodes Class See Also Send Feedback
Panic return.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_RUNRECOVERY
Visual Basic (Declaration)
Public Const DB_RUNRECOVERY As Integer
Visual C++
public:
literal int DB_RUNRECOVERY

See Also

ErrorCodes Class


DB_SECONDARY_BAD Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_SECONDARY_BAD Field
ErrorCodes Class See Also Send Feedback
Secondary index corrupt.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_SECONDARY_BAD
Visual Basic (Declaration)
Public Const DB_SECONDARY_BAD As Integer
Visual C++
public:
literal int DB_SECONDARY_BAD

See Also

ErrorCodes Class


DB_VERIFY_BAD Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_VERIFY_BAD Field
ErrorCodes Class See Also Send Feedback
Verify failed; bad format.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_VERIFY_BAD
Visual Basic (Declaration)
Public Const DB_VERIFY_BAD As Integer
Visual C++
public:
literal int DB_VERIFY_BAD

See Also

ErrorCodes Class


DB_VERSION_MISMATCH Field

[image]

Berkeley DB .NET API Documentation
ErrorCodes..::.DB_VERSION_MISMATCH Field
ErrorCodes Class See Also Send Feedback
Environment version mismatch.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public const int DB_VERSION_MISMATCH
Visual Basic (Declaration)
Public Const DB_VERSION_MISMATCH As Integer
Visual C++
public:
literal int DB_VERSION_MISMATCH

See Also

ErrorCodes Class


ErrorCodes Methods

[image] [image]

Berkeley DB .NET API Documentation
ErrorCodes Methods
ErrorCodes Class See Also Send Feedback

The ErrorCodes type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ErrorCodes Class


ErrorFeedbackDelegate Delegate

[image]

Berkeley DB .NET API Documentation
ErrorFeedbackDelegate Delegate
See Also Send Feedback
The application-specified error reporting function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate void ErrorFeedbackDelegate(
    string errPrefix,
    string errMessage
)
Visual Basic (Declaration)
Public Delegate Sub ErrorFeedbackDelegate ( _
    errPrefix As String, _
    errMessage As String _
)
Visual C++
public delegate void ErrorFeedbackDelegate(
    String^ errPrefix,
    String^ errMessage
)

Parameters

errPrefix
Type: System..::.String
The prefix string
errMessage
Type: System..::.String
The error message string

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


EventNotifyDelegate Delegate

[image]

Berkeley DB .NET API Documentation
EventNotifyDelegate Delegate
See Also Send Feedback
The application's event notification function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate void EventNotifyDelegate(
    NotificationEvent eventcode,
    byte[] event_info
)
Visual Basic (Declaration)
Public Delegate Sub EventNotifyDelegate ( _
    eventcode As NotificationEvent, _
    event_info As Byte() _
)
Visual C++
public delegate void EventNotifyDelegate(
    NotificationEvent eventcode,
    array<unsigned char>^ event_info
)

Parameters

eventcode
Type: BerkeleyDB..::.NotificationEvent
An even code specifying the Berkeley DB event
event_info
Type: array< System..::.Byte >[]()[]
Additional information describing an event. By default, event_info is null; specific events may pass non-null values, in which case the event also describes the information's structure.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


ForeignConflictException Class

[image]

Berkeley DB .NET API Documentation
ForeignConflictException Class
Members See Also Send Feedback

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class ForeignConflictException : DatabaseException
Visual Basic (Declaration)
Public Class ForeignConflictException _
    Inherits DatabaseException
Visual C++
public ref class ForeignConflictException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.ForeignConflictException

See Also

ForeignConflictException Members


ForeignConflictException Members

[image] [image]

Berkeley DB .NET API Documentation
ForeignConflictException Members
ForeignConflictException Class Constructors Methods Fields Properties See Also Send Feedback

The ForeignConflictException type exposes the following members.

Constructors

Name | Description
ForeignConflictException | Initialize a new instance of the ForeignConflictException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ForeignConflictException Class


ForeignConflictException Constructor

[image]

Berkeley DB .NET API Documentation
ForeignConflictException Constructor
ForeignConflictException Class See Also Send Feedback
Initialize a new instance of the ForeignConflictException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ForeignConflictException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ForeignConflictException()

See Also

ForeignConflictException Class


ForeignConflictException Fields

[image] [image]

Berkeley DB .NET API Documentation
ForeignConflictException Fields
ForeignConflictException Class See Also Send Feedback

The ForeignConflictException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

ForeignConflictException Class


ForeignConflictException Methods

[image] [image]

Berkeley DB .NET API Documentation
ForeignConflictException Methods
ForeignConflictException Class See Also Send Feedback

The ForeignConflictException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ForeignConflictException Class


ForeignConflictException Properties

[image] [image]

Berkeley DB .NET API Documentation
ForeignConflictException Properties
ForeignConflictException Class See Also Send Feedback

The ForeignConflictException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ForeignConflictException Class


ForeignKeyDeleteAction Enumeration

[image]

Berkeley DB .NET API Documentation
ForeignKeyDeleteAction Enumeration
See Also Send Feedback
Specifies the action to take when deleting a foreign key

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum ForeignKeyDeleteAction
Visual Basic (Declaration)
Public Enumeration ForeignKeyDeleteAction
Visual C++
public enum class ForeignKeyDeleteAction

Members

Member name | Description
ABORT | Abort the deletion.
CASCADE | Delete records that refer to the foreign key
NULLIFY | Nullify records that refer to the foreign key

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


ForeignKeyNullifyDelegate Delegate

[image]

Berkeley DB .NET API Documentation
ForeignKeyNullifyDelegate Delegate
See Also Send Feedback

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate DatabaseEntry ForeignKeyNullifyDelegate(
    DatabaseEntry key,
    DatabaseEntry data,
    DatabaseEntry foreignkey
)
Visual Basic (Declaration)
Public Delegate Function ForeignKeyNullifyDelegate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    foreignkey As DatabaseEntry _
) As DatabaseEntry
Visual C++
public delegate DatabaseEntry^ ForeignKeyNullifyDelegate(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    DatabaseEntry^ foreignkey
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
data
Type: BerkeleyDB..::.DatabaseEntry
foreignkey
Type: BerkeleyDB..::.DatabaseEntry

Return Value

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


FullLogBufferException Class

[image]

Berkeley DB .NET API Documentation
FullLogBufferException Class
Members See Also Send Feedback
In-memory logs are configured and no more log buffer space is available.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class FullLogBufferException : DatabaseException
Visual Basic (Declaration)
Public Class FullLogBufferException _
    Inherits DatabaseException
Visual C++
public ref class FullLogBufferException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.FullLogBufferException

See Also

FullLogBufferException Members


FullLogBufferException Members

[image] [image]

Berkeley DB .NET API Documentation
FullLogBufferException Members
FullLogBufferException Class Constructors Methods Fields Properties See Also Send Feedback

The FullLogBufferException type exposes the following members.

Constructors

Name | Description
FullLogBufferException | Initialize a new instance of the FullLogBufferException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FullLogBufferException Class


FullLogBufferException Constructor

[image]

Berkeley DB .NET API Documentation
FullLogBufferException Constructor
FullLogBufferException Class See Also Send Feedback
Initialize a new instance of the FullLogBufferException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public FullLogBufferException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FullLogBufferException()

See Also

FullLogBufferException Class


FullLogBufferException Fields

[image] [image]

Berkeley DB .NET API Documentation
FullLogBufferException Fields
FullLogBufferException Class See Also Send Feedback

The FullLogBufferException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

FullLogBufferException Class


FullLogBufferException Methods

[image] [image]

Berkeley DB .NET API Documentation
FullLogBufferException Methods
FullLogBufferException Class See Also Send Feedback

The FullLogBufferException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FullLogBufferException Class


FullLogBufferException Properties

[image] [image]

Berkeley DB .NET API Documentation
FullLogBufferException Properties
FullLogBufferException Class See Also Send Feedback

The FullLogBufferException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FullLogBufferException Class


HashCursor Class

[image]

Berkeley DB .NET API Documentation
HashCursor Class
Members See Also Send Feedback
A class for traversing the records of a HashDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HashCursor : Cursor
Visual Basic (Declaration)
Public Class HashCursor _
    Inherits Cursor
Visual C++
public ref class HashCursor : public Cursor

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseCursor
BerkeleyDB..::.Cursor
BerkeleyDB..::.HashCursor

See Also

HashCursor Members


HashCursor Members

[image] [image]

Berkeley DB .NET API Documentation
HashCursor Members
HashCursor Class Methods Properties See Also Send Feedback

The HashCursor type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddUnique | Insert the specified key/data pair into the database, unless a key/data pair comparing equally to it already exists in the database.
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
DbStream | Overloaded.
Delete | Delete the key/data pair to which the cursor refers. (Inherited from Cursor.)
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Cursor. (Inherited from Cursor.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Insert | Insert the data element as a duplicate element of the key to which the cursor refers.
Move | Overloaded.
MoveFirst | Overloaded.
MoveFirstMultiple | Overloaded. If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).
MoveFirstMultipleKey | Overloaded.
MoveLast | Overloaded.
MoveMultiple | Overloaded.
MoveMultipleKey | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextDuplicateMultiple | Overloaded.
MoveNextDuplicateMultipleKey | Overloaded.
MoveNextMultiple | Overloaded.
MoveNextMultipleKey | Overloaded.
MoveNextUnique | Overloaded.
MoveNextUniqueMultiple | Overloaded.
MoveNextUniqueMultipleKey | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Overwrite | Overwrite the data of the key/data pair to which the cursor refers with the specified data item. (Inherited from Cursor.)
Refresh | Overloaded.
RefreshMultiple | Overloaded.
RefreshMultipleKey | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Current | The key/data pair at which the cursor currently points. (Inherited from Cursor.)
CurrentMultiple | The key and multiple data items at which the cursor currently points. (Inherited from Cursor.)
CurrentMultipleKey | The multiple key and data items at which the cursor currently points. (Inherited from Cursor.)
Priority | The cache priority for pages referenced by the cursor. (Inherited from Cursor.)

See Also

HashCursor Class


HashCursor Methods

[image] [image]

Berkeley DB .NET API Documentation
HashCursor Methods
HashCursor Class See Also Send Feedback

The HashCursor type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddUnique | Insert the specified key/data pair into the database, unless a key/data pair comparing equally to it already exists in the database.
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
DbStream | Overloaded.
Delete | Delete the key/data pair to which the cursor refers. (Inherited from Cursor.)
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Cursor. (Inherited from Cursor.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Insert | Insert the data element as a duplicate element of the key to which the cursor refers.
Move | Overloaded.
MoveFirst | Overloaded.
MoveFirstMultiple | Overloaded. If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).
MoveFirstMultipleKey | Overloaded.
MoveLast | Overloaded.
MoveMultiple | Overloaded.
MoveMultipleKey | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextDuplicateMultiple | Overloaded.
MoveNextDuplicateMultipleKey | Overloaded.
MoveNextMultiple | Overloaded.
MoveNextMultipleKey | Overloaded.
MoveNextUnique | Overloaded.
MoveNextUniqueMultiple | Overloaded.
MoveNextUniqueMultipleKey | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Overwrite | Overwrite the data of the key/data pair to which the cursor refers with the specified data item. (Inherited from Cursor.)
Refresh | Overloaded.
RefreshMultiple | Overloaded.
RefreshMultipleKey | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HashCursor Class


Add Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.Add Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
Add(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>)) | Stores the key/data pair in the database. (Inherited from Cursor.)
Add(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Cursor..::.InsertLocation) | Insert the specified key/data pair into the database.

See Also

HashCursor Class
HashCursor Members


Add Method (KeyValuePair(DatabaseEntry, DatabaseEntry), Cursor.InsertLocation)

[image]

Berkeley DB .NET API Documentation
HashCursor..::.Add Method (KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Cursor..::.InsertLocation)
HashCursor Class See Also Send Feedback
Insert the specified key/data pair into the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Add(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair,
    Cursor..::.InsertLocation loc
)
Visual Basic (Declaration)
Public Sub Add ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry), _
    loc As Cursor..::.InsertLocation _
)
Visual C++
public:
void Add(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair,
    Cursor..::.InsertLocation loc
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair to be inserted
loc
Type: BerkeleyDB..::.Cursor..::.InsertLocation
If the key already exists in the database and no duplicate sort function has been specified, specify whether the inserted data item is added as the first or the last of the data items for that key.

See Also

HashCursor Class
Add Overload


AddUnique Method

[image]

Berkeley DB .NET API Documentation
HashCursor..::.AddUnique Method
HashCursor Class See Also Send Feedback
Insert the specified key/data pair into the database, unless a key/data pair comparing equally to it already exists in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void AddUnique(
    KeyValuePair<DatabaseEntry, DatabaseEntry> pair
)
Visual Basic (Declaration)
Public Sub AddUnique ( _
    pair As KeyValuePair(Of DatabaseEntry, DatabaseEntry) _
)
Visual C++
public:
void AddUnique(
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> pair
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)
The key/data pair to be inserted

Exceptions

Exception | Condition
BerkeleyDB..::.KeyExistException | Thrown if a matching key/data pair already exists in the database.

See Also

HashCursor Class


DbStream Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.DbStream Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
DbStream()()() | Create a database stream pointing to a key/value pair where the data item is a blob.
DbStream(DatabaseStreamConfig) | Create a database stream pointing to a key/value pair where the data item is a blob with the given configuration.

See Also

HashCursor Class
HashCursor Members


DbStream Method

[image]

Berkeley DB .NET API Documentation
HashCursor..::.DbStream Method
HashCursor Class See Also Send Feedback
Create a database stream pointing to a key/value pair where the data item is a blob.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseStream DbStream()
Visual Basic (Declaration)
Public Function DbStream As DatabaseStream
Visual C++
public:
DatabaseStream^ DbStream()

Return Value

A newly created database stream

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException | Thrown if the data item is not a blob.

See Also

HashCursor Class
DbStream Overload


DbStream Method (DatabaseStreamConfig)

[image]

Berkeley DB .NET API Documentation
HashCursor..::.DbStream Method (DatabaseStreamConfig)
HashCursor Class See Also Send Feedback
Create a database stream pointing to a key/value pair where the data item is a blob with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseStream DbStream(
    DatabaseStreamConfig cfg
)
Visual Basic (Declaration)
Public Function DbStream ( _
    cfg As DatabaseStreamConfig _
) As DatabaseStream
Visual C++
public:
DatabaseStream^ DbStream(
    DatabaseStreamConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.DatabaseStreamConfig
The configuration properties for the database stream.

Return Value

A newly created database stream

Exceptions

Exception | Condition
BerkeleyDB..::.DatabaseException | Thrown if the data of the key/value pair it is pointing to is not a blob.

See Also

HashCursor Class
DbStream Overload


Duplicate Method

[image]

Berkeley DB .NET API Documentation
HashCursor..::.Duplicate Method
HashCursor Class See Also Send Feedback
Create a new cursor that uses the same transaction and locker ID as the original cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashCursor Duplicate(
    bool keepPosition
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    keepPosition As Boolean _
) As HashCursor
Visual C++
public:
HashCursor^ Duplicate(
    bool keepPosition
)

Parameters

keepPosition
Type: System..::.Boolean
If true, the newly created cursor is initialized to refer to the same position in the database as the original cursor (if any) and hold the same locks (if any). If false, or if the original cursor does not hold a database position and locks, the created cursor is uninitialized and behaves like a cursor newly created by Cursor()()().

Return Value

A newly created cursor

Remarks

This is useful when an application is using locking and requires two or more cursors in the same thread of control.

See Also

HashCursor Class


Insert Method

[image]

Berkeley DB .NET API Documentation
HashCursor..::.Insert Method
HashCursor Class See Also Send Feedback
Insert the data element as a duplicate element of the key to which the cursor refers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Insert(
    DatabaseEntry data,
    Cursor..::.InsertLocation loc
)
Visual Basic (Declaration)
Public Sub Insert ( _
    data As DatabaseEntry, _
    loc As Cursor..::.InsertLocation _
)
Visual C++
public:
void Insert(
    DatabaseEntry^ data,
    Cursor..::.InsertLocation loc
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data element to insert
loc
Type: BerkeleyDB..::.Cursor..::.InsertLocation
Specify whether to insert the data item immediately before or immediately after the cursor's current position.

See Also

HashCursor Class


Move Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.Move Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
Move(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
Move(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
Move(DatabaseEntry, DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned. (Inherited from Cursor.)
Move(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
Move(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
Move(DatabaseEntry, DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveFirst Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveFirst Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirst()()() | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveFirst(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveFirst(DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveFirst(DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveFirstMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveFirstMultiple Method
HashCursor Class See Also Send Feedback
If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

Overload List

Name | Description
MoveFirstMultiple()()() | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(Int32) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(Int32, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveFirstMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveFirstMultipleKey Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirstMultipleKey()()() | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(Int32) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(Int32, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveLast Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveLast Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveLast()()() | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveLast(LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveLast(DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveLast(DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveMultiple Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveMultiple(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(DatabaseEntry, Boolean, Int32) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(DatabaseEntry, Boolean, Int32, LockingInfo) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveMultipleKey Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveMultipleKey(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(DatabaseEntry, Boolean, Int32) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(DatabaseEntry, Boolean, Int32, LockingInfo) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNext Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNext Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNext()()() | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MoveNext(LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MoveNext(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNext(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNextDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNextDuplicate Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicate()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicate(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicate(DatabaseEntry, DatabaseEntry) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNextDuplicate(DatabaseEntry, DatabaseEntry, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNextDuplicateMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNextDuplicateMultiple Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicateMultiple()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(Int32) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, then move cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(Int32, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNextDuplicateMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNextDuplicateMultipleKey Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicateMultipleKey()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(Int32) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(Int32, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNextMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNextMultiple Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextMultiple()()() | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(LockingInfo) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(Int32) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNextMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNextMultipleKey Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextMultipleKey()()() | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(LockingInfo) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(Int32) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNextUnique Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNextUnique Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUnique()()() | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUnique(LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUnique(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNextUnique(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNextUniqueMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNextUniqueMultiple Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUniqueMultiple()()() | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(Int32) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MoveNextUniqueMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MoveNextUniqueMultipleKey Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUniqueMultipleKey()()() | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(Int32) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MovePrev Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MovePrev Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrev()()() | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MovePrev(LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MovePrev(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrev(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MovePrevDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MovePrevDuplicate Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevDuplicate()()() | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MovePrevDuplicate(LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MovePrevDuplicate(DatabaseEntry, DatabaseEntry) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrevDuplicate(DatabaseEntry, DatabaseEntry, LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


MovePrevUnique Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.MovePrevUnique Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevUnique()()() | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MovePrevUnique(LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MovePrevUnique(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if ntheo non-duplicate key/data pairs exist after the cursor position in database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrevUnique(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


Refresh Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.Refresh Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
Refresh()()() | Store the key/data pair to which the cursor refers in Current. (Inherited from Cursor.)
Refresh(LockingInfo) | Store the key/data pair to which the cursor refers in Current. (Inherited from Cursor.)
Refresh(DatabaseEntry, DatabaseEntry) | Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned. (Inherited from Cursor.)
Refresh(DatabaseEntry, DatabaseEntry, LockingInfo) | Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


RefreshMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.RefreshMultiple Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
RefreshMultiple()()() | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(LockingInfo) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(Int32) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(Int32, LockingInfo) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


RefreshMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
HashCursor..::.RefreshMultipleKey Method
HashCursor Class See Also Send Feedback

Overload List

Name | Description
RefreshMultipleKey()()() | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(LockingInfo) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(Int32) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(Int32, LockingInfo) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)

See Also

HashCursor Class
HashCursor Members


HashCursor Properties

[image] [image]

Berkeley DB .NET API Documentation
HashCursor Properties
HashCursor Class See Also Send Feedback

The HashCursor type exposes the following members.

Properties

Name | Description
Current | The key/data pair at which the cursor currently points. (Inherited from Cursor.)
CurrentMultiple | The key and multiple data items at which the cursor currently points. (Inherited from Cursor.)
CurrentMultipleKey | The multiple key and data items at which the cursor currently points. (Inherited from Cursor.)
Priority | The cache priority for pages referenced by the cursor. (Inherited from Cursor.)

See Also

HashCursor Class


HashDatabase Class

[image]

Berkeley DB .NET API Documentation
HashDatabase Class
Members See Also Send Feedback
A class representing a HashDatabase. The Hash format is an extensible, dynamic hashing scheme.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HashDatabase : Database
Visual Basic (Declaration)
Public Class HashDatabase _
    Inherits Database
Visual C++
public ref class HashDatabase : public Database

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.Database
BerkeleyDB..::.HashDatabase

See Also

HashDatabase Members


HashDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase Members
HashDatabase Class Methods Properties See Also Send Feedback

The HashDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Compact | Overloaded.
Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoDuplicate | Overloaded.
PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by BTreeStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.
TruncateUnusedPages | Overloaded.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
BlobDir | The path of the directory where blobs are stored.
BlobThreshold | The threshold value in bytes beyond which data items are stored as blobs. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. A value of 0 indicates that blobs are not used by the database.
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Compare | The Hash key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
DupCompare | The duplicate data item comparison function.
Duplicates | Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FillFactor | The desired density within the hash table.
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HashFunction | A user-defined hash function; if no hash function is specified, a default hash function is used.
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
NParts | Return the number of partitions created in the database.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Partition | Return the application-specified partitioning function.
PartitionKeys | Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
TableSize | An estimate of the final size of the hash table.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

HashDatabase Class


HashDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase Methods
HashDatabase Class See Also Send Feedback

The HashDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Compact | Overloaded.
Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoDuplicate | Overloaded.
PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by BTreeStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.
TruncateUnusedPages | Overloaded.

See Also

HashDatabase Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Close Method
HashDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

HashDatabase Class
HashDatabase Members


Compact Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Compact Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
Compact(CompactConfig) | Compact the database, and optionally return unused database pages to the underlying filesystem.
Compact(CompactConfig, Transaction) | Compact the database, and optionally return unused database pages to the underlying filesystem.

See Also

HashDatabase Class
HashDatabase Members


Compact Method (CompactConfig)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Compact Method (CompactConfig)
HashDatabase Class See Also Send Feedback
Compact the database, and optionally return unused database pages to the underlying filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CompactData Compact(
    CompactConfig cdata
)
Visual Basic (Declaration)
Public Function Compact ( _
    cdata As CompactConfig _
) As CompactData
Visual C++
public:
CompactData^ Compact(
    CompactConfig^ cdata
)

Parameters

cdata
Type: BerkeleyDB..::.CompactConfig
Compact configuration parameters

Return Value

Compact operation statistics, where End holds the integer value representing which bucket the compaction stopped in.

Remarks

If the operation occurs in a transactional database, the operation is implicitly transaction protected using multiple transactions. These transactions are periodically committed to avoid locking large sections of the tree. Any deadlocks encountered cause the compaction operation to be retried from the point of the last transaction commit.

See Also

HashDatabase Class
Compact Overload


Compact Method (CompactConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Compact Method (CompactConfig, Transaction)
HashDatabase Class See Also Send Feedback
Compact the database, and optionally return unused database pages to the underlying filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CompactData Compact(
    CompactConfig cdata,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Compact ( _
    cdata As CompactConfig, _
    txn As Transaction _
) As CompactData
Visual C++
public:
CompactData^ Compact(
    CompactConfig^ cdata,
    Transaction^ txn
)

Parameters

cdata
Type: BerkeleyDB..::.CompactConfig
Compact configuration parameters
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

Compact operation statistics, where End holds the integer value representing which bucket the compaction stopped in.

Remarks

If txn is non-null, then the operation is performed using that transaction. In this event, large sections of the tree may be locked during the course of the transaction.

If txn is null, but the operation occurs in a transactional database, the operation is implicitly transaction protected using multiple transactions. These transactions are periodically committed to avoid locking large sections of the tree. Any deadlocks encountered cause the compaction operation to be retried from the point of the last transaction commit.

See Also

HashDatabase Class
Compact Overload


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Cursor Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor.
Cursor(CursorConfig) | Create a database cursor with the given configuration.
Cursor(Transaction) | Create a transactionally protected database cursor.
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration.

See Also

HashDatabase Class
HashDatabase Members


Cursor Method

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Cursor Method
HashDatabase Class See Also Send Feedback
Create a database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashCursor Cursor()
Visual Basic (Declaration)
Public Function Cursor As HashCursor
Visual C++
public:
HashCursor^ Cursor()

Return Value

A newly created cursor

See Also

HashDatabase Class
Cursor Overload


Cursor Method (CursorConfig)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Cursor Method (CursorConfig)
HashDatabase Class See Also Send Feedback
Create a database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashCursor Cursor(
    CursorConfig cfg
)
Visual Basic (Declaration)
Public Function Cursor ( _
    cfg As CursorConfig _
) As HashCursor
Visual C++
public:
HashCursor^ Cursor(
    CursorConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.

Return Value

A newly created cursor

See Also

HashDatabase Class
Cursor Overload


Cursor Method (Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Cursor Method (Transaction)
HashDatabase Class See Also Send Feedback
Create a transactionally protected database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashCursor Cursor(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Cursor ( _
    txn As Transaction _
) As HashCursor
Visual C++
public:
HashCursor^ Cursor(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

HashDatabase Class
Cursor Overload


Cursor Method (CursorConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Cursor Method (CursorConfig, Transaction)
HashDatabase Class See Also Send Feedback
Create a transactionally protected database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashCursor Cursor(
    CursorConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Cursor ( _
    cfg As CursorConfig, _
    txn As Transaction _
) As HashCursor
Visual C++
public:
HashCursor^ Cursor(
    CursorConfig^ cfg,
    Transaction^ txn
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.
txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

HashDatabase Class
Cursor Overload


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Delete Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

HashDatabase Class
HashDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Exists Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

HashDatabase Class
HashDatabase Members


FastStats Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.FastStats Method
HashDatabase Class See Also Send Feedback

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
FastStats()()() | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction) | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction, Isolation) | Return the database statistical information which does not require traversal of the database.

See Also

HashDatabase Class
HashDatabase Members


FastStats Method

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.FastStats Method
HashDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashStats FastStats()
Visual Basic (Declaration)
Public Function FastStats As HashStats
Visual C++
public:
HashStats^ FastStats()

Return Value

The database statistical information which does not require traversal of the database.

See Also

HashDatabase Class
FastStats Overload


FastStats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.FastStats Method (Transaction)
HashDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashStats FastStats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction _
) As HashStats
Visual C++
public:
HashStats^ FastStats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The database statistical information which does not require traversal of the database.

See Also

HashDatabase Class
FastStats Overload


FastStats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.FastStats Method (Transaction, Isolation)
HashDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashStats FastStats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As HashStats
Visual C++
public:
HashStats^ FastStats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE is silently ignored for databases which did not specify ReadUncommitted.

Return Value

The database statistical information which does not require traversal of the database.

See Also

HashDatabase Class
FastStats Overload


Get Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Get Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

HashDatabase Class
HashDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.GetBoth Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

HashDatabase Class
HashDatabase Members


GetBothMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.GetBothMultiple Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBothMultiple(DatabaseEntry, DatabaseEntry) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction, LockingInfo) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)

See Also

HashDatabase Class
HashDatabase Members


GetMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.GetMultiple Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
GetMultiple(DatabaseEntry) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32, Transaction) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32, Transaction, LockingInfo) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)

See Also

HashDatabase Class
HashDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Open Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, HashDatabaseConfig) | Instantiate a new HashDatabase object and open the database represented by Filename.
Open(String, HashDatabaseConfig, Transaction) | Instantiate a new HashDatabase object and open the database represented by Filename.
Open(String, String, HashDatabaseConfig) | Instantiate a new HashDatabase object and open the database represented by Filename and DatabaseName.
Open(String, String, HashDatabaseConfig, Transaction) | Instantiate a new HashDatabase object and open the database represented by Filename and DatabaseName.

See Also

HashDatabase Class
HashDatabase Members


Open Method (String, HashDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Open Method (String, HashDatabaseConfig)
HashDatabase Class See Also Send Feedback
Instantiate a new HashDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static HashDatabase Open(
    string Filename,
    HashDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As HashDatabaseConfig _
) As HashDatabase
Visual C++
public:
static HashDatabase^ Open(
    String^ Filename,
    HashDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.HashDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

HashDatabase Class
Open Overload


Open Method (String, HashDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Open Method (String, HashDatabaseConfig, Transaction)
HashDatabase Class See Also Send Feedback
Instantiate a new HashDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static HashDatabase Open(
    string Filename,
    HashDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As HashDatabaseConfig, _
    txn As Transaction _
) As HashDatabase
Visual C++
public:
static HashDatabase^ Open(
    String^ Filename,
    HashDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.HashDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

HashDatabase Class
Open Overload


Open Method (String, String, HashDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Open Method (String, String, HashDatabaseConfig)
HashDatabase Class See Also Send Feedback
Instantiate a new HashDatabase object and open the database represented by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static HashDatabase Open(
    string Filename,
    string DatabaseName,
    HashDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As HashDatabaseConfig _
) As HashDatabase
Visual C++
public:
static HashDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    HashDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.HashDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

HashDatabase Class
Open Overload


Open Method (String, String, HashDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Open Method (String, String, HashDatabaseConfig, Transaction)
HashDatabase Class See Also Send Feedback
Instantiate a new HashDatabase object and open the database represented by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static HashDatabase Open(
    string Filename,
    string DatabaseName,
    HashDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As HashDatabaseConfig, _
    txn As Transaction _
) As HashDatabase
Visual C++
public:
static HashDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    HashDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.HashDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and be replicated to client sites in any replication group.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

HashDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.PrintFastStats Method
HashDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

HashDatabase Class
HashDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.PrintStats Method
HashDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

HashDatabase Class
HashDatabase Members


Put Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Put Method
HashDatabase Class See Also Send Feedback

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

Overload List

Name | Description
Put(MultipleKeyDatabaseEntry) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)
Put(MultipleKeyDatabaseEntry, Transaction) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)

See Also

HashDatabase Class
HashDatabase Members


PutNoDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.PutNoDuplicate Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
PutNoDuplicate(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database only if it does not already appear in the database.
PutNoDuplicate(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database only if it does not already appear in the database.

See Also

HashDatabase Class
HashDatabase Members


PutNoDuplicate Method (DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.PutNoDuplicate Method (DatabaseEntry, DatabaseEntry)
HashDatabase Class See Also Send Feedback
Store the key/data pair in the database only if it does not already appear in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PutNoDuplicate(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Sub PutNoDuplicate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
)
Visual C++
public:
void PutNoDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to store in the database
data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database

See Also

HashDatabase Class
PutNoDuplicate Overload


PutNoDuplicate Method (DatabaseEntry, DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.PutNoDuplicate Method (DatabaseEntry, DatabaseEntry, Transaction)
HashDatabase Class See Also Send Feedback
Store the key/data pair in the database only if it does not already appear in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PutNoDuplicate(
    DatabaseEntry key,
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub PutNoDuplicate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry, _
    txn As Transaction _
)
Visual C++
public:
void PutNoDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key to store in the database
data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

See Also

HashDatabase Class
PutNoDuplicate Overload


PutNoOverwrite Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.PutNoOverwrite Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
PutNoOverwrite(MultipleKeyDatabaseEntry) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(MultipleKeyDatabaseEntry, Transaction) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)

See Also

HashDatabase Class
HashDatabase Members


Stats Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Stats Method
HashDatabase Class See Also Send Feedback
The statistical information is described by BTreeStats.

Overload List

Name | Description
Stats()()() | Return the database statistical information for this database.
Stats(Transaction) | Return the database statistical information for this database.
Stats(Transaction, Isolation) | Return the database statistical information for this database.

See Also

HashDatabase Class
HashDatabase Members


Stats Method

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Stats Method
HashDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashStats Stats()
Visual Basic (Declaration)
Public Function Stats As HashStats
Visual C++
public:
HashStats^ Stats()

Return Value

Database statistical information.

See Also

HashDatabase Class
Stats Overload


Stats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Stats Method (Transaction)
HashDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashStats Stats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction _
) As HashStats
Visual C++
public:
HashStats^ Stats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

Database statistical information.

See Also

HashDatabase Class
Stats Overload


Stats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Stats Method (Transaction, Isolation)
HashDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashStats Stats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As HashStats
Visual C++
public:
HashStats^ Stats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE is silently ignored for databases which did not specify ReadUncommitted.

Return Value

Database statistical information.

See Also

HashDatabase Class
Stats Overload


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.Truncate Method
HashDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

HashDatabase Class
HashDatabase Members


TruncateUnusedPages Method

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase..::.TruncateUnusedPages Method
HashDatabase Class See Also Send Feedback

Overload List

Name | Description
TruncateUnusedPages()()() | Return pages to the filesystem that are already free and at the end of the file.
TruncateUnusedPages(Transaction) | Return pages to the filesystem that are already free and at the end of the file.

See Also

HashDatabase Class
HashDatabase Members


TruncateUnusedPages Method

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.TruncateUnusedPages Method
HashDatabase Class See Also Send Feedback
Return pages to the filesystem that are already free and at the end of the file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TruncateUnusedPages()
Visual Basic (Declaration)
Public Function TruncateUnusedPages As UInteger
Visual C++
public:
unsigned int TruncateUnusedPages()

Return Value

The number of database pages returned to the filesystem

See Also

HashDatabase Class
TruncateUnusedPages Overload


TruncateUnusedPages Method (Transaction)

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.TruncateUnusedPages Method (Transaction)
HashDatabase Class See Also Send Feedback
Return pages to the filesystem that are already free and at the end of the file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TruncateUnusedPages(
    Transaction txn
)
Visual Basic (Declaration)
Public Function TruncateUnusedPages ( _
    txn As Transaction _
) As UInteger
Visual C++
public:
unsigned int TruncateUnusedPages(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The number of database pages returned to the filesystem

See Also

HashDatabase Class
TruncateUnusedPages Overload


HashDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
HashDatabase Properties
HashDatabase Class See Also Send Feedback

The HashDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
BlobDir | The path of the directory where blobs are stored.
BlobThreshold | The threshold value in bytes beyond which data items are stored as blobs. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. A value of 0 indicates that blobs are not used by the database.
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Compare | The Hash key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
DupCompare | The duplicate data item comparison function.
Duplicates | Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FillFactor | The desired density within the hash table.
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HashFunction | A user-defined hash function; if no hash function is specified, a default hash function is used.
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
NParts | Return the number of partitions created in the database.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Partition | Return the application-specified partitioning function.
PartitionKeys | Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
TableSize | An estimate of the final size of the hash table.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

HashDatabase Class


BlobDir Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.BlobDir Property
HashDatabase Class See Also Send Feedback
The path of the directory where blobs are stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BlobDir { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlobDir As String
Visual C++
public:
property String^ BlobDir {
    String^ get ();
}

See Also

HashDatabase Class


BlobThreshold Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.BlobThreshold Property
HashDatabase Class See Also Send Feedback
The threshold value in bytes beyond which data items are stored as blobs.

Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob.

A value of 0 indicates that blobs are not used by the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BlobThreshold { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlobThreshold As UInteger
Visual C++
public:
property unsigned int BlobThreshold {
    unsigned int get ();
}

See Also

HashDatabase Class


Compare Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Compare Property
HashDatabase Class See Also Send Feedback
The Hash key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate Compare { get; private set; }
Visual Basic (Declaration)
Public Property Compare As EntryComparisonDelegate
Visual C++
public:
property EntryComparisonDelegate^ Compare {
    EntryComparisonDelegate^ get ();
    void set (EntryComparisonDelegate^ value);
}

See Also

HashDatabase Class


DupCompare Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.DupCompare Property
HashDatabase Class See Also Send Feedback
The duplicate data item comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate DupCompare { get; private set; }
Visual Basic (Declaration)
Public Property DupCompare As EntryComparisonDelegate
Visual C++
public:
property EntryComparisonDelegate^ DupCompare {
    EntryComparisonDelegate^ get ();
    void set (EntryComparisonDelegate^ value);
}

See Also

HashDatabase Class


Duplicates Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Duplicates Property
HashDatabase Class See Also Send Feedback
Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DuplicatesPolicy Duplicates { get; }
Visual Basic (Declaration)
Public ReadOnly Property Duplicates As DuplicatesPolicy
Visual C++
public:
property DuplicatesPolicy Duplicates {
    DuplicatesPolicy get ();
}

See Also

HashDatabase Class


FillFactor Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.FillFactor Property
HashDatabase Class See Also Send Feedback
The desired density within the hash table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FillFactor { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillFactor As UInteger
Visual C++
public:
property unsigned int FillFactor {
    unsigned int get ();
}

See Also

HashDatabase Class


HashFunction Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.HashFunction Property
HashDatabase Class See Also Send Feedback
A user-defined hash function; if no hash function is specified, a default hash function is used.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashFunctionDelegate HashFunction { get; private set; }
Visual Basic (Declaration)
Public Property HashFunction As HashFunctionDelegate
Visual C++
public:
property HashFunctionDelegate^ HashFunction {
    HashFunctionDelegate^ get ();
    void set (HashFunctionDelegate^ value);
}

See Also

HashDatabase Class


NParts Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.NParts Property
HashDatabase Class See Also Send Feedback
Return the number of partitions created in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NParts { get; private set; }
Visual Basic (Declaration)
Public Property NParts As UInteger
Visual C++
public:
property unsigned int NParts {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

HashDatabase Class


Partition Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.Partition Property
HashDatabase Class See Also Send Feedback
Return the application-specified partitioning function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public PartitionDelegate Partition { get; private set; }
Visual Basic (Declaration)
Public Property Partition As PartitionDelegate
Visual C++
public:
property PartitionDelegate^ Partition {
    PartitionDelegate^ get ();
    void set (PartitionDelegate^ value);
}

See Also

HashDatabase Class


PartitionKeys Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.PartitionKeys Property
HashDatabase Class See Also Send Feedback
Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry[] PartitionKeys { get; private set; }
Visual Basic (Declaration)
Public Property PartitionKeys As DatabaseEntry()
Visual C++
public:
property array<DatabaseEntry^>^ PartitionKeys {
    array<DatabaseEntry^>^ get ();
    void set (array<DatabaseEntry^>^ value);
}

See Also

HashDatabase Class


TableSize Property

[image]

Berkeley DB .NET API Documentation
HashDatabase..::.TableSize Property
HashDatabase Class See Also Send Feedback
An estimate of the final size of the hash table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TableSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property TableSize As UInteger
Visual C++
public:
property unsigned int TableSize {
    unsigned int get ();
}

See Also

HashDatabase Class


HashDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for HashDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HashDatabaseConfig : DatabaseConfig
Visual Basic (Declaration)
Public Class HashDatabaseConfig _
    Inherits DatabaseConfig
Visual C++
public ref class HashDatabaseConfig : public DatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.HashDatabaseConfig

See Also

HashDatabaseConfig Members


HashDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
HashDatabaseConfig Members
HashDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The HashDatabaseConfig type exposes the following members.

Constructors

Name | Description
HashDatabaseConfig | Instantiate a new HashDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetPartitionByCallback | Enable database partitioning using the specified number of partitions and partition function. Return true if the specified number of partitions are successfully enabled; otherwise return false. The number of partitions to createThe name of partitioning function
SetPartitionByKeys | Enable database partitioning using the specified partition keys. Return true if partitioning is successfully enabled; otherwise return false. An array of DatabaseEntry where each array entry defines the range of key values to be stored in each partition
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BlobDir | The path of the directory where blobs are stored. If the database is opened within DatabaseEnvironment, this path setting is ignored during Open(String, HashDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
DuplicateCompare | The duplicate data item comparison function.
Duplicates | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
HashComparison | The Hash key comparison function.
HashFunction | A user-defined hash function; if no hash function is specified, a default hash function is used.
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

Properties

Name | Description
BlobThreshold | The size in bytes which is used to determine when a data item is stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, blobs are never be used by the database. It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
FillFactor | The desired density within the hash table. If no value is specified, the fill factor is selected dynamically as pages are filled.
NParts | Return the number of partitions to create.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Partition | Return the application-specified partitioning function.
PartitionKeys | Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.
TableSize | An estimate of the final size of the hash table.

See Also

HashDatabaseConfig Class


HashDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig Constructor
HashDatabaseConfig Class See Also Send Feedback
Instantiate a new HashDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashDatabaseConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HashDatabaseConfig()

See Also

HashDatabaseConfig Class


HashDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
HashDatabaseConfig Fields
HashDatabaseConfig Class See Also Send Feedback

The HashDatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BlobDir | The path of the directory where blobs are stored. If the database is opened within DatabaseEnvironment, this path setting is ignored during Open(String, HashDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
DuplicateCompare | The duplicate data item comparison function.
Duplicates | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
HashComparison | The Hash key comparison function.
HashFunction | A user-defined hash function; if no hash function is specified, a default hash function is used.
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

See Also

HashDatabaseConfig Class


BlobDir Field

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.BlobDir Field
HashDatabaseConfig Class See Also Send Feedback
The path of the directory where blobs are stored.

If the database is opened within DatabaseEnvironment, this path setting is ignored during Open(String, HashDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BlobDir
Visual Basic (Declaration)
Public BlobDir As String
Visual C++
public:
String^ BlobDir

See Also

HashDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.Creation Field
HashDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, HashDatabaseConfig) fails.

See Also

HashDatabaseConfig Class


DuplicateCompare Field

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.DuplicateCompare Field
HashDatabaseConfig Class See Also Send Feedback
The duplicate data item comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate DuplicateCompare
Visual Basic (Declaration)
Public DuplicateCompare As EntryComparisonDelegate
Visual C++
public:
EntryComparisonDelegate^ DuplicateCompare

Remarks

The comparison function is called whenever it is necessary to compare a data item specified by the application with a data item currently stored in the database. Setting DuplicateCompare implies setting Duplicates to SORTED.

If no comparison function is specified, the data items are compared lexically, with shorter data items collating before longer data items.

If the database already exists when Open(String, HashDatabaseConfig) is called, the delegate must be the same as that historically used to create the database or corruption can occur.

See Also

HashDatabaseConfig Class


Duplicates Field

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.Duplicates Field
HashDatabaseConfig Class See Also Send Feedback
Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DuplicatesPolicy Duplicates
Visual Basic (Declaration)
Public Duplicates As DuplicatesPolicy
Visual C++
public:
DuplicatesPolicy Duplicates

Remarks

The ordering of duplicates in the database for UNSORTED is determined by the order of insertion, unless the ordering is otherwise specified by use of a cursor operation or a duplicate sort function. The ordering of duplicates in the database for SORTED is determined by the duplicate comparison function. If the application does not specify a comparison function using DuplicateCompare, a default lexical comparison is be used.

SORTED is preferred to UNSORTED for performance reasons. UNSORTED should only be used by applications wanting to order duplicate data items manually.

If the database already exists, the value of Duplicates must be the same as the existing database or an error is returned.

See Also

HashDatabaseConfig Class


HashComparison Field

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.HashComparison Field
HashDatabaseConfig Class See Also Send Feedback
The Hash key comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate HashComparison
Visual Basic (Declaration)
Public HashComparison As EntryComparisonDelegate
Visual C++
public:
EntryComparisonDelegate^ HashComparison

Remarks

The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.

If no comparison function is specified, the keys are compared lexically, with shorter keys collating before longer keys.

If the database already exists, the comparison function must be the same as that historically used to create the database or corruption can occur.

See Also

HashDatabaseConfig Class


HashFunction Field

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.HashFunction Field
HashDatabaseConfig Class See Also Send Feedback
A user-defined hash function; if no hash function is specified, a default hash function is used.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashFunctionDelegate HashFunction
Visual Basic (Declaration)
Public HashFunction As HashFunctionDelegate
Visual C++
public:
HashFunctionDelegate^ HashFunction

Remarks

Because no hash function performs equally well on all possible data, the user may find that the built-in hash function performs poorly with a particular data set.

If the database already exists, HashFunction must be the same as that historically used to create the database or corruption can occur.

See Also

HashDatabaseConfig Class


HashDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
HashDatabaseConfig Methods
HashDatabaseConfig Class See Also Send Feedback

The HashDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetPartitionByCallback | Enable database partitioning using the specified number of partitions and partition function. Return true if the specified number of partitions are successfully enabled; otherwise return false. The number of partitions to createThe name of partitioning function
SetPartitionByKeys | Enable database partitioning using the specified partition keys. Return true if partitioning is successfully enabled; otherwise return false. An array of DatabaseEntry where each array entry defines the range of key values to be stored in each partition
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HashDatabaseConfig Class


SetPartitionByCallback Method

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.SetPartitionByCallback Method
HashDatabaseConfig Class See Also Send Feedback
Enable database partitioning using the specified number of partitions and partition function. Return true if the specified number of partitions are successfully enabled; otherwise return false. The number of partitions to createThe name of partitioning function

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SetPartitionByCallback(
    uint parts,
    PartitionDelegate partFunc
)
Visual Basic (Declaration)
Public Function SetPartitionByCallback ( _
    parts As UInteger, _
    partFunc As PartitionDelegate _
) As Boolean
Visual C++
public:
bool SetPartitionByCallback(
    unsigned int parts,
    PartitionDelegate^ partFunc
)

Parameters

parts
Type: System..::.UInt32
partFunc
Type: BerkeleyDB..::.PartitionDelegate

See Also

HashDatabaseConfig Class


SetPartitionByKeys Method

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.SetPartitionByKeys Method
HashDatabaseConfig Class See Also Send Feedback
Enable database partitioning using the specified partition keys. Return true if partitioning is successfully enabled; otherwise return false. An array of DatabaseEntry where each array entry defines the range of key values to be stored in each partition

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool SetPartitionByKeys(
    DatabaseEntry[] keys
)
Visual Basic (Declaration)
Public Function SetPartitionByKeys ( _
    keys As DatabaseEntry() _
) As Boolean
Visual C++
public:
bool SetPartitionByKeys(
    array<DatabaseEntry^>^ keys
)

Parameters

keys
Type: array< BerkeleyDB..::.DatabaseEntry >[]()[]

See Also

HashDatabaseConfig Class


HashDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
HashDatabaseConfig Properties
HashDatabaseConfig Class See Also Send Feedback

The HashDatabaseConfig type exposes the following members.

Properties

Name | Description
BlobThreshold | The size in bytes which is used to determine when a data item is stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, blobs are never be used by the database. It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
FillFactor | The desired density within the hash table. If no value is specified, the fill factor is selected dynamically as pages are filled.
NParts | Return the number of partitions to create.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Partition | Return the application-specified partitioning function.
PartitionKeys | Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.
TableSize | An estimate of the final size of the hash table.

See Also

HashDatabaseConfig Class


BlobThreshold Property

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.BlobThreshold Property
HashDatabaseConfig Class See Also Send Feedback
The size in bytes which is used to determine when a data item is stored as a blob.

Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob.

If the threshold value is 0, blobs are never be used by the database.

It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BlobThreshold { get; set; }
Visual Basic (Declaration)
Public Property BlobThreshold As UInteger
Visual C++
public:
property unsigned int BlobThreshold {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

HashDatabaseConfig Class


FillFactor Property

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.FillFactor Property
HashDatabaseConfig Class See Also Send Feedback
The desired density within the hash table. If no value is specified, the fill factor is selected dynamically as pages are filled.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FillFactor { get; set; }
Visual Basic (Declaration)
Public Property FillFactor As UInteger
Visual C++
public:
property unsigned int FillFactor {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The density is an approximation of the number of keys allowed to accumulate in any one bucket, determining when the hash table grows or shrinks. If you know the average sizes of the keys and data in your data set, setting the fill factor can enhance performance. A reasonable rule computing fill factor is to set it to the following:

(pagesize - 32) / (average_key_size + average_data_size + 8)

If the database already exists, this setting is ignored.

See Also

HashDatabaseConfig Class


NParts Property

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.NParts Property
HashDatabaseConfig Class See Also Send Feedback
Return the number of partitions to create.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NParts { get; }
Visual Basic (Declaration)
Public ReadOnly Property NParts As UInteger
Visual C++
public:
property unsigned int NParts {
    unsigned int get ();
}

See Also

HashDatabaseConfig Class


Partition Property

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.Partition Property
HashDatabaseConfig Class See Also Send Feedback
Return the application-specified partitioning function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public PartitionDelegate Partition { get; }
Visual Basic (Declaration)
Public ReadOnly Property Partition As PartitionDelegate
Visual C++
public:
property PartitionDelegate^ Partition {
    PartitionDelegate^ get ();
}

See Also

HashDatabaseConfig Class


PartitionKeys Property

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.PartitionKeys Property
HashDatabaseConfig Class See Also Send Feedback
Return an array of type DatabaseEntry where each array entry contains the range of keys contained in one of the database's partitions. The array contains the information for the entire database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry[] PartitionKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartitionKeys As DatabaseEntry()
Visual C++
public:
property array<DatabaseEntry^>^ PartitionKeys {
    array<DatabaseEntry^>^ get ();
}

See Also

HashDatabaseConfig Class


TableSize Property

[image]

Berkeley DB .NET API Documentation
HashDatabaseConfig..::.TableSize Property
HashDatabaseConfig Class See Also Send Feedback
An estimate of the final size of the hash table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TableSize { get; set; }
Visual Basic (Declaration)
Public Property TableSize As UInteger
Visual C++
public:
property unsigned int TableSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

In order for the estimate to be used when creating the database, FillFactor must also be set. If the estimate or fill factor is not set or is set too low, hash tables still expand gracefully as keys are entered, although a slight performance degradation may be noticed.

If the database already exists, this setting is ignored.

See Also

HashDatabaseConfig Class


HashFunctionDelegate Delegate

[image]

Berkeley DB .NET API Documentation
HashFunctionDelegate Delegate
See Also Send Feedback
The application-specified hash function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate uint HashFunctionDelegate(
    byte[] data
)
Visual Basic (Declaration)
Public Delegate Function HashFunctionDelegate ( _
    data As Byte() _
) As UInteger
Visual C++
public delegate unsigned int HashFunctionDelegate(
    array<unsigned char>^ data
)

Parameters

data
Type: array< System..::.Byte >[]()[]
A byte string representing a key in the database

Return Value

The hashed value of data

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


HashStats Class

[image]

Berkeley DB .NET API Documentation
HashStats Class
Members See Also Send Feedback
Statistical information about a HashDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HashStats
Visual Basic (Declaration)
Public Class HashStats
Visual C++
public ref class HashStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.HashStats

See Also

HashStats Members


HashStats Members

[image] [image]

Berkeley DB .NET API Documentation
HashStats Members
HashStats Class Methods Properties See Also Send Feedback

The HashStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BigPages | Number of big key/data pages.
BigPagesFreeBytes | Bytes free on big item pages.
BucketPagesFreeBytes | Bytes free on bucket pages.
DuplicatePages | Number of duplicate pages.
DuplicatePagesFreeBytes | Bytes free on duplicate pages.
FillFactor | Fill factor specified at create.
FreePages | Pages on the free list.
MagicNumber | Magic number.
MetadataFlags | Metadata flags.
nBlobRecords | Number of blob records.
nData | Number of data items.
nHashBuckets | Number of hash buckets.
nKeys | Number of unique keys.
nPages | Page count.
OverflowPages | Number of overflow pages.
OverflowPagesFreeBytes | Bytes free on overflow pages.
PageSize | Page size.
Version | Version number.

See Also

HashStats Class


HashStats Methods

[image] [image]

Berkeley DB .NET API Documentation
HashStats Methods
HashStats Class See Also Send Feedback

The HashStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HashStats Class


HashStats Properties

[image] [image]

Berkeley DB .NET API Documentation
HashStats Properties
HashStats Class See Also Send Feedback

The HashStats type exposes the following members.

Properties

Name | Description
BigPages | Number of big key/data pages.
BigPagesFreeBytes | Bytes free on big item pages.
BucketPagesFreeBytes | Bytes free on bucket pages.
DuplicatePages | Number of duplicate pages.
DuplicatePagesFreeBytes | Bytes free on duplicate pages.
FillFactor | Fill factor specified at create.
FreePages | Pages on the free list.
MagicNumber | Magic number.
MetadataFlags | Metadata flags.
nBlobRecords | Number of blob records.
nData | Number of data items.
nHashBuckets | Number of hash buckets.
nKeys | Number of unique keys.
nPages | Page count.
OverflowPages | Number of overflow pages.
OverflowPagesFreeBytes | Bytes free on overflow pages.
PageSize | Page size.
Version | Version number.

See Also

HashStats Class


BigPages Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.BigPages Property
HashStats Class See Also Send Feedback
Number of big key/data pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BigPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property BigPages As UInteger
Visual C++
public:
property unsigned int BigPages {
    unsigned int get ();
}

See Also

HashStats Class


BigPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.BigPagesFreeBytes Property
HashStats Class See Also Send Feedback
Bytes free on big item pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BigPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property BigPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long BigPagesFreeBytes {
    unsigned long long get ();
}

See Also

HashStats Class


BucketPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.BucketPagesFreeBytes Property
HashStats Class See Also Send Feedback
Bytes free on bucket pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BucketPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property BucketPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long BucketPagesFreeBytes {
    unsigned long long get ();
}

See Also

HashStats Class


DuplicatePages Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.DuplicatePages Property
HashStats Class See Also Send Feedback
Number of duplicate pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DuplicatePages { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuplicatePages As UInteger
Visual C++
public:
property unsigned int DuplicatePages {
    unsigned int get ();
}

See Also

HashStats Class


DuplicatePagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.DuplicatePagesFreeBytes Property
HashStats Class See Also Send Feedback
Bytes free on duplicate pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong DuplicatePagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuplicatePagesFreeBytes As ULong
Visual C++
public:
property unsigned long long DuplicatePagesFreeBytes {
    unsigned long long get ();
}

See Also

HashStats Class


FillFactor Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.FillFactor Property
HashStats Class See Also Send Feedback
Fill factor specified at create.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FillFactor { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillFactor As UInteger
Visual C++
public:
property unsigned int FillFactor {
    unsigned int get ();
}

See Also

HashStats Class


FreePages Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.FreePages Property
HashStats Class See Also Send Feedback
Pages on the free list.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FreePages { get; }
Visual Basic (Declaration)
Public ReadOnly Property FreePages As UInteger
Visual C++
public:
property unsigned int FreePages {
    unsigned int get ();
}

See Also

HashStats Class


MagicNumber Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.MagicNumber Property
HashStats Class See Also Send Feedback
Magic number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MagicNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property MagicNumber As UInteger
Visual C++
public:
property unsigned int MagicNumber {
    unsigned int get ();
}

See Also

HashStats Class


MetadataFlags Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.MetadataFlags Property
HashStats Class See Also Send Feedback
Metadata flags.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MetadataFlags { get; }
Visual Basic (Declaration)
Public ReadOnly Property MetadataFlags As UInteger
Visual C++
public:
property unsigned int MetadataFlags {
    unsigned int get ();
}

See Also

HashStats Class


nBlobRecords Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.nBlobRecords Property
HashStats Class See Also Send Feedback
Number of blob records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nBlobRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property nBlobRecords As UInteger
Visual C++
public:
property unsigned int nBlobRecords {
    unsigned int get ();
}

See Also

HashStats Class


nData Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.nData Property
HashStats Class See Also Send Feedback
Number of data items.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nData { get; }
Visual Basic (Declaration)
Public ReadOnly Property nData As UInteger
Visual C++
public:
property unsigned int nData {
    unsigned int get ();
}

See Also

HashStats Class


nHashBuckets Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.nHashBuckets Property
HashStats Class See Also Send Feedback
Number of hash buckets.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nHashBuckets { get; }
Visual Basic (Declaration)
Public ReadOnly Property nHashBuckets As UInteger
Visual C++
public:
property unsigned int nHashBuckets {
    unsigned int get ();
}

See Also

HashStats Class


nKeys Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.nKeys Property
HashStats Class See Also Send Feedback
Number of unique keys.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property nKeys As UInteger
Visual C++
public:
property unsigned int nKeys {
    unsigned int get ();
}

See Also

HashStats Class


nPages Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.nPages Property
HashStats Class See Also Send Feedback
Page count.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property nPages As UInteger
Visual C++
public:
property unsigned int nPages {
    unsigned int get ();
}

See Also

HashStats Class


OverflowPages Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.OverflowPages Property
HashStats Class See Also Send Feedback
Number of overflow pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint OverflowPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowPages As UInteger
Visual C++
public:
property unsigned int OverflowPages {
    unsigned int get ();
}

See Also

HashStats Class


OverflowPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.OverflowPagesFreeBytes Property
HashStats Class See Also Send Feedback
Bytes free on overflow pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong OverflowPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long OverflowPagesFreeBytes {
    unsigned long long get ();
}

See Also

HashStats Class


PageSize Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.PageSize Property
HashStats Class See Also Send Feedback
Page size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As UInteger
Visual C++
public:
property unsigned int PageSize {
    unsigned int get ();
}

See Also

HashStats Class


Version Property

[image]

Berkeley DB .NET API Documentation
HashStats..::.Version Property
HashStats Class See Also Send Feedback
Version number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As UInteger
Visual C++
public:
property unsigned int Version {
    unsigned int get ();
}

See Also

HashStats Class


HeapDatabase Class

[image]

Berkeley DB .NET API Documentation
HeapDatabase Class
Members See Also Send Feedback
A class representing a HeapDatabase.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HeapDatabase : Database
Visual Basic (Declaration)
Public Class HeapDatabase _
    Inherits Database
Visual C++
public ref class HeapDatabase : public Database

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.Database
BerkeleyDB..::.HeapDatabase

See Also

HeapDatabase Members


HeapDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase Members
HeapDatabase Class Methods Properties See Also Send Feedback

The HeapDatabase type exposes the following members.

Methods

Name | Description
Append | Overloaded.
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by HeapStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
BlobDir | The path of the directory where blobs are stored.
BlobThreshold | The threshold value in bytes beyond which data items are stored as blobs. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. A value of 0 indicates that blobs are not used by the database.
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
MaxSizeBytes | The bytes component of the maximum on-disk database file size.
MaxSizeGBytes | The gigabytes component of the maximum on-disk database file size.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
RegionSize | The number of pages in a region of the database. It is set by RegionSize when the heap database is opened.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class


HeapDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase Methods
HeapDatabase Class See Also Send Feedback

The HeapDatabase type exposes the following members.

Methods

Name | Description
Append | Overloaded.
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by HeapStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

See Also

HeapDatabase Class


Append Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Append Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
Append(DatabaseEntry) | Append the data item to the end of the database.
Append(DatabaseEntry, Transaction) | Append the data item to the end of the database.

See Also

HeapDatabase Class
HeapDatabase Members


Append Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Append Method (DatabaseEntry)
HeapDatabase Class See Also Send Feedback
Append the data item to the end of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapRecordId Append(
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function Append ( _
    data As DatabaseEntry _
) As HeapRecordId
Visual C++
public:
HeapRecordId^ Append(
    DatabaseEntry^ data
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database

Return Value

The heap record id allocated to the record

See Also

HeapDatabase Class
Append Overload


Append Method (DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Append Method (DatabaseEntry, Transaction)
HeapDatabase Class See Also Send Feedback
Append the data item to the end of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapRecordId Append(
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Append ( _
    data As DatabaseEntry, _
    txn As Transaction _
) As HeapRecordId
Visual C++
public:
HeapRecordId^ Append(
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The heap record id allocated to the record

See Also

HeapDatabase Class
Append Overload


Close Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Close Method
HeapDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Cursor Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig) | Create a database cursor with the given configuration. (Inherited from BaseDatabase.)
Cursor(Transaction) | Create a transactionally protected database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Delete Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Exists Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


FastStats Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.FastStats Method
HeapDatabase Class See Also Send Feedback

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
FastStats()()() | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction) | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction, Isolation) | Return the database statistical information which does not require traversal of the database.

See Also

HeapDatabase Class
HeapDatabase Members


FastStats Method

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.FastStats Method
HeapDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapStats FastStats()
Visual Basic (Declaration)
Public Function FastStats As HeapStats
Visual C++
public:
HeapStats^ FastStats()

Return Value

The database statistical information which does not require traversal of the database.

See Also

HeapDatabase Class
FastStats Overload


FastStats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.FastStats Method (Transaction)
HeapDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapStats FastStats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction _
) As HeapStats
Visual C++
public:
HeapStats^ FastStats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The database statistical information which does not require traversal of the database.

See Also

HeapDatabase Class
FastStats Overload


FastStats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.FastStats Method (Transaction, Isolation)
HeapDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapStats FastStats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As HeapStats
Visual C++
public:
HeapStats^ FastStats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE is silently ignored for databases which did not specify ReadUncommitted.

Return Value

The database statistical information which does not require traversal of the database.

See Also

HeapDatabase Class
FastStats Overload


Get Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Get Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.GetBoth Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


GetBothMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.GetBothMultiple Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBothMultiple(DatabaseEntry, DatabaseEntry) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction, LockingInfo) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)

See Also

HeapDatabase Class
HeapDatabase Members


GetMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.GetMultiple Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
GetMultiple(DatabaseEntry) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32, Transaction) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32, Transaction, LockingInfo) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)

See Also

HeapDatabase Class
HeapDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Open Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, HeapDatabaseConfig) | Instantiate a new HeapDatabase object and open the database represented by Filename.
Open(String, HeapDatabaseConfig, Transaction) | Instantiate a new HeapDatabase object and open the database represented by Filename.

See Also

HeapDatabase Class
HeapDatabase Members


Open Method (String, HeapDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Open Method (String, HeapDatabaseConfig)
HeapDatabase Class See Also Send Feedback
Instantiate a new HeapDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static HeapDatabase Open(
    string Filename,
    HeapDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As HeapDatabaseConfig _
) As HeapDatabase
Visual C++
public:
static HeapDatabase^ Open(
    String^ Filename,
    HeapDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back up the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.HeapDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

HeapDatabase Class
Open Overload


Open Method (String, HeapDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Open Method (String, HeapDatabaseConfig, Transaction)
HeapDatabase Class See Also Send Feedback
Instantiate a new HeapDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static HeapDatabase Open(
    string Filename,
    HeapDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As HeapDatabaseConfig, _
    txn As Transaction _
) As HeapDatabase
Visual C++
public:
static HeapDatabase^ Open(
    String^ Filename,
    HeapDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back up the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.HeapDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

HeapDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.PrintFastStats Method
HeapDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.PrintStats Method
HeapDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


Put Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Put Method
HeapDatabase Class See Also Send Feedback

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

Overload List

Name | Description
Put(MultipleKeyDatabaseEntry) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)
Put(MultipleKeyDatabaseEntry, Transaction) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)

See Also

HeapDatabase Class
HeapDatabase Members


PutNoOverwrite Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.PutNoOverwrite Method
HeapDatabase Class See Also Send Feedback

Overload List

Name | Description
PutNoOverwrite(MultipleKeyDatabaseEntry) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(MultipleKeyDatabaseEntry, Transaction) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)

See Also

HeapDatabase Class
HeapDatabase Members


Stats Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Stats Method
HeapDatabase Class See Also Send Feedback
The statistical information is described by HeapStats.

Overload List

Name | Description
Stats()()() | Return the database statistical information for this database.
Stats(Transaction) | Return the database statistical information for this database.
Stats(Transaction, Isolation) | Return the database statistical information for this database.

See Also

HeapDatabase Class
HeapDatabase Members


Stats Method

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Stats Method
HeapDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapStats Stats()
Visual Basic (Declaration)
Public Function Stats As HeapStats
Visual C++
public:
HeapStats^ Stats()

Return Value

Database statistical information.

See Also

HeapDatabase Class
Stats Overload


Stats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Stats Method (Transaction)
HeapDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapStats Stats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction _
) As HeapStats
Visual C++
public:
HeapStats^ Stats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

Database statistical information.

See Also

HeapDatabase Class
Stats Overload


Stats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Stats Method (Transaction, Isolation)
HeapDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapStats Stats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As HeapStats
Visual C++
public:
HeapStats^ Stats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE is silently ignored for databases which did not specify ReadUncommitted.

Return Value

Database statistical information.

See Also

HeapDatabase Class
Stats Overload


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase..::.Truncate Method
HeapDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class
HeapDatabase Members


HeapDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabase Properties
HeapDatabase Class See Also Send Feedback

The HeapDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
BlobDir | The path of the directory where blobs are stored.
BlobThreshold | The threshold value in bytes beyond which data items are stored as blobs. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. A value of 0 indicates that blobs are not used by the database.
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
MaxSizeBytes | The bytes component of the maximum on-disk database file size.
MaxSizeGBytes | The gigabytes component of the maximum on-disk database file size.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
RegionSize | The number of pages in a region of the database. It is set by RegionSize when the heap database is opened.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

HeapDatabase Class


BlobDir Property

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.BlobDir Property
HeapDatabase Class See Also Send Feedback
The path of the directory where blobs are stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BlobDir { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlobDir As String
Visual C++
public:
property String^ BlobDir {
    String^ get ();
}

See Also

HeapDatabase Class


BlobThreshold Property

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.BlobThreshold Property
HeapDatabase Class See Also Send Feedback
The threshold value in bytes beyond which data items are stored as blobs.

Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob.

A value of 0 indicates that blobs are not used by the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BlobThreshold { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlobThreshold As UInteger
Visual C++
public:
property unsigned int BlobThreshold {
    unsigned int get ();
}

See Also

HeapDatabase Class


MaxSizeBytes Property

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.MaxSizeBytes Property
HeapDatabase Class See Also Send Feedback
The bytes component of the maximum on-disk database file size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxSizeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxSizeBytes As UInteger
Visual C++
public:
property unsigned int MaxSizeBytes {
    unsigned int get ();
}

See Also

HeapDatabase Class


MaxSizeGBytes Property

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.MaxSizeGBytes Property
HeapDatabase Class See Also Send Feedback
The gigabytes component of the maximum on-disk database file size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxSizeGBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxSizeGBytes As UInteger
Visual C++
public:
property unsigned int MaxSizeGBytes {
    unsigned int get ();
}

See Also

HeapDatabase Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
HeapDatabase..::.RegionSize Property
HeapDatabase Class See Also Send Feedback
The number of pages in a region of the database. It is set by RegionSize when the heap database is opened.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RegionSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionSize As UInteger
Visual C++
public:
property unsigned int RegionSize {
    unsigned int get ();
}

See Also

HeapDatabase Class


HeapDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for HeapDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HeapDatabaseConfig : DatabaseConfig
Visual Basic (Declaration)
Public Class HeapDatabaseConfig _
    Inherits DatabaseConfig
Visual C++
public ref class HeapDatabaseConfig : public DatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.HeapDatabaseConfig

See Also

HeapDatabaseConfig Members


HeapDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig Members
HeapDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The HeapDatabaseConfig type exposes the following members.

Constructors

Name | Description
HeapDatabaseConfig | Instantiate a new HeapDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MaxSize | Set the maximum on-disk database file size used by the database. Attempts to update or create records in a database that have reached this file size limit throw a HeapFullException. If this value is not set, the database file size can grow infinitely.
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BlobDir | The path of the directory where blobs are stored. If the database is opened within DatabaseEnvironment, this path setting will be ignored during Open(String, HeapDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

Properties

Name | Description
BlobThreshold | The size in bytes which is used to determine when a data item will be stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, blobs are never used by the database. It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
MaxSizeBytes | The bytes component of the maximum on-disk database file size.
MaxSizeGBytes | The gigabytes component of the maximum on-disk database file size.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
RegionSize | The number of pages in a region of the database. If this value is never set, the default region size for the database's page size is used. You can set the database page size using PageSize. If the database already exists, this value is ignored. If the specified region size is larger than the maximum region size for the database's page size, an error is returned when Open(String, DatabaseConfig) is called. The maximum allowable region size is included in the error message.

See Also

HeapDatabaseConfig Class


HeapDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig Constructor
HeapDatabaseConfig Class See Also Send Feedback
Instantiate a new HeapDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapDatabaseConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HeapDatabaseConfig()

See Also

HeapDatabaseConfig Class


HeapDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig Fields
HeapDatabaseConfig Class See Also Send Feedback

The HeapDatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BlobDir | The path of the directory where blobs are stored. If the database is opened within DatabaseEnvironment, this path setting will be ignored during Open(String, HeapDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

See Also

HeapDatabaseConfig Class


BlobDir Field

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig..::.BlobDir Field
HeapDatabaseConfig Class See Also Send Feedback
The path of the directory where blobs are stored.

If the database is opened within DatabaseEnvironment, this path setting will be ignored during Open(String, HeapDatabaseConfig). Use BlobDir to identify the current storage location of blobs after opening the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BlobDir
Visual Basic (Declaration)
Public BlobDir As String
Visual C++
public:
String^ BlobDir

See Also

HeapDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig..::.Creation Field
HeapDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, HeapDatabaseConfig) fails.

See Also

HeapDatabaseConfig Class


HeapDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig Methods
HeapDatabaseConfig Class See Also Send Feedback

The HeapDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MaxSize | Set the maximum on-disk database file size used by the database. Attempts to update or create records in a database that have reached this file size limit throw a HeapFullException. If this value is not set, the database file size can grow infinitely.
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HeapDatabaseConfig Class


MaxSize Method

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig..::.MaxSize Method
HeapDatabaseConfig Class See Also Send Feedback
Set the maximum on-disk database file size used by the database. Attempts to update or create records in a database that have reached this file size limit throw a HeapFullException. If this value is not set, the database file size can grow infinitely.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void MaxSize(
    uint GBytes,
    uint Bytes
)
Visual Basic (Declaration)
Public Sub MaxSize ( _
    GBytes As UInteger, _
    Bytes As UInteger _
)
Visual C++
public:
void MaxSize(
    unsigned int GBytes,
    unsigned int Bytes
)

Parameters

GBytes
Type: System..::.UInt32
The size of the database is set to GBytes gigabytes plus Bytes.
Bytes
Type: System..::.UInt32
The size of the database is set to GBytes gigabytes plus Bytes.

Remarks

The size specified must be at least three times the database page size. The database must contain at least three database pages. You can set the database page size using PageSize. If this value is set for an existing database, the size specified here must match the size used to create the database. Specifying an incorrect size does not result in an error until the database is opened.

See Also

HeapDatabaseConfig Class


HeapDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig Properties
HeapDatabaseConfig Class See Also Send Feedback

The HeapDatabaseConfig type exposes the following members.

Properties

Name | Description
BlobThreshold | The size in bytes which is used to determine when a data item will be stored as a blob. Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob. If the threshold value is 0, blobs are never used by the database. It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
MaxSizeBytes | The bytes component of the maximum on-disk database file size.
MaxSizeGBytes | The gigabytes component of the maximum on-disk database file size.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
RegionSize | The number of pages in a region of the database. If this value is never set, the default region size for the database's page size is used. You can set the database page size using PageSize. If the database already exists, this value is ignored. If the specified region size is larger than the maximum region size for the database's page size, an error is returned when Open(String, DatabaseConfig) is called. The maximum allowable region size is included in the error message.

See Also

HeapDatabaseConfig Class


BlobThreshold Property

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig..::.BlobThreshold Property
HeapDatabaseConfig Class See Also Send Feedback
The size in bytes which is used to determine when a data item will be stored as a blob.

Any data item that is equal to or larger in size than the threshold value is automatically stored as a blob.

If the threshold value is 0, blobs are never used by the database.

It is illegal to enable blob support in the database which is configured as in-memory database or with chksum, encryption, duplicates, sorted duplicates, compression, multiversion concurrency control and transactional read operations with degree 1 isolation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BlobThreshold { get; set; }
Visual Basic (Declaration)
Public Property BlobThreshold As UInteger
Visual C++
public:
property unsigned int BlobThreshold {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

HeapDatabaseConfig Class


MaxSizeBytes Property

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig..::.MaxSizeBytes Property
HeapDatabaseConfig Class See Also Send Feedback
The bytes component of the maximum on-disk database file size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxSizeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxSizeBytes As UInteger
Visual C++
public:
property unsigned int MaxSizeBytes {
    unsigned int get ();
}

See Also

HeapDatabaseConfig Class


MaxSizeGBytes Property

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig..::.MaxSizeGBytes Property
HeapDatabaseConfig Class See Also Send Feedback
The gigabytes component of the maximum on-disk database file size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxSizeGBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxSizeGBytes As UInteger
Visual C++
public:
property unsigned int MaxSizeGBytes {
    unsigned int get ();
}

See Also

HeapDatabaseConfig Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
HeapDatabaseConfig..::.RegionSize Property
HeapDatabaseConfig Class See Also Send Feedback
The number of pages in a region of the database. If this value is never set, the default region size for the database's page size is used. You can set the database page size using PageSize. If the database already exists, this value is ignored. If the specified region size is larger than the maximum region size for the database's page size, an error is returned when Open(String, DatabaseConfig) is called. The maximum allowable region size is included in the error message.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RegionSize { get; set; }
Visual Basic (Declaration)
Public Property RegionSize As UInteger
Visual C++
public:
property unsigned int RegionSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

HeapDatabaseConfig Class


HeapFullException Class

[image]

Berkeley DB .NET API Documentation
HeapFullException Class
Members See Also Send Feedback
An attempt was made to add or update a record in a HeapDatabase. However, the size of the database was constrained using MaxSize(UInt32, UInt32), and that limit has been reached.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HeapFullException : DatabaseException
Visual Basic (Declaration)
Public Class HeapFullException _
    Inherits DatabaseException
Visual C++
public ref class HeapFullException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.HeapFullException

See Also

HeapFullException Members


HeapFullException Members

[image] [image]

Berkeley DB .NET API Documentation
HeapFullException Members
HeapFullException Class Constructors Methods Fields Properties See Also Send Feedback

The HeapFullException type exposes the following members.

Constructors

Name | Description
HeapFullException | Initialize a new instance of the HeapFullException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

HeapFullException Class


HeapFullException Constructor

[image]

Berkeley DB .NET API Documentation
HeapFullException Constructor
HeapFullException Class See Also Send Feedback
Initialize a new instance of the HeapFullException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapFullException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
HeapFullException()

See Also

HeapFullException Class


HeapFullException Fields

[image] [image]

Berkeley DB .NET API Documentation
HeapFullException Fields
HeapFullException Class See Also Send Feedback

The HeapFullException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

HeapFullException Class


HeapFullException Methods

[image] [image]

Berkeley DB .NET API Documentation
HeapFullException Methods
HeapFullException Class See Also Send Feedback

The HeapFullException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

HeapFullException Class


HeapFullException Properties

[image] [image]

Berkeley DB .NET API Documentation
HeapFullException Properties
HeapFullException Class See Also Send Feedback

The HeapFullException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

HeapFullException Class


HeapRecordId Class

[image]

Berkeley DB .NET API Documentation
HeapRecordId Class
Members See Also Send Feedback
Content used for the key in a Heap database record. Berkeley DB creates this value for you when you create a record in a Heap database. You should never create this structure yourself; Berkeley DB must create it for you. This structure is returned in the key DatabaseEntry parameter of the method that you use to add a record to the Heap database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HeapRecordId
Visual Basic (Declaration)
Public Class HeapRecordId
Visual C++
public ref class HeapRecordId

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.HeapRecordId

See Also

HeapRecordId Members


HeapRecordId Members

[image] [image]

Berkeley DB .NET API Documentation
HeapRecordId Members
HeapRecordId Class Constructors Methods Properties See Also Send Feedback

The HeapRecordId type exposes the following members.

Constructors

Name | Description
HeapRecordId | Construct a new record id, given a page number and index.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
fromArray | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
toArray | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Index | Index in the offset table where the record can be found.
PageNumber | The database page number where the record is stored.

See Also

HeapRecordId Class


HeapRecordId Constructor

[image]

Berkeley DB .NET API Documentation
HeapRecordId Constructor
HeapRecordId Class See Also Send Feedback
Construct a new record id, given a page number and index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HeapRecordId(
    uint pgno,
    ushort indx
)
Visual Basic (Declaration)
Public Sub New ( _
    pgno As UInteger, _
    indx As UShort _
)
Visual C++
public:
HeapRecordId(
    unsigned int pgno,
    unsigned short indx
)

Parameters

pgno
Type: System..::.UInt32
The database page number where the record is stored.
indx
Type: System..::.UInt16
Index in the offset table where the record can be found.

See Also

HeapRecordId Class


HeapRecordId Methods

[image] [image]

Berkeley DB .NET API Documentation
HeapRecordId Methods
HeapRecordId Class See Also Send Feedback

The HeapRecordId type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
fromArray | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
toArray | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HeapRecordId Class


fromArray Method

[image] [image]

Berkeley DB .NET API Documentation
HeapRecordId..::.fromArray Method
HeapRecordId Class See Also Send Feedback

Overload List

Name | Description
fromArray(array<Byte>[]()[]) | Construct a HeapRecordId from a byte array, typically Data.
fromArray(array<Byte>[]()[], ByteOrder) | Construct a HeapRecordId from a byte array, typically Data.

See Also

HeapRecordId Class
HeapRecordId Members


fromArray Method (Byte[])

[image]

Berkeley DB .NET API Documentation
HeapRecordId..::.fromArray Method (array<Byte>[]()[])
HeapRecordId Class See Also Send Feedback
Construct a HeapRecordId from a byte array, typically Data.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static HeapRecordId fromArray(
    byte[] array
)
Visual Basic (Declaration)
Public Shared Function fromArray ( _
    array As Byte() _
) As HeapRecordId
Visual C++
public:
static HeapRecordId^ fromArray(
    array<unsigned char>^ array
)

Parameters

array
Type: array< System..::.Byte >[]()[]
The array representing the record id

Return Value

A new HeapRecordId

See Also

HeapRecordId Class
fromArray Overload


fromArray Method (Byte[], ByteOrder)

[image]

Berkeley DB .NET API Documentation
HeapRecordId..::.fromArray Method (array<Byte>[]()[], ByteOrder)
HeapRecordId Class See Also Send Feedback
Construct a HeapRecordId from a byte array, typically Data.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static HeapRecordId fromArray(
    byte[] array,
    ByteOrder order
)
Visual Basic (Declaration)
Public Shared Function fromArray ( _
    array As Byte(), _
    order As ByteOrder _
) As HeapRecordId
Visual C++
public:
static HeapRecordId^ fromArray(
    array<unsigned char>^ array,
    ByteOrder^ order
)

Parameters

array
Type: array< System..::.Byte >[]()[]
The array representing the record id
order
Type: BerkeleyDB..::.ByteOrder
The byte order of the data in array

Return Value

A new HeapRecordId

See Also

HeapRecordId Class
fromArray Overload


toArray Method

[image] [image]

Berkeley DB .NET API Documentation
HeapRecordId..::.toArray Method
HeapRecordId Class See Also Send Feedback

Overload List

Name | Description
toArray()()() | Return a byte array representing this record id.
toArray(ByteOrder) | Return a byte array representing this record id.

See Also

HeapRecordId Class
HeapRecordId Members


toArray Method

[image]

Berkeley DB .NET API Documentation
HeapRecordId..::.toArray Method
HeapRecordId Class See Also Send Feedback
Return a byte array representing this record id.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public byte[] toArray()
Visual Basic (Declaration)
Public Function toArray As Byte()
Visual C++
public:
array<unsigned char>^ toArray()

Return Value

A byte array representing this record id.

See Also

HeapRecordId Class
toArray Overload


toArray Method (ByteOrder)

[image]

Berkeley DB .NET API Documentation
HeapRecordId..::.toArray Method (ByteOrder)
HeapRecordId Class See Also Send Feedback
Return a byte array representing this record id.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public byte[] toArray(
    ByteOrder order
)
Visual Basic (Declaration)
Public Function toArray ( _
    order As ByteOrder _
) As Byte()
Visual C++
public:
array<unsigned char>^ toArray(
    ByteOrder^ order
)

Parameters

order
Type: BerkeleyDB..::.ByteOrder
The byte order to use when constructing the array.

Return Value

A byte array representing this record id.

See Also

HeapRecordId Class
toArray Overload


HeapRecordId Properties

[image] [image]

Berkeley DB .NET API Documentation
HeapRecordId Properties
HeapRecordId Class See Also Send Feedback

The HeapRecordId type exposes the following members.

Properties

Name | Description
Index | Index in the offset table where the record can be found.
PageNumber | The database page number where the record is stored.

See Also

HeapRecordId Class


Index Property

[image]

Berkeley DB .NET API Documentation
HeapRecordId..::.Index Property
HeapRecordId Class See Also Send Feedback
Index in the offset table where the record can be found.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ushort Index { get; set; }
Visual Basic (Declaration)
Public Property Index As UShort
Visual C++
public:
property unsigned short Index {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

HeapRecordId Class


PageNumber Property

[image]

Berkeley DB .NET API Documentation
HeapRecordId..::.PageNumber Property
HeapRecordId Class See Also Send Feedback
The database page number where the record is stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageNumber { get; set; }
Visual Basic (Declaration)
Public Property PageNumber As UInteger
Visual C++
public:
property unsigned int PageNumber {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

HeapRecordId Class


HeapStats Class

[image]

Berkeley DB .NET API Documentation
HeapStats Class
Members See Also Send Feedback
Statistical information about a QueueDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class HeapStats
Visual Basic (Declaration)
Public Class HeapStats
Visual C++
public ref class HeapStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.HeapStats

See Also

HeapStats Members


HeapStats Members

[image] [image]

Berkeley DB .NET API Documentation
HeapStats Members
HeapStats Class Methods Properties See Also Send Feedback

The HeapStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
MagicNumber | Magic number that identifies the file as a Heap file.
MetadataFlags | Reports internal flags. For internal use only.
nBlobRecords | Number of blob records.
nPages | The number of pages in the database.
nRecords | Reports the number of records in the Heap database.
nRegions | The number of regions in the Heap database.
PageSize | The underlying database page (and bucket) size, in bytes.
RegionSize | The region size of the Heap database.
Version | The version of the Heap database.

See Also

HeapStats Class


HeapStats Methods

[image] [image]

Berkeley DB .NET API Documentation
HeapStats Methods
HeapStats Class See Also Send Feedback

The HeapStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HeapStats Class


HeapStats Properties

[image] [image]

Berkeley DB .NET API Documentation
HeapStats Properties
HeapStats Class See Also Send Feedback

The HeapStats type exposes the following members.

Properties

Name | Description
MagicNumber | Magic number that identifies the file as a Heap file.
MetadataFlags | Reports internal flags. For internal use only.
nBlobRecords | Number of blob records.
nPages | The number of pages in the database.
nRecords | Reports the number of records in the Heap database.
nRegions | The number of regions in the Heap database.
PageSize | The underlying database page (and bucket) size, in bytes.
RegionSize | The region size of the Heap database.
Version | The version of the Heap database.

See Also

HeapStats Class


MagicNumber Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.MagicNumber Property
HeapStats Class See Also Send Feedback
Magic number that identifies the file as a Heap file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MagicNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property MagicNumber As UInteger
Visual C++
public:
property unsigned int MagicNumber {
    unsigned int get ();
}

See Also

HeapStats Class


MetadataFlags Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.MetadataFlags Property
HeapStats Class See Also Send Feedback
Reports internal flags. For internal use only.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MetadataFlags { get; }
Visual Basic (Declaration)
Public ReadOnly Property MetadataFlags As UInteger
Visual C++
public:
property unsigned int MetadataFlags {
    unsigned int get ();
}

See Also

HeapStats Class


nBlobRecords Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.nBlobRecords Property
HeapStats Class See Also Send Feedback
Number of blob records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nBlobRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property nBlobRecords As UInteger
Visual C++
public:
property unsigned int nBlobRecords {
    unsigned int get ();
}

See Also

HeapStats Class


nPages Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.nPages Property
HeapStats Class See Also Send Feedback
The number of pages in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property nPages As UInteger
Visual C++
public:
property unsigned int nPages {
    unsigned int get ();
}

See Also

HeapStats Class


nRecords Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.nRecords Property
HeapStats Class See Also Send Feedback
Reports the number of records in the Heap database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property nRecords As UInteger
Visual C++
public:
property unsigned int nRecords {
    unsigned int get ();
}

See Also

HeapStats Class


nRegions Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.nRegions Property
HeapStats Class See Also Send Feedback
The number of regions in the Heap database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nRegions { get; }
Visual Basic (Declaration)
Public ReadOnly Property nRegions As UInteger
Visual C++
public:
property unsigned int nRegions {
    unsigned int get ();
}

See Also

HeapStats Class


PageSize Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.PageSize Property
HeapStats Class See Also Send Feedback
The underlying database page (and bucket) size, in bytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As UInteger
Visual C++
public:
property unsigned int PageSize {
    unsigned int get ();
}

See Also

HeapStats Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.RegionSize Property
HeapStats Class See Also Send Feedback
The region size of the Heap database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RegionSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionSize As UInteger
Visual C++
public:
property unsigned int RegionSize {
    unsigned int get ();
}

See Also

HeapStats Class


Version Property

[image]

Berkeley DB .NET API Documentation
HeapStats..::.Version Property
HeapStats Class See Also Send Feedback
The version of the Heap database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As UInteger
Visual C++
public:
property unsigned int Version {
    unsigned int get ();
}

See Also

HeapStats Class


IBackup Interface

[image]

Berkeley DB .NET API Documentation
IBackup Interface
Members See Also Send Feedback
An interface that can optionally be used to override the default behavior performed by the Backup(String, BackupOptions) and BackupDatabase(String, String, Boolean) methods. Implementation of this interface is required if the DatabaseEnvironment.backup or DatabaseEnvironment.backupDatabase target parameter is null. You configure the environment with this handler via BackupHandler.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public interface IBackup
Visual Basic (Declaration)
Public Interface IBackup
Visual C++
public interface class IBackup

See Also

IBackup Members


IBackup Members

[image] [image]

Berkeley DB .NET API Documentation
IBackup Members
IBackup Interface Methods See Also Send Feedback

The IBackup type exposes the following members.

Methods

Name | Description
Close | Called when ending a backup and closing a backup target.
Open | Called when a target location is opened during a backup. This method should do whatever is necessary to prepare the backup destination for writing the data.
Write | Called when writing data during a backup.

See Also

IBackup Interface


IBackup Methods

[image] [image]

Berkeley DB .NET API Documentation
IBackup Methods
IBackup Interface See Also Send Feedback

The IBackup type exposes the following members.

Methods

Name | Description
Close | Called when ending a backup and closing a backup target.
Open | Called when a target location is opened during a backup. This method should do whatever is necessary to prepare the backup destination for writing the data.
Write | Called when writing data during a backup.

See Also

IBackup Interface


Close Method

[image]

Berkeley DB .NET API Documentation
IBackup..::.Close Method
IBackup Interface See Also Send Feedback
Called when ending a backup and closing a backup target.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
int Close(
    string dbname
)
Visual Basic (Declaration)
Function Close ( _
    dbname As String _
) As Integer
Visual C++
int Close(
    String^ dbname
)

Parameters

dbname
Type: System..::.String
The name of the database that has been backed up.

Return Value

0 on success, non-zero on error.

See Also

IBackup Interface


Open Method

[image]

Berkeley DB .NET API Documentation
IBackup..::.Open Method
IBackup Interface See Also Send Feedback
Called when a target location is opened during a backup. This method should do whatever is necessary to prepare the backup destination for writing the data.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
int Open(
    string dbname,
    string target
)
Visual Basic (Declaration)
Function Open ( _
    dbname As String, _
    target As String _
) As Integer
Visual C++
int Open(
    String^ dbname,
    String^ target
)

Parameters

dbname
Type: System..::.String
The backup's directory destination.
target
Type: System..::.String
The name of the database being backed up.

Return Value

0 on success, non-zero on error.

See Also

IBackup Interface


Write Method

[image]

Berkeley DB .NET API Documentation
IBackup..::.Write Method
IBackup Interface See Also Send Feedback
Called when writing data during a backup.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
int Write(
    byte[] data,
    long offset,
    int count
)
Visual Basic (Declaration)
Function Write ( _
    data As Byte(), _
    offset As Long, _
    count As Integer _
) As Integer
Visual C++
int Write(
    array<unsigned char>^ data,
    long long offset,
    int count
)

Parameters

data
Type: array< System..::.Byte >[]()[]
Identifies the buffer which contains the data to be backed up.
offset
Type: System..::.Int64
Identifies the position in the file where bytes from buf should be written.
count
Type: System..::.Int32
Identifies the number of bytes to write to the file from the buffer.

Return Value

0 on success, non-zero on error.

See Also

IBackup Interface


Isolation Enumeration

[image]

Berkeley DB .NET API Documentation
Isolation Enumeration
See Also Send Feedback
Specify the degree of isolation for transactional operations

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum Isolation
Visual Basic (Declaration)
Public Enumeration Isolation
Visual C++
public enum class Isolation

Members

Member name | Description
DEGREE_ONE | Read operations on the database may request the return of modified but not yet committed data.
DEGREE_TWO | Provide for cursor stability but not repeatable reads. Data items which have been previously read by a transaction may be deleted or modified by other transactions before the original transaction completes.
DEGREE_THREE | For the life of the transaction, every time a thread of control reads a data item, it is unchanged from its previous value (assuming, of course, the thread of control does not itself modify the item). This is Berkeley DB's default degree of isolation.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


JoinCursor Class

[image]

Berkeley DB .NET API Documentation
JoinCursor Class
Members See Also Send Feedback
A class representing a join cursor, for use in performing equality or natural joins on secondary indices. For information on how to organize your data to use this functionality, see Equality join in the Programmer's Reference Guide.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class JoinCursor : IDisposable, IEnumerable<KeyValuePair<DatabaseEntry, DatabaseEntry>>,
    IEnumerable
Visual Basic (Declaration)
Public Class JoinCursor _
    Implements IDisposable, IEnumerable(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry)),  _
    IEnumerable
Visual C++
public ref class JoinCursor : IDisposable,
    IEnumerable<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>, IEnumerable

Remarks

JoinCursor does not support many of the operations offered by Cursor and is not a subclass of Cursor.

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.JoinCursor

See Also

JoinCursor Members
BerkeleyDB Namespace
Database..::.Join(array<SecondaryCursor>[]()[], Boolean)


JoinCursor Members

[image] [image]

Berkeley DB .NET API Documentation
JoinCursor Members
JoinCursor Class Methods Properties See Also Send Feedback

The JoinCursor type exposes the following members.

Methods

Name | Description
Close | Discard the cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again.
Dispose | Release the resources held by this object, and close the cursor if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the JoinCursor.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MoveNext | Overloaded.
MoveNextItem | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Current | The key/data pair at which the cursor currently points.

See Also

JoinCursor Class


JoinCursor Methods

[image] [image]

Berkeley DB .NET API Documentation
JoinCursor Methods
JoinCursor Class See Also Send Feedback

The JoinCursor type exposes the following members.

Methods

Name | Description
Close | Discard the cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again.
Dispose | Release the resources held by this object, and close the cursor if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the JoinCursor.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
MoveNext | Overloaded.
MoveNextItem | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

JoinCursor Class


Close Method

[image]

Berkeley DB .NET API Documentation
JoinCursor..::.Close Method
JoinCursor Class See Also Send Feedback

Discard the cursor.

It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed.

After Close has been called, regardless of its result, the object may not be used again.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

Exceptions

Exception | Condition
BerkeleyDB..::.DeadlockException |

See Also

JoinCursor Class


Dispose Method

[image]

Berkeley DB .NET API Documentation
JoinCursor..::.Dispose Method
JoinCursor Class See Also Send Feedback
Release the resources held by this object, and close the cursor if it is still open.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

JoinCursor Class


GetEnumerator Method

[image]

Berkeley DB .NET API Documentation
JoinCursor..::.GetEnumerator Method
JoinCursor Class See Also Send Feedback
Returns an enumerator that iterates through the JoinCursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public IEnumerator<KeyValuePair<DatabaseEntry, DatabaseEntry>> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry))
Visual C++
public:
virtual IEnumerator<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>^ GetEnumerator() sealed

Return Value

An enumerator for the Cursor.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

Remarks

The enumerator begins at the cursor's current position (or the first record if the cursor has not yet been positioned) and iterate forwards (i.e. in the direction of MoveNext()()()) over the remaining records.

See Also

JoinCursor Class


MoveNext Method

[image] [image]

Berkeley DB .NET API Documentation
JoinCursor..::.MoveNext Method
JoinCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNext()()() | Iterate over the values associated with the keys to which each SecondaryCursor passed to Join(array<SecondaryCursor>[]()[], Boolean) was initialized. Any data value that appears in all SecondaryCursors is then used as a key into the primary, and the key/data pair found in the primary is stored in Current.
MoveNext(LockingInfo) | Iterate over the values associated with the keys to which each SecondaryCursor passed to Join(array<SecondaryCursor>[]()[], Boolean) was initialized. Any data value that appears in all SecondaryCursors is then used as a key into the primary, and the key/data pair found in the primary is stored in Current.

See Also

JoinCursor Class
JoinCursor Members


MoveNext Method

[image]

Berkeley DB .NET API Documentation
JoinCursor..::.MoveNext Method
JoinCursor Class See Also Send Feedback
Iterate over the values associated with the keys to which each SecondaryCursor passed to Join(array<SecondaryCursor>[]()[], Boolean) was initialized. Any data value that appears in all SecondaryCursors is then used as a key into the primary, and the key/data pair found in the primary is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext()
Visual Basic (Declaration)
Public Function MoveNext As Boolean
Visual C++
public:
bool MoveNext()

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

JoinCursor Class
MoveNext Overload


MoveNext Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
JoinCursor..::.MoveNext Method (LockingInfo)
JoinCursor Class See Also Send Feedback
Iterate over the values associated with the keys to which each SecondaryCursor passed to Join(array<SecondaryCursor>[]()[], Boolean) was initialized. Any data value that appears in all SecondaryCursors is then used as a key into the primary, and the key/data pair found in the primary is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNext ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNext(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

See Also

JoinCursor Class
MoveNext Overload


MoveNextItem Method

[image] [image]

Berkeley DB .NET API Documentation
JoinCursor..::.MoveNextItem Method
JoinCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextItem()()() | Iterate over the values associated with the keys to which each SecondaryCursor passed to Join(array<SecondaryCursor>[]()[], Boolean) was initialized. Any data value that appears in all SecondaryCursors is then stored in Current.Key.
MoveNextItem(LockingInfo) | Iterate over the values associated with the keys to which each SecondaryCursor passed to Join(array<SecondaryCursor>[]()[], Boolean) was initialized. Any data value that appears in all SecondaryCursors is then stored in Current.Key.

See Also

JoinCursor Class
JoinCursor Members


MoveNextItem Method

[image]

Berkeley DB .NET API Documentation
JoinCursor..::.MoveNextItem Method
JoinCursor Class See Also Send Feedback
Iterate over the values associated with the keys to which each SecondaryCursor passed to Join(array<SecondaryCursor>[]()[], Boolean) was initialized. Any data value that appears in all SecondaryCursors is then stored in Current.Key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextItem()
Visual Basic (Declaration)
Public Function MoveNextItem As Boolean
Visual C++
public:
bool MoveNextItem()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

Current.Value contains an empty DatabaseEntry.

See Also

JoinCursor Class
MoveNextItem Overload


MoveNextItem Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
JoinCursor..::.MoveNextItem Method (LockingInfo)
JoinCursor Class See Also Send Feedback
Iterate over the values associated with the keys to which each SecondaryCursor passed to Join(array<SecondaryCursor>[]()[], Boolean) was initialized. Any data value that appears in all SecondaryCursors is then stored in Current.Key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextItem(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextItem ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextItem(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

Current.Value contains an empty DatabaseEntry.

See Also

JoinCursor Class
MoveNextItem Overload


JoinCursor Properties

[image] [image]

Berkeley DB .NET API Documentation
JoinCursor Properties
JoinCursor Class See Also Send Feedback

The JoinCursor type exposes the following members.

Properties

Name | Description
Current | The key/data pair at which the cursor currently points.

See Also

JoinCursor Class


Current Property

[image]

Berkeley DB .NET API Documentation
JoinCursor..::.Current Property
JoinCursor Class See Also Send Feedback
The key/data pair at which the cursor currently points.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, DatabaseEntry> Current { get; private set; }
Visual Basic (Declaration)
Public Property Current As KeyValuePair(Of DatabaseEntry, DatabaseEntry)
Visual C++
public:
property KeyValuePair<DatabaseEntry^, DatabaseEntry^> Current {
    KeyValuePair<DatabaseEntry^, DatabaseEntry^> get ();
    void set (KeyValuePair<DatabaseEntry^, DatabaseEntry^> value);
}

See Also

JoinCursor Class


KeyEmptyException Class

[image]

Berkeley DB .NET API Documentation
KeyEmptyException Class
Members See Also Send Feedback
The requested key/data pair logically exists but was never explicitly created by the application, or that the requested key/data pair was deleted and never re-created. In addition, the Queue access method throws a KeyEmptyException for records that were created as part of a transaction that was later aborted and never re-created.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class KeyEmptyException : DatabaseException
Visual Basic (Declaration)
Public Class KeyEmptyException _
    Inherits DatabaseException
Visual C++
public ref class KeyEmptyException : public DatabaseException

Remarks

The Recno and Queue access methods automatically create key/data pairs under some circumstances.

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.KeyEmptyException

See Also

KeyEmptyException Members


KeyEmptyException Members

[image] [image]

Berkeley DB .NET API Documentation
KeyEmptyException Members
KeyEmptyException Class Constructors Methods Fields Properties See Also Send Feedback

The KeyEmptyException type exposes the following members.

Constructors

Name | Description
KeyEmptyException | Initialize a new instance of the KeyEmptyException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

KeyEmptyException Class


KeyEmptyException Constructor

[image]

Berkeley DB .NET API Documentation
KeyEmptyException Constructor
KeyEmptyException Class See Also Send Feedback
Initialize a new instance of the KeyEmptyException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyEmptyException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
KeyEmptyException()

See Also

KeyEmptyException Class


KeyEmptyException Fields

[image] [image]

Berkeley DB .NET API Documentation
KeyEmptyException Fields
KeyEmptyException Class See Also Send Feedback

The KeyEmptyException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

KeyEmptyException Class


KeyEmptyException Methods

[image] [image]

Berkeley DB .NET API Documentation
KeyEmptyException Methods
KeyEmptyException Class See Also Send Feedback

The KeyEmptyException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

KeyEmptyException Class


KeyEmptyException Properties

[image] [image]

Berkeley DB .NET API Documentation
KeyEmptyException Properties
KeyEmptyException Class See Also Send Feedback

The KeyEmptyException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

KeyEmptyException Class


KeyExistException Class

[image]

Berkeley DB .NET API Documentation
KeyExistException Class
Members See Also Send Feedback
A key/data pair was inserted into the database using PutNoOverwrite(MultipleKeyDatabaseEntry) and the key already exists in the database, or using PutNoDuplicate(DatabaseEntry, DatabaseEntry) or PutNoDuplicate(DatabaseEntry, DatabaseEntry) and the key/data pair already exists in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class KeyExistException : DatabaseException
Visual Basic (Declaration)
Public Class KeyExistException _
    Inherits DatabaseException
Visual C++
public ref class KeyExistException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.KeyExistException

See Also

KeyExistException Members


KeyExistException Members

[image] [image]

Berkeley DB .NET API Documentation
KeyExistException Members
KeyExistException Class Constructors Methods Fields Properties See Also Send Feedback

The KeyExistException type exposes the following members.

Constructors

Name | Description
KeyExistException | Initialize a new instance of the KeyExistException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

KeyExistException Class


KeyExistException Constructor

[image]

Berkeley DB .NET API Documentation
KeyExistException Constructor
KeyExistException Class See Also Send Feedback
Initialize a new instance of the KeyExistException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyExistException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
KeyExistException()

See Also

KeyExistException Class


KeyExistException Fields

[image] [image]

Berkeley DB .NET API Documentation
KeyExistException Fields
KeyExistException Class See Also Send Feedback

The KeyExistException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

KeyExistException Class


KeyExistException Methods

[image] [image]

Berkeley DB .NET API Documentation
KeyExistException Methods
KeyExistException Class See Also Send Feedback

The KeyExistException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

KeyExistException Class


KeyExistException Properties

[image] [image]

Berkeley DB .NET API Documentation
KeyExistException Properties
KeyExistException Class See Also Send Feedback

The KeyExistException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

KeyExistException Class


KeyRange Class

[image]

Berkeley DB .NET API Documentation
KeyRange Class
Members See Also Send Feedback

A class representing an estimate of the proportion of keys that are less than, equal to, and greater than a given key.

Values are in the range of 0 to 1; for example, if the field less is 0.05, 5% of the keys in the database are less than the key parameter. The value for equal is zero if there is no matching key, and is non-zero otherwise.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class KeyRange
Visual Basic (Declaration)
Public Class KeyRange
Visual C++
public ref class KeyRange

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.KeyRange

See Also

KeyRange Members


KeyRange Members

[image] [image]

Berkeley DB .NET API Documentation
KeyRange Members
KeyRange Class Methods Properties See Also Send Feedback

The KeyRange type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Equal | A value between 0 and 1, the proportion of keys equal to the specified key.
Greater | A value between 0 and 1, the proportion of keys greater than the specified key.
Less | A value between 0 and 1, the proportion of keys less than the specified key.

See Also

KeyRange Class


KeyRange Methods

[image] [image]

Berkeley DB .NET API Documentation
KeyRange Methods
KeyRange Class See Also Send Feedback

The KeyRange type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

KeyRange Class


KeyRange Properties

[image] [image]

Berkeley DB .NET API Documentation
KeyRange Properties
KeyRange Class See Also Send Feedback

The KeyRange type exposes the following members.

Properties

Name | Description
Equal | A value between 0 and 1, the proportion of keys equal to the specified key.
Greater | A value between 0 and 1, the proportion of keys greater than the specified key.
Less | A value between 0 and 1, the proportion of keys less than the specified key.

See Also

KeyRange Class


Equal Property

[image]

Berkeley DB .NET API Documentation
KeyRange..::.Equal Property
KeyRange Class See Also Send Feedback
A value between 0 and 1, the proportion of keys equal to the specified key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public double Equal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Equal As Double
Visual C++
public:
property double Equal {
    double get ();
}

See Also

KeyRange Class


Greater Property

[image]

Berkeley DB .NET API Documentation
KeyRange..::.Greater Property
KeyRange Class See Also Send Feedback
A value between 0 and 1, the proportion of keys greater than the specified key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public double Greater { get; }
Visual Basic (Declaration)
Public ReadOnly Property Greater As Double
Visual C++
public:
property double Greater {
    double get ();
}

See Also

KeyRange Class


Less Property

[image]

Berkeley DB .NET API Documentation
KeyRange..::.Less Property
KeyRange Class See Also Send Feedback
A value between 0 and 1, the proportion of keys less than the specified key.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public double Less { get; }
Visual Basic (Declaration)
Public ReadOnly Property Less As Double
Visual C++
public:
property double Less {
    double get ();
}

See Also

KeyRange Class


LeaseExpiredException Class

[image]

Berkeley DB .NET API Documentation
LeaseExpiredException Class
Members See Also Send Feedback
The site's replication master lease has expired.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LeaseExpiredException : DatabaseException
Visual Basic (Declaration)
Public Class LeaseExpiredException _
    Inherits DatabaseException
Visual C++
public ref class LeaseExpiredException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.LeaseExpiredException

See Also

LeaseExpiredException Members


LeaseExpiredException Members

[image] [image]

Berkeley DB .NET API Documentation
LeaseExpiredException Members
LeaseExpiredException Class Constructors Methods Fields Properties See Also Send Feedback

The LeaseExpiredException type exposes the following members.

Constructors

Name | Description
LeaseExpiredException | Initialize a new instance of the LeaseExpiredException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LeaseExpiredException Class


LeaseExpiredException Constructor

[image]

Berkeley DB .NET API Documentation
LeaseExpiredException Constructor
LeaseExpiredException Class See Also Send Feedback
Initialize a new instance of the LeaseExpiredException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LeaseExpiredException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LeaseExpiredException()

See Also

LeaseExpiredException Class


LeaseExpiredException Fields

[image] [image]

Berkeley DB .NET API Documentation
LeaseExpiredException Fields
LeaseExpiredException Class See Also Send Feedback

The LeaseExpiredException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

LeaseExpiredException Class


LeaseExpiredException Methods

[image] [image]

Berkeley DB .NET API Documentation
LeaseExpiredException Methods
LeaseExpiredException Class See Also Send Feedback

The LeaseExpiredException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LeaseExpiredException Class


LeaseExpiredException Properties

[image] [image]

Berkeley DB .NET API Documentation
LeaseExpiredException Properties
LeaseExpiredException Class See Also Send Feedback

The LeaseExpiredException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LeaseExpiredException Class


LockingConfig Class

[image]

Berkeley DB .NET API Documentation
LockingConfig Class
Members See Also Send Feedback
A class representing configuration parameters for a DatabaseEnvironment's locking subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LockingConfig
Visual Basic (Declaration)
Public Class LockingConfig
Visual C++
public ref class LockingConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.LockingConfig

See Also

LockingConfig Members


LockingConfig Members

[image] [image]

Berkeley DB .NET API Documentation
LockingConfig Members
LockingConfig Class Constructors Methods Fields Properties See Also Send Feedback

The LockingConfig type exposes the following members.

Constructors

Name | Description
LockingConfig | Initializes a new instance of the LockingConfig class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
DeadlockResolution | If non-null, the deadlock detector is to be run whenever a lock conflict occurs, lock request(s) should be rejected according to the specified policy.

Properties

Name | Description
Conflicts | The locking conflicts matrix.
InitLockCount | The initial number of locks created by the Berkeley DB environment
InitLockerCount | The initial number of simultaneous locking entities created by the Berkeley DB environment
InitLockObjectCount | The initial number of lock objects created by the Berkeley DB environment
MaxLockers | The maximum number of simultaneous locking entities supported by the Berkeley DB environment
MaxLocks | The maximum number of locks supported by the Berkeley DB environment.
MaxObjects | The maximum number of locked objects supported by the Berkeley DB environment.
Partitions | The number of lock table partitions in the Berkeley DB environment.
TableSize | Set the number of buckets in the lock object hash table in the Berkeley DB environment.

See Also

LockingConfig Class


LockingConfig Constructor

[image]

Berkeley DB .NET API Documentation
LockingConfig Constructor
LockingConfig Class See Also Send Feedback
Initializes a new instance of the LockingConfig class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LockingConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LockingConfig()

See Also

LockingConfig Class


LockingConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
LockingConfig Fields
LockingConfig Class See Also Send Feedback

The LockingConfig type exposes the following members.

Fields

Name | Description
DeadlockResolution | If non-null, the deadlock detector is to be run whenever a lock conflict occurs, lock request(s) should be rejected according to the specified policy.

See Also

LockingConfig Class


DeadlockResolution Field

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.DeadlockResolution Field
LockingConfig Class See Also Send Feedback
If non-null, the deadlock detector is to be run whenever a lock conflict occurs, lock request(s) should be rejected according to the specified policy.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DeadlockPolicy DeadlockResolution
Visual Basic (Declaration)
Public DeadlockResolution As DeadlockPolicy
Visual C++
public:
DeadlockPolicy^ DeadlockResolution

Remarks

As transactions acquire locks on behalf of a single locker ID, rejecting a lock request associated with a transaction normally requires the transaction be aborted.

See Also

LockingConfig Class


LockingConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
LockingConfig Methods
LockingConfig Class See Also Send Feedback

The LockingConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LockingConfig Class


LockingConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
LockingConfig Properties
LockingConfig Class See Also Send Feedback

The LockingConfig type exposes the following members.

Properties

Name | Description
Conflicts | The locking conflicts matrix.
InitLockCount | The initial number of locks created by the Berkeley DB environment
InitLockerCount | The initial number of simultaneous locking entities created by the Berkeley DB environment
InitLockObjectCount | The initial number of lock objects created by the Berkeley DB environment
MaxLockers | The maximum number of simultaneous locking entities supported by the Berkeley DB environment
MaxLocks | The maximum number of locks supported by the Berkeley DB environment.
MaxObjects | The maximum number of locked objects supported by the Berkeley DB environment.
Partitions | The number of lock table partitions in the Berkeley DB environment.
TableSize | Set the number of buckets in the lock object hash table in the Berkeley DB environment.

See Also

LockingConfig Class


Conflicts Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.Conflicts Property
LockingConfig Class See Also Send Feedback
The locking conflicts matrix.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public byte[,] Conflicts { get; set; }
Visual Basic (Declaration)
Public Property Conflicts As Byte(,)
Visual C++
public:
property array<unsigned char,2>^ Conflicts {
    array<unsigned char,2>^ get ();
    void set (array<unsigned char,2>^ value);
}

Remarks

If Conflicts is never set, a standard conflicts array is used; see Standard Lock Modes in the Programmer's Reference Guide for more information.

Conflicts parameter is an nmodes by nmodes array. A non-0 value for the array element indicates that requested_mode and held_mode conflict:

CopyC#
conflicts[requested_mode][held_mode]

The not-granted mode must be represented by 0.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of Conflicts is ignored.

See Also

LockingConfig Class


InitLockCount Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.InitLockCount Property
LockingConfig Class See Also Send Feedback
The initial number of locks created by the Berkeley DB environment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLockCount { get; set; }
Visual Basic (Declaration)
Public Property InitLockCount As UInteger
Visual C++
public:
property unsigned int InitLockCount {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to force Berkeley DB to allocate a certain number of locks when the environment is created. This can be useful if an application uses a large number of locks, and experiences performance issues with the default dynamic allocation algorithm.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of InitLocks is ignored.

See Also

LockingConfig Class


InitLockerCount Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.InitLockerCount Property
LockingConfig Class See Also Send Feedback
The initial number of simultaneous locking entities created by the Berkeley DB environment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLockerCount { get; set; }
Visual Basic (Declaration)
Public Property InitLockerCount As UInteger
Visual C++
public:
property unsigned int InitLockerCount {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to force Berkeley DB to allocate a certain number of locker objects when the environment is created. This can be useful if an application uses a large number of locker objects, and experiences performance issues with the default dynamic allocation algorithm.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of InitLockers is ignored.

See Also

LockingConfig Class


InitLockObjectCount Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.InitLockObjectCount Property
LockingConfig Class See Also Send Feedback
The initial number of lock objects created by the Berkeley DB environment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLockObjectCount { get; set; }
Visual Basic (Declaration)
Public Property InitLockObjectCount As UInteger
Visual C++
public:
property unsigned int InitLockObjectCount {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to force Berkeley DB to allocate a certain number of lock objects when the environment is created. This can be useful if an application uses a large number of lock objects, and experiences performance issues with the default dynamic allocation algorithm.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of InitLockObjects is ignored.

See Also

LockingConfig Class


MaxLockers Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.MaxLockers Property
LockingConfig Class See Also Send Feedback
The maximum number of simultaneous locking entities supported by the Berkeley DB environment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLockers { get; set; }
Visual Basic (Declaration)
Public Property MaxLockers As UInteger
Visual C++
public:
property unsigned int MaxLockers {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to estimate how much space to allocate for various lock-table data structures. The default value is 1000 lockers. For specific information on configuring the size of the lock subsystem, see Configuring locking: sizing the system in the Programmer's Reference Guide.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of MaxLockers is ignored.

See Also

LockingConfig Class


MaxLocks Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.MaxLocks Property
LockingConfig Class See Also Send Feedback
The maximum number of locks supported by the Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLocks { get; set; }
Visual Basic (Declaration)
Public Property MaxLocks As UInteger
Visual C++
public:
property unsigned int MaxLocks {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to estimate how much space to allocate for various lock-table data structures. The default value is 1000 lockers. For specific information on configuring the size of the lock subsystem, see Configuring locking: sizing the system in the Programmer's Reference Guide.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of MaxLocks is ignored.

See Also

LockingConfig Class


MaxObjects Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.MaxObjects Property
LockingConfig Class See Also Send Feedback
The maximum number of locked objects supported by the Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxObjects { get; set; }
Visual Basic (Declaration)
Public Property MaxObjects As UInteger
Visual C++
public:
property unsigned int MaxObjects {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to estimate how much space to allocate for various lock-table data structures. The default value is 1000 lockers. For specific information on configuring the size of the lock subsystem, see Configuring locking: sizing the system in the Programmer's Reference Guide.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of MaxObjects is ignored.

See Also

LockingConfig Class


Partitions Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.Partitions Property
LockingConfig Class See Also Send Feedback
The number of lock table partitions in the Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Partitions { get; set; }
Visual Basic (Declaration)
Public Property Partitions As UInteger
Visual C++
public:
property unsigned int Partitions {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The default value is 10 times the number of CPUs on the system if there is more than one CPU. Increasing the number of partitions can provide for greater throughput on a system with multiple CPUs and more than one thread contending for the lock manager. On single processor systems more than one partition may increase the overhead of the lock manager. Systems often report threading contexts as CPUs. If your system does this, set the number of partitions to 1 to get optimal performance.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of Partitions is ignored.

See Also

LockingConfig Class


TableSize Property

[image]

Berkeley DB .NET API Documentation
LockingConfig..::.TableSize Property
LockingConfig Class See Also Send Feedback
Set the number of buckets in the lock object hash table in the Berkeley DB environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TableSize { get; set; }
Visual Basic (Declaration)
Public Property TableSize As UInteger
Visual C++
public:
property unsigned int TableSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The table is generally set to be close to the number of lock objects in the system to avoid collisions and delays in processing of lock operations.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of tablesize is ignored.

See Also

LockingConfig Class


LockingInfo Class

[image]

Berkeley DB .NET API Documentation
LockingInfo Class
Members See Also Send Feedback
A class representing the locking options for Berkeley DB operations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LockingInfo
Visual Basic (Declaration)
Public Class LockingInfo
Visual C++
public ref class LockingInfo

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.LockingInfo

See Also

LockingInfo Members


LockingInfo Members

[image] [image]

Berkeley DB .NET API Documentation
LockingInfo Members
LockingInfo Class Constructors Methods Fields See Also Send Feedback

The LockingInfo type exposes the following members.

Constructors

Name | Description
LockingInfo | Instantiate a new LockingInfo object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
IsolationDegree | The isolation degree of the operation.
ReadModifyWrite | If true and if locking is configured, acquire write locks instead of read locks when doing a read.

See Also

LockingInfo Class


LockingInfo Constructor

[image]

Berkeley DB .NET API Documentation
LockingInfo Constructor
LockingInfo Class See Also Send Feedback
Instantiate a new LockingInfo object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LockingInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LockingInfo()

See Also

LockingInfo Class


LockingInfo Fields

[image] [image]

Berkeley DB .NET API Documentation
LockingInfo Fields
LockingInfo Class See Also Send Feedback

The LockingInfo type exposes the following members.

Fields

Name | Description
IsolationDegree | The isolation degree of the operation.
ReadModifyWrite | If true and if locking is configured, acquire write locks instead of read locks when doing a read.

See Also

LockingInfo Class


IsolationDegree Field

[image]

Berkeley DB .NET API Documentation
LockingInfo..::.IsolationDegree Field
LockingInfo Class See Also Send Feedback
The isolation degree of the operation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Isolation IsolationDegree
Visual Basic (Declaration)
Public IsolationDegree As Isolation
Visual C++
public:
Isolation IsolationDegree

See Also

LockingInfo Class


ReadModifyWrite Field

[image]

Berkeley DB .NET API Documentation
LockingInfo..::.ReadModifyWrite Field
LockingInfo Class See Also Send Feedback
If true and if locking is configured, acquire write locks instead of read locks when doing a read.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReadModifyWrite
Visual Basic (Declaration)
Public ReadModifyWrite As Boolean
Visual C++
public:
bool ReadModifyWrite

Remarks

Setting ReadModifyWrite can eliminate deadlock during a read-modify-write cycle by acquiring the write lock during the read part of the cycle so that another thread of control acquiring a read lock for the same item, in its own read-modify-write cycle, does not result in deadlock.

See Also

LockingInfo Class


LockingInfo Methods

[image] [image]

Berkeley DB .NET API Documentation
LockingInfo Methods
LockingInfo Class See Also Send Feedback

The LockingInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LockingInfo Class


LockNotGrantedException Class

[image]

Berkeley DB .NET API Documentation
LockNotGrantedException Class
Members See Also Send Feedback
If TimeNotGranted is true, database calls timing out based on lock or transaction timeout values throw a LockNotGrantedException, instead of a DeadlockException.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LockNotGrantedException : DatabaseException
Visual Basic (Declaration)
Public Class LockNotGrantedException _
    Inherits DatabaseException
Visual C++
public ref class LockNotGrantedException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.LockNotGrantedException

See Also

LockNotGrantedException Members


LockNotGrantedException Members

[image] [image]

Berkeley DB .NET API Documentation
LockNotGrantedException Members
LockNotGrantedException Class Constructors Methods Fields Properties See Also Send Feedback

The LockNotGrantedException type exposes the following members.

Constructors

Name | Description
LockNotGrantedException | Initialize a new instance of the LockNotGrantedException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LockNotGrantedException Class


LockNotGrantedException Constructor

[image]

Berkeley DB .NET API Documentation
LockNotGrantedException Constructor
LockNotGrantedException Class See Also Send Feedback
Initialize a new instance of the LockNotGrantedException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LockNotGrantedException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LockNotGrantedException()

See Also

LockNotGrantedException Class


LockNotGrantedException Fields

[image] [image]

Berkeley DB .NET API Documentation
LockNotGrantedException Fields
LockNotGrantedException Class See Also Send Feedback

The LockNotGrantedException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

LockNotGrantedException Class


LockNotGrantedException Methods

[image] [image]

Berkeley DB .NET API Documentation
LockNotGrantedException Methods
LockNotGrantedException Class See Also Send Feedback

The LockNotGrantedException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

LockNotGrantedException Class


LockNotGrantedException Properties

[image] [image]

Berkeley DB .NET API Documentation
LockNotGrantedException Properties
LockNotGrantedException Class See Also Send Feedback

The LockNotGrantedException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

LockNotGrantedException Class


LockStats Class

[image]

Berkeley DB .NET API Documentation
LockStats Class
Members See Also Send Feedback
Statistical information about the locking subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LockStats
Visual Basic (Declaration)
Public Class LockStats
Visual C++
public ref class LockStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.LockStats

See Also

LockStats Members


LockStats Members

[image] [image]

Berkeley DB .NET API Documentation
LockStats Members
LockStats Class Methods Properties See Also Send Feedback

The LockStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AllocatedLockers | Current number of lockers allocated.
AllocatedLocks | Current number of locks allocated.
AllocatedObjects | Current number of lock objects allocated.
InitLockers | Initial number of lockers allocated.
InitLocks | Initial number of locks allocated.
InitObjects | Initial number of lock objects allocated.
LastAllocatedLockerID | Last allocated locker ID.
LockConflictsNoWait | Lock conflicts w/o subsequent wait
LockConflictsWait | Lock conflicts w/ subsequent wait
LockDeadlocks | Number of lock deadlocks.
LockDowngrades | Number of lock downgrades.
LockerNoWait | Locker lock granted without wait.
Lockers | Current number of lockers.
LockersHit | Number of hits in the thread locker cache.
LockersReused | Total number of lockers reused.
LockerWait | Locker lock granted after wait.
LockModes | Number of lock modes.
LockPuts | Number of lock puts.
LockRequests | Number of lock gets.
Locks | Current number of locks.
LockSteals | Number of lock steals so far.
LockTimeoutLength | Lock timeout.
LockTimeouts | Number of lock timeouts.
LockUpgrades | Number of lock upgrades.
MaxBucketLength | Max length of bucket.
MaxLockers | Maximum number of lockers so far.
MaxLockersInTable | Maximum num of lockers in table.
MaxLocks | Maximum number of locks so far.
MaxLocksInBucket | Maximum number of locks in any bucket.
MaxLocksInTable | Maximum number of locks in table.
MaxLockSteals | Maximum number steals in any partition.
MaxObjects | Maximum number of objects so far.
MaxObjectsInBucket | Maximum number of objectsin any bucket.
MaxObjectsInTable | Maximum number of objects in table.
MaxObjectSteals | Maximum number of steals in any partition.
MaxPartitionLockNoWait | Max partition lock granted without wait.
MaxPartitionLockWait | Max partition lock granted after wait.
MaxUnusedID | Current maximum unused ID.
nPartitions | Number of partitions.
ObjectNoWait | Object lock granted without wait.
Objects | Current number of objects.
ObjectSteals | Number of objects steals so far.
ObjectWait | Object lock granted after wait.
PartitionLockNoWait | Partition lock granted without wait.
PartitionLockWait | Partition lock granted after wait.
RegionNoWait | Region lock granted without wait.
RegionSize | Region size.
RegionWait | Region lock granted after wait.
TableSize | Size of object hash table.
TxnTimeoutLength | Transaction timeout.
TxnTimeouts | Number of transaction timeouts.

See Also

LockStats Class


LockStats Methods

[image] [image]

Berkeley DB .NET API Documentation
LockStats Methods
LockStats Class See Also Send Feedback

The LockStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LockStats Class


LockStats Properties

[image] [image]

Berkeley DB .NET API Documentation
LockStats Properties
LockStats Class See Also Send Feedback

The LockStats type exposes the following members.

Properties

Name | Description
AllocatedLockers | Current number of lockers allocated.
AllocatedLocks | Current number of locks allocated.
AllocatedObjects | Current number of lock objects allocated.
InitLockers | Initial number of lockers allocated.
InitLocks | Initial number of locks allocated.
InitObjects | Initial number of lock objects allocated.
LastAllocatedLockerID | Last allocated locker ID.
LockConflictsNoWait | Lock conflicts w/o subsequent wait
LockConflictsWait | Lock conflicts w/ subsequent wait
LockDeadlocks | Number of lock deadlocks.
LockDowngrades | Number of lock downgrades.
LockerNoWait | Locker lock granted without wait.
Lockers | Current number of lockers.
LockersHit | Number of hits in the thread locker cache.
LockersReused | Total number of lockers reused.
LockerWait | Locker lock granted after wait.
LockModes | Number of lock modes.
LockPuts | Number of lock puts.
LockRequests | Number of lock gets.
Locks | Current number of locks.
LockSteals | Number of lock steals so far.
LockTimeoutLength | Lock timeout.
LockTimeouts | Number of lock timeouts.
LockUpgrades | Number of lock upgrades.
MaxBucketLength | Max length of bucket.
MaxLockers | Maximum number of lockers so far.
MaxLockersInTable | Maximum num of lockers in table.
MaxLocks | Maximum number of locks so far.
MaxLocksInBucket | Maximum number of locks in any bucket.
MaxLocksInTable | Maximum number of locks in table.
MaxLockSteals | Maximum number steals in any partition.
MaxObjects | Maximum number of objects so far.
MaxObjectsInBucket | Maximum number of objectsin any bucket.
MaxObjectsInTable | Maximum number of objects in table.
MaxObjectSteals | Maximum number of steals in any partition.
MaxPartitionLockNoWait | Max partition lock granted without wait.
MaxPartitionLockWait | Max partition lock granted after wait.
MaxUnusedID | Current maximum unused ID.
nPartitions | Number of partitions.
ObjectNoWait | Object lock granted without wait.
Objects | Current number of objects.
ObjectSteals | Number of objects steals so far.
ObjectWait | Object lock granted after wait.
PartitionLockNoWait | Partition lock granted without wait.
PartitionLockWait | Partition lock granted after wait.
RegionNoWait | Region lock granted without wait.
RegionSize | Region size.
RegionWait | Region lock granted after wait.
TableSize | Size of object hash table.
TxnTimeoutLength | Transaction timeout.
TxnTimeouts | Number of transaction timeouts.

See Also

LockStats Class


AllocatedLockers Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.AllocatedLockers Property
LockStats Class See Also Send Feedback
Current number of lockers allocated.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint AllocatedLockers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllocatedLockers As UInteger
Visual C++
public:
property unsigned int AllocatedLockers {
    unsigned int get ();
}

See Also

LockStats Class


AllocatedLocks Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.AllocatedLocks Property
LockStats Class See Also Send Feedback
Current number of locks allocated.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint AllocatedLocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllocatedLocks As UInteger
Visual C++
public:
property unsigned int AllocatedLocks {
    unsigned int get ();
}

See Also

LockStats Class


AllocatedObjects Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.AllocatedObjects Property
LockStats Class See Also Send Feedback
Current number of lock objects allocated.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint AllocatedObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllocatedObjects As UInteger
Visual C++
public:
property unsigned int AllocatedObjects {
    unsigned int get ();
}

See Also

LockStats Class


InitLockers Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.InitLockers Property
LockStats Class See Also Send Feedback
Initial number of lockers allocated.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLockers { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitLockers As UInteger
Visual C++
public:
property unsigned int InitLockers {
    unsigned int get ();
}

See Also

LockStats Class


InitLocks Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.InitLocks Property
LockStats Class See Also Send Feedback
Initial number of locks allocated.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitLocks As UInteger
Visual C++
public:
property unsigned int InitLocks {
    unsigned int get ();
}

See Also

LockStats Class


InitObjects Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.InitObjects Property
LockStats Class See Also Send Feedback
Initial number of lock objects allocated.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitObjects As UInteger
Visual C++
public:
property unsigned int InitObjects {
    unsigned int get ();
}

See Also

LockStats Class


LastAllocatedLockerID Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LastAllocatedLockerID Property
LockStats Class See Also Send Feedback
Last allocated locker ID.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LastAllocatedLockerID { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastAllocatedLockerID As UInteger
Visual C++
public:
property unsigned int LastAllocatedLockerID {
    unsigned int get ();
}

See Also

LockStats Class


LockConflictsNoWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockConflictsNoWait Property
LockStats Class See Also Send Feedback
Lock conflicts w/o subsequent wait

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockConflictsNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockConflictsNoWait As ULong
Visual C++
public:
property unsigned long long LockConflictsNoWait {
    unsigned long long get ();
}

See Also

LockStats Class


LockConflictsWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockConflictsWait Property
LockStats Class See Also Send Feedback
Lock conflicts w/ subsequent wait

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockConflictsWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockConflictsWait As ULong
Visual C++
public:
property unsigned long long LockConflictsWait {
    unsigned long long get ();
}

See Also

LockStats Class


LockDeadlocks Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockDeadlocks Property
LockStats Class See Also Send Feedback
Number of lock deadlocks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockDeadlocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockDeadlocks As ULong
Visual C++
public:
property unsigned long long LockDeadlocks {
    unsigned long long get ();
}

See Also

LockStats Class


LockDowngrades Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockDowngrades Property
LockStats Class See Also Send Feedback
Number of lock downgrades.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockDowngrades { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockDowngrades As ULong
Visual C++
public:
property unsigned long long LockDowngrades {
    unsigned long long get ();
}

See Also

LockStats Class


LockerNoWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockerNoWait Property
LockStats Class See Also Send Feedback
Locker lock granted without wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockerNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockerNoWait As ULong
Visual C++
public:
property unsigned long long LockerNoWait {
    unsigned long long get ();
}

See Also

LockStats Class


Lockers Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.Lockers Property
LockStats Class See Also Send Feedback
Current number of lockers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Lockers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Lockers As UInteger
Visual C++
public:
property unsigned int Lockers {
    unsigned int get ();
}

See Also

LockStats Class


LockersHit Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockersHit Property
LockStats Class See Also Send Feedback
Number of hits in the thread locker cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockersHit { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockersHit As ULong
Visual C++
public:
property unsigned long long LockersHit {
    unsigned long long get ();
}

See Also

LockStats Class


LockersReused Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockersReused Property
LockStats Class See Also Send Feedback
Total number of lockers reused.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockersReused { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockersReused As ULong
Visual C++
public:
property unsigned long long LockersReused {
    unsigned long long get ();
}

See Also

LockStats Class


LockerWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockerWait Property
LockStats Class See Also Send Feedback
Locker lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockerWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockerWait As ULong
Visual C++
public:
property unsigned long long LockerWait {
    unsigned long long get ();
}

See Also

LockStats Class


LockModes Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockModes Property
LockStats Class See Also Send Feedback
Number of lock modes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int LockModes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockModes As Integer
Visual C++
public:
property int LockModes {
    int get ();
}

See Also

LockStats Class


LockPuts Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockPuts Property
LockStats Class See Also Send Feedback
Number of lock puts.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockPuts { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockPuts As ULong
Visual C++
public:
property unsigned long long LockPuts {
    unsigned long long get ();
}

See Also

LockStats Class


LockRequests Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockRequests Property
LockStats Class See Also Send Feedback
Number of lock gets.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockRequests { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockRequests As ULong
Visual C++
public:
property unsigned long long LockRequests {
    unsigned long long get ();
}

See Also

LockStats Class


Locks Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.Locks Property
LockStats Class See Also Send Feedback
Current number of locks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Locks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Locks As UInteger
Visual C++
public:
property unsigned int Locks {
    unsigned int get ();
}

See Also

LockStats Class


LockSteals Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockSteals Property
LockStats Class See Also Send Feedback
Number of lock steals so far.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockSteals { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockSteals As ULong
Visual C++
public:
property unsigned long long LockSteals {
    unsigned long long get ();
}

See Also

LockStats Class


LockTimeoutLength Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockTimeoutLength Property
LockStats Class See Also Send Feedback
Lock timeout.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LockTimeoutLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockTimeoutLength As UInteger
Visual C++
public:
property unsigned int LockTimeoutLength {
    unsigned int get ();
}

See Also

LockStats Class


LockTimeouts Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockTimeouts Property
LockStats Class See Also Send Feedback
Number of lock timeouts.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockTimeouts { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockTimeouts As ULong
Visual C++
public:
property unsigned long long LockTimeouts {
    unsigned long long get ();
}

See Also

LockStats Class


LockUpgrades Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.LockUpgrades Property
LockStats Class See Also Send Feedback
Number of lock upgrades.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockUpgrades { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockUpgrades As ULong
Visual C++
public:
property unsigned long long LockUpgrades {
    unsigned long long get ();
}

See Also

LockStats Class


MaxBucketLength Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxBucketLength Property
LockStats Class See Also Send Feedback
Max length of bucket.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxBucketLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxBucketLength As UInteger
Visual C++
public:
property unsigned int MaxBucketLength {
    unsigned int get ();
}

See Also

LockStats Class


MaxLockers Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxLockers Property
LockStats Class See Also Send Feedback
Maximum number of lockers so far.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLockers { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxLockers As UInteger
Visual C++
public:
property unsigned int MaxLockers {
    unsigned int get ();
}

See Also

LockStats Class


MaxLockersInTable Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxLockersInTable Property
LockStats Class See Also Send Feedback
Maximum num of lockers in table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLockersInTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxLockersInTable As UInteger
Visual C++
public:
property unsigned int MaxLockersInTable {
    unsigned int get ();
}

See Also

LockStats Class


MaxLocks Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxLocks Property
LockStats Class See Also Send Feedback
Maximum number of locks so far.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxLocks As UInteger
Visual C++
public:
property unsigned int MaxLocks {
    unsigned int get ();
}

See Also

LockStats Class


MaxLocksInBucket Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxLocksInBucket Property
LockStats Class See Also Send Feedback
Maximum number of locks in any bucket.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLocksInBucket { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxLocksInBucket As UInteger
Visual C++
public:
property unsigned int MaxLocksInBucket {
    unsigned int get ();
}

See Also

LockStats Class


MaxLocksInTable Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxLocksInTable Property
LockStats Class See Also Send Feedback
Maximum number of locks in table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLocksInTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxLocksInTable As UInteger
Visual C++
public:
property unsigned int MaxLocksInTable {
    unsigned int get ();
}

See Also

LockStats Class


MaxLockSteals Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxLockSteals Property
LockStats Class See Also Send Feedback
Maximum number steals in any partition.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxLockSteals { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxLockSteals As ULong
Visual C++
public:
property unsigned long long MaxLockSteals {
    unsigned long long get ();
}

See Also

LockStats Class


MaxObjects Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxObjects Property
LockStats Class See Also Send Feedback
Maximum number of objects so far.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxObjects { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxObjects As UInteger
Visual C++
public:
property unsigned int MaxObjects {
    unsigned int get ();
}

See Also

LockStats Class


MaxObjectsInBucket Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxObjectsInBucket Property
LockStats Class See Also Send Feedback
Maximum number of objectsin any bucket.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxObjectsInBucket { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxObjectsInBucket As UInteger
Visual C++
public:
property unsigned int MaxObjectsInBucket {
    unsigned int get ();
}

See Also

LockStats Class


MaxObjectsInTable Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxObjectsInTable Property
LockStats Class See Also Send Feedback
Maximum number of objects in table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxObjectsInTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxObjectsInTable As UInteger
Visual C++
public:
property unsigned int MaxObjectsInTable {
    unsigned int get ();
}

See Also

LockStats Class


MaxObjectSteals Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxObjectSteals Property
LockStats Class See Also Send Feedback
Maximum number of steals in any partition.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxObjectSteals { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxObjectSteals As ULong
Visual C++
public:
property unsigned long long MaxObjectSteals {
    unsigned long long get ();
}

See Also

LockStats Class


MaxPartitionLockNoWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxPartitionLockNoWait Property
LockStats Class See Also Send Feedback
Max partition lock granted without wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxPartitionLockNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxPartitionLockNoWait As ULong
Visual C++
public:
property unsigned long long MaxPartitionLockNoWait {
    unsigned long long get ();
}

See Also

LockStats Class


MaxPartitionLockWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxPartitionLockWait Property
LockStats Class See Also Send Feedback
Max partition lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxPartitionLockWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxPartitionLockWait As ULong
Visual C++
public:
property unsigned long long MaxPartitionLockWait {
    unsigned long long get ();
}

See Also

LockStats Class


MaxUnusedID Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.MaxUnusedID Property
LockStats Class See Also Send Feedback
Current maximum unused ID.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxUnusedID { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxUnusedID As UInteger
Visual C++
public:
property unsigned int MaxUnusedID {
    unsigned int get ();
}

See Also

LockStats Class


nPartitions Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.nPartitions Property
LockStats Class See Also Send Feedback
Number of partitions.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nPartitions { get; }
Visual Basic (Declaration)
Public ReadOnly Property nPartitions As UInteger
Visual C++
public:
property unsigned int nPartitions {
    unsigned int get ();
}

See Also

LockStats Class


ObjectNoWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.ObjectNoWait Property
LockStats Class See Also Send Feedback
Object lock granted without wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ObjectNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectNoWait As ULong
Visual C++
public:
property unsigned long long ObjectNoWait {
    unsigned long long get ();
}

See Also

LockStats Class


Objects Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.Objects Property
LockStats Class See Also Send Feedback
Current number of objects.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Objects { get; }
Visual Basic (Declaration)
Public ReadOnly Property Objects As UInteger
Visual C++
public:
property unsigned int Objects {
    unsigned int get ();
}

See Also

LockStats Class


ObjectSteals Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.ObjectSteals Property
LockStats Class See Also Send Feedback
Number of objects steals so far.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ObjectSteals { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectSteals As ULong
Visual C++
public:
property unsigned long long ObjectSteals {
    unsigned long long get ();
}

See Also

LockStats Class


ObjectWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.ObjectWait Property
LockStats Class See Also Send Feedback
Object lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ObjectWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property ObjectWait As ULong
Visual C++
public:
property unsigned long long ObjectWait {
    unsigned long long get ();
}

See Also

LockStats Class


PartitionLockNoWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.PartitionLockNoWait Property
LockStats Class See Also Send Feedback
Partition lock granted without wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PartitionLockNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartitionLockNoWait As ULong
Visual C++
public:
property unsigned long long PartitionLockNoWait {
    unsigned long long get ();
}

See Also

LockStats Class


PartitionLockWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.PartitionLockWait Property
LockStats Class See Also Send Feedback
Partition lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PartitionLockWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartitionLockWait As ULong
Visual C++
public:
property unsigned long long PartitionLockWait {
    unsigned long long get ();
}

See Also

LockStats Class


RegionNoWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.RegionNoWait Property
LockStats Class See Also Send Feedback
Region lock granted without wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionNoWait As ULong
Visual C++
public:
property unsigned long long RegionNoWait {
    unsigned long long get ();
}

See Also

LockStats Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.RegionSize Property
LockStats Class See Also Send Feedback
Region size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionSize As ULong
Visual C++
public:
property unsigned long long RegionSize {
    unsigned long long get ();
}

See Also

LockStats Class


RegionWait Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.RegionWait Property
LockStats Class See Also Send Feedback
Region lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionWait As ULong
Visual C++
public:
property unsigned long long RegionWait {
    unsigned long long get ();
}

See Also

LockStats Class


TableSize Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.TableSize Property
LockStats Class See Also Send Feedback
Size of object hash table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TableSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property TableSize As UInteger
Visual C++
public:
property unsigned int TableSize {
    unsigned int get ();
}

See Also

LockStats Class


TxnTimeoutLength Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.TxnTimeoutLength Property
LockStats Class See Also Send Feedback
Transaction timeout.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TxnTimeoutLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property TxnTimeoutLength As UInteger
Visual C++
public:
property unsigned int TxnTimeoutLength {
    unsigned int get ();
}

See Also

LockStats Class


TxnTimeouts Property

[image]

Berkeley DB .NET API Documentation
LockStats..::.TxnTimeouts Property
LockStats Class See Also Send Feedback
Number of transaction timeouts.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong TxnTimeouts { get; }
Visual Basic (Declaration)
Public ReadOnly Property TxnTimeouts As ULong
Visual C++
public:
property unsigned long long TxnTimeouts {
    unsigned long long get ();
}

See Also

LockStats Class


LogConfig Class

[image]

Berkeley DB .NET API Documentation
LogConfig Class
Members See Also Send Feedback
A class representing configuration parameters for a DatabaseEnvironment's logging subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LogConfig
Visual Basic (Declaration)
Public Class LogConfig
Visual C++
public ref class LogConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.LogConfig

See Also

LogConfig Members


LogConfig Members

[image] [image]

Berkeley DB .NET API Documentation
LogConfig Members
LogConfig Class Constructors Methods Fields Properties See Also Send Feedback

The LogConfig type exposes the following members.

Constructors

Name | Description
LogConfig | Initializes a new instance of the LogConfig class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoRemove | If true, Berkeley DB automatically removes log files that are no longer needed.
Dir | The path of a directory to be used as the location of logging files. Log files created by the Log Manager subsystem are created in this directory.
ForceSync | If true, Berkeley DB flushes log writes to the backing disk before returning from the write system call, rather than flushing log writes explicitly in a separate system call, as necessary.
InMemory | If true, maintain transaction logs in-memory rather than on disk.
LogBlobContent | If true, enables full logging of blob data. Required if using HA or the hotbackup utility.
NoBuffer | If true, turn off system buffering of Berkeley DB log files to avoid double caching.
NoSync | If true, avoid the fsync() call when the log flies are flushed.
ZeroOnCreate | If true, zero all pages of a log file when that log file is created.

Properties

Name | Description
BufferSize | The size of the in-memory log buffer, in bytes.
FileMode | The absolute file mode for created log files.
InitLogIdCount | The initial number of log identifier entities created by the Berkeley DB environment
MaxFileSize | The maximum size of a single file in the log, in bytes. Because Offset is an unsigned four-byte value, MaxFileSize may not be larger than the maximum unsigned four-byte value.
RegionSize | Te size of the underlying logging area of the Berkeley DB environment, in bytes.

See Also

LogConfig Class


LogConfig Constructor

[image]

Berkeley DB .NET API Documentation
LogConfig Constructor
LogConfig Class See Also Send Feedback
Initializes a new instance of the LogConfig class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LogConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogConfig()

See Also

LogConfig Class


LogConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
LogConfig Fields
LogConfig Class See Also Send Feedback

The LogConfig type exposes the following members.

Fields

Name | Description
AutoRemove | If true, Berkeley DB automatically removes log files that are no longer needed.
Dir | The path of a directory to be used as the location of logging files. Log files created by the Log Manager subsystem are created in this directory.
ForceSync | If true, Berkeley DB flushes log writes to the backing disk before returning from the write system call, rather than flushing log writes explicitly in a separate system call, as necessary.
InMemory | If true, maintain transaction logs in-memory rather than on disk.
LogBlobContent | If true, enables full logging of blob data. Required if using HA or the hotbackup utility.
NoBuffer | If true, turn off system buffering of Berkeley DB log files to avoid double caching.
NoSync | If true, avoid the fsync() call when the log flies are flushed.
ZeroOnCreate | If true, zero all pages of a log file when that log file is created.

See Also

LogConfig Class


AutoRemove Field

[image]

Berkeley DB .NET API Documentation
LogConfig..::.AutoRemove Field
LogConfig Class See Also Send Feedback
If true, Berkeley DB automatically removes log files that are no longer needed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool AutoRemove
Visual Basic (Declaration)
Public AutoRemove As Boolean
Visual C++
public:
bool AutoRemove

Remarks

Automatic log file removal is likely to make catastrophic recovery impossible.

Replication Manager applications operate in a group-aware manner for log file removal. Automatic log file removal simplifies the application.

Replication Base API applications rarely want to configure automatic log file removal as it increases the likelihood a master is unable to satisfy a client's request for a recent log record.

See Also

LogConfig Class


Dir Field

[image]

Berkeley DB .NET API Documentation
LogConfig..::.Dir Field
LogConfig Class See Also Send Feedback
The path of a directory to be used as the location of logging files. Log files created by the Log Manager subsystem are created in this directory.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Dir
Visual Basic (Declaration)
Public Dir As String
Visual C++
public:
String^ Dir

Remarks

If no logging directory is specified, log files are created in the environment home directory. See Berkeley DB File Naming in the Programmer's Reference Guide for more information.

For the greatest degree of recoverability from system or application failure, database files and log files should be located on separate physical devices.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of Dir must be consistent with the existing environment or corruption can occur.

See Also

LogConfig Class


ForceSync Field

[image]

Berkeley DB .NET API Documentation
LogConfig..::.ForceSync Field
LogConfig Class See Also Send Feedback
If true, Berkeley DB flushes log writes to the backing disk before returning from the write system call, rather than flushing log writes explicitly in a separate system call, as necessary.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ForceSync
Visual Basic (Declaration)
Public ForceSync As Boolean
Visual C++
public:
bool ForceSync

Remarks

This is only available on some systems (for example, systems supporting the IEEE/ANSI Std 1003.1 (POSIX) standard O_DSYNC flag, or systems supporting the Windows FILE_FLAG_WRITE_THROUGH flag). This flag may result in inaccurate file modification times and other file-level information for Berkeley DB log files. This flag may offer a performance increase on some systems and a performance decrease on others.

See Also

LogConfig Class


InMemory Field

[image]

Berkeley DB .NET API Documentation
LogConfig..::.InMemory Field
LogConfig Class See Also Send Feedback
If true, maintain transaction logs in-memory rather than on disk.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool InMemory
Visual Basic (Declaration)
Public InMemory As Boolean
Visual C++
public:
bool InMemory

Remarks

This means that transactions exhibit the ACI (atomicity, consistency, and isolation) properties, but not D (durability); database integrity is maintained, but if the application or system fails, integrity does not persist. All database files must be verified and/or restored from a replication group master or archival backup after application or system failure.

When in-memory logs are configured and no more log buffer space is available, Berkeley DB methods may throw FullLogBufferException. When choosing log buffer and file sizes for in-memory logs, applications should ensure the in-memory log buffer size is large enough that no transaction ever spans the entire buffer, and avoids a state where the in-memory buffer is full and no space can be freed because a transaction that started in the first log "file" is still active.

See Also

LogConfig Class


LogBlobContent Field

[image]

Berkeley DB .NET API Documentation
LogConfig..::.LogBlobContent Field
LogConfig Class See Also Send Feedback
If true, enables full logging of blob data. Required if using HA or the hotbackup utility.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool LogBlobContent
Visual Basic (Declaration)
Public LogBlobContent As Boolean
Visual C++
public:
bool LogBlobContent

See Also

LogConfig Class


NoBuffer Field

[image]

Berkeley DB .NET API Documentation
LogConfig..::.NoBuffer Field
LogConfig Class See Also Send Feedback
If true, turn off system buffering of Berkeley DB log files to avoid double caching.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoBuffer
Visual Basic (Declaration)
Public NoBuffer As Boolean
Visual C++
public:
bool NoBuffer

See Also

LogConfig Class


NoSync Field

[image]

Berkeley DB .NET API Documentation
LogConfig..::.NoSync Field
LogConfig Class See Also Send Feedback
If true, avoid the fsync() call when the log flies are flushed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoSync
Visual Basic (Declaration)
Public NoSync As Boolean
Visual C++
public:
bool NoSync

See Also

LogConfig Class


ZeroOnCreate Field

[image]

Berkeley DB .NET API Documentation
LogConfig..::.ZeroOnCreate Field
LogConfig Class See Also Send Feedback
If true, zero all pages of a log file when that log file is created.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ZeroOnCreate
Visual Basic (Declaration)
Public ZeroOnCreate As Boolean
Visual C++
public:
bool ZeroOnCreate

Remarks

This has shown to provide greater transaction throughput in some environments. The log file is zeroed by the thread which needs to re-create the new log file. Other threads may not write to the log file while this is happening.

See Also

LogConfig Class


LogConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
LogConfig Methods
LogConfig Class See Also Send Feedback

The LogConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LogConfig Class


LogConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
LogConfig Properties
LogConfig Class See Also Send Feedback

The LogConfig type exposes the following members.

Properties

Name | Description
BufferSize | The size of the in-memory log buffer, in bytes.
FileMode | The absolute file mode for created log files.
InitLogIdCount | The initial number of log identifier entities created by the Berkeley DB environment
MaxFileSize | The maximum size of a single file in the log, in bytes. Because Offset is an unsigned four-byte value, MaxFileSize may not be larger than the maximum unsigned four-byte value.
RegionSize | Te size of the underlying logging area of the Berkeley DB environment, in bytes.

See Also

LogConfig Class


BufferSize Property

[image]

Berkeley DB .NET API Documentation
LogConfig..::.BufferSize Property
LogConfig Class See Also Send Feedback
The size of the in-memory log buffer, in bytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BufferSize { get; set; }
Visual Basic (Declaration)
Public Property BufferSize As UInteger
Visual C++
public:
property unsigned int BufferSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

When the logging subsystem is configured for on-disk logging, the default size of the in-memory log buffer is approximately 32KB. Log information is stored in-memory until the storage space fills up or transaction commit forces the information to be flushed to stable storage. In the presence of long-running transactions or transactions producing large amounts of data, larger buffer sizes can increase throughput.

When the logging subsystem is configured for in-memory logging, the default size of the in-memory log buffer is 1MB. Log information is stored in-memory until the storage space fills up or transaction abort or commit frees up the memory for new transactions. In the presence of long-running transactions or transactions producing large amounts of data, the buffer size must be sufficient to hold all log information that can accumulate during the longest running transaction. When choosing log buffer and file sizes for in-memory logs, applications should ensure the in-memory log buffer size is large enough that no transaction ever spans the entire buffer, and avoid a state where the in-memory buffer is full and no space can be freed because a transaction that started in the first log "file" is still active.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of BufferSize will be ignored.

See Also

LogConfig Class


FileMode Property

[image]

Berkeley DB .NET API Documentation
LogConfig..::.FileMode Property
LogConfig Class See Also Send Feedback
The absolute file mode for created log files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int FileMode { get; set; }
Visual Basic (Declaration)
Public Property FileMode As Integer
Visual C++
public:
property int FileMode {
    int get ();
    void set (int value);
}

Remarks

This method is only useful for the rare Berkeley DB application that does not control its umask value.

Normally, if Berkeley DB applications set their umask appropriately, all processes in the application suite obtain read permission on the log files created by any process in the application suite. However, if the Berkeley DB application is a library, a process using the library might set its umask to a value preventing other processes in the application suite from reading the log files it creates. In this rare case, the DB_ENV->set_lg_filemode() method can be used to set the mode of created log files to an absolute value.

See Also

LogConfig Class


InitLogIdCount Property

[image]

Berkeley DB .NET API Documentation
LogConfig..::.InitLogIdCount Property
LogConfig Class See Also Send Feedback
The initial number of log identifier entities created by the Berkeley DB environment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitLogIdCount { get; set; }
Visual Basic (Declaration)
Public Property InitLogIdCount As UInteger
Visual C++
public:
property unsigned int InitLogIdCount {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to force Berkeley DB to allocate a certain number of log identifier objects when the environment is created. This can be useful if an application uses a large number of log identifier objects, and experiences performance issues with the default dynamic allocation algorithm.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of InitLogIds is ignored.

See Also

LogConfig Class


MaxFileSize Property

[image]

Berkeley DB .NET API Documentation
LogConfig..::.MaxFileSize Property
LogConfig Class See Also Send Feedback
The maximum size of a single file in the log, in bytes. Because Offset is an unsigned four-byte value, MaxFileSize may not be larger than the maximum unsigned four-byte value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxFileSize { get; set; }
Visual Basic (Declaration)
Public Property MaxFileSize As UInteger
Visual C++
public:
property unsigned int MaxFileSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

When the logging subsystem is configured for on-disk logging, the default size of a log file is 10MB.

When the logging subsystem is configured for in-memory logging, the default size of a log file is 256KB. In addition, the configured log buffer size must be larger than the log file size. (The logging subsystem divides memory configured for in-memory log records into "files", as database environments configured for in-memory log records may exchange log records with other members of a replication group, and those members may be configured to store log records on-disk.) When choosing log buffer and file sizes for in-memory logs, applications should ensure the in-memory log buffer size is large enough that no transaction ever spans the entire buffer, and avoids a state where the in-memory buffer is full and no space can be freed because a transaction that started in the first log "file" is still active.

See Log File Limits in the Programmer's Reference Guide for more information.

If no size is specified by the application, the size last specified for the database region is used, or if no database region previously existed, the default is used.

See Also

LogConfig Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
LogConfig..::.RegionSize Property
LogConfig Class See Also Send Feedback
Te size of the underlying logging area of the Berkeley DB environment, in bytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RegionSize { get; set; }
Visual Basic (Declaration)
Public Property RegionSize As UInteger
Visual C++
public:
property unsigned int RegionSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

By default, or if the value is set to 0, the default size is approximately 60KB. The log region is used to store filenames, and so may need to be increased in size if a large number of files are opened and registered with the specified Berkeley DB environment's log manager.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of RegionSize is ignored.

See Also

LogConfig Class


LogStats Class

[image]

Berkeley DB .NET API Documentation
LogStats Class
Members See Also Send Feedback
Statistical information about the logging subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LogStats
Visual Basic (Declaration)
Public Class LogStats
Visual C++
public ref class LogStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.LogStats

See Also

LogStats Members


LogStats Members

[image] [image]

Berkeley DB .NET API Documentation
LogStats Members
LogStats Class Methods Properties See Also Send Feedback

The LogStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BufferSize | Log buffer size.
Bytes | Bytes to log.
BytesSinceCheckpoint | Bytes to log since checkpoint.
CurrentFile | Current log file number.
CurrentOffset | Current log file offset.
DiskFileNumber | Known on disk log file number.
DiskOffset | Known on disk log file offset.
FileId | Current fileids in use.
FileSize | Log file size.
InitFileId | Initial fileid allocation.
MagicNumber | Log file magic number.
MaxCommitsPerFlush | Max number of commits in a flush.
MaxFileId | Maximum fileids used.
MBytes | Megabytes to log.
MBytesSinceCheckpoint | Megabytes to log since checkpoint.
MinCommitsPerFlush | Min number of commits in a flush.
OverflowWrites | Overflow writes to the log.
PermissionsMode | Log file permissions mode.
Reads | Total I/O reads from the log.
Records | Records entered into the log.
RegionLockNoWait | Region lock granted without wait.
RegionLockWait | Region lock granted after wait.
RegionSize | Region size.
Syncs | Total syncs to the log.
Version | Log file version number.
Writes | Total I/O writes to the log.

See Also

LogStats Class


LogStats Methods

[image] [image]

Berkeley DB .NET API Documentation
LogStats Methods
LogStats Class See Also Send Feedback

The LogStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LogStats Class


LogStats Properties

[image] [image]

Berkeley DB .NET API Documentation
LogStats Properties
LogStats Class See Also Send Feedback

The LogStats type exposes the following members.

Properties

Name | Description
BufferSize | Log buffer size.
Bytes | Bytes to log.
BytesSinceCheckpoint | Bytes to log since checkpoint.
CurrentFile | Current log file number.
CurrentOffset | Current log file offset.
DiskFileNumber | Known on disk log file number.
DiskOffset | Known on disk log file offset.
FileId | Current fileids in use.
FileSize | Log file size.
InitFileId | Initial fileid allocation.
MagicNumber | Log file magic number.
MaxCommitsPerFlush | Max number of commits in a flush.
MaxFileId | Maximum fileids used.
MBytes | Megabytes to log.
MBytesSinceCheckpoint | Megabytes to log since checkpoint.
MinCommitsPerFlush | Min number of commits in a flush.
OverflowWrites | Overflow writes to the log.
PermissionsMode | Log file permissions mode.
Reads | Total I/O reads from the log.
Records | Records entered into the log.
RegionLockNoWait | Region lock granted without wait.
RegionLockWait | Region lock granted after wait.
RegionSize | Region size.
Syncs | Total syncs to the log.
Version | Log file version number.
Writes | Total I/O writes to the log.

See Also

LogStats Class


BufferSize Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.BufferSize Property
LogStats Class See Also Send Feedback
Log buffer size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BufferSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property BufferSize As UInteger
Visual C++
public:
property unsigned int BufferSize {
    unsigned int get ();
}

See Also

LogStats Class


Bytes Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.Bytes Property
LogStats Class See Also Send Feedback
Bytes to log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Bytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Bytes As UInteger
Visual C++
public:
property unsigned int Bytes {
    unsigned int get ();
}

See Also

LogStats Class


BytesSinceCheckpoint Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.BytesSinceCheckpoint Property
LogStats Class See Also Send Feedback
Bytes to log since checkpoint.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint BytesSinceCheckpoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property BytesSinceCheckpoint As UInteger
Visual C++
public:
property unsigned int BytesSinceCheckpoint {
    unsigned int get ();
}

See Also

LogStats Class


CurrentFile Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.CurrentFile Property
LogStats Class See Also Send Feedback
Current log file number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CurrentFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentFile As UInteger
Visual C++
public:
property unsigned int CurrentFile {
    unsigned int get ();
}

See Also

LogStats Class


CurrentOffset Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.CurrentOffset Property
LogStats Class See Also Send Feedback
Current log file offset.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CurrentOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentOffset As UInteger
Visual C++
public:
property unsigned int CurrentOffset {
    unsigned int get ();
}

See Also

LogStats Class


DiskFileNumber Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.DiskFileNumber Property
LogStats Class See Also Send Feedback
Known on disk log file number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DiskFileNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property DiskFileNumber As UInteger
Visual C++
public:
property unsigned int DiskFileNumber {
    unsigned int get ();
}

See Also

LogStats Class


DiskOffset Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.DiskOffset Property
LogStats Class See Also Send Feedback
Known on disk log file offset.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DiskOffset { get; }
Visual Basic (Declaration)
Public ReadOnly Property DiskOffset As UInteger
Visual C++
public:
property unsigned int DiskOffset {
    unsigned int get ();
}

See Also

LogStats Class


FileId Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.FileId Property
LogStats Class See Also Send Feedback
Current fileids in use.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FileId { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileId As UInteger
Visual C++
public:
property unsigned int FileId {
    unsigned int get ();
}

See Also

LogStats Class


FileSize Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.FileSize Property
LogStats Class See Also Send Feedback
Log file size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FileSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileSize As UInteger
Visual C++
public:
property unsigned int FileSize {
    unsigned int get ();
}

See Also

LogStats Class


InitFileId Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.InitFileId Property
LogStats Class See Also Send Feedback
Initial fileid allocation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitFileId { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitFileId As UInteger
Visual C++
public:
property unsigned int InitFileId {
    unsigned int get ();
}

See Also

LogStats Class


MagicNumber Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.MagicNumber Property
LogStats Class See Also Send Feedback
Log file magic number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MagicNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property MagicNumber As UInteger
Visual C++
public:
property unsigned int MagicNumber {
    unsigned int get ();
}

See Also

LogStats Class


MaxCommitsPerFlush Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.MaxCommitsPerFlush Property
LogStats Class See Also Send Feedback
Max number of commits in a flush.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxCommitsPerFlush { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxCommitsPerFlush As UInteger
Visual C++
public:
property unsigned int MaxCommitsPerFlush {
    unsigned int get ();
}

See Also

LogStats Class


MaxFileId Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.MaxFileId Property
LogStats Class See Also Send Feedback
Maximum fileids used.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxFileId { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxFileId As UInteger
Visual C++
public:
property unsigned int MaxFileId {
    unsigned int get ();
}

See Also

LogStats Class


MBytes Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.MBytes Property
LogStats Class See Also Send Feedback
Megabytes to log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property MBytes As UInteger
Visual C++
public:
property unsigned int MBytes {
    unsigned int get ();
}

See Also

LogStats Class


MBytesSinceCheckpoint Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.MBytesSinceCheckpoint Property
LogStats Class See Also Send Feedback
Megabytes to log since checkpoint.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MBytesSinceCheckpoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property MBytesSinceCheckpoint As UInteger
Visual C++
public:
property unsigned int MBytesSinceCheckpoint {
    unsigned int get ();
}

See Also

LogStats Class


MinCommitsPerFlush Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.MinCommitsPerFlush Property
LogStats Class See Also Send Feedback
Min number of commits in a flush.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MinCommitsPerFlush { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinCommitsPerFlush As UInteger
Visual C++
public:
property unsigned int MinCommitsPerFlush {
    unsigned int get ();
}

See Also

LogStats Class


OverflowWrites Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.OverflowWrites Property
LogStats Class See Also Send Feedback
Overflow writes to the log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong OverflowWrites { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowWrites As ULong
Visual C++
public:
property unsigned long long OverflowWrites {
    unsigned long long get ();
}

See Also

LogStats Class


PermissionsMode Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.PermissionsMode Property
LogStats Class See Also Send Feedback
Log file permissions mode.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int PermissionsMode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PermissionsMode As Integer
Visual C++
public:
property int PermissionsMode {
    int get ();
}

See Also

LogStats Class


Reads Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.Reads Property
LogStats Class See Also Send Feedback
Total I/O reads from the log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Reads { get; }
Visual Basic (Declaration)
Public ReadOnly Property Reads As ULong
Visual C++
public:
property unsigned long long Reads {
    unsigned long long get ();
}

See Also

LogStats Class


Records Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.Records Property
LogStats Class See Also Send Feedback
Records entered into the log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Records { get; }
Visual Basic (Declaration)
Public ReadOnly Property Records As ULong
Visual C++
public:
property unsigned long long Records {
    unsigned long long get ();
}

See Also

LogStats Class


RegionLockNoWait Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.RegionLockNoWait Property
LogStats Class See Also Send Feedback
Region lock granted without wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionLockNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionLockNoWait As ULong
Visual C++
public:
property unsigned long long RegionLockNoWait {
    unsigned long long get ();
}

See Also

LogStats Class


RegionLockWait Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.RegionLockWait Property
LogStats Class See Also Send Feedback
Region lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionLockWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionLockWait As ULong
Visual C++
public:
property unsigned long long RegionLockWait {
    unsigned long long get ();
}

See Also

LogStats Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.RegionSize Property
LogStats Class See Also Send Feedback
Region size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionSize As ULong
Visual C++
public:
property unsigned long long RegionSize {
    unsigned long long get ();
}

See Also

LogStats Class


Syncs Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.Syncs Property
LogStats Class See Also Send Feedback
Total syncs to the log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Syncs { get; }
Visual Basic (Declaration)
Public ReadOnly Property Syncs As ULong
Visual C++
public:
property unsigned long long Syncs {
    unsigned long long get ();
}

See Also

LogStats Class


Version Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.Version Property
LogStats Class See Also Send Feedback
Log file version number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As UInteger
Visual C++
public:
property unsigned int Version {
    unsigned int get ();
}

See Also

LogStats Class


Writes Property

[image]

Berkeley DB .NET API Documentation
LogStats..::.Writes Property
LogStats Class See Also Send Feedback
Total I/O writes to the log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Writes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Writes As ULong
Visual C++
public:
property unsigned long long Writes {
    unsigned long long get ();
}

See Also

LogStats Class


LogVerifyConfig Class

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig Class
Members See Also Send Feedback
A class representing configuration parameters for log verification.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LogVerifyConfig
Visual Basic (Declaration)
Public Class LogVerifyConfig
Visual C++
public ref class LogVerifyConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.LogVerifyConfig

See Also

LogVerifyConfig Members


LogVerifyConfig Members

[image] [image]

Berkeley DB .NET API Documentation
LogVerifyConfig Members
LogVerifyConfig Class Constructors Methods Properties See Also Send Feedback

The LogVerifyConfig type exposes the following members.

Constructors

Name | Description
LogVerifyConfig | Instantiate a new LogVerifyConfig object, with the default configuration settings.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CacheSize | The cache size for the internal database environment.
ContinueAfterFail | Whether continue verifying after a failed check.
DbFile | The database file name whose logs are to be verified.
DbName | The database name whose logs are to be verified.
EndLsn | The ending lsn to verify.
EndTime | The ending time to verify.
EnvHome | The home directory of the Berkeley DB environment to be used internally during log verification.
StartLsn | The starting lsn to verify.
StartTime | The starting time to verify.
Verbose | Whether output verbose information.

See Also

LogVerifyConfig Class


LogVerifyConfig Constructor

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig Constructor
LogVerifyConfig Class See Also Send Feedback
Instantiate a new LogVerifyConfig object, with the default configuration settings.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LogVerifyConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LogVerifyConfig()

See Also

LogVerifyConfig Class


LogVerifyConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
LogVerifyConfig Methods
LogVerifyConfig Class See Also Send Feedback

The LogVerifyConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LogVerifyConfig Class


LogVerifyConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
LogVerifyConfig Properties
LogVerifyConfig Class See Also Send Feedback

The LogVerifyConfig type exposes the following members.

Properties

Name | Description
CacheSize | The cache size for the internal database environment.
ContinueAfterFail | Whether continue verifying after a failed check.
DbFile | The database file name whose logs are to be verified.
DbName | The database name whose logs are to be verified.
EndLsn | The ending lsn to verify.
EndTime | The ending time to verify.
EnvHome | The home directory of the Berkeley DB environment to be used internally during log verification.
StartLsn | The starting lsn to verify.
StartTime | The starting time to verify.
Verbose | Whether output verbose information.

See Also

LogVerifyConfig Class


CacheSize Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.CacheSize Property
LogVerifyConfig Class See Also Send Feedback
The cache size for the internal database environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CacheSize { get; set; }
Visual Basic (Declaration)
Public Property CacheSize As UInteger
Visual C++
public:
property unsigned int CacheSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

LogVerifyConfig Class


ContinueAfterFail Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.ContinueAfterFail Property
LogVerifyConfig Class See Also Send Feedback
Whether continue verifying after a failed check.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ContinueAfterFail { get; set; }
Visual Basic (Declaration)
Public Property ContinueAfterFail As Boolean
Visual C++
public:
property bool ContinueAfterFail {
    bool get ();
    void set (bool value);
}

See Also

LogVerifyConfig Class


DbFile Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.DbFile Property
LogVerifyConfig Class See Also Send Feedback
The database file name whose logs are to be verified.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string DbFile { get; set; }
Visual Basic (Declaration)
Public Property DbFile As String
Visual C++
public:
property String^ DbFile {
    String^ get ();
    void set (String^ value);
}

See Also

LogVerifyConfig Class


DbName Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.DbName Property
LogVerifyConfig Class See Also Send Feedback
The database name whose logs are to be verified.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string DbName { get; set; }
Visual Basic (Declaration)
Public Property DbName As String
Visual C++
public:
property String^ DbName {
    String^ get ();
    void set (String^ value);
}

See Also

LogVerifyConfig Class


EndLsn Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.EndLsn Property
LogVerifyConfig Class See Also Send Feedback
The ending lsn to verify.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN EndLsn { get; set; }
Visual Basic (Declaration)
Public Property EndLsn As LSN
Visual C++
public:
property LSN^ EndLsn {
    LSN^ get ();
    void set (LSN^ value);
}

See Also

LogVerifyConfig Class


EndTime Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.EndTime Property
LogVerifyConfig Class See Also Send Feedback
The ending time to verify.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic (Declaration)
Public Property EndTime As DateTime
Visual C++
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

LogVerifyConfig Class


EnvHome Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.EnvHome Property
LogVerifyConfig Class See Also Send Feedback
The home directory of the Berkeley DB environment to be used internally during log verification.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string EnvHome { get; set; }
Visual Basic (Declaration)
Public Property EnvHome As String
Visual C++
public:
property String^ EnvHome {
    String^ get ();
    void set (String^ value);
}

See Also

LogVerifyConfig Class


StartLsn Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.StartLsn Property
LogVerifyConfig Class See Also Send Feedback
The starting lsn to verify.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN StartLsn { get; set; }
Visual Basic (Declaration)
Public Property StartLsn As LSN
Visual C++
public:
property LSN^ StartLsn {
    LSN^ get ();
    void set (LSN^ value);
}

See Also

LogVerifyConfig Class


StartTime Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.StartTime Property
LogVerifyConfig Class See Also Send Feedback
The starting time to verify.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DateTime StartTime { get; set; }
Visual Basic (Declaration)
Public Property StartTime As DateTime
Visual C++
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

LogVerifyConfig Class


Verbose Property

[image]

Berkeley DB .NET API Documentation
LogVerifyConfig..::.Verbose Property
LogVerifyConfig Class See Also Send Feedback
Whether output verbose information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Verbose { get; set; }
Visual Basic (Declaration)
Public Property Verbose As Boolean
Visual C++
public:
property bool Verbose {
    bool get ();
    void set (bool value);
}

See Also

LogVerifyConfig Class


LSN Class

[image]

Berkeley DB .NET API Documentation
LSN Class
Members See Also Send Feedback
A log sequence number, which specifies a unique location in a log file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class LSN
Visual Basic (Declaration)
Public Class LSN
Visual C++
public ref class LSN

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.LSN

See Also

LSN Members


LSN Members

[image] [image]

Berkeley DB .NET API Documentation
LSN Members
LSN Class Constructors Methods Fields See Also Send Feedback

The LSN type exposes the following members.

Constructors

Name | Description
LSN | Instantiate a new LSN object

Methods

Name | Description
Compare | Compare two LSNs.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
LogFileNumber | The log file number.
Offset | The offset in the log file.

See Also

LSN Class


LSN Constructor

[image]

Berkeley DB .NET API Documentation
LSN Constructor
LSN Class See Also Send Feedback
Instantiate a new LSN object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN(
    uint file,
    uint off
)
Visual Basic (Declaration)
Public Sub New ( _
    file As UInteger, _
    off As UInteger _
)
Visual C++
public:
LSN(
    unsigned int file,
    unsigned int off
)

Parameters

file
Type: System..::.UInt32
The log file number.
off
Type: System..::.UInt32
The offset in the log file.

See Also

LSN Class


LSN Fields

[image] [image]

Berkeley DB .NET API Documentation
LSN Fields
LSN Class See Also Send Feedback

The LSN type exposes the following members.

Fields

Name | Description
LogFileNumber | The log file number.
Offset | The offset in the log file.

See Also

LSN Class


LogFileNumber Field

[image]

Berkeley DB .NET API Documentation
LSN..::.LogFileNumber Field
LSN Class See Also Send Feedback
The log file number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LogFileNumber
Visual Basic (Declaration)
Public LogFileNumber As UInteger
Visual C++
public:
unsigned int LogFileNumber

See Also

LSN Class


Offset Field

[image]

Berkeley DB .NET API Documentation
LSN..::.Offset Field
LSN Class See Also Send Feedback
The offset in the log file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Offset
Visual Basic (Declaration)
Public Offset As UInteger
Visual C++
public:
unsigned int Offset

See Also

LSN Class


LSN Methods

[image] [image]

Berkeley DB .NET API Documentation
LSN Methods
LSN Class See Also Send Feedback

The LSN type exposes the following members.

Methods

Name | Description
Compare | Compare two LSNs.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LSN Class


Compare Method

[image]

Berkeley DB .NET API Documentation
LSN..::.Compare Method
LSN Class See Also Send Feedback
Compare two LSNs.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static int Compare(
    LSN lsn1,
    LSN lsn2
)
Visual Basic (Declaration)
Public Shared Function Compare ( _
    lsn1 As LSN, _
    lsn2 As LSN _
) As Integer
Visual C++
public:
static int Compare(
    LSN^ lsn1,
    LSN^ lsn2
)

Parameters

lsn1
Type: BerkeleyDB..::.LSN
The first LSN to compare
lsn2
Type: BerkeleyDB..::.LSN
The second LSN to compare

Return Value

0 if they are equal, 1 if lsn1 is greater than lsn2, and -1 if lsn1 is less than lsn2.

See Also

LSN Class


MessageDispatchDelegate Delegate

[image]

Berkeley DB .NET API Documentation
MessageDispatchDelegate Delegate
See Also Send Feedback
Application-specific function used to handle messages sent over Replication Manager message channels.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate void MessageDispatchDelegate(
    DbChannel channel,
    ref DatabaseEntry[] requests,
    out uint size,
    bool need_response
)
Visual Basic (Declaration)
Public Delegate Sub MessageDispatchDelegate ( _
    channel As DbChannel, _
    ByRef requests As DatabaseEntry(), _
    <OutAttribute> ByRef size As UInteger, _
    need_response As Boolean _
)
Visual C++
public delegate void MessageDispatchDelegate(
    DbChannel^ channel,
    array<DatabaseEntry^>^% requests,
    [OutAttribute] unsigned int% size,
    bool need_response
)

Parameters

channel
Type: BerkeleyDB..::.DbChannel
Channel used to send a reply back to the originator of the message.
requests
Type: array< BerkeleyDB..::.DatabaseEntry >[]()[] %
DatabaseEntry array containing the message received from the remote site.
size
Type: System..::.UInt32 %
The number of elements in the request array.
need_response
Type: System..::.Boolean
Whether the message requires a response.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


MessageFeedbackDelegate Delegate

[image]

Berkeley DB .NET API Documentation
MessageFeedbackDelegate Delegate
See Also Send Feedback
The application-specified reporting function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate void MessageFeedbackDelegate(
    string Message
)
Visual Basic (Declaration)
Public Delegate Sub MessageFeedbackDelegate ( _
    Message As String _
)
Visual C++
public delegate void MessageFeedbackDelegate(
    String^ Message
)

Parameters

Message
Type: System..::.String
The message string

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


MetaCheckSumFailException Class

[image]

Berkeley DB .NET API Documentation
MetaCheckSumFailException Class
Members See Also Send Feedback
A checksum mismatch was detected on a database metadata page. Either the database is corrupted or the file is not a Berkeley DB database file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class MetaCheckSumFailException : DatabaseException
Visual Basic (Declaration)
Public Class MetaCheckSumFailException _
    Inherits DatabaseException
Visual C++
public ref class MetaCheckSumFailException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.MetaCheckSumFailException

See Also

MetaCheckSumFailException Members


MetaCheckSumFailException Members

[image] [image]

Berkeley DB .NET API Documentation
MetaCheckSumFailException Members
MetaCheckSumFailException Class Constructors Methods Fields Properties See Also Send Feedback

The MetaCheckSumFailException type exposes the following members.

Constructors

Name | Description
MetaCheckSumFailException | Initializes a new instance of the MetaCheckSumFailException class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MetaCheckSumFailException Class


MetaCheckSumFailException Constructor

[image]

Berkeley DB .NET API Documentation
MetaCheckSumFailException Constructor
MetaCheckSumFailException Class See Also Send Feedback
Initializes a new instance of the MetaCheckSumFailException class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MetaCheckSumFailException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MetaCheckSumFailException()

See Also

MetaCheckSumFailException Class


MetaCheckSumFailException Fields

[image] [image]

Berkeley DB .NET API Documentation
MetaCheckSumFailException Fields
MetaCheckSumFailException Class See Also Send Feedback

The MetaCheckSumFailException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

MetaCheckSumFailException Class


MetaCheckSumFailException Methods

[image] [image]

Berkeley DB .NET API Documentation
MetaCheckSumFailException Methods
MetaCheckSumFailException Class See Also Send Feedback

The MetaCheckSumFailException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MetaCheckSumFailException Class


MetaCheckSumFailException Properties

[image] [image]

Berkeley DB .NET API Documentation
MetaCheckSumFailException Properties
MetaCheckSumFailException Class See Also Send Feedback

The MetaCheckSumFailException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MetaCheckSumFailException Class


MPoolConfig Class

[image]

Berkeley DB .NET API Documentation
MPoolConfig Class
Members See Also Send Feedback
A class representing configuration parameters for a DatabaseEnvironment's memory pool subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class MPoolConfig
Visual Basic (Declaration)
Public Class MPoolConfig
Visual C++
public ref class MPoolConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.MPoolConfig

See Also

MPoolConfig Members


MPoolConfig Members

[image] [image]

Berkeley DB .NET API Documentation
MPoolConfig Members
MPoolConfig Class Constructors Methods Fields Properties See Also Send Feedback

The MPoolConfig type exposes the following members.

Constructors

Name | Description
MPoolConfig | Initializes a new instance of the MPoolConfig class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetMaxSequentialWrites | Limit the number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
CacheSize | The size of the shared memory buffer pool (the cache).
MaxCacheSize | The maximum cache size.

Properties

Name | Description
MaxOpenFiles | The number of file descriptors the library opens concurrently when flushing dirty pages from the cache.
MaxSequentialWrites | The number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
MMapSize | The maximum file size, in bytes, for a file to be mapped into the process address space. If no value is specified, it defaults to 10MB.
SequentialWritePause | The number of microseconds the thread of control should pause before scheduling further write operations.

See Also

MPoolConfig Class


MPoolConfig Constructor

[image]

Berkeley DB .NET API Documentation
MPoolConfig Constructor
MPoolConfig Class See Also Send Feedback
Initializes a new instance of the MPoolConfig class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MPoolConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MPoolConfig()

See Also

MPoolConfig Class


MPoolConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
MPoolConfig Fields
MPoolConfig Class See Also Send Feedback

The MPoolConfig type exposes the following members.

Fields

Name | Description
CacheSize | The size of the shared memory buffer pool (the cache).
MaxCacheSize | The maximum cache size.

See Also

MPoolConfig Class


CacheSize Field

[image]

Berkeley DB .NET API Documentation
MPoolConfig..::.CacheSize Field
MPoolConfig Class See Also Send Feedback
The size of the shared memory buffer pool (the cache).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CacheInfo CacheSize
Visual Basic (Declaration)
Public CacheSize As CacheInfo
Visual C++
public:
CacheInfo^ CacheSize

Remarks

The cache should be the size of the normal working data set of the application, with some small amount of additional memory for unusual situations. (Note: the working set is not the same as the number of pages accessed simultaneously, and is usually much larger.)

The default cache size is 256KB, and may not be specified as less than 20KB. Any cache size less than 500MB is automatically increased by 25% to account for buffer pool overhead; cache sizes larger than 500MB are used as specified. The maximum size of a single cache is 4GB on 32-bit systems and 10TB on 64-bit systems. (All sizes are in powers-of-two, 256KB is 2^18 not 256,000.) For information on tuning the Berkeley DB cache size, see Selecting a cache size in the Programmer's Reference Guide.

See Also

MPoolConfig Class


MaxCacheSize Field

[image]

Berkeley DB .NET API Documentation
MPoolConfig..::.MaxCacheSize Field
MPoolConfig Class See Also Send Feedback
The maximum cache size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CacheInfo MaxCacheSize
Visual Basic (Declaration)
Public MaxCacheSize As CacheInfo
Visual C++
public:
CacheInfo^ MaxCacheSize

Remarks

The specified size is rounded to the nearest multiple of the cache region size, which is the initial cache size divided by CacheSize.NCaches. If no value is specified, it defaults to the initial cache size.

See Also

MPoolConfig Class


MPoolConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
MPoolConfig Methods
MPoolConfig Class See Also Send Feedback

The MPoolConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetMaxSequentialWrites | Limit the number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MPoolConfig Class


SetMaxSequentialWrites Method

[image]

Berkeley DB .NET API Documentation
MPoolConfig..::.SetMaxSequentialWrites Method
MPoolConfig Class See Also Send Feedback
Limit the number of sequential write operations scheduled by the library when flushing dirty pages from the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetMaxSequentialWrites(
    int maxWrites,
    uint pause
)
Visual Basic (Declaration)
Public Sub SetMaxSequentialWrites ( _
    maxWrites As Integer, _
    pause As UInteger _
)
Visual C++
public:
void SetMaxSequentialWrites(
    int maxWrites,
    unsigned int pause
)

Parameters

maxWrites
Type: System..::.Int32
The maximum number of sequential write operations scheduled by the library when flushing dirty pages from the cache, or 0 if there is no limitation on the number of sequential write operations.
pause
Type: System..::.UInt32
The number of microseconds the thread of control should pause before scheduling further write operations. It must be specified as an unsigned 32-bit number of microseconds, limiting the maximum pause to roughly 71 minutes.

See Also

MPoolConfig Class


MPoolConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
MPoolConfig Properties
MPoolConfig Class See Also Send Feedback

The MPoolConfig type exposes the following members.

Properties

Name | Description
MaxOpenFiles | The number of file descriptors the library opens concurrently when flushing dirty pages from the cache.
MaxSequentialWrites | The number of sequential write operations scheduled by the library when flushing dirty pages from the cache.
MMapSize | The maximum file size, in bytes, for a file to be mapped into the process address space. If no value is specified, it defaults to 10MB.
SequentialWritePause | The number of microseconds the thread of control should pause before scheduling further write operations.

See Also

MPoolConfig Class


MaxOpenFiles Property

[image]

Berkeley DB .NET API Documentation
MPoolConfig..::.MaxOpenFiles Property
MPoolConfig Class See Also Send Feedback
The number of file descriptors the library opens concurrently when flushing dirty pages from the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int MaxOpenFiles { get; set; }
Visual Basic (Declaration)
Public Property MaxOpenFiles As Integer
Visual C++
public:
property int MaxOpenFiles {
    int get ();
    void set (int value);
}

See Also

MPoolConfig Class


MaxSequentialWrites Property

[image]

Berkeley DB .NET API Documentation
MPoolConfig..::.MaxSequentialWrites Property
MPoolConfig Class See Also Send Feedback
The number of sequential write operations scheduled by the library when flushing dirty pages from the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int MaxSequentialWrites { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxSequentialWrites As Integer
Visual C++
public:
property int MaxSequentialWrites {
    int get ();
}

See Also

MPoolConfig Class


MMapSize Property

[image]

Berkeley DB .NET API Documentation
MPoolConfig..::.MMapSize Property
MPoolConfig Class See Also Send Feedback
The maximum file size, in bytes, for a file to be mapped into the process address space. If no value is specified, it defaults to 10MB.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MMapSize { get; set; }
Visual Basic (Declaration)
Public Property MMapSize As UInteger
Visual C++
public:
property unsigned int MMapSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Files that are opened read-only in the cache (and that satisfy a few other criteria) are, by default, mapped into the process address space instead of being copied into the local cache. This can result in better-than-usual performance because available virtual memory is normally much larger than the local cache, and page faults are faster than page copying on many systems. However, it can cause resource starvation in the presence of limited virtual memory, and it can result in immense process sizes in the presence of large databases.

See Also

MPoolConfig Class


SequentialWritePause Property

[image]

Berkeley DB .NET API Documentation
MPoolConfig..::.SequentialWritePause Property
MPoolConfig Class See Also Send Feedback
The number of microseconds the thread of control should pause before scheduling further write operations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint SequentialWritePause { get; }
Visual Basic (Declaration)
Public ReadOnly Property SequentialWritePause As UInteger
Visual C++
public:
property unsigned int SequentialWritePause {
    unsigned int get ();
}

See Also

MPoolConfig Class


MPoolFileStats Class

[image]

Berkeley DB .NET API Documentation
MPoolFileStats Class
Members See Also Send Feedback
Statistical information about a file in the memory pool

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class MPoolFileStats
Visual Basic (Declaration)
Public Class MPoolFileStats
Visual C++
public ref class MPoolFileStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.MPoolFileStats

See Also

MPoolFileStats Members


MPoolFileStats Members

[image] [image]

Berkeley DB .NET API Documentation
MPoolFileStats Members
MPoolFileStats Class Methods Properties See Also Send Feedback

The MPoolFileStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BackupSpins | Number of spins by a backup.
FileName | File name.
MappedPages | Pages from mapped files.
PagesCreatedInCache | Pages created in the cache.
PagesInCache | Pages found in the cache.
PageSize | Page size.
PagesNotInCache | Pages not found in the cache.
PagesRead | Pages read in.
PagesWritten | Pages written out.

See Also

MPoolFileStats Class


MPoolFileStats Methods

[image] [image]

Berkeley DB .NET API Documentation
MPoolFileStats Methods
MPoolFileStats Class See Also Send Feedback

The MPoolFileStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MPoolFileStats Class


MPoolFileStats Properties

[image] [image]

Berkeley DB .NET API Documentation
MPoolFileStats Properties
MPoolFileStats Class See Also Send Feedback

The MPoolFileStats type exposes the following members.

Properties

Name | Description
BackupSpins | Number of spins by a backup.
FileName | File name.
MappedPages | Pages from mapped files.
PagesCreatedInCache | Pages created in the cache.
PagesInCache | Pages found in the cache.
PageSize | Page size.
PagesNotInCache | Pages not found in the cache.
PagesRead | Pages read in.
PagesWritten | Pages written out.

See Also

MPoolFileStats Class


BackupSpins Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.BackupSpins Property
MPoolFileStats Class See Also Send Feedback
Number of spins by a backup.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BackupSpins { get; }
Visual Basic (Declaration)
Public ReadOnly Property BackupSpins As ULong
Visual C++
public:
property unsigned long long BackupSpins {
    unsigned long long get ();
}

See Also

MPoolFileStats Class


FileName Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.FileName Property
MPoolFileStats Class See Also Send Feedback
File name.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string FileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileName As String
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

MPoolFileStats Class


MappedPages Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.MappedPages Property
MPoolFileStats Class See Also Send Feedback
Pages from mapped files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MappedPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property MappedPages As UInteger
Visual C++
public:
property unsigned int MappedPages {
    unsigned int get ();
}

See Also

MPoolFileStats Class


PagesCreatedInCache Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.PagesCreatedInCache Property
MPoolFileStats Class See Also Send Feedback
Pages created in the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesCreatedInCache { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesCreatedInCache As ULong
Visual C++
public:
property unsigned long long PagesCreatedInCache {
    unsigned long long get ();
}

See Also

MPoolFileStats Class


PagesInCache Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.PagesInCache Property
MPoolFileStats Class See Also Send Feedback
Pages found in the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesInCache { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesInCache As ULong
Visual C++
public:
property unsigned long long PagesInCache {
    unsigned long long get ();
}

See Also

MPoolFileStats Class


PageSize Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.PageSize Property
MPoolFileStats Class See Also Send Feedback
Page size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As UInteger
Visual C++
public:
property unsigned int PageSize {
    unsigned int get ();
}

See Also

MPoolFileStats Class


PagesNotInCache Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.PagesNotInCache Property
MPoolFileStats Class See Also Send Feedback
Pages not found in the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesNotInCache { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesNotInCache As ULong
Visual C++
public:
property unsigned long long PagesNotInCache {
    unsigned long long get ();
}

See Also

MPoolFileStats Class


PagesRead Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.PagesRead Property
MPoolFileStats Class See Also Send Feedback
Pages read in.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesRead { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesRead As ULong
Visual C++
public:
property unsigned long long PagesRead {
    unsigned long long get ();
}

See Also

MPoolFileStats Class


PagesWritten Property

[image]

Berkeley DB .NET API Documentation
MPoolFileStats..::.PagesWritten Property
MPoolFileStats Class See Also Send Feedback
Pages written out.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesWritten { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesWritten As ULong
Visual C++
public:
property unsigned long long PagesWritten {
    unsigned long long get ();
}

See Also

MPoolFileStats Class


MPoolStats Class

[image]

Berkeley DB .NET API Documentation
MPoolStats Class
Members See Also Send Feedback
Statistical information about the memory pool subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class MPoolStats
Visual Basic (Declaration)
Public Class MPoolStats
Visual C++
public ref class MPoolStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.MPoolStats

See Also

MPoolStats Members


MPoolStats Members

[image] [image]

Berkeley DB .NET API Documentation
MPoolStats Members
MPoolStats Class Methods Properties See Also Send Feedback

The MPoolStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BlockedOperations | Thread waited on buffer I/O.
BucketsCheckedDuringAlloc | Buckets checked during allocation.
CacheRegions | Maximum number of regions.
CacheSettings | Total cache size and number of regions
CleanPages | Clean pages.
CleanPagesEvicted | Clean pages forced from the cache.
DirtyPages | Dirty pages.
DirtyPagesEvicted | Dirty pages forced from the cache.
Files | Stats for files open in the memory pool
FrozenBuffers | Buffers frozen.
FrozenBuffersFreed | Frozen buffers freed.
HashBucketMutexes | Number of hash bucket mutexes.
HashBuckets | Number of hash buckets.
HashChainSearches | Total hash chain searches.
HashEntriesSearched | Total hash entries searched.
HashLockNoWait | Hash lock granted with nowait.
HashLockWait | Hash lock granted after wait.
LongestHashChainSearch | Longest hash chain searched.
MappedPages | Pages from mapped files.
MaxBucketsCheckedDuringAlloc | Max buckets checked during allocation.
MaxBufferWrites | Maximum buffers to write.
MaxBufferWritesSleep | Sleep after writing max buffers.
MaxHashLockNoWait | Max hash lock granted with nowait.
MaxHashLockWait | Max hash lock granted after wait.
MaxMMapSize | Maximum file size for mmap.
MaxOpenFileDescriptors | Maximum number of open file descriptors.
MaxPagesCheckedDuringAlloc | Max pages checked during allocation.
OddFileSizeDetected | Odd file size detected.
OddFileSizeResolve | Odd file size resolved.
OutdatedInvisibleBuffersReused | Outdated invisible buffers reused.
PageAllocations | Number of page allocations.
Pages | Total number of pages.
PagesCheckedDuringAlloc | Pages checked during allocation.
PagesCreatedInCache | Pages created in the cache.
PagesInCache | Pages found in the cache.
PageSize | Assumed page size.
PagesNotInCache | Pages not found in the cache.
PagesRead | Pages read in.
PagesTrickled | Pages written by memp_trickle.
PagesWritten | Pages written out.
RegionLockNoWait | Region lock granted with nowait.
RegionLockWait | Region lock granted after wait.
RegionMax | Individual cache max.
RegionSize | Region size.
SyncInterrupted | Number of times sync interrupted.
ThawedBuffers | Buffers thawed.

See Also

MPoolStats Class


MPoolStats Methods

[image] [image]

Berkeley DB .NET API Documentation
MPoolStats Methods
MPoolStats Class See Also Send Feedback

The MPoolStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MPoolStats Class


MPoolStats Properties

[image] [image]

Berkeley DB .NET API Documentation
MPoolStats Properties
MPoolStats Class See Also Send Feedback

The MPoolStats type exposes the following members.

Properties

Name | Description
BlockedOperations | Thread waited on buffer I/O.
BucketsCheckedDuringAlloc | Buckets checked during allocation.
CacheRegions | Maximum number of regions.
CacheSettings | Total cache size and number of regions
CleanPages | Clean pages.
CleanPagesEvicted | Clean pages forced from the cache.
DirtyPages | Dirty pages.
DirtyPagesEvicted | Dirty pages forced from the cache.
Files | Stats for files open in the memory pool
FrozenBuffers | Buffers frozen.
FrozenBuffersFreed | Frozen buffers freed.
HashBucketMutexes | Number of hash bucket mutexes.
HashBuckets | Number of hash buckets.
HashChainSearches | Total hash chain searches.
HashEntriesSearched | Total hash entries searched.
HashLockNoWait | Hash lock granted with nowait.
HashLockWait | Hash lock granted after wait.
LongestHashChainSearch | Longest hash chain searched.
MappedPages | Pages from mapped files.
MaxBucketsCheckedDuringAlloc | Max buckets checked during allocation.
MaxBufferWrites | Maximum buffers to write.
MaxBufferWritesSleep | Sleep after writing max buffers.
MaxHashLockNoWait | Max hash lock granted with nowait.
MaxHashLockWait | Max hash lock granted after wait.
MaxMMapSize | Maximum file size for mmap.
MaxOpenFileDescriptors | Maximum number of open file descriptors.
MaxPagesCheckedDuringAlloc | Max pages checked during allocation.
OddFileSizeDetected | Odd file size detected.
OddFileSizeResolve | Odd file size resolved.
OutdatedInvisibleBuffersReused | Outdated invisible buffers reused.
PageAllocations | Number of page allocations.
Pages | Total number of pages.
PagesCheckedDuringAlloc | Pages checked during allocation.
PagesCreatedInCache | Pages created in the cache.
PagesInCache | Pages found in the cache.
PageSize | Assumed page size.
PagesNotInCache | Pages not found in the cache.
PagesRead | Pages read in.
PagesTrickled | Pages written by memp_trickle.
PagesWritten | Pages written out.
RegionLockNoWait | Region lock granted with nowait.
RegionLockWait | Region lock granted after wait.
RegionMax | Individual cache max.
RegionSize | Region size.
SyncInterrupted | Number of times sync interrupted.
ThawedBuffers | Buffers thawed.

See Also

MPoolStats Class


BlockedOperations Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.BlockedOperations Property
MPoolStats Class See Also Send Feedback
Thread waited on buffer I/O.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BlockedOperations { get; }
Visual Basic (Declaration)
Public ReadOnly Property BlockedOperations As ULong
Visual C++
public:
property unsigned long long BlockedOperations {
    unsigned long long get ();
}

See Also

MPoolStats Class


BucketsCheckedDuringAlloc Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.BucketsCheckedDuringAlloc Property
MPoolStats Class See Also Send Feedback
Buckets checked during allocation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BucketsCheckedDuringAlloc { get; }
Visual Basic (Declaration)
Public ReadOnly Property BucketsCheckedDuringAlloc As ULong
Visual C++
public:
property unsigned long long BucketsCheckedDuringAlloc {
    unsigned long long get ();
}

See Also

MPoolStats Class


CacheRegions Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.CacheRegions Property
MPoolStats Class See Also Send Feedback
Maximum number of regions.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CacheRegions { get; }
Visual Basic (Declaration)
Public ReadOnly Property CacheRegions As UInteger
Visual C++
public:
property unsigned int CacheRegions {
    unsigned int get ();
}

See Also

MPoolStats Class


CacheSettings Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.CacheSettings Property
MPoolStats Class See Also Send Feedback
Total cache size and number of regions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CacheInfo CacheSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property CacheSettings As CacheInfo
Visual C++
public:
property CacheInfo^ CacheSettings {
    CacheInfo^ get ();
}

See Also

MPoolStats Class


CleanPages Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.CleanPages Property
MPoolStats Class See Also Send Feedback
Clean pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CleanPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property CleanPages As UInteger
Visual C++
public:
property unsigned int CleanPages {
    unsigned int get ();
}

See Also

MPoolStats Class


CleanPagesEvicted Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.CleanPagesEvicted Property
MPoolStats Class See Also Send Feedback
Clean pages forced from the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong CleanPagesEvicted { get; }
Visual Basic (Declaration)
Public ReadOnly Property CleanPagesEvicted As ULong
Visual C++
public:
property unsigned long long CleanPagesEvicted {
    unsigned long long get ();
}

See Also

MPoolStats Class


DirtyPages Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.DirtyPages Property
MPoolStats Class See Also Send Feedback
Dirty pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DirtyPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property DirtyPages As UInteger
Visual C++
public:
property unsigned int DirtyPages {
    unsigned int get ();
}

See Also

MPoolStats Class


DirtyPagesEvicted Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.DirtyPagesEvicted Property
MPoolStats Class See Also Send Feedback
Dirty pages forced from the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong DirtyPagesEvicted { get; }
Visual Basic (Declaration)
Public ReadOnly Property DirtyPagesEvicted As ULong
Visual C++
public:
property unsigned long long DirtyPagesEvicted {
    unsigned long long get ();
}

See Also

MPoolStats Class


Files Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.Files Property
MPoolStats Class See Also Send Feedback
Stats for files open in the memory pool

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public List<MPoolFileStats> Files { get; }
Visual Basic (Declaration)
Public ReadOnly Property Files As List(Of MPoolFileStats)
Visual C++
public:
property List<MPoolFileStats^>^ Files {
    List<MPoolFileStats^>^ get ();
}

See Also

MPoolStats Class


FrozenBuffers Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.FrozenBuffers Property
MPoolStats Class See Also Send Feedback
Buffers frozen.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong FrozenBuffers { get; }
Visual Basic (Declaration)
Public ReadOnly Property FrozenBuffers As ULong
Visual C++
public:
property unsigned long long FrozenBuffers {
    unsigned long long get ();
}

See Also

MPoolStats Class


FrozenBuffersFreed Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.FrozenBuffersFreed Property
MPoolStats Class See Also Send Feedback
Frozen buffers freed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong FrozenBuffersFreed { get; }
Visual Basic (Declaration)
Public ReadOnly Property FrozenBuffersFreed As ULong
Visual C++
public:
property unsigned long long FrozenBuffersFreed {
    unsigned long long get ();
}

See Also

MPoolStats Class


HashBucketMutexes Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.HashBucketMutexes Property
MPoolStats Class See Also Send Feedback
Number of hash bucket mutexes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint HashBucketMutexes { get; }
Visual Basic (Declaration)
Public ReadOnly Property HashBucketMutexes As UInteger
Visual C++
public:
property unsigned int HashBucketMutexes {
    unsigned int get ();
}

See Also

MPoolStats Class


HashBuckets Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.HashBuckets Property
MPoolStats Class See Also Send Feedback
Number of hash buckets.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint HashBuckets { get; }
Visual Basic (Declaration)
Public ReadOnly Property HashBuckets As UInteger
Visual C++
public:
property unsigned int HashBuckets {
    unsigned int get ();
}

See Also

MPoolStats Class


HashChainSearches Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.HashChainSearches Property
MPoolStats Class See Also Send Feedback
Total hash chain searches.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint HashChainSearches { get; }
Visual Basic (Declaration)
Public ReadOnly Property HashChainSearches As UInteger
Visual C++
public:
property unsigned int HashChainSearches {
    unsigned int get ();
}

See Also

MPoolStats Class


HashEntriesSearched Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.HashEntriesSearched Property
MPoolStats Class See Also Send Feedback
Total hash entries searched.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong HashEntriesSearched { get; }
Visual Basic (Declaration)
Public ReadOnly Property HashEntriesSearched As ULong
Visual C++
public:
property unsigned long long HashEntriesSearched {
    unsigned long long get ();
}

See Also

MPoolStats Class


HashLockNoWait Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.HashLockNoWait Property
MPoolStats Class See Also Send Feedback
Hash lock granted with nowait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong HashLockNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property HashLockNoWait As ULong
Visual C++
public:
property unsigned long long HashLockNoWait {
    unsigned long long get ();
}

See Also

MPoolStats Class


HashLockWait Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.HashLockWait Property
MPoolStats Class See Also Send Feedback
Hash lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong HashLockWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property HashLockWait As ULong
Visual C++
public:
property unsigned long long HashLockWait {
    unsigned long long get ();
}

See Also

MPoolStats Class


LongestHashChainSearch Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.LongestHashChainSearch Property
MPoolStats Class See Also Send Feedback
Longest hash chain searched.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LongestHashChainSearch { get; }
Visual Basic (Declaration)
Public ReadOnly Property LongestHashChainSearch As UInteger
Visual C++
public:
property unsigned int LongestHashChainSearch {
    unsigned int get ();
}

See Also

MPoolStats Class


MappedPages Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MappedPages Property
MPoolStats Class See Also Send Feedback
Pages from mapped files.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MappedPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property MappedPages As UInteger
Visual C++
public:
property unsigned int MappedPages {
    unsigned int get ();
}

See Also

MPoolStats Class


MaxBucketsCheckedDuringAlloc Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MaxBucketsCheckedDuringAlloc Property
MPoolStats Class See Also Send Feedback
Max buckets checked during allocation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxBucketsCheckedDuringAlloc { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxBucketsCheckedDuringAlloc As ULong
Visual C++
public:
property unsigned long long MaxBucketsCheckedDuringAlloc {
    unsigned long long get ();
}

See Also

MPoolStats Class


MaxBufferWrites Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MaxBufferWrites Property
MPoolStats Class See Also Send Feedback
Maximum buffers to write.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int MaxBufferWrites { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxBufferWrites As Integer
Visual C++
public:
property int MaxBufferWrites {
    int get ();
}

See Also

MPoolStats Class


MaxBufferWritesSleep Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MaxBufferWritesSleep Property
MPoolStats Class See Also Send Feedback
Sleep after writing max buffers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxBufferWritesSleep { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxBufferWritesSleep As UInteger
Visual C++
public:
property unsigned int MaxBufferWritesSleep {
    unsigned int get ();
}

See Also

MPoolStats Class


MaxHashLockNoWait Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MaxHashLockNoWait Property
MPoolStats Class See Also Send Feedback
Max hash lock granted with nowait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxHashLockNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxHashLockNoWait As ULong
Visual C++
public:
property unsigned long long MaxHashLockNoWait {
    unsigned long long get ();
}

See Also

MPoolStats Class


MaxHashLockWait Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MaxHashLockWait Property
MPoolStats Class See Also Send Feedback
Max hash lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxHashLockWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxHashLockWait As ULong
Visual C++
public:
property unsigned long long MaxHashLockWait {
    unsigned long long get ();
}

See Also

MPoolStats Class


MaxMMapSize Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MaxMMapSize Property
MPoolStats Class See Also Send Feedback
Maximum file size for mmap.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxMMapSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxMMapSize As ULong
Visual C++
public:
property unsigned long long MaxMMapSize {
    unsigned long long get ();
}

See Also

MPoolStats Class


MaxOpenFileDescriptors Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MaxOpenFileDescriptors Property
MPoolStats Class See Also Send Feedback
Maximum number of open file descriptors.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int MaxOpenFileDescriptors { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxOpenFileDescriptors As Integer
Visual C++
public:
property int MaxOpenFileDescriptors {
    int get ();
}

See Also

MPoolStats Class


MaxPagesCheckedDuringAlloc Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.MaxPagesCheckedDuringAlloc Property
MPoolStats Class See Also Send Feedback
Max pages checked during allocation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxPagesCheckedDuringAlloc { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxPagesCheckedDuringAlloc As ULong
Visual C++
public:
property unsigned long long MaxPagesCheckedDuringAlloc {
    unsigned long long get ();
}

See Also

MPoolStats Class


OddFileSizeDetected Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.OddFileSizeDetected Property
MPoolStats Class See Also Send Feedback
Odd file size detected.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint OddFileSizeDetected { get; }
Visual Basic (Declaration)
Public ReadOnly Property OddFileSizeDetected As UInteger
Visual C++
public:
property unsigned int OddFileSizeDetected {
    unsigned int get ();
}

See Also

MPoolStats Class


OddFileSizeResolve Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.OddFileSizeResolve Property
MPoolStats Class See Also Send Feedback
Odd file size resolved.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint OddFileSizeResolve { get; }
Visual Basic (Declaration)
Public ReadOnly Property OddFileSizeResolve As UInteger
Visual C++
public:
property unsigned int OddFileSizeResolve {
    unsigned int get ();
}

See Also

MPoolStats Class


OutdatedInvisibleBuffersReused Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.OutdatedInvisibleBuffersReused Property
MPoolStats Class See Also Send Feedback
Outdated invisible buffers reused.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong OutdatedInvisibleBuffersReused { get; }
Visual Basic (Declaration)
Public ReadOnly Property OutdatedInvisibleBuffersReused As ULong
Visual C++
public:
property unsigned long long OutdatedInvisibleBuffersReused {
    unsigned long long get ();
}

See Also

MPoolStats Class


PageAllocations Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PageAllocations Property
MPoolStats Class See Also Send Feedback
Number of page allocations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PageAllocations { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageAllocations As ULong
Visual C++
public:
property unsigned long long PageAllocations {
    unsigned long long get ();
}

See Also

MPoolStats Class


Pages Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.Pages Property
MPoolStats Class See Also Send Feedback
Total number of pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Pages { get; }
Visual Basic (Declaration)
Public ReadOnly Property Pages As UInteger
Visual C++
public:
property unsigned int Pages {
    unsigned int get ();
}

See Also

MPoolStats Class


PagesCheckedDuringAlloc Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PagesCheckedDuringAlloc Property
MPoolStats Class See Also Send Feedback
Pages checked during allocation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesCheckedDuringAlloc { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesCheckedDuringAlloc As ULong
Visual C++
public:
property unsigned long long PagesCheckedDuringAlloc {
    unsigned long long get ();
}

See Also

MPoolStats Class


PagesCreatedInCache Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PagesCreatedInCache Property
MPoolStats Class See Also Send Feedback
Pages created in the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesCreatedInCache { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesCreatedInCache As ULong
Visual C++
public:
property unsigned long long PagesCreatedInCache {
    unsigned long long get ();
}

See Also

MPoolStats Class


PagesInCache Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PagesInCache Property
MPoolStats Class See Also Send Feedback
Pages found in the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesInCache { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesInCache As ULong
Visual C++
public:
property unsigned long long PagesInCache {
    unsigned long long get ();
}

See Also

MPoolStats Class


PageSize Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PageSize Property
MPoolStats Class See Also Send Feedback
Assumed page size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As UInteger
Visual C++
public:
property unsigned int PageSize {
    unsigned int get ();
}

See Also

MPoolStats Class


PagesNotInCache Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PagesNotInCache Property
MPoolStats Class See Also Send Feedback
Pages not found in the cache.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesNotInCache { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesNotInCache As ULong
Visual C++
public:
property unsigned long long PagesNotInCache {
    unsigned long long get ();
}

See Also

MPoolStats Class


PagesRead Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PagesRead Property
MPoolStats Class See Also Send Feedback
Pages read in.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesRead { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesRead As ULong
Visual C++
public:
property unsigned long long PagesRead {
    unsigned long long get ();
}

See Also

MPoolStats Class


PagesTrickled Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PagesTrickled Property
MPoolStats Class See Also Send Feedback
Pages written by memp_trickle.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesTrickled { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesTrickled As ULong
Visual C++
public:
property unsigned long long PagesTrickled {
    unsigned long long get ();
}

See Also

MPoolStats Class


PagesWritten Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.PagesWritten Property
MPoolStats Class See Also Send Feedback
Pages written out.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong PagesWritten { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesWritten As ULong
Visual C++
public:
property unsigned long long PagesWritten {
    unsigned long long get ();
}

See Also

MPoolStats Class


RegionLockNoWait Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.RegionLockNoWait Property
MPoolStats Class See Also Send Feedback
Region lock granted with nowait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionLockNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionLockNoWait As ULong
Visual C++
public:
property unsigned long long RegionLockNoWait {
    unsigned long long get ();
}

See Also

MPoolStats Class


RegionLockWait Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.RegionLockWait Property
MPoolStats Class See Also Send Feedback
Region lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionLockWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionLockWait As ULong
Visual C++
public:
property unsigned long long RegionLockWait {
    unsigned long long get ();
}

See Also

MPoolStats Class


RegionMax Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.RegionMax Property
MPoolStats Class See Also Send Feedback
Individual cache max.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionMax { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionMax As ULong
Visual C++
public:
property unsigned long long RegionMax {
    unsigned long long get ();
}

See Also

MPoolStats Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.RegionSize Property
MPoolStats Class See Also Send Feedback
Region size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionSize As ULong
Visual C++
public:
property unsigned long long RegionSize {
    unsigned long long get ();
}

See Also

MPoolStats Class


SyncInterrupted Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.SyncInterrupted Property
MPoolStats Class See Also Send Feedback
Number of times sync interrupted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong SyncInterrupted { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncInterrupted As ULong
Visual C++
public:
property unsigned long long SyncInterrupted {
    unsigned long long get ();
}

See Also

MPoolStats Class


ThawedBuffers Property

[image]

Berkeley DB .NET API Documentation
MPoolStats..::.ThawedBuffers Property
MPoolStats Class See Also Send Feedback
Buffers thawed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ThawedBuffers { get; }
Visual Basic (Declaration)
Public ReadOnly Property ThawedBuffers As ULong
Visual C++
public:
property unsigned long long ThawedBuffers {
    unsigned long long get ();
}

See Also

MPoolStats Class


MultipleDatabaseEntry Class

[image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry Class
Members See Also Send Feedback
A class providing access to multiple DatabaseEntry objects.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class MultipleDatabaseEntry : DatabaseEntry,
    IEnumerable<DatabaseEntry>, IEnumerable
Visual Basic (Declaration)
Public Class MultipleDatabaseEntry _
    Inherits DatabaseEntry _
    Implements IEnumerable(Of DatabaseEntry), IEnumerable
Visual C++
public ref class MultipleDatabaseEntry : public DatabaseEntry,
    IEnumerable<DatabaseEntry^>, IEnumerable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseEntry
BerkeleyDB..::.MultipleDatabaseEntry

See Also

MultipleDatabaseEntry Members


MultipleDatabaseEntry Members

[image] [image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry Members
MultipleDatabaseEntry Class Constructors Methods Properties See Also Send Feedback

The MultipleDatabaseEntry type exposes the following members.

Constructors

Name | Description
MultipleDatabaseEntry | Overloaded.

Methods

Name | Description
Dispose | Release the resources held by the underlying C library. (Inherited from DatabaseEntry.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Return an enumerator which iterates over all DatabaseEntry objects represented by the MultipleDatabaseEntry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Blob | Whether the record data will be stored as a blob, regardless of size. (Inherited from DatabaseEntry.)
Data | The byte string stored in or retrieved from a database (Inherited from DatabaseEntry.)
Partial | Whether the DatabaseEntry is partial record. (Inherited from DatabaseEntry.)
PartialLen | The byte length of the partial record being read or written by the application (Inherited from DatabaseEntry.)
PartialOffset | The offset of the partial record being read or written by the application, in bytes. (Inherited from DatabaseEntry.)
ReadOnly | Set this DatabaseEntry as read only - Berkeley DB cannot alter the entry. (Inherited from DatabaseEntry.)
Recno | Whether the bulk buffer is for recno or queue database.

See Also

MultipleDatabaseEntry Class


MultipleDatabaseEntry Constructor

[image] [image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry Constructor
MultipleDatabaseEntry Class See Also Send Feedback

Overload List

Name | Description
MultipleDatabaseEntry(IEnumerable<(Of <(UInt32>)>)) | Construct a new key or data bulk buffer with a bunch of record numbers, as keys in RecnoDatabase or QueueDatabase
MultipleDatabaseEntry(array<Byte>[]()[], Boolean) | Construct a new key or data bulk buffer with a formatted byte array.
MultipleDatabaseEntry(IEnumerable<(Of <(DatabaseEntry>)>), Boolean) | Construct a new key or data bulk buffer with a bunch of DatabaseEntry referring to recno.

See Also

MultipleDatabaseEntry Class
MultipleDatabaseEntry Members


MultipleDatabaseEntry Constructor (IEnumerable(UInt32))

[image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry Constructor (IEnumerable<(Of <(UInt32>)>))
MultipleDatabaseEntry Class See Also Send Feedback
Construct a new key or data bulk buffer with a bunch of record numbers, as keys in RecnoDatabase or QueueDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MultipleDatabaseEntry(
    IEnumerable<uint> recnos
)
Visual Basic (Declaration)
Public Sub New ( _
    recnos As IEnumerable(Of UInteger) _
)
Visual C++
public:
MultipleDatabaseEntry(
    IEnumerable<unsigned int>^ recnos
)

Parameters

recnos
Type: System.Collections.Generic..::.IEnumerable <(Of <( UInt32 >)>)
Enumerable record numbers

See Also

MultipleDatabaseEntry Class
MultipleDatabaseEntry Overload


MultipleDatabaseEntry Constructor (Byte[], Boolean)

[image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry Constructor (array<Byte>[]()[], Boolean)
MultipleDatabaseEntry Class See Also Send Feedback
Construct a new key or data bulk buffer with a formatted byte array.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MultipleDatabaseEntry(
    byte[] data,
    bool recno
)
Visual Basic (Declaration)
Public Sub New ( _
    data As Byte(), _
    recno As Boolean _
)
Visual C++
public:
MultipleDatabaseEntry(
    array<unsigned char>^ data,
    bool recno
)

Parameters

data
Type: array< System..::.Byte >[]()[]
The formatted byte array
recno
Type: System..::.Boolean
Whether it is buffer for keys in RecnoDatabase or QueueDatabase

See Also

MultipleDatabaseEntry Class
MultipleDatabaseEntry Overload


MultipleDatabaseEntry Constructor (IEnumerable(DatabaseEntry), Boolean)

[image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry Constructor (IEnumerable<(Of <(DatabaseEntry>)>), Boolean)
MultipleDatabaseEntry Class See Also Send Feedback
Construct a new key or data bulk buffer with a bunch of DatabaseEntry referring to recno.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MultipleDatabaseEntry(
    IEnumerable<DatabaseEntry> data,
    bool recno
)
Visual Basic (Declaration)
Public Sub New ( _
    data As IEnumerable(Of DatabaseEntry), _
    recno As Boolean _
)
Visual C++
public:
MultipleDatabaseEntry(
    IEnumerable<DatabaseEntry^>^ data,
    bool recno
)

Parameters

data
Type: System.Collections.Generic..::.IEnumerable <(Of <( DatabaseEntry >)>)
Enumerable data
recno
Type: System..::.Boolean
Whether it is buffer for keys in RecnoDatabase or QueueDatabase

See Also

MultipleDatabaseEntry Class
MultipleDatabaseEntry Overload


MultipleDatabaseEntry Methods

[image] [image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry Methods
MultipleDatabaseEntry Class See Also Send Feedback

The MultipleDatabaseEntry type exposes the following members.

Methods

Name | Description
Dispose | Release the resources held by the underlying C library. (Inherited from DatabaseEntry.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Return an enumerator which iterates over all DatabaseEntry objects represented by the MultipleDatabaseEntry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MultipleDatabaseEntry Class


GetEnumerator Method

[image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry..::.GetEnumerator Method
MultipleDatabaseEntry Class See Also Send Feedback
Return an enumerator which iterates over all DatabaseEntry objects represented by the MultipleDatabaseEntry.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public IEnumerator<DatabaseEntry> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of DatabaseEntry)
Visual C++
public:
virtual IEnumerator<DatabaseEntry^>^ GetEnumerator() sealed

Return Value

An enumerator for the MultipleDatabaseEntry

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

MultipleDatabaseEntry Class


MultipleDatabaseEntry Properties

[image] [image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry Properties
MultipleDatabaseEntry Class See Also Send Feedback

The MultipleDatabaseEntry type exposes the following members.

Properties

Name | Description
Blob | Whether the record data will be stored as a blob, regardless of size. (Inherited from DatabaseEntry.)
Data | The byte string stored in or retrieved from a database (Inherited from DatabaseEntry.)
Partial | Whether the DatabaseEntry is partial record. (Inherited from DatabaseEntry.)
PartialLen | The byte length of the partial record being read or written by the application (Inherited from DatabaseEntry.)
PartialOffset | The offset of the partial record being read or written by the application, in bytes. (Inherited from DatabaseEntry.)
ReadOnly | Set this DatabaseEntry as read only - Berkeley DB cannot alter the entry. (Inherited from DatabaseEntry.)
Recno | Whether the bulk buffer is for recno or queue database.

See Also

MultipleDatabaseEntry Class


Recno Property

[image]

Berkeley DB .NET API Documentation
MultipleDatabaseEntry..::.Recno Property
MultipleDatabaseEntry Class See Also Send Feedback
Whether the bulk buffer is for recno or queue database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Recno { get; }
Visual Basic (Declaration)
Public ReadOnly Property Recno As Boolean
Visual C++
public:
property bool Recno {
    bool get ();
}

See Also

MultipleDatabaseEntry Class


MultipleKeyDatabaseEntry Class

[image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry Class
Members See Also Send Feedback
A class providing access to multiple key/data pairs.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class MultipleKeyDatabaseEntry : DatabaseEntry,
    IEnumerable<KeyValuePair<DatabaseEntry, DatabaseEntry>>, IEnumerable
Visual Basic (Declaration)
Public Class MultipleKeyDatabaseEntry _
    Inherits DatabaseEntry _
    Implements IEnumerable(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry)),  _
    IEnumerable
Visual C++
public ref class MultipleKeyDatabaseEntry : public DatabaseEntry,
    IEnumerable<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>, IEnumerable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseEntry
BerkeleyDB..::.MultipleKeyDatabaseEntry

See Also

MultipleKeyDatabaseEntry Members


MultipleKeyDatabaseEntry Members

[image] [image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry Members
MultipleKeyDatabaseEntry Class Constructors Methods Properties See Also Send Feedback

The MultipleKeyDatabaseEntry type exposes the following members.

Constructors

Name | Description
MultipleKeyDatabaseEntry | Overloaded.

Methods

Name | Description
Dispose | Release the resources held by the underlying C library. (Inherited from DatabaseEntry.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Return an enumerator which iterates over all DatabaseEntry pairs represented by the MultipleKeyDatabaseEntry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Blob | Whether the record data will be stored as a blob, regardless of size. (Inherited from DatabaseEntry.)
Data | The byte string stored in or retrieved from a database (Inherited from DatabaseEntry.)
Partial | Whether the DatabaseEntry is partial record. (Inherited from DatabaseEntry.)
PartialLen | The byte length of the partial record being read or written by the application (Inherited from DatabaseEntry.)
PartialOffset | The offset of the partial record being read or written by the application, in bytes. (Inherited from DatabaseEntry.)
ReadOnly | Set this DatabaseEntry as read only - Berkeley DB cannot alter the entry. (Inherited from DatabaseEntry.)
Recno | Whether the bulk buffer is for recno or queue database.

See Also

MultipleKeyDatabaseEntry Class


MultipleKeyDatabaseEntry Constructor

[image] [image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry Constructor
MultipleKeyDatabaseEntry Class See Also Send Feedback

Overload List

Name | Description
MultipleKeyDatabaseEntry(array<Byte>[]()[], Boolean) | Construct a new bulk buffer for key/data pairs with a formatted byte array.
MultipleKeyDatabaseEntry(IEnumerable<(Of <(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>)>)>), Boolean) | Construct a new bulk buffer for key/data pairs.

See Also

MultipleKeyDatabaseEntry Class
MultipleKeyDatabaseEntry Members


MultipleKeyDatabaseEntry Constructor (Byte[], Boolean)

[image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry Constructor (array<Byte>[]()[], Boolean)
MultipleKeyDatabaseEntry Class See Also Send Feedback
Construct a new bulk buffer for key/data pairs with a formatted byte array.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MultipleKeyDatabaseEntry(
    byte[] data,
    bool recno
)
Visual Basic (Declaration)
Public Sub New ( _
    data As Byte(), _
    recno As Boolean _
)
Visual C++
public:
MultipleKeyDatabaseEntry(
    array<unsigned char>^ data,
    bool recno
)

Parameters

data
Type: array< System..::.Byte >[]()[]
The formatted byte array
recno
Type: System..::.Boolean
Whether the bulk is for recno/queue database.

See Also

MultipleKeyDatabaseEntry Class
MultipleKeyDatabaseEntry Overload


MultipleKeyDatabaseEntry Constructor (IEnumerable(KeyValuePair(DatabaseEntry, DatabaseEntry)), Boolean)

[image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry Constructor (IEnumerable<(Of <(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>)>)>), Boolean)
MultipleKeyDatabaseEntry Class See Also Send Feedback
Construct a new bulk buffer for key/data pairs.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MultipleKeyDatabaseEntry(
    IEnumerable<KeyValuePair<DatabaseEntry, DatabaseEntry>> data,
    bool recno
)
Visual Basic (Declaration)
Public Sub New ( _
    data As IEnumerable(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry)), _
    recno As Boolean _
)
Visual C++
public:
MultipleKeyDatabaseEntry(
    IEnumerable<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>^ data,
    bool recno
)

Parameters

data
Type: System.Collections.Generic..::.IEnumerable <(Of <( KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)>)>)
Enumerable key/data pairs
recno
Type: System..::.Boolean
Whether the bulk buffer is for queue/recno database

See Also

MultipleKeyDatabaseEntry Class
MultipleKeyDatabaseEntry Overload


MultipleKeyDatabaseEntry Methods

[image] [image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry Methods
MultipleKeyDatabaseEntry Class See Also Send Feedback

The MultipleKeyDatabaseEntry type exposes the following members.

Methods

Name | Description
Dispose | Release the resources held by the underlying C library. (Inherited from DatabaseEntry.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Return an enumerator which iterates over all DatabaseEntry pairs represented by the MultipleKeyDatabaseEntry.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MultipleKeyDatabaseEntry Class


GetEnumerator Method

[image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry..::.GetEnumerator Method
MultipleKeyDatabaseEntry Class See Also Send Feedback
Return an enumerator which iterates over all DatabaseEntry pairs represented by the MultipleKeyDatabaseEntry.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public IEnumerator<KeyValuePair<DatabaseEntry, DatabaseEntry>> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of DatabaseEntry, DatabaseEntry))
Visual C++
public:
virtual IEnumerator<KeyValuePair<DatabaseEntry^, DatabaseEntry^>>^ GetEnumerator() sealed

Return Value

An enumerator for the MultipleDatabaseEntry

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

MultipleKeyDatabaseEntry Class


MultipleKeyDatabaseEntry Properties

[image] [image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry Properties
MultipleKeyDatabaseEntry Class See Also Send Feedback

The MultipleKeyDatabaseEntry type exposes the following members.

Properties

Name | Description
Blob | Whether the record data will be stored as a blob, regardless of size. (Inherited from DatabaseEntry.)
Data | The byte string stored in or retrieved from a database (Inherited from DatabaseEntry.)
Partial | Whether the DatabaseEntry is partial record. (Inherited from DatabaseEntry.)
PartialLen | The byte length of the partial record being read or written by the application (Inherited from DatabaseEntry.)
PartialOffset | The offset of the partial record being read or written by the application, in bytes. (Inherited from DatabaseEntry.)
ReadOnly | Set this DatabaseEntry as read only - Berkeley DB cannot alter the entry. (Inherited from DatabaseEntry.)
Recno | Whether the bulk buffer is for recno or queue database.

See Also

MultipleKeyDatabaseEntry Class


Recno Property

[image]

Berkeley DB .NET API Documentation
MultipleKeyDatabaseEntry..::.Recno Property
MultipleKeyDatabaseEntry Class See Also Send Feedback
Whether the bulk buffer is for recno or queue database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Recno { get; }
Visual Basic (Declaration)
Public ReadOnly Property Recno As Boolean
Visual C++
public:
property bool Recno {
    bool get ();
}

See Also

MultipleKeyDatabaseEntry Class


MutexConfig Class

[image]

Berkeley DB .NET API Documentation
MutexConfig Class
Members See Also Send Feedback
A class representing configuration parameters for a DatabaseEnvironment's mutex subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class MutexConfig
Visual Basic (Declaration)
Public Class MutexConfig
Visual C++
public ref class MutexConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.MutexConfig

See Also

MutexConfig Members


MutexConfig Members

[image] [image]

Berkeley DB .NET API Documentation
MutexConfig Members
MutexConfig Class Constructors Methods Properties See Also Send Feedback

The MutexConfig type exposes the following members.

Constructors

Name | Description
MutexConfig | Initializes a new instance of the MutexConfig class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Alignment | The mutex alignment, in bytes.
Increment | Configure the number of additional mutexes to allocate.
InitMutexes | The initial number of mutexes to allocate.
MaxMutexes | The total number of mutexes to allocate.
NumTestAndSetSpins | The number of spins test-and-set mutexes should execute before blocking.

See Also

MutexConfig Class


MutexConfig Constructor

[image]

Berkeley DB .NET API Documentation
MutexConfig Constructor
MutexConfig Class See Also Send Feedback
Initializes a new instance of the MutexConfig class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public MutexConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MutexConfig()

See Also

MutexConfig Class


MutexConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
MutexConfig Methods
MutexConfig Class See Also Send Feedback

The MutexConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MutexConfig Class


MutexConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
MutexConfig Properties
MutexConfig Class See Also Send Feedback

The MutexConfig type exposes the following members.

Properties

Name | Description
Alignment | The mutex alignment, in bytes.
Increment | Configure the number of additional mutexes to allocate.
InitMutexes | The initial number of mutexes to allocate.
MaxMutexes | The total number of mutexes to allocate.
NumTestAndSetSpins | The number of spins test-and-set mutexes should execute before blocking.

See Also

MutexConfig Class


Alignment Property

[image]

Berkeley DB .NET API Documentation
MutexConfig..::.Alignment Property
MutexConfig Class See Also Send Feedback
The mutex alignment, in bytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Alignment { get; set; }
Visual Basic (Declaration)
Public Property Alignment As UInteger
Visual C++
public:
property unsigned int Alignment {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

It is sometimes advantageous to align mutexes on specific byte boundaries in order to minimize cache line collisions. Alignment specifies an alignment for mutexes allocated by Berkeley DB.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of Alignment is ignored.

See Also

MutexConfig Class


Increment Property

[image]

Berkeley DB .NET API Documentation
MutexConfig..::.Increment Property
MutexConfig Class See Also Send Feedback
Configure the number of additional mutexes to allocate.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Increment { get; set; }
Visual Basic (Declaration)
Public Property Increment As UInteger
Visual C++
public:
property unsigned int Increment {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

If both Increment and MaxMutexes are set, the value of Increment is silently ignored.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of Increment will be ignored.

See Also

MutexConfig Class


InitMutexes Property

[image]

Berkeley DB .NET API Documentation
MutexConfig..::.InitMutexes Property
MutexConfig Class See Also Send Feedback
The initial number of mutexes to allocate.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitMutexes { get; set; }
Visual Basic (Declaration)
Public Property InitMutexes As UInteger
Visual C++
public:
property unsigned int InitMutexes {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Berkeley DB allocates a default number of mutexes based on the initial configuration of the database environment. This method allows the user to override that default value.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of InitMutexes is ignored.

See Also

MutexConfig Class


MaxMutexes Property

[image]

Berkeley DB .NET API Documentation
MutexConfig..::.MaxMutexes Property
MutexConfig Class See Also Send Feedback
The total number of mutexes to allocate.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxMutexes { get; set; }
Visual Basic (Declaration)
Public Property MaxMutexes As UInteger
Visual C++
public:
property unsigned int MaxMutexes {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Berkeley DB allocates a default number of mutexes based on the initial configuration of the database environment. That default calculation may be too small if the application has an unusual need for mutexes (for example, if the application opens an unexpectedly large number of databases) or too large (if the application is trying to minimize its memory footprint). MaxMutexes is used to specify an absolute number of mutexes to allocate.

If both Increment and MaxMutexes are set, the value of Increment is silently ignored.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of MaxMutexes is ignored.

See Also

MutexConfig Class


NumTestAndSetSpins Property

[image]

Berkeley DB .NET API Documentation
MutexConfig..::.NumTestAndSetSpins Property
MutexConfig Class See Also Send Feedback
The number of spins test-and-set mutexes should execute before blocking.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NumTestAndSetSpins { get; set; }
Visual Basic (Declaration)
Public Property NumTestAndSetSpins As UInteger
Visual C++
public:
property unsigned int NumTestAndSetSpins {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

MutexConfig Class


MutexStats Class

[image]

Berkeley DB .NET API Documentation
MutexStats Class
Members See Also Send Feedback
Statistical information about the mutex subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class MutexStats
Visual Basic (Declaration)
Public Class MutexStats
Visual C++
public ref class MutexStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.MutexStats

See Also

MutexStats Members


MutexStats Members

[image] [image]

Berkeley DB .NET API Documentation
MutexStats Members
MutexStats Class Methods Properties See Also Send Feedback

The MutexStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Alignment | Mutex alignment
Available | Available mutexes
Count | Mutex count
InitCount | Mutex initial count
InUse | Mutexes in use
Max | Mutex max count
MaxInUse | Maximum mutexes ever in use
RegionMax | Mutex region max size.
RegionNoWait | Region lock granted without wait.
RegionSize | Region size.
RegionWait | Region lock granted after wait.
TASSpins | Mutex test-and-set spins

See Also

MutexStats Class


MutexStats Methods

[image] [image]

Berkeley DB .NET API Documentation
MutexStats Methods
MutexStats Class See Also Send Feedback

The MutexStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

MutexStats Class


MutexStats Properties

[image] [image]

Berkeley DB .NET API Documentation
MutexStats Properties
MutexStats Class See Also Send Feedback

The MutexStats type exposes the following members.

Properties

Name | Description
Alignment | Mutex alignment
Available | Available mutexes
Count | Mutex count
InitCount | Mutex initial count
InUse | Mutexes in use
Max | Mutex max count
MaxInUse | Maximum mutexes ever in use
RegionMax | Mutex region max size.
RegionNoWait | Region lock granted without wait.
RegionSize | Region size.
RegionWait | Region lock granted after wait.
TASSpins | Mutex test-and-set spins

See Also

MutexStats Class


Alignment Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.Alignment Property
MutexStats Class See Also Send Feedback
Mutex alignment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Alignment { get; }
Visual Basic (Declaration)
Public ReadOnly Property Alignment As UInteger
Visual C++
public:
property unsigned int Alignment {
    unsigned int get ();
}

See Also

MutexStats Class


Available Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.Available Property
MutexStats Class See Also Send Feedback
Available mutexes

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Available { get; }
Visual Basic (Declaration)
Public ReadOnly Property Available As UInteger
Visual C++
public:
property unsigned int Available {
    unsigned int get ();
}

See Also

MutexStats Class


Count Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.Count Property
MutexStats Class See Also Send Feedback
Mutex count

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As UInteger
Visual C++
public:
property unsigned int Count {
    unsigned int get ();
}

See Also

MutexStats Class


InitCount Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.InitCount Property
MutexStats Class See Also Send Feedback
Mutex initial count

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitCount As UInteger
Visual C++
public:
property unsigned int InitCount {
    unsigned int get ();
}

See Also

MutexStats Class


InUse Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.InUse Property
MutexStats Class See Also Send Feedback
Mutexes in use

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property InUse As UInteger
Visual C++
public:
property unsigned int InUse {
    unsigned int get ();
}

See Also

MutexStats Class


Max Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.Max Property
MutexStats Class See Also Send Feedback
Mutex max count

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Max { get; }
Visual Basic (Declaration)
Public ReadOnly Property Max As UInteger
Visual C++
public:
property unsigned int Max {
    unsigned int get ();
}

See Also

MutexStats Class


MaxInUse Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.MaxInUse Property
MutexStats Class See Also Send Feedback
Maximum mutexes ever in use

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxInUse { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxInUse As UInteger
Visual C++
public:
property unsigned int MaxInUse {
    unsigned int get ();
}

See Also

MutexStats Class


RegionMax Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.RegionMax Property
MutexStats Class See Also Send Feedback
Mutex region max size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionMax { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionMax As ULong
Visual C++
public:
property unsigned long long RegionMax {
    unsigned long long get ();
}

See Also

MutexStats Class


RegionNoWait Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.RegionNoWait Property
MutexStats Class See Also Send Feedback
Region lock granted without wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionNoWait As ULong
Visual C++
public:
property unsigned long long RegionNoWait {
    unsigned long long get ();
}

See Also

MutexStats Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.RegionSize Property
MutexStats Class See Also Send Feedback
Region size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionSize As ULong
Visual C++
public:
property unsigned long long RegionSize {
    unsigned long long get ();
}

See Also

MutexStats Class


RegionWait Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.RegionWait Property
MutexStats Class See Also Send Feedback
Region lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionWait As ULong
Visual C++
public:
property unsigned long long RegionWait {
    unsigned long long get ();
}

See Also

MutexStats Class


TASSpins Property

[image]

Berkeley DB .NET API Documentation
MutexStats..::.TASSpins Property
MutexStats Class See Also Send Feedback
Mutex test-and-set spins

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TASSpins { get; }
Visual Basic (Declaration)
Public ReadOnly Property TASSpins As UInteger
Visual C++
public:
property unsigned int TASSpins {
    unsigned int get ();
}

See Also

MutexStats Class


NotFoundException Class

[image]

Berkeley DB .NET API Documentation
NotFoundException Class
Members See Also Send Feedback
The requested key/data pair did not exist in the database or that start-of- or end-of-file has been reached by a cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class NotFoundException : DatabaseException
Visual Basic (Declaration)
Public Class NotFoundException _
    Inherits DatabaseException
Visual C++
public ref class NotFoundException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.NotFoundException

See Also

NotFoundException Members


NotFoundException Members

[image] [image]

Berkeley DB .NET API Documentation
NotFoundException Members
NotFoundException Class Constructors Methods Fields Properties See Also Send Feedback

The NotFoundException type exposes the following members.

Constructors

Name | Description
NotFoundException | Initialize a new instance of the NotFoundException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NotFoundException Class


NotFoundException Constructor

[image]

Berkeley DB .NET API Documentation
NotFoundException Constructor
NotFoundException Class See Also Send Feedback
Initialize a new instance of the NotFoundException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public NotFoundException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NotFoundException()

See Also

NotFoundException Class


NotFoundException Fields

[image] [image]

Berkeley DB .NET API Documentation
NotFoundException Fields
NotFoundException Class See Also Send Feedback

The NotFoundException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

NotFoundException Class


NotFoundException Methods

[image] [image]

Berkeley DB .NET API Documentation
NotFoundException Methods
NotFoundException Class See Also Send Feedback

The NotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

NotFoundException Class


NotFoundException Properties

[image] [image]

Berkeley DB .NET API Documentation
NotFoundException Properties
NotFoundException Class See Also Send Feedback

The NotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

NotFoundException Class


NotificationEvent Enumeration

[image]

Berkeley DB .NET API Documentation
NotificationEvent Enumeration
See Also Send Feedback
Specify a Berkeley DB event

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum NotificationEvent
Visual Basic (Declaration)
Public Enumeration NotificationEvent
Visual C++
public enum class NotificationEvent

Members

Member name | Description
PANIC | The database environment has failed.
REP_AUTOTAKEOVER_FAILED | The replication manager subordinate process was unable to take over as the replication process.
REP_CLIENT | The local site is now a replication client.
REP_CONNECT_BROKEN | A previously established connection has been broken.
REP_CONNECT_ESTD | A connection with a remote site has been established.
REP_CONNECT_TRY_FAILED | An attempt to establish a new connection to a known remote site failed.
REP_DUPMASTER | A duplicate master site has been discovered in the replication group.
REP_ELECTED | The local replication site has just won an election.
REP_ELECTION_FAILED | The local site's attempt to initiate or participate in a replication master election failed, due to the lack of timely message response from a sufficient number of remote sites.
REP_INIT_DONE | The internal initialization has been completed.
REP_INQUEUE_FULL | Incoming messages have been dropped because the Replication Mananger incoming queue has reached its maximum threshold.
REP_JOIN_FAILURE | The local site could not synchronize with the master because an internal initialization was required, but internal initialization has been turned off by RepAutoInit.
REP_LOCAL_SITE_REMOVED | The local site has been removed from the group.
REP_MASTER | The local site is now the master site of its replication group. It is the application's responsibility to begin acting as the master environment.
REP_MASTER_FAILURE | The connection to the remote master replication site has failed.
REP_NEWMASTER | The replication group of which this site is a member has just established a new master; the local site is not the new master. The event_info parameter to the EventNotifyDelegate stores an integer containing the environment ID of the new master.
REP_PERM_FAILED | The replication manager did not receive enough acknowledgements (based on the acknowledgement policy configured with RepMgrAckPolicy) to ensure a transaction's durability within the replication group. The transaction will be flushed to the master's local disk storage for durability.
REP_STARTUPDONE | The client has completed startup synchronization and is now processing live log records received from the master.
REP_SITE_ADDED | A new site has joined the group.
REP_SITE_REMOVED | An existing remote site has been removed from the group.
WRITE_FAILED | A Berkeley DB write to stable storage failed.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


OldVersionException Class

[image]

Berkeley DB .NET API Documentation
OldVersionException Class
Members See Also Send Feedback
This version of Berkeley DB is unable to upgrade a given database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class OldVersionException : DatabaseException
Visual Basic (Declaration)
Public Class OldVersionException _
    Inherits DatabaseException
Visual C++
public ref class OldVersionException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.OldVersionException

See Also

OldVersionException Members


OldVersionException Members

[image] [image]

Berkeley DB .NET API Documentation
OldVersionException Members
OldVersionException Class Constructors Methods Fields Properties See Also Send Feedback

The OldVersionException type exposes the following members.

Constructors

Name | Description
OldVersionException | Initialize a new instance of the OldVersionException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OldVersionException Class


OldVersionException Constructor

[image]

Berkeley DB .NET API Documentation
OldVersionException Constructor
OldVersionException Class See Also Send Feedback
Initialize a new instance of the OldVersionException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public OldVersionException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OldVersionException()

See Also

OldVersionException Class


OldVersionException Fields

[image] [image]

Berkeley DB .NET API Documentation
OldVersionException Fields
OldVersionException Class See Also Send Feedback

The OldVersionException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

OldVersionException Class


OldVersionException Methods

[image] [image]

Berkeley DB .NET API Documentation
OldVersionException Methods
OldVersionException Class See Also Send Feedback

The OldVersionException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

OldVersionException Class


OldVersionException Properties

[image] [image]

Berkeley DB .NET API Documentation
OldVersionException Properties
OldVersionException Class See Also Send Feedback

The OldVersionException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OldVersionException Class


PageNotFoundException Class

[image]

Berkeley DB .NET API Documentation
PageNotFoundException Class
Members See Also Send Feedback

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class PageNotFoundException : DatabaseException
Visual Basic (Declaration)
Public Class PageNotFoundException _
    Inherits DatabaseException
Visual C++
public ref class PageNotFoundException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.PageNotFoundException

See Also

PageNotFoundException Members


PageNotFoundException Members

[image] [image]

Berkeley DB .NET API Documentation
PageNotFoundException Members
PageNotFoundException Class Constructors Methods Fields Properties See Also Send Feedback

The PageNotFoundException type exposes the following members.

Constructors

Name | Description
PageNotFoundException | Initializes a new instance of the PageNotFoundException class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PageNotFoundException Class


PageNotFoundException Constructor

[image]

Berkeley DB .NET API Documentation
PageNotFoundException Constructor
PageNotFoundException Class See Also Send Feedback
Initializes a new instance of the PageNotFoundException class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public PageNotFoundException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PageNotFoundException()

See Also

PageNotFoundException Class


PageNotFoundException Fields

[image] [image]

Berkeley DB .NET API Documentation
PageNotFoundException Fields
PageNotFoundException Class See Also Send Feedback

The PageNotFoundException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

PageNotFoundException Class


PageNotFoundException Methods

[image] [image]

Berkeley DB .NET API Documentation
PageNotFoundException Methods
PageNotFoundException Class See Also Send Feedback

The PageNotFoundException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

PageNotFoundException Class


PageNotFoundException Properties

[image] [image]

Berkeley DB .NET API Documentation
PageNotFoundException Properties
PageNotFoundException Class See Also Send Feedback

The PageNotFoundException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

PageNotFoundException Class


PartitionDelegate Delegate

[image]

Berkeley DB .NET API Documentation
PartitionDelegate Delegate
See Also Send Feedback
An application-specified partitioning function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate uint PartitionDelegate(
    DatabaseEntry key
)
Visual Basic (Declaration)
Public Delegate Function PartitionDelegate ( _
    key As DatabaseEntry _
) As UInteger
Visual C++
public delegate unsigned int PartitionDelegate(
    DatabaseEntry^ key
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The value used to determine which partition number should be returned.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


PreparedTransaction Class

[image]

Berkeley DB .NET API Documentation
PreparedTransaction Class
Members See Also Send Feedback
A class representing a transaction that must be resolved by the application following Recover(Int32, Boolean).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class PreparedTransaction
Visual Basic (Declaration)
Public Class PreparedTransaction
Visual C++
public ref class PreparedTransaction

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.PreparedTransaction

See Also

PreparedTransaction Members


PreparedTransaction Members

[image] [image]

Berkeley DB .NET API Documentation
PreparedTransaction Members
PreparedTransaction Class Methods Properties See Also Send Feedback

The PreparedTransaction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
GlobalID | The global transaction ID for the transaction. The global transaction ID is the one specified when the transaction was prepared. The application is responsible for ensuring uniqueness among global transaction IDs.
Txn | The transaction which must be committed, aborted or discarded.

See Also

PreparedTransaction Class


PreparedTransaction Methods

[image] [image]

Berkeley DB .NET API Documentation
PreparedTransaction Methods
PreparedTransaction Class See Also Send Feedback

The PreparedTransaction type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

PreparedTransaction Class


PreparedTransaction Properties

[image] [image]

Berkeley DB .NET API Documentation
PreparedTransaction Properties
PreparedTransaction Class See Also Send Feedback

The PreparedTransaction type exposes the following members.

Properties

Name | Description
GlobalID | The global transaction ID for the transaction. The global transaction ID is the one specified when the transaction was prepared. The application is responsible for ensuring uniqueness among global transaction IDs.
Txn | The transaction which must be committed, aborted or discarded.

See Also

PreparedTransaction Class


GlobalID Property

[image]

Berkeley DB .NET API Documentation
PreparedTransaction..::.GlobalID Property
PreparedTransaction Class See Also Send Feedback
The global transaction ID for the transaction. The global transaction ID is the one specified when the transaction was prepared. The application is responsible for ensuring uniqueness among global transaction IDs.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public byte[] GlobalID { get; }
Visual Basic (Declaration)
Public ReadOnly Property GlobalID As Byte()
Visual C++
public:
property array<unsigned char>^ GlobalID {
    array<unsigned char>^ get ();
}

See Also

PreparedTransaction Class


Txn Property

[image]

Berkeley DB .NET API Documentation
PreparedTransaction..::.Txn Property
PreparedTransaction Class See Also Send Feedback
The transaction which must be committed, aborted or discarded.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Transaction Txn { get; }
Visual Basic (Declaration)
Public ReadOnly Property Txn As Transaction
Visual C++
public:
property Transaction^ Txn {
    Transaction^ get ();
}

See Also

PreparedTransaction Class


QueueDatabase Class

[image]

Berkeley DB .NET API Documentation
QueueDatabase Class
Members See Also Send Feedback
A class representing a QueueDatabase. The Queue format supports fast access to fixed-length records accessed sequentially or by logical record number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class QueueDatabase : Database
Visual Basic (Declaration)
Public Class QueueDatabase _
    Inherits Database
Visual C++
public ref class QueueDatabase : public Database

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.Database
BerkeleyDB..::.QueueDatabase

See Also

QueueDatabase Members


QueueDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase Members
QueueDatabase Class Methods Properties See Also Send Feedback

The QueueDatabase type exposes the following members.

Methods

Name | Description
Append | Overloaded.
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Consume | Overloaded.
Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by BTreeStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
ExtentSize | The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
InOrder | If true, modify the operation of Consume(Boolean) to return key/data pairs in order. They always return the key/data item from the head of the queue.
Length | The length of records in the database.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
PadByte | The padding character for short, fixed-length records.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class


QueueDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase Methods
QueueDatabase Class See Also Send Feedback

The QueueDatabase type exposes the following members.

Methods

Name | Description
Append | Overloaded.
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Consume | Overloaded.
Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by BTreeStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

See Also

QueueDatabase Class


Append Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Append Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Append(DatabaseEntry) | Append the data item to the end of the database.
Append(DatabaseEntry, Transaction) | Append the data item to the end of the database.

See Also

QueueDatabase Class
QueueDatabase Members


Append Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Append Method (DatabaseEntry)
QueueDatabase Class See Also Send Feedback
Append the data item to the end of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Append(
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function Append ( _
    data As DatabaseEntry _
) As UInteger
Visual C++
public:
unsigned int Append(
    DatabaseEntry^ data
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database

Return Value

The record number allocated to the record

See Also

QueueDatabase Class
Append Overload


Append Method (DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Append Method (DatabaseEntry, Transaction)
QueueDatabase Class See Also Send Feedback
Append the data item to the end of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Append(
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Append ( _
    data As DatabaseEntry, _
    txn As Transaction _
) As UInteger
Visual C++
public:
unsigned int Append(
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The record number allocated to the record

Remarks

There is a minor behavioral difference between Append(DatabaseEntry) and Append(DatabaseEntry). If a transaction enclosing an Append operation aborts, the record number may be reallocated in a subsequent Append(DatabaseEntry) operation, but it is not reallocated in a subsequent Append(DatabaseEntry) operation.

See Also

QueueDatabase Class
Append Overload


Close Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Close Method
QueueDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


Consume Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Consume Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Consume(Boolean) | Return the record number and data from the available record closest to the head of the queue, and delete the record.
Consume(Boolean, Transaction) | Return the record number and data from the available record closest to the head of the queue, and delete the record.
Consume(Boolean, Transaction, LockingInfo) | Return the record number and data from the available record closest to the head of the queue, and delete the record.

See Also

QueueDatabase Class
QueueDatabase Members


Consume Method (Boolean)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Consume Method (Boolean)
QueueDatabase Class See Also Send Feedback
Return the record number and data from the available record closest to the head of the queue, and delete the record.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<uint, DatabaseEntry> Consume(
    bool wait
)
Visual Basic (Declaration)
Public Function Consume ( _
    wait As Boolean _
) As KeyValuePair(Of UInteger, DatabaseEntry)
Visual C++
public:
KeyValuePair<unsigned int, DatabaseEntry^> Consume(
    bool wait
)

Parameters

wait
Type: System..::.Boolean
If true and the Queue database is empty, the thread of control waits until there is data in the queue before returning.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is the record number and whose Value parameter is the retrieved data.

Exceptions

Exception | Condition
BerkeleyDB..::.LockNotGrantedException | If lock or transaction timeouts have been specified, a LockNotGrantedException may be thrown. This failure, by itself, does not require the enclosing transaction be aborted.

See Also

QueueDatabase Class
Consume Overload


Consume Method (Boolean, Transaction)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Consume Method (Boolean, Transaction)
QueueDatabase Class See Also Send Feedback
Return the record number and data from the available record closest to the head of the queue, and delete the record.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<uint, DatabaseEntry> Consume(
    bool wait,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Consume ( _
    wait As Boolean, _
    txn As Transaction _
) As KeyValuePair(Of UInteger, DatabaseEntry)
Visual C++
public:
KeyValuePair<unsigned int, DatabaseEntry^> Consume(
    bool wait,
    Transaction^ txn
)

Parameters

wait
Type: System..::.Boolean
If true and the Queue database is empty, the thread of control waits until there is data in the queue before returning.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is the record number and whose Value parameter is the retrieved data.

Exceptions

Exception | Condition
BerkeleyDB..::.LockNotGrantedException | If lock or transaction timeouts have been specified, a LockNotGrantedException may be thrown. This failure, by itself, does not require the enclosing transaction be aborted.

See Also

QueueDatabase Class
Consume Overload


Consume Method (Boolean, Transaction, LockingInfo)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Consume Method (Boolean, Transaction, LockingInfo)
QueueDatabase Class See Also Send Feedback
Return the record number and data from the available record closest to the head of the queue, and delete the record.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<uint, DatabaseEntry> Consume(
    bool wait,
    Transaction txn,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Consume ( _
    wait As Boolean, _
    txn As Transaction, _
    info As LockingInfo _
) As KeyValuePair(Of UInteger, DatabaseEntry)
Visual C++
public:
KeyValuePair<unsigned int, DatabaseEntry^> Consume(
    bool wait,
    Transaction^ txn,
    LockingInfo^ info
)

Parameters

wait
Type: System..::.Boolean
If true and the Queue database is empty, the thread of control waits until there is data in the queue before returning.
txn
Type: BerkeleyDB..::.Transaction
txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

A KeyValuePair<(Of <(TKey, TValue>)>) whose Key parameter is the record number and whose Value parameter is the retrieved data.

Exceptions

Exception | Condition
BerkeleyDB..::.LockNotGrantedException | If lock or transaction timeouts have been specified, a LockNotGrantedException may be thrown. This failure, by itself, does not require the enclosing transaction be aborted.

See Also

QueueDatabase Class
Consume Overload


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Cursor Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig) | Create a database cursor with the given configuration. (Inherited from BaseDatabase.)
Cursor(Transaction) | Create a transactionally protected database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Delete Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Exists Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


FastStats Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.FastStats Method
QueueDatabase Class See Also Send Feedback

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
FastStats()()() | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction) | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction, Isolation) | Return the database statistical information which does not require traversal of the database.

See Also

QueueDatabase Class
QueueDatabase Members


FastStats Method

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.FastStats Method
QueueDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public QueueStats FastStats()
Visual Basic (Declaration)
Public Function FastStats As QueueStats
Visual C++
public:
QueueStats^ FastStats()

Return Value

The database statistical information which does not require traversal of the database.

See Also

QueueDatabase Class
FastStats Overload


FastStats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.FastStats Method (Transaction)
QueueDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public QueueStats FastStats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction _
) As QueueStats
Visual C++
public:
QueueStats^ FastStats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The database statistical information which does not require traversal of the database.

See Also

QueueDatabase Class
FastStats Overload


FastStats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.FastStats Method (Transaction, Isolation)
QueueDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public QueueStats FastStats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As QueueStats
Visual C++
public:
QueueStats^ FastStats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE will be silently ignored for databases which did not specify ReadUncommitted.

Return Value

The database statistical information which does not require traversal of the database.

See Also

QueueDatabase Class
FastStats Overload


Get Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Get Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.GetBoth Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


GetBothMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.GetBothMultiple Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBothMultiple(DatabaseEntry, DatabaseEntry) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction, LockingInfo) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)

See Also

QueueDatabase Class
QueueDatabase Members


GetMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.GetMultiple Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
GetMultiple(DatabaseEntry) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32, Transaction) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32, Transaction, LockingInfo) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)

See Also

QueueDatabase Class
QueueDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Open Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, QueueDatabaseConfig) | Instantiate a new QueueDatabase object and open the database represented by Filename.
Open(String, QueueDatabaseConfig, Transaction) | Instantiate a new QueueDatabase object and open the database represented by Filename.

See Also

QueueDatabase Class
QueueDatabase Members


Open Method (String, QueueDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Open Method (String, QueueDatabaseConfig)
QueueDatabase Class See Also Send Feedback
Instantiate a new QueueDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static QueueDatabase Open(
    string Filename,
    QueueDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As QueueDatabaseConfig _
) As QueueDatabase
Visual C++
public:
static QueueDatabase^ Open(
    String^ Filename,
    QueueDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file that is used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.QueueDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

QueueDatabase Class
Open Overload


Open Method (String, QueueDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Open Method (String, QueueDatabaseConfig, Transaction)
QueueDatabase Class See Also Send Feedback
Instantiate a new QueueDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static QueueDatabase Open(
    string Filename,
    QueueDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As QueueDatabaseConfig, _
    txn As Transaction _
) As QueueDatabase
Visual C++
public:
static QueueDatabase^ Open(
    String^ Filename,
    QueueDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file that is used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.QueueDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

QueueDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.PrintFastStats Method
QueueDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.PrintStats Method
QueueDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


Put Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Put Method
QueueDatabase Class See Also Send Feedback

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

Overload List

Name | Description
Put(MultipleKeyDatabaseEntry) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)
Put(MultipleKeyDatabaseEntry, Transaction) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)

See Also

QueueDatabase Class
QueueDatabase Members


PutNoOverwrite Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.PutNoOverwrite Method
QueueDatabase Class See Also Send Feedback

Overload List

Name | Description
PutNoOverwrite(MultipleKeyDatabaseEntry) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(MultipleKeyDatabaseEntry, Transaction) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)

See Also

QueueDatabase Class
QueueDatabase Members


Stats Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Stats Method
QueueDatabase Class See Also Send Feedback
The statistical information is described by BTreeStats.

Overload List

Name | Description
Stats()()() | Return the database statistical information for this database.
Stats(Transaction) | Return the database statistical information for this database.
Stats(Transaction, Isolation) | Return the database statistical information for this database.

See Also

QueueDatabase Class
QueueDatabase Members


Stats Method

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Stats Method
QueueDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public QueueStats Stats()
Visual Basic (Declaration)
Public Function Stats As QueueStats
Visual C++
public:
QueueStats^ Stats()

Return Value

Database statistical information.

See Also

QueueDatabase Class
Stats Overload


Stats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Stats Method (Transaction)
QueueDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public QueueStats Stats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction _
) As QueueStats
Visual C++
public:
QueueStats^ Stats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

Database statistical information.

See Also

QueueDatabase Class
Stats Overload


Stats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Stats Method (Transaction, Isolation)
QueueDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public QueueStats Stats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As QueueStats
Visual C++
public:
QueueStats^ Stats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE will be silently ignored for databases which did not specify ReadUncommitted.

Return Value

Database statistical information.

See Also

QueueDatabase Class
Stats Overload


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Truncate Method
QueueDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class
QueueDatabase Members


QueueDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabase Properties
QueueDatabase Class See Also Send Feedback

The QueueDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
ExtentSize | The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
InOrder | If true, modify the operation of Consume(Boolean) to return key/data pairs in order. They always return the key/data item from the head of the queue.
Length | The length of records in the database.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
PadByte | The padding character for short, fixed-length records.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

QueueDatabase Class


ExtentSize Property

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.ExtentSize Property
QueueDatabase Class See Also Send Feedback
The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ExtentSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtentSize As UInteger
Visual C++
public:
property unsigned int ExtentSize {
    unsigned int get ();
}

See Also

QueueDatabase Class


InOrder Property

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.InOrder Property
QueueDatabase Class See Also Send Feedback
If true, modify the operation of Consume(Boolean) to return key/data pairs in order. They always return the key/data item from the head of the queue.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool InOrder { get; }
Visual Basic (Declaration)
Public ReadOnly Property InOrder As Boolean
Visual C++
public:
property bool InOrder {
    bool get ();
}

See Also

QueueDatabase Class


Length Property

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.Length Property
QueueDatabase Class See Also Send Feedback
The length of records in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As UInteger
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
}

See Also

QueueDatabase Class


PadByte Property

[image]

Berkeley DB .NET API Documentation
QueueDatabase..::.PadByte Property
QueueDatabase Class See Also Send Feedback
The padding character for short, fixed-length records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int PadByte { get; }
Visual Basic (Declaration)
Public ReadOnly Property PadByte As Integer
Visual C++
public:
property int PadByte {
    int get ();
}

See Also

QueueDatabase Class


QueueDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for QueueDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class QueueDatabaseConfig : DatabaseConfig
Visual Basic (Declaration)
Public Class QueueDatabaseConfig _
    Inherits DatabaseConfig
Visual C++
public ref class QueueDatabaseConfig : public DatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.QueueDatabaseConfig

See Also

QueueDatabaseConfig Members


QueueDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig Members
QueueDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The QueueDatabaseConfig type exposes the following members.

Constructors

Name | Description
QueueDatabaseConfig | Instantiate a new QueueDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Append | A function to call after the record number has been selected but before the data has been stored into the database.
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
ConsumeInOrder | If true, modify the operation of Consume(Boolean) to return key/data pairs in order. They always return the key/data item from the head of the queue.
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ExtentSize | The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.
Length | Specify the length of records in the database.
PadByte | The padding character for short, fixed-length records.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)

See Also

QueueDatabaseConfig Class


QueueDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig Constructor
QueueDatabaseConfig Class See Also Send Feedback
Instantiate a new QueueDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public QueueDatabaseConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
QueueDatabaseConfig()

See Also

QueueDatabaseConfig Class


QueueDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig Fields
QueueDatabaseConfig Class See Also Send Feedback

The QueueDatabaseConfig type exposes the following members.

Fields

Name | Description
Append | A function to call after the record number has been selected but before the data has been stored into the database.
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
ConsumeInOrder | If true, modify the operation of Consume(Boolean) to return key/data pairs in order. They always return the key/data item from the head of the queue.
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

See Also

QueueDatabaseConfig Class


Append Field

[image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig..::.Append Field
QueueDatabaseConfig Class See Also Send Feedback
A function to call after the record number has been selected but before the data has been stored into the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public AppendRecordDelegate Append
Visual Basic (Declaration)
Public Append As AppendRecordDelegate
Visual C++
public:
AppendRecordDelegate^ Append

Remarks

When using Append(DatabaseEntry), it may be useful to modify the stored data based on the generated key. If a delegate is specified, it is called after the record number has been selected, but before the data has been stored.

See Also

QueueDatabaseConfig Class


ConsumeInOrder Field

[image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig..::.ConsumeInOrder Field
QueueDatabaseConfig Class See Also Send Feedback
If true, modify the operation of Consume(Boolean) to return key/data pairs in order. They always return the key/data item from the head of the queue.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ConsumeInOrder
Visual Basic (Declaration)
Public ConsumeInOrder As Boolean
Visual C++
public:
bool ConsumeInOrder

Remarks

The default behavior of queue databases is optimized for multiple readers, and does not guarantee records to be retrieved in the order they are added to the queue. Specifically, if a writing thread adds multiple records to an empty queue, reading threads may skip some of the initial records when the next Consume(Boolean) call returns.

This setting modifies Consume(Boolean) to verify that the record being returned is in fact the head of the queue. This increases contention and reduces concurrency when there are many reading threads.

See Also

QueueDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig..::.Creation Field
QueueDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, QueueDatabaseConfig) fails.

See Also

QueueDatabaseConfig Class


QueueDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig Methods
QueueDatabaseConfig Class See Also Send Feedback

The QueueDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

QueueDatabaseConfig Class


QueueDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig Properties
QueueDatabaseConfig Class See Also Send Feedback

The QueueDatabaseConfig type exposes the following members.

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ExtentSize | The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.
Length | Specify the length of records in the database.
PadByte | The padding character for short, fixed-length records.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)

See Also

QueueDatabaseConfig Class


ExtentSize Property

[image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig..::.ExtentSize Property
QueueDatabaseConfig Class See Also Send Feedback
The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ExtentSize { get; set; }
Visual Basic (Declaration)
Public Property ExtentSize As UInteger
Visual C++
public:
property unsigned int ExtentSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Each extent is created as a separate physical file. If no extent size is set, the default behavior is to create only a single underlying database file.

For information on tuning the extent size, see Selecting a extent size in the Programmer's Reference Guide.

If the database already exists, this setting is ignored.

See Also

QueueDatabaseConfig Class


Length Property

[image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig..::.Length Property
QueueDatabaseConfig Class See Also Send Feedback
Specify the length of records in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Length { get; set; }
Visual Basic (Declaration)
Public Property Length As UInteger
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The record length must be enough smaller than PageSize that at least one record plus the database page's metadata information can fit on each database page.

Any records added to the database that are less than Length bytes long are automatically padded (see PadByte for more information).

Any attempt to insert records into the database that are greater than Length bytes long causes the call to fail immediately and return an error.

If the database already exists, this setting is ignored.

See Also

QueueDatabaseConfig Class


PadByte Property

[image]

Berkeley DB .NET API Documentation
QueueDatabaseConfig..::.PadByte Property
QueueDatabaseConfig Class See Also Send Feedback
The padding character for short, fixed-length records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int PadByte { get; set; }
Visual Basic (Declaration)
Public Property PadByte As Integer
Visual C++
public:
property int PadByte {
    int get ();
    void set (int value);
}

Remarks

If no pad character is specified, space characters (ASCII 0x20) are used for padding.

If the database already exists, this setting is ignored.

See Also

QueueDatabaseConfig Class


QueueStats Class

[image]

Berkeley DB .NET API Documentation
QueueStats Class
Members See Also Send Feedback
Statistical information about a QueueDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class QueueStats
Visual Basic (Declaration)
Public Class QueueStats
Visual C++
public ref class QueueStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.QueueStats

See Also

QueueStats Members


QueueStats Members

[image] [image]

Berkeley DB .NET API Documentation
QueueStats Members
QueueStats Class Methods Properties See Also Send Feedback

The QueueStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
DataPages | Data pages.
DataPagesBytesFree | Bytes free in data pages.
FirstRecordNumber | First not deleted record.
MagicNumber | Magic number.
MetadataFlags | Metadata flags.
nData | Number of data items.
NextRecordNumber | Next available record number.
nKeys | Number of unique keys.
PageSize | Page size.
PagesPerExtent | Pages per extent.
RecordLength | Fixed-length record length.
RecordPadByte | Fixed-length record pad.
Version | Version number.

See Also

QueueStats Class


QueueStats Methods

[image] [image]

Berkeley DB .NET API Documentation
QueueStats Methods
QueueStats Class See Also Send Feedback

The QueueStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

QueueStats Class


QueueStats Properties

[image] [image]

Berkeley DB .NET API Documentation
QueueStats Properties
QueueStats Class See Also Send Feedback

The QueueStats type exposes the following members.

Properties

Name | Description
DataPages | Data pages.
DataPagesBytesFree | Bytes free in data pages.
FirstRecordNumber | First not deleted record.
MagicNumber | Magic number.
MetadataFlags | Metadata flags.
nData | Number of data items.
NextRecordNumber | Next available record number.
nKeys | Number of unique keys.
PageSize | Page size.
PagesPerExtent | Pages per extent.
RecordLength | Fixed-length record length.
RecordPadByte | Fixed-length record pad.
Version | Version number.

See Also

QueueStats Class


DataPages Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.DataPages Property
QueueStats Class See Also Send Feedback
Data pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DataPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataPages As UInteger
Visual C++
public:
property unsigned int DataPages {
    unsigned int get ();
}

See Also

QueueStats Class


DataPagesBytesFree Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.DataPagesBytesFree Property
QueueStats Class See Also Send Feedback
Bytes free in data pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DataPagesBytesFree { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataPagesBytesFree As UInteger
Visual C++
public:
property unsigned int DataPagesBytesFree {
    unsigned int get ();
}

See Also

QueueStats Class


FirstRecordNumber Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.FirstRecordNumber Property
QueueStats Class See Also Send Feedback
First not deleted record.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FirstRecordNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstRecordNumber As UInteger
Visual C++
public:
property unsigned int FirstRecordNumber {
    unsigned int get ();
}

See Also

QueueStats Class


MagicNumber Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.MagicNumber Property
QueueStats Class See Also Send Feedback
Magic number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MagicNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property MagicNumber As UInteger
Visual C++
public:
property unsigned int MagicNumber {
    unsigned int get ();
}

See Also

QueueStats Class


MetadataFlags Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.MetadataFlags Property
QueueStats Class See Also Send Feedback
Metadata flags.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MetadataFlags { get; }
Visual Basic (Declaration)
Public ReadOnly Property MetadataFlags As UInteger
Visual C++
public:
property unsigned int MetadataFlags {
    unsigned int get ();
}

See Also

QueueStats Class


nData Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.nData Property
QueueStats Class See Also Send Feedback
Number of data items.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nData { get; }
Visual Basic (Declaration)
Public ReadOnly Property nData As UInteger
Visual C++
public:
property unsigned int nData {
    unsigned int get ();
}

See Also

QueueStats Class


NextRecordNumber Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.NextRecordNumber Property
QueueStats Class See Also Send Feedback
Next available record number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NextRecordNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextRecordNumber As UInteger
Visual C++
public:
property unsigned int NextRecordNumber {
    unsigned int get ();
}

See Also

QueueStats Class


nKeys Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.nKeys Property
QueueStats Class See Also Send Feedback
Number of unique keys.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property nKeys As UInteger
Visual C++
public:
property unsigned int nKeys {
    unsigned int get ();
}

See Also

QueueStats Class


PageSize Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.PageSize Property
QueueStats Class See Also Send Feedback
Page size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As UInteger
Visual C++
public:
property unsigned int PageSize {
    unsigned int get ();
}

See Also

QueueStats Class


PagesPerExtent Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.PagesPerExtent Property
QueueStats Class See Also Send Feedback
Pages per extent.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PagesPerExtent { get; }
Visual Basic (Declaration)
Public ReadOnly Property PagesPerExtent As UInteger
Visual C++
public:
property unsigned int PagesPerExtent {
    unsigned int get ();
}

See Also

QueueStats Class


RecordLength Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.RecordLength Property
QueueStats Class See Also Send Feedback
Fixed-length record length.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RecordLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordLength As UInteger
Visual C++
public:
property unsigned int RecordLength {
    unsigned int get ();
}

See Also

QueueStats Class


RecordPadByte Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.RecordPadByte Property
QueueStats Class See Also Send Feedback
Fixed-length record pad.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RecordPadByte { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordPadByte As UInteger
Visual C++
public:
property unsigned int RecordPadByte {
    unsigned int get ();
}

See Also

QueueStats Class


Version Property

[image]

Berkeley DB .NET API Documentation
QueueStats..::.Version Property
QueueStats Class See Also Send Feedback
Version number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As UInteger
Visual C++
public:
property unsigned int Version {
    unsigned int get ();
}

See Also

QueueStats Class


RecnoCursor Class

[image]

Berkeley DB .NET API Documentation
RecnoCursor Class
Members See Also Send Feedback
A class for traversing the records of a RecnoDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class RecnoCursor : Cursor
Visual Basic (Declaration)
Public Class RecnoCursor _
    Inherits Cursor
Visual C++
public ref class RecnoCursor : public Cursor

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseCursor
BerkeleyDB..::.Cursor
BerkeleyDB..::.RecnoCursor

See Also

RecnoCursor Members


RecnoCursor Members

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor Members
RecnoCursor Class Methods Properties See Also Send Feedback

The RecnoCursor type exposes the following members.

Methods

Name | Description
Add | Stores the key/data pair in the database. (Inherited from Cursor.)
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
Delete | Delete the key/data pair to which the cursor refers. (Inherited from Cursor.)
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Cursor. (Inherited from Cursor.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Insert | Insert the data element as a duplicate element of the key to which the cursor refers.
Move | Overloaded.
MoveFirst | Overloaded.
MoveFirstMultiple | Overloaded. If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).
MoveFirstMultipleKey | Overloaded.
MoveLast | Overloaded.
MoveMultiple | Overloaded.
MoveMultipleKey | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextDuplicateMultiple | Overloaded.
MoveNextDuplicateMultipleKey | Overloaded.
MoveNextMultiple | Overloaded.
MoveNextMultipleKey | Overloaded.
MoveNextUnique | Overloaded.
MoveNextUniqueMultiple | Overloaded.
MoveNextUniqueMultipleKey | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Overwrite | Overwrite the data of the key/data pair to which the cursor refers with the specified data item. (Inherited from Cursor.)
Refresh | Overloaded.
RefreshMultiple | Overloaded.
RefreshMultipleKey | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Current | The key/data pair at which the cursor currently points. (Inherited from Cursor.)
CurrentMultiple | The key and multiple data items at which the cursor currently points. (Inherited from Cursor.)
CurrentMultipleKey | The multiple key and data items at which the cursor currently points. (Inherited from Cursor.)
Priority | The cache priority for pages referenced by the cursor. (Inherited from Cursor.)

See Also

RecnoCursor Class


RecnoCursor Methods

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor Methods
RecnoCursor Class See Also Send Feedback

The RecnoCursor type exposes the following members.

Methods

Name | Description
Add | Stores the key/data pair in the database. (Inherited from Cursor.)
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
Delete | Delete the key/data pair to which the cursor refers. (Inherited from Cursor.)
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Cursor. (Inherited from Cursor.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Insert | Insert the data element as a duplicate element of the key to which the cursor refers.
Move | Overloaded.
MoveFirst | Overloaded.
MoveFirstMultiple | Overloaded. If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).
MoveFirstMultipleKey | Overloaded.
MoveLast | Overloaded.
MoveMultiple | Overloaded.
MoveMultipleKey | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextDuplicateMultiple | Overloaded.
MoveNextDuplicateMultipleKey | Overloaded.
MoveNextMultiple | Overloaded.
MoveNextMultipleKey | Overloaded.
MoveNextUnique | Overloaded.
MoveNextUniqueMultiple | Overloaded.
MoveNextUniqueMultipleKey | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Overwrite | Overwrite the data of the key/data pair to which the cursor refers with the specified data item. (Inherited from Cursor.)
Refresh | Overloaded.
RefreshMultiple | Overloaded.
RefreshMultipleKey | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RecnoCursor Class


Duplicate Method

[image]

Berkeley DB .NET API Documentation
RecnoCursor..::.Duplicate Method
RecnoCursor Class See Also Send Feedback
Create a new cursor that uses the same transaction and locker ID as the original cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoCursor Duplicate(
    bool keepPosition
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    keepPosition As Boolean _
) As RecnoCursor
Visual C++
public:
RecnoCursor^ Duplicate(
    bool keepPosition
)

Parameters

keepPosition
Type: System..::.Boolean
If true, the newly created cursor is initialized to refer to the same position in the database as the original cursor (if any) and hold the same locks (if any). If false, or if the original cursor does not hold a database position and locks, the created cursor is uninitialized and behaves like a cursor newly created by Cursor()()().

Return Value

A newly created cursor

Remarks

This is useful when an application is using locking and requires two or more cursors in the same thread of control.

See Also

RecnoCursor Class


Insert Method

[image]

Berkeley DB .NET API Documentation
RecnoCursor..::.Insert Method
RecnoCursor Class See Also Send Feedback
Insert the data element as a duplicate element of the key to which the cursor refers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Insert(
    DatabaseEntry data,
    Cursor..::.InsertLocation loc
)
Visual Basic (Declaration)
Public Sub Insert ( _
    data As DatabaseEntry, _
    loc As Cursor..::.InsertLocation _
)
Visual C++
public:
void Insert(
    DatabaseEntry^ data,
    Cursor..::.InsertLocation loc
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data element to insert
loc
Type: BerkeleyDB..::.Cursor..::.InsertLocation
Specify whether to insert the data item immediately before or immediately after the cursor's current position.

See Also

RecnoCursor Class


Move Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.Move Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
Move(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
Move(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
Move(DatabaseEntry, DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned. (Inherited from Cursor.)
Move(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
Move(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
Move(DatabaseEntry, DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the datum associated with the given key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveFirst Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveFirst Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirst()()() | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveFirst(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveFirst(DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveFirst(DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveFirstMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveFirstMultiple Method
RecnoCursor Class See Also Send Feedback
If positioning the cursor fails, CurrentMultiple contains an empty KeyValuePair<(Of <(TKey, TValue>)>).

Overload List

Name | Description
MoveFirstMultiple()()() | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(Int32) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveFirstMultiple(Int32, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that key and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveFirstMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveFirstMultipleKey Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirstMultipleKey()()() | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(Int32) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveFirstMultipleKey(Int32, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveLast Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveLast Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveLast()()() | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveLast(LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. (Inherited from Cursor.)
MoveLast(DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveLast(DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store that pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveMultiple Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveMultiple(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(DatabaseEntry, Boolean, Int32) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of one database page in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultiple(DatabaseEntry, Boolean, Int32, LockingInfo) | Set the cursor to refer to key, and store that key and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
MoveMultiple(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many duplicate data items associated with the given key that can fit in a buffer the size of BufferSize in CurrentMultiple. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveMultipleKey Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveMultipleKey(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(DatabaseEntry, Boolean, Int32) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)
MoveMultipleKey(DatabaseEntry, Boolean, Int32, LockingInfo) | Set the cursor to refer to key, and store that key and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
MoveMultipleKey(KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>), Boolean, Int32, LockingInfo) | Move the cursor to the specified key/data pair of the database, and store that key/data pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNext Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNext Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNext()()() | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MoveNext(LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MoveNext(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNext(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNextDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNextDuplicate Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicate()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicate(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicate(DatabaseEntry, DatabaseEntry) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNextDuplicate(DatabaseEntry, DatabaseEntry, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNextDuplicateMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNextDuplicateMultiple Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicateMultiple()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(Int32) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, then move cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultiple(Int32, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextDuplicateMultiple returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNextDuplicateMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNextDuplicateMultipleKey Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicateMultipleKey()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(Int32) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MoveNextDuplicateMultipleKey(Int32, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextDuplicateMultipleKey returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNextMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNextMultiple Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextMultiple()()() | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(LockingInfo) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(Int32) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)
MoveNextMultiple(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. In the presence of duplicate key values, the value of CurrentMultiple.Key may not change. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNextMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNextMultipleKey Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextMultipleKey()()() | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(LockingInfo) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(Int32) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)
MoveNextMultipleKey(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store that pair and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. In the presence of duplicate key values, the keys of CurrentMultipleKey may not change. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNextUnique Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNextUnique Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUnique()()() | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUnique(LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUnique(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)
MoveNextUnique(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNextUniqueMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNextUniqueMultiple Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUniqueMultiple()()() | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(Int32) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultiple(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultiple is identical to MoveFirstMultiple(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. MoveNextUniqueMultiple returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MoveNextUniqueMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MoveNextUniqueMultipleKey Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUniqueMultipleKey()()() | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(Int32) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MoveNextUniqueMultipleKey(Int32, LockingInfo) | If the cursor is not yet initialized, MoveNextUniqueMultipleKey is identical to MoveFirstMultipleKey(Int32, LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store that key and associated datum and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. MoveNextUniqueMultipleKey returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MovePrev Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MovePrev Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrev()()() | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MovePrev(LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. (Inherited from Cursor.)
MovePrev(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrev(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store that pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MovePrevDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MovePrevDuplicate Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevDuplicate()()() | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MovePrevDuplicate(LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. (Inherited from Cursor.)
MovePrevDuplicate(DatabaseEntry, DatabaseEntry) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrevDuplicate(DatabaseEntry, DatabaseEntry, LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and that pair is stored in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


MovePrevUnique Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.MovePrevUnique Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevUnique()()() | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MovePrevUnique(LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. (Inherited from Cursor.)
MovePrevUnique(DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if ntheo non-duplicate key/data pairs exist after the cursor position in database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)
MovePrevUnique(DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store that key and associated datum in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


Refresh Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.Refresh Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
Refresh()()() | Store the key/data pair to which the cursor refers in Current. (Inherited from Cursor.)
Refresh(LockingInfo) | Store the key/data pair to which the cursor refers in Current. (Inherited from Cursor.)
Refresh(DatabaseEntry, DatabaseEntry) | Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned. (Inherited from Cursor.)
Refresh(DatabaseEntry, DatabaseEntry, LockingInfo) | Store the key/data pair to which the cursor refers in Current. If either the key or the data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


RefreshMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.RefreshMultiple Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
RefreshMultiple()()() | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(LockingInfo) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of one database page in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(Int32) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)
RefreshMultiple(Int32, LockingInfo) | Store the key/data pair to which the cursor refers and as many duplicate data items that can fit in a buffer the size of BufferSize in CurrentMultiple. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


RefreshMultipleKey Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor..::.RefreshMultipleKey Method
RecnoCursor Class See Also Send Feedback

Overload List

Name | Description
RefreshMultipleKey()()() | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(LockingInfo) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of one database page in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(Int32) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)
RefreshMultipleKey(Int32, LockingInfo) | Store the key/data pair to which the cursor refers and as many ensuing key/data pairs that can fit in a buffer the size of BufferSize in CurrentMultipleKey. (Inherited from Cursor.)

See Also

RecnoCursor Class
RecnoCursor Members


RecnoCursor Properties

[image] [image]

Berkeley DB .NET API Documentation
RecnoCursor Properties
RecnoCursor Class See Also Send Feedback

The RecnoCursor type exposes the following members.

Properties

Name | Description
Current | The key/data pair at which the cursor currently points. (Inherited from Cursor.)
CurrentMultiple | The key and multiple data items at which the cursor currently points. (Inherited from Cursor.)
CurrentMultipleKey | The multiple key and data items at which the cursor currently points. (Inherited from Cursor.)
Priority | The cache priority for pages referenced by the cursor. (Inherited from Cursor.)

See Also

RecnoCursor Class


RecnoDatabase Class

[image]

Berkeley DB .NET API Documentation
RecnoDatabase Class
Members See Also Send Feedback
A class representing a RecnoDatabase. The Recno format supports fixed- or variable-length records, accessed sequentially or by logical record number, and optionally backed by a flat text file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class RecnoDatabase : Database
Visual Basic (Declaration)
Public Class RecnoDatabase _
    Inherits Database
Visual C++
public ref class RecnoDatabase : public Database

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.Database
BerkeleyDB..::.RecnoDatabase

See Also

RecnoDatabase Members


RecnoDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase Members
RecnoDatabase Class Methods Properties See Also Send Feedback

The RecnoDatabase type exposes the following members.

Methods

Name | Description
Append | Overloaded.
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Compact | Overloaded.
Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by BTreeStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.
TruncateUnusedPages | Overloaded.

Properties

Name | Description
AppendCallback | A function to call after the record number has been selected but before the data has been stored into the database.
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
RecordDelimiter | The delimiting byte used to mark the end of a record in SourceFile.
RecordLength | If using fixed-length, not byte-delimited records, the length of the records.
RecordPad | The padding character for short, fixed-length records.
Renumber | If true, the logical record numbers are mutable, and change as records are added to and deleted from the database.
Snapshot | If true, any SourceFile file is read in its entirety when Open(String, RecnoDatabaseConfig) is called. If false, SourceFile may be read lazily.
SourceFile | The underlying source file for the Recno access method.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class


RecnoDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase Methods
RecnoDatabase Class See Also Send Feedback

The RecnoDatabase type exposes the following members.

Methods

Name | Description
Append | Overloaded.
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Compact | Overloaded.
Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
FastStats Overloaded.

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Get | Overloaded.
GetBoth | Overloaded.
GetBothMultiple | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetMultiple | Overloaded.
GetType
Gets the type of the current instance.
(Inherited from Object.)
Join
Create a specialized join cursor for use in performing equality or natural joins on secondary indices.
(Inherited from Database.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
Put Overloaded.

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

PutNoOverwrite | Overloaded.
Stats Overloaded.
The statistical information is described by BTreeStats.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.
TruncateUnusedPages | Overloaded.

See Also

RecnoDatabase Class


Append Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Append Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Append(DatabaseEntry) | Append the data item to the end of the database.
Append(DatabaseEntry, Transaction) | Append the data item to the end of the database.

See Also

RecnoDatabase Class
RecnoDatabase Members


Append Method (DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Append Method (DatabaseEntry)
RecnoDatabase Class See Also Send Feedback
Append the data item to the end of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Append(
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function Append ( _
    data As DatabaseEntry _
) As UInteger
Visual C++
public:
unsigned int Append(
    DatabaseEntry^ data
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database

Return Value

The record number allocated to the record

See Also

RecnoDatabase Class
Append Overload


Append Method (DatabaseEntry, Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Append Method (DatabaseEntry, Transaction)
RecnoDatabase Class See Also Send Feedback
Append the data item to the end of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Append(
    DatabaseEntry data,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Append ( _
    data As DatabaseEntry, _
    txn As Transaction _
) As UInteger
Visual C++
public:
unsigned int Append(
    DatabaseEntry^ data,
    Transaction^ txn
)

Parameters

data
Type: BerkeleyDB..::.DatabaseEntry
The data item to store in the database
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The record number allocated to the record

Remarks

There is a minor behavioral difference between Append(DatabaseEntry) and Append(DatabaseEntry). If a transaction enclosing an Append operation aborts, the record number may be reallocated in a subsequent Append(DatabaseEntry) operation, but it is not reallocated in a subsequent Append(DatabaseEntry) operation.

See Also

RecnoDatabase Class
Append Overload


Close Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Close Method
RecnoDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class
RecnoDatabase Members


Compact Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Compact Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Compact(CompactConfig) | Compact the database, and optionally return unused database pages to the underlying filesystem.
Compact(CompactConfig, Transaction) | Compact the database, and optionally return unused database pages to the underlying filesystem.

See Also

RecnoDatabase Class
RecnoDatabase Members


Compact Method (CompactConfig)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Compact Method (CompactConfig)
RecnoDatabase Class See Also Send Feedback
Compact the database, and optionally return unused database pages to the underlying filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CompactData Compact(
    CompactConfig cdata
)
Visual Basic (Declaration)
Public Function Compact ( _
    cdata As CompactConfig _
) As CompactData
Visual C++
public:
CompactData^ Compact(
    CompactConfig^ cdata
)

Parameters

cdata
Type: BerkeleyDB..::.CompactConfig
Compact configuration parameters

Return Value

Compact operation statistics

Remarks

If the operation occurs in a transactional database, the operation is implicitly transaction protected using multiple transactions. These transactions are periodically committed to avoid locking large sections of the tree. Any deadlocks encountered cause the compaction operation to be retried from the point of the last transaction commit.

See Also

RecnoDatabase Class
Compact Overload


Compact Method (CompactConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Compact Method (CompactConfig, Transaction)
RecnoDatabase Class See Also Send Feedback
Compact the database, and optionally return unused database pages to the underlying filesystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CompactData Compact(
    CompactConfig cdata,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Compact ( _
    cdata As CompactConfig, _
    txn As Transaction _
) As CompactData
Visual C++
public:
CompactData^ Compact(
    CompactConfig^ cdata,
    Transaction^ txn
)

Parameters

cdata
Type: BerkeleyDB..::.CompactConfig
Compact configuration parameters
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

Compact operation statistics

Remarks

If txn is non-null, then the operation is performed using that transaction. In this event, large sections of the tree may be locked during the course of the transaction.

If txn is null, but the operation occurs in a transactional database, the operation is implicitly transaction protected using multiple transactions. These transactions are periodically committed to avoid locking large sections of the tree. Any deadlocks encountered cause the compaction operation to be retried from the point of the last transaction commit.

See Also

RecnoDatabase Class
Compact Overload


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Cursor Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor.
Cursor(CursorConfig) | Create a database cursor with the given configuration.
Cursor(Transaction) | Create a transactionally protected database cursor.
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration.

See Also

RecnoDatabase Class
RecnoDatabase Members


Cursor Method

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Cursor Method
RecnoDatabase Class See Also Send Feedback
Create a database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoCursor Cursor()
Visual Basic (Declaration)
Public Function Cursor As RecnoCursor
Visual C++
public:
RecnoCursor^ Cursor()

Return Value

A newly created cursor

See Also

RecnoDatabase Class
Cursor Overload


Cursor Method (CursorConfig)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Cursor Method (CursorConfig)
RecnoDatabase Class See Also Send Feedback
Create a database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoCursor Cursor(
    CursorConfig cfg
)
Visual Basic (Declaration)
Public Function Cursor ( _
    cfg As CursorConfig _
) As RecnoCursor
Visual C++
public:
RecnoCursor^ Cursor(
    CursorConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.

Return Value

A newly created cursor

See Also

RecnoDatabase Class
Cursor Overload


Cursor Method (Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Cursor Method (Transaction)
RecnoDatabase Class See Also Send Feedback
Create a transactionally protected database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoCursor Cursor(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Cursor ( _
    txn As Transaction _
) As RecnoCursor
Visual C++
public:
RecnoCursor^ Cursor(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

RecnoDatabase Class
Cursor Overload


Cursor Method (CursorConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Cursor Method (CursorConfig, Transaction)
RecnoDatabase Class See Also Send Feedback
Create a transactionally protected database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoCursor Cursor(
    CursorConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Cursor ( _
    cfg As CursorConfig, _
    txn As Transaction _
) As RecnoCursor
Visual C++
public:
RecnoCursor^ Cursor(
    CursorConfig^ cfg,
    Transaction^ txn
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.
txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

RecnoDatabase Class
Cursor Overload


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Delete Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class
RecnoDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Exists Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class
RecnoDatabase Members


FastStats Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.FastStats Method
RecnoDatabase Class See Also Send Feedback

Among other things, this method makes it possible for applications to request key and record counts without incurring the performance penalty of traversing the entire database.

The statistical information is described by the BTreeStats, HashStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
FastStats()()() | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction) | Return the database statistical information which does not require traversal of the database.
FastStats(Transaction, Isolation) | Return the database statistical information which does not require traversal of the database.

See Also

RecnoDatabase Class
RecnoDatabase Members


FastStats Method

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.FastStats Method
RecnoDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoStats FastStats()
Visual Basic (Declaration)
Public Function FastStats As RecnoStats
Visual C++
public:
RecnoStats^ FastStats()

Return Value

The database statistical information which does not require traversal of the database.

See Also

RecnoDatabase Class
FastStats Overload


FastStats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.FastStats Method (Transaction)
RecnoDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoStats FastStats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction _
) As RecnoStats
Visual C++
public:
RecnoStats^ FastStats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The database statistical information which does not require traversal of the database.

See Also

RecnoDatabase Class
FastStats Overload


FastStats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.FastStats Method (Transaction, Isolation)
RecnoDatabase Class See Also Send Feedback
Return the database statistical information which does not require traversal of the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoStats FastStats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function FastStats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As RecnoStats
Visual C++
public:
RecnoStats^ FastStats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE is silently ignored for databases which did not specify ReadUncommitted.

Return Value

The database statistical information which does not require traversal of the database.

See Also

RecnoDatabase Class
FastStats Overload


Get Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Get Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class
RecnoDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.GetBoth Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class
RecnoDatabase Members


GetBothMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.GetBothMultiple Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBothMultiple(DatabaseEntry, DatabaseEntry) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)
GetBothMultiple(DatabaseEntry, DatabaseEntry, Int32, Transaction, LockingInfo) | If a key/data pair in the database matches key and data, return the key and all duplicate data items. (Inherited from Database.)

See Also

RecnoDatabase Class
RecnoDatabase Members


GetMultiple Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.GetMultiple Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
GetMultiple(DatabaseEntry) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32, Transaction) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)
GetMultiple(DatabaseEntry, Int32, Transaction, LockingInfo) | Retrieve a key and all duplicate data items from the database. (Inherited from Database.)

See Also

RecnoDatabase Class
RecnoDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Open Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, RecnoDatabaseConfig) | Instantiate a new RecnoDatabase object and open the database represented by Filename.
Open(String, RecnoDatabaseConfig, Transaction) | Instantiate a new RecnoDatabase object and open the database represented by Filename.
Open(String, String, RecnoDatabaseConfig) | Instantiate a new RecnoDatabase object and open the database represented by Filename and DatabaseName.
Open(String, String, RecnoDatabaseConfig, Transaction) | Instantiate a new RecnoDatabase object and open the database represented by Filename and DatabaseName.

See Also

RecnoDatabase Class
RecnoDatabase Members


Open Method (String, RecnoDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Open Method (String, RecnoDatabaseConfig)
RecnoDatabase Class See Also Send Feedback
Instantiate a new RecnoDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static RecnoDatabase Open(
    string Filename,
    RecnoDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As RecnoDatabaseConfig _
) As RecnoDatabase
Visual C++
public:
static RecnoDatabase^ Open(
    String^ Filename,
    RecnoDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.RecnoDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

RecnoDatabase Class
Open Overload


Open Method (String, RecnoDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Open Method (String, RecnoDatabaseConfig, Transaction)
RecnoDatabase Class See Also Send Feedback
Instantiate a new RecnoDatabase object and open the database represented by Filename.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static RecnoDatabase Open(
    string Filename,
    RecnoDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As RecnoDatabaseConfig, _
    txn As Transaction _
) As RecnoDatabase
Visual C++
public:
static RecnoDatabase^ Open(
    String^ Filename,
    RecnoDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.RecnoDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

RecnoDatabase Class
Open Overload


Open Method (String, String, RecnoDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Open Method (String, String, RecnoDatabaseConfig)
RecnoDatabase Class See Also Send Feedback
Instantiate a new RecnoDatabase object and open the database represented by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static RecnoDatabase Open(
    string Filename,
    string DatabaseName,
    RecnoDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As RecnoDatabaseConfig _
) As RecnoDatabase
Visual C++
public:
static RecnoDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    RecnoDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.RecnoDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and will be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

RecnoDatabase Class
Open Overload


Open Method (String, String, RecnoDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Open Method (String, String, RecnoDatabaseConfig, Transaction)
RecnoDatabase Class See Also Send Feedback
Instantiate a new RecnoDatabase object and open the database represented by Filename and DatabaseName.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static RecnoDatabase Open(
    string Filename,
    string DatabaseName,
    RecnoDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As RecnoDatabaseConfig, _
    txn As Transaction _
) As RecnoDatabase
Visual C++
public:
static RecnoDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    RecnoDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.RecnoDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and will be replicated to client sites in any replication group.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

RecnoDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.PrintFastStats Method
RecnoDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class
RecnoDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.PrintStats Method
RecnoDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class
RecnoDatabase Members


Put Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Put Method
RecnoDatabase Class See Also Send Feedback

If the database supports duplicates, add the new data value at the end of the duplicate set. If the database supports sorted duplicates, the new data value is inserted at the correct sorted location.

Overload List

Name | Description
Put(MultipleKeyDatabaseEntry) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)
Put(MultipleKeyDatabaseEntry, Transaction) | Store multiple data items using keys from the buffer to which the key parameter refers and data values from the buffer to which the data parameter refers. A successful bulk operation is logically equivalent to a loop through each key/data pair, performing a Put for each one. (Inherited from Database.)
Put(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, replacing any previously existing key if duplicates are disallowed, or adding a duplicate data item if duplicates are allowed. (Inherited from Database.)

See Also

RecnoDatabase Class
RecnoDatabase Members


PutNoOverwrite Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.PutNoOverwrite Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
PutNoOverwrite(MultipleKeyDatabaseEntry) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(MultipleKeyDatabaseEntry, Transaction) | Store the key/data pairs in the database, only if the key does not already appear in the database. (Inherited from Database.)
PutNoOverwrite(DatabaseEntry, DatabaseEntry, Transaction) | Store the key/data pair in the database, only if the key does not already appear in the database. (Inherited from Database.)

See Also

RecnoDatabase Class
RecnoDatabase Members


Stats Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Stats Method
RecnoDatabase Class See Also Send Feedback
The statistical information is described by BTreeStats.

Overload List

Name | Description
Stats()()() | Return the database statistical information for this database.
Stats(Transaction) | Return the database statistical information for this database.
Stats(Transaction, Isolation) | Return the database statistical information for this database.

See Also

RecnoDatabase Class
RecnoDatabase Members


Stats Method

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Stats Method
RecnoDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoStats Stats()
Visual Basic (Declaration)
Public Function Stats As RecnoStats
Visual C++
public:
RecnoStats^ Stats()

Return Value

Database statistical information.

See Also

RecnoDatabase Class
Stats Overload


Stats Method (Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Stats Method (Transaction)
RecnoDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoStats Stats(
    Transaction txn
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction _
) As RecnoStats
Visual C++
public:
RecnoStats^ Stats(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

Database statistical information.

See Also

RecnoDatabase Class
Stats Overload


Stats Method (Transaction, Isolation)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Stats Method (Transaction, Isolation)
RecnoDatabase Class See Also Send Feedback
Return the database statistical information for this database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoStats Stats(
    Transaction txn,
    Isolation isoDegree
)
Visual Basic (Declaration)
Public Function Stats ( _
    txn As Transaction, _
    isoDegree As Isolation _
) As RecnoStats
Visual C++
public:
RecnoStats^ Stats(
    Transaction^ txn,
    Isolation isoDegree
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.
isoDegree
Type: BerkeleyDB..::.Isolation
The level of isolation for database reads. DEGREE_ONE is silently ignored for databases which did not specify ReadUncommitted.

Return Value

Database statistical information.

See Also

RecnoDatabase Class
Stats Overload


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Truncate Method
RecnoDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class
RecnoDatabase Members


TruncateUnusedPages Method

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.TruncateUnusedPages Method
RecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
TruncateUnusedPages()()() | Return pages to the filesystem that are already free and at the end of the file.
TruncateUnusedPages(Transaction) | Return pages to the filesystem that are already free and at the end of the file.

See Also

RecnoDatabase Class
RecnoDatabase Members


TruncateUnusedPages Method

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.TruncateUnusedPages Method
RecnoDatabase Class See Also Send Feedback
Return pages to the filesystem that are already free and at the end of the file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TruncateUnusedPages()
Visual Basic (Declaration)
Public Function TruncateUnusedPages As UInteger
Visual C++
public:
unsigned int TruncateUnusedPages()

Return Value

The number of database pages returned to the filesystem

See Also

RecnoDatabase Class
TruncateUnusedPages Overload


TruncateUnusedPages Method (Transaction)

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.TruncateUnusedPages Method (Transaction)
RecnoDatabase Class See Also Send Feedback
Return pages to the filesystem that are already free and at the end of the file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TruncateUnusedPages(
    Transaction txn
)
Visual Basic (Declaration)
Public Function TruncateUnusedPages ( _
    txn As Transaction _
) As UInteger
Visual C++
public:
unsigned int TruncateUnusedPages(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

The number of database pages returned to the filesystem

See Also

RecnoDatabase Class
TruncateUnusedPages Overload


RecnoDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabase Properties
RecnoDatabase Class See Also Send Feedback

The RecnoDatabase type exposes the following members.

Properties

Name | Description
AppendCallback | A function to call after the record number has been selected but before the data has been stored into the database.
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
RecordDelimiter | The delimiting byte used to mark the end of a record in SourceFile.
RecordLength | If using fixed-length, not byte-delimited records, the length of the records.
RecordPad | The padding character for short, fixed-length records.
Renumber | If true, the logical record numbers are mutable, and change as records are added to and deleted from the database.
Snapshot | If true, any SourceFile file is read in its entirety when Open(String, RecnoDatabaseConfig) is called. If false, SourceFile may be read lazily.
SourceFile | The underlying source file for the Recno access method.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

RecnoDatabase Class


AppendCallback Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.AppendCallback Property
RecnoDatabase Class See Also Send Feedback
A function to call after the record number has been selected but before the data has been stored into the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public AppendRecordDelegate AppendCallback { get; set; }
Visual Basic (Declaration)
Public Property AppendCallback As AppendRecordDelegate
Visual C++
public:
property AppendRecordDelegate^ AppendCallback {
    AppendRecordDelegate^ get ();
    void set (AppendRecordDelegate^ value);
}

Remarks

When using Append(DatabaseEntry), it may be useful to modify the stored data based on the generated key. If a delegate is specified, it will be called after the record number has been selected, but before the data has been stored.

See Also

RecnoDatabase Class


RecordDelimiter Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.RecordDelimiter Property
RecnoDatabase Class See Also Send Feedback
The delimiting byte used to mark the end of a record in SourceFile.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int RecordDelimiter { get; private set; }
Visual Basic (Declaration)
Public Property RecordDelimiter As Integer
Visual C++
public:
property int RecordDelimiter {
    int get ();
    void set (int value);
}

See Also

RecnoDatabase Class


RecordLength Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.RecordLength Property
RecnoDatabase Class See Also Send Feedback
If using fixed-length, not byte-delimited records, the length of the records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RecordLength { get; private set; }
Visual Basic (Declaration)
Public Property RecordLength As UInteger
Visual C++
public:
property unsigned int RecordLength {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

RecnoDatabase Class


RecordPad Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.RecordPad Property
RecnoDatabase Class See Also Send Feedback
The padding character for short, fixed-length records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int RecordPad { get; private set; }
Visual Basic (Declaration)
Public Property RecordPad As Integer
Visual C++
public:
property int RecordPad {
    int get ();
    void set (int value);
}

See Also

RecnoDatabase Class


Renumber Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Renumber Property
RecnoDatabase Class See Also Send Feedback
If true, the logical record numbers are mutable, and change as records are added to and deleted from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Renumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property Renumber As Boolean
Visual C++
public:
property bool Renumber {
    bool get ();
}

See Also

RecnoDatabase Class


Snapshot Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.Snapshot Property
RecnoDatabase Class See Also Send Feedback
If true, any SourceFile file is read in its entirety when Open(String, RecnoDatabaseConfig) is called. If false, SourceFile may be read lazily.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Snapshot { get; }
Visual Basic (Declaration)
Public ReadOnly Property Snapshot As Boolean
Visual C++
public:
property bool Snapshot {
    bool get ();
}

See Also

RecnoDatabase Class


SourceFile Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabase..::.SourceFile Property
RecnoDatabase Class See Also Send Feedback
The underlying source file for the Recno access method.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string SourceFile { get; private set; }
Visual Basic (Declaration)
Public Property SourceFile As String
Visual C++
public:
property String^ SourceFile {
    String^ get ();
    void set (String^ value);
}

See Also

RecnoDatabase Class


RecnoDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for RecnoDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class RecnoDatabaseConfig : DatabaseConfig
Visual Basic (Declaration)
Public Class RecnoDatabaseConfig _
    Inherits DatabaseConfig
Visual C++
public ref class RecnoDatabaseConfig : public DatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.RecnoDatabaseConfig

See Also

RecnoDatabaseConfig Members


RecnoDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig Members
RecnoDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The RecnoDatabaseConfig type exposes the following members.

Constructors

Name | Description
RecnoDatabaseConfig | Instantiate a new RecnoDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Append | A function to call after the record number has been selected but before the data has been stored into the database.
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BackingFile | The underlying source file for the Recno access method.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Renumber | Causes the logical record numbers to be mutable, and change as records are added to and deleted from the database.
Snapshot | If true, any BackingFile file is read in its entirety when Open(String, RecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

Properties

Name | Description
Delimiter | The delimiting byte used to mark the end of a record in BackingFile.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Length | Specify that the records are fixed-length, not byte-delimited, and are of length Length.
PadByte | The padding character for short, fixed-length records.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)

See Also

RecnoDatabaseConfig Class


RecnoDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig Constructor
RecnoDatabaseConfig Class See Also Send Feedback
Instantiate a new RecnoDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RecnoDatabaseConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RecnoDatabaseConfig()

See Also

RecnoDatabaseConfig Class


RecnoDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig Fields
RecnoDatabaseConfig Class See Also Send Feedback

The RecnoDatabaseConfig type exposes the following members.

Fields

Name | Description
Append | A function to call after the record number has been selected but before the data has been stored into the database.
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BackingFile | The underlying source file for the Recno access method.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Renumber | Causes the logical record numbers to be mutable, and change as records are added to and deleted from the database.
Snapshot | If true, any BackingFile file is read in its entirety when Open(String, RecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

See Also

RecnoDatabaseConfig Class


Append Field

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig..::.Append Field
RecnoDatabaseConfig Class See Also Send Feedback
A function to call after the record number has been selected but before the data has been stored into the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public AppendRecordDelegate Append
Visual Basic (Declaration)
Public Append As AppendRecordDelegate
Visual C++
public:
AppendRecordDelegate^ Append

Remarks

When using Append(DatabaseEntry), it may be useful to modify the stored data based on the generated key. If a delegate is specified, it is called after the record number has been selected, but before the data has been stored.

See Also

RecnoDatabaseConfig Class


BackingFile Field

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig..::.BackingFile Field
RecnoDatabaseConfig Class See Also Send Feedback
The underlying source file for the Recno access method.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BackingFile
Visual Basic (Declaration)
Public BackingFile As String
Visual C++
public:
String^ BackingFile

Remarks

The purpose of the source file is to provide fast access and modification to databases that are normally stored as flat text files.

The source parameter specifies an underlying flat text database file that is read to initialize a transient record number index. In the case of variable length records, the records are separated, as specified by Delimiter. For example, standard UNIX byte stream files can be interpreted as a sequence of variable length records separated by newline characters.

In addition, when cached data would normally be written back to the underlying database file (for example, Close()()() or Sync()()()), the in-memory copy of the database is written back to the source file.

By default, the backing source file is read lazily; records are not read from the file until they are requested by the application. If multiple processes (not threads) are accessing a Recno database concurrently, and are either inserting or deleting records, the backing source file must be read in its entirety before more than a single process accesses the database, and only that process should specify the backing source file as part of the Open(String, RecnoDatabaseConfig) call. See Snapshot for more information.

Reading and writing the backing source file specified by source cannot be transaction-protected because it involves filesystem operations that are not part of the Db transaction methodology. For this reason, if a temporary database is used to hold the records, it is possible to lose the contents of the source file, for example, if the system crashes at the right instant. If a file is used to hold the database, normal database recovery on that file can be used to prevent information loss, although it is still possible that the contents of source are lost if the system crashes.

The source file must already exist (but may be zero-length) when Open(String, RecnoDatabaseConfig) is called.

It is not an error to specify a read-only source file when creating a database, nor is it an error to modify the resulting database. However, any attempt to write the changes to the backing source file using either the Sync()()() or Close()()() methods fail, of course. Use Close(Boolean) to stop it from attempting to write the changes to the backing file; instead, they are silently discarded.

For all of the previous reasons, the source file is generally used to specify databases that are read-only for Berkeley DB applications; and that are either generated on the fly by software tools or modified using a different mechanism — for example, a text editor.

If the database already exists, BackingFile must be the same as that historically used to create the database or corruption can occur.

See Also

RecnoDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig..::.Creation Field
RecnoDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, RecnoDatabaseConfig) fails.

See Also

RecnoDatabaseConfig Class


Renumber Field

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig..::.Renumber Field
RecnoDatabaseConfig Class See Also Send Feedback
Causes the logical record numbers to be mutable, and change as records are added to and deleted from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Renumber
Visual Basic (Declaration)
Public Renumber As Boolean
Visual C++
public:
bool Renumber

Remarks

Using Put(MultipleKeyDatabaseEntry) or Put(DatabaseEntry, DatabaseEntry, UInt32) to create new records causes the creation of multiple records if the record number is more than one greater than the largest record currently in the database. For example, creating record 28 when record 25 was previously the last record in the database creates records 26 and 27 as well as 28. Attempts to retrieve records that were created in this manner throw a KeyEmptyException.

If a created record is not at the end of the database, all records following the new record are automatically renumbered upward by one. For example, the creation of a new record numbered 8 causes records numbered 8 and greater to be renumbered upward by one. If a cursor was positioned to record number 8 or greater before the insertion, it is shifted upward one logical record, continuing to refer to the same record as it did before.

If a deleted record is not at the end of the database, all records following the removed record are automatically renumbered downward by one. For example, deleting the record numbered 8 causes records numbered 9 and greater to be renumbered downward by one. If a cursor was positioned to record number 9 or greater before the removal, it is shifted downward one logical record, continuing to refer to the same record as it did before.

If a record is deleted, all cursors that were positioned on that record prior to the removal are no longer positioned on a valid entry. This includes cursors used to delete an item. For example, if a cursor was positioned to record number 8 before the removal of that record, subsequent calls to Refresh()()() returns false until the cursor is moved to another record. A call to MoveNext()()() returns the new record numbered 8 - which is the record that was numbered 9 prior to the delete (if such a record existed).

For these reasons, concurrent access to a RecnoDatabase with this setting specified may be largely meaningless, although it is supported.

If the database already exists, this setting must be the same as the existing database or an exception is thrown.

See Also

RecnoDatabaseConfig Class


Snapshot Field

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig..::.Snapshot Field
RecnoDatabaseConfig Class See Also Send Feedback
If true, any BackingFile file is read in its entirety when Open(String, RecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Snapshot
Visual Basic (Declaration)
Public Snapshot As Boolean
Visual C++
public:
bool Snapshot

See Also

RecnoDatabaseConfig Class


RecnoDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig Methods
RecnoDatabaseConfig Class See Also Send Feedback

The RecnoDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RecnoDatabaseConfig Class


RecnoDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig Properties
RecnoDatabaseConfig Class See Also Send Feedback

The RecnoDatabaseConfig type exposes the following members.

Properties

Name | Description
Delimiter | The delimiting byte used to mark the end of a record in BackingFile.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Length | Specify that the records are fixed-length, not byte-delimited, and are of length Length.
PadByte | The padding character for short, fixed-length records.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)

See Also

RecnoDatabaseConfig Class


Delimiter Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig..::.Delimiter Property
RecnoDatabaseConfig Class See Also Send Feedback
The delimiting byte used to mark the end of a record in BackingFile.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int Delimiter { get; set; }
Visual Basic (Declaration)
Public Property Delimiter As Integer
Visual C++
public:
property int Delimiter {
    int get ();
    void set (int value);
}

Remarks

This byte is used for variable length records if BackingFile is set. If BackingFile is specified and no delimiting byte was specified, newline characters (ASCII 0x0a) are interpreted as end-of-record markers.

If the database already exists, this setting is ignored.

See Also

RecnoDatabaseConfig Class


Length Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig..::.Length Property
RecnoDatabaseConfig Class See Also Send Feedback
Specify that the records are fixed-length, not byte-delimited, and are of length Length.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Length { get; set; }
Visual Basic (Declaration)
Public Property Length As UInteger
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Any records added to the database that are less than Length bytes long are automatically padded (see PadByte for more information).

Any attempt to insert records into the database that are greater than Length bytes long cause the call to fail immediately and return an error.

If the database already exists, this setting is ignored.

See Also

RecnoDatabaseConfig Class


PadByte Property

[image]

Berkeley DB .NET API Documentation
RecnoDatabaseConfig..::.PadByte Property
RecnoDatabaseConfig Class See Also Send Feedback
The padding character for short, fixed-length records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int PadByte { get; set; }
Visual Basic (Declaration)
Public Property PadByte As Integer
Visual C++
public:
property int PadByte {
    int get ();
    void set (int value);
}

Remarks

If no pad character is specified, space characters (ASCII 0x20) are used for padding.

If the database already exists, this setting is ignored.

See Also

RecnoDatabaseConfig Class


RecnoStats Class

[image]

Berkeley DB .NET API Documentation
RecnoStats Class
Members See Also Send Feedback
Statistical information about a RecnoDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class RecnoStats
Visual Basic (Declaration)
Public Class RecnoStats
Visual C++
public ref class RecnoStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.RecnoStats

See Also

RecnoStats Members


RecnoStats Members

[image] [image]

Berkeley DB .NET API Documentation
RecnoStats Members
RecnoStats Class Methods Properties See Also Send Feedback

The RecnoStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
DuplicatePages | Duplicate pages.
DuplicatePagesFreeBytes | Bytes free in duplicate pages.
EmptyPages | Empty pages.
FreePages | Pages on the free list.
InternalPages | Internal pages.
InternalPagesFreeBytes | Bytes free in internal pages.
LeafPages | Leaf pages.
LeafPagesFreeBytes | Bytes free in leaf pages.
Levels | Tree levels.
MagicNumber | Magic number.
MetadataFlags | Metadata flags.
MinKey | Minkey value.
nData | Number of data items.
nKeys | Number of unique keys.
nPages | Page count.
OverflowPages | Overflow pages.
OverflowPagesFreeBytes | Bytes free in overflow pages.
PageSize | Page size.
RecordLength | Fixed-length record length.
RecordPadByte | Fixed-length record pad.
Version | Version number.

See Also

RecnoStats Class


RecnoStats Methods

[image] [image]

Berkeley DB .NET API Documentation
RecnoStats Methods
RecnoStats Class See Also Send Feedback

The RecnoStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RecnoStats Class


RecnoStats Properties

[image] [image]

Berkeley DB .NET API Documentation
RecnoStats Properties
RecnoStats Class See Also Send Feedback

The RecnoStats type exposes the following members.

Properties

Name | Description
DuplicatePages | Duplicate pages.
DuplicatePagesFreeBytes | Bytes free in duplicate pages.
EmptyPages | Empty pages.
FreePages | Pages on the free list.
InternalPages | Internal pages.
InternalPagesFreeBytes | Bytes free in internal pages.
LeafPages | Leaf pages.
LeafPagesFreeBytes | Bytes free in leaf pages.
Levels | Tree levels.
MagicNumber | Magic number.
MetadataFlags | Metadata flags.
MinKey | Minkey value.
nData | Number of data items.
nKeys | Number of unique keys.
nPages | Page count.
OverflowPages | Overflow pages.
OverflowPagesFreeBytes | Bytes free in overflow pages.
PageSize | Page size.
RecordLength | Fixed-length record length.
RecordPadByte | Fixed-length record pad.
Version | Version number.

See Also

RecnoStats Class


DuplicatePages Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.DuplicatePages Property
RecnoStats Class See Also Send Feedback
Duplicate pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DuplicatePages { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuplicatePages As UInteger
Visual C++
public:
property unsigned int DuplicatePages {
    unsigned int get ();
}

See Also

RecnoStats Class


DuplicatePagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.DuplicatePagesFreeBytes Property
RecnoStats Class See Also Send Feedback
Bytes free in duplicate pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong DuplicatePagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuplicatePagesFreeBytes As ULong
Visual C++
public:
property unsigned long long DuplicatePagesFreeBytes {
    unsigned long long get ();
}

See Also

RecnoStats Class


EmptyPages Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.EmptyPages Property
RecnoStats Class See Also Send Feedback
Empty pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint EmptyPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property EmptyPages As UInteger
Visual C++
public:
property unsigned int EmptyPages {
    unsigned int get ();
}

See Also

RecnoStats Class


FreePages Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.FreePages Property
RecnoStats Class See Also Send Feedback
Pages on the free list.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FreePages { get; }
Visual Basic (Declaration)
Public ReadOnly Property FreePages As UInteger
Visual C++
public:
property unsigned int FreePages {
    unsigned int get ();
}

See Also

RecnoStats Class


InternalPages Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.InternalPages Property
RecnoStats Class See Also Send Feedback
Internal pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InternalPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalPages As UInteger
Visual C++
public:
property unsigned int InternalPages {
    unsigned int get ();
}

See Also

RecnoStats Class


InternalPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.InternalPagesFreeBytes Property
RecnoStats Class See Also Send Feedback
Bytes free in internal pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong InternalPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property InternalPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long InternalPagesFreeBytes {
    unsigned long long get ();
}

See Also

RecnoStats Class


LeafPages Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.LeafPages Property
RecnoStats Class See Also Send Feedback
Leaf pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LeafPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeafPages As UInteger
Visual C++
public:
property unsigned int LeafPages {
    unsigned int get ();
}

See Also

RecnoStats Class


LeafPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.LeafPagesFreeBytes Property
RecnoStats Class See Also Send Feedback
Bytes free in leaf pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LeafPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeafPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long LeafPagesFreeBytes {
    unsigned long long get ();
}

See Also

RecnoStats Class


Levels Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.Levels Property
RecnoStats Class See Also Send Feedback
Tree levels.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Levels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Levels As UInteger
Visual C++
public:
property unsigned int Levels {
    unsigned int get ();
}

See Also

RecnoStats Class


MagicNumber Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.MagicNumber Property
RecnoStats Class See Also Send Feedback
Magic number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MagicNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property MagicNumber As UInteger
Visual C++
public:
property unsigned int MagicNumber {
    unsigned int get ();
}

See Also

RecnoStats Class


MetadataFlags Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.MetadataFlags Property
RecnoStats Class See Also Send Feedback
Metadata flags.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MetadataFlags { get; }
Visual Basic (Declaration)
Public ReadOnly Property MetadataFlags As UInteger
Visual C++
public:
property unsigned int MetadataFlags {
    unsigned int get ();
}

See Also

RecnoStats Class


MinKey Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.MinKey Property
RecnoStats Class See Also Send Feedback
Minkey value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MinKey { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinKey As UInteger
Visual C++
public:
property unsigned int MinKey {
    unsigned int get ();
}

See Also

RecnoStats Class


nData Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.nData Property
RecnoStats Class See Also Send Feedback
Number of data items.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nData { get; }
Visual Basic (Declaration)
Public ReadOnly Property nData As UInteger
Visual C++
public:
property unsigned int nData {
    unsigned int get ();
}

See Also

RecnoStats Class


nKeys Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.nKeys Property
RecnoStats Class See Also Send Feedback
Number of unique keys.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nKeys { get; }
Visual Basic (Declaration)
Public ReadOnly Property nKeys As UInteger
Visual C++
public:
property unsigned int nKeys {
    unsigned int get ();
}

See Also

RecnoStats Class


nPages Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.nPages Property
RecnoStats Class See Also Send Feedback
Page count.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint nPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property nPages As UInteger
Visual C++
public:
property unsigned int nPages {
    unsigned int get ();
}

See Also

RecnoStats Class


OverflowPages Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.OverflowPages Property
RecnoStats Class See Also Send Feedback
Overflow pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint OverflowPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowPages As UInteger
Visual C++
public:
property unsigned int OverflowPages {
    unsigned int get ();
}

See Also

RecnoStats Class


OverflowPagesFreeBytes Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.OverflowPagesFreeBytes Property
RecnoStats Class See Also Send Feedback
Bytes free in overflow pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong OverflowPagesFreeBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property OverflowPagesFreeBytes As ULong
Visual C++
public:
property unsigned long long OverflowPagesFreeBytes {
    unsigned long long get ();
}

See Also

RecnoStats Class


PageSize Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.PageSize Property
RecnoStats Class See Also Send Feedback
Page size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint PageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property PageSize As UInteger
Visual C++
public:
property unsigned int PageSize {
    unsigned int get ();
}

See Also

RecnoStats Class


RecordLength Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.RecordLength Property
RecnoStats Class See Also Send Feedback
Fixed-length record length.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RecordLength { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordLength As UInteger
Visual C++
public:
property unsigned int RecordLength {
    unsigned int get ();
}

See Also

RecnoStats Class


RecordPadByte Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.RecordPadByte Property
RecnoStats Class See Also Send Feedback
Fixed-length record pad.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RecordPadByte { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordPadByte As UInteger
Visual C++
public:
property unsigned int RecordPadByte {
    unsigned int get ();
}

See Also

RecnoStats Class


Version Property

[image]

Berkeley DB .NET API Documentation
RecnoStats..::.Version Property
RecnoStats Class See Also Send Feedback
Version number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Version { get; }
Visual Basic (Declaration)
Public ReadOnly Property Version As UInteger
Visual C++
public:
property unsigned int Version {
    unsigned int get ();
}

See Also

RecnoStats Class


ReplicationConfig Class

[image]

Berkeley DB .NET API Documentation
ReplicationConfig Class
Members See Also Send Feedback
A class representing configuration parameters for a DatabaseEnvironment's replication subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class ReplicationConfig
Visual Basic (Declaration)
Public Class ReplicationConfig
Visual C++
public ref class ReplicationConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.ReplicationConfig

See Also

ReplicationConfig Members


ReplicationConfig Members

[image] [image]

Berkeley DB .NET API Documentation
ReplicationConfig Members
ReplicationConfig Class Constructors Methods Fields Properties See Also Send Feedback

The ReplicationConfig type exposes the following members.

Constructors

Name | Description
ReplicationConfig | Instantiate a new ReplicationConfig object with default configuration values.

Methods

Name | Description
Clockskew | Set the clock skew ratio among replication group members based on the fastest and slowest measurements among the group for use with master leases.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
RepmgrIncomingQueueMax | Set a byte-count limit on the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RetransmissionRequest | Set a threshold for the minimum and maximum time that a client waits before requesting retransmission of a missing message.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TransmitLimit | Set a byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32). The limit is not a hard limit, and the record that exceeds the limit is the last record to be sent.

Fields

Name | Description
AutoInit | If true, the replication master automatically re-initializes outdated clients (defaults to true).
BulkTransfer | If true, the replication master sends groups of records to the clients in a single network transfer
DelayClientSync | If true, the client delays synchronizing to a newly declared master (defaults to false). Clients configured in this way remain unsynchronized until the application calls RepSync()()().
Elections | If true, Replication Manager automatically runs elections to choose a new master when the old master appears to have become disconnected (defaults to true).
InMemory | If true, replication only stores the internal information in-memory and cannot keep persistent state across a site crash or reboot. By default, it is false and replication creates files in the environment home directory to preserve the internal information. This configuration flag can only be set before the DatabaseEnvironment is opened.
NoBlocking | If true, Berkeley DB method calls that would normally block while clients are in recovery will return errors immediately (defaults to false).
PrefmasClient | This flag is used to specify the client site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The client site in a preferred master replication group takes over temporarily as master when the preferred master site is unavailable.
PrefmasMaster | This flag is used to specify the preferred master site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The preferred master site operates as the master site whenever possible.
RepMgrAckPolicy | Specify how master and client sites handle the acknowledgment of replication messages which is necessary for "permanent" records. The current implementation requires all sites in a replication group to configure the same acknowledgement policy.
RepmgrSitesConfig | A list of site configurations.
Strict2Site | If true, the Replication Manager observes the strict "majority" rule in managing elections, even in a group with only 2 sites. This means the client in a 2-site group is unable to take over as master if the original master fails or becomes disconnected. (See the Elections section in the Berkeley DB Reference Guide for more information.) Both sites in the replication group should have the same value for this parameter.
Transport | The delegate used to transmit data using the replication application's communication infrastructure.
UseMasterLeases | If true, master leases are used for this site (defaults to false).

Properties

Name | Description
AckTimeout | The amount of time the replication manager's transport function waits to collect enough acknowledgments from replication group clients, before giving up and returning a failure indication. The default wait time is 1 second.
CheckpointDelay | The amount of time a master site delays between completing a checkpoint and writing a checkpoint record into the log.
ClockskewFast | The value, relative to ClockskewSlow, of the fastest clock in the group of sites.
ClockskewSlow | The value of the slowest clock in the group of sites.
ConnectionRetry | The amount of time the replication manager waits before trying to re-establish a connection to another site after a communication failure. The default wait time is 30 seconds.
ElectionRetry | Configure the amount of time the replication manager waits before retrying a failed election. The default wait time is 10 seconds.
ElectionTimeout | The timeout period for an election. The default timeout is 2 seconds.
FullElectionTimeout | An optional configuration timeout period to wait for full election participation the first time the replication group finds a master. By default this option is turned off and normal election timeouts are used. (See the Elections section in the Berkeley DB Reference Guide for more information.)
HeartbeatMonitor | The amount of time the replication manager, running at a client site, waits for some message activity on the connection from the master (heartbeats or other messages) before concluding that the connection has been lost. When 0 (the default), no monitoring is performed.
HeartbeatSend | The frequency at which the replication manager, running at a master site, broadcasts a heartbeat message in an otherwise idle system. When 0 (the default), no heartbeat messages are sent.
LeaseTimeout | The amount of time a client grants its master lease to a master. When using master leases all sites in a replication group must use the same lease timeout value. There is no default value. If leases are desired, this method must be called prior to calling RepStartClient()()() or RepStartMaster()()().
NSites | The total number of sites in the replication group.
Priority | The database environment's priority in replication group elections. A special value of 0 indicates that this environment cannot be a replication group master. If not configured, then a default value of 100 is used.
ReplicationView | Create a replication view and specify the function to determine whether a database file is replicated to the local site.
RepmgrIncomingQueueMaxBytes | The bytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RepmgrIncomingQueueMaxGBytes | The gigabytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RetransmissionRequestMax | The maximum number of microseconds a client waits before requesting retransmission.
RetransmissionRequestMin | The minimum number of microseconds a client waits before requesting retransmission.
TransmitLimitBytes | The bytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
TransmitLimitGBytes | The gigabytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

See Also

ReplicationConfig Class


ReplicationConfig Constructor

[image]

Berkeley DB .NET API Documentation
ReplicationConfig Constructor
ReplicationConfig Class See Also Send Feedback
Instantiate a new ReplicationConfig object with default configuration values.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReplicationConfig()

See Also

ReplicationConfig Class


ReplicationConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
ReplicationConfig Fields
ReplicationConfig Class See Also Send Feedback

The ReplicationConfig type exposes the following members.

Fields

Name | Description
AutoInit | If true, the replication master automatically re-initializes outdated clients (defaults to true).
BulkTransfer | If true, the replication master sends groups of records to the clients in a single network transfer
DelayClientSync | If true, the client delays synchronizing to a newly declared master (defaults to false). Clients configured in this way remain unsynchronized until the application calls RepSync()()().
Elections | If true, Replication Manager automatically runs elections to choose a new master when the old master appears to have become disconnected (defaults to true).
InMemory | If true, replication only stores the internal information in-memory and cannot keep persistent state across a site crash or reboot. By default, it is false and replication creates files in the environment home directory to preserve the internal information. This configuration flag can only be set before the DatabaseEnvironment is opened.
NoBlocking | If true, Berkeley DB method calls that would normally block while clients are in recovery will return errors immediately (defaults to false).
PrefmasClient | This flag is used to specify the client site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The client site in a preferred master replication group takes over temporarily as master when the preferred master site is unavailable.
PrefmasMaster | This flag is used to specify the preferred master site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The preferred master site operates as the master site whenever possible.
RepMgrAckPolicy | Specify how master and client sites handle the acknowledgment of replication messages which is necessary for "permanent" records. The current implementation requires all sites in a replication group to configure the same acknowledgement policy.
RepmgrSitesConfig | A list of site configurations.
Strict2Site | If true, the Replication Manager observes the strict "majority" rule in managing elections, even in a group with only 2 sites. This means the client in a 2-site group is unable to take over as master if the original master fails or becomes disconnected. (See the Elections section in the Berkeley DB Reference Guide for more information.) Both sites in the replication group should have the same value for this parameter.
Transport | The delegate used to transmit data using the replication application's communication infrastructure.
UseMasterLeases | If true, master leases are used for this site (defaults to false).

See Also

ReplicationConfig Class


AutoInit Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.AutoInit Field
ReplicationConfig Class See Also Send Feedback
If true, the replication master automatically re-initializes outdated clients (defaults to true).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool AutoInit
Visual Basic (Declaration)
Public AutoInit As Boolean
Visual C++
public:
bool AutoInit

See Also

ReplicationConfig Class


BulkTransfer Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.BulkTransfer Field
ReplicationConfig Class See Also Send Feedback
If true, the replication master sends groups of records to the clients in a single network transfer

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool BulkTransfer
Visual Basic (Declaration)
Public BulkTransfer As Boolean
Visual C++
public:
bool BulkTransfer

See Also

ReplicationConfig Class


DelayClientSync Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.DelayClientSync Field
ReplicationConfig Class See Also Send Feedback
If true, the client delays synchronizing to a newly declared master (defaults to false). Clients configured in this way remain unsynchronized until the application calls RepSync()()().

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool DelayClientSync
Visual Basic (Declaration)
Public DelayClientSync As Boolean
Visual C++
public:
bool DelayClientSync

See Also

ReplicationConfig Class


Elections Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.Elections Field
ReplicationConfig Class See Also Send Feedback
If true, Replication Manager automatically runs elections to choose a new master when the old master appears to have become disconnected (defaults to true).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Elections
Visual Basic (Declaration)
Public Elections As Boolean
Visual C++
public:
bool Elections

See Also

ReplicationConfig Class


InMemory Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.InMemory Field
ReplicationConfig Class See Also Send Feedback
If true, replication only stores the internal information in-memory and cannot keep persistent state across a site crash or reboot. By default, it is false and replication creates files in the environment home directory to preserve the internal information. This configuration flag can only be set before the DatabaseEnvironment is opened.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool InMemory
Visual Basic (Declaration)
Public InMemory As Boolean
Visual C++
public:
bool InMemory

See Also

ReplicationConfig Class


NoBlocking Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.NoBlocking Field
ReplicationConfig Class See Also Send Feedback
If true, Berkeley DB method calls that would normally block while clients are in recovery will return errors immediately (defaults to false).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoBlocking
Visual Basic (Declaration)
Public NoBlocking As Boolean
Visual C++
public:
bool NoBlocking

See Also

ReplicationConfig Class


PrefmasClient Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.PrefmasClient Field
ReplicationConfig Class See Also Send Feedback
This flag is used to specify the client site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The client site in a preferred master replication group takes over temporarily as master when the preferred master site is unavailable.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool PrefmasClient
Visual Basic (Declaration)
Public PrefmasClient As Boolean
Visual C++
public:
bool PrefmasClient

See Also

ReplicationConfig Class


PrefmasMaster Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.PrefmasMaster Field
ReplicationConfig Class See Also Send Feedback
This flag is used to specify the preferred master site in a replication group operating in preferred master mode. A preferred master replication group must contain only two sites, with one site specified as the preferred master site and the other site specified as the client site. The preferred master site operates as the master site whenever possible.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool PrefmasMaster
Visual Basic (Declaration)
Public PrefmasMaster As Boolean
Visual C++
public:
bool PrefmasMaster

See Also

ReplicationConfig Class


RepMgrAckPolicy Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.RepMgrAckPolicy Field
ReplicationConfig Class See Also Send Feedback
Specify how master and client sites handle the acknowledgment of replication messages which is necessary for "permanent" records. The current implementation requires all sites in a replication group to configure the same acknowledgement policy.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public AckPolicy RepMgrAckPolicy
Visual Basic (Declaration)
Public RepMgrAckPolicy As AckPolicy
Visual C++
public:
AckPolicy^ RepMgrAckPolicy

See Also

ReplicationConfig Class
BerkeleyDB Namespace
ReplicationConfig..::.AckTimeout


RepmgrSitesConfig Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.RepmgrSitesConfig Field
ReplicationConfig Class See Also Send Feedback
A list of site configurations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public List<DbSiteConfig> RepmgrSitesConfig
Visual Basic (Declaration)
Public RepmgrSitesConfig As List(Of DbSiteConfig)
Visual C++
public:
List<DbSiteConfig^>^ RepmgrSitesConfig

See Also

ReplicationConfig Class


Strict2Site Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.Strict2Site Field
ReplicationConfig Class See Also Send Feedback
If true, the Replication Manager observes the strict "majority" rule in managing elections, even in a group with only 2 sites. This means the client in a 2-site group is unable to take over as master if the original master fails or becomes disconnected. (See the Elections section in the Berkeley DB Reference Guide for more information.) Both sites in the replication group should have the same value for this parameter.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Strict2Site
Visual Basic (Declaration)
Public Strict2Site As Boolean
Visual C++
public:
bool Strict2Site

See Also

ReplicationConfig Class


Transport Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.Transport Field
ReplicationConfig Class See Also Send Feedback
The delegate used to transmit data using the replication application's communication infrastructure.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationTransportDelegate Transport
Visual Basic (Declaration)
Public Transport As ReplicationTransportDelegate
Visual C++
public:
ReplicationTransportDelegate^ Transport

See Also

ReplicationConfig Class


UseMasterLeases Field

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.UseMasterLeases Field
ReplicationConfig Class See Also Send Feedback
If true, master leases are used for this site (defaults to false).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseMasterLeases
Visual Basic (Declaration)
Public UseMasterLeases As Boolean
Visual C++
public:
bool UseMasterLeases

Remarks

Configuring this option may result in a LeaseExpiredException when attempting to read entries from a database after the site's master lease has expired.

See Also

ReplicationConfig Class


ReplicationConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
ReplicationConfig Methods
ReplicationConfig Class See Also Send Feedback

The ReplicationConfig type exposes the following members.

Methods

Name | Description
Clockskew | Set the clock skew ratio among replication group members based on the fastest and slowest measurements among the group for use with master leases.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
RepmgrIncomingQueueMax | Set a byte-count limit on the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RetransmissionRequest | Set a threshold for the minimum and maximum time that a client waits before requesting retransmission of a missing message.
ToString | Returns a string that represents the current object. (Inherited from Object.)
TransmitLimit | Set a byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32). The limit is not a hard limit, and the record that exceeds the limit is the last record to be sent.

See Also

ReplicationConfig Class


Clockskew Method

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.Clockskew Method
ReplicationConfig Class See Also Send Feedback
Set the clock skew ratio among replication group members based on the fastest and slowest measurements among the group for use with master leases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Clockskew(
    uint fast,
    uint slow
)
Visual Basic (Declaration)
Public Sub Clockskew ( _
    fast As UInteger, _
    slow As UInteger _
)
Visual C++
public:
void Clockskew(
    unsigned int fast,
    unsigned int slow
)

Parameters

fast
Type: System..::.UInt32
The value, relative to slow, of the fastest clock in the group of sites.
slow
Type: System..::.UInt32
The value of the slowest clock in the group of sites.

Remarks

Calling this method is optional, the default values for clock skew assume no skew. The user must also configure leases via UseMasterLeases. Additionally, the user must also set the master lease timeout via LeaseTimeout and the number of sites in the replication group via NSites. These settings may be configured in any order. For a description of the clock skew values, see Clock skew in the Berkeley DB Programmer's Reference Guide. For a description of master leases, see Master leases in the Berkeley DB Programmer's Reference Guide.

These arguments can be used to express either raw measurements of a clock timing experiment or a percentage across machines. For instance a group of sites have a 2% variance, then fast should be set to 102, and slow should be set to 100. Or, for a 0.03% difference, you can use 10003 and 10000 respectively.

See Also

ReplicationConfig Class


RepmgrIncomingQueueMax Method

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.RepmgrIncomingQueueMax Method
ReplicationConfig Class See Also Send Feedback
Set a byte-count limit on the maximum amount of dynamic memory used by the Replication Manager incoming queue.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RepmgrIncomingQueueMax(
    uint GBytes,
    uint Bytes
)
Visual Basic (Declaration)
Public Sub RepmgrIncomingQueueMax ( _
    GBytes As UInteger, _
    Bytes As UInteger _
)
Visual C++
public:
void RepmgrIncomingQueueMax(
    unsigned int GBytes,
    unsigned int Bytes
)

Parameters

GBytes
Type: System..::.UInt32
The number of gigabytes which, when added to Bytes, specifies the maximum amount of dynamic memory used by the Replication Manager incoming queue.
Bytes
Type: System..::.UInt32
The number of bytes which, when added to GBytes, specifies the maximum amount of dynamic memory used by the Replication Manager incoming queue.

Remarks

By default, the Replication Manager incoming queue size has a limit of 100MB.

If both GBytes and Bytes are zero, then the Replication Manager incoming queue size is limited by available heap memory.

See Also

ReplicationConfig Class


RetransmissionRequest Method

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.RetransmissionRequest Method
ReplicationConfig Class See Also Send Feedback
Set a threshold for the minimum and maximum time that a client waits before requesting retransmission of a missing message.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void RetransmissionRequest(
    uint min,
    uint max
)
Visual Basic (Declaration)
Public Sub RetransmissionRequest ( _
    min As UInteger, _
    max As UInteger _
)
Visual C++
public:
void RetransmissionRequest(
    unsigned int min,
    unsigned int max
)

Parameters

min
Type: System..::.UInt32
The minimum number of microseconds a client waits before requesting retransmission.
max
Type: System..::.UInt32
The maximum number of microseconds a client waits before requesting retransmission.

Remarks

If the client detects a gap in the sequence of incoming log records or database pages, Berkeley DB waits for at least min microseconds before requesting retransmission of the missing record. Berkeley DB doubles that amount before requesting the same missing record again, and so on, up to a maximum threshold of max microseconds.

These values are thresholds only. Replication Manager applications use these values to determine when to automatically request retransmission of missing messages. For Base API applications, Berkeley DB has no thread available in the library as a timer, the threshold is only checked when a thread enters the Berkeley DB library to process an incoming replication message. Any amount of time may have passed since the last message arrived and Berkeley DB only checks whether the amount of time since a request was made is beyond the threshold value or not.

By default the minimum is 40000 and the maximum is 1280000 (1.28 seconds). These defaults are fairly arbitrary and the application likely needs to adjust these. The values should be based on expected load and performance characteristics of the master and client host platforms and transport infrastructure as well as round-trip message time.

See Also

ReplicationConfig Class


TransmitLimit Method

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.TransmitLimit Method
ReplicationConfig Class See Also Send Feedback
Set a byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32). The limit is not a hard limit, and the record that exceeds the limit is the last record to be sent.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void TransmitLimit(
    uint GBytes,
    uint Bytes
)
Visual Basic (Declaration)
Public Sub TransmitLimit ( _
    GBytes As UInteger, _
    Bytes As UInteger _
)
Visual C++
public:
void TransmitLimit(
    unsigned int GBytes,
    unsigned int Bytes
)

Parameters

GBytes
Type: System..::.UInt32
The number of gigabytes which, when added to Bytes, specifies the maximum number of bytes that are sent in a single call to RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
Bytes
Type: System..::.UInt32
The number of bytes which, when added to GBytes, specifies the maximum number of bytes that are sent in a single call to RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

Remarks

Record transmission throttling is turned on by default with a limit of 10MB.

If both GBytes and Bytes are zero, then the transmission limit is turned off.

See Also

ReplicationConfig Class


ReplicationConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
ReplicationConfig Properties
ReplicationConfig Class See Also Send Feedback

The ReplicationConfig type exposes the following members.

Properties

Name | Description
AckTimeout | The amount of time the replication manager's transport function waits to collect enough acknowledgments from replication group clients, before giving up and returning a failure indication. The default wait time is 1 second.
CheckpointDelay | The amount of time a master site delays between completing a checkpoint and writing a checkpoint record into the log.
ClockskewFast | The value, relative to ClockskewSlow, of the fastest clock in the group of sites.
ClockskewSlow | The value of the slowest clock in the group of sites.
ConnectionRetry | The amount of time the replication manager waits before trying to re-establish a connection to another site after a communication failure. The default wait time is 30 seconds.
ElectionRetry | Configure the amount of time the replication manager waits before retrying a failed election. The default wait time is 10 seconds.
ElectionTimeout | The timeout period for an election. The default timeout is 2 seconds.
FullElectionTimeout | An optional configuration timeout period to wait for full election participation the first time the replication group finds a master. By default this option is turned off and normal election timeouts are used. (See the Elections section in the Berkeley DB Reference Guide for more information.)
HeartbeatMonitor | The amount of time the replication manager, running at a client site, waits for some message activity on the connection from the master (heartbeats or other messages) before concluding that the connection has been lost. When 0 (the default), no monitoring is performed.
HeartbeatSend | The frequency at which the replication manager, running at a master site, broadcasts a heartbeat message in an otherwise idle system. When 0 (the default), no heartbeat messages are sent.
LeaseTimeout | The amount of time a client grants its master lease to a master. When using master leases all sites in a replication group must use the same lease timeout value. There is no default value. If leases are desired, this method must be called prior to calling RepStartClient()()() or RepStartMaster()()().
NSites | The total number of sites in the replication group.
Priority | The database environment's priority in replication group elections. A special value of 0 indicates that this environment cannot be a replication group master. If not configured, then a default value of 100 is used.
ReplicationView | Create a replication view and specify the function to determine whether a database file is replicated to the local site.
RepmgrIncomingQueueMaxBytes | The bytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RepmgrIncomingQueueMaxGBytes | The gigabytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.
RetransmissionRequestMax | The maximum number of microseconds a client waits before requesting retransmission.
RetransmissionRequestMin | The minimum number of microseconds a client waits before requesting retransmission.
TransmitLimitBytes | The bytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).
TransmitLimitGBytes | The gigabytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

See Also

ReplicationConfig Class


AckTimeout Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.AckTimeout Property
ReplicationConfig Class See Also Send Feedback
The amount of time the replication manager's transport function waits to collect enough acknowledgments from replication group clients, before giving up and returning a failure indication. The default wait time is 1 second.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint AckTimeout { get; set; }
Visual Basic (Declaration)
Public Property AckTimeout As UInteger
Visual C++
public:
property unsigned int AckTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


CheckpointDelay Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.CheckpointDelay Property
ReplicationConfig Class See Also Send Feedback
The amount of time a master site delays between completing a checkpoint and writing a checkpoint record into the log.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CheckpointDelay { get; set; }
Visual Basic (Declaration)
Public Property CheckpointDelay As UInteger
Visual C++
public:
property unsigned int CheckpointDelay {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This delay allows clients to complete their own checkpoints before the master requires completion of them. The default is 30 seconds. If all databases in the environment, and the environment's transaction log, are configured to reside in-memory (never preserved to disk), then, although checkpoints are still necessary, the delay is not useful and should be set to 0.

See Also

ReplicationConfig Class


ClockskewFast Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.ClockskewFast Property
ReplicationConfig Class See Also Send Feedback
The value, relative to ClockskewSlow, of the fastest clock in the group of sites.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ClockskewFast { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClockskewFast As UInteger
Visual C++
public:
property unsigned int ClockskewFast {
    unsigned int get ();
}

See Also

ReplicationConfig Class


ClockskewSlow Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.ClockskewSlow Property
ReplicationConfig Class See Also Send Feedback
The value of the slowest clock in the group of sites.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ClockskewSlow { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClockskewSlow As UInteger
Visual C++
public:
property unsigned int ClockskewSlow {
    unsigned int get ();
}

See Also

ReplicationConfig Class


ConnectionRetry Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.ConnectionRetry Property
ReplicationConfig Class See Also Send Feedback
The amount of time the replication manager waits before trying to re-establish a connection to another site after a communication failure. The default wait time is 30 seconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ConnectionRetry { get; set; }
Visual Basic (Declaration)
Public Property ConnectionRetry As UInteger
Visual C++
public:
property unsigned int ConnectionRetry {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


ElectionRetry Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.ElectionRetry Property
ReplicationConfig Class See Also Send Feedback
Configure the amount of time the replication manager waits before retrying a failed election. The default wait time is 10 seconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionRetry { get; set; }
Visual Basic (Declaration)
Public Property ElectionRetry As UInteger
Visual C++
public:
property unsigned int ElectionRetry {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


ElectionTimeout Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.ElectionTimeout Property
ReplicationConfig Class See Also Send Feedback
The timeout period for an election. The default timeout is 2 seconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionTimeout { get; set; }
Visual Basic (Declaration)
Public Property ElectionTimeout As UInteger
Visual C++
public:
property unsigned int ElectionTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


FullElectionTimeout Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.FullElectionTimeout Property
ReplicationConfig Class See Also Send Feedback
An optional configuration timeout period to wait for full election participation the first time the replication group finds a master. By default this option is turned off and normal election timeouts are used. (See the Elections section in the Berkeley DB Reference Guide for more information.)

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FullElectionTimeout { get; set; }
Visual Basic (Declaration)
Public Property FullElectionTimeout As UInteger
Visual C++
public:
property unsigned int FullElectionTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


HeartbeatMonitor Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.HeartbeatMonitor Property
ReplicationConfig Class See Also Send Feedback
The amount of time the replication manager, running at a client site, waits for some message activity on the connection from the master (heartbeats or other messages) before concluding that the connection has been lost. When 0 (the default), no monitoring is performed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint HeartbeatMonitor { get; set; }
Visual Basic (Declaration)
Public Property HeartbeatMonitor As UInteger
Visual C++
public:
property unsigned int HeartbeatMonitor {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


HeartbeatSend Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.HeartbeatSend Property
ReplicationConfig Class See Also Send Feedback
The frequency at which the replication manager, running at a master site, broadcasts a heartbeat message in an otherwise idle system. When 0 (the default), no heartbeat messages are sent.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint HeartbeatSend { get; set; }
Visual Basic (Declaration)
Public Property HeartbeatSend As UInteger
Visual C++
public:
property unsigned int HeartbeatSend {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


LeaseTimeout Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.LeaseTimeout Property
ReplicationConfig Class See Also Send Feedback
The amount of time a client grants its master lease to a master. When using master leases all sites in a replication group must use the same lease timeout value. There is no default value. If leases are desired, this method must be called prior to calling RepStartClient()()() or RepStartMaster()()().

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LeaseTimeout { get; set; }
Visual Basic (Declaration)
Public Property LeaseTimeout As UInteger
Visual C++
public:
property unsigned int LeaseTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


NSites Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.NSites Property
ReplicationConfig Class See Also Send Feedback
The total number of sites in the replication group.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NSites { get; set; }
Visual Basic (Declaration)
Public Property NSites As UInteger
Visual C++
public:
property unsigned int NSites {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This setting is typically used by applications which use the Berkeley DB library "replication manager" support. (However, see also RepHoldElection()()(), the description of the nsites parameter.)

See Also

ReplicationConfig Class


Priority Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.Priority Property
ReplicationConfig Class See Also Send Feedback
The database environment's priority in replication group elections. A special value of 0 indicates that this environment cannot be a replication group master. If not configured, then a default value of 100 is used.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Priority { get; set; }
Visual Basic (Declaration)
Public Property Priority As UInteger
Visual C++
public:
property unsigned int Priority {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

ReplicationConfig Class


ReplicationView Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.ReplicationView Property
ReplicationConfig Class See Also Send Feedback
Create a replication view and specify the function to determine whether a database file is replicated to the local site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationViewDelegate ReplicationView { get; set; }
Visual Basic (Declaration)
Public Property ReplicationView As ReplicationViewDelegate
Visual C++
public:
property ReplicationViewDelegate^ ReplicationView {
    ReplicationViewDelegate^ get ();
    void set (ReplicationViewDelegate^ value);
}

Remarks

If it is null, the replication view is a full view and all database files are replicated to the local site. Otherwise it is a partial view and only some database files are replicated to the local site.

See Also

ReplicationConfig Class


RepmgrIncomingQueueMaxBytes Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.RepmgrIncomingQueueMaxBytes Property
ReplicationConfig Class See Also Send Feedback
The bytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepmgrIncomingQueueMaxBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepmgrIncomingQueueMaxBytes As UInteger
Visual C++
public:
property unsigned int RepmgrIncomingQueueMaxBytes {
    unsigned int get ();
}

See Also

ReplicationConfig Class


RepmgrIncomingQueueMaxGBytes Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.RepmgrIncomingQueueMaxGBytes Property
ReplicationConfig Class See Also Send Feedback
The gigabytes component of the maximum amount of dynamic memory used by the Replication Manager incoming queue.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RepmgrIncomingQueueMaxGBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property RepmgrIncomingQueueMaxGBytes As UInteger
Visual C++
public:
property unsigned int RepmgrIncomingQueueMaxGBytes {
    unsigned int get ();
}

See Also

ReplicationConfig Class


RetransmissionRequestMax Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.RetransmissionRequestMax Property
ReplicationConfig Class See Also Send Feedback
The maximum number of microseconds a client waits before requesting retransmission.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RetransmissionRequestMax { get; }
Visual Basic (Declaration)
Public ReadOnly Property RetransmissionRequestMax As UInteger
Visual C++
public:
property unsigned int RetransmissionRequestMax {
    unsigned int get ();
}

See Also

ReplicationConfig Class


RetransmissionRequestMin Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.RetransmissionRequestMin Property
ReplicationConfig Class See Also Send Feedback
The minimum number of microseconds a client waits before requesting retransmission.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RetransmissionRequestMin { get; }
Visual Basic (Declaration)
Public ReadOnly Property RetransmissionRequestMin As UInteger
Visual C++
public:
property unsigned int RetransmissionRequestMin {
    unsigned int get ();
}

See Also

ReplicationConfig Class


TransmitLimitBytes Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.TransmitLimitBytes Property
ReplicationConfig Class See Also Send Feedback
The bytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TransmitLimitBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property TransmitLimitBytes As UInteger
Visual C++
public:
property unsigned int TransmitLimitBytes {
    unsigned int get ();
}

See Also

ReplicationConfig Class


TransmitLimitGBytes Property

[image]

Berkeley DB .NET API Documentation
ReplicationConfig..::.TransmitLimitGBytes Property
ReplicationConfig Class See Also Send Feedback
The gigabytes component of the byte-count limit on the amount of data that is transmitted from a site in response to a single message processed by RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TransmitLimitGBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property TransmitLimitGBytes As UInteger
Visual C++
public:
property unsigned int TransmitLimitGBytes {
    unsigned int get ();
}

See Also

ReplicationConfig Class


ReplicationHostAddress Class

[image]

Berkeley DB .NET API Documentation
ReplicationHostAddress Class
Members See Also Send Feedback
A class representing the address of a replication site used by Berkeley DB HA.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class ReplicationHostAddress
Visual Basic (Declaration)
Public Class ReplicationHostAddress
Visual C++
public ref class ReplicationHostAddress

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.ReplicationHostAddress

See Also

ReplicationHostAddress Members


ReplicationHostAddress Members

[image] [image]

Berkeley DB .NET API Documentation
ReplicationHostAddress Members
ReplicationHostAddress Class Constructors Methods Fields See Also Send Feedback

The ReplicationHostAddress type exposes the following members.

Constructors

Name | Description
ReplicationHostAddress | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Host | The site's host identification string, generally a TCP/IP host name.
Port | The port number on which the site is receiving.

See Also

ReplicationHostAddress Class


ReplicationHostAddress Constructor

[image] [image]

Berkeley DB .NET API Documentation
ReplicationHostAddress Constructor
ReplicationHostAddress Class See Also Send Feedback

Overload List

Name | Description
ReplicationHostAddress()()() | Instantiate a new, empty address
ReplicationHostAddress(String) | Instantiate a new address, parsing the host and port from the given string
ReplicationHostAddress(String, UInt32) | Instantiate a new address

See Also

ReplicationHostAddress Class
ReplicationHostAddress Members


ReplicationHostAddress Constructor

[image]

Berkeley DB .NET API Documentation
ReplicationHostAddress Constructor
ReplicationHostAddress Class See Also Send Feedback
Instantiate a new, empty address

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationHostAddress()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ReplicationHostAddress()

See Also

ReplicationHostAddress Class
ReplicationHostAddress Overload


ReplicationHostAddress Constructor (String)

[image]

Berkeley DB .NET API Documentation
ReplicationHostAddress Constructor (String)
ReplicationHostAddress Class See Also Send Feedback
Instantiate a new address, parsing the host and port from the given string

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationHostAddress(
    string HostAndPort
)
Visual Basic (Declaration)
Public Sub New ( _
    HostAndPort As String _
)
Visual C++
public:
ReplicationHostAddress(
    String^ HostAndPort
)

Parameters

HostAndPort
Type: System..::.String
A string in host:port format

See Also

ReplicationHostAddress Class
ReplicationHostAddress Overload


ReplicationHostAddress Constructor (String, UInt32)

[image]

Berkeley DB .NET API Documentation
ReplicationHostAddress Constructor (String, UInt32)
ReplicationHostAddress Class See Also Send Feedback
Instantiate a new address

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationHostAddress(
    string Host,
    uint Port
)
Visual Basic (Declaration)
Public Sub New ( _
    Host As String, _
    Port As UInteger _
)
Visual C++
public:
ReplicationHostAddress(
    String^ Host,
    unsigned int Port
)

Parameters

Host
Type: System..::.String
The site's host identification string
Port
Type: System..::.UInt32
The port number on which the site is receiving.

See Also

ReplicationHostAddress Class
ReplicationHostAddress Overload


ReplicationHostAddress Fields

[image] [image]

Berkeley DB .NET API Documentation
ReplicationHostAddress Fields
ReplicationHostAddress Class See Also Send Feedback

The ReplicationHostAddress type exposes the following members.

Fields

Name | Description
Host | The site's host identification string, generally a TCP/IP host name.
Port | The port number on which the site is receiving.

See Also

ReplicationHostAddress Class


Host Field

[image]

Berkeley DB .NET API Documentation
ReplicationHostAddress..::.Host Field
ReplicationHostAddress Class See Also Send Feedback
The site's host identification string, generally a TCP/IP host name.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Host
Visual Basic (Declaration)
Public Host As String
Visual C++
public:
String^ Host

See Also

ReplicationHostAddress Class


Port Field

[image]

Berkeley DB .NET API Documentation
ReplicationHostAddress..::.Port Field
ReplicationHostAddress Class See Also Send Feedback
The port number on which the site is receiving.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Port
Visual Basic (Declaration)
Public Port As UInteger
Visual C++
public:
unsigned int Port

See Also

ReplicationHostAddress Class


ReplicationHostAddress Methods

[image] [image]

Berkeley DB .NET API Documentation
ReplicationHostAddress Methods
ReplicationHostAddress Class See Also Send Feedback

The ReplicationHostAddress type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReplicationHostAddress Class


ReplicationStats Class

[image]

Berkeley DB .NET API Documentation
ReplicationStats Class
Members See Also Send Feedback
Statistical information about the replication subsystem

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class ReplicationStats
Visual Basic (Declaration)
Public Class ReplicationStats
Visual C++
public ref class ReplicationStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.ReplicationStats

See Also

ReplicationStats Members


ReplicationStats Members

[image] [image]

Berkeley DB .NET API Documentation
ReplicationStats Members
ReplicationStats Class Methods Properties See Also Send Feedback

The ReplicationStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AppliedTransactions | Number of transactions applied.
AwaitedLSN | Awaited LSN, if any.
AwaitedPage | Awaited Page, if any.
BadGenerationMessages | Messages with a bad generation number.
BulkBufferFills | Bulk buffer fills.
BulkBufferOverflows | Bulk buffer overflows.
BulkBufferTransfers | Transfers of bulk buffers.
BulkRecordsStored | Bulk records stored.
ClientServiceRequests | Number of client service requests received by this client.
ClientServiceRequestsMissing | Number of client service requests missing on this client.
ClientStartupComplete | Site completed client sync-up.
CurrentElectionGenerationNumber | Current election gen number.
CurrentGenerationNumber | Current generation number.
CurrentQueuedLogRecords | Log records currently queued.
CurrentWinner | Current front-runner.
CurrentWinnerMaxLSN | Maximum LSN of current winner.
DuplicateLogRecords | Log records received multiply.
DuplicatePages | Pages received multiply.
DupMasters | Number of times a duplicate master condition was detected.
ElectionDataGeneration | Winner data generation.
ElectionGenerationNumber | Election generation number.
ElectionPriority | Current election priority.
Elections | Number of elections held.
ElectionStatus | Current election status.
ElectionsWon | Number of elections won by this site.
ElectionTiebreaker | Election tiebreaker value.
ElectionTimeSec | Last election time seconds.
ElectionTimeUSec | Last election time useconds.
EnvID | Current environment ID.
EnvPriority | Current environment priority.
FailedMessageSends | Number of failed message sends.
ForcedRerequests | Number of forced rerequests.
IgnoredMessages | Messages ignored because this site was a client in recovery.
LeaseCheckedMissesNumber | Number of invalid lease validity checks.
LeaseCheckedNumber | Number of lease validity checks.
LeaseCheckedRefreshNumber | Number of lease refresh attempts during lease validity checks.
LeaseSentNumber | Number of live messages sent while using leases.
MasterChanges | Number of times masters have switched.
MasterEnvID | Env. ID of the current master.
MaxLeaseSec | Maximum lease timestamp seconds.
MaxLeaseUSec | Maximum lease timestamp useconds.
MaxPermanentLSN | Maximum permanent LSN.
MaxQueuedLogRecords | Maximum log records queued at once.
MessagesSent | Number of successful message sends.
MissedLogRecords | Log records missed and requested.
MissedPages | Pages missed and requested.
NewSiteMessages | Number of NEWSITE messages received.
NextLSN | Next LSN to use or expect.
NextPage | Next page expected.
Outdated | Number of times an OUTDATED condition is detected and returned
QueuedLogRecords | Total number of log records ever queued.
ReceivedLogRecords | Log records received and put.
ReceivedMessages | Messages received and processed.
ReceivedPages | Pages received and stored.
RegisteredSites | Number of "registered voters".
RegisteredSitesNeeded | Number of "registered voters" needed.
Sites | Current number of sites assumed during elections.
StartSyncMessagesDelayed | Number of STARTSYNC msgs delayed.
Status | Current replication status.
Throttled | Number of throttled times.
View | True if the site is a view and false if not.
Votes | Votes received in this round.

See Also

ReplicationStats Class


ReplicationStats Methods

[image] [image]

Berkeley DB .NET API Documentation
ReplicationStats Methods
ReplicationStats Class See Also Send Feedback

The ReplicationStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

ReplicationStats Class


ReplicationStats Properties

[image] [image]

Berkeley DB .NET API Documentation
ReplicationStats Properties
ReplicationStats Class See Also Send Feedback

The ReplicationStats type exposes the following members.

Properties

Name | Description
AppliedTransactions | Number of transactions applied.
AwaitedLSN | Awaited LSN, if any.
AwaitedPage | Awaited Page, if any.
BadGenerationMessages | Messages with a bad generation number.
BulkBufferFills | Bulk buffer fills.
BulkBufferOverflows | Bulk buffer overflows.
BulkBufferTransfers | Transfers of bulk buffers.
BulkRecordsStored | Bulk records stored.
ClientServiceRequests | Number of client service requests received by this client.
ClientServiceRequestsMissing | Number of client service requests missing on this client.
ClientStartupComplete | Site completed client sync-up.
CurrentElectionGenerationNumber | Current election gen number.
CurrentGenerationNumber | Current generation number.
CurrentQueuedLogRecords | Log records currently queued.
CurrentWinner | Current front-runner.
CurrentWinnerMaxLSN | Maximum LSN of current winner.
DuplicateLogRecords | Log records received multiply.
DuplicatePages | Pages received multiply.
DupMasters | Number of times a duplicate master condition was detected.
ElectionDataGeneration | Winner data generation.
ElectionGenerationNumber | Election generation number.
ElectionPriority | Current election priority.
Elections | Number of elections held.
ElectionStatus | Current election status.
ElectionsWon | Number of elections won by this site.
ElectionTiebreaker | Election tiebreaker value.
ElectionTimeSec | Last election time seconds.
ElectionTimeUSec | Last election time useconds.
EnvID | Current environment ID.
EnvPriority | Current environment priority.
FailedMessageSends | Number of failed message sends.
ForcedRerequests | Number of forced rerequests.
IgnoredMessages | Messages ignored because this site was a client in recovery.
LeaseCheckedMissesNumber | Number of invalid lease validity checks.
LeaseCheckedNumber | Number of lease validity checks.
LeaseCheckedRefreshNumber | Number of lease refresh attempts during lease validity checks.
LeaseSentNumber | Number of live messages sent while using leases.
MasterChanges | Number of times masters have switched.
MasterEnvID | Env. ID of the current master.
MaxLeaseSec | Maximum lease timestamp seconds.
MaxLeaseUSec | Maximum lease timestamp useconds.
MaxPermanentLSN | Maximum permanent LSN.
MaxQueuedLogRecords | Maximum log records queued at once.
MessagesSent | Number of successful message sends.
MissedLogRecords | Log records missed and requested.
MissedPages | Pages missed and requested.
NewSiteMessages | Number of NEWSITE messages received.
NextLSN | Next LSN to use or expect.
NextPage | Next page expected.
Outdated | Number of times an OUTDATED condition is detected and returned
QueuedLogRecords | Total number of log records ever queued.
ReceivedLogRecords | Log records received and put.
ReceivedMessages | Messages received and processed.
ReceivedPages | Pages received and stored.
RegisteredSites | Number of "registered voters".
RegisteredSitesNeeded | Number of "registered voters" needed.
Sites | Current number of sites assumed during elections.
StartSyncMessagesDelayed | Number of STARTSYNC msgs delayed.
Status | Current replication status.
Throttled | Number of throttled times.
View | True if the site is a view and false if not.
Votes | Votes received in this round.

See Also

ReplicationStats Class


AppliedTransactions Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.AppliedTransactions Property
ReplicationStats Class See Also Send Feedback
Number of transactions applied.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong AppliedTransactions { get; }
Visual Basic (Declaration)
Public ReadOnly Property AppliedTransactions As ULong
Visual C++
public:
property unsigned long long AppliedTransactions {
    unsigned long long get ();
}

See Also

ReplicationStats Class


AwaitedLSN Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.AwaitedLSN Property
ReplicationStats Class See Also Send Feedback
Awaited LSN, if any.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN AwaitedLSN { get; }
Visual Basic (Declaration)
Public ReadOnly Property AwaitedLSN As LSN
Visual C++
public:
property LSN^ AwaitedLSN {
    LSN^ get ();
}

See Also

ReplicationStats Class


AwaitedPage Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.AwaitedPage Property
ReplicationStats Class See Also Send Feedback
Awaited Page, if any.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint AwaitedPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property AwaitedPage As UInteger
Visual C++
public:
property unsigned int AwaitedPage {
    unsigned int get ();
}

See Also

ReplicationStats Class


BadGenerationMessages Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.BadGenerationMessages Property
ReplicationStats Class See Also Send Feedback
Messages with a bad generation number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BadGenerationMessages { get; }
Visual Basic (Declaration)
Public ReadOnly Property BadGenerationMessages As ULong
Visual C++
public:
property unsigned long long BadGenerationMessages {
    unsigned long long get ();
}

See Also

ReplicationStats Class


BulkBufferFills Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.BulkBufferFills Property
ReplicationStats Class See Also Send Feedback
Bulk buffer fills.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BulkBufferFills { get; }
Visual Basic (Declaration)
Public ReadOnly Property BulkBufferFills As ULong
Visual C++
public:
property unsigned long long BulkBufferFills {
    unsigned long long get ();
}

See Also

ReplicationStats Class


BulkBufferOverflows Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.BulkBufferOverflows Property
ReplicationStats Class See Also Send Feedback
Bulk buffer overflows.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BulkBufferOverflows { get; }
Visual Basic (Declaration)
Public ReadOnly Property BulkBufferOverflows As ULong
Visual C++
public:
property unsigned long long BulkBufferOverflows {
    unsigned long long get ();
}

See Also

ReplicationStats Class


BulkBufferTransfers Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.BulkBufferTransfers Property
ReplicationStats Class See Also Send Feedback
Transfers of bulk buffers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BulkBufferTransfers { get; }
Visual Basic (Declaration)
Public ReadOnly Property BulkBufferTransfers As ULong
Visual C++
public:
property unsigned long long BulkBufferTransfers {
    unsigned long long get ();
}

See Also

ReplicationStats Class


BulkRecordsStored Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.BulkRecordsStored Property
ReplicationStats Class See Also Send Feedback
Bulk records stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong BulkRecordsStored { get; }
Visual Basic (Declaration)
Public ReadOnly Property BulkRecordsStored As ULong
Visual C++
public:
property unsigned long long BulkRecordsStored {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ClientServiceRequests Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ClientServiceRequests Property
ReplicationStats Class See Also Send Feedback
Number of client service requests received by this client.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ClientServiceRequests { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientServiceRequests As ULong
Visual C++
public:
property unsigned long long ClientServiceRequests {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ClientServiceRequestsMissing Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ClientServiceRequestsMissing Property
ReplicationStats Class See Also Send Feedback
Number of client service requests missing on this client.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ClientServiceRequestsMissing { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientServiceRequestsMissing As ULong
Visual C++
public:
property unsigned long long ClientServiceRequestsMissing {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ClientStartupComplete Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ClientStartupComplete Property
ReplicationStats Class See Also Send Feedback
Site completed client sync-up.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ClientStartupComplete { get; }
Visual Basic (Declaration)
Public ReadOnly Property ClientStartupComplete As Boolean
Visual C++
public:
property bool ClientStartupComplete {
    bool get ();
}

See Also

ReplicationStats Class


CurrentElectionGenerationNumber Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.CurrentElectionGenerationNumber Property
ReplicationStats Class See Also Send Feedback
Current election gen number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CurrentElectionGenerationNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentElectionGenerationNumber As UInteger
Visual C++
public:
property unsigned int CurrentElectionGenerationNumber {
    unsigned int get ();
}

See Also

ReplicationStats Class


CurrentGenerationNumber Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.CurrentGenerationNumber Property
ReplicationStats Class See Also Send Feedback
Current generation number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CurrentGenerationNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentGenerationNumber As UInteger
Visual C++
public:
property unsigned int CurrentGenerationNumber {
    unsigned int get ();
}

See Also

ReplicationStats Class


CurrentQueuedLogRecords Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.CurrentQueuedLogRecords Property
ReplicationStats Class See Also Send Feedback
Log records currently queued.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong CurrentQueuedLogRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentQueuedLogRecords As ULong
Visual C++
public:
property unsigned long long CurrentQueuedLogRecords {
    unsigned long long get ();
}

See Also

ReplicationStats Class


CurrentWinner Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.CurrentWinner Property
ReplicationStats Class See Also Send Feedback
Current front-runner.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long CurrentWinner { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentWinner As Long
Visual C++
public:
property long long CurrentWinner {
    long long get ();
}

See Also

ReplicationStats Class


CurrentWinnerMaxLSN Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.CurrentWinnerMaxLSN Property
ReplicationStats Class See Also Send Feedback
Maximum LSN of current winner.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN CurrentWinnerMaxLSN { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentWinnerMaxLSN As LSN
Visual C++
public:
property LSN^ CurrentWinnerMaxLSN {
    LSN^ get ();
}

See Also

ReplicationStats Class


DuplicateLogRecords Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.DuplicateLogRecords Property
ReplicationStats Class See Also Send Feedback
Log records received multiply.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong DuplicateLogRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuplicateLogRecords As ULong
Visual C++
public:
property unsigned long long DuplicateLogRecords {
    unsigned long long get ();
}

See Also

ReplicationStats Class


DuplicatePages Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.DuplicatePages Property
ReplicationStats Class See Also Send Feedback
Pages received multiply.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong DuplicatePages { get; }
Visual Basic (Declaration)
Public ReadOnly Property DuplicatePages As ULong
Visual C++
public:
property unsigned long long DuplicatePages {
    unsigned long long get ();
}

See Also

ReplicationStats Class


DupMasters Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.DupMasters Property
ReplicationStats Class See Also Send Feedback
Number of times a duplicate master condition was detected.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint DupMasters { get; }
Visual Basic (Declaration)
Public ReadOnly Property DupMasters As UInteger
Visual C++
public:
property unsigned int DupMasters {
    unsigned int get ();
}

See Also

ReplicationStats Class


ElectionDataGeneration Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ElectionDataGeneration Property
ReplicationStats Class See Also Send Feedback
Winner data generation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionDataGeneration { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionDataGeneration As UInteger
Visual C++
public:
property unsigned int ElectionDataGeneration {
    unsigned int get ();
}

See Also

ReplicationStats Class


ElectionGenerationNumber Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ElectionGenerationNumber Property
ReplicationStats Class See Also Send Feedback
Election generation number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionGenerationNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionGenerationNumber As UInteger
Visual C++
public:
property unsigned int ElectionGenerationNumber {
    unsigned int get ();
}

See Also

ReplicationStats Class


ElectionPriority Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ElectionPriority Property
ReplicationStats Class See Also Send Feedback
Current election priority.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionPriority { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionPriority As UInteger
Visual C++
public:
property unsigned int ElectionPriority {
    unsigned int get ();
}

See Also

ReplicationStats Class


Elections Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.Elections Property
ReplicationStats Class See Also Send Feedback
Number of elections held.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Elections { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elections As ULong
Visual C++
public:
property unsigned long long Elections {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ElectionStatus Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ElectionStatus Property
ReplicationStats Class See Also Send Feedback
Current election status.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int ElectionStatus { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionStatus As Integer
Visual C++
public:
property int ElectionStatus {
    int get ();
}

See Also

ReplicationStats Class


ElectionsWon Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ElectionsWon Property
ReplicationStats Class See Also Send Feedback
Number of elections won by this site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ElectionsWon { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionsWon As ULong
Visual C++
public:
property unsigned long long ElectionsWon {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ElectionTiebreaker Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ElectionTiebreaker Property
ReplicationStats Class See Also Send Feedback
Election tiebreaker value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionTiebreaker { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionTiebreaker As UInteger
Visual C++
public:
property unsigned int ElectionTiebreaker {
    unsigned int get ();
}

See Also

ReplicationStats Class


ElectionTimeSec Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ElectionTimeSec Property
ReplicationStats Class See Also Send Feedback
Last election time seconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionTimeSec { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionTimeSec As UInteger
Visual C++
public:
property unsigned int ElectionTimeSec {
    unsigned int get ();
}

See Also

ReplicationStats Class


ElectionTimeUSec Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ElectionTimeUSec Property
ReplicationStats Class See Also Send Feedback
Last election time useconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionTimeUSec { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionTimeUSec As UInteger
Visual C++
public:
property unsigned int ElectionTimeUSec {
    unsigned int get ();
}

See Also

ReplicationStats Class


EnvID Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.EnvID Property
ReplicationStats Class See Also Send Feedback
Current environment ID.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long EnvID { get; }
Visual Basic (Declaration)
Public ReadOnly Property EnvID As Long
Visual C++
public:
property long long EnvID {
    long long get ();
}

See Also

ReplicationStats Class


EnvPriority Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.EnvPriority Property
ReplicationStats Class See Also Send Feedback
Current environment priority.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint EnvPriority { get; }
Visual Basic (Declaration)
Public ReadOnly Property EnvPriority As UInteger
Visual C++
public:
property unsigned int EnvPriority {
    unsigned int get ();
}

See Also

ReplicationStats Class


FailedMessageSends Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.FailedMessageSends Property
ReplicationStats Class See Also Send Feedback
Number of failed message sends.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong FailedMessageSends { get; }
Visual Basic (Declaration)
Public ReadOnly Property FailedMessageSends As ULong
Visual C++
public:
property unsigned long long FailedMessageSends {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ForcedRerequests Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ForcedRerequests Property
ReplicationStats Class See Also Send Feedback
Number of forced rerequests.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ForcedRerequests { get; }
Visual Basic (Declaration)
Public ReadOnly Property ForcedRerequests As ULong
Visual C++
public:
property unsigned long long ForcedRerequests {
    unsigned long long get ();
}

See Also

ReplicationStats Class


IgnoredMessages Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.IgnoredMessages Property
ReplicationStats Class See Also Send Feedback
Messages ignored because this site was a client in recovery.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong IgnoredMessages { get; }
Visual Basic (Declaration)
Public ReadOnly Property IgnoredMessages As ULong
Visual C++
public:
property unsigned long long IgnoredMessages {
    unsigned long long get ();
}

See Also

ReplicationStats Class


LeaseCheckedMissesNumber Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.LeaseCheckedMissesNumber Property
ReplicationStats Class See Also Send Feedback
Number of invalid lease validity checks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LeaseCheckedMissesNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeaseCheckedMissesNumber As ULong
Visual C++
public:
property unsigned long long LeaseCheckedMissesNumber {
    unsigned long long get ();
}

See Also

ReplicationStats Class


LeaseCheckedNumber Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.LeaseCheckedNumber Property
ReplicationStats Class See Also Send Feedback
Number of lease validity checks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LeaseCheckedNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeaseCheckedNumber As ULong
Visual C++
public:
property unsigned long long LeaseCheckedNumber {
    unsigned long long get ();
}

See Also

ReplicationStats Class


LeaseCheckedRefreshNumber Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.LeaseCheckedRefreshNumber Property
ReplicationStats Class See Also Send Feedback
Number of lease refresh attempts during lease validity checks.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LeaseCheckedRefreshNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeaseCheckedRefreshNumber As ULong
Visual C++
public:
property unsigned long long LeaseCheckedRefreshNumber {
    unsigned long long get ();
}

See Also

ReplicationStats Class


LeaseSentNumber Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.LeaseSentNumber Property
ReplicationStats Class See Also Send Feedback
Number of live messages sent while using leases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LeaseSentNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property LeaseSentNumber As ULong
Visual C++
public:
property unsigned long long LeaseSentNumber {
    unsigned long long get ();
}

See Also

ReplicationStats Class


MasterChanges Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MasterChanges Property
ReplicationStats Class See Also Send Feedback
Number of times masters have switched.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MasterChanges { get; }
Visual Basic (Declaration)
Public ReadOnly Property MasterChanges As ULong
Visual C++
public:
property unsigned long long MasterChanges {
    unsigned long long get ();
}

See Also

ReplicationStats Class


MasterEnvID Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MasterEnvID Property
ReplicationStats Class See Also Send Feedback
Env. ID of the current master.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long MasterEnvID { get; }
Visual Basic (Declaration)
Public ReadOnly Property MasterEnvID As Long
Visual C++
public:
property long long MasterEnvID {
    long long get ();
}

See Also

ReplicationStats Class


MaxLeaseSec Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MaxLeaseSec Property
ReplicationStats Class See Also Send Feedback
Maximum lease timestamp seconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLeaseSec { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxLeaseSec As UInteger
Visual C++
public:
property unsigned int MaxLeaseSec {
    unsigned int get ();
}

See Also

ReplicationStats Class


MaxLeaseUSec Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MaxLeaseUSec Property
ReplicationStats Class See Also Send Feedback
Maximum lease timestamp useconds.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxLeaseUSec { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxLeaseUSec As UInteger
Visual C++
public:
property unsigned int MaxLeaseUSec {
    unsigned int get ();
}

See Also

ReplicationStats Class


MaxPermanentLSN Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MaxPermanentLSN Property
ReplicationStats Class See Also Send Feedback
Maximum permanent LSN.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN MaxPermanentLSN { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxPermanentLSN As LSN
Visual C++
public:
property LSN^ MaxPermanentLSN {
    LSN^ get ();
}

See Also

ReplicationStats Class


MaxQueuedLogRecords Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MaxQueuedLogRecords Property
ReplicationStats Class See Also Send Feedback
Maximum log records queued at once.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MaxQueuedLogRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxQueuedLogRecords As ULong
Visual C++
public:
property unsigned long long MaxQueuedLogRecords {
    unsigned long long get ();
}

See Also

ReplicationStats Class


MessagesSent Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MessagesSent Property
ReplicationStats Class See Also Send Feedback
Number of successful message sends.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MessagesSent { get; }
Visual Basic (Declaration)
Public ReadOnly Property MessagesSent As ULong
Visual C++
public:
property unsigned long long MessagesSent {
    unsigned long long get ();
}

See Also

ReplicationStats Class


MissedLogRecords Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MissedLogRecords Property
ReplicationStats Class See Also Send Feedback
Log records missed and requested.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MissedLogRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property MissedLogRecords As ULong
Visual C++
public:
property unsigned long long MissedLogRecords {
    unsigned long long get ();
}

See Also

ReplicationStats Class


MissedPages Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.MissedPages Property
ReplicationStats Class See Also Send Feedback
Pages missed and requested.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong MissedPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property MissedPages As ULong
Visual C++
public:
property unsigned long long MissedPages {
    unsigned long long get ();
}

See Also

ReplicationStats Class


NewSiteMessages Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.NewSiteMessages Property
ReplicationStats Class See Also Send Feedback
Number of NEWSITE messages received.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong NewSiteMessages { get; }
Visual Basic (Declaration)
Public ReadOnly Property NewSiteMessages As ULong
Visual C++
public:
property unsigned long long NewSiteMessages {
    unsigned long long get ();
}

See Also

ReplicationStats Class


NextLSN Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.NextLSN Property
ReplicationStats Class See Also Send Feedback
Next LSN to use or expect.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN NextLSN { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextLSN As LSN
Visual C++
public:
property LSN^ NextLSN {
    LSN^ get ();
}

See Also

ReplicationStats Class


NextPage Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.NextPage Property
ReplicationStats Class See Also Send Feedback
Next page expected.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint NextPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextPage As UInteger
Visual C++
public:
property unsigned int NextPage {
    unsigned int get ();
}

See Also

ReplicationStats Class


Outdated Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.Outdated Property
ReplicationStats Class See Also Send Feedback
Number of times an OUTDATED condition is detected and returned

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Outdated { get; }
Visual Basic (Declaration)
Public ReadOnly Property Outdated As ULong
Visual C++
public:
property unsigned long long Outdated {
    unsigned long long get ();
}

See Also

ReplicationStats Class


QueuedLogRecords Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.QueuedLogRecords Property
ReplicationStats Class See Also Send Feedback
Total number of log records ever queued.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong QueuedLogRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property QueuedLogRecords As ULong
Visual C++
public:
property unsigned long long QueuedLogRecords {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ReceivedLogRecords Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ReceivedLogRecords Property
ReplicationStats Class See Also Send Feedback
Log records received and put.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ReceivedLogRecords { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReceivedLogRecords As ULong
Visual C++
public:
property unsigned long long ReceivedLogRecords {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ReceivedMessages Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ReceivedMessages Property
ReplicationStats Class See Also Send Feedback
Messages received and processed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ReceivedMessages { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReceivedMessages As ULong
Visual C++
public:
property unsigned long long ReceivedMessages {
    unsigned long long get ();
}

See Also

ReplicationStats Class


ReceivedPages Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.ReceivedPages Property
ReplicationStats Class See Also Send Feedback
Pages received and stored.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong ReceivedPages { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReceivedPages As ULong
Visual C++
public:
property unsigned long long ReceivedPages {
    unsigned long long get ();
}

See Also

ReplicationStats Class


RegisteredSites Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.RegisteredSites Property
ReplicationStats Class See Also Send Feedback
Number of "registered voters".

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RegisteredSites { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegisteredSites As UInteger
Visual C++
public:
property unsigned int RegisteredSites {
    unsigned int get ();
}

See Also

ReplicationStats Class


RegisteredSitesNeeded Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.RegisteredSitesNeeded Property
ReplicationStats Class See Also Send Feedback
Number of "registered voters" needed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint RegisteredSitesNeeded { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegisteredSitesNeeded As UInteger
Visual C++
public:
property unsigned int RegisteredSitesNeeded {
    unsigned int get ();
}

See Also

ReplicationStats Class


Sites Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.Sites Property
ReplicationStats Class See Also Send Feedback
Current number of sites assumed during elections.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Sites { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sites As UInteger
Visual C++
public:
property unsigned int Sites {
    unsigned int get ();
}

See Also

ReplicationStats Class


StartSyncMessagesDelayed Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.StartSyncMessagesDelayed Property
ReplicationStats Class See Also Send Feedback
Number of STARTSYNC msgs delayed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong StartSyncMessagesDelayed { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartSyncMessagesDelayed As ULong
Visual C++
public:
property unsigned long long StartSyncMessagesDelayed {
    unsigned long long get ();
}

See Also

ReplicationStats Class


Status Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.Status Property
ReplicationStats Class See Also Send Feedback
Current replication status.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Status { get; }
Visual Basic (Declaration)
Public ReadOnly Property Status As UInteger
Visual C++
public:
property unsigned int Status {
    unsigned int get ();
}

See Also

ReplicationStats Class


Throttled Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.Throttled Property
ReplicationStats Class See Also Send Feedback
Number of throttled times.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Throttled { get; }
Visual Basic (Declaration)
Public ReadOnly Property Throttled As ULong
Visual C++
public:
property unsigned long long Throttled {
    unsigned long long get ();
}

See Also

ReplicationStats Class


View Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.View Property
ReplicationStats Class See Also Send Feedback
True if the site is a view and false if not.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool View { get; }
Visual Basic (Declaration)
Public ReadOnly Property View As Boolean
Visual C++
public:
property bool View {
    bool get ();
}

See Also

ReplicationStats Class


Votes Property

[image]

Berkeley DB .NET API Documentation
ReplicationStats..::.Votes Property
ReplicationStats Class See Also Send Feedback
Votes received in this round.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Votes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Votes As UInteger
Visual C++
public:
property unsigned int Votes {
    unsigned int get ();
}

See Also

ReplicationStats Class


ReplicationTransportDelegate Delegate

[image]

Berkeley DB .NET API Documentation
ReplicationTransportDelegate Delegate
See Also Send Feedback
The function used to transmit data using the replication application's communication infrastructure.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate int ReplicationTransportDelegate(
    DatabaseEntry control,
    DatabaseEntry rec,
    LSN lsn,
    int envid,
    uint flags
)
Visual Basic (Declaration)
Public Delegate Function ReplicationTransportDelegate ( _
    control As DatabaseEntry, _
    rec As DatabaseEntry, _
    lsn As LSN, _
    envid As Integer, _
    flags As UInteger _
) As Integer
Visual C++
public delegate int ReplicationTransportDelegate(
    DatabaseEntry^ control,
    DatabaseEntry^ rec,
    LSN^ lsn,
    int envid,
    unsigned int flags
)

Parameters

control
Type: BerkeleyDB..::.DatabaseEntry
The first of the two data elements to be transmitted by the send function.
rec
Type: BerkeleyDB..::.DatabaseEntry
The second of the two data elements to be transmitted by the send function.
lsn
Type: BerkeleyDB..::.LSN
If the type of message to be sent has an LSN associated with it, then this is the LSN of the record being sent. This LSN can be used to determine that certain records have been processed successfully by clients.
envid
Type: System..::.Int32

A positive integer identifier that specifies the replication environment to which the message should be sent.

The special identifier EID_BROADCAST indicates that a message should be broadcast to every environment in the replication group. The application may use a true broadcast protocol or may send the message in sequence to each machine with which it is in communication. In both cases, the sending site should not be asked to process the message.

The special identifier EID_INVALID indicates an invalid environment ID. This may be used to initialize values that are subsequently checked for validity.

flags
Type: System..::.UInt32
XXX: TBD

Return Value

0 on success and non-zero on failure

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


ReplicationViewDelegate Delegate

[image]

Berkeley DB .NET API Documentation
ReplicationViewDelegate Delegate
See Also Send Feedback
Application-specific function used by a replication view to determine whether a database file is replicated to the local site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate int ReplicationViewDelegate(
    string name,
    ref int result,
    uint flags
)
Visual Basic (Declaration)
Public Delegate Function ReplicationViewDelegate ( _
    name As String, _
    ByRef result As Integer, _
    flags As UInteger _
) As Integer
Visual C++
public delegate int ReplicationViewDelegate(
    String^ name,
    int% result,
    unsigned int flags
)

Parameters

name
Type: System..::.String
The name of the database file.
result
Type: System..::.Int32 %
Indicates whether or not the database file should be replicated. If non-zero, the database file is replicated; otherwise the database file is not replicated.
flags
Type: System..::.UInt32
Currently unused.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


RepMgrSite Class

[image]

Berkeley DB .NET API Documentation
RepMgrSite Class
Members See Also Send Feedback
A class representing a replication site used by Replication Manager.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class RepMgrSite
Visual Basic (Declaration)
Public Class RepMgrSite
Visual C++
public ref class RepMgrSite

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.RepMgrSite

See Also

RepMgrSite Members


RepMgrSite Members

[image] [image]

Berkeley DB .NET API Documentation
RepMgrSite Members
RepMgrSite Class Methods Fields See Also Send Feedback

The RepMgrSite type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Address | The address of the site.
EId | Environment ID assigned by the replication manager. This is the same value that is passed to EventNotify for the REP_NEWMASTER event.
isConnected | If true, the site is connected.
isPeer | If true, the site is client-to-client peer.
isView | If true, the site is a view site.

See Also

RepMgrSite Class


RepMgrSite Fields

[image] [image]

Berkeley DB .NET API Documentation
RepMgrSite Fields
RepMgrSite Class See Also Send Feedback

The RepMgrSite type exposes the following members.

Fields

Name | Description
Address | The address of the site.
EId | Environment ID assigned by the replication manager. This is the same value that is passed to EventNotify for the REP_NEWMASTER event.
isConnected | If true, the site is connected.
isPeer | If true, the site is client-to-client peer.
isView | If true, the site is a view site.

See Also

RepMgrSite Class


Address Field

[image]

Berkeley DB .NET API Documentation
RepMgrSite..::.Address Field
RepMgrSite Class See Also Send Feedback
The address of the site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ReplicationHostAddress Address
Visual Basic (Declaration)
Public Address As ReplicationHostAddress
Visual C++
public:
ReplicationHostAddress^ Address

See Also

RepMgrSite Class


EId Field

[image]

Berkeley DB .NET API Documentation
RepMgrSite..::.EId Field
RepMgrSite Class See Also Send Feedback
Environment ID assigned by the replication manager. This is the same value that is passed to EventNotify for the REP_NEWMASTER event.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int EId
Visual Basic (Declaration)
Public EId As Integer
Visual C++
public:
int EId

See Also

RepMgrSite Class


isConnected Field

[image]

Berkeley DB .NET API Documentation
RepMgrSite..::.isConnected Field
RepMgrSite Class See Also Send Feedback
If true, the site is connected.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool isConnected
Visual Basic (Declaration)
Public isConnected As Boolean
Visual C++
public:
bool isConnected

See Also

RepMgrSite Class


isPeer Field

[image]

Berkeley DB .NET API Documentation
RepMgrSite..::.isPeer Field
RepMgrSite Class See Also Send Feedback
If true, the site is client-to-client peer.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool isPeer
Visual Basic (Declaration)
Public isPeer As Boolean
Visual C++
public:
bool isPeer

See Also

RepMgrSite Class


isView Field

[image]

Berkeley DB .NET API Documentation
RepMgrSite..::.isView Field
RepMgrSite Class See Also Send Feedback
If true, the site is a view site.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool isView
Visual Basic (Declaration)
Public isView As Boolean
Visual C++
public:
bool isView

See Also

RepMgrSite Class


RepMgrSite Methods

[image] [image]

Berkeley DB .NET API Documentation
RepMgrSite Methods
RepMgrSite Class See Also Send Feedback

The RepMgrSite type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RepMgrSite Class


RepMgrStats Class

[image]

Berkeley DB .NET API Documentation
RepMgrStats Class
Members See Also Send Feedback
Statistical information about the Replication Manager

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class RepMgrStats
Visual Basic (Declaration)
Public Class RepMgrStats
Visual C++
public ref class RepMgrStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.RepMgrStats

See Also

RepMgrStats Members


RepMgrStats Members

[image] [image]

Berkeley DB .NET API Documentation
RepMgrStats Members
RepMgrStats Class Methods Properties See Also Send Feedback

The RepMgrStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
AutoTakeovers | Number of automatic replication process takeovers.
DroppedConnections | Existing connections dropped.
DroppedMessages | Number of messages discarded due to excessive queue length.
ElectionThreads | Number of currently active election threads
FailedConnections | Failed new connection attempts.
FailedMessages | Number of insufficiently acknowledged messages.
IncomingDroppedMessages | Number of msgs discarded due to incoming queue full.
IncomingQueueBytes | Incoming queue size: Gytes.
IncomingQueueGBytes | Incoming queue size: Gigabytes.
MaxElectionThreads | Election threads for which space is reserved
ParticipantSites | Number of replication group participant sites.
QueuedMessages | Number of messages queued for network delay.
TotalSites | Total number of replication group sites.
ViewSites | Number of replication group view sites.

See Also

RepMgrStats Class


RepMgrStats Methods

[image] [image]

Berkeley DB .NET API Documentation
RepMgrStats Methods
RepMgrStats Class See Also Send Feedback

The RepMgrStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RepMgrStats Class


RepMgrStats Properties

[image] [image]

Berkeley DB .NET API Documentation
RepMgrStats Properties
RepMgrStats Class See Also Send Feedback

The RepMgrStats type exposes the following members.

Properties

Name | Description
AutoTakeovers | Number of automatic replication process takeovers.
DroppedConnections | Existing connections dropped.
DroppedMessages | Number of messages discarded due to excessive queue length.
ElectionThreads | Number of currently active election threads
FailedConnections | Failed new connection attempts.
FailedMessages | Number of insufficiently acknowledged messages.
IncomingDroppedMessages | Number of msgs discarded due to incoming queue full.
IncomingQueueBytes | Incoming queue size: Gytes.
IncomingQueueGBytes | Incoming queue size: Gigabytes.
MaxElectionThreads | Election threads for which space is reserved
ParticipantSites | Number of replication group participant sites.
QueuedMessages | Number of messages queued for network delay.
TotalSites | Total number of replication group sites.
ViewSites | Number of replication group view sites.

See Also

RepMgrStats Class


AutoTakeovers Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.AutoTakeovers Property
RepMgrStats Class See Also Send Feedback
Number of automatic replication process takeovers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong AutoTakeovers { get; }
Visual Basic (Declaration)
Public ReadOnly Property AutoTakeovers As ULong
Visual C++
public:
property unsigned long long AutoTakeovers {
    unsigned long long get ();
}

See Also

RepMgrStats Class


DroppedConnections Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.DroppedConnections Property
RepMgrStats Class See Also Send Feedback
Existing connections dropped.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong DroppedConnections { get; }
Visual Basic (Declaration)
Public ReadOnly Property DroppedConnections As ULong
Visual C++
public:
property unsigned long long DroppedConnections {
    unsigned long long get ();
}

See Also

RepMgrStats Class


DroppedMessages Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.DroppedMessages Property
RepMgrStats Class See Also Send Feedback
Number of messages discarded due to excessive queue length.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong DroppedMessages { get; }
Visual Basic (Declaration)
Public ReadOnly Property DroppedMessages As ULong
Visual C++
public:
property unsigned long long DroppedMessages {
    unsigned long long get ();
}

See Also

RepMgrStats Class


ElectionThreads Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.ElectionThreads Property
RepMgrStats Class See Also Send Feedback
Number of currently active election threads

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ElectionThreads { get; }
Visual Basic (Declaration)
Public ReadOnly Property ElectionThreads As UInteger
Visual C++
public:
property unsigned int ElectionThreads {
    unsigned int get ();
}

See Also

RepMgrStats Class


FailedConnections Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.FailedConnections Property
RepMgrStats Class See Also Send Feedback
Failed new connection attempts.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong FailedConnections { get; }
Visual Basic (Declaration)
Public ReadOnly Property FailedConnections As ULong
Visual C++
public:
property unsigned long long FailedConnections {
    unsigned long long get ();
}

See Also

RepMgrStats Class


FailedMessages Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.FailedMessages Property
RepMgrStats Class See Also Send Feedback
Number of insufficiently acknowledged messages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong FailedMessages { get; }
Visual Basic (Declaration)
Public ReadOnly Property FailedMessages As ULong
Visual C++
public:
property unsigned long long FailedMessages {
    unsigned long long get ();
}

See Also

RepMgrStats Class


IncomingDroppedMessages Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.IncomingDroppedMessages Property
RepMgrStats Class See Also Send Feedback
Number of msgs discarded due to incoming queue full.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong IncomingDroppedMessages { get; }
Visual Basic (Declaration)
Public ReadOnly Property IncomingDroppedMessages As ULong
Visual C++
public:
property unsigned long long IncomingDroppedMessages {
    unsigned long long get ();
}

See Also

RepMgrStats Class


IncomingQueueBytes Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.IncomingQueueBytes Property
RepMgrStats Class See Also Send Feedback
Incoming queue size: Gytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong IncomingQueueBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property IncomingQueueBytes As ULong
Visual C++
public:
property unsigned long long IncomingQueueBytes {
    unsigned long long get ();
}

See Also

RepMgrStats Class


IncomingQueueGBytes Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.IncomingQueueGBytes Property
RepMgrStats Class See Also Send Feedback
Incoming queue size: Gigabytes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong IncomingQueueGBytes { get; }
Visual Basic (Declaration)
Public ReadOnly Property IncomingQueueGBytes As ULong
Visual C++
public:
property unsigned long long IncomingQueueGBytes {
    unsigned long long get ();
}

See Also

RepMgrStats Class


MaxElectionThreads Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.MaxElectionThreads Property
RepMgrStats Class See Also Send Feedback
Election threads for which space is reserved

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxElectionThreads { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxElectionThreads As UInteger
Visual C++
public:
property unsigned int MaxElectionThreads {
    unsigned int get ();
}

See Also

RepMgrStats Class


ParticipantSites Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.ParticipantSites Property
RepMgrStats Class See Also Send Feedback
Number of replication group participant sites.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ParticipantSites { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParticipantSites As UInteger
Visual C++
public:
property unsigned int ParticipantSites {
    unsigned int get ();
}

See Also

RepMgrStats Class


QueuedMessages Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.QueuedMessages Property
RepMgrStats Class See Also Send Feedback
Number of messages queued for network delay.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong QueuedMessages { get; }
Visual Basic (Declaration)
Public ReadOnly Property QueuedMessages As ULong
Visual C++
public:
property unsigned long long QueuedMessages {
    unsigned long long get ();
}

See Also

RepMgrStats Class


TotalSites Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.TotalSites Property
RepMgrStats Class See Also Send Feedback
Total number of replication group sites.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TotalSites { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalSites As UInteger
Visual C++
public:
property unsigned int TotalSites {
    unsigned int get ();
}

See Also

RepMgrStats Class


ViewSites Property

[image]

Berkeley DB .NET API Documentation
RepMgrStats..::.ViewSites Property
RepMgrStats Class See Also Send Feedback
Number of replication group view sites.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ViewSites { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewSites As UInteger
Visual C++
public:
property unsigned int ViewSites {
    unsigned int get ();
}

See Also

RepMgrStats Class


RepProcMsgResult Class

[image]

Berkeley DB .NET API Documentation
RepProcMsgResult Class
Members See Also Send Feedback
A class representing the return value of RepProcessMessage(DatabaseEntry, DatabaseEntry, Int32).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class RepProcMsgResult
Visual Basic (Declaration)
Public Class RepProcMsgResult
Visual C++
public ref class RepProcMsgResult

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.RepProcMsgResult

See Also

RepProcMsgResult Members


RepProcMsgResult Members

[image] [image]

Berkeley DB .NET API Documentation
RepProcMsgResult Members
RepProcMsgResult Class Methods Fields See Also Send Feedback

The RepProcMsgResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Result | The result of processing an incoming replication message.
RetLsn | The log sequence number of the permanent log message that could not be written to disk if Result is NOT_PERMANENT. The largest log sequence number of the permanent records that are now written to disk as a result of processing the message, if Result is IS_PERMANENT. In all other cases the value is undefined.

See Also

RepProcMsgResult Class


RepProcMsgResult Fields

[image] [image]

Berkeley DB .NET API Documentation
RepProcMsgResult Fields
RepProcMsgResult Class See Also Send Feedback

The RepProcMsgResult type exposes the following members.

Fields

Name | Description
Result | The result of processing an incoming replication message.
RetLsn | The log sequence number of the permanent log message that could not be written to disk if Result is NOT_PERMANENT. The largest log sequence number of the permanent records that are now written to disk as a result of processing the message, if Result is IS_PERMANENT. In all other cases the value is undefined.

See Also

RepProcMsgResult Class


Result Field

[image]

Berkeley DB .NET API Documentation
RepProcMsgResult..::.Result Field
RepProcMsgResult Class See Also Send Feedback
The result of processing an incoming replication message.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RepProcMsgResult..::.ProcMsgResult Result
Visual Basic (Declaration)
Public Result As RepProcMsgResult..::.ProcMsgResult
Visual C++
public:
RepProcMsgResult..::.ProcMsgResult Result

See Also

RepProcMsgResult Class


RetLsn Field

[image]

Berkeley DB .NET API Documentation
RepProcMsgResult..::.RetLsn Field
RepProcMsgResult Class See Also Send Feedback
The log sequence number of the permanent log message that could not be written to disk if Result is NOT_PERMANENT. The largest log sequence number of the permanent records that are now written to disk as a result of processing the message, if Result is IS_PERMANENT. In all other cases the value is undefined.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN RetLsn
Visual Basic (Declaration)
Public RetLsn As LSN
Visual C++
public:
LSN^ RetLsn

See Also

RepProcMsgResult Class


RepProcMsgResult Methods

[image] [image]

Berkeley DB .NET API Documentation
RepProcMsgResult Methods
RepProcMsgResult Class See Also Send Feedback

The RepProcMsgResult type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

RepProcMsgResult Class


RepProcMsgResult.ProcMsgResult Enumeration

[image]

Berkeley DB .NET API Documentation
RepProcMsgResult..::.ProcMsgResult Enumeration
RepProcMsgResult Class See Also Send Feedback
The result of processing an incoming replication message.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum ProcMsgResult
Visual Basic (Declaration)
Public Enumeration ProcMsgResult
Visual C++
public enum class ProcMsgResult

Members

Member name | Description
DUPLICATE_MASTER | The replication group has more than one master.
ERROR | An unspecified error occurred.
HOLD_ELECTION | An election is needed.
IGNORED | A message cannot be processed.
IS_PERMANENT | Processing a message resulted in the processing of records that are permanent.
JOIN_FAILURE | A new master has been chosen but the client is unable to synchronize with the new master.
NEW_SITE | The system received contact information from a new environment.
NOT_PERMANENT | A message carrying a DB_REP_PERMANENT flag was processed successfully, but was not written to disk.
SUCCESS | Processing a message succeded.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


RunRecoveryException Class

[image]

Berkeley DB .NET API Documentation
RunRecoveryException Class
Members See Also Send Feedback
Berkeley DB has encountered an error it considers fatal to an entire environment. Once a RunRecoveryException has been thrown by any interface, it is returned from all subsequent Berkeley DB calls made by any threads of control participating in the environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class RunRecoveryException : DatabaseException
Visual Basic (Declaration)
Public Class RunRecoveryException _
    Inherits DatabaseException
Visual C++
public ref class RunRecoveryException : public DatabaseException

Remarks

An example of this type of fatal error is a corrupted database page. The only way to recover from this type of error is to have all threads of control exit the Berkeley DB environment, run recovery of the environment, and re-enter Berkeley DB. (It is not strictly necessary that the processes exit, although that is the only way to recover system resources, such as file descriptors and memory, allocated by Berkeley DB.)

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.RunRecoveryException

See Also

RunRecoveryException Members


RunRecoveryException Members

[image] [image]

Berkeley DB .NET API Documentation
RunRecoveryException Members
RunRecoveryException Class Constructors Methods Fields Properties See Also Send Feedback

The RunRecoveryException type exposes the following members.

Constructors

Name | Description
RunRecoveryException | Initialize a new instance of the RunRecoveryException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RunRecoveryException Class


RunRecoveryException Constructor

[image]

Berkeley DB .NET API Documentation
RunRecoveryException Constructor
RunRecoveryException Class See Also Send Feedback
Initialize a new instance of the RunRecoveryException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public RunRecoveryException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RunRecoveryException()

See Also

RunRecoveryException Class


RunRecoveryException Fields

[image] [image]

Berkeley DB .NET API Documentation
RunRecoveryException Fields
RunRecoveryException Class See Also Send Feedback

The RunRecoveryException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

RunRecoveryException Class


RunRecoveryException Methods

[image] [image]

Berkeley DB .NET API Documentation
RunRecoveryException Methods
RunRecoveryException Class See Also Send Feedback

The RunRecoveryException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RunRecoveryException Class


RunRecoveryException Properties

[image] [image]

Berkeley DB .NET API Documentation
RunRecoveryException Properties
RunRecoveryException Class See Also Send Feedback

The RunRecoveryException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RunRecoveryException Class


SecondaryBTreeDatabase Class

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase Class
Members See Also Send Feedback
A class representing a SecondaryBTreeDatabase. The Btree format is a representation of a sorted, balanced tree structure.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryBTreeDatabase : SecondaryDatabase
Visual Basic (Declaration)
Public Class SecondaryBTreeDatabase _
    Inherits SecondaryDatabase
Visual C++
public ref class SecondaryBTreeDatabase : public SecondaryDatabase

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.SecondaryDatabase
BerkeleyDB..::.SecondaryBTreeDatabase

See Also

SecondaryBTreeDatabase Members


SecondaryBTreeDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase Members
SecondaryBTreeDatabase Class Methods Properties See Also Send Feedback

The SecondaryBTreeDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Compare | The Btree key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
DupCompare | The duplicate data item comparison function.
Duplicates | Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
MinKeysPerPage | The minimum number of key/data pairs intended to be stored on any single Btree leaf page.
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
PrefixCompare | The Btree prefix function. The prefix function is used to determine the amount by which keys stored on the Btree internal pages can be safely truncated without losing their uniqueness.
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
RecordNumbers | If true, this object supports retrieval from the Btree using record numbers.
ReverseSplit | If false, empty pages are not coalesced into higher-level pages.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class


SecondaryBTreeDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase Methods
SecondaryBTreeDatabase Class See Also Send Feedback

The SecondaryBTreeDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

See Also

SecondaryBTreeDatabase Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Close Method
SecondaryBTreeDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Cursor Method
SecondaryBTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig) | Create a database cursor with the given configuration. (Inherited from BaseDatabase.)
Cursor(Transaction) | Create a transactionally protected database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Delete Method
SecondaryBTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Exists Method
SecondaryBTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


Get Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Get Method
SecondaryBTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.GetBoth Method
SecondaryBTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Open Method
SecondaryBTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, SecondaryBTreeDatabaseConfig) | Instantiate a new SecondaryBTreeDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, SecondaryBTreeDatabaseConfig, Transaction) | Instantiate a new SecondaryBTreeDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, String, SecondaryBTreeDatabaseConfig) | Instantiate a new SecondaryBTreeDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, String, SecondaryBTreeDatabaseConfig, Transaction) | Instantiate a new SecondaryBTreeDatabase object, open the database represented by Filename and associate the database with the primary index.

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


Open Method (String, SecondaryBTreeDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Open Method (String, SecondaryBTreeDatabaseConfig)
SecondaryBTreeDatabase Class See Also Send Feedback
Instantiate a new SecondaryBTreeDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryBTreeDatabase Open(
    string Filename,
    SecondaryBTreeDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryBTreeDatabaseConfig _
) As SecondaryBTreeDatabase
Visual C++
public:
static SecondaryBTreeDatabase^ Open(
    String^ Filename,
    SecondaryBTreeDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.SecondaryBTreeDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryBTreeDatabase Class
Open Overload


Open Method (String, SecondaryBTreeDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Open Method (String, SecondaryBTreeDatabaseConfig, Transaction)
SecondaryBTreeDatabase Class See Also Send Feedback
Instantiate a new SecondaryBTreeDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryBTreeDatabase Open(
    string Filename,
    SecondaryBTreeDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryBTreeDatabaseConfig, _
    txn As Transaction _
) As SecondaryBTreeDatabase
Visual C++
public:
static SecondaryBTreeDatabase^ Open(
    String^ Filename,
    SecondaryBTreeDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.SecondaryBTreeDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

SecondaryBTreeDatabase Class
Open Overload


Open Method (String, String, SecondaryBTreeDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Open Method (String, String, SecondaryBTreeDatabaseConfig)
SecondaryBTreeDatabase Class See Also Send Feedback
Instantiate a new SecondaryBTreeDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryBTreeDatabase Open(
    string Filename,
    string DatabaseName,
    SecondaryBTreeDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As SecondaryBTreeDatabaseConfig _
) As SecondaryBTreeDatabase
Visual C++
public:
static SecondaryBTreeDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    SecondaryBTreeDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.SecondaryBTreeDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryBTreeDatabase Class
Open Overload


Open Method (String, String, SecondaryBTreeDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Open Method (String, String, SecondaryBTreeDatabaseConfig, Transaction)
SecondaryBTreeDatabase Class See Also Send Feedback
Instantiate a new SecondaryBTreeDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryBTreeDatabase Open(
    string Filename,
    string DatabaseName,
    SecondaryBTreeDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As SecondaryBTreeDatabaseConfig, _
    txn As Transaction _
) As SecondaryBTreeDatabase
Visual C++
public:
static SecondaryBTreeDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    SecondaryBTreeDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.SecondaryBTreeDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and be replicated to client sites in any replication group.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

SecondaryBTreeDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.PrintFastStats Method
SecondaryBTreeDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.PrintStats Method
SecondaryBTreeDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


SecondaryCursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.SecondaryCursor Method
SecondaryBTreeDatabase Class See Also Send Feedback

Overload List

Name | Description
SecondaryCursor()()() | Create a secondary database cursor. (Inherited from SecondaryDatabase.)
SecondaryCursor(CursorConfig) | Create a secondary database cursor with the given configuration. (Inherited from SecondaryDatabase.)
SecondaryCursor(Transaction) | Create a transactionally protected secondary database cursor. (Inherited from SecondaryDatabase.)
SecondaryCursor(CursorConfig, Transaction) | Create a transactionally protected secondary database cursor with the given configuration. (Inherited from SecondaryDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Truncate Method
SecondaryBTreeDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class
SecondaryBTreeDatabase Members


SecondaryBTreeDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase Properties
SecondaryBTreeDatabase Class See Also Send Feedback

The SecondaryBTreeDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Compare | The Btree key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
DupCompare | The duplicate data item comparison function.
Duplicates | Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
MinKeysPerPage | The minimum number of key/data pairs intended to be stored on any single Btree leaf page.
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
PrefixCompare | The Btree prefix function. The prefix function is used to determine the amount by which keys stored on the Btree internal pages can be safely truncated without losing their uniqueness.
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
RecordNumbers | If true, this object supports retrieval from the Btree using record numbers.
ReverseSplit | If false, empty pages are not coalesced into higher-level pages.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryBTreeDatabase Class


Compare Property

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Compare Property
SecondaryBTreeDatabase Class See Also Send Feedback
The Btree key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate Compare { get; private set; }
Visual Basic (Declaration)
Public Property Compare As EntryComparisonDelegate
Visual C++
public:
property EntryComparisonDelegate^ Compare {
    EntryComparisonDelegate^ get ();
    void set (EntryComparisonDelegate^ value);
}

See Also

SecondaryBTreeDatabase Class


DupCompare Property

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.DupCompare Property
SecondaryBTreeDatabase Class See Also Send Feedback
The duplicate data item comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate DupCompare { get; private set; }
Visual Basic (Declaration)
Public Property DupCompare As EntryComparisonDelegate
Visual C++
public:
property EntryComparisonDelegate^ DupCompare {
    EntryComparisonDelegate^ get ();
    void set (EntryComparisonDelegate^ value);
}

See Also

SecondaryBTreeDatabase Class


Duplicates Property

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.Duplicates Property
SecondaryBTreeDatabase Class See Also Send Feedback
Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DuplicatesPolicy Duplicates { get; }
Visual Basic (Declaration)
Public ReadOnly Property Duplicates As DuplicatesPolicy
Visual C++
public:
property DuplicatesPolicy Duplicates {
    DuplicatesPolicy get ();
}

See Also

SecondaryBTreeDatabase Class


MinKeysPerPage Property

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.MinKeysPerPage Property
SecondaryBTreeDatabase Class See Also Send Feedback
The minimum number of key/data pairs intended to be stored on any single Btree leaf page.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MinKeysPerPage { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinKeysPerPage As UInteger
Visual C++
public:
property unsigned int MinKeysPerPage {
    unsigned int get ();
}

See Also

SecondaryBTreeDatabase Class


PrefixCompare Property

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.PrefixCompare Property
SecondaryBTreeDatabase Class See Also Send Feedback
The Btree prefix function. The prefix function is used to determine the amount by which keys stored on the Btree internal pages can be safely truncated without losing their uniqueness.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryPrefixComparisonDelegate PrefixCompare { get; private set; }
Visual Basic (Declaration)
Public Property PrefixCompare As EntryPrefixComparisonDelegate
Visual C++
public:
property EntryPrefixComparisonDelegate^ PrefixCompare {
    EntryPrefixComparisonDelegate^ get ();
    void set (EntryPrefixComparisonDelegate^ value);
}

See Also

SecondaryBTreeDatabase Class


RecordNumbers Property

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.RecordNumbers Property
SecondaryBTreeDatabase Class See Also Send Feedback
If true, this object supports retrieval from the Btree using record numbers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RecordNumbers { get; }
Visual Basic (Declaration)
Public ReadOnly Property RecordNumbers As Boolean
Visual C++
public:
property bool RecordNumbers {
    bool get ();
}

See Also

SecondaryBTreeDatabase Class


ReverseSplit Property

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabase..::.ReverseSplit Property
SecondaryBTreeDatabase Class See Also Send Feedback
If false, empty pages are not coalesced into higher-level pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReverseSplit { get; }
Visual Basic (Declaration)
Public ReadOnly Property ReverseSplit As Boolean
Visual C++
public:
property bool ReverseSplit {
    bool get ();
}

See Also

SecondaryBTreeDatabase Class


SecondaryBTreeDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for SecondaryBTreeDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryBTreeDatabaseConfig : SecondaryDatabaseConfig
Visual Basic (Declaration)
Public Class SecondaryBTreeDatabaseConfig _
    Inherits SecondaryDatabaseConfig
Visual C++
public ref class SecondaryBTreeDatabaseConfig : public SecondaryDatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.SecondaryDatabaseConfig
BerkeleyDB..::.SecondaryBTreeDatabaseConfig

See Also

SecondaryBTreeDatabaseConfig Members


SecondaryBTreeDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig Members
SecondaryBTreeDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The SecondaryBTreeDatabaseConfig type exposes the following members.

Constructors

Name | Description
SecondaryBTreeDatabaseConfig | Create a new SecondaryBTreeDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Compare | The Btree key comparison function.
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
DuplicateCompare | The duplicate data item comparison function.
Duplicates | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
ImmutableKey | If true, the secondary key is immutable. (Inherited from SecondaryDatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoReverseSplitting | Turn reverse splitting in the Btree on or off.
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive. (Inherited from SecondaryDatabaseConfig.)
PrefixCompare | The Btree prefix function.
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)
UseRecordNumbers | If true, support retrieval from the Btree using record numbers.

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ForeignKeyDatabase | The database used to check the foreign key integrity constraint. (Inherited from SecondaryDatabaseConfig.)
ForeignKeyNullfier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabaseConfig.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabaseConfig.)
MinKeysPerPage | The minimum number of key/data pairs intended to be stored on any single Btree leaf page.
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted. (Inherited from SecondaryDatabaseConfig.)
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryBTreeDatabaseConfig Class


SecondaryBTreeDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig Constructor
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
Create a new SecondaryBTreeDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryBTreeDatabaseConfig(
    Database PrimaryDB,
    SecondaryKeyGenDelegate KeyGenFunc
)
Visual Basic (Declaration)
Public Sub New ( _
    PrimaryDB As Database, _
    KeyGenFunc As SecondaryKeyGenDelegate _
)
Visual C++
public:
SecondaryBTreeDatabaseConfig(
    Database^ PrimaryDB,
    SecondaryKeyGenDelegate^ KeyGenFunc
)

Parameters

PrimaryDB
Type: BerkeleyDB..::.Database
KeyGenFunc
Type: BerkeleyDB..::.SecondaryKeyGenDelegate

See Also

SecondaryBTreeDatabaseConfig Class


SecondaryBTreeDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig Fields
SecondaryBTreeDatabaseConfig Class See Also Send Feedback

The SecondaryBTreeDatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Compare | The Btree key comparison function.
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
DuplicateCompare | The duplicate data item comparison function.
Duplicates | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
ImmutableKey | If true, the secondary key is immutable. (Inherited from SecondaryDatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoReverseSplitting | Turn reverse splitting in the Btree on or off.
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive. (Inherited from SecondaryDatabaseConfig.)
PrefixCompare | The Btree prefix function.
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)
UseRecordNumbers | If true, support retrieval from the Btree using record numbers.

See Also

SecondaryBTreeDatabaseConfig Class


Compare Field

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.Compare Field
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
The Btree key comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate Compare
Visual Basic (Declaration)
Public Compare As EntryComparisonDelegate
Visual C++
public:
EntryComparisonDelegate^ Compare

Remarks

The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.

If no comparison function is specified, the keys are compared lexically, with shorter keys collating before longer keys.

If the database already exists, the comparison function must be the same as that historically used to create the database or corruption can occur.

See Also

SecondaryBTreeDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.Creation Field
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, SecondaryBTreeDatabaseConfig) fails.

See Also

SecondaryBTreeDatabaseConfig Class


DuplicateCompare Field

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.DuplicateCompare Field
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
The duplicate data item comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate DuplicateCompare
Visual Basic (Declaration)
Public DuplicateCompare As EntryComparisonDelegate
Visual C++
public:
EntryComparisonDelegate^ DuplicateCompare

Remarks

The comparison function is called whenever it is necessary to compare a data item specified by the application with a data item currently stored in the database. Setting DuplicateCompare implies setting Duplicates to SORTED.

If no comparison function is specified, the data items are compared lexically, with shorter data items collating before longer data items.

If the database already exists when Open(String, SecondaryBTreeDatabaseConfig) is called, the delegate must be the same as that historically used to create the database or corruption can occur.

See Also

SecondaryBTreeDatabaseConfig Class


Duplicates Field

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.Duplicates Field
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DuplicatesPolicy Duplicates
Visual Basic (Declaration)
Public Duplicates As DuplicatesPolicy
Visual C++
public:
DuplicatesPolicy Duplicates

Remarks

The ordering of duplicates in the database for UNSORTED is determined by the order of insertion, unless the ordering is otherwise specified by use of a cursor operation or a duplicate sort function. The ordering of duplicates in the database for SORTED is determined by the duplicate comparison function. If the application does not specify a comparison function using DuplicateCompare, a default lexical comparison is used.

SORTED is preferred to UNSORTED for performance reasons. UNSORTED should only be used by applications wanting to order duplicate data items manually.

If the database already exists, the value of Duplicates must be the same as the existing database or an error is returned.

It is an error to specify UseRecordNumbers and anything other than NONE.

See Also

SecondaryBTreeDatabaseConfig Class


NoReverseSplitting Field

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.NoReverseSplitting Field
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
Turn reverse splitting in the Btree on or off.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoReverseSplitting
Visual Basic (Declaration)
Public NoReverseSplitting As Boolean
Visual C++
public:
bool NoReverseSplitting

Remarks

As pages are emptied in a database, the Berkeley DB Btree implementation attempts to coalesce empty pages into higher-level pages in order to keep the database as small as possible and minimize search time. This can hurt performance in applications with cyclical data demands; applications where the database grows and shrinks repeatedly. For example, because Berkeley DB does page-level locking, the maximum level of concurrency in a database of two pages is far smaller than that in a database of 100 pages, so a database that has shrunk to a minimal size can cause severe deadlocking when a new cycle of data insertion begins.

See Also

SecondaryBTreeDatabaseConfig Class


PrefixCompare Field

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.PrefixCompare Field
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
The Btree prefix function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryPrefixComparisonDelegate PrefixCompare
Visual Basic (Declaration)
Public PrefixCompare As EntryPrefixComparisonDelegate
Visual C++
public:
EntryPrefixComparisonDelegate^ PrefixCompare

Remarks

The prefix function is used to determine the amount by which keys stored on the Btree internal pages can be safely truncated without losing their uniqueness. See the Btree prefix comparison section of the Berkeley DB Reference Guide for more details about how this works. The usefulness of this is data-dependent, but can produce significantly reduced tree sizes and search times in some data sets.

If no prefix function or key comparison function is specified by the application, a default lexical comparison function is used as the prefix function. If no prefix function is specified and Compare is specified, no prefix function is used. It is an error to specify a prefix function without also specifying Compare.

If the database already exists, the prefix function must be the same as that historically used to create the database or corruption can occur.

See Also

SecondaryBTreeDatabaseConfig Class


UseRecordNumbers Field

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.UseRecordNumbers Field
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
If true, support retrieval from the Btree using record numbers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool UseRecordNumbers
Visual Basic (Declaration)
Public UseRecordNumbers As Boolean
Visual C++
public:
bool UseRecordNumbers

Remarks

Logical record numbers in Btree databases are mutable in the face of record insertion or deletion. See Renumber for further discussion.

Maintaining record counts within a Btree introduces a serious point of contention, namely the page locations where the record counts are stored. In addition, the entire database must be locked during both insertions and deletions, effectively single-threading the database for those operations. Specifying UseRecordNumbers can result in serious performance degradation for some applications and data sets.

It is an error to specify UseRecordNumbers and anything other than NONE.

If the database already exists, the value of UseRecordNumbers must be the same as the existing database or an error is returned.

See Also

SecondaryBTreeDatabaseConfig Class


SecondaryBTreeDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig Methods
SecondaryBTreeDatabaseConfig Class See Also Send Feedback

The SecondaryBTreeDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecondaryBTreeDatabaseConfig Class


SetForeignKeyConstraint Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.SetForeignKeyConstraint Method
SecondaryBTreeDatabaseConfig Class See Also Send Feedback

Overload List

Name | Description
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction) | Specify the action taken when a referenced record in the foreign key database is deleted. (Inherited from SecondaryDatabaseConfig.)
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction, ForeignKeyNullifyDelegate) | Specify the action taken when a referenced record in the foreign key database is deleted. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryBTreeDatabaseConfig Class
SecondaryBTreeDatabaseConfig Members


SecondaryBTreeDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig Properties
SecondaryBTreeDatabaseConfig Class See Also Send Feedback

The SecondaryBTreeDatabaseConfig type exposes the following members.

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ForeignKeyDatabase | The database used to check the foreign key integrity constraint. (Inherited from SecondaryDatabaseConfig.)
ForeignKeyNullfier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabaseConfig.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabaseConfig.)
MinKeysPerPage | The minimum number of key/data pairs intended to be stored on any single Btree leaf page.
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted. (Inherited from SecondaryDatabaseConfig.)
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryBTreeDatabaseConfig Class


MinKeysPerPage Property

[image]

Berkeley DB .NET API Documentation
SecondaryBTreeDatabaseConfig..::.MinKeysPerPage Property
SecondaryBTreeDatabaseConfig Class See Also Send Feedback
The minimum number of key/data pairs intended to be stored on any single Btree leaf page.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MinKeysPerPage { get; set; }
Visual Basic (Declaration)
Public Property MinKeysPerPage As UInteger
Visual C++
public:
property unsigned int MinKeysPerPage {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used to determine if key or data items are stored on overflow pages instead of Btree leaf pages. For more information on the specific algorithm used, see the Berkeley DB Reference Guide. The value specified must be at least 2; if not explicitly set, a value of 2 is used.

If the database already exists, MinKeysPerPage is ignored.

See Also

SecondaryBTreeDatabaseConfig Class


SecondaryCursor Class

[image]

Berkeley DB .NET API Documentation
SecondaryCursor Class
Members See Also Send Feedback
A class representing database cursors over secondary indexes, which allow for traversal of database records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryCursor : BaseCursor,
    IEnumerable<KeyValuePair<DatabaseEntry, KeyValuePair<DatabaseEntry, DatabaseEntry>>>,
    IEnumerable
Visual Basic (Declaration)
Public Class SecondaryCursor _
    Inherits BaseCursor _
    Implements IEnumerable(Of KeyValuePair(Of DatabaseEntry, KeyValuePair(Of DatabaseEntry, DatabaseEntry))),  _
    IEnumerable
Visual C++
public ref class SecondaryCursor : public BaseCursor,
    IEnumerable<KeyValuePair<DatabaseEntry^, KeyValuePair<DatabaseEntry^, DatabaseEntry^>>>,
    IEnumerable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseCursor
BerkeleyDB..::.SecondaryCursor

See Also

SecondaryCursor Members


SecondaryCursor Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor Members
SecondaryCursor Class Methods Properties See Also Send Feedback

The SecondaryCursor type exposes the following members.

Methods

Name | Description
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
Delete | Delete the key/data pair to which the cursor refers from the primary database and all secondary indices.
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the SecondaryCursor.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Move | Overloaded.
MoveFirst | Overloaded.
MoveLast | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextUnique | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Refresh | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Current | The secondary key and primary key/data pair at which the cursor currently points.

See Also

SecondaryCursor Class


SecondaryCursor Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor Methods
SecondaryCursor Class See Also Send Feedback

The SecondaryCursor type exposes the following members.

Methods

Name | Description
Close | Discard the cursor. If you do not close the cursor before closing the database handle or the transaction handle that owns this cursor, then, closing either a database or transaction handle closes this cursor. It is possible for the Close() method to throw a DeadlockException, signaling that any enclosing transaction should be aborted. If the application is already intending to abort the transaction, this error should be ignored, and the application should proceed. After Close has been called, regardless of its result, the object may not be used again. (Inherited from BaseCursor.)
Compare | Compare this cursor's position to another's. (Inherited from BaseCursor.)
Count | Returns a count of the number of data items for the key to which the cursor refers. (Inherited from BaseCursor.)
Delete | Delete the key/data pair to which the cursor refers from the primary database and all secondary indices.
Dispose | Release the resources held by this object, and close the cursor if it is still open. (Inherited from BaseCursor.)
Duplicate | Create a new cursor that uses the same transaction and locker ID as the original cursor.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the SecondaryCursor.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Move | Overloaded.
MoveFirst | Overloaded.
MoveLast | Overloaded.
MoveNext | Overloaded.
MoveNextDuplicate | Overloaded.
MoveNextUnique | Overloaded.
MovePrev | Overloaded.
MovePrevDuplicate | Overloaded.
MovePrevUnique | Overloaded.
Refresh | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecondaryCursor Class


Delete Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Delete Method
SecondaryCursor Class See Also Send Feedback
Delete the key/data pair to which the cursor refers from the primary database and all secondary indices.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete
Visual C++
public:
void Delete()

Remarks

The cursor position is unchanged after a delete, and subsequent calls to cursor functions expecting the cursor to refer to an existing key will fail.

Exceptions

Exception | Condition
BerkeleyDB..::.KeyEmptyException | The element has already been deleted.

See Also

SecondaryCursor Class


Duplicate Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Duplicate Method
SecondaryCursor Class See Also Send Feedback
Create a new cursor that uses the same transaction and locker ID as the original cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryCursor Duplicate(
    bool keepPosition
)
Visual Basic (Declaration)
Public Function Duplicate ( _
    keepPosition As Boolean _
) As SecondaryCursor
Visual C++
public:
SecondaryCursor^ Duplicate(
    bool keepPosition
)

Parameters

keepPosition
Type: System..::.Boolean
If true, the newly created cursor is initialized to refer to the same position in the database as the original cursor (if any) and hold the same locks (if any). If false, or if the original cursor does not hold a database position and locks, the created cursor is uninitialized and behaves like a cursor newly created by Cursor()()().

Return Value

A newly created cursor

Remarks

This is useful when an application is using locking and requires two or more cursors in the same thread of control.

See Also

SecondaryCursor Class


GetEnumerator Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.GetEnumerator Method
SecondaryCursor Class See Also Send Feedback
Returns an enumerator that iterates through the SecondaryCursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public IEnumerator<KeyValuePair<DatabaseEntry, KeyValuePair<DatabaseEntry, DatabaseEntry>>> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of DatabaseEntry, KeyValuePair(Of DatabaseEntry, DatabaseEntry)))
Visual C++
public:
virtual IEnumerator<KeyValuePair<DatabaseEntry^, KeyValuePair<DatabaseEntry^, DatabaseEntry^>>>^ GetEnumerator() sealed

Return Value

An enumerator for the SecondaryCursor.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

Remarks

The enumerator begins at the cursor's current position (or the first record if the cursor has not yet been positioned) and iterate forwards (i.e. in the direction of MoveNext()()()) over the remaining records.

See Also

SecondaryCursor Class


Move Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Move Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
Move(DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the primary key/data pair associated with the given secondary key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current.
Move(KeyValuePair<(Of <(DatabaseEntry, KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>)>)>), Boolean) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
Move(DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the primary key/data pair associated with the given secondary key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current.
Move(KeyValuePair<(Of <(DatabaseEntry, KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>)>)>), Boolean, LockingInfo) | Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.
Move(DatabaseEntry, DatabaseEntry, DatabaseEntry, Boolean) | Set the cursor to refer to key, and store the primary key/data pair associated with the given secondary key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned.
Move(DatabaseEntry, DatabaseEntry, DatabaseEntry, Boolean, LockingInfo) | Set the cursor to refer to key, and store the primary key/data pair associated with the given secondary key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


Move Method (DatabaseEntry, Boolean)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Move Method (DatabaseEntry, Boolean)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to key, and store the primary key/data pair associated with the given secondary key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    DatabaseEntry key,
    bool exact
)
Visual Basic (Declaration)
Public Function Move ( _
    key As DatabaseEntry, _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool Move(
    DatabaseEntry^ key,
    bool exact
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
Move Overload


Move Method (KeyValuePair(DatabaseEntry, KeyValuePair(DatabaseEntry, DatabaseEntry)), Boolean)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Move Method (KeyValuePair<(Of <(DatabaseEntry, KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>)>)>), Boolean)
SecondaryCursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    KeyValuePair<DatabaseEntry, KeyValuePair<DatabaseEntry, DatabaseEntry>> pair,
    bool exact
)
Visual Basic (Declaration)
Public Function Move ( _
    pair As KeyValuePair(Of DatabaseEntry, KeyValuePair(Of DatabaseEntry, DatabaseEntry)), _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool Move(
    KeyValuePair<DatabaseEntry^, KeyValuePair<DatabaseEntry^, DatabaseEntry^>> pair,
    bool exact
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)>)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

If this flag is specified on a database configured without sorted duplicate support, the value of exact is ignored.

See Also

SecondaryCursor Class
Move Overload


Move Method (DatabaseEntry, Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Move Method (DatabaseEntry, Boolean, LockingInfo)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to key, and store the primary key/data pair associated with the given secondary key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    DatabaseEntry key,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Move ( _
    key As DatabaseEntry, _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Move(
    DatabaseEntry^ key,
    bool exact,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
Move Overload


Move Method (KeyValuePair(DatabaseEntry, KeyValuePair(DatabaseEntry, DatabaseEntry)), Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Move Method (KeyValuePair<(Of <(DatabaseEntry, KeyValuePair<(Of <(DatabaseEntry, DatabaseEntry>)>)>)>), Boolean, LockingInfo)
SecondaryCursor Class See Also Send Feedback
Move the cursor to the specified key/data pair of the database. The cursor is positioned to a key/data pair if both the key and data match the values provided on the key and data parameters.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    KeyValuePair<DatabaseEntry, KeyValuePair<DatabaseEntry, DatabaseEntry>> pair,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Move ( _
    pair As KeyValuePair(Of DatabaseEntry, KeyValuePair(Of DatabaseEntry, DatabaseEntry)), _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Move(
    KeyValuePair<DatabaseEntry^, KeyValuePair<DatabaseEntry^, DatabaseEntry^>> pair,
    bool exact,
    LockingInfo^ info
)

Parameters

pair
Type: System.Collections.Generic..::.KeyValuePair <(Of <( DatabaseEntry, KeyValuePair <(Of <( DatabaseEntry, DatabaseEntry >)>)>)>)
The key/data pair at which to position the cursor.
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest data value which is greater than or equal to the value provided by pair.Value (as determined by the comparison function). Otherwise, require the given key and data to match the key and data in the database exactly.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

If this flag is specified on a database configured without sorted duplicate support, the value of exact is ignored.

See Also

SecondaryCursor Class
Move Overload


Move Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, Boolean)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Move Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, Boolean)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to key, and store the primary key/data pair associated with the given secondary key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    bool exact
)
Visual Basic (Declaration)
Public Function Move ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    exact As Boolean _
) As Boolean
Visual C++
public:
bool Move(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    bool exact
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the current matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the current matching record in primary db
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
Move Overload


Move Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, Boolean, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Move Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, Boolean, LockingInfo)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to key, and store the primary key/data pair associated with the given secondary key in Current. In the presence of duplicate key values, the first data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Move is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Move(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    bool exact,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Move ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    exact As Boolean, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Move(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    bool exact,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The key at which to position the cursor
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the current matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the current matching record in primary db
exact
Type: System..::.Boolean
If false and in a database configured for sorted duplicates, position the cursor at the smallest key greater than or equal to the specified key, permitting partial key matches and range searches. Otherwise, require the given key to match the key in the database exactly.
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
Move Overload


MoveFirst Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveFirst Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
MoveFirst()()() | Set the cursor to refer to the first key/data pair of the database, and store the secondary key along with the corresponding primary key/data pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current.
MoveFirst(LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store the secondary key along with the corresponding primary key/data pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current.
MoveFirst(DatabaseEntry, DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the first key/data pair of the database, and store the secondary key along with the corresponding primary key/data pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned.
MoveFirst(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the first key/data pair of the database, and store the secondary key along with the corresponding primary key/data pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


MoveFirst Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveFirst Method
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store the secondary key along with the corresponding primary key/data pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirst()
Visual Basic (Declaration)
Public Function MoveFirst As Boolean
Visual C++
public:
bool MoveFirst()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveFirst Overload


MoveFirst Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveFirst Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store the secondary key along with the corresponding primary key/data pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirst(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveFirst ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveFirst(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveFirst Overload


MoveFirst Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveFirst Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store the secondary key along with the corresponding primary key/data pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirst(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveFirst ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveFirst(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveFirst Overload


MoveFirst Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveFirst Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to the first key/data pair of the database, and store the secondary key along with the corresponding primary key/data pair in Current. If the first key has duplicate values, the first data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveFirst is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveFirst(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveFirst ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveFirst(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The retrieved data in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveFirst Overload


MoveLast Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveLast Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
MoveLast()()() | Set the cursor to refer to the last key/data pair of the database, and store the secondary key and primary key/data pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current.
MoveLast(LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store the secondary key and primary key/data pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current.
MoveLast(DatabaseEntry, DatabaseEntry, DatabaseEntry) | Set the cursor to refer to the last key/data pair of the database, and store the secondary key and primary key/data pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned.
MoveLast(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | Set the cursor to refer to the last key/data pair of the database, and store the secondary key and primary key/data pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


MoveLast Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveLast Method
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to the last key/data pair of the database, and store the secondary key and primary key/data pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveLast()
Visual Basic (Declaration)
Public Function MoveLast As Boolean
Visual C++
public:
bool MoveLast()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveLast Overload


MoveLast Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveLast Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to the last key/data pair of the database, and store the secondary key and primary key/data pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveLast(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveLast ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveLast(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveLast Overload


MoveLast Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveLast Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to the last key/data pair of the database, and store the secondary key and primary key/data pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveLast(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveLast ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveLast(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveLast Overload


MoveLast Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveLast Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
Set the cursor to refer to the last key/data pair of the database, and store the secondary key and primary key/data pair in Current. If the last key has duplicate values, the last data item in the set of duplicates is stored in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveLast is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveLast(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveLast ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveLast(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveLast Overload


MoveNext Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNext Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNext()()() | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.
MoveNext(LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.
MoveNext(DatabaseEntry, DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned.
MoveNext(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


MoveNext Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNext Method
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext()
Visual Basic (Declaration)
Public Function MoveNext As Boolean
Visual C++
public:
bool MoveNext()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNext Overload


MoveNext Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNext Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNext ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNext(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNext Overload


MoveNext Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNext Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNext is identical to MoveFirst()()(). Otherwise, move the cursor to the next key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveNext ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveNext(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNext Overload


MoveNext Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNext Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNext is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNext is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNext(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNext ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNext(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNext Overload


MoveNextDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextDuplicate Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextDuplicate()()() | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store the secondary key and primary key/data pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicate(LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store the secondary key and primary key/data pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.
MoveNextDuplicate(DatabaseEntry, DatabaseEntry, DatabaseEntry) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store the secondary key and primary key/data pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned.
MoveNextDuplicate(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store the secondary key and primary key/data pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


MoveNextDuplicate Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextDuplicate Method
SecondaryCursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store the secondary key and primary key/data pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicate()
Visual Basic (Declaration)
Public Function MoveNextDuplicate As Boolean
Visual C++
public:
bool MoveNextDuplicate()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNextDuplicate Overload


MoveNextDuplicate Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextDuplicate Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store the secondary key and primary key/data pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicate(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextDuplicate ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextDuplicate(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNextDuplicate Overload


MoveNextDuplicate Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextDuplicate Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store the secondary key and primary key/data pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicate(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveNextDuplicate ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveNextDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNextDuplicate Overload


MoveNextDuplicate Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextDuplicate Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the next key/data pair of the database is a duplicate data record for the current key/data pair, move the cursor to the next key/data pair in the database, and store the secondary key and primary key/data pair in Current. MoveNextDuplicate returns false if the next key/data pair of the database is not a duplicate data record for the current key/data pair. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextDuplicate is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextDuplicate(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextDuplicate ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNextDuplicate Overload


MoveNextUnique Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextUnique Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
MoveNextUnique()()() | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUnique(LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MoveNextUnique(DatabaseEntry, DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned.
MoveNextUnique(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


MoveNextUnique Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextUnique Method
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUnique()
Visual Basic (Declaration)
Public Function MoveNextUnique As Boolean
Visual C++
public:
bool MoveNextUnique()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNextUnique Overload


MoveNextUnique Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextUnique Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUnique(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextUnique ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextUnique(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If the database is a Queue or Recno database, MoveNextUnique ignores any keys that exist but were never explicitly created by the application, or those that were created and later deleted.

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNextUnique Overload


MoveNextUnique Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextUnique Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst()()(). Otherwise, move the cursor to the next non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUnique(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MoveNextUnique ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MoveNextUnique(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNextUnique Overload


MoveNextUnique Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MoveNextUnique Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MoveNextUnique is identical to MoveFirst(LockingInfo). Otherwise, move the cursor to the next non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MoveNextUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MoveNextUnique is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MoveNextUnique(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MoveNextUnique ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MoveNextUnique(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MoveNextUnique Overload


MovePrev Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrev Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrev()()() | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.
MovePrev(LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.
MovePrev(DatabaseEntry, DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned.
MovePrev(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


MovePrev Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrev Method
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrev()
Visual Basic (Declaration)
Public Function MovePrev As Boolean
Visual C++
public:
bool MovePrev()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrev Overload


MovePrev Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrev Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrev(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrev ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrev(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrev Overload


MovePrev Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrev Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrev is identical to MoveLast()()(). Otherwise, move the cursor to the previous key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrev(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MovePrev ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MovePrev(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrev Overload


MovePrev Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrev Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrev is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous key/data pair of the database, and store the secondary key and primary key/data pair in Current. In the presence of duplicate key values, the value of Current.Key may not change. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrev is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrev(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrev ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrev(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrev Overload


MovePrevDuplicate Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevDuplicate Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevDuplicate()()() | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and the secondary key and primary key/data pair in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair.
MovePrevDuplicate(LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and the secondary key and primary key/data pair in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair.
MovePrevDuplicate(DatabaseEntry, DatabaseEntry, DatabaseEntry) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and the secondary key and primary key/data pair in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned.
MovePrevDuplicate(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and the secondary key and primary key/data pair in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


MovePrevDuplicate Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevDuplicate Method
SecondaryCursor Class See Also Send Feedback
If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and the secondary key and primary key/data pair in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevDuplicate()
Visual Basic (Declaration)
Public Function MovePrevDuplicate As Boolean
Visual C++
public:
bool MovePrevDuplicate()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrevDuplicate Overload


MovePrevDuplicate Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevDuplicate Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and the secondary key and primary key/data pair in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevDuplicate(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrevDuplicate ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrevDuplicate(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrevDuplicate Overload


MovePrevDuplicate Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevDuplicate Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and the secondary key and primary key/data pair in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevDuplicate(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MovePrevDuplicate ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MovePrevDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrevDuplicate Overload


MovePrevDuplicate Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevDuplicate Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the previous key/data pair of the database is a duplicate data record for the current key/data pair, the cursor is moved to the previous key/data pair of the database, and the secondary key and primary key/data pair in Current. MovePrevDuplicate returns false if the previous key/data pair of the database is not a duplicate data record for the current key/data pair. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevDuplicate is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevDuplicate(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrevDuplicate ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrevDuplicate(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrevDuplicate Overload


MovePrevUnique Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevUnique Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
MovePrevUnique()()() | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MovePrevUnique(LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.
MovePrevUnique(DatabaseEntry, DatabaseEntry, DatabaseEntry) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned.
MovePrevUnique(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


MovePrevUnique Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevUnique Method
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevUnique()
Visual Basic (Declaration)
Public Function MovePrevUnique As Boolean
Visual C++
public:
bool MovePrevUnique()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrevUnique Overload


MovePrevUnique Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevUnique Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevUnique(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrevUnique ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrevUnique(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrevUnique Overload


MovePrevUnique Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevUnique Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast()()(). Otherwise, move the cursor to the previous non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevUnique(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function MovePrevUnique ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool MovePrevUnique(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrevUnique Overload


MovePrevUnique Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.MovePrevUnique Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
If the cursor is not yet initialized, MovePrevUnique is identical to MoveLast(LockingInfo). Otherwise, move the cursor to the previous non-duplicate key in the database, and store the secondary key and primary key/data pair in Current. MovePrevUnique returns false if no non-duplicate key/data pairs exist after the cursor position in the database. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, MovePrevUnique is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool MovePrevUnique(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function MovePrevUnique ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool MovePrevUnique(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
MovePrevUnique Overload


Refresh Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Refresh Method
SecondaryCursor Class See Also Send Feedback

Overload List

Name | Description
Refresh()()() | Store the secondary key and primary key/data pair to which the cursor refers in Current.
Refresh(LockingInfo) | Store the secondary key and primary key/data pair to which the cursor refers in Current.
Refresh(DatabaseEntry, DatabaseEntry, DatabaseEntry) | Store the secondary key and primary key/data pair to which the cursor refers in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned.
Refresh(DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo) | Store the secondary key and primary key/data pair to which the cursor refers in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned.

See Also

SecondaryCursor Class
SecondaryCursor Members


Refresh Method

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Refresh Method
SecondaryCursor Class See Also Send Feedback
Store the secondary key and primary key/data pair to which the cursor refers in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Refresh()
Visual Basic (Declaration)
Public Function Refresh As Boolean
Visual C++
public:
bool Refresh()

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
Refresh Overload


Refresh Method (LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Refresh Method (LockingInfo)
SecondaryCursor Class See Also Send Feedback
Store the secondary key and primary key/data pair to which the cursor refers in Current.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Refresh(
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Refresh ( _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Refresh(
    LockingInfo^ info
)

Parameters

info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use.

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
Refresh Overload


Refresh Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Refresh Method (DatabaseEntry, DatabaseEntry, DatabaseEntry)
SecondaryCursor Class See Also Send Feedback
Store the secondary key and primary key/data pair to which the cursor refers in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Refresh(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Function Refresh ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry _
) As Boolean
Visual C++
public:
bool Refresh(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
Refresh Overload


Refresh Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Refresh Method (DatabaseEntry, DatabaseEntry, DatabaseEntry, LockingInfo)
SecondaryCursor Class See Also Send Feedback
Store the secondary key and primary key/data pair to which the cursor refers in Current. If key, or pkey, or data is partial DatabaseEntry, its PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprised the entire record. If any or all of the specified bytes do not exist in the record, Refresh is successful, and any existing bytes are returned.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Refresh(
    DatabaseEntry key,
    DatabaseEntry pkey,
    DatabaseEntry data,
    LockingInfo info
)
Visual Basic (Declaration)
Public Function Refresh ( _
    key As DatabaseEntry, _
    pkey As DatabaseEntry, _
    data As DatabaseEntry, _
    info As LockingInfo _
) As Boolean
Visual C++
public:
bool Refresh(
    DatabaseEntry^ key,
    DatabaseEntry^ pkey,
    DatabaseEntry^ data,
    LockingInfo^ info
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The retrieved key in secondary db
pkey
Type: BerkeleyDB..::.DatabaseEntry
The key of the matching record in primary db
data
Type: BerkeleyDB..::.DatabaseEntry
The data of the matching record in primary db
info
Type: BerkeleyDB..::.LockingInfo
The locking behavior to use

Return Value

True if the cursor was positioned successfully, false otherwise.

Remarks

If positioning the cursor fails, Current will contain an empty KeyValuePair<(Of <(TKey, TValue>)>).

See Also

SecondaryCursor Class
Refresh Overload


SecondaryCursor Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryCursor Properties
SecondaryCursor Class See Also Send Feedback

The SecondaryCursor type exposes the following members.

Properties

Name | Description
Current | The secondary key and primary key/data pair at which the cursor currently points.

See Also

SecondaryCursor Class


Current Property

[image]

Berkeley DB .NET API Documentation
SecondaryCursor..::.Current Property
SecondaryCursor Class See Also Send Feedback
The secondary key and primary key/data pair at which the cursor currently points.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public KeyValuePair<DatabaseEntry, KeyValuePair<DatabaseEntry, DatabaseEntry>> Current { get; private set; }
Visual Basic (Declaration)
Public Property Current As KeyValuePair(Of DatabaseEntry, KeyValuePair(Of DatabaseEntry, DatabaseEntry))
Visual C++
public:
property KeyValuePair<DatabaseEntry^, KeyValuePair<DatabaseEntry^, DatabaseEntry^>> Current {
    KeyValuePair<DatabaseEntry^, KeyValuePair<DatabaseEntry^, DatabaseEntry^>> get ();
    void set (KeyValuePair<DatabaseEntry^, KeyValuePair<DatabaseEntry^, DatabaseEntry^>> value);
}

See Also

SecondaryCursor Class


SecondaryDatabase Class

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase Class
Members See Also Send Feedback
A class representing a secondary Berkeley DB database, a base class for access method specific classes.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryDatabase : BaseDatabase
Visual Basic (Declaration)
Public Class SecondaryDatabase _
    Inherits BaseDatabase
Visual C++
public ref class SecondaryDatabase : public BaseDatabase

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.SecondaryDatabase
BerkeleyDB..::.SecondaryBTreeDatabase
BerkeleyDB..::.SecondaryHashDatabase
BerkeleyDB..::.SecondaryQueueDatabase
BerkeleyDB..::.SecondaryRecnoDatabase

See Also

SecondaryDatabase Members


SecondaryDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase Members
SecondaryDatabase Class Methods Properties See Also Send Feedback

The SecondaryDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class


SecondaryDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase Methods
SecondaryDatabase Class See Also Send Feedback

The SecondaryDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

See Also

SecondaryDatabase Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Close Method
SecondaryDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Cursor Method
SecondaryDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig) | Create a database cursor with the given configuration. (Inherited from BaseDatabase.)
Cursor(Transaction) | Create a transactionally protected database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Delete Method
SecondaryDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Exists Method
SecondaryDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


Get Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Get Method
SecondaryDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.GetBoth Method
SecondaryDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Open Method
SecondaryDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, SecondaryDatabaseConfig) | Instantiate a new SecondaryDatabase object, open the database represented by Filename and associate the database with the primary index. The file specified by Filename must exist.
Open(String, SecondaryDatabaseConfig, Transaction) | Instantiate a new SecondaryDatabase object, open the database represented by Filename and associate the database with the primary index. The file specified by Filename must exist.
Open(String, String, SecondaryDatabaseConfig) | Instantiate a new SecondaryDatabase object, open the database represented by Filename and associate the database with the primary index. The file specified by Filename must exist.
Open(String, String, SecondaryDatabaseConfig, Transaction) | Instantiate a new SecondaryDatabase object, open the database represented by Filename and associate the database with the primary index. The file specified by Filename must exist.

See Also

SecondaryDatabase Class
SecondaryDatabase Members


Open Method (String, SecondaryDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Open Method (String, SecondaryDatabaseConfig)
SecondaryDatabase Class See Also Send Feedback
Instantiate a new SecondaryDatabase object, open the database represented by Filename and associate the database with the primary index. The file specified by Filename must exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryDatabase Open(
    string Filename,
    SecondaryDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryDatabaseConfig _
) As SecondaryDatabase
Visual C++
public:
static SecondaryDatabase^ Open(
    String^ Filename,
    SecondaryDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database.
cfg
Type: BerkeleyDB..::.SecondaryDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryDatabase Class
Open Overload


Open Method (String, SecondaryDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Open Method (String, SecondaryDatabaseConfig, Transaction)
SecondaryDatabase Class See Also Send Feedback
Instantiate a new SecondaryDatabase object, open the database represented by Filename and associate the database with the primary index. The file specified by Filename must exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryDatabase Open(
    string Filename,
    SecondaryDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryDatabaseConfig, _
    txn As Transaction _
) As SecondaryDatabase
Visual C++
public:
static SecondaryDatabase^ Open(
    String^ Filename,
    SecondaryDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database.
cfg
Type: BerkeleyDB..::.SecondaryDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryDatabase Class
Open Overload


Open Method (String, String, SecondaryDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Open Method (String, String, SecondaryDatabaseConfig)
SecondaryDatabase Class See Also Send Feedback
Instantiate a new SecondaryDatabase object, open the database represented by Filename and associate the database with the primary index. The file specified by Filename must exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryDatabase Open(
    string Filename,
    string DatabaseName,
    SecondaryDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As SecondaryDatabaseConfig _
) As SecondaryDatabase
Visual C++
public:
static SecondaryDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    SecondaryDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.SecondaryDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and will be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryDatabase Class
Open Overload


Open Method (String, String, SecondaryDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Open Method (String, String, SecondaryDatabaseConfig, Transaction)
SecondaryDatabase Class See Also Send Feedback
Instantiate a new SecondaryDatabase object, open the database represented by Filename and associate the database with the primary index. The file specified by Filename must exist.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryDatabase Open(
    string Filename,
    string DatabaseName,
    SecondaryDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As SecondaryDatabaseConfig, _
    txn As Transaction _
) As SecondaryDatabase
Visual C++
public:
static SecondaryDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    SecondaryDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.SecondaryDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and will be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.PrintFastStats Method
SecondaryDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.PrintStats Method
SecondaryDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


SecondaryCursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.SecondaryCursor Method
SecondaryDatabase Class See Also Send Feedback

Overload List

Name | Description
SecondaryCursor()()() | Create a secondary database cursor.
SecondaryCursor(CursorConfig) | Create a secondary database cursor with the given configuration.
SecondaryCursor(Transaction) | Create a transactionally protected secondary database cursor.
SecondaryCursor(CursorConfig, Transaction) | Create a transactionally protected secondary database cursor with the given configuration.

See Also

SecondaryDatabase Class
SecondaryDatabase Members


SecondaryCursor Method

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.SecondaryCursor Method
SecondaryDatabase Class See Also Send Feedback
Create a secondary database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryCursor SecondaryCursor()
Visual Basic (Declaration)
Public Function SecondaryCursor As SecondaryCursor
Visual C++
public:
SecondaryCursor^ SecondaryCursor()

Return Value

A newly created cursor

See Also

SecondaryDatabase Class
SecondaryCursor Overload


SecondaryCursor Method (CursorConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.SecondaryCursor Method (CursorConfig)
SecondaryDatabase Class See Also Send Feedback
Create a secondary database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryCursor SecondaryCursor(
    CursorConfig cfg
)
Visual Basic (Declaration)
Public Function SecondaryCursor ( _
    cfg As CursorConfig _
) As SecondaryCursor
Visual C++
public:
SecondaryCursor^ SecondaryCursor(
    CursorConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.

Return Value

A newly created cursor

See Also

SecondaryDatabase Class
SecondaryCursor Overload


SecondaryCursor Method (Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.SecondaryCursor Method (Transaction)
SecondaryDatabase Class See Also Send Feedback
Create a transactionally protected secondary database cursor.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryCursor SecondaryCursor(
    Transaction txn
)
Visual Basic (Declaration)
Public Function SecondaryCursor ( _
    txn As Transaction _
) As SecondaryCursor
Visual C++
public:
SecondaryCursor^ SecondaryCursor(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

SecondaryDatabase Class
SecondaryCursor Overload


SecondaryCursor Method (CursorConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.SecondaryCursor Method (CursorConfig, Transaction)
SecondaryDatabase Class See Also Send Feedback
Create a transactionally protected secondary database cursor with the given configuration.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryCursor SecondaryCursor(
    CursorConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Function SecondaryCursor ( _
    cfg As CursorConfig, _
    txn As Transaction _
) As SecondaryCursor
Visual C++
public:
SecondaryCursor^ SecondaryCursor(
    CursorConfig^ cfg,
    Transaction^ txn
)

Parameters

cfg
Type: BerkeleyDB..::.CursorConfig
The configuration properties for the cursor.
txn
Type: BerkeleyDB..::.Transaction
The transaction context in which the cursor may be used.

Return Value

A newly created cursor

See Also

SecondaryDatabase Class
SecondaryCursor Overload


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Truncate Method
SecondaryDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class
SecondaryDatabase Members


SecondaryDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabase Properties
SecondaryDatabase Class See Also Send Feedback

The SecondaryDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryDatabase Class


KeyGen Property

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.KeyGen Property
SecondaryDatabase Class See Also Send Feedback
The delegate that creates the set of secondary keys corresponding to a given primary key and data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryKeyGenDelegate KeyGen { get; private set; }
Visual Basic (Declaration)
Public Property KeyGen As SecondaryKeyGenDelegate
Visual C++
public:
property SecondaryKeyGenDelegate^ KeyGen {
    SecondaryKeyGenDelegate^ get ();
    void set (SecondaryKeyGenDelegate^ value);
}

See Also

SecondaryDatabase Class


Nullifier Property

[image]

Berkeley DB .NET API Documentation
SecondaryDatabase..::.Nullifier Property
SecondaryDatabase Class See Also Send Feedback
The nullifying function used to set the foreign key to null.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ForeignKeyNullifyDelegate Nullifier { get; private set; }
Visual Basic (Declaration)
Public Property Nullifier As ForeignKeyNullifyDelegate
Visual C++
public:
property ForeignKeyNullifyDelegate^ Nullifier {
    ForeignKeyNullifyDelegate^ get ();
    void set (ForeignKeyNullifyDelegate^ value);
}

See Also

SecondaryDatabase Class


SecondaryDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for SecondaryDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryDatabaseConfig : DatabaseConfig
Visual Basic (Declaration)
Public Class SecondaryDatabaseConfig _
    Inherits DatabaseConfig
Visual C++
public ref class SecondaryDatabaseConfig : public DatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.SecondaryDatabaseConfig
BerkeleyDB..::.SecondaryBTreeDatabaseConfig
BerkeleyDB..::.SecondaryHashDatabaseConfig
BerkeleyDB..::.SecondaryQueueDatabaseConfig
BerkeleyDB..::.SecondaryRecnoDatabaseConfig

See Also

SecondaryDatabaseConfig Members


SecondaryDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig Members
SecondaryDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The SecondaryDatabaseConfig type exposes the following members.

Constructors

Name | Description
SecondaryDatabaseConfig | Instantiate a new SecondaryDatabaseConfig object, with the default configuration settings.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
ImmutableKey | If true, the secondary key is immutable.
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive.
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ForeignKeyDatabase | The database used to check the foreign key integrity constraint.
ForeignKeyNullfier | The nullifying function used to set the foreign key to null.
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair.
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary.

See Also

SecondaryDatabaseConfig Class


SecondaryDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig Constructor
SecondaryDatabaseConfig Class See Also Send Feedback
Instantiate a new SecondaryDatabaseConfig object, with the default configuration settings.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryDatabaseConfig(
    Database PrimaryDB,
    SecondaryKeyGenDelegate KeyGenFunc
)
Visual Basic (Declaration)
Public Sub New ( _
    PrimaryDB As Database, _
    KeyGenFunc As SecondaryKeyGenDelegate _
)
Visual C++
public:
SecondaryDatabaseConfig(
    Database^ PrimaryDB,
    SecondaryKeyGenDelegate^ KeyGenFunc
)

Parameters

PrimaryDB
Type: BerkeleyDB..::.Database
KeyGenFunc
Type: BerkeleyDB..::.SecondaryKeyGenDelegate

See Also

SecondaryDatabaseConfig Class


SecondaryDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig Fields
SecondaryDatabaseConfig Class See Also Send Feedback

The SecondaryDatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
ImmutableKey | If true, the secondary key is immutable.
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive.
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

See Also

SecondaryDatabaseConfig Class


ImmutableKey Field

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.ImmutableKey Field
SecondaryDatabaseConfig Class See Also Send Feedback
If true, the secondary key is immutable.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ImmutableKey
Visual Basic (Declaration)
Public ImmutableKey As Boolean
Visual C++
public:
bool ImmutableKey

Remarks

This setting can be used to optimize updates when the secondary key in a primary record is never changed after the primary record is inserted. For immutable secondary keys, a best effort is made to avoid calling the secondary callback function when primary records are updated. This optimization may reduce the overhead of update operations significantly if the callback function is expensive.

Be sure to specify this setting only if the secondary key in the primary record is never changed. If this rule is violated, the secondary index will become corrupted, that is, it will become out of sync with the primary.

See Also

SecondaryDatabaseConfig Class


Populate Field

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.Populate Field
SecondaryDatabaseConfig Class See Also Send Feedback
If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Populate
Visual Basic (Declaration)
Public Populate As Boolean
Visual C++
public:
bool Populate

Remarks

If the secondary database has been opened in an environment configured with transactions, the entire secondary index creation is performed in the context of a single transaction.

Care should be taken not to use a newly-populated secondary database in another thread of control until Open(String, SecondaryDatabaseConfig) has returned successfully in the first thread.

If transactions are not being used, care should be taken not to modify a primary database being used to populate a secondary database, in another thread of control, until Open(String, SecondaryDatabaseConfig) has returned successfully in the first thread. If transactions are being used, Berkeley DB performs appropriate locking and the application need not do any special operation ordering.

See Also

SecondaryDatabaseConfig Class


SecondaryDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig Methods
SecondaryDatabaseConfig Class See Also Send Feedback

The SecondaryDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecondaryDatabaseConfig Class


SetForeignKeyConstraint Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.SetForeignKeyConstraint Method
SecondaryDatabaseConfig Class See Also Send Feedback

Overload List

Name | Description
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction) | Specify the action taken when a referenced record in the foreign key database is deleted.
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction, ForeignKeyNullifyDelegate) | Specify the action taken when a referenced record in the foreign key database is deleted.

See Also

SecondaryDatabaseConfig Class
SecondaryDatabaseConfig Members


SetForeignKeyConstraint Method (Database, ForeignKeyDeleteAction)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.SetForeignKeyConstraint Method (Database, ForeignKeyDeleteAction)
SecondaryDatabaseConfig Class See Also Send Feedback
Specify the action taken when a referenced record in the foreign key database is deleted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetForeignKeyConstraint(
    Database ForeignDB,
    ForeignKeyDeleteAction OnDelete
)
Visual Basic (Declaration)
Public Sub SetForeignKeyConstraint ( _
    ForeignDB As Database, _
    OnDelete As ForeignKeyDeleteAction _
)
Visual C++
public:
void SetForeignKeyConstraint(
    Database^ ForeignDB,
    ForeignKeyDeleteAction OnDelete
)

Parameters

ForeignDB
Type: BerkeleyDB..::.Database
The foreign key database.
OnDelete
Type: BerkeleyDB..::.ForeignKeyDeleteAction
The action taken when a referenced record is deleted.

See Also

SecondaryDatabaseConfig Class
SetForeignKeyConstraint Overload


SetForeignKeyConstraint Method (Database, ForeignKeyDeleteAction, ForeignKeyNullifyDelegate)

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.SetForeignKeyConstraint Method (Database, ForeignKeyDeleteAction, ForeignKeyNullifyDelegate)
SecondaryDatabaseConfig Class See Also Send Feedback
Specify the action taken when a referenced record in the foreign key database is deleted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetForeignKeyConstraint(
    Database ForeignDB,
    ForeignKeyDeleteAction OnDelete,
    ForeignKeyNullifyDelegate NullifyFunc
)
Visual Basic (Declaration)
Public Sub SetForeignKeyConstraint ( _
    ForeignDB As Database, _
    OnDelete As ForeignKeyDeleteAction, _
    NullifyFunc As ForeignKeyNullifyDelegate _
)
Visual C++
public:
void SetForeignKeyConstraint(
    Database^ ForeignDB,
    ForeignKeyDeleteAction OnDelete,
    ForeignKeyNullifyDelegate^ NullifyFunc
)

Parameters

ForeignDB
Type: BerkeleyDB..::.Database
The foreign key database.
OnDelete
Type: BerkeleyDB..::.ForeignKeyDeleteAction
The action taken when a reference record is deleted.
NullifyFunc
Type: BerkeleyDB..::.ForeignKeyNullifyDelegate
When OnDelete is NULLIFY, NullifyFunc is used to set the foreign key to null.

See Also

SecondaryDatabaseConfig Class
SetForeignKeyConstraint Overload


SecondaryDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig Properties
SecondaryDatabaseConfig Class See Also Send Feedback

The SecondaryDatabaseConfig type exposes the following members.

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ForeignKeyDatabase | The database used to check the foreign key integrity constraint.
ForeignKeyNullfier | The nullifying function used to set the foreign key to null.
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair.
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary.

See Also

SecondaryDatabaseConfig Class


ForeignKeyDatabase Property

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.ForeignKeyDatabase Property
SecondaryDatabaseConfig Class See Also Send Feedback
The database used to check the foreign key integrity constraint.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Database ForeignKeyDatabase { get; }
Visual Basic (Declaration)
Public ReadOnly Property ForeignKeyDatabase As Database
Visual C++
public:
property Database^ ForeignKeyDatabase {
    Database^ get ();
}

See Also

SecondaryDatabaseConfig Class


ForeignKeyNullfier Property

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.ForeignKeyNullfier Property
SecondaryDatabaseConfig Class See Also Send Feedback
The nullifying function used to set the foreign key to null.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ForeignKeyNullifyDelegate ForeignKeyNullfier { get; }
Visual Basic (Declaration)
Public ReadOnly Property ForeignKeyNullfier As ForeignKeyNullifyDelegate
Visual C++
public:
property ForeignKeyNullifyDelegate^ ForeignKeyNullfier {
    ForeignKeyNullifyDelegate^ get ();
}

See Also

SecondaryDatabaseConfig Class


KeyGen Property

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.KeyGen Property
SecondaryDatabaseConfig Class See Also Send Feedback
The delegate that creates the set of secondary keys corresponding to a given primary key and data pair.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryKeyGenDelegate KeyGen { get; set; }
Visual Basic (Declaration)
Public Property KeyGen As SecondaryKeyGenDelegate
Visual C++
public:
property SecondaryKeyGenDelegate^ KeyGen {
    SecondaryKeyGenDelegate^ get ();
    void set (SecondaryKeyGenDelegate^ value);
}

Remarks

KeyGen may be null if both Primary.ReadOnly and ReadOnly are true.

See Also

SecondaryDatabaseConfig Class


OnForeignKeyDelete Property

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.OnForeignKeyDelete Property
SecondaryDatabaseConfig Class See Also Send Feedback
The action taken when a referenced record in ForeignKeyDatabase is deleted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ForeignKeyDeleteAction OnForeignKeyDelete { get; }
Visual Basic (Declaration)
Public ReadOnly Property OnForeignKeyDelete As ForeignKeyDeleteAction
Visual C++
public:
property ForeignKeyDeleteAction OnForeignKeyDelete {
    ForeignKeyDeleteAction get ();
}

See Also

SecondaryDatabaseConfig Class


Primary Property

[image]

Berkeley DB .NET API Documentation
SecondaryDatabaseConfig..::.Primary Property
SecondaryDatabaseConfig Class See Also Send Feedback
All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Database Primary { get; set; }
Visual Basic (Declaration)
Public Property Primary As Database
Visual C++
public:
property Database^ Primary {
    Database^ get ();
    void set (Database^ value);
}

Remarks

As primary keys must be unique for secondary indices to work, Primary must have been configured with NONE.

See Also

SecondaryDatabaseConfig Class


SecondaryHashDatabase Class

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase Class
Members See Also Send Feedback
A class representing a SecondaryHashDatabase. The Hash format is an extensible, dynamic hashing scheme.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryHashDatabase : SecondaryDatabase
Visual Basic (Declaration)
Public Class SecondaryHashDatabase _
    Inherits SecondaryDatabase
Visual C++
public ref class SecondaryHashDatabase : public SecondaryDatabase

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.SecondaryDatabase
BerkeleyDB..::.SecondaryHashDatabase

See Also

SecondaryHashDatabase Members


SecondaryHashDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase Members
SecondaryHashDatabase Class Methods Properties See Also Send Feedback

The SecondaryHashDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Compare | The secondary Hash key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
DupCompare | The duplicate data item comparison function.
Duplicates | Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FillFactor | The desired density within the hash table.
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HashFunction | A user-defined hash function; if no hash function is specified, a default hash function is used.
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
TableSize | An estimate of the final size of the hash table.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class


SecondaryHashDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase Methods
SecondaryHashDatabase Class See Also Send Feedback

The SecondaryHashDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

See Also

SecondaryHashDatabase Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Close Method
SecondaryHashDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Cursor Method
SecondaryHashDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig) | Create a database cursor with the given configuration. (Inherited from BaseDatabase.)
Cursor(Transaction) | Create a transactionally protected database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Delete Method
SecondaryHashDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Exists Method
SecondaryHashDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


Get Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Get Method
SecondaryHashDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.GetBoth Method
SecondaryHashDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Open Method
SecondaryHashDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, SecondaryHashDatabaseConfig) | Instantiate a new SecondaryHashDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, SecondaryHashDatabaseConfig, Transaction) | Instantiate a new SecondaryHashDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, String, SecondaryHashDatabaseConfig) | Instantiate a new SecondaryHashDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, String, SecondaryHashDatabaseConfig, Transaction) | Instantiate a new SecondaryHashDatabase object, open the database represented by Filename and associate the database with the primary index.

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


Open Method (String, SecondaryHashDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Open Method (String, SecondaryHashDatabaseConfig)
SecondaryHashDatabase Class See Also Send Feedback
Instantiate a new SecondaryHashDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryHashDatabase Open(
    string Filename,
    SecondaryHashDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryHashDatabaseConfig _
) As SecondaryHashDatabase
Visual C++
public:
static SecondaryHashDatabase^ Open(
    String^ Filename,
    SecondaryHashDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.SecondaryHashDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryHashDatabase Class
Open Overload


Open Method (String, SecondaryHashDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Open Method (String, SecondaryHashDatabaseConfig, Transaction)
SecondaryHashDatabase Class See Also Send Feedback
Instantiate a new SecondaryHashDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryHashDatabase Open(
    string Filename,
    SecondaryHashDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryHashDatabaseConfig, _
    txn As Transaction _
) As SecondaryHashDatabase
Visual C++
public:
static SecondaryHashDatabase^ Open(
    String^ Filename,
    SecondaryHashDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.SecondaryHashDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

SecondaryHashDatabase Class
Open Overload


Open Method (String, String, SecondaryHashDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Open Method (String, String, SecondaryHashDatabaseConfig)
SecondaryHashDatabase Class See Also Send Feedback
Instantiate a new SecondaryHashDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryHashDatabase Open(
    string Filename,
    string DatabaseName,
    SecondaryHashDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As SecondaryHashDatabaseConfig _
) As SecondaryHashDatabase
Visual C++
public:
static SecondaryHashDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    SecondaryHashDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.SecondaryHashDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and will be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryHashDatabase Class
Open Overload


Open Method (String, String, SecondaryHashDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Open Method (String, String, SecondaryHashDatabaseConfig, Transaction)
SecondaryHashDatabase Class See Also Send Feedback
Instantiate a new SecondaryHashDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryHashDatabase Open(
    string Filename,
    string DatabaseName,
    SecondaryHashDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As SecondaryHashDatabaseConfig, _
    txn As Transaction _
) As SecondaryHashDatabase
Visual C++
public:
static SecondaryHashDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    SecondaryHashDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.SecondaryHashDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and will be replicated to client sites in any replication group.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

SecondaryHashDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.PrintFastStats Method
SecondaryHashDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.PrintStats Method
SecondaryHashDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


SecondaryCursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.SecondaryCursor Method
SecondaryHashDatabase Class See Also Send Feedback

Overload List

Name | Description
SecondaryCursor()()() | Create a secondary database cursor. (Inherited from SecondaryDatabase.)
SecondaryCursor(CursorConfig) | Create a secondary database cursor with the given configuration. (Inherited from SecondaryDatabase.)
SecondaryCursor(Transaction) | Create a transactionally protected secondary database cursor. (Inherited from SecondaryDatabase.)
SecondaryCursor(CursorConfig, Transaction) | Create a transactionally protected secondary database cursor with the given configuration. (Inherited from SecondaryDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Truncate Method
SecondaryHashDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class
SecondaryHashDatabase Members


SecondaryHashDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase Properties
SecondaryHashDatabase Class See Also Send Feedback

The SecondaryHashDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Compare | The secondary Hash key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
DupCompare | The duplicate data item comparison function.
Duplicates | Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FillFactor | The desired density within the hash table.
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HashFunction | A user-defined hash function; if no hash function is specified, a default hash function is used.
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabase.)
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabase.)
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
TableSize | An estimate of the final size of the hash table.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryHashDatabase Class


Compare Property

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Compare Property
SecondaryHashDatabase Class See Also Send Feedback
The secondary Hash key comparison function. The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate Compare { get; private set; }
Visual Basic (Declaration)
Public Property Compare As EntryComparisonDelegate
Visual C++
public:
property EntryComparisonDelegate^ Compare {
    EntryComparisonDelegate^ get ();
    void set (EntryComparisonDelegate^ value);
}

See Also

SecondaryHashDatabase Class


DupCompare Property

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.DupCompare Property
SecondaryHashDatabase Class See Also Send Feedback
The duplicate data item comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate DupCompare { get; private set; }
Visual Basic (Declaration)
Public Property DupCompare As EntryComparisonDelegate
Visual C++
public:
property EntryComparisonDelegate^ DupCompare {
    EntryComparisonDelegate^ get ();
    void set (EntryComparisonDelegate^ value);
}

See Also

SecondaryHashDatabase Class


Duplicates Property

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.Duplicates Property
SecondaryHashDatabase Class See Also Send Feedback
Whether the insertion of duplicate data items in the database is permitted, and whether duplicates items are sorted.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DuplicatesPolicy Duplicates { get; }
Visual Basic (Declaration)
Public ReadOnly Property Duplicates As DuplicatesPolicy
Visual C++
public:
property DuplicatesPolicy Duplicates {
    DuplicatesPolicy get ();
}

See Also

SecondaryHashDatabase Class


FillFactor Property

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.FillFactor Property
SecondaryHashDatabase Class See Also Send Feedback
The desired density within the hash table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FillFactor { get; }
Visual Basic (Declaration)
Public ReadOnly Property FillFactor As UInteger
Visual C++
public:
property unsigned int FillFactor {
    unsigned int get ();
}

See Also

SecondaryHashDatabase Class


HashFunction Property

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.HashFunction Property
SecondaryHashDatabase Class See Also Send Feedback
A user-defined hash function; if no hash function is specified, a default hash function is used.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashFunctionDelegate HashFunction { get; private set; }
Visual Basic (Declaration)
Public Property HashFunction As HashFunctionDelegate
Visual C++
public:
property HashFunctionDelegate^ HashFunction {
    HashFunctionDelegate^ get ();
    void set (HashFunctionDelegate^ value);
}

See Also

SecondaryHashDatabase Class


TableSize Property

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabase..::.TableSize Property
SecondaryHashDatabase Class See Also Send Feedback
An estimate of the final size of the hash table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TableSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property TableSize As UInteger
Visual C++
public:
property unsigned int TableSize {
    unsigned int get ();
}

See Also

SecondaryHashDatabase Class


SecondaryHashDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for SecondaryHashDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryHashDatabaseConfig : SecondaryDatabaseConfig
Visual Basic (Declaration)
Public Class SecondaryHashDatabaseConfig _
    Inherits SecondaryDatabaseConfig
Visual C++
public ref class SecondaryHashDatabaseConfig : public SecondaryDatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.SecondaryDatabaseConfig
BerkeleyDB..::.SecondaryHashDatabaseConfig

See Also

SecondaryHashDatabaseConfig Members


SecondaryHashDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig Members
SecondaryHashDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The SecondaryHashDatabaseConfig type exposes the following members.

Constructors

Name | Description
SecondaryHashDatabaseConfig | Instantiate a new SecondaryHashDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Compare | The Secondary Hash key comparison function.
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
DuplicateCompare | The duplicate data item comparison function.
Duplicates | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
HashFunction | A user-defined hash function; if no hash function is specified, a default hash function is used.
ImmutableKey | If true, the secondary key is immutable. (Inherited from SecondaryDatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive. (Inherited from SecondaryDatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
FillFactor | The desired density within the hash table. If no value is specified, the fill factor is selected dynamically as pages are filled.
ForeignKeyDatabase | The database used to check the foreign key integrity constraint. (Inherited from SecondaryDatabaseConfig.)
ForeignKeyNullfier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabaseConfig.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabaseConfig.)
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted. (Inherited from SecondaryDatabaseConfig.)
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary. (Inherited from SecondaryDatabaseConfig.)
TableSize | An estimate of the final size of the hash table.

See Also

SecondaryHashDatabaseConfig Class


SecondaryHashDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig Constructor
SecondaryHashDatabaseConfig Class See Also Send Feedback
Instantiate a new SecondaryHashDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryHashDatabaseConfig(
    Database PrimaryDB,
    SecondaryKeyGenDelegate KeyGenFunc
)
Visual Basic (Declaration)
Public Sub New ( _
    PrimaryDB As Database, _
    KeyGenFunc As SecondaryKeyGenDelegate _
)
Visual C++
public:
SecondaryHashDatabaseConfig(
    Database^ PrimaryDB,
    SecondaryKeyGenDelegate^ KeyGenFunc
)

Parameters

PrimaryDB
Type: BerkeleyDB..::.Database
KeyGenFunc
Type: BerkeleyDB..::.SecondaryKeyGenDelegate

See Also

SecondaryHashDatabaseConfig Class


SecondaryHashDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig Fields
SecondaryHashDatabaseConfig Class See Also Send Feedback

The SecondaryHashDatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Compare | The Secondary Hash key comparison function.
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
DuplicateCompare | The duplicate data item comparison function.
Duplicates | Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
HashFunction | A user-defined hash function; if no hash function is specified, a default hash function is used.
ImmutableKey | If true, the secondary key is immutable. (Inherited from SecondaryDatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive. (Inherited from SecondaryDatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

See Also

SecondaryHashDatabaseConfig Class


Compare Field

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig..::.Compare Field
SecondaryHashDatabaseConfig Class See Also Send Feedback
The Secondary Hash key comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate Compare
Visual Basic (Declaration)
Public Compare As EntryComparisonDelegate
Visual C++
public:
EntryComparisonDelegate^ Compare

Remarks

The comparison function is called whenever it is necessary to compare a key specified by the application with a key currently stored in the tree.

If no comparison function is specified, the keys are compared lexically, with shorter keys collating before longer keys.

If the database already exists, the comparison function must be the same as that historically used to create the database or corruption can occur.

See Also

SecondaryHashDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig..::.Creation Field
SecondaryHashDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, SecondaryHashDatabaseConfig) fails.

See Also

SecondaryHashDatabaseConfig Class


DuplicateCompare Field

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig..::.DuplicateCompare Field
SecondaryHashDatabaseConfig Class See Also Send Feedback
The duplicate data item comparison function.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public EntryComparisonDelegate DuplicateCompare
Visual Basic (Declaration)
Public DuplicateCompare As EntryComparisonDelegate
Visual C++
public:
EntryComparisonDelegate^ DuplicateCompare

Remarks

The comparison function is called whenever it is necessary to compare a data item specified by the application with a data item currently stored in the database. Setting DuplicateCompare implies setting Duplicates to SORTED.

If no comparison function is specified, the data items are compared lexically, with shorter data items collating before longer data items.

If the database already exists when Open(String, SecondaryHashDatabaseConfig) is called, the delegate must be the same as that historically used to create the database or corruption can occur.

See Also

SecondaryHashDatabaseConfig Class


Duplicates Field

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig..::.Duplicates Field
SecondaryHashDatabaseConfig Class See Also Send Feedback
Policy for duplicate data items in the database. Allows a key/data pair to be inserted into the database even if the key already exists.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DuplicatesPolicy Duplicates
Visual Basic (Declaration)
Public Duplicates As DuplicatesPolicy
Visual C++
public:
DuplicatesPolicy Duplicates

Remarks

The ordering of duplicates in the database for UNSORTED is determined by the order of insertion, unless the ordering is otherwise specified by use of a cursor operation or a duplicate sort function. The ordering of duplicates in the database for SORTED is determined by the duplicate comparison function. If the application does not specify a comparison function using DuplicateCompare, a default lexical comparison is used.

SORTED is preferred to UNSORTED for performance reasons. UNSORTED should only be used by applications wanting to order duplicate data items manually.

If the database already exists, the value of Duplicates must be the same as the existing database or an error is returned.

See Also

SecondaryHashDatabaseConfig Class


HashFunction Field

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig..::.HashFunction Field
SecondaryHashDatabaseConfig Class See Also Send Feedback
A user-defined hash function; if no hash function is specified, a default hash function is used.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public HashFunctionDelegate HashFunction
Visual Basic (Declaration)
Public HashFunction As HashFunctionDelegate
Visual C++
public:
HashFunctionDelegate^ HashFunction

Remarks

Because no hash function performs equally well on all possible data, the user may find that the built-in hash function performs poorly with a particular data set.

If the database already exists, HashFunction must be the same as that historically used to create the database or corruption can occur.

See Also

SecondaryHashDatabaseConfig Class


SecondaryHashDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig Methods
SecondaryHashDatabaseConfig Class See Also Send Feedback

The SecondaryHashDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecondaryHashDatabaseConfig Class


SetForeignKeyConstraint Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig..::.SetForeignKeyConstraint Method
SecondaryHashDatabaseConfig Class See Also Send Feedback

Overload List

Name | Description
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction) | Specify the action taken when a referenced record in the foreign key database is deleted. (Inherited from SecondaryDatabaseConfig.)
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction, ForeignKeyNullifyDelegate) | Specify the action taken when a referenced record in the foreign key database is deleted. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryHashDatabaseConfig Class
SecondaryHashDatabaseConfig Members


SecondaryHashDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig Properties
SecondaryHashDatabaseConfig Class See Also Send Feedback

The SecondaryHashDatabaseConfig type exposes the following members.

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
FillFactor | The desired density within the hash table. If no value is specified, the fill factor is selected dynamically as pages are filled.
ForeignKeyDatabase | The database used to check the foreign key integrity constraint. (Inherited from SecondaryDatabaseConfig.)
ForeignKeyNullfier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabaseConfig.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabaseConfig.)
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted. (Inherited from SecondaryDatabaseConfig.)
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary. (Inherited from SecondaryDatabaseConfig.)
TableSize | An estimate of the final size of the hash table.

See Also

SecondaryHashDatabaseConfig Class


FillFactor Property

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig..::.FillFactor Property
SecondaryHashDatabaseConfig Class See Also Send Feedback
The desired density within the hash table. If no value is specified, the fill factor is selected dynamically as pages are filled.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint FillFactor { get; set; }
Visual Basic (Declaration)
Public Property FillFactor As UInteger
Visual C++
public:
property unsigned int FillFactor {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The density is an approximation of the number of keys allowed to accumulate in any one bucket, determining when the hash table grows or shrinks. If you know the average sizes of the keys and data in your data set, setting the fill factor can enhance performance. A reasonable rule computing fill factor is to set it to the following:

(pagesize - 32) / (average_key_size + average_data_size + 8)

If the database already exists, this setting is ignored.

See Also

SecondaryHashDatabaseConfig Class


TableSize Property

[image]

Berkeley DB .NET API Documentation
SecondaryHashDatabaseConfig..::.TableSize Property
SecondaryHashDatabaseConfig Class See Also Send Feedback
An estimate of the final size of the hash table.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TableSize { get; set; }
Visual Basic (Declaration)
Public Property TableSize As UInteger
Visual C++
public:
property unsigned int TableSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

In order for the estimate to be used when creating the database, FillFactor must also be set. If the estimate or fill factor are not set or are set too low, hash tables still expand gracefully as keys are entered, although a slight performance degradation may be noticed.

If the database already exists, this setting is ignored.

See Also

SecondaryHashDatabaseConfig Class


SecondaryKeyGenDelegate Delegate

[image]

Berkeley DB .NET API Documentation
SecondaryKeyGenDelegate Delegate
See Also Send Feedback
The function that creates the set of secondary keys corresponding to a given primary key and data pair. To create multiple secondary keys, return a MultipleDatabaseEntry.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate DatabaseEntry SecondaryKeyGenDelegate(
    DatabaseEntry key,
    DatabaseEntry data
)
Visual Basic (Declaration)
Public Delegate Function SecondaryKeyGenDelegate ( _
    key As DatabaseEntry, _
    data As DatabaseEntry _
) As DatabaseEntry
Visual C++
public delegate DatabaseEntry^ SecondaryKeyGenDelegate(
    DatabaseEntry^ key,
    DatabaseEntry^ data
)

Parameters

key
Type: BerkeleyDB..::.DatabaseEntry
The primary key
data
Type: BerkeleyDB..::.DatabaseEntry
The primary data item

Return Value

The secondary key(s)

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


SecondaryQueueDatabase Class

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase Class
Members See Also Send Feedback
A class representing a SecondaryQueueDatabase. The Queue format supports fast access to fixed-length records accessed sequentially or by logical record number.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryQueueDatabase : SecondaryDatabase
Visual Basic (Declaration)
Public Class SecondaryQueueDatabase _
    Inherits SecondaryDatabase
Visual C++
public ref class SecondaryQueueDatabase : public SecondaryDatabase

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.SecondaryDatabase
BerkeleyDB..::.SecondaryQueueDatabase

See Also

SecondaryQueueDatabase Members


SecondaryQueueDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase Members
SecondaryQueueDatabase Class Methods Properties See Also Send Feedback

The SecondaryQueueDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
ExtentSize | The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabase.)
Length | The length of records in the database.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabase.)
PadByte | The padding character for short, fixed-length records.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class


SecondaryQueueDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase Methods
SecondaryQueueDatabase Class See Also Send Feedback

The SecondaryQueueDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

See Also

SecondaryQueueDatabase Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Close Method
SecondaryQueueDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Cursor Method
SecondaryQueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig) | Create a database cursor with the given configuration. (Inherited from BaseDatabase.)
Cursor(Transaction) | Create a transactionally protected database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Delete Method
SecondaryQueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Exists Method
SecondaryQueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


Get Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Get Method
SecondaryQueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.GetBoth Method
SecondaryQueueDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Open Method
SecondaryQueueDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, SecondaryQueueDatabaseConfig) | Instantiate a new SecondaryQueueDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, SecondaryQueueDatabaseConfig, Transaction) | Instantiate a new SecondaryQueueDatabase object, open the database represented by Filename and associate the database with the primary index.

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


Open Method (String, SecondaryQueueDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Open Method (String, SecondaryQueueDatabaseConfig)
SecondaryQueueDatabase Class See Also Send Feedback
Instantiate a new SecondaryQueueDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryQueueDatabase Open(
    string Filename,
    SecondaryQueueDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryQueueDatabaseConfig _
) As SecondaryQueueDatabase
Visual C++
public:
static SecondaryQueueDatabase^ Open(
    String^ Filename,
    SecondaryQueueDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.SecondaryQueueDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryQueueDatabase Class
Open Overload


Open Method (String, SecondaryQueueDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Open Method (String, SecondaryQueueDatabaseConfig, Transaction)
SecondaryQueueDatabase Class See Also Send Feedback
Instantiate a new SecondaryQueueDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryQueueDatabase Open(
    string Filename,
    SecondaryQueueDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryQueueDatabaseConfig, _
    txn As Transaction _
) As SecondaryQueueDatabase
Visual C++
public:
static SecondaryQueueDatabase^ Open(
    String^ Filename,
    SecondaryQueueDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.SecondaryQueueDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

SecondaryQueueDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.PrintFastStats Method
SecondaryQueueDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.PrintStats Method
SecondaryQueueDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


SecondaryCursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.SecondaryCursor Method
SecondaryQueueDatabase Class See Also Send Feedback

Overload List

Name | Description
SecondaryCursor()()() | Create a secondary database cursor. (Inherited from SecondaryDatabase.)
SecondaryCursor(CursorConfig) | Create a secondary database cursor with the given configuration. (Inherited from SecondaryDatabase.)
SecondaryCursor(Transaction) | Create a transactionally protected secondary database cursor. (Inherited from SecondaryDatabase.)
SecondaryCursor(CursorConfig, Transaction) | Create a transactionally protected secondary database cursor with the given configuration. (Inherited from SecondaryDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Truncate Method
SecondaryQueueDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class
SecondaryQueueDatabase Members


SecondaryQueueDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase Properties
SecondaryQueueDatabase Class See Also Send Feedback

The SecondaryQueueDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
ExtentSize | The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabase.)
Length | The length of records in the database.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabase.)
PadByte | The padding character for short, fixed-length records.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryQueueDatabase Class


ExtentSize Property

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.ExtentSize Property
SecondaryQueueDatabase Class See Also Send Feedback
The size of the extents used to hold pages in a QueueDatabase, specified as a number of pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ExtentSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property ExtentSize As UInteger
Visual C++
public:
property unsigned int ExtentSize {
    unsigned int get ();
}

See Also

SecondaryQueueDatabase Class


Length Property

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.Length Property
SecondaryQueueDatabase Class See Also Send Feedback
The length of records in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As UInteger
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
}

See Also

SecondaryQueueDatabase Class


PadByte Property

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabase..::.PadByte Property
SecondaryQueueDatabase Class See Also Send Feedback
The padding character for short, fixed-length records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int PadByte { get; }
Visual Basic (Declaration)
Public ReadOnly Property PadByte As Integer
Visual C++
public:
property int PadByte {
    int get ();
}

See Also

SecondaryQueueDatabase Class


SecondaryQueueDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for SecondaryQueueDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryQueueDatabaseConfig : SecondaryDatabaseConfig
Visual Basic (Declaration)
Public Class SecondaryQueueDatabaseConfig _
    Inherits SecondaryDatabaseConfig
Visual C++
public ref class SecondaryQueueDatabaseConfig : public SecondaryDatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.SecondaryDatabaseConfig
BerkeleyDB..::.SecondaryQueueDatabaseConfig

See Also

SecondaryQueueDatabaseConfig Members


SecondaryQueueDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig Members
SecondaryQueueDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The SecondaryQueueDatabaseConfig type exposes the following members.

Constructors

Name | Description
SecondaryQueueDatabaseConfig | Instantiate a new SecondaryQueueDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
ImmutableKey | If true, the secondary key is immutable. (Inherited from SecondaryDatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive. (Inherited from SecondaryDatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ExtentSize | The size of the extents used to hold pages in a SecondaryQueueDatabase, specified as a number of pages.
ForeignKeyDatabase | The database used to check the foreign key integrity constraint. (Inherited from SecondaryDatabaseConfig.)
ForeignKeyNullfier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabaseConfig.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabaseConfig.)
Length | Specify the length of records in the database.
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted. (Inherited from SecondaryDatabaseConfig.)
PadByte | The padding character for short, fixed-length records.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryQueueDatabaseConfig Class


SecondaryQueueDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig Constructor
SecondaryQueueDatabaseConfig Class See Also Send Feedback
Instantiate a new SecondaryQueueDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryQueueDatabaseConfig(
    Database PrimaryDB,
    SecondaryKeyGenDelegate KeyGenFunc
)
Visual Basic (Declaration)
Public Sub New ( _
    PrimaryDB As Database, _
    KeyGenFunc As SecondaryKeyGenDelegate _
)
Visual C++
public:
SecondaryQueueDatabaseConfig(
    Database^ PrimaryDB,
    SecondaryKeyGenDelegate^ KeyGenFunc
)

Parameters

PrimaryDB
Type: BerkeleyDB..::.Database
KeyGenFunc
Type: BerkeleyDB..::.SecondaryKeyGenDelegate

See Also

SecondaryQueueDatabaseConfig Class


SecondaryQueueDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig Fields
SecondaryQueueDatabaseConfig Class See Also Send Feedback

The SecondaryQueueDatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
ImmutableKey | If true, the secondary key is immutable. (Inherited from SecondaryDatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive. (Inherited from SecondaryDatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

See Also

SecondaryQueueDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig..::.Creation Field
SecondaryQueueDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, SecondaryQueueDatabaseConfig) fails.

See Also

SecondaryQueueDatabaseConfig Class


SecondaryQueueDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig Methods
SecondaryQueueDatabaseConfig Class See Also Send Feedback

The SecondaryQueueDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecondaryQueueDatabaseConfig Class


SetForeignKeyConstraint Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig..::.SetForeignKeyConstraint Method
SecondaryQueueDatabaseConfig Class See Also Send Feedback

Overload List

Name | Description
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction) | Specify the action taken when a referenced record in the foreign key database is deleted. (Inherited from SecondaryDatabaseConfig.)
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction, ForeignKeyNullifyDelegate) | Specify the action taken when a referenced record in the foreign key database is deleted. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryQueueDatabaseConfig Class
SecondaryQueueDatabaseConfig Members


SecondaryQueueDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig Properties
SecondaryQueueDatabaseConfig Class See Also Send Feedback

The SecondaryQueueDatabaseConfig type exposes the following members.

Properties

Name | Description
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ExtentSize | The size of the extents used to hold pages in a SecondaryQueueDatabase, specified as a number of pages.
ForeignKeyDatabase | The database used to check the foreign key integrity constraint. (Inherited from SecondaryDatabaseConfig.)
ForeignKeyNullfier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabaseConfig.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabaseConfig.)
Length | Specify the length of records in the database.
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted. (Inherited from SecondaryDatabaseConfig.)
PadByte | The padding character for short, fixed-length records.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryQueueDatabaseConfig Class


ExtentSize Property

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig..::.ExtentSize Property
SecondaryQueueDatabaseConfig Class See Also Send Feedback
The size of the extents used to hold pages in a SecondaryQueueDatabase, specified as a number of pages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint ExtentSize { get; set; }
Visual Basic (Declaration)
Public Property ExtentSize As UInteger
Visual C++
public:
property unsigned int ExtentSize {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Each extent is created as a separate physical file. If no extent size is set, the default behavior is to create only a single underlying database file.

For information on tuning the extent size, see Selecting a extent size in the Programmer's Reference Guide.

If the database already exists, this setting is ignored.

See Also

SecondaryQueueDatabaseConfig Class


Length Property

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig..::.Length Property
SecondaryQueueDatabaseConfig Class See Also Send Feedback
Specify the length of records in the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Length { get; set; }
Visual Basic (Declaration)
Public Property Length As UInteger
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

The record length must be enough smaller than PageSize that at least one record plus the database page's metadata information can fit on each database page.

Any records added to the database that are less than Length bytes long are automatically padded (see PadByte for more information).

Any attempt to insert records into the database that are greater than Length bytes long cause the call to fail immediately and return an error.

If the database already exists, this setting is ignored.

See Also

SecondaryQueueDatabaseConfig Class


PadByte Property

[image]

Berkeley DB .NET API Documentation
SecondaryQueueDatabaseConfig..::.PadByte Property
SecondaryQueueDatabaseConfig Class See Also Send Feedback
The padding character for short, fixed-length records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int PadByte { get; set; }
Visual Basic (Declaration)
Public Property PadByte As Integer
Visual C++
public:
property int PadByte {
    int get ();
    void set (int value);
}

Remarks

If no pad character is specified, space characters (ASCII 0x20) are used for padding.

If the database already exists, this setting is ignored.

See Also

SecondaryQueueDatabaseConfig Class


SecondaryRecnoDatabase Class

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase Class
Members See Also Send Feedback
A class representing a RecnoDatabase. The Recno format supports fixed- or variable-length records, accessed sequentially or by logical record number, and optionally backed by a flat text file.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryRecnoDatabase : SecondaryDatabase
Visual Basic (Declaration)
Public Class SecondaryRecnoDatabase _
    Inherits SecondaryDatabase
Visual C++
public ref class SecondaryRecnoDatabase : public SecondaryDatabase

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.BaseDatabase
BerkeleyDB..::.SecondaryDatabase
BerkeleyDB..::.SecondaryRecnoDatabase

See Also

SecondaryRecnoDatabase Members


SecondaryRecnoDatabase Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase Members
SecondaryRecnoDatabase Class Methods Properties See Also Send Feedback

The SecondaryRecnoDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
BackingFile | The underlying source file for the Recno access method.
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
Delimiter | The delimiting byte used to mark the end of a record in BackingFile.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabase.)
Length | If using fixed-length, not byte-delimited records, the length of the records.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabase.)
PadByte | The padding character for short, fixed-length records.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Renumber | If true, the logical record numbers are mutable, and change as records are added to and deleted from the database.
Snapshot | If true, any BackingFile file is read in its entirety when Open(String, SecondaryRecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class


SecondaryRecnoDatabase Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase Methods
SecondaryRecnoDatabase Class See Also Send Feedback

The SecondaryRecnoDatabase type exposes the following members.

Methods

Name | Description
Close Overloaded.

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Cursor | Overloaded.
Delete | Overloaded.
Dispose
Release the resources held by this object, and close the database if it is still open.
(Inherited from BaseDatabase.)
Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
Exists | Overloaded.
Get | Overloaded.
GetBoth | Overloaded.
GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
GetType
Gets the type of the current instance.
(Inherited from Object.)
Open | Overloaded.
PrintFastStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
PrintStats Overloaded.
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.
SecondaryCursor | Overloaded.
Sync
Flush any cached information to disk.
(Inherited from BaseDatabase.)
ToString
Returns a string that represents the current object.
(Inherited from Object.)
Truncate Overloaded.
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

See Also

SecondaryRecnoDatabase Class


Close Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Close Method
SecondaryRecnoDatabase Class See Also Send Feedback

Although closing a database also closes any open cursors, it is recommended that applications explicitly close all their Cursor objects before closing the database. The reason why is that when the cursor is explicitly closed, the memory allocated for it is reclaimed; however, this does not happen if you close a database while cursors are still opened.

The same rule, for the same reasons, holds true for Transaction objects. Simply make sure you resolve all your transaction objects before closing your database handle.

Because key/data pairs are cached in-memory, applications should make a point to always either close database handles or sync their data to disk (using Sync()()() before exiting, to ensure that any data cached in main memory is reflected in the underlying file system.

When called on a secondary index's primary database, the primary should be closed only after all secondary indices referencing it have been closed.

When multiple threads use the object concurrently, only a single thread may call the Close method.

The object may not be accessed again after Close is called, regardless of its outcome.

Overload List

Name | Description
Close()()() | Flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)
Close(Boolean) | Optionally flush any cached database information to disk, close any open Cursor()()() objects, free any allocated resources, and close any underlying files. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


Cursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Cursor Method
SecondaryRecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Cursor()()() | Create a database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig) | Create a database cursor with the given configuration. (Inherited from BaseDatabase.)
Cursor(Transaction) | Create a transactionally protected database cursor. (Inherited from BaseDatabase.)
Cursor(CursorConfig, Transaction) | Create a transactionally protected database cursor with the given configuration. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


Delete Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Delete Method
SecondaryRecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Delete(DatabaseEntry) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)
Delete(DatabaseEntry, Transaction) | Remove key/data pairs from the database. If key is DatabaseEntry, the key/data pair associated with key is discarded from the database. In the presence of duplicate key values, all records associated with the designated key are discarded. If key is MultipleDatabaseEntry, delete multiple data items using keys from the buffer to which the key parameter refers. If key is MultipleKeyDatabaseEntry, delete multiple data items using keys and data from the buffer to which the key parameter refers. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


Exists Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Exists Method
SecondaryRecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Exists(DatabaseEntry) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction) | Check whether key appears in the database. (Inherited from BaseDatabase.)
Exists(DatabaseEntry, Transaction, LockingInfo) | Check whether key appears in the database. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


Get Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Get Method
SecondaryRecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Get(DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)
Get(DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. (Inherited from BaseDatabase.)
Get(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database. In the presence of duplicate key values, Get returns the first data item for key. If the data is a partial DatabaseEntry, PartialLen bytes starting PartialOffset bytes from the beginning of the retrieved data record are returned as if they comprise the entire record. If any or all of the specified bytes do not exist in the record, Get is successful, and any existing bytes are returned. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


GetBoth Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.GetBoth Method
SecondaryRecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
GetBoth(DatabaseEntry, DatabaseEntry) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)
GetBoth(DatabaseEntry, DatabaseEntry, Transaction, LockingInfo) | Retrieve a key/data pair from the database which matches key and data. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


Open Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Open Method
SecondaryRecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
Open(String, SecondaryRecnoDatabaseConfig) | Instantiate a new SecondaryRecnoDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, SecondaryRecnoDatabaseConfig, Transaction) | Instantiate a new SecondaryRecnoDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, String, SecondaryRecnoDatabaseConfig) | Instantiate a new SecondaryRecnoDatabase object, open the database represented by Filename and associate the database with the primary index.
Open(String, String, SecondaryRecnoDatabaseConfig, Transaction) | Instantiate a new SecondaryRecnoDatabase object, open the database represented by Filename and associate the database with the primary index.

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


Open Method (String, SecondaryRecnoDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Open Method (String, SecondaryRecnoDatabaseConfig)
SecondaryRecnoDatabase Class See Also Send Feedback
Instantiate a new SecondaryRecnoDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryRecnoDatabase Open(
    string Filename,
    SecondaryRecnoDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryRecnoDatabaseConfig _
) As SecondaryRecnoDatabase
Visual C++
public:
static SecondaryRecnoDatabase^ Open(
    String^ Filename,
    SecondaryRecnoDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.SecondaryRecnoDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryRecnoDatabase Class
Open Overload


Open Method (String, SecondaryRecnoDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Open Method (String, SecondaryRecnoDatabaseConfig, Transaction)
SecondaryRecnoDatabase Class See Also Send Feedback
Instantiate a new SecondaryRecnoDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryRecnoDatabase Open(
    string Filename,
    SecondaryRecnoDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    cfg As SecondaryRecnoDatabaseConfig, _
    txn As Transaction _
) As SecondaryRecnoDatabase
Visual C++
public:
static SecondaryRecnoDatabase^ Open(
    String^ Filename,
    SecondaryRecnoDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
cfg
Type: BerkeleyDB..::.SecondaryRecnoDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If Filename is null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

SecondaryRecnoDatabase Class
Open Overload


Open Method (String, String, SecondaryRecnoDatabaseConfig)

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Open Method (String, String, SecondaryRecnoDatabaseConfig)
SecondaryRecnoDatabase Class See Also Send Feedback
Instantiate a new SecondaryRecnoDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryRecnoDatabase Open(
    string Filename,
    string DatabaseName,
    SecondaryRecnoDatabaseConfig cfg
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As SecondaryRecnoDatabaseConfig _
) As SecondaryRecnoDatabase
Visual C++
public:
static SecondaryRecnoDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    SecondaryRecnoDatabaseConfig^ cfg
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.SecondaryRecnoDatabaseConfig
The database's configuration

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and will be replicated to client sites in any replication group.

If AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open.

See Also

SecondaryRecnoDatabase Class
Open Overload


Open Method (String, String, SecondaryRecnoDatabaseConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Open Method (String, String, SecondaryRecnoDatabaseConfig, Transaction)
SecondaryRecnoDatabase Class See Also Send Feedback
Instantiate a new SecondaryRecnoDatabase object, open the database represented by Filename and associate the database with the primary index.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static SecondaryRecnoDatabase Open(
    string Filename,
    string DatabaseName,
    SecondaryRecnoDatabaseConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Shared Function Open ( _
    Filename As String, _
    DatabaseName As String, _
    cfg As SecondaryRecnoDatabaseConfig, _
    txn As Transaction _
) As SecondaryRecnoDatabase
Visual C++
public:
static SecondaryRecnoDatabase^ Open(
    String^ Filename,
    String^ DatabaseName,
    SecondaryRecnoDatabaseConfig^ cfg,
    Transaction^ txn
)

Parameters

Filename
Type: System..::.String
The name of an underlying file used to back the database. In-memory databases never intended to be preserved on disk may be created by setting this parameter to null.
DatabaseName
Type: System..::.String
This parameter allows applications to have multiple databases in a single file. Although no DatabaseName needs to be specified, it is an error to attempt to open a second database in a file that was not initially created using a database name.
cfg
Type: BerkeleyDB..::.SecondaryRecnoDatabaseConfig
The database's configuration
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Return Value

A new, open database object

Remarks

If both Filename and DatabaseName are null, the database is strictly temporary and cannot be opened by any other thread of control, thus the database can only be accessed by sharing the single database object that created it, in circumstances where doing so is safe. If Filename is null and DatabaseName is non-null, the database can be opened by other threads of control and will be replicated to client sites in any replication group.

If txn is null, but AutoCommit is set, the operation is implicitly transaction protected. Transactionally protected operations on a database object requires the object itself be transactionally protected during its open. The transaction must be committed before the object is closed.

See Also

SecondaryRecnoDatabase Class
Open Overload


PrintFastStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.PrintFastStats Method
SecondaryRecnoDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintFastStats()()() | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)
PrintFastStats(Boolean) | Display the database statistical information which does not require traversal of the database. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.PrintStats Method
SecondaryRecnoDatabase Class See Also Send Feedback
The statistical information is described by the BTreeStats, HashStats, HeapStats, QueueStats, and RecnoStats classes.

Overload List

Name | Description
PrintStats()()() | Display the database statistical information. (Inherited from BaseDatabase.)
PrintStats(Boolean) | Display the database statistical information. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


SecondaryCursor Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.SecondaryCursor Method
SecondaryRecnoDatabase Class See Also Send Feedback

Overload List

Name | Description
SecondaryCursor()()() | Create a secondary database cursor. (Inherited from SecondaryDatabase.)
SecondaryCursor(CursorConfig) | Create a secondary database cursor with the given configuration. (Inherited from SecondaryDatabase.)
SecondaryCursor(Transaction) | Create a transactionally protected secondary database cursor. (Inherited from SecondaryDatabase.)
SecondaryCursor(CursorConfig, Transaction) | Create a transactionally protected secondary database cursor with the given configuration. (Inherited from SecondaryDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


Truncate Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Truncate Method
SecondaryRecnoDatabase Class See Also Send Feedback
When called on a database configured with secondary indices, This method truncates the primary database and all secondary indices. A count of the records discarded from the primary database is returned.

Overload List

Name | Description
Truncate()()() | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)
Truncate(Transaction) | Empty the database, discarding all records it contains. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class
SecondaryRecnoDatabase Members


SecondaryRecnoDatabase Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase Properties
SecondaryRecnoDatabase Class See Also Send Feedback

The SecondaryRecnoDatabase type exposes the following members.

Properties

Name | Description
AutoCommit | If true, all database modification operations based on this object are transactionally protected. (Inherited from BaseDatabase.)
BackingFile | The underlying source file for the Recno access method.
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from BaseDatabase.)
Creation | The CreatePolicy with which this database was opened. (Inherited from BaseDatabase.)
DatabaseName | The name of this database, if it has one. (Inherited from BaseDatabase.)
Delimiter | The delimiting byte used to mark the end of a record in BackingFile.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from BaseDatabase.)
EncryptAlgorithm | The algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from BaseDatabase.)
Encrypted | If true, encrypt all data stored in the database. (Inherited from BaseDatabase.)
Endianness | The database byte order. (Inherited from BaseDatabase.)
ErrorFeedback | The mechanism for reporting detailed error messages to the application. (Inherited from BaseDatabase.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from BaseDatabase.)
Feedback | Monitor progress within long running operations. (Inherited from BaseDatabase.)
FileName | The filename of this database, if it has one. (Inherited from BaseDatabase.)
FreeThreaded | If true, the object is free-threaded; concurrently usable by multiple threads in the address space. (Inherited from BaseDatabase.)
HasMultiple | If true, the object references a physical file supporting multiple databases. (Inherited from BaseDatabase.)
InHostOrder | If true, the underlying database files were created on an architecture of the same byte order as the current one. This information may be used to determine whether application data needs to be adjusted for this architecture or not. (Inherited from BaseDatabase.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabase.)
Length | If using fixed-length, not byte-delimited records, the length of the records.
messageFeedback | The mechanism for reporting detailed statistic messages to the application. (Inherited from BaseDatabase.)
Msgfile | The message file. (Inherited from BaseDatabase.)
NoMMap | If true, this database is not mapped into process memory. See MMapSize for further information. (Inherited from BaseDatabase.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from BaseDatabase.)
NoWaitDbExclusiveLock | If true, configure the database handle to obtain a write lock on the entire database. When the database is opened it immediately throws LockNotGrantedException if it cannot obtain the exclusive lock immediately. If False, configure the database handle to obtain a write lock on the entire database. When the database is opened, it blocks until it can obtain the exclusive lock. If null, do not configure the database handle to obtain a write lock on the entire database. (Inherited from BaseDatabase.)
Nullifier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabase.)
PadByte | The padding character for short, fixed-length records.
Pagesize | The database's current page size. (Inherited from BaseDatabase.)
Priority | The cache priority for pages referenced by this object. (Inherited from BaseDatabase.)
ReadOnly | If true, this database has been opened for read only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from BaseDatabase.)
ReadUncommitted | If true, this database supports transactional read operations with degree 1 isolation. Read operations on the database may request the return of modified but not yet committed data. (Inherited from BaseDatabase.)
Renumber | If true, the logical record numbers are mutable, and change as records are added to and deleted from the database.
Snapshot | If true, any BackingFile file is read in its entirety when Open(String, SecondaryRecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.
Transactional | If true, this database has been opened in a transactional mode. (Inherited from BaseDatabase.)
Truncated | If true, the underlying file was physically truncated upon open, discarding all previous databases it might have held. (Inherited from BaseDatabase.)
Type | The type of the underlying access method (and file format). This value may be used to determine the type of the database after an Open(String, DatabaseConfig). (Inherited from BaseDatabase.)
UseMVCC | If true, the database was opened with support for multiversion concurrency control. (Inherited from BaseDatabase.)

See Also

SecondaryRecnoDatabase Class


BackingFile Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.BackingFile Property
SecondaryRecnoDatabase Class See Also Send Feedback
The underlying source file for the Recno access method.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BackingFile { get; }
Visual Basic (Declaration)
Public ReadOnly Property BackingFile As String
Visual C++
public:
property String^ BackingFile {
    String^ get ();
}

See Also

SecondaryRecnoDatabase Class


Delimiter Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Delimiter Property
SecondaryRecnoDatabase Class See Also Send Feedback
The delimiting byte used to mark the end of a record in BackingFile.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int Delimiter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Delimiter As Integer
Visual C++
public:
property int Delimiter {
    int get ();
}

See Also

SecondaryRecnoDatabase Class


Length Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Length Property
SecondaryRecnoDatabase Class See Also Send Feedback
If using fixed-length, not byte-delimited records, the length of the records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Length { get; }
Visual Basic (Declaration)
Public ReadOnly Property Length As UInteger
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
}

See Also

SecondaryRecnoDatabase Class


PadByte Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.PadByte Property
SecondaryRecnoDatabase Class See Also Send Feedback
The padding character for short, fixed-length records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int PadByte { get; }
Visual Basic (Declaration)
Public ReadOnly Property PadByte As Integer
Visual C++
public:
property int PadByte {
    int get ();
}

See Also

SecondaryRecnoDatabase Class


Renumber Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Renumber Property
SecondaryRecnoDatabase Class See Also Send Feedback
If true, the logical record numbers are mutable, and change as records are added to and deleted from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Renumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property Renumber As Boolean
Visual C++
public:
property bool Renumber {
    bool get ();
}

See Also

SecondaryRecnoDatabase Class


Snapshot Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabase..::.Snapshot Property
SecondaryRecnoDatabase Class See Also Send Feedback
If true, any BackingFile file is read in its entirety when Open(String, SecondaryRecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Snapshot { get; }
Visual Basic (Declaration)
Public ReadOnly Property Snapshot As Boolean
Visual C++
public:
property bool Snapshot {
    bool get ();
}

See Also

SecondaryRecnoDatabase Class


SecondaryRecnoDatabaseConfig Class

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig Class
Members See Also Send Feedback
A class representing configuration parameters for RecnoDatabase

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SecondaryRecnoDatabaseConfig : SecondaryDatabaseConfig
Visual Basic (Declaration)
Public Class SecondaryRecnoDatabaseConfig _
    Inherits SecondaryDatabaseConfig
Visual C++
public ref class SecondaryRecnoDatabaseConfig : public SecondaryDatabaseConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.DatabaseConfig
BerkeleyDB..::.SecondaryDatabaseConfig
BerkeleyDB..::.SecondaryRecnoDatabaseConfig

See Also

SecondaryRecnoDatabaseConfig Members


SecondaryRecnoDatabaseConfig Members

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig Members
SecondaryRecnoDatabaseConfig Class Constructors Methods Fields Properties See Also Send Feedback

The SecondaryRecnoDatabaseConfig type exposes the following members.

Constructors

Name | Description
SecondaryRecnoDatabaseConfig | Instantiate a new SecondaryRecnoDatabaseConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BackingFile | The underlying source file for the Recno access method.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
ImmutableKey | If true, the secondary key is immutable. (Inherited from SecondaryDatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive. (Inherited from SecondaryDatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Renumber | Cause the logical record numbers to be mutable, and change as records are added to and deleted from the database.
Snapshot | If true, any BackingFile file is read in its entirety when Open(String, SecondaryRecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

Properties

Name | Description
Delimiter | The delimiting byte used to mark the end of a record in BackingFile.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ForeignKeyDatabase | The database used to check the foreign key integrity constraint. (Inherited from SecondaryDatabaseConfig.)
ForeignKeyNullfier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabaseConfig.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabaseConfig.)
Length | Specify that the records are fixed-length, not byte-delimited, and are of length Length.
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted. (Inherited from SecondaryDatabaseConfig.)
PadByte | The padding character for short, fixed-length records.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryRecnoDatabaseConfig Class


SecondaryRecnoDatabaseConfig Constructor

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig Constructor
SecondaryRecnoDatabaseConfig Class See Also Send Feedback
Instantiate a new SecondaryRecnoDatabaseConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SecondaryRecnoDatabaseConfig(
    Database PrimaryDB,
    SecondaryKeyGenDelegate KeyGenFunc
)
Visual Basic (Declaration)
Public Sub New ( _
    PrimaryDB As Database, _
    KeyGenFunc As SecondaryKeyGenDelegate _
)
Visual C++
public:
SecondaryRecnoDatabaseConfig(
    Database^ PrimaryDB,
    SecondaryKeyGenDelegate^ KeyGenFunc
)

Parameters

PrimaryDB
Type: BerkeleyDB..::.Database
KeyGenFunc
Type: BerkeleyDB..::.SecondaryKeyGenDelegate

See Also

SecondaryRecnoDatabaseConfig Class


SecondaryRecnoDatabaseConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig Fields
SecondaryRecnoDatabaseConfig Class See Also Send Feedback

The SecondaryRecnoDatabaseConfig type exposes the following members.

Fields

Name | Description
AutoCommit | Enclose the open call within a transaction. If the call succeeds, the open operation is recoverable and all subsequent database modification operations based on this handle will be transactionally protected. If the call fails, no database has been created. (Inherited from DatabaseConfig.)
BackingFile | The underlying source file for the Recno access method.
ByteOrder | The byte order for integers in the stored database metadata. The host byte order of the machine where the Berkeley DB library was compiled is the default value. (Inherited from DatabaseConfig.)
CacheSize | The size of the shared memory buffer pool (the cache). (Inherited from DatabaseConfig.)
Creation | The policy for how to handle database creation.
DoChecksum | If true, do checksum verification of pages read into the cache from the backing filestore. (Inherited from DatabaseConfig.)
Env | The Berkeley DB environment within which to create a database. If null, the database is created stand-alone; it is not part of any Berkeley DB environment. (Inherited from DatabaseConfig.)
ErrorFeedback | The mechanism for reporting error messages to the application. (Inherited from DatabaseConfig.)
ErrorPrefix | The prefix string that appears before error messages issued by Berkeley DB. (Inherited from DatabaseConfig.)
Feedback | (Inherited from DatabaseConfig.)
FreeThreaded | Causes the database object to be free-threaded; that is, concurrently usable by multiple threads in the address space. (Inherited from DatabaseConfig.)
ImmutableKey | If true, the secondary key is immutable. (Inherited from SecondaryDatabaseConfig.)
NoMMap | Do not map this database into process memory. (Inherited from DatabaseConfig.)
NonDurableTxns | If true, Berkeley DB does not write log records for this database. (Inherited from DatabaseConfig.)
NoWaitDbExclusiveLock | Configuration of BaseDatabase handle to obtain a write lock on the entire database. (Inherited from DatabaseConfig.)
Populate | If true and the secondary database is empty, walk through Primary and create an index to it in the empty secondary. This operation is potentially very expensive. (Inherited from SecondaryDatabaseConfig.)
Priority | The cache priority for pages referenced by the database. (Inherited from DatabaseConfig.)
ReadOnly | Open the database for reading only. Any attempt to modify items in the database will fail, regardless of the actual permissions of any underlying files. (Inherited from DatabaseConfig.)
ReadUncommitted | Support transactional read operations with degree 1 isolation. (Inherited from DatabaseConfig.)
Renumber | Cause the logical record numbers to be mutable, and change as records are added to and deleted from the database.
Snapshot | If true, any BackingFile file is read in its entirety when Open(String, SecondaryRecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.
Truncate | Physically truncate the underlying file, discarding all previous databases it might have held. (Inherited from DatabaseConfig.)
UseMVCC | Open the database with support for multiversion concurrency control. (Inherited from DatabaseConfig.)

See Also

SecondaryRecnoDatabaseConfig Class


BackingFile Field

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig..::.BackingFile Field
SecondaryRecnoDatabaseConfig Class See Also Send Feedback
The underlying source file for the Recno access method.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string BackingFile
Visual Basic (Declaration)
Public BackingFile As String
Visual C++
public:
String^ BackingFile

Remarks

The purpose of the source file is to provide fast access and modification to databases that are normally stored as flat text files.

The source parameter specifies an underlying flat text database file that is read to initialize a transient record number index. In the case of variable length records, the records are separated, as specified by Delimiter. For example, standard UNIX byte stream files can be interpreted as a sequence of variable length records separated by newline characters.

In addition, when cached data would normally be written back to the underlying database file (for example, Close()()() or Sync()()()), the in-memory copy of the database is written back to the source file.

By default, the backing source file is read lazily; records are not read from the file until they are requested by the application. If multiple processes (not threads) are accessing a Recno database concurrently, and are either inserting or deleting records, the backing source file must be read in its entirety before more than a single process accesses the database, and only that process should specify the backing source file as part of the Open(String, SecondaryRecnoDatabaseConfig) call. See Snapshot for more information.

Reading and writing the backing source file specified by source cannot be transaction-protected because it involves filesystem operations that are not part of the Db transaction methodology. For this reason, if a temporary database is used to hold the records, it is possible to lose the contents of the source file, for example, if the system crashes at the right instant. If a file is used to hold the database, normal database recovery on that file can be used to prevent information loss, although it is still possible that the contents of source become lost if the system crashes.

The source file must already exist (but may be zero-length) when Open(String, SecondaryRecnoDatabaseConfig) is called.

It is not an error to specify a read-only source file when creating a database, nor is it an error to modify the resulting database. However, any attempt to write the changes to the backing source file using either the Sync()()() or Close()()() methods fail, of course. Use Close(Boolean) to stop it from attempting to write the changes to the backing file; instead, they are silently discarded.

For all of the previous reasons, the source file is generally used to specify databases that are read-only for Berkeley DB applications; and that are either generated on the fly by software tools or modified using a different mechanism — for example, a text editor.

If the database already exists, BackingFile must be the same as that historically used to create the database or corruption can occur.

See Also

SecondaryRecnoDatabaseConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig..::.Creation Field
SecondaryRecnoDatabaseConfig Class See Also Send Feedback
The policy for how to handle database creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the database does not already exist and NEVER is set, Open(String, SecondaryRecnoDatabaseConfig) fails.

See Also

SecondaryRecnoDatabaseConfig Class


Renumber Field

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig..::.Renumber Field
SecondaryRecnoDatabaseConfig Class See Also Send Feedback
Cause the logical record numbers to be mutable, and change as records are added to and deleted from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Renumber
Visual Basic (Declaration)
Public Renumber As Boolean
Visual C++
public:
bool Renumber

Remarks

For example, the deletion of record number 4 causes records numbered 5 and greater to be renumbered downward by one. If a cursor was positioned as record number 4 before the deletion, it refers to the new record number 4, if any such record exists, after the deletion. If a cursor was positioned after record number 4 before the deletion, it is shifted downward one logical record, continuing to refer to the same record as it did before.

Using Put(MultipleKeyDatabaseEntry) or Put(DatabaseEntry, DatabaseEntry, UInt32) to create new records causes the creation of multiple records if the record number is more than one greater than the largest record currently in the database. For example, creating record 28 when record 25 was previously the last record in the database creates records 26 and 27 as well as 28. Attempts to retrieve records that were created in this manner throw a KeyEmptyException.

If a created record is not at the end of the database, all records following the new record are automatically renumbered upward by one. For example, the creation of a new record numbered 8 causes records numbered 8 and greater to be renumbered upward by one. If a cursor was positioned to record number 8 or greater before the insertion, it is shifted upward one logical record, continuing to refer to the same record as it did before.

For these reasons, concurrent access to a SecondaryRecnoDatabase with this setting specified may be largely meaningless, although it is supported.

If the database already exists, this setting must be the same as the existing database or an exception is thrown.

See Also

SecondaryRecnoDatabaseConfig Class


Snapshot Field

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig..::.Snapshot Field
SecondaryRecnoDatabaseConfig Class See Also Send Feedback
If true, any BackingFile file is read in its entirety when Open(String, SecondaryRecnoDatabaseConfig) is called. If false, BackingFile may be read lazily.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Snapshot
Visual Basic (Declaration)
Public Snapshot As Boolean
Visual C++
public:
bool Snapshot

See Also

SecondaryRecnoDatabaseConfig Class


SecondaryRecnoDatabaseConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig Methods
SecondaryRecnoDatabaseConfig Class See Also Send Feedback

The SecondaryRecnoDatabaseConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetEncryption | Set the password and algorithm used by the Berkeley DB library to perform encryption and decryption. (Inherited from DatabaseConfig.)
SetForeignKeyConstraint | Overloaded.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SecondaryRecnoDatabaseConfig Class


SetForeignKeyConstraint Method

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig..::.SetForeignKeyConstraint Method
SecondaryRecnoDatabaseConfig Class See Also Send Feedback

Overload List

Name | Description
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction) | Specify the action taken when a referenced record in the foreign key database is deleted. (Inherited from SecondaryDatabaseConfig.)
SetForeignKeyConstraint(Database, ForeignKeyDeleteAction, ForeignKeyNullifyDelegate) | Specify the action taken when a referenced record in the foreign key database is deleted. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryRecnoDatabaseConfig Class
SecondaryRecnoDatabaseConfig Members


SecondaryRecnoDatabaseConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig Properties
SecondaryRecnoDatabaseConfig Class See Also Send Feedback

The SecondaryRecnoDatabaseConfig type exposes the following members.

Properties

Name | Description
Delimiter | The delimiting byte used to mark the end of a record in BackingFile.
EncryptAlgorithm | The algorithm used to perform encryption and decryption. (Inherited from DatabaseConfig.)
Encrypted | Encrypt the database using the cryptographic password specified by DatabaseConfig.SetEncryption or DatabaseEnvironmentConfig.SetEncryption. (Inherited from DatabaseConfig.)
EncryptionPassword | The password used to perform encryption and decryption. (Inherited from DatabaseConfig.)
ForeignKeyDatabase | The database used to check the foreign key integrity constraint. (Inherited from SecondaryDatabaseConfig.)
ForeignKeyNullfier | The nullifying function used to set the foreign key to null. (Inherited from SecondaryDatabaseConfig.)
KeyGen | The delegate that creates the set of secondary keys corresponding to a given primary key and data pair. (Inherited from SecondaryDatabaseConfig.)
Length | Specify that the records are fixed-length, not byte-delimited, and are of length Length.
OnForeignKeyDelete | The action taken when a referenced record in ForeignKeyDatabase is deleted. (Inherited from SecondaryDatabaseConfig.)
PadByte | The padding character for short, fixed-length records.
PageSize | The size of the pages used to hold items in the database, in bytes. (Inherited from DatabaseConfig.)
Primary | All updates to the primary database are automatically reflected in the secondary and all reads from the secondary return corresponding data from Primary. (Inherited from SecondaryDatabaseConfig.)

See Also

SecondaryRecnoDatabaseConfig Class


Delimiter Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig..::.Delimiter Property
SecondaryRecnoDatabaseConfig Class See Also Send Feedback
The delimiting byte used to mark the end of a record in BackingFile.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int Delimiter { get; set; }
Visual Basic (Declaration)
Public Property Delimiter As Integer
Visual C++
public:
property int Delimiter {
    int get ();
    void set (int value);
}

Remarks

This byte is used for variable length records if BackingFile is set. If BackingFile is specified and no delimiting byte was specified, newline characters (ASCII 0x0a) are interpreted as end-of-record markers.

If the database already exists, this setting is ignored.

See Also

SecondaryRecnoDatabaseConfig Class


Length Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig..::.Length Property
SecondaryRecnoDatabaseConfig Class See Also Send Feedback
Specify that the records are fixed-length, not byte-delimited, and are of length Length.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Length { get; set; }
Visual Basic (Declaration)
Public Property Length As UInteger
Visual C++
public:
property unsigned int Length {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Any records added to the database that are less than Length bytes long are automatically padded (see PadByte for more information).

Any attempt to insert records into the database that are greater than Length bytes long cause the call to fail immediately and return an error.

If the database already exists, this setting is ignored.

See Also

SecondaryRecnoDatabaseConfig Class


PadByte Property

[image]

Berkeley DB .NET API Documentation
SecondaryRecnoDatabaseConfig..::.PadByte Property
SecondaryRecnoDatabaseConfig Class See Also Send Feedback
The padding character for short, fixed-length records.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public int PadByte { get; set; }
Visual Basic (Declaration)
Public Property PadByte As Integer
Visual C++
public:
property int PadByte {
    int get ();
    void set (int value);
}

Remarks

If no pad character is specified, space characters (ASCII 0x20) are used for padding.

If the database already exists, this setting is ignored.

See Also

SecondaryRecnoDatabaseConfig Class


Sequence Class

[image]

Berkeley DB .NET API Documentation
Sequence Class
Members See Also Send Feedback
A class that provides an arbitrary number of persistent objects that return an increasing or decreasing sequence of integers.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class Sequence : IDisposable
Visual Basic (Declaration)
Public Class Sequence _
    Implements IDisposable
Visual C++
public ref class Sequence : IDisposable

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.Sequence

See Also

Sequence Members


Sequence Members

[image] [image]

Berkeley DB .NET API Documentation
Sequence Members
Sequence Class Constructors Methods Properties See Also Send Feedback

The Sequence type exposes the following members.

Constructors

Name | Description
Sequence | Overloaded.

Methods

Name | Description
Close | Close the sequence handle. Any unused cached values are lost.
Dispose | Release the resources held by this object, and close the sequence if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Get | Overloaded. If there are enough cached values in the sequence handle then they will be returned. Otherwise the next value will be fetched from the database and incremented (decremented) by enough to cover the delta and the next batch of cached values. By default, sequence ranges do not wrap; to cause the sequence to wrap around the beginning or end of its range, set Wrap to true.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
PrintStats | Overloaded. The diagnostic information is described by SequenceStats.
Remove | Overloaded.
Stats | Overloaded. In the presence of multiple threads or processes accessing an active sequence, the information returned by DB_SEQUENCE->stat() may be out-of-date. The DB_SEQUENCE->stat() method cannot be transaction-protected. For this reason, it should be called in a thread of control that has no open cursors or active transactions.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
BackingDatabase | The database used by the sequence.
Cachesize | The current cache size.
Decrement | If true, the sequence is decremented.
Increment | If true, the sequence is incremented. This is the default.
Key | The key for the sequence.
Max | The maximum value in the sequence.
Min | The minimum value in the sequence.
Wrap | If true, the sequence should wrap around when it is incremented (decremented) past the specified maximum (minimum) value.

See Also

Sequence Class


Sequence Constructor

[image] [image]

Berkeley DB .NET API Documentation
Sequence Constructor
Sequence Class See Also Send Feedback

Overload List

Name | Description
Sequence(SequenceConfig) | Instantiate a new Sequence object.
Sequence(SequenceConfig, Transaction) | Instantiate a new Sequence object.

See Also

Sequence Class
Sequence Members


Sequence Constructor (SequenceConfig)

[image]

Berkeley DB .NET API Documentation
Sequence Constructor (SequenceConfig)
Sequence Class See Also Send Feedback
Instantiate a new Sequence object.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Sequence(
    SequenceConfig cfg
)
Visual Basic (Declaration)
Public Sub New ( _
    cfg As SequenceConfig _
)
Visual C++
public:
Sequence(
    SequenceConfig^ cfg
)

Parameters

cfg
Type: BerkeleyDB..::.SequenceConfig
Configuration parameters for the Sequence

See Also

Sequence Class
Sequence Overload


Sequence Constructor (SequenceConfig, Transaction)

[image]

Berkeley DB .NET API Documentation
Sequence Constructor (SequenceConfig, Transaction)
Sequence Class See Also Send Feedback
Instantiate a new Sequence object.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Sequence(
    SequenceConfig cfg,
    Transaction txn
)
Visual Basic (Declaration)
Public Sub New ( _
    cfg As SequenceConfig, _
    txn As Transaction _
)
Visual C++
public:
Sequence(
    SequenceConfig^ cfg,
    Transaction^ txn
)

Parameters

cfg
Type: BerkeleyDB..::.SequenceConfig
Configuration parameters for the Sequence
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

Remarks

If txn is null and the operation occurs in a transactional database, the operation will be implicitly transaction protected.

See Also

Sequence Class
Sequence Overload


Sequence Methods

[image] [image]

Berkeley DB .NET API Documentation
Sequence Methods
Sequence Class See Also Send Feedback

The Sequence type exposes the following members.

Methods

Name | Description
Close | Close the sequence handle. Any unused cached values are lost.
Dispose | Release the resources held by this object, and close the sequence if it is still open.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Get | Overloaded. If there are enough cached values in the sequence handle then they will be returned. Otherwise the next value will be fetched from the database and incremented (decremented) by enough to cover the delta and the next batch of cached values. By default, sequence ranges do not wrap; to cause the sequence to wrap around the beginning or end of its range, set Wrap to true.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
PrintStats | Overloaded. The diagnostic information is described by SequenceStats.
Remove | Overloaded.
Stats | Overloaded. In the presence of multiple threads or processes accessing an active sequence, the information returned by DB_SEQUENCE->stat() may be out-of-date. The DB_SEQUENCE->stat() method cannot be transaction-protected. For this reason, it should be called in a thread of control that has no open cursors or active transactions.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Sequence Class


Close Method

[image]

Berkeley DB .NET API Documentation
Sequence..::.Close Method
Sequence Class See Also Send Feedback
Close the sequence handle. Any unused cached values are lost.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

See Also

Sequence Class


Dispose Method

[image]

Berkeley DB .NET API Documentation
Sequence..::.Dispose Method
Sequence Class See Also Send Feedback
Release the resources held by this object, and close the sequence if it is still open.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

Sequence Class


Get Method

[image] [image]

Berkeley DB .NET API Documentation
Sequence..::.Get Method
Sequence Class See Also Send Feedback

If there are enough cached values in the sequence handle then they will be returned. Otherwise the next value will be fetched from the database and incremented (decremented) by enough to cover the delta and the next batch of cached values.

By default, sequence ranges do not wrap; to cause the sequence to wrap around the beginning or end of its range, set Wrap to true.

Overload List

Name | Description
Get(UInt32) | Return the next available element in the sequence and change the sequence value by Delta.
Get(UInt32, Transaction) | Return the next available element in the sequence and change the sequence value by Delta.
Get(UInt32, Boolean) | Return the next available element in the sequence and change the sequence value by Delta.

See Also

Sequence Class
Sequence Members


Get Method (UInt32)

[image]

Berkeley DB .NET API Documentation
Sequence..::.Get Method (UInt32)
Sequence Class See Also Send Feedback
Return the next available element in the sequence and change the sequence value by Delta.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Get(
    uint Delta
)
Visual Basic (Declaration)
Public Function Get ( _
    Delta As UInteger _
) As Long
Visual C++
public:
long long Get(
    unsigned int Delta
)

Parameters

Delta
Type: System..::.UInt32
The amount by which to increment the sequence value. Must be greater than 0.

Return Value

The next available element in the sequence.

See Also

Sequence Class
Get Overload


Get Method (UInt32, Transaction)

[image]

Berkeley DB .NET API Documentation
Sequence..::.Get Method (UInt32, Transaction)
Sequence Class See Also Send Feedback
Return the next available element in the sequence and change the sequence value by Delta.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Get(
    uint Delta,
    Transaction txn
)
Visual Basic (Declaration)
Public Function Get ( _
    Delta As UInteger, _
    txn As Transaction _
) As Long
Visual C++
public:
long long Get(
    unsigned int Delta,
    Transaction^ txn
)

Parameters

Delta
Type: System..::.UInt32
The amount by which to increment the sequence value. Must be greater than 0.
txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null. Must be null if the sequence was opened with a non-zero cache size.

Return Value

The next available element in the sequence.

See Also

Sequence Class
Get Overload


Get Method (UInt32, Boolean)

[image]

Berkeley DB .NET API Documentation
Sequence..::.Get Method (UInt32, Boolean)
Sequence Class See Also Send Feedback
Return the next available element in the sequence and change the sequence value by Delta.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Get(
    uint Delta,
    bool NoSync
)
Visual Basic (Declaration)
Public Function Get ( _
    Delta As UInteger, _
    NoSync As Boolean _
) As Long
Visual C++
public:
long long Get(
    unsigned int Delta,
    bool NoSync
)

Parameters

Delta
Type: System..::.UInt32
The amount by which to increment the sequence value. Must be greater than 0.
NoSync
Type: System..::.Boolean
If true, and if the operation is implicitly transaction protected, do not synchronously flush the log when the transaction commits.

Return Value

The next available element in the sequence.

See Also

Sequence Class
Get Overload


PrintStats Method

[image] [image]

Berkeley DB .NET API Documentation
Sequence..::.PrintStats Method
Sequence Class See Also Send Feedback
The diagnostic information is described by SequenceStats.

Overload List

Name | Description
PrintStats()()() | Print diagnostic information.
PrintStats(Boolean) | Print diagnostic information.

See Also

Sequence Class
Sequence Members


PrintStats Method

[image]

Berkeley DB .NET API Documentation
Sequence..::.PrintStats Method
Sequence Class See Also Send Feedback
Print diagnostic information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintStats()
Visual Basic (Declaration)
Public Sub PrintStats
Visual C++
public:
void PrintStats()

See Also

Sequence Class
PrintStats Overload


PrintStats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
Sequence..::.PrintStats Method (Boolean)
Sequence Class See Also Send Feedback
Print diagnostic information.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void PrintStats(
    bool ClearStats
)
Visual Basic (Declaration)
Public Sub PrintStats ( _
    ClearStats As Boolean _
)
Visual C++
public:
void PrintStats(
    bool ClearStats
)

Parameters

ClearStats
Type: System..::.Boolean
If true, reset statistics after printing.

See Also

Sequence Class
PrintStats Overload


Remove Method

[image] [image]

Berkeley DB .NET API Documentation
Sequence..::.Remove Method
Sequence Class See Also Send Feedback

Overload List

Name | Description
Remove()()() | Remove the sequence from the database.
Remove(Transaction) | Remove the sequence from the database.
Remove(Boolean) | Remove the sequence from the database.

See Also

Sequence Class
Sequence Members


Remove Method

[image]

Berkeley DB .NET API Documentation
Sequence..::.Remove Method
Sequence Class See Also Send Feedback
Remove the sequence from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove
Visual C++
public:
void Remove()

See Also

Sequence Class
Remove Overload


Remove Method (Transaction)

[image]

Berkeley DB .NET API Documentation
Sequence..::.Remove Method (Transaction)
Sequence Class See Also Send Feedback
Remove the sequence from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Remove(
    Transaction txn
)
Visual Basic (Declaration)
Public Sub Remove ( _
    txn As Transaction _
)
Visual C++
public:
void Remove(
    Transaction^ txn
)

Parameters

txn
Type: BerkeleyDB..::.Transaction
If the operation is part of an application-specified transaction, txn is a Transaction object returned from BeginTransaction()()(); if the operation is part of a Berkeley DB Concurrent Data Store group, txn is a handle returned from BeginCDSGroup()()(); otherwise null.

See Also

Sequence Class
Remove Overload


Remove Method (Boolean)

[image]

Berkeley DB .NET API Documentation
Sequence..::.Remove Method (Boolean)
Sequence Class See Also Send Feedback
Remove the sequence from the database.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Remove(
    bool NoSync
)
Visual Basic (Declaration)
Public Sub Remove ( _
    NoSync As Boolean _
)
Visual C++
public:
void Remove(
    bool NoSync
)

Parameters

NoSync
Type: System..::.Boolean
If true, and if the operation is implicitly transaction protected, do not synchronously flush the log when the transaction commits.

See Also

Sequence Class
Remove Overload


Stats Method

[image] [image]

Berkeley DB .NET API Documentation
Sequence..::.Stats Method
Sequence Class See Also Send Feedback

In the presence of multiple threads or processes accessing an active sequence, the information returned by DB_SEQUENCE->stat() may be out-of-date.

The DB_SEQUENCE->stat() method cannot be transaction-protected. For this reason, it should be called in a thread of control that has no open cursors or active transactions.

Overload List

Name | Description
Stats()()() | Return statistical information for this sequence.
Stats(Boolean) | Return statistical information for this sequence.

See Also

Sequence Class
Sequence Members


Stats Method

[image]

Berkeley DB .NET API Documentation
Sequence..::.Stats Method
Sequence Class See Also Send Feedback
Return statistical information for this sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SequenceStats Stats()
Visual Basic (Declaration)
Public Function Stats As SequenceStats
Visual C++
public:
SequenceStats^ Stats()

Return Value

Statistical information for this sequence.

See Also

Sequence Class
Stats Overload


Stats Method (Boolean)

[image]

Berkeley DB .NET API Documentation
Sequence..::.Stats Method (Boolean)
Sequence Class See Also Send Feedback
Return statistical information for this sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SequenceStats Stats(
    bool clear
)
Visual Basic (Declaration)
Public Function Stats ( _
    clear As Boolean _
) As SequenceStats
Visual C++
public:
SequenceStats^ Stats(
    bool clear
)

Parameters

clear
Type: System..::.Boolean
If true, reset statistics.

Return Value

Statistical information for this sequence.

See Also

Sequence Class
Stats Overload


Sequence Properties

[image] [image]

Berkeley DB .NET API Documentation
Sequence Properties
Sequence Class See Also Send Feedback

The Sequence type exposes the following members.

Properties

Name | Description
BackingDatabase | The database used by the sequence.
Cachesize | The current cache size.
Decrement | If true, the sequence is decremented.
Increment | If true, the sequence is incremented. This is the default.
Key | The key for the sequence.
Max | The maximum value in the sequence.
Min | The minimum value in the sequence.
Wrap | If true, the sequence should wrap around when it is incremented (decremented) past the specified maximum (minimum) value.

See Also

Sequence Class


BackingDatabase Property

[image]

Berkeley DB .NET API Documentation
Sequence..::.BackingDatabase Property
Sequence Class See Also Send Feedback
The database used by the sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Database BackingDatabase { get; }
Visual Basic (Declaration)
Public ReadOnly Property BackingDatabase As Database
Visual C++
public:
property Database^ BackingDatabase {
    Database^ get ();
}

See Also

Sequence Class


Cachesize Property

[image]

Berkeley DB .NET API Documentation
Sequence..::.Cachesize Property
Sequence Class See Also Send Feedback
The current cache size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Cachesize { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cachesize As UInteger
Visual C++
public:
property unsigned int Cachesize {
    unsigned int get ();
}

See Also

Sequence Class


Decrement Property

[image]

Berkeley DB .NET API Documentation
Sequence..::.Decrement Property
Sequence Class See Also Send Feedback
If true, the sequence is decremented.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Decrement { get; }
Visual Basic (Declaration)
Public ReadOnly Property Decrement As Boolean
Visual C++
public:
property bool Decrement {
    bool get ();
}

See Also

Sequence Class


Increment Property

[image]

Berkeley DB .NET API Documentation
Sequence..::.Increment Property
Sequence Class See Also Send Feedback
If true, the sequence is incremented. This is the default.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Increment { get; }
Visual Basic (Declaration)
Public ReadOnly Property Increment As Boolean
Visual C++
public:
property bool Increment {
    bool get ();
}

See Also

Sequence Class


Key Property

[image]

Berkeley DB .NET API Documentation
Sequence..::.Key Property
Sequence Class See Also Send Feedback
The key for the sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry Key { get; }
Visual Basic (Declaration)
Public ReadOnly Property Key As DatabaseEntry
Visual C++
public:
property DatabaseEntry^ Key {
    DatabaseEntry^ get ();
}

See Also

Sequence Class


Max Property

[image]

Berkeley DB .NET API Documentation
Sequence..::.Max Property
Sequence Class See Also Send Feedback
The maximum value in the sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Max { get; }
Visual Basic (Declaration)
Public ReadOnly Property Max As Long
Visual C++
public:
property long long Max {
    long long get ();
}

See Also

Sequence Class


Min Property

[image]

Berkeley DB .NET API Documentation
Sequence..::.Min Property
Sequence Class See Also Send Feedback
The minimum value in the sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Min { get; }
Visual Basic (Declaration)
Public ReadOnly Property Min As Long
Visual C++
public:
property long long Min {
    long long get ();
}

See Also

Sequence Class


Wrap Property

[image]

Berkeley DB .NET API Documentation
Sequence..::.Wrap Property
Sequence Class See Also Send Feedback
If true, the sequence should wrap around when it is incremented (decremented) past the specified maximum (minimum) value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Wrap { get; }
Visual Basic (Declaration)
Public ReadOnly Property Wrap As Boolean
Visual C++
public:
property bool Wrap {
    bool get ();
}

See Also

Sequence Class


SequenceConfig Class

[image]

Berkeley DB .NET API Documentation
SequenceConfig Class
Members See Also Send Feedback
Configuration properties for a Sequence

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SequenceConfig
Visual Basic (Declaration)
Public Class SequenceConfig
Visual C++
public ref class SequenceConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.SequenceConfig

See Also

SequenceConfig Members


SequenceConfig Members

[image] [image]

Berkeley DB .NET API Documentation
SequenceConfig Members
SequenceConfig Class Constructors Methods Fields Properties See Also Send Feedback

The SequenceConfig type exposes the following members.

Constructors

Name | Description
SequenceConfig | Initializes a new instance of the SequenceConfig class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetRange | Set the minimum and maximum values in the sequence.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
BackingDatabase | An open database which holds the persistent data for the sequence.
Creation | The policy for how to handle sequence creation.
FreeThreaded | If true, the object returned by the Sequence constructor is free-threaded; usable by multiple threads within a single address space. If multiple threads create multiple sequences using the same BackingDatabase, that database must have also been opened free-threaded.
key | The record in the database that stores the persistent sequence data.
Wrap | If true, the sequence should wrap around when it is incremented (decremented) past the specified maximum (minimum) value.

Properties

Name | Description
CacheSize | The number of elements cached by a sequence handle.
Decrement | If true, the sequence is decremented.
Increment | If true, the sequence is incremented. This is the default.
InitialValue | The initial value for a sequence.
Max | The maximum value in the sequence.
Min | The minimum value in the sequence.

See Also

SequenceConfig Class


SequenceConfig Constructor

[image]

Berkeley DB .NET API Documentation
SequenceConfig Constructor
SequenceConfig Class See Also Send Feedback
Initializes a new instance of the SequenceConfig class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public SequenceConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SequenceConfig()

See Also

SequenceConfig Class


SequenceConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
SequenceConfig Fields
SequenceConfig Class See Also Send Feedback

The SequenceConfig type exposes the following members.

Fields

Name | Description
BackingDatabase | An open database which holds the persistent data for the sequence.
Creation | The policy for how to handle sequence creation.
FreeThreaded | If true, the object returned by the Sequence constructor is free-threaded; usable by multiple threads within a single address space. If multiple threads create multiple sequences using the same BackingDatabase, that database must have also been opened free-threaded.
key | The record in the database that stores the persistent sequence data.
Wrap | If true, the sequence should wrap around when it is incremented (decremented) past the specified maximum (minimum) value.

See Also

SequenceConfig Class


BackingDatabase Field

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.BackingDatabase Field
SequenceConfig Class See Also Send Feedback
An open database which holds the persistent data for the sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Database BackingDatabase
Visual Basic (Declaration)
Public BackingDatabase As Database
Visual C++
public:
Database^ BackingDatabase

Remarks

The database may be of any type, but must not have been configured to support duplicate data items.

If BackingDatabase was opened in a transaction, calling Get may result in changes to the sequence object; these changes are automatically committed in a transaction internal to the Berkeley DB library. If the thread of control calling Get has an active transaction, which holds locks on the same database as the one in which the sequence object is stored, it is possible for a thread of control calling Get to self-deadlock because the active transaction's locks conflict with the internal transaction's locks. For this reason, it is often preferable for sequence objects to be stored in their own database.

See Also

SequenceConfig Class


Creation Field

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.Creation Field
SequenceConfig Class See Also Send Feedback
The policy for how to handle sequence creation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public CreatePolicy Creation
Visual Basic (Declaration)
Public Creation As CreatePolicy
Visual C++
public:
CreatePolicy Creation

Remarks

If the sequence does not already exist and NEVER is set, the Sequence constructor fails.

See Also

SequenceConfig Class


FreeThreaded Field

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.FreeThreaded Field
SequenceConfig Class See Also Send Feedback
If true, the object returned by the Sequence constructor is free-threaded; usable by multiple threads within a single address space. If multiple threads create multiple sequences using the same BackingDatabase, that database must have also been opened free-threaded.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool FreeThreaded
Visual Basic (Declaration)
Public FreeThreaded As Boolean
Visual C++
public:
bool FreeThreaded

See Also

SequenceConfig Class


key Field

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.key Field
SequenceConfig Class See Also Send Feedback
The record in the database that stores the persistent sequence data.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public DatabaseEntry key
Visual Basic (Declaration)
Public key As DatabaseEntry
Visual C++
public:
DatabaseEntry^ key

See Also

SequenceConfig Class


Wrap Field

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.Wrap Field
SequenceConfig Class See Also Send Feedback
If true, the sequence should wrap around when it is incremented (decremented) past the specified maximum (minimum) value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Wrap
Visual Basic (Declaration)
Public Wrap As Boolean
Visual C++
public:
bool Wrap

See Also

SequenceConfig Class


SequenceConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
SequenceConfig Methods
SequenceConfig Class See Also Send Feedback

The SequenceConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
SetRange | Set the minimum and maximum values in the sequence.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SequenceConfig Class


SetRange Method

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.SetRange Method
SequenceConfig Class See Also Send Feedback
Set the minimum and maximum values in the sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetRange(
    long Min,
    long Max
)
Visual Basic (Declaration)
Public Sub SetRange ( _
    Min As Long, _
    Max As Long _
)
Visual C++
public:
void SetRange(
    long long Min,
    long long Max
)

Parameters

Min
Type: System..::.Int64
The minimum value in the sequence.
Max
Type: System..::.Int64
The maximum value in the sequence.

See Also

SequenceConfig Class


SequenceConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
SequenceConfig Properties
SequenceConfig Class See Also Send Feedback

The SequenceConfig type exposes the following members.

Properties

Name | Description
CacheSize | The number of elements cached by a sequence handle.
Decrement | If true, the sequence is decremented.
Increment | If true, the sequence is incremented. This is the default.
InitialValue | The initial value for a sequence.
Max | The maximum value in the sequence.
Min | The minimum value in the sequence.

See Also

SequenceConfig Class


CacheSize Property

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.CacheSize Property
SequenceConfig Class See Also Send Feedback
The number of elements cached by a sequence handle.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CacheSize { get; set; }
Visual Basic (Declaration)
Public Property CacheSize As UInteger
Visual C++
public:
property unsigned int CacheSize {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

SequenceConfig Class


Decrement Property

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.Decrement Property
SequenceConfig Class See Also Send Feedback
If true, the sequence is decremented.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Decrement { get; set; }
Visual Basic (Declaration)
Public Property Decrement As Boolean
Visual C++
public:
property bool Decrement {
    bool get ();
    void set (bool value);
}

See Also

SequenceConfig Class


Increment Property

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.Increment Property
SequenceConfig Class See Also Send Feedback
If true, the sequence is incremented. This is the default.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Increment { get; set; }
Visual Basic (Declaration)
Public Property Increment As Boolean
Visual C++
public:
property bool Increment {
    bool get ();
    void set (bool value);
}

See Also

SequenceConfig Class


InitialValue Property

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.InitialValue Property
SequenceConfig Class See Also Send Feedback
The initial value for a sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long InitialValue { get; set; }
Visual Basic (Declaration)
Public Property InitialValue As Long
Visual C++
public:
property long long InitialValue {
    long long get ();
    void set (long long value);
}

See Also

SequenceConfig Class


Max Property

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.Max Property
SequenceConfig Class See Also Send Feedback
The maximum value in the sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Max { get; }
Visual Basic (Declaration)
Public ReadOnly Property Max As Long
Visual C++
public:
property long long Max {
    long long get ();
}

See Also

SequenceConfig Class


Min Property

[image]

Berkeley DB .NET API Documentation
SequenceConfig..::.Min Property
SequenceConfig Class See Also Send Feedback
The minimum value in the sequence.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Min { get; }
Visual Basic (Declaration)
Public ReadOnly Property Min As Long
Visual C++
public:
property long long Min {
    long long get ();
}

See Also

SequenceConfig Class


SequenceStats Class

[image]

Berkeley DB .NET API Documentation
SequenceStats Class
Members See Also Send Feedback
Statistical information about a Sequence

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class SequenceStats
Visual Basic (Declaration)
Public Class SequenceStats
Visual C++
public ref class SequenceStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.SequenceStats

See Also

SequenceStats Members


SequenceStats Members

[image] [image]

Berkeley DB .NET API Documentation
SequenceStats Members
SequenceStats Class Methods Properties See Also Send Feedback

The SequenceStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
CachedValue | Current cached value.
CacheSize | Cache size.
Flags | Flag value.
LastCachedValue | Last cached value.
LockNoWait | Sequence lock granted after wait.
LockWait | Sequence lock granted w/o wait.
Max | Maximum value.
Min | Minimum value.
StoredValue | Current value in db.

See Also

SequenceStats Class


SequenceStats Methods

[image] [image]

Berkeley DB .NET API Documentation
SequenceStats Methods
SequenceStats Class See Also Send Feedback

The SequenceStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

SequenceStats Class


SequenceStats Properties

[image] [image]

Berkeley DB .NET API Documentation
SequenceStats Properties
SequenceStats Class See Also Send Feedback

The SequenceStats type exposes the following members.

Properties

Name | Description
CachedValue | Current cached value.
CacheSize | Cache size.
Flags | Flag value.
LastCachedValue | Last cached value.
LockNoWait | Sequence lock granted after wait.
LockWait | Sequence lock granted w/o wait.
Max | Maximum value.
Min | Minimum value.
StoredValue | Current value in db.

See Also

SequenceStats Class


CachedValue Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.CachedValue Property
SequenceStats Class See Also Send Feedback
Current cached value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long CachedValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property CachedValue As Long
Visual C++
public:
property long long CachedValue {
    long long get ();
}

See Also

SequenceStats Class


CacheSize Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.CacheSize Property
SequenceStats Class See Also Send Feedback
Cache size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint CacheSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property CacheSize As UInteger
Visual C++
public:
property unsigned int CacheSize {
    unsigned int get ();
}

See Also

SequenceStats Class


Flags Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.Flags Property
SequenceStats Class See Also Send Feedback
Flag value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Flags { get; }
Visual Basic (Declaration)
Public ReadOnly Property Flags As UInteger
Visual C++
public:
property unsigned int Flags {
    unsigned int get ();
}

See Also

SequenceStats Class


LastCachedValue Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.LastCachedValue Property
SequenceStats Class See Also Send Feedback
Last cached value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long LastCachedValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastCachedValue As Long
Visual C++
public:
property long long LastCachedValue {
    long long get ();
}

See Also

SequenceStats Class


LockNoWait Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.LockNoWait Property
SequenceStats Class See Also Send Feedback
Sequence lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockNoWait As ULong
Visual C++
public:
property unsigned long long LockNoWait {
    unsigned long long get ();
}

See Also

SequenceStats Class


LockWait Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.LockWait Property
SequenceStats Class See Also Send Feedback
Sequence lock granted w/o wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong LockWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property LockWait As ULong
Visual C++
public:
property unsigned long long LockWait {
    unsigned long long get ();
}

See Also

SequenceStats Class


Max Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.Max Property
SequenceStats Class See Also Send Feedback
Maximum value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Max { get; }
Visual Basic (Declaration)
Public ReadOnly Property Max As Long
Visual C++
public:
property long long Max {
    long long get ();
}

See Also

SequenceStats Class


Min Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.Min Property
SequenceStats Class See Also Send Feedback
Minimum value.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long Min { get; }
Visual Basic (Declaration)
Public ReadOnly Property Min As Long
Visual C++
public:
property long long Min {
    long long get ();
}

See Also

SequenceStats Class


StoredValue Property

[image]

Berkeley DB .NET API Documentation
SequenceStats..::.StoredValue Property
SequenceStats Class See Also Send Feedback
Current value in db.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long StoredValue { get; }
Visual Basic (Declaration)
Public ReadOnly Property StoredValue As Long
Visual C++
public:
property long long StoredValue {
    long long get ();
}

See Also

SequenceStats Class


SetThreadIDDelegate Delegate

[image]

Berkeley DB .NET API Documentation
SetThreadIDDelegate Delegate
See Also Send Feedback
A function which returns a unique identifier pair for a thread of control in a Berkeley DB application.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate DbThreadID SetThreadIDDelegate()
Visual Basic (Declaration)
Public Delegate Function SetThreadIDDelegate As DbThreadID
Visual C++
public delegate DbThreadID^ SetThreadIDDelegate()

Return Value

A DbThreadID object describing the current thread of control

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


SetThreadNameDelegate Delegate

[image]

Berkeley DB .NET API Documentation
SetThreadNameDelegate Delegate
See Also Send Feedback
A function which returns an identifier pair for a thread of control formatted for display.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate string SetThreadNameDelegate(
    DbThreadID info
)
Visual Basic (Declaration)
Public Delegate Function SetThreadNameDelegate ( _
    info As DbThreadID _
) As String
Visual C++
public delegate String^ SetThreadNameDelegate(
    DbThreadID^ info
)

Parameters

info
Type: BerkeleyDB..::.DbThreadID
The thread of control to format

Return Value

The formatted identifier pair

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


ThreadIsAliveDelegate Delegate

[image]

Berkeley DB .NET API Documentation
ThreadIsAliveDelegate Delegate
See Also Send Feedback
A function which returns whether the thread of control, identified by info, is still running.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public delegate bool ThreadIsAliveDelegate(
    DbThreadID info,
    bool procOnly
)
Visual Basic (Declaration)
Public Delegate Function ThreadIsAliveDelegate ( _
    info As DbThreadID, _
    procOnly As Boolean _
) As Boolean
Visual C++
public delegate bool ThreadIsAliveDelegate(
    DbThreadID^ info,
    bool procOnly
)

Parameters

info
Type: BerkeleyDB..::.DbThreadID
The thread of control to check
procOnly
Type: System..::.Boolean
If true, return only if the process is alive, and the threadID portion of info should be ignored.

Return Value

True if the tread is alive, false otherwise.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


Transaction Class

[image]

Berkeley DB .NET API Documentation
Transaction Class
Members See Also Send Feedback
A class representing Berkeley DB transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class Transaction
Visual Basic (Declaration)
Public Class Transaction
Visual C++
public ref class Transaction

Remarks

Calling Abort()()(),
Commit()()() or
Discard()()() releases the resources held by
the created object.

Transactions may only span threads if they do so serially; each transaction must be active in only a single thread of control at a time. This restriction holds for parents of nested transactions as well; no two children may be concurrently active in more than one thread of control at any one time.

Cursors may not span transactions; each cursor must be opened and closed within a single transaction.

A parent transaction may not issue any Berkeley DB operations except for BeginTransaction()()(), Abort()()()and Commit()()() while it has active child transactions (child transactions that have not yet been committed or aborted).

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.Transaction

See Also

Transaction Members


Transaction Members

[image] [image]

Berkeley DB .NET API Documentation
Transaction Members
Transaction Class Methods Fields Properties See Also Send Feedback

The Transaction type exposes the following members.

Methods

Name | Description
Abort | Cause an abnormal termination of the transaction.
Commit | Overloaded. In the case of nested transactions, if the transaction is a parent transaction, committing the parent transaction causes all unresolved children of the parent to be committed. In the case of nested transactions, if the transaction is a child transaction, its locks are not released, but are acquired by its parent. Although the commit of the child transaction succeeds, the actual resolution of the child transaction is postponed until the parent transaction is committed or aborted; if its parent transaction commits, it is committed; and if its parent transaction aborts, it is aborted. All cursors opened within the transaction must be closed before the transaction is committed. If there are cursor handles open when this method is called, they are all closed inside this method. And if there are errors when closing the cursor handles, the transaction is aborted and the first such error is returned.
Discard | Free up all the per-process resources associated with the specified Transaction instance, neither committing nor aborting the transaction.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Prepare | Initiate the beginning of a two-phase commit.
SetLockTimeout | Set the timeout value for locks for this transaction.
SetTxnTimeout | Set the timeout value for transactions for this transaction.
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
GlobalIdLength | The size of the global transaction ID

Properties

Name | Description
CommitToken | The commit token generated at the commit time of this transaction. This operation can only be performed after this transaction has committed.
Id | The unique transaction id associated with this transaction.
Name | The transaction's name. The name is returned by TransactionSystemStats()()() and displayed by PrintTransactionSystemStats()()().
Priority | The deadlock priority for this transaction. The deadlock detector rejects lock requests from lower priority transactions before those from higher priority transactions.

See Also

Transaction Class


Transaction Fields

[image] [image]

Berkeley DB .NET API Documentation
Transaction Fields
Transaction Class See Also Send Feedback

The Transaction type exposes the following members.

Fields

Name | Description
GlobalIdLength | The size of the global transaction ID

See Also

Transaction Class


GlobalIdLength Field

[image]

Berkeley DB .NET API Documentation
Transaction..::.GlobalIdLength Field
Transaction Class See Also Send Feedback
The size of the global transaction ID

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public static uint GlobalIdLength
Visual Basic (Declaration)
Public Shared GlobalIdLength As UInteger
Visual C++
public:
static unsigned int GlobalIdLength

See Also

Transaction Class


Transaction Methods

[image] [image]

Berkeley DB .NET API Documentation
Transaction Methods
Transaction Class See Also Send Feedback

The Transaction type exposes the following members.

Methods

Name | Description
Abort | Cause an abnormal termination of the transaction.
Commit | Overloaded. In the case of nested transactions, if the transaction is a parent transaction, committing the parent transaction causes all unresolved children of the parent to be committed. In the case of nested transactions, if the transaction is a child transaction, its locks are not released, but are acquired by its parent. Although the commit of the child transaction succeeds, the actual resolution of the child transaction is postponed until the parent transaction is committed or aborted; if its parent transaction commits, it is committed; and if its parent transaction aborts, it is aborted. All cursors opened within the transaction must be closed before the transaction is committed. If there are cursor handles open when this method is called, they are all closed inside this method. And if there are errors when closing the cursor handles, the transaction is aborted and the first such error is returned.
Discard | Free up all the per-process resources associated with the specified Transaction instance, neither committing nor aborting the transaction.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
Prepare | Initiate the beginning of a two-phase commit.
SetLockTimeout | Set the timeout value for locks for this transaction.
SetTxnTimeout | Set the timeout value for transactions for this transaction.
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Transaction Class


Abort Method

[image]

Berkeley DB .NET API Documentation
Transaction..::.Abort Method
Transaction Class See Also Send Feedback
Cause an abnormal termination of the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Abort()
Visual Basic (Declaration)
Public Sub Abort
Visual C++
public:
void Abort()

Remarks

Before Abort returns, any locks held by the transaction are released.

In the case of nested transactions, aborting a parent transaction causes all children (unresolved or not) of the parent transaction to be aborted.

All cursors opened within the transaction must be closed before the transaction is aborted. This method closes all open cursor handles, if any. And if a close operation fails, the rest of the cursors are closed, and the database environment is set to the panic state.

See Also

Transaction Class


Commit Method

[image] [image]

Berkeley DB .NET API Documentation
Transaction..::.Commit Method
Transaction Class See Also Send Feedback

In the case of nested transactions, if the transaction is a parent transaction, committing the parent transaction causes all unresolved children of the parent to be committed. In the case of nested transactions, if the transaction is a child transaction, its locks are not released, but are acquired by its parent. Although the commit of the child transaction succeeds, the actual resolution of the child transaction is postponed until the parent transaction is committed or aborted; if its parent transaction commits, it is committed; and if its parent transaction aborts, it is aborted.

All cursors opened within the transaction must be closed before the transaction is committed. If there are cursor handles open when this method is called, they are all closed inside this method. And if there are errors when closing the cursor handles, the transaction is aborted and the first such error is returned.

Overload List

Name | Description
Commit()()() | End the transaction.
Commit(Boolean) | End the transaction.

See Also

Transaction Class
Transaction Members


Commit Method

[image]

Berkeley DB .NET API Documentation
Transaction..::.Commit Method
Transaction Class See Also Send Feedback
End the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Commit()
Visual Basic (Declaration)
Public Sub Commit
Visual C++
public:
void Commit()

See Also

Transaction Class
Commit Overload


Commit Method (Boolean)

[image]

Berkeley DB .NET API Documentation
Transaction..::.Commit Method (Boolean)
Transaction Class See Also Send Feedback
End the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Commit(
    bool syncLog
)
Visual Basic (Declaration)
Public Sub Commit ( _
    syncLog As Boolean _
)
Visual C++
public:
void Commit(
    bool syncLog
)

Parameters

syncLog
Type: System..::.Boolean
If true, synchronously flush the log.

Remarks

Synchronously flushing the log is the default for Berkeley DB environments unless TxnNoSync was specified. Synchronous log flushing may also be set or unset for a single transaction using BeginTransaction()()(). The value of syncLog overrides both of those settings.

See Also

Transaction Class
Commit Overload


Discard Method

[image]

Berkeley DB .NET API Documentation
Transaction..::.Discard Method
Transaction Class See Also Send Feedback
Free up all the per-process resources associated with the specified Transaction instance, neither committing nor aborting the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Discard()
Visual Basic (Declaration)
Public Sub Discard
Visual C++
public:
void Discard()

Remarks

If there are cursor handles open when this method is called, they are all closed inside this method. And if there are errors when closing the cursor handles, the first such error is returned. This call may be used only after calls to Recover(Int32, Boolean) when there are multiple global transaction managers recovering transactions in a single Berkeley DB environment. Any transactions returned by Recover(Int32, Boolean) that are not handled by the current global transaction manager should be discarded using Discard.

See Also

Transaction Class


Prepare Method

[image]

Berkeley DB .NET API Documentation
Transaction..::.Prepare Method
Transaction Class See Also Send Feedback
Initiate the beginning of a two-phase commit.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void Prepare(
    byte[] globalId
)
Visual Basic (Declaration)
Public Sub Prepare ( _
    globalId As Byte() _
)
Visual C++
public:
void Prepare(
    array<unsigned char>^ globalId
)

Parameters

globalId
Type: array< System..::.Byte >[]()[]
The global transaction ID by which this transaction is known. This global transaction ID is returned in calls to Recover(Int32, Boolean) telling the application which global transactions must be resolved.

Remarks

In a distributed transaction environment, Berkeley DB can be used as a local transaction manager. In this case, the distributed transaction manager must send prepare messages to each local manager. The local manager must then call Prepare and await its successful return before responding to the distributed transaction manager. Only after the distributed transaction manager receives successful responses from all of its prepare messages should it issue any commit messages.

In the case of nested transactions, preparing the parent causes all unresolved children of the parent transaction to be committed. Child transactions should never be explicitly prepared. Their fate is resolved along with their parent's during global recovery.

If there are cursor handles open when this method is called, they are all closed inside this method. And if there are errors when closing the cursor handles, the first such error is returned.

See Also

Transaction Class


SetLockTimeout Method

[image]

Berkeley DB .NET API Documentation
Transaction..::.SetLockTimeout Method
Transaction Class See Also Send Feedback
Set the timeout value for locks for this transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetLockTimeout(
    uint timeout
)
Visual Basic (Declaration)
Public Sub SetLockTimeout ( _
    timeout As UInteger _
)
Visual C++
public:
void SetLockTimeout(
    unsigned int timeout
)

Parameters

timeout
Type: System..::.UInt32
An unsigned 32-bit number of microseconds, limiting the maximum timeout to roughly 71 minutes. A value of 0 disables timeouts for the transaction.

Remarks

Timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. This timeout is for any single lock request. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values may be specified for the database environment as a whole. See LockTimeout for more information.

See Also

Transaction Class


SetTxnTimeout Method

[image]

Berkeley DB .NET API Documentation
Transaction..::.SetTxnTimeout Method
Transaction Class See Also Send Feedback
Set the timeout value for transactions for this transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public void SetTxnTimeout(
    uint timeout
)
Visual Basic (Declaration)
Public Sub SetTxnTimeout ( _
    timeout As UInteger _
)
Visual C++
public:
void SetTxnTimeout(
    unsigned int timeout
)

Parameters

timeout
Type: System..::.UInt32
An unsigned 32-bit number of microseconds, limiting the maximum timeout to roughly 71 minutes. A value of 0 disables timeouts for the transaction.

Remarks

Timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. This timeout is for the life of the transaction. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values may be specified for the database environment as a whole. See TxnTimeout for more information.

See Also

Transaction Class


Transaction Properties

[image] [image]

Berkeley DB .NET API Documentation
Transaction Properties
Transaction Class See Also Send Feedback

The Transaction type exposes the following members.

Properties

Name | Description
CommitToken | The commit token generated at the commit time of this transaction. This operation can only be performed after this transaction has committed.
Id | The unique transaction id associated with this transaction.
Name | The transaction's name. The name is returned by TransactionSystemStats()()() and displayed by PrintTransactionSystemStats()()().
Priority | The deadlock priority for this transaction. The deadlock detector rejects lock requests from lower priority transactions before those from higher priority transactions.

See Also

Transaction Class


CommitToken Property

[image]

Berkeley DB .NET API Documentation
Transaction..::.CommitToken Property
Transaction Class See Also Send Feedback
The commit token generated at the commit time of this transaction. This operation can only be performed after this transaction has committed.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public byte[] CommitToken { get; }
Visual Basic (Declaration)
Public ReadOnly Property CommitToken As Byte()
Visual C++
public:
property array<unsigned char>^ CommitToken {
    array<unsigned char>^ get ();
}

See Also

Transaction Class


Id Property

[image]

Berkeley DB .NET API Documentation
Transaction..::.Id Property
Transaction Class See Also Send Feedback
The unique transaction id associated with this transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As UInteger
Visual C++
public:
property unsigned int Id {
    unsigned int get ();
}

See Also

Transaction Class


Name Property

[image]

Berkeley DB .NET API Documentation
Transaction..::.Name Property
Transaction Class See Also Send Feedback
The transaction's name. The name is returned by TransactionSystemStats()()() and displayed by PrintTransactionSystemStats()()().

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

If the database environment has been configured for logging and the Berkeley DB library was built in Debug mode (or with DIAGNOSTIC defined), a debugging log record is written including the transaction ID and the name.

See Also

Transaction Class


Priority Property

[image]

Berkeley DB .NET API Documentation
Transaction..::.Priority Property
Transaction Class See Also Send Feedback
The deadlock priority for this transaction. The deadlock detector rejects lock requests from lower priority transactions before those from higher priority transactions.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Priority { get; set; }
Visual Basic (Declaration)
Public Property Priority As UInteger
Visual C++
public:
property unsigned int Priority {
    unsigned int get ();
    void set (unsigned int value);
}

See Also

Transaction Class


TransactionAppliedStatus Enumeration

[image]

Berkeley DB .NET API Documentation
TransactionAppliedStatus Enumeration
See Also Send Feedback
Status values from transaction application checking operations.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum TransactionAppliedStatus
Visual Basic (Declaration)
Public Enumeration TransactionAppliedStatus
Visual C++
public enum class TransactionAppliedStatus

Members

Member name | Description
APPLIED | The transaction has been applied on the current replica node.
TIMEOUT | The transaction has not yet been applied on this replica node.
EMPTY_TRANSACTION | The transaction did not update the database.
NOTFOUND | No such transaction found in the replication group.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


TransactionConfig Class

[image]

Berkeley DB .NET API Documentation
TransactionConfig Class
Members See Also Send Feedback
A class representing configuration parameters for a Transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class TransactionConfig
Visual Basic (Declaration)
Public Class TransactionConfig
Visual C++
public ref class TransactionConfig

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.TransactionConfig

See Also

TransactionConfig Members


TransactionConfig Members

[image] [image]

Berkeley DB .NET API Documentation
TransactionConfig Members
TransactionConfig Class Constructors Methods Fields Properties See Also Send Feedback

The TransactionConfig type exposes the following members.

Constructors

Name | Description
TransactionConfig | Instantiate a new TransactionConfig object

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
Bulk | Configures the transaction to enable or disable the transactional bulk insert optimization.
IsolationDegree | The degree of isolation for this transaction
NoWait | If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw a DeadlockException (or LockNotGrantedException if configured with TimeNotGranted).
Snapshot | If true, this transaction executes with snapshot isolation.
SyncAction | Log sync behavior on transaction commit or prepare.

Properties

Name | Description
InitTransactionCount | The initial number of simultaneous transactions that are allocated for in the Berkeley DB environment
LockTimeout | The timeout value for locks for the transaction.
Name | The transaction's name. The name is returned by TransactionSystemStats()()() and displayed by PrintTransactionSystemStats()()().
TxnTimeout | The timeout value for locks for the transaction.

See Also

TransactionConfig Class


TransactionConfig Constructor

[image]

Berkeley DB .NET API Documentation
TransactionConfig Constructor
TransactionConfig Class See Also Send Feedback
Instantiate a new TransactionConfig object

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public TransactionConfig()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TransactionConfig()

See Also

TransactionConfig Class


TransactionConfig Fields

[image] [image]

Berkeley DB .NET API Documentation
TransactionConfig Fields
TransactionConfig Class See Also Send Feedback

The TransactionConfig type exposes the following members.

Fields

Name | Description
Bulk | Configures the transaction to enable or disable the transactional bulk insert optimization.
IsolationDegree | The degree of isolation for this transaction
NoWait | If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw a DeadlockException (or LockNotGrantedException if configured with TimeNotGranted).
Snapshot | If true, this transaction executes with snapshot isolation.
SyncAction | Log sync behavior on transaction commit or prepare.

See Also

TransactionConfig Class


Bulk Field

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.Bulk Field
TransactionConfig Class See Also Send Feedback
Configures the transaction to enable or disable the transactional bulk insert optimization.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Bulk
Visual Basic (Declaration)
Public Bulk As Boolean
Visual C++
public:
bool Bulk

Remarks

When this attribute is set, the transaction avoids logging the contents of insertions on newly allocated database pages. In a transaction that inserts a large number of new records, the I/O savings of choosing this option can be significant. Users of this option should be aware of several issues. When the optimization is in effect, page allocations that extend the database file are logged as usual; this allows transaction aborts to work correctly, both online and during recovery. At commit time, the database's pages are flushed to disk, eliminating the need to roll-forward the transaction during normal recovery. However, there are other recovery operations that depend on roll-forward, and care must be taken when Bulk-enabled transactions interact with them. In particular, Bulk is incompatible with replication, and is simply ignored when replication is enabled. Also, hot backup procedures must follow a particular protocol, introduced in 11gr2.5.1, to set a flag in the environment before starting to copy files. Incremental hot backups can be invalidated by use of the bulk insert optimization. Please see the hot backup description in the Getting Started with Transactions Guide, and the description of the HotbackupInProgress attribute in HotbackupInProgress for further information.

The bulk insert optimization is effective only for top-level transactions.

See Also

TransactionConfig Class


IsolationDegree Field

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.IsolationDegree Field
TransactionConfig Class See Also Send Feedback
The degree of isolation for this transaction

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public Isolation IsolationDegree
Visual Basic (Declaration)
Public IsolationDegree As Isolation
Visual C++
public:
Isolation IsolationDegree

See Also

TransactionConfig Class


NoWait Field

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.NoWait Field
TransactionConfig Class See Also Send Feedback
If true and a lock is unavailable for any Berkeley DB operation performed in the context of a transaction, cause the operation to throw a DeadlockException (or LockNotGrantedException if configured with TimeNotGranted).

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool NoWait
Visual Basic (Declaration)
Public NoWait As Boolean
Visual C++
public:
bool NoWait

Remarks

This setting overrides the behavior specified by TxnNoWait.

See Also

TransactionConfig Class


Snapshot Field

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.Snapshot Field
TransactionConfig Class See Also Send Feedback
If true, this transaction executes with snapshot isolation.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Snapshot
Visual Basic (Declaration)
Public Snapshot As Boolean
Visual C++
public:
bool Snapshot

Remarks

For databases with UseMVCC set, data values are read as they are when the transaction begins, without taking read locks. Silently ignored for operations on databases with UseMVCC not set on the underlying database (read locks are acquired).

A DeadlockException is thrown from update operations if a snapshot transaction attempts to update data which was modified after the snapshot transaction read it.

See Also

TransactionConfig Class


SyncAction Field

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.SyncAction Field
TransactionConfig Class See Also Send Feedback
Log sync behavior on transaction commit or prepare.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public TransactionConfig..::.LogFlush SyncAction
Visual Basic (Declaration)
Public SyncAction As TransactionConfig..::.LogFlush
Visual C++
public:
TransactionConfig..::.LogFlush SyncAction

Remarks

This setting overrides the behavior specified by TxnNoSync and TxnWriteNoSync.

See Also

TransactionConfig Class


TransactionConfig Methods

[image] [image]

Berkeley DB .NET API Documentation
TransactionConfig Methods
TransactionConfig Class See Also Send Feedback

The TransactionConfig type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TransactionConfig Class


TransactionConfig Properties

[image] [image]

Berkeley DB .NET API Documentation
TransactionConfig Properties
TransactionConfig Class See Also Send Feedback

The TransactionConfig type exposes the following members.

Properties

Name | Description
InitTransactionCount | The initial number of simultaneous transactions that are allocated for in the Berkeley DB environment
LockTimeout | The timeout value for locks for the transaction.
Name | The transaction's name. The name is returned by TransactionSystemStats()()() and displayed by PrintTransactionSystemStats()()().
TxnTimeout | The timeout value for locks for the transaction.

See Also

TransactionConfig Class


InitTransactionCount Property

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.InitTransactionCount Property
TransactionConfig Class See Also Send Feedback
The initial number of simultaneous transactions that are allocated for in the Berkeley DB environment

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitTransactionCount { get; set; }
Visual Basic (Declaration)
Public Property InitTransactionCount As UInteger
Visual C++
public:
property unsigned int InitTransactionCount {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

This value is used by Open(String, DatabaseEnvironmentConfig) to force Berkeley DB to allocate a certain number of transaction objects when the environment is created. This can be useful if an application uses a large number of transaction objects, and experiences performance issues with the default dynamic allocation algorithm.

If the database environment already exists when Open(String, DatabaseEnvironmentConfig) is called, the value of InitLockers will be ignored.

See Also

TransactionConfig Class


LockTimeout Property

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.LockTimeout Property
TransactionConfig Class See Also Send Feedback
The timeout value for locks for the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LockTimeout { get; set; }
Visual Basic (Declaration)
Public Property LockTimeout As UInteger
Visual C++
public:
property unsigned int LockTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. This timeout is for any single lock request. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values may be specified for the database environment as a whole. See LockTimeout for more information.

See Also

TransactionConfig Class


Name Property

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.Name Property
TransactionConfig Class See Also Send Feedback
The transaction's name. The name is returned by TransactionSystemStats()()() and displayed by PrintTransactionSystemStats()()().

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

If the database environment has been configured for logging and the Berkeley DB library was built in Debug mode (or with DIAGNOSTIC defined), a debugging log record is written including the transaction ID and the name.

See Also

TransactionConfig Class


TxnTimeout Property

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.TxnTimeout Property
TransactionConfig Class See Also Send Feedback
The timeout value for locks for the transaction.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint TxnTimeout { get; set; }
Visual Basic (Declaration)
Public Property TxnTimeout As UInteger
Visual C++
public:
property unsigned int TxnTimeout {
    unsigned int get ();
    void set (unsigned int value);
}

Remarks

Timeouts are checked whenever a thread of control blocks on a lock or when deadlock detection is performed. This timeout is for the life of the transaction. As timeouts are only checked when the lock request first blocks or when deadlock detection is performed, the accuracy of the timeout depends on how often deadlock detection is performed.

Timeout values may be specified for the database environment as a whole. See TxnTimeout for more information.

See Also

TransactionConfig Class


TransactionConfig.LogFlush Enumeration

[image]

Berkeley DB .NET API Documentation
TransactionConfig..::.LogFlush Enumeration
TransactionConfig Class See Also Send Feedback
Specifies the log flushing behavior on transaction commit

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public enum LogFlush
Visual Basic (Declaration)
Public Enumeration LogFlush
Visual C++
public enum class LogFlush

Members

Member name | Description
DEFAULT | Use Berkeley DB's default behavior of syncing the log on commit.
NOSYNC | Berkeley DB does not write or synchronously flush the log on transaction commit or prepare.
WRITE_NOSYNC | Berkeley DB writes, but does not synchronously flush, the log on transaction commit or prepare.
SYNC | Berkeley DB synchronously flushes the log on transaction commit or prepare.

See Also

BerkeleyDB Namespace
Report Feedback on this item in the Oracle Technology Network Forum

Copyright (c) 2008, 2015 Oracle. All rights reserved.


TransactionStats Class

[image]

Berkeley DB .NET API Documentation
TransactionStats Class
Members See Also Send Feedback
Statistical information about the transaction subsystem.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class TransactionStats
Visual Basic (Declaration)
Public Class TransactionStats
Visual C++
public ref class TransactionStats

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.TransactionStats

See Also

TransactionStats Members


TransactionStats Members

[image] [image]

Berkeley DB .NET API Documentation
TransactionStats Members
TransactionStats Class Methods Properties See Also Send Feedback

The TransactionStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

Name | Description
Aborted | Number of aborted transactions
Active | Number of active transactions
Begun | Number of begun transactions
Committed | Number of committed transactions
InitTxns | Initial number of transactions configured.
LastCheckpoint | LSN of the last checkpoint
LastCheckpointTime | Time of last checkpoint
LastID | Last transaction id given out
MaxActive | Maximum active transactions
MaxSnapshot | Maximum snapshot transactions
MaxTransactions | Maximum transactions possible
RegionLockNoWait | Region lock granted without wait.
RegionLockWait | Region lock granted after wait.
RegionSize | Region size.
Restored | Number of restored transactions after recovery.
Snapshot | Number of snapshot transactions
Transactions | List of active transactions

See Also

TransactionStats Class


TransactionStats Methods

[image] [image]

Berkeley DB .NET API Documentation
TransactionStats Methods
TransactionStats Class See Also Send Feedback

The TransactionStats type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

TransactionStats Class


TransactionStats Properties

[image] [image]

Berkeley DB .NET API Documentation
TransactionStats Properties
TransactionStats Class See Also Send Feedback

The TransactionStats type exposes the following members.

Properties

Name | Description
Aborted | Number of aborted transactions
Active | Number of active transactions
Begun | Number of begun transactions
Committed | Number of committed transactions
InitTxns | Initial number of transactions configured.
LastCheckpoint | LSN of the last checkpoint
LastCheckpointTime | Time of last checkpoint
LastID | Last transaction id given out
MaxActive | Maximum active transactions
MaxSnapshot | Maximum snapshot transactions
MaxTransactions | Maximum transactions possible
RegionLockNoWait | Region lock granted without wait.
RegionLockWait | Region lock granted after wait.
RegionSize | Region size.
Restored | Number of restored transactions after recovery.
Snapshot | Number of snapshot transactions
Transactions | List of active transactions

See Also

TransactionStats Class


Aborted Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.Aborted Property
TransactionStats Class See Also Send Feedback
Number of aborted transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Aborted { get; }
Visual Basic (Declaration)
Public ReadOnly Property Aborted As ULong
Visual C++
public:
property unsigned long long Aborted {
    unsigned long long get ();
}

See Also

TransactionStats Class


Active Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.Active Property
TransactionStats Class See Also Send Feedback
Number of active transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Active { get; }
Visual Basic (Declaration)
Public ReadOnly Property Active As UInteger
Visual C++
public:
property unsigned int Active {
    unsigned int get ();
}

See Also

TransactionStats Class


Begun Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.Begun Property
TransactionStats Class See Also Send Feedback
Number of begun transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Begun { get; }
Visual Basic (Declaration)
Public ReadOnly Property Begun As ULong
Visual C++
public:
property unsigned long long Begun {
    unsigned long long get ();
}

See Also

TransactionStats Class


Committed Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.Committed Property
TransactionStats Class See Also Send Feedback
Number of committed transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong Committed { get; }
Visual Basic (Declaration)
Public ReadOnly Property Committed As ULong
Visual C++
public:
property unsigned long long Committed {
    unsigned long long get ();
}

See Also

TransactionStats Class


InitTxns Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.InitTxns Property
TransactionStats Class See Also Send Feedback
Initial number of transactions configured.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint InitTxns { get; }
Visual Basic (Declaration)
Public ReadOnly Property InitTxns As UInteger
Visual C++
public:
property unsigned int InitTxns {
    unsigned int get ();
}

See Also

TransactionStats Class


LastCheckpoint Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.LastCheckpoint Property
TransactionStats Class See Also Send Feedback
LSN of the last checkpoint

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public LSN LastCheckpoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastCheckpoint As LSN
Visual C++
public:
property LSN^ LastCheckpoint {
    LSN^ get ();
}

See Also

TransactionStats Class


LastCheckpointTime Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.LastCheckpointTime Property
TransactionStats Class See Also Send Feedback
Time of last checkpoint

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public long LastCheckpointTime { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastCheckpointTime As Long
Visual C++
public:
property long long LastCheckpointTime {
    long long get ();
}

See Also

TransactionStats Class


LastID Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.LastID Property
TransactionStats Class See Also Send Feedback
Last transaction id given out

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint LastID { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastID As UInteger
Visual C++
public:
property unsigned int LastID {
    unsigned int get ();
}

See Also

TransactionStats Class


MaxActive Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.MaxActive Property
TransactionStats Class See Also Send Feedback
Maximum active transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxActive { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxActive As UInteger
Visual C++
public:
property unsigned int MaxActive {
    unsigned int get ();
}

See Also

TransactionStats Class


MaxSnapshot Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.MaxSnapshot Property
TransactionStats Class See Also Send Feedback
Maximum snapshot transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxSnapshot { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxSnapshot As UInteger
Visual C++
public:
property unsigned int MaxSnapshot {
    unsigned int get ();
}

See Also

TransactionStats Class


MaxTransactions Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.MaxTransactions Property
TransactionStats Class See Also Send Feedback
Maximum transactions possible

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint MaxTransactions { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxTransactions As UInteger
Visual C++
public:
property unsigned int MaxTransactions {
    unsigned int get ();
}

See Also

TransactionStats Class


RegionLockNoWait Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.RegionLockNoWait Property
TransactionStats Class See Also Send Feedback
Region lock granted without wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionLockNoWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionLockNoWait As ULong
Visual C++
public:
property unsigned long long RegionLockNoWait {
    unsigned long long get ();
}

See Also

TransactionStats Class


RegionLockWait Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.RegionLockWait Property
TransactionStats Class See Also Send Feedback
Region lock granted after wait.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionLockWait { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionLockWait As ULong
Visual C++
public:
property unsigned long long RegionLockWait {
    unsigned long long get ();
}

See Also

TransactionStats Class


RegionSize Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.RegionSize Property
TransactionStats Class See Also Send Feedback
Region size.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public ulong RegionSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property RegionSize As ULong
Visual C++
public:
property unsigned long long RegionSize {
    unsigned long long get ();
}

See Also

TransactionStats Class


Restored Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.Restored Property
TransactionStats Class See Also Send Feedback
Number of restored transactions after recovery.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Restored { get; }
Visual Basic (Declaration)
Public ReadOnly Property Restored As UInteger
Visual C++
public:
property unsigned int Restored {
    unsigned int get ();
}

See Also

TransactionStats Class


Snapshot Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.Snapshot Property
TransactionStats Class See Also Send Feedback
Number of snapshot transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public uint Snapshot { get; }
Visual Basic (Declaration)
Public ReadOnly Property Snapshot As UInteger
Visual C++
public:
property unsigned int Snapshot {
    unsigned int get ();
}

See Also

TransactionStats Class


Transactions Property

[image]

Berkeley DB .NET API Documentation
TransactionStats..::.Transactions Property
TransactionStats Class See Also Send Feedback
List of active transactions

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public List<ActiveTransaction> Transactions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transactions As List(Of ActiveTransaction)
Visual C++
public:
property List<ActiveTransaction^>^ Transactions {
    List<ActiveTransaction^>^ get ();
}

See Also

TransactionStats Class


VerboseMessages Class

[image]

Berkeley DB .NET API Documentation
VerboseMessages Class
Members See Also Send Feedback
Enable specific additional informational and debugging messages.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class VerboseMessages
Visual Basic (Declaration)
Public Class VerboseMessages
Visual C++
public ref class VerboseMessages

Inheritance Hierarchy

System..::.Object
BerkeleyDB..::.VerboseMessages

See Also

VerboseMessages Members


VerboseMessages Members

[image] [image]

Berkeley DB .NET API Documentation
VerboseMessages Members
VerboseMessages Class Constructors Methods Fields See Also Send Feedback

The VerboseMessages type exposes the following members.

Constructors

Name | Description
VerboseMessages | Initializes a new instance of the VerboseMessages class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

Fields

Name | Description
AllFileOps | Display additional information when performing all filesystem operations, including read and write. May not be available on all platforms.
Backup | Display additional information when performing hot backup.
Deadlock | Display additional information when doing deadlock detection.
FileOps | Display additional information when performing filesystem operations such as open, close or rename. May not be available on all platforms.
Recovery | Display additional information when performing recovery.
Register | Display additional information concerning support for Register
Replication | Display all detailed information about replication. This includes the information displayed by all of the other Replication* and RepMgr* values.
ReplicationElection | Display detailed information about replication elections.
ReplicationLease | Display detailed information about replication master leases.
ReplicationMessages | Display detailed information about replication message processing.
ReplicationMisc | Display detailed information about general replication processing not covered by the other Replication* values.
ReplicationSync | Display detailed information about replication client synchronization.
ReplicationSystemInfo | Saves replication system information to a system-owned file. This value is on by default.
ReplicationTest |
RepMgrConnectionFailure | Display detailed information about Replication Manager connection failures.
RepMgrMisc | Display detailed information about general Replication Manager processing.
WaitsForTable | Display the waits-for table when doing deadlock detection.

See Also

VerboseMessages Class


VerboseMessages Constructor

[image]

Berkeley DB .NET API Documentation
VerboseMessages Constructor
VerboseMessages Class See Also Send Feedback
Initializes a new instance of the VerboseMessages class

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public VerboseMessages()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VerboseMessages()

See Also

VerboseMessages Class


VerboseMessages Fields

[image] [image]

Berkeley DB .NET API Documentation
VerboseMessages Fields
VerboseMessages Class See Also Send Feedback

The VerboseMessages type exposes the following members.

Fields

Name | Description
AllFileOps | Display additional information when performing all filesystem operations, including read and write. May not be available on all platforms.
Backup | Display additional information when performing hot backup.
Deadlock | Display additional information when doing deadlock detection.
FileOps | Display additional information when performing filesystem operations such as open, close or rename. May not be available on all platforms.
Recovery | Display additional information when performing recovery.
Register | Display additional information concerning support for Register
Replication | Display all detailed information about replication. This includes the information displayed by all of the other Replication* and RepMgr* values.
ReplicationElection | Display detailed information about replication elections.
ReplicationLease | Display detailed information about replication master leases.
ReplicationMessages | Display detailed information about replication message processing.
ReplicationMisc | Display detailed information about general replication processing not covered by the other Replication* values.
ReplicationSync | Display detailed information about replication client synchronization.
ReplicationSystemInfo | Saves replication system information to a system-owned file. This value is on by default.
ReplicationTest |
RepMgrConnectionFailure | Display detailed information about Replication Manager connection failures.
RepMgrMisc | Display detailed information about general Replication Manager processing.
WaitsForTable | Display the waits-for table when doing deadlock detection.

See Also

VerboseMessages Class


AllFileOps Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.AllFileOps Field
VerboseMessages Class See Also Send Feedback
Display additional information when performing all filesystem operations, including read and write. May not be available on all platforms.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool AllFileOps
Visual Basic (Declaration)
Public AllFileOps As Boolean
Visual C++
public:
bool AllFileOps

See Also

VerboseMessages Class


Backup Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.Backup Field
VerboseMessages Class See Also Send Feedback
Display additional information when performing hot backup.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Backup
Visual Basic (Declaration)
Public Backup As Boolean
Visual C++
public:
bool Backup

See Also

VerboseMessages Class


Deadlock Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.Deadlock Field
VerboseMessages Class See Also Send Feedback
Display additional information when doing deadlock detection.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Deadlock
Visual Basic (Declaration)
Public Deadlock As Boolean
Visual C++
public:
bool Deadlock

See Also

VerboseMessages Class


FileOps Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.FileOps Field
VerboseMessages Class See Also Send Feedback
Display additional information when performing filesystem operations such as open, close or rename. May not be available on all platforms.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool FileOps
Visual Basic (Declaration)
Public FileOps As Boolean
Visual C++
public:
bool FileOps

See Also

VerboseMessages Class


Recovery Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.Recovery Field
VerboseMessages Class See Also Send Feedback
Display additional information when performing recovery.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Recovery
Visual Basic (Declaration)
Public Recovery As Boolean
Visual C++
public:
bool Recovery

See Also

VerboseMessages Class


Register Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.Register Field
VerboseMessages Class See Also Send Feedback
Display additional information concerning support for Register

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Register
Visual Basic (Declaration)
Public Register As Boolean
Visual C++
public:
bool Register

See Also

VerboseMessages Class


Replication Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.Replication Field
VerboseMessages Class See Also Send Feedback
Display all detailed information about replication. This includes the information displayed by all of the other Replication* and RepMgr* values.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool Replication
Visual Basic (Declaration)
Public Replication As Boolean
Visual C++
public:
bool Replication

See Also

VerboseMessages Class


ReplicationElection Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.ReplicationElection Field
VerboseMessages Class See Also Send Feedback
Display detailed information about replication elections.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReplicationElection
Visual Basic (Declaration)
Public ReplicationElection As Boolean
Visual C++
public:
bool ReplicationElection

See Also

VerboseMessages Class


ReplicationLease Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.ReplicationLease Field
VerboseMessages Class See Also Send Feedback
Display detailed information about replication master leases.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReplicationLease
Visual Basic (Declaration)
Public ReplicationLease As Boolean
Visual C++
public:
bool ReplicationLease

See Also

VerboseMessages Class


ReplicationMessages Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.ReplicationMessages Field
VerboseMessages Class See Also Send Feedback
Display detailed information about replication message processing.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReplicationMessages
Visual Basic (Declaration)
Public ReplicationMessages As Boolean
Visual C++
public:
bool ReplicationMessages

See Also

VerboseMessages Class


ReplicationMisc Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.ReplicationMisc Field
VerboseMessages Class See Also Send Feedback
Display detailed information about general replication processing not covered by the other Replication* values.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReplicationMisc
Visual Basic (Declaration)
Public ReplicationMisc As Boolean
Visual C++
public:
bool ReplicationMisc

See Also

VerboseMessages Class


ReplicationSync Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.ReplicationSync Field
VerboseMessages Class See Also Send Feedback
Display detailed information about replication client synchronization.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReplicationSync
Visual Basic (Declaration)
Public ReplicationSync As Boolean
Visual C++
public:
bool ReplicationSync

See Also

VerboseMessages Class


ReplicationSystemInfo Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.ReplicationSystemInfo Field
VerboseMessages Class See Also Send Feedback
Saves replication system information to a system-owned file. This value is on by default.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReplicationSystemInfo
Visual Basic (Declaration)
Public ReplicationSystemInfo As Boolean
Visual C++
public:
bool ReplicationSystemInfo

See Also

VerboseMessages Class


ReplicationTest Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.ReplicationTest Field
VerboseMessages Class See Also Send Feedback

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool ReplicationTest
Visual Basic (Declaration)
Public ReplicationTest As Boolean
Visual C++
public:
bool ReplicationTest

See Also

VerboseMessages Class


RepMgrConnectionFailure Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.RepMgrConnectionFailure Field
VerboseMessages Class See Also Send Feedback
Display detailed information about Replication Manager connection failures.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepMgrConnectionFailure
Visual Basic (Declaration)
Public RepMgrConnectionFailure As Boolean
Visual C++
public:
bool RepMgrConnectionFailure

See Also

VerboseMessages Class


RepMgrMisc Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.RepMgrMisc Field
VerboseMessages Class See Also Send Feedback
Display detailed information about general Replication Manager processing.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool RepMgrMisc
Visual Basic (Declaration)
Public RepMgrMisc As Boolean
Visual C++
public:
bool RepMgrMisc

See Also

VerboseMessages Class


WaitsForTable Field

[image]

Berkeley DB .NET API Documentation
VerboseMessages..::.WaitsForTable Field
VerboseMessages Class See Also Send Feedback
Display the waits-for table when doing deadlock detection.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public bool WaitsForTable
Visual Basic (Declaration)
Public WaitsForTable As Boolean
Visual C++
public:
bool WaitsForTable

See Also

VerboseMessages Class


VerboseMessages Methods

[image] [image]

Berkeley DB .NET API Documentation
VerboseMessages Methods
VerboseMessages Class See Also Send Feedback

The VerboseMessages type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the type of the current instance. (Inherited from Object.)
ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

VerboseMessages Class


VerificationException Class

[image]

Berkeley DB .NET API Documentation
VerificationException Class
Members See Also Send Feedback
Thrown by Verify(String, DatabaseConfig) if a database is corrupted, and by Salvage(String, DatabaseConfig) if all key/data pairs in the file may not have been successfully output.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class VerificationException : DatabaseException
Visual Basic (Declaration)
Public Class VerificationException _
    Inherits DatabaseException
Visual C++
public ref class VerificationException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.VerificationException

See Also

VerificationException Members


VerificationException Members

[image] [image]

Berkeley DB .NET API Documentation
VerificationException Members
VerificationException Class Constructors Methods Fields Properties See Also Send Feedback

The VerificationException type exposes the following members.

Constructors

Name | Description
VerificationException | Initialize a new instance of the VerificationException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VerificationException Class


VerificationException Constructor

[image]

Berkeley DB .NET API Documentation
VerificationException Constructor
VerificationException Class See Also Send Feedback
Initialize a new instance of the VerificationException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public VerificationException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VerificationException()

See Also

VerificationException Class


VerificationException Fields

[image] [image]

Berkeley DB .NET API Documentation
VerificationException Fields
VerificationException Class See Also Send Feedback

The VerificationException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

VerificationException Class


VerificationException Methods

[image] [image]

Berkeley DB .NET API Documentation
VerificationException Methods
VerificationException Class See Also Send Feedback

The VerificationException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

VerificationException Class


VerificationException Properties

[image] [image]

Berkeley DB .NET API Documentation
VerificationException Properties
VerificationException Class See Also Send Feedback

The VerificationException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VerificationException Class


VersionMismatchException Class

[image]

Berkeley DB .NET API Documentation
VersionMismatchException Class
Members See Also Send Feedback
The version of the Berkeley DB library does not match the version that created the database environment.

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public class VersionMismatchException : DatabaseException
Visual Basic (Declaration)
Public Class VersionMismatchException _
    Inherits DatabaseException
Visual C++
public ref class VersionMismatchException : public DatabaseException

Inheritance Hierarchy

System..::.Object
System..::.Exception
BerkeleyDB..::.DatabaseException
BerkeleyDB..::.VersionMismatchException

See Also

VersionMismatchException Members


VersionMismatchException Members

[image] [image]

Berkeley DB .NET API Documentation
VersionMismatchException Members
VersionMismatchException Class Constructors Methods Fields Properties See Also Send Feedback

The VersionMismatchException type exposes the following members.

Constructors

Name | Description
VersionMismatchException | Initialize a new instance of the VersionMismatchException

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VersionMismatchException Class


VersionMismatchException Constructor

[image]

Berkeley DB .NET API Documentation
VersionMismatchException Constructor
VersionMismatchException Class See Also Send Feedback
Initialize a new instance of the VersionMismatchException

Namespace: BerkeleyDB
Assembly: libdb_dotnet61 (in libdb_dotnet61.dll) Version: 6.1.23.0

Syntax

C#
public VersionMismatchException()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VersionMismatchException()

See Also

VersionMismatchException Class


VersionMismatchException Fields

[image] [image]

Berkeley DB .NET API Documentation
VersionMismatchException Fields
VersionMismatchException Class See Also Send Feedback

The VersionMismatchException type exposes the following members.

Fields

Name | Description
ErrorCode | The underlying error code from the Berkeley DB C library. (Inherited from DatabaseException.)

See Also

VersionMismatchException Class


VersionMismatchException Methods

[image] [image]

Berkeley DB .NET API Documentation
VersionMismatchException Methods
VersionMismatchException Class See Also Send Feedback

The VersionMismatchException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

VersionMismatchException Class


VersionMismatchException Properties

[image] [image]

Berkeley DB .NET API Documentation
VersionMismatchException Properties
VersionMismatchException Class See Also Send Feedback

The VersionMismatchException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

VersionMismatchException Class