summaryrefslogtreecommitdiff
path: root/PluginRoutingInterfaceCAPI/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'PluginRoutingInterfaceCAPI/CMakeLists.txt')
-rw-r--r--PluginRoutingInterfaceCAPI/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/PluginRoutingInterfaceCAPI/CMakeLists.txt b/PluginRoutingInterfaceCAPI/CMakeLists.txt
index c7b9594..416b9f0 100644
--- a/PluginRoutingInterfaceCAPI/CMakeLists.txt
+++ b/PluginRoutingInterfaceCAPI/CMakeLists.txt
@@ -48,7 +48,7 @@ FIND_PACKAGE(CommonAPI REQUIRED)
# The sources can be placed in the build directory (DESTINATION) or in the source tree (ALT_DESTINATION).
# The ALT_DESTINATION is used as fall back if the DESTINATION directory dosen't contain the sources or you just don't want to use the generator.
INCLUDE(CommonAPIGenerator)
-COMMON_API_GENERATE_SOUCRES(TARGET COMMON_API_ROUTING_INTERFACE
+COMMON_API_GENERATE_SOURCES(TARGET COMMON_API_ROUTING_INTERFACE
FIDLS fidl/RoutingInterface.fidl # a list with fidls
DESTINATION src-gen # a relative path to the build directory or an absolute path
ALT_DESTINATION ${CMAKE_CURRENT_SOURCE_DIR}/src-gen # an alternative relative/absolute path with common-api sources, usually in the source tree