summaryrefslogtreecommitdiff
path: root/PluginControlInterface/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'PluginControlInterface/test/CMakeLists.txt')
-rw-r--r--PluginControlInterface/test/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/PluginControlInterface/test/CMakeLists.txt b/PluginControlInterface/test/CMakeLists.txt
index 5209078..37de565 100644
--- a/PluginControlInterface/test/CMakeLists.txt
+++ b/PluginControlInterface/test/CMakeLists.txt
@@ -22,7 +22,7 @@ set(EXECUTABLE_OUTPUT_PATH ${TEST_EXECUTABLE_OUTPUT_PATH})
FIND_PACKAGE (Threads)
FIND_PACKAGE(PkgConfig)
-FIND_PACKAGE(GMock REQUIRED)
+
IF(WITH_DLT)
pkg_check_modules(DLT REQUIRED automotive-dlt>=2.2.0)
@@ -62,11 +62,11 @@ TARGET_LINK_LIBRARIES(AmControlReceiverShadowTest
${DBUS_LIBRARY}
${SQLITE_LIBRARIES}
gtest
- ${GMOCK_LIBRARY}
+ gmock
rt
)
-ADD_DEPENDENCIES(AmControlReceiverShadowTest gtest)
+ADD_DEPENDENCIES(AmControlReceiverShadowTest gtest gmock)
INSTALL(TARGETS AmControlReceiverShadowTest
DESTINATION "~/AudioManagerTest/"
@@ -74,6 +74,6 @@ INSTALL(TARGETS AmControlReceiverShadowTest
COMPONENT tests
)
-SET(ADD_DEPEND "audiomanager-bin" "dlt" "libdbus-1-3(>=1.2.16)" "google-mock" "libpthread-stubs0")
+SET(ADD_DEPEND "audiomanager-bin" "dlt" "libdbus-1-3(>=1.2.16)" "libpthread-stubs0")
set_property(GLOBAL APPEND PROPERTY tests_prop "${ADD_DEPEND}")