summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt24
1 files changed, 18 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index abf2a20..be3ed83 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,7 +98,15 @@ OPTION ( WITH_NSM
OPTION( WITH_PULSE_CONTROL_PLUGIN
"Enable PULSE Audio control plugin interface" OFF)
+OPTION( WITH_PULSE_ROUTING_PLUGIN
+ "Enable PULSE Audio routing plugin interface" OFF )
+
SET (WITH_COMMON_API_GEN ON CACHE INTERNAL "hide this!" FORCE)
+
+IF (WITH_PULSE_ROUTING_PLUGIN)
+ SET (WITH_DBUS_WRAPPER ON CACHE INTERNAL "hide this!" FORCE)
+ SET (WITH_CAPI_WRAPPER OFF CACHE INTERNAL "hide this!" FORCE)
+ENDIF (WITH_PULSE_ROUTING_PLUGIN)
IF (WITH_ENABLED_IPC STREQUAL "DBUS")
SET (WITH_DBUS_WRAPPER ON CACHE INTERNAL "hide this!" FORCE)
@@ -242,12 +250,16 @@ if(WITH_PLUGIN_COMMAND)
endif(WITH_PLUGIN_COMMAND)
if(WITH_PLUGIN_ROUTING)
- add_subdirectory (PluginRoutingInterfaceAsync)
- if(WITH_DBUS_WRAPPER)
- add_subdirectory (PluginRoutingInterfaceDbus)
- elseif(WITH_CAPI_WRAPPER)
- add_subdirectory (PluginRoutingInterfaceCAPI)
- endif()
+ if (WITH_PULSE_ROUTING_PLUGIN)
+ add_subdirectory (PluginRoutingInterfacePulse)
+ else ()
+ add_subdirectory (PluginRoutingInterfaceAsync)
+ if(WITH_DBUS_WRAPPER)
+ add_subdirectory (PluginRoutingInterfaceDbus)
+ elseif(WITH_CAPI_WRAPPER)
+ add_subdirectory (PluginRoutingInterfaceCAPI)
+ endif()
+ endif()
endif(WITH_PLUGIN_ROUTING)
if(WITH_PLUGIN_CONTROL)