summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt b/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt
index 0316083..2928335 100644
--- a/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt
@@ -57,11 +57,16 @@ file(GLOB ROUTING_INTERFACE_SRCS_CXX
"../../src/CAmSocketHandler.cpp"
"../../src/CAmRoutingReceiver.cpp"
"../../src/CAmCommandReceiver.cpp"
- "../../src/CAmNodeStateCommunicator.cpp"
"../../src/CAmDbusWrapper.cpp"
"*.cpp"
)
+IF(WITH_NSM)
+ SET (CONTROL_INTERFACE_SRCS_CXX
+ ${CONTROL_INTERFACE_SRCS_CXX}
+ "../../src/CAmNodeStateCommunicator.cpp")
+ENDIF(WITH_NSM)
+
ADD_EXECUTABLE(AmRoutingInterfaceTest ${ROUTING_INTERFACE_SRCS_CXX})
TARGET_LINK_LIBRARIES(AmRoutingInterfaceTest