summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGENIVI Audio Manager Maintainer <genivi-maint-audiomanager@smtp1.genivi.org>2018-03-13 11:28:45 +0100
committerGitHub <noreply@github.com>2018-03-13 11:28:45 +0100
commitf32875117e54fd4887f3256d19518d3f62db6225 (patch)
tree0b387aae10734f32918c7ccc218c782230449104 /CMakeLists.txt
parentcfded6ea1a53e5387e1f24c0a9132f363247669b (diff)
parentc0d9501bcfa14ea7d851e5dd1cdc89e03a651342 (diff)
downloadaudiomanager-f32875117e54fd4887f3256d19518d3f62db6225.tar.gz
Merge pull request #26 from GENIVI/utilityUpdates_CAPI_fixes
Utility updates capi fixes
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e3bddb..e61a0fa 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,8 +65,10 @@ option ( WITH_SHARED_CORE
"Build audio manager core as dynamic library" OFF)
option ( WITH_TIMERFD
- "Build with the linux specific TIMERFD feature to support timing without using signals" ON)
+ "Build with timer fd support" ON )
+option( WITH_TESTS
+ "Build together with all available unitTest" ON )
set(DBUS_SERVICE_PREFIX "org.genivi.audiomanager"
CACHE PROPERTY "The dbus service prefix for the AM - only changable for legacy dbus")
@@ -213,7 +215,6 @@ if(WITH_DOCUMENTATION)
PATTERN "def" EXCLUDE)
endif(WITH_DOCUMENTATION)
-
message(STATUS)
message(STATUS "${PROJECT_NAME} Configuration:")
message(STATUS "CMAKE_BUILD_TYPE = ${CMAKE_BUILD_TYPE}")