summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mueller <christian.ei.mueller@bmw.de>2012-05-21 19:00:35 +0200
committerchristian mueller <christian.ei.mueller@bmw.de>2012-05-24 13:40:23 +0200
commit3f65139b2825e654dd0cc36d1cee055b7ac959d9 (patch)
treef9baf9833b8da138428c7ee295f6af7953c7085f /CMakeLists.txt
parenta572fc87a811563f62b88116de699f803915383e (diff)
downloadaudiomanager-3f65139b2825e654dd0cc36d1cee055b7ac959d9.tar.gz
* [GAM-24] Watchdog concept for the AudioManager. This patch introduces the watchdog functionality of the AudioManager. The function is based on the systemd watchdog functionality. The desired time intervals for checking the watchdog can be tweaked by the unit file for systemd. A sample unit file is added to the subdirectory cmake. Via Cmake build option, the watchdog functionality can be switched off.
If the development package from systemd is available it will use the lib that comes with it. If not, the default handler will be compiled along with the audiomanager and this one will be used. Signed-off-by: Christian Mueller <christian.ei.mueller@bmw.de>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-x[-rw-r--r--]CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 722d49a..6ec4328 100644..100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,9 @@ OPTION( WITH_MAIN
OPTION( WITH_TELNET
"build with Telnetserver (can only work with SocketHandler)" ON)
+OPTION ( WITH_SYSTEMD_WATCHDOG
+ "build with systemD support & watchdog" ON)
+
OPTION ( USE_BUILD_LIBS
"build with default library path = build path" ON)
@@ -148,7 +151,7 @@ endif(WITH_PLUGIN_COMMAND)
if(WITH_PLUGIN_ROUTING)
add_subdirectory (PluginRoutingInterfaceDbus)
- add_subdirectory (PluginRoutingInterfaceAsync)
+# add_subdirectory (PluginRoutingInterfaceAsync)
endif(WITH_PLUGIN_ROUTING)
if(WITH_PLUGIN_CONTROL)