summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJaroslav Kysela <perex@perex.cz>2002-04-24 14:41:55 +0000
committerJaroslav Kysela <perex@perex.cz>2002-04-24 14:41:55 +0000
commitf23813b7e98bc6e0db7413ecb330db7e5f1b2aa9 (patch)
treedadf7e8ae3d5835dcf9f70a9292bf51d006c1263 /configure.in
parentc39d1a665d265b80770f62fed565854ed1578426 (diff)
downloadalsa-lib-f23813b7e98bc6e0db7413ecb330db7e5f1b2aa9.tar.gz
Added HAVE_SOFT_FLOAT (--with-softfloat)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8e82a804..40badb5e 100644
--- a/configure.in
+++ b/configure.in
@@ -85,6 +85,7 @@ AC_HEADER_STDC
AM_CONFIG_HEADER(include/config.h)
AC_CHECK_HEADERS(sound/asound.h)
+
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
AC_C_INLINE
@@ -120,6 +121,10 @@ else
AC_MSG_RESULT(no)
fi
+AC_ARG_WITH(softfloat,
+ [ --with-softfloat do you have floating point unit on this machine? (optional)],
+ [ AC_DEFINE(HAVE_SOFT_FLOAT, "1")],)
+
dnl Check for architecture
AC_MSG_CHECKING(for architecture)
case "$target" in