summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTakashi Iwai <tiwai@suse.de>2002-10-09 13:43:35 +0000
committerTakashi Iwai <tiwai@suse.de>2002-10-09 13:43:35 +0000
commit163ae5738d48fabc0ed0a00029f1d7c0c93e6542 (patch)
treec388915024b442074196285b652f35a705dfc323 /configure.in
parentf0e5677f29ccabb5bdb6061eb32fc41c3175e558 (diff)
downloadalsa-lib-163ae5738d48fabc0ed0a00029f1d7c0c93e6542.tar.gz
duplicated the required alsa-kernel header files into the local
include/sound directory, so that alsa-lib can be compiled without alsa-driver. with this addition, --with-kernel and --with-soundbase options are removed from configure. they are obviously unnecessary. the relevant parts in INSTALL are removed/modified.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 0 insertions, 43 deletions
diff --git a/configure.in b/configure.in
index ebc46414..253514a4 100644
--- a/configure.in
+++ b/configure.in
@@ -39,51 +39,9 @@ AC_DISABLE_STATIC
AC_LIBTOOL_DLOPEN
AM_PROG_LIBTOOL
-dnl kernel header files
-AC_MSG_CHECKING(for kernel header files)
-AC_ARG_WITH(kernel,
- [ --with-kernel=ver specify kernel version (for example 2.5.5-pre1)],
- [kerneldir="$withval"], [kerneldir=""])
-if test "$kerneldir" != "" -a -r "/lib/modules/$kerneldir/build/include/sound"; then
- kerneldir="/lib/modules/$kerneldir/build/include"
- AC_MSG_RESULT($kerneldir)
-else
- if test -z "$kerneldir"; then
- AC_MSG_RESULT("not specified")
- else
- AC_MSG_RESULT("directory /lib/modules/$kerneldir/build/include/sound not found")
- fi
- kerneldir=""
-fi
-
-dnl path for sound/asound.h
-AC_MSG_CHECKING(for directory with ALSA kernel headers)
-AC_ARG_WITH(soundbase,
- [ --with-soundbase=dir specify base directory with kernel sound headers (optional)],
- [soundbasedir="$withval"], [soundbasedir="$kerneldir"])
-if test "$soundbasedir" != "" -a -r "$soundbasedir/sound" ; then
- ALSA_CFLAGS="$ALSA_CFLAGS -I$soundbasedir"
- CFLAGS="$CFLAGS -I$soundbasedir"
- AC_MSG_RESULT($ALSA_CFLAGS)
-else
- if test "x$prefix" != xNONE; then
- aprefix=$prefix
- else
- aprefix=$ac_default_prefix
- fi
- if test -z "$soundbasedir" -a x"$aprefix" != x/usr -a -r "$aprefix/include/sound"; then
- ALSA_CFLAGS="$ALSA_CFLAGS -I$aprefix/include"
- CFLAGS="$CFLAGS -I$aprefix/include"
- AC_MSG_RESULT($ALSA_CFLAGS)
- else
- AC_MSG_RESULT("not specified - using C compilator defaults")
- fi
-fi
-
dnl Checks for header files.
AC_HEADER_STDC
AM_CONFIG_HEADER(include/config.h)
-AC_CHECK_HEADERS(sound/asound.h)
dnl Checks for typedefs, structures, and compiler characteristics.
@@ -96,7 +54,6 @@ AC_PROG_GCC_TRADITIONAL
AC_CHECK_FUNC([hsearch_r], [HAVE_HSEARCH_R=yes])
AM_CONDITIONAL(ALSA_HSEARCH_R, [test "x$HAVE_HSEARCH_R" != xyes])
-ALSA_CHECK_DRIVER
SAVE_LIBRARY_VERSION
AC_SUBST(LIBTOOL_VERSION_INFO)