summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Dale <richard.dale@codethink.co.uk>2015-06-12 16:11:41 +0100
committerRichard Dale <richard.dale@codethink.co.uk>2015-06-12 16:11:41 +0100
commita060feb534b853e079557004d1d00a19a4513039 (patch)
treec7739a8d5a1bc51db2fab8de5b94de593a007149
parentb73be0369d74c1e903a828b6ffdba9aa35477227 (diff)
downloaddefinitions-a060feb534b853e079557004d1d00a19a4513039.tar.gz
Add an iptables chunk and configure and build as similar to the
iptables/Makefile in the openwrt repo Update the firewall3 sha1 to be the most recent
-rw-r--r--strata/cpe-wrt.morph3
-rw-r--r--strata/cpe-wrt/iptables.morph19
2 files changed, 21 insertions, 1 deletions
diff --git a/strata/cpe-wrt.morph b/strata/cpe-wrt.morph
index 5cf71811..05122e16 100644
--- a/strata/cpe-wrt.morph
+++ b/strata/cpe-wrt.morph
@@ -22,6 +22,7 @@ chunks:
build-depends:
- libnl-tiny
- name: iptables
+ morph: strata/cpe-wrt/iptables.morph
repo: upstream:iptables
ref: fd7b66e7b6f535e56c0ee8eb442298a453ae4572
unpetrify-ref: baserock/1.4.21-openwrt
@@ -107,7 +108,7 @@ chunks:
- name: firewall3
morph: strata/cpe-wrt/firewall3.morph
repo: upstream:openwrt/firewall3
- ref: 165029cb8c0f1545628f44143aec965e64cef021
+ ref: 980b7859bbd1db1e5e46422fccccbce38f9809ab
unpetrify-ref:
build-depends:
- ubus
diff --git a/strata/cpe-wrt/iptables.morph b/strata/cpe-wrt/iptables.morph
new file mode 100644
index 00000000..72a6b2b7
--- /dev/null
+++ b/strata/cpe-wrt/iptables.morph
@@ -0,0 +1,19 @@
+name: iptables
+kind: chunk
+
+configure-commands:
+- autoreconf -ivf
+- |
+ ./configure --enable-shared \
+ --enable-devel \
+ --with-xtlibdir=/usr/lib/iptables \
+ --enable-static \
+ --prefix=$PREFIX
+
+build-commands:
+- make CFLAGS="-ffunction-sections -fdata-sections -DNO_LEGACY" LDFLAGS="-lm"
+
+install-commands:
+- make install
+- install extensions/libiptext*.so $DESTDIR$PREFIX/lib/
+