summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Dale <richard.dale@codethink.co.uk>2015-06-17 15:05:55 +0100
committerRichard Dale <richard.dale@codethink.co.uk>2015-06-17 15:05:55 +0100
commit9bf2a58d4d09d84830d5b1237604147d16487893 (patch)
tree082ca3d837f5532be19b3906afad19bcaa47a48c
parente6d1a21591a05e2218004993f60933e65a6820e3 (diff)
downloaddefinitions-9bf2a58d4d09d84830d5b1237604147d16487893.tar.gz
Fix up the version info in /etc/banner and other places
-rw-r--r--strata/cpe-wrt/base-files.morph18
1 files changed, 18 insertions, 0 deletions
diff --git a/strata/cpe-wrt/base-files.morph b/strata/cpe-wrt/base-files.morph
index c765a937..eea4964a 100644
--- a/strata/cpe-wrt/base-files.morph
+++ b/strata/cpe-wrt/base-files.morph
@@ -44,3 +44,21 @@ post-install-commands:
for FILE in "$DESTDIR"/etc/init.d/* ; do
IPKG_INSTROOT="$DESTDIR" bash "$DESTDIR"/etc/rc.common "$FILE" enable
done
+ # Note that this svn version needs manually updating
+ echo "r46008" > version
+ cat <<EOF > makefile
+ SED=/bin/sed -i -e
+
+ include \$(TOPDIR)/include/toplevel.mk
+ include \$(TOPDIR)/include/version.mk
+
+ version_info:
+ XXXX\$(VERSION_SED) \$(DESTDIR)/etc/banner
+ XXXX\$(VERSION_SED) \$(DESTDIR)/etc/openwrt_version
+ XXXX\$(VERSION_SED_SCRIPT) \$(DESTDIR)/etc/openwrt_release
+ XXXX\$(VERSION_SED_SCRIPT) \$(DESTDIR)/etc/device_info
+ EOF
+ # Work round limitations of YAML here files
+ sed -i -e 's/^ //' -e 's/XXXX/\t/' makefile
+
+ TOPDIR=`pwd` FORCE=1 make DESTDIR="$DESTDIR" -f makefile version_info