summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Martin <paul.martin@codethink.co.uk>2015-06-23 11:07:22 +0000
committerRichard Dale <richard.dale@codethink.co.uk>2015-06-25 15:50:13 +0100
commit14a34585da62829c50a33c9296162875d8efbf3c (patch)
treebde8f7eadbd80595e6c69d0e814c0b6080e58a3b
parent5cdcffe6672db64da0e5be214cbcfc128e93e79c (diff)
downloaddefinitions-14a34585da62829c50a33c9296162875d8efbf3c.tar.gz
cmake: bump version to 3.2.2 and fix build and bootstrap segfault
-rw-r--r--strata/core-wrt.morph4
-rw-r--r--strata/core/cmake.morph5
2 files changed, 7 insertions, 2 deletions
diff --git a/strata/core-wrt.morph b/strata/core-wrt.morph
index 36644827..1ca23bb3 100644
--- a/strata/core-wrt.morph
+++ b/strata/core-wrt.morph
@@ -12,8 +12,8 @@ chunks:
- name: cmake
morph: strata/core/cmake.morph
repo: upstream:cmake
- ref: 0b3781e4c497566acaa504d4106d11c02a642501
- unpetrify-ref: v2.8.12.2
+ ref: 91d5261b58e97107fca610a868fbc283cbb8c856
+ unpetrify-ref: v3.2.2
- name: gdbm
morph: strata/core/gdbm.morph
repo: upstream:gdbm-tarball
diff --git a/strata/core/cmake.morph b/strata/core/cmake.morph
index 1d310ef4..97b264e4 100644
--- a/strata/core/cmake.morph
+++ b/strata/core/cmake.morph
@@ -1,5 +1,10 @@
name: cmake
kind: chunk
+pre-configure-commands:
+# Missing header include
+- echo "#include <sys/stat.h>" >> Source/cmStandardIncludes.h
+# Prevent segfault when boostrapping and looking for curses library
+- sed -i 's/NOT CMAKE_SYSTEM_NAME MATCHES syllable/0/' CMakeLists.txt
configure-commands:
- ./bootstrap --prefix="$PREFIX" --docdir=/share/doc/cmake --mandir=/share/man
build-commands: