summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Hoinkis <simon.hoinkis@codethink.co.uk>2015-03-13 15:33:22 +0000
committerRichard Dale <richard.dale@codethink.co.uk>2015-05-19 16:56:06 +0100
commitfabec9d8a13ddc1be7b85f71874af527569530d6 (patch)
tree252a44bfa1170c85cde8c50abe67794313fb4e93
parent2e9ff9e129b016d0f8caf04a8bcd25130d08fc09 (diff)
downloaddefinitions-fabec9d8a13ddc1be7b85f71874af527569530d6.tar.gz
Add base-files to cpe-wrt
-rw-r--r--strata/cpe-wrt.morph8
-rw-r--r--strata/cpe-wrt/base-files.morph31
-rw-r--r--strata/cpe-wrt/procd.morph9
-rw-r--r--strata/cpe-wrt/ubox.morph5
-rw-r--r--strata/cpe-wrt/ubus.morph5
5 files changed, 57 insertions, 1 deletions
diff --git a/strata/cpe-wrt.morph b/strata/cpe-wrt.morph
index 66374403..eeac1326 100644
--- a/strata/cpe-wrt.morph
+++ b/strata/cpe-wrt.morph
@@ -94,3 +94,11 @@ chunks:
unpetrify-ref:
build-depends:
- ubus
+- name: base-files
+ morph: strata/cpe-wrt/base-files.morph
+ repo: git://git.openwrt.org/openwrt.git
+ ref: HEAD
+ unpetrify-ref:
+ build-depends:
+ - netifd
+ - procd
diff --git a/strata/cpe-wrt/base-files.morph b/strata/cpe-wrt/base-files.morph
new file mode 100644
index 00000000..a0f5dc0f
--- /dev/null
+++ b/strata/cpe-wrt/base-files.morph
@@ -0,0 +1,31 @@
+name: base-files
+kind: chunk
+
+#build-commands:
+#- |
+# export TOPDIR="../.."
+# export INCLUDE_DIR="TOPDIR/include"
+# cd package/base-files && make
+
+install-commands:
+# FHS directories
+- |
+ cp -r package/base-files/files/* "$DESTDIR"/
+
+# procd files
+- install package/system/procd/files/hotplug.json "$DESTDIR"/etc/
+- install package/system/procd/files/hotplug-preinit.json "$DESTDIR"/etc/
+- install package/system/procd/files/reload_config "$DESTDIR"/sbin/
+- install package/system/procd/files/procd.sh "$DESTDIR"/lib/functions/
+
+#netifd
+- |
+ cp -r package/network/config/netifd/files/* "$DESTDIR"/
+
+#ubox
+- |
+ cp -r package/system/ubox/files/* "$DESTDIR"/etc/init.d/log
+
+#ubox
+- |
+ cp -r package/system/uci/files/* "$DESTDIR"/
diff --git a/strata/cpe-wrt/procd.morph b/strata/cpe-wrt/procd.morph
index 7e85cab9..fc0fcabe 100644
--- a/strata/cpe-wrt/procd.morph
+++ b/strata/cpe-wrt/procd.morph
@@ -3,4 +3,11 @@ kind: chunk
pre-configure-commands:
- sed -i "s/-Werror//" CMakeLists.txt
-- sed -i "s/#include <json/#include <json-c/" service/validate.c plug/hotplug.c
+- sed -i "s/#include <json>/#include <json-c>/" service/validate.c plug/hotplug.c
+
+build-commands:
+- cmake -DCMAKE_INSTALL_PREFIX=/
+- make
+
+install-commands:
+- make install
diff --git a/strata/cpe-wrt/ubox.morph b/strata/cpe-wrt/ubox.morph
new file mode 100644
index 00000000..2280a207
--- /dev/null
+++ b/strata/cpe-wrt/ubox.morph
@@ -0,0 +1,5 @@
+name: ubox
+kind: chunk
+
+install-commands:
+- make DESTDIR="$DESTDIR" install
diff --git a/strata/cpe-wrt/ubus.morph b/strata/cpe-wrt/ubus.morph
new file mode 100644
index 00000000..245a51b6
--- /dev/null
+++ b/strata/cpe-wrt/ubus.morph
@@ -0,0 +1,5 @@
+name: ubus
+kind: chunk
+
+install-commands:
+- make install